After having HuC merged and taking feedback into account, it's time to respin
this series.

General GuC/HuC cleanup simplifying logic, and moving chunks around, as the area
is pretty rusty.

A lot of logic were extracted from intel_guc_load() to other functions - it not
only did handle the actual loading but had WA implementations and had the code
thatenabled submission baked it.

This is first the part of effort to clean it up.

Cc: Joonas Lahtinen <joonas.lahti...@linux.intel.com>

Arkadiusz Hiler (5):
  drm/i915/uc: Rename intel_?uc_{setup,load}() to _init_hw()
  drm/i915/uc: Introduce intel_uc_init()
  drm/i915/guc: Extract param logic form guc_init
  drm/i915/guc: Simplify intel_guc_init_hw()
  drm/i915/uc: Simplify fw_path

 drivers/gpu/drm/i915/i915_drv.c         |   5 +-
 drivers/gpu/drm/i915/i915_gem.c         |   2 +-
 drivers/gpu/drm/i915/intel_guc_loader.c | 187 +++++---------------------------
 drivers/gpu/drm/i915/intel_huc.c        |  24 ++--
 drivers/gpu/drm/i915/intel_uc.c         | 134 +++++++++++++++++++++++
 drivers/gpu/drm/i915/intel_uc.h         |  11 +-
 6 files changed, 186 insertions(+), 177 deletions(-)

-- 
2.9.3

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

Reply via email to