[PHP-DEV] CVS Account Request: kei

2008-06-09 Thread kei horikita
To maintenance my pear package -- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: http://www.php.net/unsub.php

[PHP-DEV] PHP 6 Bug Summary Report

2008-06-09 Thread internals
PHP 6 Bug Database summary - http://bugs.php.net/ Num Status Summary (62 total -- which includes 26 feature requests) ===[*General Issues]== 26771 Suspended register_tick_funtions crash under threaded webservers

[PHP-DEV] CVS Account Request: indeyets

2008-06-09 Thread Alexey Zakhlestin
maintaining pecl-packages (will request karma separately) -- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: http://www.php.net/unsub.php

Re: [PHP-DEV] CVS Account Request: indeyets

2008-06-09 Thread Scott MacVicar
You need to list the packages you intend to maintain, if it's a new package then we really need to see the code. This might be something more appropriate for [EMAIL PROTECTED] Scott Alexey Zakhlestin wrote: maintaining pecl-packages (will request karma separately) -- PHP Internals - PHP

Re: [PHP-DEV] CVS Account Request: indeyets

2008-06-09 Thread Antony Dovgal
On 09.06.2008 15:04, Alexey Zakhlestin wrote: maintaining pecl-packages (will request karma separately) Usually it's good idea to announce your extension in pecl-dev@ first and ask for karma after that. Just to be sure the extension is accepted. Or did you mean you're going to take over some

Re: [PHP-DEV] CVS Account Request: indeyets

2008-06-09 Thread Alexey Zakhlestin
On 6/9/08, Antony Dovgal [EMAIL PROTECTED] wrote: Usually it's good idea to announce your extension in pecl-dev@ first and ask for karma after that. Just to be sure the extension is accepted. Or did you mean you're going to take over some existing extension? Which one then? de-facto I

[PHP-DEV] Algorithm Optimizations - string search

2008-06-09 Thread Michal Dziemianko
Hello, Here: http://212.85.117.53/DIFF.txt is small patch that will speed up following functions: strpos, stripos, strrpos strripos, and probably some others (all that use zend_memnstr/php_memnstr function) The speedup of zend_memnstr is about 8% on average (about 30% in case of

Re: [PHP-DEV] Algorithm Optimizations - string search

2008-06-09 Thread Scott MacVicar
Hi Michal, Everything looks fine here and it applies cleanly, do you think you could make a patch against HEAD with this as well? I suspect it will be different due to Unicode. Scott Michal Dziemianko wrote: Hello, Here: http://212.85.117.53/DIFF.txt is small patch that will speed up

Re: [PHP-DEV] Algorithm Optimizations - string search

2008-06-09 Thread Antony Dovgal
On 09.06.2008 15:39, Michal Dziemianko wrote: Hello, Here: http://212.85.117.53/DIFF.txt is small patch that will speed up following functions: strpos, stripos, strrpos strripos, and probably some others (all that use zend_memnstr/php_memnstr function) The code below is definitely wrong.

Re: [PHP-DEV] Algorithm Optimizations - string search

2008-06-09 Thread Antony Dovgal
On 09.06.2008 15:39, Michal Dziemianko wrote: Hello, Here: http://212.85.117.53/DIFF.txt is small patch that will speed up following functions: strpos, stripos, strrpos strripos, and probably some others (all that use zend_memnstr/php_memnstr function) There is also another thing -

Re: [PHP-DEV] Algorithm Optimizations - string search

2008-06-09 Thread Nuno Lopes
Hi, So some comments: - you have some problems with the indentation. We only use tabs, so please stick to that. Also, there are some lines that are not indented correctly - Have you considered the Boyer-Moore algorithm? I think it's a little faster than KMP (take a look at e.g.

Re: [PHP-DEV] Algorithm Optimizations - string search

2008-06-09 Thread Scott MacVicar
There is rabin-karp too but its worse case is O(nm) so that might not be ideal, perhaps we should try to compare all of them. Scott Nuno Lopes wrote: Hi, So some comments: - you have some problems with the indentation. We only use tabs, so please stick to that. Also, there are some lines

[PHP-DEV] Re: Short syntax for array literals [...]

2008-06-09 Thread Nate Abele
I don't really consider myself worthy to preach to the Powers That Be, but this is an issue about which I happen to feel strongly, and y'all asked for some user-land opinions, so here goes. To further clarify (and disclaim), I have never spoken up on this list before, I haven't until

Re: [PHP-DEV] Re: Focus on HEAD

2008-06-09 Thread Felipe Pena
Hi all Em Seg, 2008-06-09 às 18:55 +0100, Steph Fox escreveu: Hi all, Andrei doesn't have time to review this lot (covers ext/standard). Could someone please check it for clangers? Thanks, - Steph Here's the rest (ext/* and main/*): http://felipe.ath.cx/diff/unicode-check.diff -

Re: [PHP-DEV] Re: Focus on HEAD

2008-06-09 Thread Steph Fox
Hey Felipe, 'Scuse top-posting, my s have let me down again. Two things: first, I did in ext/standard exactly as you did elsewhere (you know this already but the rest don't). Second, I already sent the MySQL guys some bits and pieces for their tests. Oh, and third - if nobody gets back to

[PHP-DEV] Calling original function from an overloaded function

2008-06-09 Thread Christoph Dorn
I have been looking at xdebug and have figured out how to overload a function. As a test I have overloaded the var_dump function. Now how do I call the original var_dump function from my implementation? Borrowing from OO terminology I have subclassed the var_dump method, now I want to call

Re: [PHP-DEV] Calling original function from an overloaded function

2008-06-09 Thread Alexey Zakhlestin
Well, speaking in broad terms, I would suggest to store the pointer to original function before overloading it, and calling that, when you need it On 6/10/08, Christoph Dorn [EMAIL PROTECTED] wrote: I have been looking at xdebug and have figured out how to overload a function. As a test I have

[PHP-DEV] Re: Calling original function from an overloaded function

2008-06-09 Thread Gregory Beaver
Christoph Dorn wrote: I have been looking at xdebug and have figured out how to overload a function. As a test I have overloaded the var_dump function. Now how do I call the original var_dump function from my implementation? Borrowing from OO terminology I have subclassed the var_dump