Re: [PHP-DEV] [RFC] Zend Signal Handling

2008-08-03 Thread Lucas Nealan
Reviewed to my ability and will soon be posting the updated patch for 5_3 and 6 as well as wiki changes. On 8/1/08 6:45 PM, Arnaud Le Blanc [EMAIL PROTECTED] wrote: The ZTS-enabled version of your patch can be found at [1] :) Changes: Zend Signal Handling is now enabled in ZTS builds. Should

[PHP-DEV] Intended behavior of ArrayObject::exchangeArray() ?

2008-08-03 Thread Robin Fernandes
Hi all, I have two questions about the intended behaviour of ArrayObject::exchangeArray() : 1. What should happen when the argument is an object? The docs suggest that the arg should be an array, but the prototype in the code indicates objects are OK too. However, when an object is passed, the

Re: [PHP-DEV] [RFC] Zend Signal Handling

2008-08-03 Thread Pierre Joye
hi! On Sun, Aug 3, 2008 at 9:34 AM, Lucas Nealan [EMAIL PROTECTED] wrote: Reviewed to my ability and will soon be posting the updated patch for 5_3 and 6 as well as wiki changes. On 8/1/08 6:45 PM, Arnaud Le Blanc [EMAIL PROTECTED] wrote: The ZTS-enabled version of your patch can be found at

Re: [PHP-DEV] __invoke concerns

2008-08-03 Thread Marcus Boerger
Hello Etienne, Saturday, August 2, 2008, 7:36:23 PM, you wrote: Hi, this is probably not the best time to raise concerns about __invoke (closures) now that alpha1 is already realeased, but I believe it's worth it. Actually it is the best time, well earlier would probably have been even

Re: [PHP-DEV] Intended behavior of ArrayObject::exchangeArray() ?

2008-08-03 Thread Marcus Boerger
Hello Robin, Sunday, August 3, 2008, 1:07:56 PM, you wrote: Hi all, I have two questions about the intended behaviour of ArrayObject::exchangeArray() : 1. What should happen when the argument is an object? The docs suggest that the arg should be an array, but the prototype in the code

[PHP-DEV] Inconsistencies in 5.3

2008-08-03 Thread Marcus Boerger
Hello Internals, please let's not introduce new inconsistencies. Rather lets make new stuff consistent with old stuff during the alpha phase of 5.3. 1) new keyword 'use'. Semantically it is the same as 'static' or 'global' so it should be used in the same location. 2) namespaces, either use

[PHP-DEV] Re: [PHP-CVS] cvs: php-src(PHP_5_3) / NEWS

2008-08-03 Thread Rasmus Lerdorf
Jani Taskinen wrote: -- Changed PCRE, Reflection and SPL extensions to always be enabled. (Marcus) +- Changed PCRE, Reflection and SPL extensions to be always enabled. (Marcus) That was amazingly pedantic, even for you Jani. Captain Kirk blasted away the split infinitive rule when he decided

Re: [PHP-DEV] Inconsistencies in 5.3

2008-08-03 Thread Jeremy Privett
Hey Marcus, On Sun, 03 Aug 2008 07:26:59 -0500, Marcus Boerger [EMAIL PROTECTED] wrote: Hello Internals, please let's not introduce new inconsistencies. Rather lets make new stuff consistent with old stuff during the alpha phase of 5.3. 1) new keyword 'use'. Semantically it is the same as

[PHP-DEV] Re: [PHP-CVS] cvs: php-src /ext/date config.w32 /ext/date/lib parse_iso_intervals.re

2008-08-03 Thread Pierre Joye
On Sun, Aug 3, 2008 at 5:51 PM, Derick Rethans [EMAIL PROTECTED] wrote: On Sat, 2 Aug 2008, Pierre-Alain Joye wrote: pajoyeSat Aug 2 16:49:56 2008 UTC Modified files: /php-src/ext/date config.w32 /php-src/ext/date/lib parse_iso_intervals.re Log: -

[PHP-DEV] Re: [PHP-CVS] cvs: php-src /ext/date config.w32 /ext/date/lib parse_iso_intervals.re

2008-08-03 Thread Derick Rethans
On Sun, 3 Aug 2008, Pierre Joye wrote: On Sun, Aug 3, 2008 at 5:51 PM, Derick Rethans [EMAIL PROTECTED] wrote: On Sat, 2 Aug 2008, Pierre-Alain Joye wrote: pajoyeSat Aug 2 16:49:56 2008 UTC Modified files: /php-src/ext/date config.w32

Re: [PHP-DEV] Const-correctness

2008-08-03 Thread Marcus Boerger
Hello Felipe, Sunday, August 3, 2008, 3:12:01 PM, you wrote: Hi all, I made a patch that add the const qualifier in several function parameters in Zend/* where it seems suitable (mostly the API). http://felipe.ath.cx/diff/const-ness.diff (5_3) HEAD comming soon in case of no objection.

Re: [PHP-DEV] Another PECL candidate and more extension considerations.

2008-08-03 Thread Lukas Kahwe Smith
On 01.08.2008, at 22:03, Marcus Boerger wrote: 1) Move everything that can be disabled to PECL. This renders the resulting PHP pretty much useless for allmost everyone and thus forces people to start using PECL and distributors even more to carefully select. In the long run this is the way

[PHP-DEV] Re: [PHP-CVS] cvs: php-src /ext/date config.w32 /ext/date/lib parse_iso_intervals.re

2008-08-03 Thread Pierre Joye
Hi Derick, On Sun, Aug 3, 2008 at 6:34 PM, Derick Rethans [EMAIL PROTECTED] wrote: you're not reading what I said. It does not make one single bit of sense that a short function gives problems while an enormously long function is fine. This does *NOT* make sense. If you have no idea either,

Re: [PHP-DEV] Intended behavior of ArrayObject::exchangeArray() ?

2008-08-03 Thread Robin Fernandes
Hi Marcus! 1. What should happen when the argument is an object? Seems like an error message is missing there. It allows to take an instance of another ArrayObject/Iterator and use the array from that. In case any other Object is passed it is ignored. What do you feel? Sounds alright to

Re: [PHP-DEV] [RFC] Zend Signal Handling

2008-08-03 Thread Lucas Nealan
On 8/3/08 3:00 AM, Pierre Joye [EMAIL PROTECTED] wrote: We also provide binaries for non ZTS mode, so if the patch is not ready for Windows, it should disable this feature on Windows. I was presuming that non-zts, non-cygwin windows will not satisfy the sigaction requirement, thus we wouldn't

Re: [PHP-DEV] Intended behavior of ArrayObject::exchangeArray() ?

2008-08-03 Thread Marcus Boerger
Hello Robin, Sunday, August 3, 2008, 10:24:17 PM, you wrote: Hi Marcus! 1. What should happen when the argument is an object? Seems like an error message is missing there. It allows to take an instance of another ArrayObject/Iterator and use the array from that. In case any other Object

Re: [PHP-DEV] Const-correctness

2008-08-03 Thread Felipe Pena
Hello Marcus, Em Dom, 2008-08-03 às 18:46 +0200, Marcus Boerger escreveu: Index: Zend/zend.c === -static void print_hash(HashTable *ht, int indent, zend_bool is_object TSRMLS_DC) /* {{{ */ +static void print_hash(HashTable *

[PHP-DEV] Re: [PHP-DOC] Re: [PHP-DEV] [Fwd: #45687 [Opn-Bgs]: Why is PCNTL marked experimental]

2008-08-03 Thread Antony Dovgal
On 03.08.2008 02:25, Hannes Magnusson wrote: Bundling an experimental extension for 6 years is silly. Either move it to PECL or mark it as stable (or whatever the opposite of experimental is). Keeping the experimental status for so many years is a nonsense. Apparently it's not experimental

Re: [PHP-DEV] Re: [PHP-DOC] Re: [PHP-DEV] [Fwd: #45687 [Opn-Bgs]: Why is PCNTL marked experimental]

2008-08-03 Thread Brian Moon
Antony Dovgal wrote: Keeping the experimental status for so many years is a nonsense. Apparently it's not experimental anymore. It has been working for me for years. I would say it is not experimental. -- Brian Moon Senior Web Engineer -- When you care enough to

Re: [PHP-DEV] [RFC] Zend Signal Handling

2008-08-03 Thread Pierre Joye
Hi Lucas, On Sun, Aug 3, 2008 at 11:06 PM, Lucas Nealan [EMAIL PROTECTED] wrote: On 8/3/08 3:00 AM, Pierre Joye [EMAIL PROTECTED] wrote: We also provide binaries for non ZTS mode, so if the patch is not ready for Windows, it should disable this feature on Windows. I was presuming that

Re: [PHP-DEV] Re: __invoke concerns

2008-08-03 Thread Marcus Boerger
Hello Etienne, Monday, August 4, 2008, 12:03:01 AM, you wrote: Hello, On Sat, Aug 2, 2008 at 7:36 PM, Etienne Kneuss [EMAIL PROTECTED] wrote: Hi, this is probably not the best time to raise concerns about __invoke (closures) now that alpha1 is already realeased, but I believe it's worth

[PHP-DEV] [PATCH] Alias stream_context_get_default() as stream_context_set_default()

2008-08-03 Thread Davey Shafik
Hey, it has come to my attention that stream_context_get_default() is / grossly/ misnamed, considering that it can be used (and is the only way) to SET default options. It works more like ini_set() in that you pass in the new defaults and it returns the old. With the current name, it is as

Re: [PHP-DEV] [RFC] Zend Signal Handling

2008-08-03 Thread Steph Fox
I do not know either, only pointed that we release non ZTS windows build as well, just in case :) So user confusion is not an issue here? Just asking, on account of the amount of user confusion over NTS/ZTS in php-gtk2 history since that became an option... - Steph -- PHP Internals -

Re: [PHP-DEV] [RFC] Zend Signal Handling

2008-08-03 Thread Pierre Joye
On Mon, Aug 4, 2008 at 1:33 AM, Steph Fox [EMAIL PROTECTED] wrote: I do not know either, only pointed that we release non ZTS windows build as well, just in case :) So user confusion is not an issue here? It is off topic yes. The only point discussed here is whether the signal handling

Re: [PHP-DEV] Inconsistencies in 5.3

2008-08-03 Thread Moriyoshi Koizumi
Fully agreed with all of those. (especially for 1) Moriyoshi Marcus Boerger wrote: Hello Internals, please let's not introduce new inconsistencies. Rather lets make new stuff consistent with old stuff during the alpha phase of 5.3. 1) new keyword 'use'. Semantically it is the same as

Re: [PHP-DEV] Const-correctness

2008-08-03 Thread Moriyoshi Koizumi
Marcus Boerger wrote: Overall you do a ton of 'struct * const var' which only means that you are going to copy the pointer explicitly. Now functions that use a pointer in a loop and increment it cannot optimize the code anymore and are forced to use an additional real variable on the stack. So

Re: [PHP-DEV] enabling everything by default

2008-08-03 Thread Ilia Alshanetsky
Perhaps its more of a perception then anything else. If enabled by default simply meant we do so because we can (no external libs needed) rather we think you should have it. There really would be any sort of an issue, and perhaps finally convince people to install what they need rather

Re: [PHP-DEV] [RFC] Zend Signal Handling

2008-08-03 Thread Arnaud LB
On Sun, Aug 3, 2008 at 9:34 AM, Lucas Nealan [EMAIL PROTECTED] wrote: Reviewed to my ability and will soon be posting the updated patch for 5_3 and 6 as well as wiki changes. On 8/1/08 6:45 PM, Arnaud Le Blanc [EMAIL PROTECTED] wrote: The ZTS-enabled version of your patch can be found at [1]

Re: [PHP-DEV] Inconsistencies in 5.3

2008-08-03 Thread Stanislav Malyshev
Hi! 1) new keyword 'use'. Semantically it is the same as 'static' or 'global' so it should be used in the same location. Of course it's not. It does entirely different thing from static or global, it doesn't even deal with variables. 2) namespaces, either use 'package' and only one per

Re: [PHP-DEV] __invoke concerns

2008-08-03 Thread Stanislav Malyshev
Hi! 1) I don't believe that having it thrown as another of those magic method is a good idea. Rather, I'd like to have it represented by an interface: Invokable. That way, type hints/checks can be done in user land in a sane matter: We can have Invokable and even have Closure implement it, if

Re: [PHP-DEV] Re: __invoke concerns

2008-08-03 Thread Stanislav Malyshev
Hi! 1) With the interface, the prototype is fixed. That definitely would not work. Interface could leave __invoke undefined, though then it'd be more of documentation/attribute purpose than enforcing having __invoke. But it can be workable. However, I'd still like to make closures more

Re: [PHP-DEV] Inconsistencies in 5.3

2008-08-03 Thread Stanislav Malyshev
Hi! Of course it's not. It does entirely different thing from static or global, it doesn't even deal with variables. Or you meant use in lambda definition? Then I don't have opinion to either side :) -- Stanislav Malyshev, Zend Software Architect [EMAIL PROTECTED] http://www.zend.com/