Re: [PHP-DEV] [RFC] Deprecate the extract function in PHP 7.3

2017-09-16 Thread Rick Widmer
On 9/16/2017 3:50 AM, ilija.tov...@me.com wrote: That’s fine, I have no problem with feedback. I changed my mind once other people pointed out the flaws in my thinking. Politely. Sorry for spending my free time thinking about how to make PHP better. I’m not claiming to be an expert in any

Re: [PHP-DEV] Changes to SuperGlobals for PHP 8

2017-07-28 Thread Rick Widmer
On 7/28/2017 10:42 AM, li...@rhsoft.net wrote: Am 28.07.2017 um 18:21 schrieb Kalle Sommer Nielsen: 2017-07-28 17:11 GMT+02:00 Sara Golemon : I'm sure there will be many strong opinions on this, but let's move this to a new thread. :D 1. This would be an 8.0 change as it

Re: [PHP-DEV] header() removes all header of the same name.

2016-10-20 Thread Rick Widmer
On 10/20/2016 4:58 PM, Guy Marriott wrote: FWIW Yasuo, I also think this is a bad idea. If you remove the ability to set cookie _headers_ with the header function then the function needs a more appropriate name - perhaps headerExceptCookie. That makes 5 people opposed - 100% of the individuals

Re: [PHP-DEV] Re: Improving PHP's type system

2016-04-19 Thread Rick Widmer
On 4/19/2016 5:10 PM, Stanislav Malyshev wrote: In general, improving the type system provides a much more interesting and practical playground for any kind of tool that would rely on static That's my point - "more interesting playground" does not sound like a reason enough to mess with the

Re: [PHP-DEV] Re: Improving PHP's type system

2016-04-19 Thread Rick Widmer
On 4/19/2016 2:41 PM, Stanislav Malyshev wrote: I try to share my worry that some of the things being proposed include seriously complicating PHP's conceptual model while serving at best infrequent use cases. Simplicity is a virtue, and we have already lost significant amount of that virtue.

Re: [PHP-DEV] PHP7 and types - and alternatives to annotation

2015-07-13 Thread Rick Widmer
On 7/13/2015 4:36 AM, Lester Caine wrote: Coming from a background of 'traditional' php design, all of my code and the libraries I use are documented via phpdoc style annotation which the IDE picks up, and phpdocumentor1 produced a good API description. This was also a GOOD basis to tidy up the

Re: [PHP-DEV] Consistent function names

2015-03-11 Thread Rick Widmer
On 3/11/2015 8:08 PM, Lester Caine wrote: Personally I just want to keep the current name set and so the sheer volume of changes proposed is a big kick in the face to me. YES! The time to make such a change to the names is about 1998 or maybe 2000. Every person who learns the current names

Re: [PHP-DEV] Re: [RFC-Discuss] Scalar Type Declarations v0.5

2015-02-18 Thread Rick Widmer
On 2/18/2015 6:33 PM, Christoph Becker wrote: It seems to me you're thinking too much (maybe only?) about database types. IMHO PHP can be used more versatile, and there might be issues which are exemplified in the RFC[1]: Maybe PHP can be more versatile, but what percentage of PHP code sits

Re: [PHP-DEV] Digit separators for numeric literals

2015-02-18 Thread Rick Widmer
On 2/18/2015 7:44 PM, Rasmus Lerdorf wrote: On 02/18/2015 06:07 PM, Christoph Becker wrote: Hi internals! A while ago a question was asked on the php-general mailing list with regard to digit seperators in numeric literals[1]. IMHO it might be a useful enhancement to allow such digit

Re: [PHP-DEV] [RFC] Supports 'finally' keyword for PHP exceptions

2012-07-24 Thread Rick WIdmer
On 7/24/2012 5:45 AM, Laruence wrote: On Tue, Jul 24, 2012 at 7:41 PM, Alexey Zakhlestin indey...@gmail.com wrote: On 24.07.2012, at 15:20, Laruence wrote: Will it work without catch in your implementation? nope for now. but if it is needed, I can implemente it Yes, please. -- PHP

Re: [PHP-DEV] Make try/catch brackets optinal

2012-07-20 Thread Rick WIdmer
On 7/20/2012 7:51 AM, Léo Peltier wrote: Enforcing coding style should be forbidden. YES!! I just thought that needed to be repeated! On Fri, Jul 20, 2012 at 3:51 PM, Léo Peltier cont...@leo-peltier.fr wrote: Clearly you don't work in a team or contribute to Open Source projects.

Re: [PHP-DEV] Re: Go for votes for the open tag-less PHP files

2012-04-16 Thread Rick WIdmer
On 4/16/2012 3:31 AM, Arvids Godjuks wrote: That's sad really, to be honest. I wonder if people even use this: echo include 'foo.bar', 'baz'; Probably not, Try it! you get: 1baz It actually works more like echo (include foo.bar), 'baz'; than echo include( foo.bar), 'baz';

Re: [PHP-DEV] Re: Go for votes for the open tag-less PHP files

2012-04-16 Thread Rick WIdmer
On 4/16/2012 1:02 PM, Kris Craig wrote: On Mon, Apr 16, 2012 at 10:31 AM, Rick WIdmervch...@developersdesk.comwrote: More important include doesn't currently allow multiple parms: include foo.bar, 'baz'; Parse error: syntax error, unexpected ',' in bla.php on line xx Regarding

Re: [PHP-DEV] Re: RFC: source files without opening tag

2012-04-09 Thread Rick WIdmer
Option 1: Introduce require_path I think require_code is a better name. Parm 1 isn't a path, it is a file, so require_path seems wrong to me. I'd prefer a 'start in code mode' optional second parameter to include[_once] and require[_once]. Option 2: Filename Convention The PHP engine

Re: [PHP-DEV] Scalar-type-hinting - which way is the best to go?

2012-03-18 Thread Rick WIdmer
On 3/17/2012 11:46 PM, Marco Pivetta wrote: Thank you for clarifying some things :) 4. Strict weak type hinting: This realm is the most likely to succeed because the core already does something like this for internal functions (via zend_parse_parameters). This balances utility (enforcing

Re: [PHP-DEV] Scalar Type Hinting

2012-03-07 Thread Rick WIdmer
On 3/7/2012 8:48 PM, John Crenshaw wrote: In fact, nearly every input to PHP is a string. This is why PHP was designed with some seriously robust type juggling on scalars. Any typing proposal that wants to actually pass a vote is going to have to allow appropriate implicit conversions from

Re: [PHP-DEV] Scalar type hinting

2012-02-28 Thread Rick WIdmer
On 2/28/2012 2:58 PM, Kris Craig wrote: strong int $a = 1; // Converts to 1. May or may not throw an error (I'm still on the fence). It this is an error, it is no longer PHP. -- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: http://www.php.net/unsub.php

Re: [PHP-DEV] Re: Clarification on the Enum language structure

2011-02-18 Thread Rick Widmer
On 2/18/2011 9:28 PM, Ben Schmidt wrote: I did some research on methods in enums and discovered that there is some usefulness to the idea - I wouldn't go so far as to say that they would be needed, but C#, for example, allows you to create extension methods for enums and MSDN has a decent

Re: [PHP-DEV] Deprecating global + $GLOBALS, making $_REQUEST, $_GET, $_POST read-only

2010-12-09 Thread Rick Widmer
On 12/9/2010 9:53 AM, Andrey Hristov wrote: . fixing a design flaw of the past, evolution in other words. Global and $GLOBALS are not a design flaw! They are a carefully thought out technique to insure that you do not shoot your self in the foot by accidentally accessing a global variable

Re: [PHP-DEV] mail() logging for PHP

2006-12-14 Thread Rick Widmer
Stut wrote: Cracking point. Putting the domain in a header would make this far more useful, and I don't think that's too much info to include in a header. Ideally it would be the full URL, and I have to say that I don't think that's too much information for a mail header, and it's exactly

Re: [PHP-DEV] Feature request

2006-11-10 Thread Rick Widmer
Stanislav Malyshev wrote: I'd say expression(f()[1]) means $tmp = f(); expression($tmp); unset($tmp); which here means: $tmp = foo(); $tmp[1] = 4; unset($tmp); which is meaningless but should work. IIRC the engine can make free's at the end of expression, so it shouldn't be big problem.

Re: [PHP-DEV] Seeking 'coalesce' php internal function

2006-05-03 Thread Rick Widmer
D. Dante Lorenso wrote: Eric, This reply is too basic and is not the answer. The problem is more complex then you have grasped. function ifsetor() { $args = func_get_args(); $count = count( $args ); for( $i=0; $i$count; $i++ ) { if isset( $args[ $i ] )) { return $args[ $i ];

Re: [PHP-DEV] Seeking 'coalesce' php internal function

2006-05-03 Thread Rick Widmer
D. Dante Lorenso wrote: No, that doesn't address the problem. See this: print @ifsetor($x, $y, $z, dante).\n; -- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: http://www.php.net/unsub.php