Re: [kvm-devel] [01/17]PATCH Add API for allocating dynamic TR resouce. V8

2008-04-01 Thread Carsten Otte
Zhang, Xiantao wrote: > Carsten Otte wrote: >> Zhang, Xiantao wrote: >>> +/* mca_insert_tr >>> + * >>> + * Switch rid when TR reload and needed! >>> + * iord: 1: itr, 2: itr; >>> + * >>> +*/ >>> +static void mca_insert_tr(u64 iord) >>> +{ >>> + >>> + int i; >>> + u64 old_rr; >>> + struct i

Re: [kvm-devel] [01/17]PATCH Add API for allocating dynamic TR resouce. V8

2008-03-31 Thread Zhang, Xiantao
Carsten Otte wrote: > Zhang, Xiantao wrote: >> +/* mca_insert_tr >> + * >> + * Switch rid when TR reload and needed! >> + * iord: 1: itr, 2: itr; >> + * >> +*/ >> +static void mca_insert_tr(u64 iord) >> +{ >> + >> +int i; >> +u64 old_rr; >> +struct ia64_tr_entry *p; >> +unsigned

Re: [kvm-devel] [01/17]PATCH Add API for allocating dynamic TR resouce. V8

2008-03-31 Thread Carsten Otte
Zhang, Xiantao wrote: > +/* mca_insert_tr > + * > + * Switch rid when TR reload and needed! > + * iord: 1: itr, 2: itr; > + * > +*/ > +static void mca_insert_tr(u64 iord) > +{ > + > + int i; > + u64 old_rr; > + struct ia64_tr_entry *p; > + unsigned long psr; > + int cpu = smp

Re: [kvm-devel] [01/17]PATCH Add API for allocating dynamic TR resouce. V8

2008-03-31 Thread Zhang, Xiantao
Jes Sorensen wrote: > Hi Xiantao, > > I general I think the code in this patch is fine. I have a couple of > nit-picking comments: > >> +if (target_mask&0x1) { > > The formatting here isn't quite what most of the kernel does. It would > be better if you added spaces so it's a little easier t

Re: [kvm-devel] [01/17]PATCH Add API for allocating dynamic TR resouce. V8

2008-03-31 Thread Jes Sorensen
Hi Xiantao, I general I think the code in this patch is fine. I have a couple of nit-picking comments: > + if (target_mask&0x1) { The formatting here isn't quite what most of the kernel does. It would be better if you added spaces so it's a little easier to read, ie: if (target_mask

[kvm-devel] [01/17]PATCH Add API for allocating dynamic TR resouce. V8

2008-03-31 Thread Zhang, Xiantao
>From 32013d1407ccbacf962031c308f31494b3f24aa3 Mon Sep 17 00:00:00 2001 From: Xiantao Zhang <[EMAIL PROTECTED]> Date: Sat, 29 Mar 2008 09:23:37 +0800 Subject: [PATCH] KVM:IA64 Add API for allocating Dynamic TR resource. Dynamic TR resource should be managed in the uniform way. Add two interfaces f

[kvm-devel] [01/17]PATCH Add API for allocating dynamic TR resouce. V7

2008-03-28 Thread Zhang, Xiantao
From 1028321e00b0f3a60fc414484754f489a70f2400 Mon Sep 17 00:00:00 2001 From: Xiantao Zhang <[EMAIL PROTECTED]> Date: Sat, 29 Mar 2008 09:23:37 +0800 Subject: [PATCH] Add API for allocating Dynamic TR resouce. Dynamic TR resouce should be managed in an uniform way. Signed-off-by: Xiantao Zhang <[E

[kvm-devel] [01/17]PATCH Add API for allocating dynamic TR resouce.

2008-03-28 Thread Zhang, Xiantao
Refined according to Tony's comments. >From 837f0508a617ea0386808de9fd0f42ef4aefe5e0 Mon Sep 17 00:00:00 2001 From: Xiantao Zhang <[EMAIL PROTECTED]> Date: Thu, 27 Mar 2008 10:18:29 +0800 Subject: [PATCH] Add API for allocating TR resouce. Dynamic TR resouce should be managed in an uniform way.