[libav-devel] [PATCH] arm: Check for the .arch directive in configure

2017-05-04 Thread Martin Storsjö
When targeting windows, the .arch directive isn't available. So far, when building for windows, we've always used gas-preprocessor, both when using msvc's armasm and when using clang. Lately, clang/llvm has implemented the last missing piece (altmacro support) for building our assembly without

Re: [libav-devel] [PATCH] arm: Check for the .arch directive in configure

2017-05-04 Thread Luca Barbato
On 5/4/17 10:45 AM, Martin Storsjö wrote: > is used), as suggested by Janne on irc. Looks fine. ___ libav-devel mailing list libav-devel@libav.org https://lists.libav.org/mailman/listinfo/libav-devel

Re: [libav-devel] [PATCH 4/5] dxva: move d3d11 locking/unlocking to functions

2017-05-04 Thread wm4
On Thu, 4 May 2017 11:15:42 +0200 Hendrik Leppkes wrote: > On Thu, May 4, 2017 at 8:44 AM, wm4 wrote: > > I want to make it non-mandatory to set a mutex in the D3D11 device > > context, and replacing it with user callbacks seems like the best > >

Re: [libav-devel] [PATCH 4/5] dxva: move d3d11 locking/unlocking to functions

2017-05-04 Thread Hendrik Leppkes
On Thu, May 4, 2017 at 8:44 AM, wm4 wrote: > I want to make it non-mandatory to set a mutex in the D3D11 device > context, and replacing it with user callbacks seems like the best > solution. This is preparation for it. Also makes the code slightly more > readable. > With

[libav-devel] [PATCH] arm: Check for the .arch directive in configure

2017-05-04 Thread Martin Storsjö
When targeting windows, the .arch directive isn't available. So far, when building for windows, we've always used gas-preprocessor, both when using msvc's armasm and when using clang. Lately, clang/llvm has implemented the last missing piece (altmacro support) for building our assembly without

[libav-devel] [PATCH 2/2] hevc: Add NEON 32x32 IDCT

2017-05-04 Thread Alexandra Hájková
--- libavcodec/arm/hevc_idct.S| 311 +++--- libavcodec/arm/hevcdsp_init_arm.c | 4 + 2 files changed, 294 insertions(+), 21 deletions(-) diff --git a/libavcodec/arm/hevc_idct.S b/libavcodec/arm/hevc_idct.S index eeb81e3..79799b2 100644 ---

Re: [libav-devel] [PATCH 1/5] lavu: add new D3D11 pixfmt and hwcontext

2017-05-04 Thread wm4
On Thu, 4 May 2017 08:44:04 +0200 wm4 wrote: > +AV_PIX_FMT_D3D11, ///< HW decoding through Direct3D11 via new API, > Picture.data[0] contains a ID3D11Texture2D pointer, and data[1] contains the > texture array index of the frame as intptr_t if the

[libav-devel] [PATCH 3/5] dxva: preparations for new hwaccel API

2017-05-04 Thread wm4
The actual hwaccel code will need to access an internal context instead of avctx->hwaccel_context, so add a new DXVA_CONTEXT() macro, that will dispatch between the "old" external and the new internal context. Also, the new API requires a new D3D11 pixfmt, so all places which check for the pixfmt

[libav-devel] [PATCH 5/5] dxva: add support for new dxva2 and d3d11 hwaccel APIs

2017-05-04 Thread wm4
This also adds support to avconv (which is trivial due to the new hwaccel API being generic enough). For now, this keeps avconv_dxva2.c as "dxva2-old", although it doesn't work as avconv.c can't handle multiple hwaccels with the same pixfmt. The new decoder setup code in dxva2.c is significantly

[libav-devel] [PATCH 1/5] lavu: add new D3D11 pixfmt and hwcontext

2017-05-04 Thread wm4
To be used with the new d3d11 hwaccel decode API. With the new hwaccel API, we don't want surfaces to depend on the decoder (other than the required dimension and format). The old D3D11VA pixfmt uses ID3D11VideoDecoderOutputView pointers, which include the decoder configuration, and thus is

[libav-devel] [PATCH 0/5] New D3D hwaccel API stuff

2017-05-04 Thread wm4
Radically rebased, and omits a few in-between commits that are unnecessary for the end result. avconv_dxva2.c should probably also be deleted, but for now it'd only inflate the diff. As part of the rebase I've also removed Steve Lhomme as author name - let me know whether I should set his name

[libav-devel] [PATCH 2/5] lavc: set avctx->hwaccel before init

2017-05-04 Thread wm4
So a hwaccel can access avctx->hwaccel in init for whatever reason. This is for the new d3d hwaccel API. We could create separate entrypoints for each of the 3 hwaccel types (dxva2, d3d11va, new d3d11va), but this seems nicer. --- libavcodec/decode.c | 4 ++-- 1 file changed, 2 insertions(+), 2

[libav-devel] [PATCH 4/5] dxva: move d3d11 locking/unlocking to functions

2017-05-04 Thread wm4
I want to make it non-mandatory to set a mutex in the D3D11 device context, and replacing it with user callbacks seems like the best solution. This is preparation for it. Also makes the code slightly more readable. --- And yes, only because INVALID_HANDLE_VALUE != NULL --- libavcodec/dxva2.c | 46

[libav-devel] [PATCH 1/2] hevc: 16x16 NEON idct: Use the right element size for stores.

2017-05-04 Thread Alexandra Hájková
This doesn't change the actual behaviour of the code but improves readability. --- libavcodec/arm/hevc_idct.S | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git a/libavcodec/arm/hevc_idct.S b/libavcodec/arm/hevc_idct.S index fac5758..eeb81e3 100644 ---

Re: [libav-devel] [PATCH 2/2] hevc: Add NEON 32x32 IDCT

2017-05-04 Thread Martin Storsjö
On Thu, 4 May 2017, Alexandra Hájková wrote: --- libavcodec/arm/hevc_idct.S| 311 +++--- libavcodec/arm/hevcdsp_init_arm.c | 4 + 2 files changed, 294 insertions(+), 21 deletions(-) My main issues with it have been taken care of, so I don't see it as

Re: [libav-devel] [PATCH 1/2] hevc: 16x16 NEON idct: Use the right element size for stores.

2017-05-04 Thread Martin Storsjö
On Thu, 4 May 2017, Alexandra Hájková wrote: This doesn't change the actual behaviour of the code but improves readability. --- libavcodec/arm/hevc_idct.S | 16 1 file changed, 8 insertions(+), 8 deletions(-) OK // Martin ___

Re: [libav-devel] [PATCH] checkasm: aarch64: Specify alignment for the register_init const array

2017-05-04 Thread Luca Barbato
On 5/4/17 8:46 PM, Martin Storsjö wrote: > Loads from this strictly doesn't require alignment, but specify it > just for consistency with the arm version. > --- > tests/checkasm/aarch64/checkasm.S | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git

[libav-devel] [GASPP PATCH] Support converting more instructions to their thumb equivalent

2017-05-04 Thread Martin Storsjo
--- These are used for supporting building x264 for windows/arm with msvc/armasm (currently in the x264 sandbox repo). --- gas-preprocessor.pl | 14 ++ 1 file changed, 14 insertions(+) diff --git a/gas-preprocessor.pl b/gas-preprocessor.pl index 35d201d..afdfc9e 100755 ---

[libav-devel] [PATCH] checkasm: aarch64: Specify alignment for the register_init const array

2017-05-04 Thread Martin Storsjö
Loads from this strictly doesn't require alignment, but specify it just for consistency with the arm version. --- tests/checkasm/aarch64/checkasm.S | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/tests/checkasm/aarch64/checkasm.S b/tests/checkasm/aarch64/checkasm.S index