Re: [PATCH] qemu: capabilities: rename piix4-acpi-root-hotplug-en to more appropriate name

2021-10-04 Thread Ani Sinha
On Mon, 4 Oct 2021, Laine Stump wrote: > On 10/4/21 1:26 PM, Ani Sinha wrote: > > The capability name piix4-acpi-root-hotplug-en is not conventional and > > appreared to be confusing to some. "en" suffix is also incorrect as the > > capability in qemu is used to both enable and disable hotplug

[PATCH v6 3/4] qemu: command: add support for acpi-bridge-hotplug feature

2021-10-04 Thread Ani Sinha
This change adds backend qemu command line support for new libvirt global feature 'acpi-bridge-hotplug'. This option can be used as following: The '' sub-element under '' is also newly introduced. 'acpi-bridge-hotplug' turns on the following command line option to qemu for x86

[PATCH v6 0/4] introduce support for acpi-bridge-hotplug feature

2021-10-04 Thread Ani Sinha
changelog: v6: rebased to latest. capabilities have been renamed as per suggestions that were made here: https://listman.redhat.com/archives/libvir-list/2021-October/msg00061.html v5: rebased the patchset with the latest master. v4: split the original series into two - pci-root controller

[PATCH v6 4/4] NEWS: add new acpi pci hotplug config option in the release note for next release

2021-10-04 Thread Ani Sinha
Added the following new libvirt conf option to the release note to indicate their availability with the next release: Signed-off-by: Ani Sinha --- NEWS.rst | 7 +++ 1 file changed, 7 insertions(+) diff --git a/NEWS.rst b/NEWS.rst index caa61f0646..25de621c91 100644 ---

[PATCH v6 1/4] qemu: capablities: detect presence of acpi-pci-hotplug-with-bridge-support

2021-10-04 Thread Ani Sinha
qemu added support for i440fx specific global boolean flag PIIX4_PM.acpi-pci-hotplug-with-bridge-support around version 2.1. This flag is enabled by default. When disabled, it turns off acpi pci hotplug for cold plugged pci bridges in i440fx machine types. Very recently, in qemu version 6.1,

[PATCH v6 2/4] conf: introduce support for acpi-bridge-hotplug feature

2021-10-04 Thread Ani Sinha
This change introduces a new libvirt sub-element under that can be used to configure all pci related features. Currently the only sub-sub element supported by this sub-element is 'acpi-bridge-hotplug' as shown below: The above option is only available for qemu driver and that too

Re: [PATCH 2/5] ch_monitor: Correctly close and ref the virCHMonitor

2021-10-04 Thread Laine Stump
On 10/3/21 10:10 PM, Douglas, William wrote: On Sun, 2021-10-03 at 15:52 -0400, Laine Stump wrote: On 10/3/21 3:43 PM, Laine Stump wrote:     cleanup: +    if (mon) +    virCHMonitorClose(mon); Oops, I also meant to point out that the "if (mon)" is unnecessary here, because (as with all

Re: [PATCH] qemu: capabilities: rename piix4-acpi-root-hotplug-en to more appropriate name

2021-10-04 Thread Laine Stump
On 10/4/21 1:26 PM, Ani Sinha wrote: The capability name piix4-acpi-root-hotplug-en is not conventional and appreared to be confusing to some. "en" suffix is also incorrect as the capability in qemu is used to both enable and disable hotplug on the pci root bus on the i440fx. Hence, rename it to

Re: [PATCH v7 1/4] qemu: capablities: detect presence of acpi-root-pci-hotplug for i440fx machines

2021-10-04 Thread Laine Stump
On 10/4/21 1:05 PM, Andrea Bolognani wrote: On Mon, Oct 04, 2021 at 10:19:17PM +0530, Ani Sinha wrote: On Mon, 4 Oct 2021, Andrea Bolognani wrote: On Fri, Oct 01, 2021 at 02:59:45PM +0530, Ani Sinha wrote: +++ b/src/qemu/qemu_capabilities.c + /* 410 */ +

[PATCH] qemu: capabilities: rename piix4-acpi-root-hotplug-en to more appropriate name

2021-10-04 Thread Ani Sinha
The capability name piix4-acpi-root-hotplug-en is not conventional and appreared to be confusing to some. "en" suffix is also incorrect as the capability in qemu is used to both enable and disable hotplug on the pci root bus on the i440fx. Hence, rename it to piix4.acpi-root-pci-hotplug so that it

Re: [PATCH v7 1/4] qemu: capablities: detect presence of acpi-root-pci-hotplug for i440fx machines

2021-10-04 Thread Ani Sinha
On Mon, 4 Oct 2021, Andrea Bolognani wrote: > On Mon, Oct 04, 2021 at 10:19:17PM +0530, Ani Sinha wrote: > > On Mon, 4 Oct 2021, Andrea Bolognani wrote: > > > On Fri, Oct 01, 2021 at 02:59:45PM +0530, Ani Sinha wrote: > > > > +++ b/src/qemu/qemu_capabilities.c > > > > + /* 410 */

Re: [PATCH v7 1/4] qemu: capablities: detect presence of acpi-root-pci-hotplug for i440fx machines

2021-10-04 Thread Andrea Bolognani
On Mon, Oct 04, 2021 at 10:19:17PM +0530, Ani Sinha wrote: > On Mon, 4 Oct 2021, Andrea Bolognani wrote: > > On Fri, Oct 01, 2021 at 02:59:45PM +0530, Ani Sinha wrote: > > > +++ b/src/qemu/qemu_capabilities.c > > > + /* 410 */ > > > + "piix4-acpi-root-hotplug-en", /* > >

Re: [PATCH] NEWS: cosmetic - fix indentation

2021-10-04 Thread Ani Sinha
On Mon, 4 Oct 2021, Andrea Bolognani wrote: > On Sat, Oct 02, 2021 at 09:37:13PM +0530, Ani Sinha wrote: > > The indentation of the first item under the categoty "new features" for the > > future release v7.9.0 is not right. Fix it. > > > > Signed-off-by: Ani Sinha > > --- > > NEWS.rst | 2

Re: [PATCH v7 1/4] qemu: capablities: detect presence of acpi-root-pci-hotplug for i440fx machines

2021-10-04 Thread Ani Sinha
On Mon, 4 Oct 2021, Andrea Bolognani wrote: > On Fri, Oct 01, 2021 at 02:59:45PM +0530, Ani Sinha wrote: > > +++ b/src/qemu/qemu_capabilities.c > > + /* 410 */ > > + "piix4-acpi-root-hotplug-en", /* > > QEMU_CAPS_PIIX_ACPI_ROOT_PCI_HOTPLUG */ > > Sorry if this is a

Re: [PATCH] virsh: Fix --nvram and --keep-nvram help strings

2021-10-04 Thread Andrea Bolognani
On Fri, Oct 01, 2021 at 09:05:52AM +0200, Michal Privoznik wrote: > The --nvram and --keep-nvram options of the undefine command can > be used regardless of the domain status (the only consumer so far > - qemuDomainUndefineFlags() doesn't care about the domain > status). Yet, their corresponding

Re: [PATCH v7 1/4] qemu: capablities: detect presence of acpi-root-pci-hotplug for i440fx machines

2021-10-04 Thread Andrea Bolognani
On Fri, Oct 01, 2021 at 02:59:45PM +0530, Ani Sinha wrote: > +++ b/src/qemu/qemu_capabilities.c > + /* 410 */ > + "piix4-acpi-root-hotplug-en", /* > QEMU_CAPS_PIIX_ACPI_ROOT_PCI_HOTPLUG */ Sorry if this is a silly question, but can you please explain where the "-en"

Re: [PATCH] NEWS: cosmetic - fix indentation

2021-10-04 Thread Andrea Bolognani
On Sat, Oct 02, 2021 at 09:37:13PM +0530, Ani Sinha wrote: > The indentation of the first item under the categoty "new features" for the > future release v7.9.0 is not right. Fix it. > > Signed-off-by: Ani Sinha > --- > NEWS.rst | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-)

Re: [PATCH 0/1] vmx: Fix mapping

2021-10-04 Thread Richard W.M. Jones
On Mon, Oct 04, 2021 at 04:50:51PM +0200, Laszlo Ersek wrote: > On 10/04/21 11:59, Richard W.M. Jones wrote: > > It turns out that changing the qemu implementation is painful, > > particularly if we wish to maintain backwards compatibility of the > > command line and live migration. > > > >

Re: Squelch 'eof from qemu monitor' error on normal VM shutdown

2021-10-04 Thread Michal Prívozník
On 9/30/21 7:15 PM, Jim Fehlig wrote: > On 9/29/21 21:29, Jim Fehlig wrote: >> Hi All, >> >> Likely Christian received a bug report that motivated commit >> aeda1b8c56, which was later reverted by Michal with commit 72adaf2f10. >> In the past, I recall being asked about "internal error: End of

Re: [PATCH 0/1] vmx: Fix mapping

2021-10-04 Thread Laszlo Ersek
On 10/04/21 11:59, Richard W.M. Jones wrote: > It turns out that changing the qemu implementation is painful, > particularly if we wish to maintain backwards compatibility of the > command line and live migration. > > Instead I opted to document comprehensively what all the > different hypervisors

Re: [PATCH 09/11] qdev: Avoid QemuOpts in QMP device_add

2021-10-04 Thread Kevin Wolf
Am 04.10.2021 um 14:18 hat Damien Hedde geschrieben: > > > On 10/1/21 16:42, Peter Krempa wrote: > > On Fri, Sep 24, 2021 at 11:04:25 +0200, Kevin Wolf wrote: > > > Directly call qdev_device_add_from_qdict() for QMP device_add instead of > > > first going through QemuOpts and converting back to

[PATCH] docs: describe flag VIR_STORAGE_POOL_CREATE_NORMAL to correct the HTML doc

2021-10-04 Thread Erik Skultety
From: Robin Lee This patch makes the descriptions of virStoragePoolCreateFlags annotate to the correct flag in the generated HTML file. --- Resending a merged change from GitLab. include/libvirt/libvirt-storage.h | 1 + 1 file changed, 1 insertion(+) diff --git

Re: [PATCH 09/11] qdev: Avoid QemuOpts in QMP device_add

2021-10-04 Thread Damien Hedde
On 10/1/21 16:42, Peter Krempa wrote: On Fri, Sep 24, 2021 at 11:04:25 +0200, Kevin Wolf wrote: Directly call qdev_device_add_from_qdict() for QMP device_add instead of first going through QemuOpts and converting back to QDict. Note that this changes the behaviour of device_add, though in

Re: [PATCH] failover: allow to pause the VM during the migration

2021-10-04 Thread Laurent Vivier
On 30/09/2021 22:17, Laine Stump wrote: On 9/30/21 1:09 PM, Laurent Vivier wrote: If we want to save a snapshot of a VM to a file, we used to follow the following steps: 1- stop the VM:     (qemu) stop 2- migrate the VM to a file:     (qemu) migrate "exec:cat > snapshot" 3- resume the VM:    

Re: [PATCH 0/1] vmx: Fix mapping

2021-10-04 Thread Richard W.M. Jones
It turns out that changing the qemu implementation is painful, particularly if we wish to maintain backwards compatibility of the command line and live migration. Instead I opted to document comprehensively what all the different hypervisors do: