[Lift] Set MappedLongForeignKey defaultValue...

2009-07-09 Thread Hannes
Hey Lifters, I wanna set the defaultValue for this object: object status extends MappedLongForeignKey(this, OrderStateMetaObj){ override def defaultValue = OrderStateMetaObj.find(By(OrderStateMetaObj.name, "NEW")) openOr 0L } The problem is, that the referenced OrderState object doesn't

[Lift] Re: howto do simple calculation with MappedInt

2009-07-10 Thread Hannes
Dave, This helped me a lot to understand things better! thanks. > Sorry it took so long to get to this... my inbox keeps growing... sigh. > > Anyway, Order.scala: 64 should be: > > > def currentCost = Order.this.lots * > (Order.this.marketPlace.obj.map(_.lotValue.is) openOr 0 ) > > The mar

[Lift] find, set and save

2009-07-22 Thread Hannes
Hi Lifters, It seems like I'm having problems to modify items that are already in the database. What I do is, first find the item, then set a new value to it and then save it. So far so good, or? Because its a expensive filter process to find those items to modify, I made a local copy of the

[Lift] Re: find, set and save

2009-07-22 Thread Hannes
the logic? What gets updated under which conditions? > > > On Wed, Jul 22, 2009 at 5:35 AM, Hannes <mailto:hannes.flo...@gmx.li>> wrote: > > > Hi Lifters, > > It seems like I'm having problems to modify items that are already in >

[Lift] Re: find, set and save

2009-07-22 Thread Hannes
> can you describe the logic? What gets updated under which conditions? > > > On Wed, Jul 22, 2009 at 5:35 AM, Hannes <mailto:hannes.flo...@gmx.li>> wrote: > > > Hi Lifters, > > It seems like I'm having problems to modify items that are already in

[Lift] Re: find, set and save

2009-07-22 Thread Hannes
<http://o1.tradetype.name/>)} > > findMap applies the filtering operation as each row is pulled from the > RDBMS... so you'll have fewer objects in memory. > > In terms of the remaining logic... I'm a little lost in your code... > can you describe the logic? Wh

[Lift] Re: find, set and save

2009-07-29 Thread Hannes
uff with LongKeyedMetaMapper[MyStuff] { > def mutate(in: MyStuff) { > for { > // find all the items where info = 'NEW' and dog != the value of > in's dog field > item <- MyStuff.findAll(By(MyStuff.info, "NEW"), > NotBy(MyStu

[Lift] strange behaviour of findAll(By(...))

2009-08-07 Thread Hannes
Why does the By method not accept two integers to compare? See erro belowthanks! /home/wacky/NetBeansProjects/virtualMarket/src/main/scala/org/tobster/comet/Market.scala:83: error: overloaded method value apply with alternatives [O <: net.liftweb.mapper.Mapper[O],T,Q <: net.liftweb.mapper

[Lift] Wiki article - CRUD

2009-08-19 Thread Hannes
Hey Lifters, Again and again I'm having problems to do simple CRUD operations with mapped fields, especially referenced fields (foreign keys). Because I think everyone need those things and I couldn't find a simple way to do it (I still don't really know how to use .map(...) with openOr to ge

[Lift] Re: CRUDify trait in 1.1-SNAPSHOT

2009-09-11 Thread Hannes
I've got another problem with CRUDify since I updated to release 1.0.2 (in M3 everything was fine). error: value showAllMenuLocParams is not a member of LimitOrder with net.liftweb.mapper.LongKeyedMetaMapper[...LimitOrder] with net.liftweb.mapper.CRUDify[long, LimitOrder] with ScalaObj

[Lift] Re: CRUDify trait in 1.1-SNAPSHOT

2009-09-11 Thread Hannes
ups! thanks anyway > > > On Fri, Sep 11, 2009 at 6:01 AM, Hannes <mailto:hannes.flo...@gmx.li>> wrote: > > > I've got another problem with CRUDify since I updated to release 1.0.2 > (in M3 everything was fine). > > > Release 1.0.2 is o

[Lift] What is the current working pattern for storing timestamps?

2010-02-21 Thread Hannes
Hi Lifters, I'm using Mapper with Lift 1.1-M7 and I need to have some information about time. Especially I wanna store a time-stamp for a status field that can have three values: NEW; OPEN; CLOSED; So, what I thought about was defining two new fields open_time and close_time that I'd use

Re: [Lift] Re: What is the current working pattern for storing timestamps?

2010-02-22 Thread Hannes
Hi Peter, Thanks in advance. I was browsing through the list and read, that there's a lot of problems with the Java stuff. That's why I asked. I'll have a look at this JodaTime thing... thanks. Hi Hannes, Jonathan's suggestion of MappedDateTime is a good one and

Re: [Lift] scala-time and Lift pom.xml

2010-02-26 Thread Hannes
Hi Peter, I read your mail, maybe you can help me. I'm wondering how I can integrate JodaTime or scala-time into my project. thanks. Hannes This is more a question for Jorge than anyone else but since it's Lift- related I thought I'd put it here: What's the easiest way t

Re: [Lift] scala-time and Lift pom.xml

2010-02-26 Thread Hannes
dding this: joda-time joda-time 1.6 to the dependency section to your maven POM will bring in the jar files. On Fri, Feb 26, 2010 at 10:14 AM, Hannes <mailto:hannes.flo...@gmx.li>> wrote: Hi Peter, I read your mail, maybe you can help me. I'm wondering how I ca

Re: [Lift] scala-time and Lift pom.xml

2010-02-26 Thread Hannes
THANKS! You saved my weekend On Fri, Feb 26, 2010 at 10:43 AM, Hannes <mailto:hannes.flo...@gmx.li>> wrote: Jim, Thanks that helped! Maybe its to late, or I don't know what, but. Its a bit complicated to use I think. What's about scala-time? Fo

Re: [Lift] scala-time and Lift pom.xml

2010-02-26 Thread Hannes
I swear that I ONLY use it to compare "if things are older than other things". I think comparison of long values is faster than string or date comparison, or? thanks. On Fri, Feb 26, 2010 at 10:52 AM, Hannes <mailto:hannes.flo...@gmx.li>> wrote: THANKS! Y

Re: [Lift] Re: scala-time and Lift pom.xml

2010-02-26 Thread Hannes
11:12 AM, Hannes wrote: I swear that I ONLY use it to compare "if things are older than other things". I think comparison of long values is faster than string or date comparison, or? In what timezone? and for what calendar? thanks. On Fri, Feb 26, 2

[Lift] java.sql.SQLException | ERROR 07000

2009-10-13 Thread Hannes
Hi Lifters, I encountered a problem after I started & tried to test my project today. I'm almost sure that this error didn't occured before..I also updated to 1.1-M6 but the error is still there. Do I've to do some other update? I think the problem is related to some actor stuff.??? H

[Lift] Re: java.sql.SQLException | ERROR 07000

2009-10-13 Thread Hannes
OK, thanks. I'll have a look! > On Tue, Oct 13, 2009 at 8:27 AM, Hannes wrote: > >> I'm almost sure that this error didn't occured before..I also >> updated to 1.1-M6 but the error is still there. Do I've to do some other >> update? I thin

[Lift] Re: Create the website and all the links are Https ?

2009-10-13 Thread Hannes
You can use Apache to secure your page with HTTPS. > Hi all, > > How can we create the website and all the links are https? > > Just like: www.xing.com > > That all of the operations and communications are used https. > > Thanks very much ! > > Cheers, > Neil > > > > --~--~---

[Lift] Generate Visual Diagram from existing Sources

2009-10-26 Thread Hannes
Hi Lifters, Is there a way to automatically generate a Diagram (e.g. UML) from existing source files, that shows composition, association, class attributes, methods, etc.? thanks. --~--~-~--~~~---~--~~ You received this message because you are subscribed to th

[Lift] not found: Full, Empty, Box

2009-11-06 Thread Hannes
Hey Lifters, I just updated to scala 2.7.7 and lift 1.1-M7. Now I get the above compilation errors. I couldn't find any documentation where Full, Empty and Box are located now...sorry to bother you with this thanks. --~--~-~--~~~---~--~~ You received this m

[Lift] Re: New Milestone coming soon

2009-11-12 Thread Hannes
Hi David, I wrote you a message about the "CometActor received shutdown" thing. I'm almost sure, that this is related to M7, but I've no idea, why or what. kind regards Tobias > Folks, > > There are two critical issues with M7: > > * Issue 164 http://github.com/dpp/liftweb/issues#issue/164 >

[Lift] Re: New Milestone coming soon

2009-11-13 Thread Hannes
Hi David, I read your response, but I didn't replied. Sorry. I've to figure out, what causes my problem. Seems like the CometActor update or something doesn't work properly, in M6 it did. But I don't really know, yet. thanks. > > > On Thu, Nov 12, 2009 at 11:37 A

[Lift] Another List "XYZ" Menu Entry

2009-11-16 Thread Hannes
Hi Lifters, I need a new menu entry that displays a table similar to the one, that is shown by the CRUDify List "XYZ" link. But I need to display different fields without the chance to edit or delete the "items". So basically, just a simple table. Later on, some Comet stuff would be nice, to s

Re: [Lift] Another List "XYZ" Menu Entry

2009-11-20 Thread Hannes
y? thanks. > > > On Mon, Nov 16, 2009 at 8:51 AM, Hannes <mailto:hannes.flo...@gmx.li>> wrote: > > > Hi Lifters, > > I need a new menu entry that displays a table similar to the one, that > is shown by the CRUDify List "XYZ" link. But I

Re: [Lift] Another List "XYZ" Menu Entry

2009-11-20 Thread Hannes
Maybe you could give a one liner, showing how to write the menu item in Boot.scala. thanks. > On Fri, Nov 20, 2009 at 6:26 AM, Hannes <mailto:hannes.flo...@gmx.li>> wrote: > > I meant, that I had general problems to find a way how to do it, > not talking about th

Re: [Lift] Another List "XYZ" Menu Entry

2009-11-20 Thread Hannes
I read some stuff of chapter five before, but this was the extra hint, that I needed... thanks! > > > On Fri, Nov 20, 2009 at 7:07 AM, Hannes <mailto:hannes.flo...@gmx.li>> wrote: > > Maybe you could give a one liner, showing how to write the menu > item

[Lift] Sitemap + Menu Names + Change Order

2009-11-29 Thread Hannes
Hi Lifters, I couldn't find anything about how to change a menu name, that is generated from CRUDify. Furthermore, I want to change the internal order of CRUDify menus. I believe that its more "natural" to use, when the create item comes before the list item. thanks. -- You received this me

Re: [Lift] Sitemap + Menu Names + Change Order

2009-11-29 Thread Hannes
Hi Heiko, thanks for the quick and helpful answer! The renaming was quite easy, but what do I've to write inside CRUDify.menus? thanks. > Hannes, > > 2009/11/29 Hannes mailto:hannes.flo...@gmx.li>> > > > I couldn't find anything about how to change a menu

Re: [Lift] Sitemap + Menu Names + Change Order

2009-11-29 Thread Hannes
Thanks! It was the box again, I'm still not really comfortable in getting things out of it > Hi Hannes, > > 2009/11/29 Hannes mailto:hannes.flo...@gmx.li>> > > > thanks for the quick and helpful answer! > > > You're welcome ;-) > > &g

[Lift] method call from out of nowhere

2009-11-29 Thread Hannes
Hey Lifters, I've some really strange things going on here. Please consider this method definition. I've put alot of print "debug" statements between other statements. There's a while-loop that only starts, when the given list (orders) is not empty. It stops when "done" is set to true. So far,

Re: [Lift] method call from out of nowhere

2009-11-29 Thread Hannes
Hi Tim, > Hannes, > > Firstly, I really, really wouldn't write your code like that... > > Things of note: > - two defs inside defs... you usually wouldnt do this without a good reason > (like SHtml.submit(whatever _)) > The two defs only make sence together, that

Re: [Lift] method call from out of nowhere

2009-11-30 Thread Hannes
It is called outside from an Actor, everytime a new item is created. thanks. > Where is joinOtherOrders()called within your code? > > alex > > On Sun, Nov 29, 2009 at 7:24 AM, Hannes <mailto:hannes.flo...@gmx.li>> wrote: > > Hey Lifters, > > I've

Re: [Lift] Re: method call from out of nowhere

2009-11-30 Thread Hannes
Hi Marius, the method is called from an Actor, everytime a new order is created. I did override def afterCreate in my LimitOrder MetaObject. thanks. > In your code in what conditions joinOtherOrders gets called ? > > Br's, > Marius > > On Nov 29, 6:18 pm, Hannes wrote:

Re: [Lift] Re: method call from out of nowhere

2009-11-30 Thread Hannes
Timothy Perrett schrieb: >> The two defs only make sence together, that's why I put them together in >> one def. I think that's encapsulation...> - dont use while loops. period. >> you have a List[T], use foreach if you have a unit operation >> >> > > If you want encapsulation, because they "

Re: [Lift] method call from out of nowhere

2009-11-30 Thread Hannes
; t really know, why it gets called after the old scope of joinOtherOrders ends... thanks. > > > On Sun, Nov 29, 2009 at 7:24 AM, Hannes <mailto:hannes.flo...@gmx.li>> wrote: > > Hey Lifters, > > > How is joinOtherOrders being invoked? > > > >

Re: [Lift] method call from out of nowhere

2009-11-30 Thread Hannes
ok, I'll do that. thanks. > Or you can get stack trace information from Thread. I have a utility > function "getCaller" that does a getStackTrace and then looks at the > proper element of the array. (second, third? I forget) > > On Mon, Nov 30, 2009 at 12:30 AM, Alex Boisvert > wrote: > >> An

Re: [Lift] method call from out of nowhere

2009-11-30 Thread Hannes
Hi David, > > > On Mon, Nov 30, 2009 at 12:11 AM, Hannes <mailto:hannes.flo...@gmx.li>> wrote: > > Hi David, > > In my LimitOrder Meta Object, I did: > > override def afterCreate > > to inform an Actor, everytime a new Order

Re: [Lift] method call from out of nowhere

2009-12-01 Thread Hannes
David Pollak schrieb: > > > On Mon, Nov 30, 2009 at 11:26 PM, Hannes <mailto:hannes.flo...@gmx.li>> wrote: > > Hi David, > >> >> >> On Mon, Nov 30, 2009 at 12:11 AM, Hannes > <mailto:hannes.flo...@gmx.li>> wrote: >> >

[Lift] Documentation Site

2009-12-19 Thread Hannes
Hi Lifters, I'm thinking about setting up a site that takes together all available information about Lift (Links, News, ...). I would like to know, if this would be appreciated or not. I still think that all the available information is to much spread out - specially for people who get started

Re: [Lift] Re: Documentation Site

2009-12-19 Thread Hannes
I think that Lift is still at the point where one location of docs is > better. > > My opinion. > > On Dec 19, 6:37 am, Hannes wrote: > >> Hi Lifters, >> >> I'm thinking about setting up a site that takes together all available >> information a

Re: [Lift] Re: Documentation Site

2009-12-20 Thread Hannes
vailable for all kinds of stuff (a lot of stuff that doesn't need to be re-invented). And I believe that one system is easier to handle than three different ones. Like I said before, just my opinion and an idea. > Cheers, Tim > > PS: Sorry that was a bit of a rant, but this is a fr

[Lift] redirectTo in (Stateful)Snippets

2010-02-19 Thread Restel, Hannes
else { S.notice("Value was: " + searchExpression) redirectTo("/search") } } bind("entry", xhtml, "searchfield" -> SHtml.text(searchExpression.is, searchExpression(_)), "submit" -> SHtml.submi

RE: [Lift] Re: redirectTo in (Stateful)Snippets

2010-02-22 Thread Restel, Hannes
e (i.e. my page) is not found. So please try again :-) (And yes: I did read The Lift Book :-) Cheers, Hannes -Original Message- From: liftweb@googlegroups.com [mailto:lift...@googlegroups.com] On Behalf Of Nico Tromp Sent: Friday, February 19, 2010 2:46 PM To: Lift Subject:

RE: [Lift] Re: redirectTo in (Stateful)Snippets

2010-02-23 Thread Restel, Hannes
scala.io.Source.report(Source.scala:368) scala.io.Source.reportError(Source.scala:355) (..) " When chosing another name for the page then all works fine. So the question is: is the page name "search" an reserved keyword in Lift? Thanks! Hannes Restel | Fraunh