Re: [PATCH 1/3] HID: sony: Enable LED controls and rumble for the Sixaxis on Bluetooth.

2014-02-19 Thread David Herrmann
Hi On Tue, Feb 18, 2014 at 11:22 PM, Frank Praznik wrote: > Add a SIXAXIS_CONTROLLER macro to simplify conditionals where the > connection type is irrelevant. > > Enable the LED and force feedback controls for Sixaxis controllers connected > via > Bluetooth. > > Send Sixaxis Bluetooth output rep

Re: [PATCH 2/3] HID: sony: Force-feedback cleanup

2014-02-19 Thread David Herrmann
Hi On Tue, Feb 18, 2014 at 11:22 PM, Frank Praznik wrote: > Only initialize force feedback for devices that actually support it (Sixaxis > and > Dualshock 4). > > Move the cancel_work_sync() call out of sony_destroy_ff() since the state > worker > is used for the LEDs even when force-feedback i

Re: [PATCH 3/3] HID: sony: Prevent duplicate controller connections.

2014-02-19 Thread David Herrmann
Hi On Tue, Feb 18, 2014 at 11:22 PM, Frank Praznik wrote: > If a Sixaxis or Dualshock 4 controller is connected via USB while already > connected via Bluetooth it will cause duplicate devices to be added to the > input device list. > > To prevent this a global list of controllers and their MAC ad

ff-core effect id handling in case of a failed effect upload

2014-02-19 Thread Elias Vanderstuyft
Hi, In the process of reviewing the Wine DInput translation layer, I noticed an inconvenience (in the ff-core implementation?) that can possibly lead to confusing problems to application developers (not only for Wine), in short: If a new (id==-1) effect was uploaded (look at ff-core.c::input_ff_u

[PATCH v2 2/3] Input: gpio_keys - convert to use devm_*

2014-02-19 Thread Andy Shevchenko
This makes the error handling much more simpler than open-coding everything and in addition makes the probe function smaller an tidier. Signed-off-by: Andy Shevchenko --- drivers/input/keyboard/gpio_keys.c | 75 +- 1 file changed, 25 insertions(+), 50 deletion

[PATCH v2 3/3] Input: gpio_keys - convert struct descriptions to kernel-doc

2014-02-19 Thread Andy Shevchenko
This patch converts descriptions of the structures defined in linux/gpio_keys.h to follow kernel-doc format. There is no functional change. Signed-off-by: Andy Shevchenko --- include/linux/gpio_keys.h | 45 + 1 file changed, 33 insertions(+), 12 delet

[PATCH v2 1/3] Input: gpio_keys - use dev instead of pdev in gpio_keys_setup_key()

2014-02-19 Thread Andy Shevchenko
The platform device is not used in gpio_keys_setup_key(). This patch substitutes it by struct device. Signed-off-by: Andy Shevchenko --- drivers/input/keyboard/gpio_keys.c | 7 +++ 1 file changed, 3 insertions(+), 4 deletions(-) diff --git a/drivers/input/keyboard/gpio_keys.c b/drivers/inp

Re: ff-core effect id handling in case of a failed effect upload

2014-02-19 Thread Anssi Hannula
(added Dmitry to CC) 19.02.2014 13:42, Elias Vanderstuyft kirjoitti: > Hi, > Hi, > In the process of reviewing the Wine DInput translation layer, I > noticed an inconvenience (in the ff-core implementation?) that can > possibly lead to confusing problems to application developers (not > only fo

Re: ff-core effect id handling in case of a failed effect upload

2014-02-19 Thread Elias Vanderstuyft
On Wed, Feb 19, 2014 at 5:49 PM, Anssi Hannula wrote: > (added Dmitry to CC) > > 19.02.2014 13:42, Elias Vanderstuyft kirjoitti: >> Hi, >> > > Hi, > >> In the process of reviewing the Wine DInput translation layer, I >> noticed an inconvenience (in the ff-core implementation?) that can >> possibly

[PATCH] HID: sony: Fix work queue issues.

2014-02-19 Thread Frank Praznik
Don't initialize force-feedback for devices that don't support it to avoid calls to schedule_work() with an uninitialized work_struct. Move the cancel_work_sync() call out of sony_destroy_ff() since the state worker is used for the LEDs even when force-feedback is disabled. Remove sony_destroy_ff

Re: [PATCH] HID: sony: Fix work queue issues.

2014-02-19 Thread Greg KH
On Wed, Feb 19, 2014 at 01:09:22PM -0500, Frank Praznik wrote: > Don't initialize force-feedback for devices that don't support it to avoid > calls > to schedule_work() with an uninitialized work_struct. > > Move the cancel_work_sync() call out of sony_destroy_ff() since the state > worker > is

Re: [PATCH] HID: sony: Fix work queue issues.

2014-02-19 Thread David Herrmann
Hi Frank On Wed, Feb 19, 2014 at 7:09 PM, Frank Praznik wrote: > Don't initialize force-feedback for devices that don't support it to avoid > calls > to schedule_work() with an uninitialized work_struct. > > Move the cancel_work_sync() call out of sony_destroy_ff() since the state > worker > is

Re: Questions about the documentation/specification of Linux ForceFeedback input.h

2014-02-19 Thread Elias Vanderstuyft
On Sun, Feb 16, 2014 at 12:04 AM, Anssi Hannula wrote: > 15.02.2014 22:32, Elias Vanderstuyft kirjoitti: >> On Sat, Feb 15, 2014 at 3:04 PM, Anssi Hannula wrote: >>> >>> However, from what I can see, you can achieve the exact same effect with >>> these parameters (DInput deadband definition): >>>

Re: [PATCH] HID: sony: Fix work queue issues.

2014-02-19 Thread Frank Praznik
On Wed, Feb 19, 2014 at 1:41 PM, David Herrmann wrote: > Hi Frank > > On Wed, Feb 19, 2014 at 7:09 PM, Frank Praznik > wrote: >> Don't initialize force-feedback for devices that don't support it to avoid >> calls >> to schedule_work() with an uninitialized work_struct. >> >> Move the cancel_wor

Problem with Logitech SpaceNavigator

2014-02-19 Thread Christian Ehrlicher
Hi, I've a problem with some SpaceNavigator devices with a newer firmware (4.31). The problem is that the fixup for the EV_REL/EV_ABS (LG_RDESC_REL_ABS) is not applied for the new firmware because the report_descriptor is different (see attachments). It looks like the checked and modified byt

Re: ff-core effect id handling in case of a failed effect upload

2014-02-19 Thread Andrew Eikum
On Wed, Feb 19, 2014 at 06:32:54PM +0100, Elias Vanderstuyft wrote: > I'll include the code (with effectId_old variable) and this discussion > when I submit my whole patchset for Wine's DInput libs to Wine-devel > mailing list. Right now, I don't know who I should personally mail to. > Patches re

Re: ff-core effect id handling in case of a failed effect upload

2014-02-19 Thread Elias Vanderstuyft
On Wed, Feb 19, 2014 at 8:32 PM, Andrew Eikum wrote: > On Wed, Feb 19, 2014 at 06:32:54PM +0100, Elias Vanderstuyft wrote: >> I'll include the code (with effectId_old variable) and this discussion >> when I submit my whole patchset for Wine's DInput libs to Wine-devel >> mailing list. Right now, I

Re: ff-core effect id handling in case of a failed effect upload

2014-02-19 Thread Dmitry Torokhov
On Wed, Feb 19, 2014 at 06:49:36PM +0200, Anssi Hannula wrote: > (added Dmitry to CC) > > 19.02.2014 13:42, Elias Vanderstuyft kirjoitti: > > Hi, > > > > Hi, > > > In the process of reviewing the Wine DInput translation layer, I > > noticed an inconvenience (in the ff-core implementation?) that

Re: [PATCH v2] Input: add i2c/smbus driver for elan touchpad

2014-02-19 Thread Benson Leung
On Thu, Feb 6, 2014 at 4:21 PM, Benson Leung wrote: > On Fri, Jan 10, 2014 at 12:30 PM, Benson Leung wrote: >> On Mon, Jan 6, 2014 at 7:08 PM, Duson Lin wrote: >>> This driver adds support for elan i2c/smbus touchpad found on some laptops >>> PC >>> >>> Signed-off-by: Duson Lin >> >> Reviewed-

Re: ff-core effect id handling in case of a failed effect upload

2014-02-19 Thread Elias Vanderstuyft
On Wed, Feb 19, 2014 at 10:05 PM, Dmitry Torokhov wrote: > On Wed, Feb 19, 2014 at 06:49:36PM +0200, Anssi Hannula wrote: >> (added Dmitry to CC) >> >> 19.02.2014 13:42, Elias Vanderstuyft kirjoitti: >> > Hi, >> > >> >> Hi, >> >> > In the process of reviewing the Wine DInput translation layer, I >

Re: [PATCH] HID: sony: Fix work queue issues.

2014-02-19 Thread David Herrmann
Hi On Wed, Feb 19, 2014 at 8:21 PM, Frank Praznik wrote: > On Wed, Feb 19, 2014 at 1:41 PM, David Herrmann wrote: >> Hi Frank >> >> On Wed, Feb 19, 2014 at 7:09 PM, Frank Praznik >> wrote: >>> Don't initialize force-feedback for devices that don't support it to avoid >>> calls >>> to schedule