[PATCH] lib/siphash.c: mark expected switch fall-throughs

2019-04-16 Thread Stephen Rothwell
In preparation to enabling -Wimplicit-fallthrough, mark switch cases where we are expecting to fall through. This patch aims to suppress up to 18 missing-break-in-switch false positives on some architectures. Cc: Jason A. Donenfeld Cc: Gustavo A. R. Silva Cc: Kees Cook Signed-off-by: Stephen

Re: [PATCH] x86/PCI: fix a memory leak bug

2019-04-16 Thread Ingo Molnar
* Wenwen Wang wrote: > In pcibios_irq_init(), the PCI IRQ routing table 'pirq_table' is firstly > found through pirq_find_routing_table(). If the table is not found and > 'CONFIG_PCI_BIOS' is defined, the table is then allocated in > pcibios_get_irq_routing_table() using kmalloc(). In the

Re: [RFC] mmc: cqhci: clear pending interrupt and halt

2019-04-16 Thread Adrian Hunter
On 16/04/19 9:48 AM, Peng Fan wrote: > On i.MX8MM, we are running Dual Linux OS, with 1st Linux using SD Card > as rootfs storage, 2nd Linux using eMMC as rootfs storage. We let the > the 1st linux configure power/clock for the 2nd Linux. > > When the 2nd Linux is booting into rootfs stage, we

Re: [RESEND PATCH v3 1/2] power: supply: add input voltage limit property

2019-04-16 Thread Pavel Machek
Hi! > This patch exposes a new property, similar to input current limit, to > re-configure the maximum voltage from the external supply at runtime > based on system-level knowledge or user input. Well, and I suspect it should expose input power limit, not input voltage limit. DC-DC convertor

Re: [PATCH v2 13/19] PM / devfreq: tegra: Mark ACTMON's governor as immutable

2019-04-16 Thread Chanwoo Choi
Hi, On 19. 4. 15. 오후 11:54, Dmitry Osipenko wrote: > The ACTMON's governor supports only the Tegra's devfreq device and there > is no need to use any other governor, hence let's mark Tegra governor as > immutable to permanently stick it with Tegra's devfreq device. > > Signed-off-by: Dmitry

Re: [PATCH v2 12/19] PM / devfreq: tegra: Avoid inconsistency of current frequency value

2019-04-16 Thread Chanwoo Choi
Hi, On 19. 4. 15. 오후 11:54, Dmitry Osipenko wrote: > The frequency value potentially could change in-between. It doesn't > cause any real problem at all right now, but that could change in the > future. Hence let's avoid the inconsistency. > > Signed-off-by: Dmitry Osipenko > --- >

Re: [PATCH] ARM: OMAP1: ams-delta: fix early boot crash when LED support is disabled

2019-04-16 Thread Pavel Machek
On Tue 2019-04-16 02:37:32, Aaro Koskinen wrote: > When we boot with the LED support (CONFIG_NEW_LEDS) disabled, > gpio_led_register_device() will return a NULL pointer and we try > to dereference it. Fix by checking also for a NULL pointer. > > Fixes: 19a2668a8ae3 ("ARM: OMAP1: ams-delta:

linux-next: Tree for Apr 16

2019-04-16 Thread Stephen Rothwell
Hi all, Changes since 20190415: The netfilter tree lost its build failure. The netfilter-next tree lost its build failure. The drm tree still had its build failure for which I disabled a driver. The drm-misc tree lost its build failure. The tpmdd tree gained a build failure so I used the

[tip:x86/mm] x86/mm: Fix the 56-bit addresses memory map in Documentation/x86/x86_64/mm.txt

2019-04-16 Thread tip-bot for Stephen Kitt
Commit-ID: 89502a01979033a1c0c0c4d6d9aef07e59021005 Gitweb: https://git.kernel.org/tip/89502a01979033a1c0c0c4d6d9aef07e59021005 Author: Stephen Kitt AuthorDate: Mon, 15 Apr 2019 17:08:53 +0200 Committer: Ingo Molnar CommitDate: Tue, 16 Apr 2019 09:00:34 +0200 x86/mm: Fix the 56-bit

[tip:locking/urgent] locking/lockdep: Make lockdep_unregister_key() honor 'debug_locks' again

2019-04-16 Thread tip-bot for Bart Van Assche
Commit-ID: 8b39adbee805c539a461dbf208b125b096152b1c Gitweb: https://git.kernel.org/tip/8b39adbee805c539a461dbf208b125b096152b1c Author: Bart Van Assche AuthorDate: Mon, 15 Apr 2019 10:05:38 -0700 Committer: Ingo Molnar CommitDate: Tue, 16 Apr 2019 08:21:51 +0200 locking/lockdep: Make

Re: linux-next: build warning after merge of the akpm-current tree

2019-04-16 Thread Stephen Rothwell
Hi all, On Fri, 29 Mar 2019 13:39:14 +1100 Stephen Rothwell wrote: > > After merging the akpm-current tree, today's linux-next build (arm > multi_v7_defconfig) produced this warning: > > lib/list_sort.c:17:36: warning: 'pure' attribute ignored [-Wattributes] >struct list_head const *,

Re: [PATCH] iwlegacy: fix spelling mistake "acumulative" -> "accumulative"

2019-04-16 Thread Mukesh Ojha
On 4/15/2019 4:07 PM, Colin King wrote: From: Colin Ian King Fix spelling mistakes in rx stats text. I missed these from an earlier round of fixing the same spelling mistake. Signed-off-by: Colin Ian King Reviewed-by: Mukesh Ojha Cheers, -Mukesh ---

[RFC] mmc: cqhci: clear pending interrupt and halt

2019-04-16 Thread Peng Fan
On i.MX8MM, we are running Dual Linux OS, with 1st Linux using SD Card as rootfs storage, 2nd Linux using eMMC as rootfs storage. We let the the 1st linux configure power/clock for the 2nd Linux. When the 2nd Linux is booting into rootfs stage, we let the 1st Linux to destroy the 2nd linux, then

[PATCH] configfs: Fix possible use-after-free in configfs_register_group

2019-04-16 Thread Yue Haibing
From: YueHaibing Syzkaller report this: BUG: KASAN: use-after-free in __list_add_valid+0xd4/0xe0 lib/list_debug.c:26 Read of size 8 at addr 8881ef61ae20 by task syz-executor.0/5996 CPU: 1 PID: 5996 Comm: syz-executor.0 Tainted: G C5.0.0+ #5 Hardware name: QEMU Standard PC

[PATCH v4 0/7] ARM: sun8i: a83t: Enable USB OTG

2019-04-16 Thread Chen-Yu Tsai
From: Chen-Yu Tsai Hi everyone, This is v4 of my A83T USB power supply / OTG series. Hopefully this is the last revision even though it's kind of late in the -rc cycle for the patches to make the next release. Fingers crossed. Changes since v3: - Dropped patch for disabling current limit

[PATCH v4 1/7] dt-bindings: power: supply: axp20x_usb_power: add axp813 compatible

2019-04-16 Thread Chen-Yu Tsai
From: Chen-Yu Tsai This adds the "x-powers,axp813-usb-power-supply" to the list of compatibles for AXP20X VBUS power supply driver. Reviewed-by: Rob Herring Signed-off-by: Chen-Yu Tsai --- Changes since v2: - Collected Rob's Reviewed-by ---

[PATCH v4 2/7] power: supply: axp20x_usb_power: Fix typo in VBUS current limit macros

2019-04-16 Thread Chen-Yu Tsai
From: Chen-Yu Tsai The VBUS current limit value macros have VBUS typed as VBUC, while the bitmask macro is named correctly. Fix it. Fixes: 69fb4dcada77 ("power: Add an axp20x-usb-power driver") Signed-off-by: Chen-Yu Tsai --- drivers/power/supply/axp20x_usb_power.c | 16 1

Re: [PATCH 1/1] pinctrl: Add alternative way for specifying register bases

2019-04-16 Thread Light Hsieh
Hi, Sean: On Sun, 2019-04-14 at 16:01 -0700, Sean Wang wrote: > Hi, Light > > On Thu, Apr 11, 2019 at 8:15 PM Light Hsieh wrote: > > > > The orginal PINCTRL_MTK_PARIS/PINCTRL_MTK_MOORE need more effort for > > specifying register bases when porting platform driver: > > 1. Write

[PATCH 5/5] lib/test_bitmap: add tests for bitmap_parselist_user

2019-04-16 Thread Yury Norov
From: Yury Norov Propagate existing bitmap_parselist() tests to bitmap_parselist_user(). Signed-off-by: Yury Norov Reviewed-by: Andy Shevchenko --- lib/test_bitmap.c | 46 -- 1 file changed, 36 insertions(+), 10 deletions(-) diff --git

[PATCH v5 0/5] lib: rework bitmap_parselist and tests

2019-04-16 Thread Yury Norov
bitmap_parselist has been evolved from a pretty simple idea for long and now lacks for refactoring. It is not structured, has nested loops and a set of opaque-named variables. Things are more complicated because bitmap_parselist() is a part of user interface, and its behavior should not change.

[PATCH 1/5] lib: make bitmap_parselist_user() a wrapper on bitmap_parselist()

2019-04-16 Thread Yury Norov
From: Yury Norov Currently we parse user data byte after byte which leads to overcomplification of parsing algorithm. The only user of bitmap_parselist_user() is not performance-critical, and so we can duplicate user data to kernel buffer and simply call bitmap_parselist(). This rework lets us

[PATCH 3/5] lib/test_bitmap: switch test_bitmap_parselist to ktime_get()

2019-04-16 Thread Yury Norov
From: Yury Norov test_bitmap_parselist currently uses get_cycles which is not implemented on some platforms, so use ktime_get() instead. Signed-off-by: Yury Norov Reviewed-by: Andy Shevchenko --- lib/test_bitmap.c | 9 - 1 file changed, 4 insertions(+), 5 deletions(-) diff --git

[PATCH 2/5] lib: rework bitmap_parselist

2019-04-16 Thread Yury Norov
From: Yury Norov Remove __bitmap_parselist helper and split the function to logical parts. Signed-off-by: Yury Norov --- lib/bitmap.c | 255 --- 1 file changed, 142 insertions(+), 113 deletions(-) diff --git a/lib/bitmap.c b/lib/bitmap.c index

[PATCH 4/5] lib/test_bitmap: add testcases for bitmap_parselist

2019-04-16 Thread Yury Norov
From: Yury Norov Add tests for non-number character, empty regions, integer overflow. Signed-off-by: Yury Norov Reviewed-by: Andy Shevchenko --- lib/test_bitmap.c | 18 +- 1 file changed, 17 insertions(+), 1 deletion(-) diff --git a/lib/test_bitmap.c b/lib/test_bitmap.c

[PATCH v15 3/3] Documentation/filesystems/proc.txt: add AVX512_elapsed_ms

2019-04-16 Thread Aubrey Li
Added AVX512_elapsed_ms in /proc//status. Report it in Documentation/filesystems/proc.txt Signed-off-by: Aubrey Li Cc: Peter Zijlstra Cc: Andi Kleen Cc: Tim Chen Cc: Dave Hansen Cc: Arjan van de Ven Cc: Linux API Cc: Alexey Dobriyan Cc: Andrew Morton ---

[PATCH v15 2/3] x86,/proc/pid/status: Add AVX-512 usage elapsed time

2019-04-16 Thread Aubrey Li
AVX-512 components use could cause core turbo frequency drop. So it's useful to expose AVX-512 usage elapsed time as a heuristic hint for the user space job scheduler to cluster the AVX-512 using tasks together. Tensorflow example: $ while [ 1 ]; do cat /proc/tid/status | grep AVX; sleep 1; done

[PATCH v15 1/3] /proc/pid/status: Add support for architecture specific output

2019-04-16 Thread Aubrey Li
The architecture specific information of the running processes could be useful to the userland. Add support to examine process architecture specific information externally. Signed-off-by: Aubrey Li Cc: Peter Zijlstra Cc: Andi Kleen Cc: Tim Chen Cc: Dave Hansen Cc: Arjan van de Ven Cc: Linux

Re: [PATCH 0/3] Add ST lsm6dso i3c suppport

2019-04-16 Thread Boris Brezillon
Hi Vitor, On Mon, 15 Apr 2019 21:19:38 +0200 Vitor Soares wrote: I like the very detailed description in your cover letter :P. Anyway, glad to see I3C support added to regmap. Also happy to have a new driver for an I3C device. Thanks for working on that. Boris > Vitor Soares (3): > remap:

Re: [PATCH] pci: fix warning for struct hisi_pcie_platform_ops

2019-04-16 Thread Zhou Wang
On 2019/4/15 16:53, Mao Wenan wrote: > There is one warning exist while compiling > drivers/pci/controller/dwc/pcie-hisi.c. > make allmodconfig ARCH=arm64 CROSS_COMPILE=aarch64-linux-gnu- > make C=2 drivers/pci/controller/dwc/pcie-hisi.o ARCH=arm64 > CROSS_COMPILE=aarch64-linux-gnu- >

[tip:x86/urgent] x86/build/lto: Fix truncated .bss with -fdata-sections

2019-04-16 Thread tip-bot for Sami Tolvanen
Commit-ID: 6a03469a1edc94da52b65478f1e00837add869a3 Gitweb: https://git.kernel.org/tip/6a03469a1edc94da52b65478f1e00837add869a3 Author: Sami Tolvanen AuthorDate: Mon, 15 Apr 2019 09:49:56 -0700 Committer: Ingo Molnar CommitDate: Tue, 16 Apr 2019 08:20:55 +0200 x86/build/lto: Fix

Re: [PATCH 3/3] iio: imu: st_lsm6dsx: Add i3c basic support

2019-04-16 Thread Boris Brezillon
On Mon, 15 Apr 2019 21:19:41 +0200 Vitor Soares wrote: > For today the st_lsm6dsx driver support lsm6dso sensor only in > spi and i2c mode. > > The lsm6dso is also i3c capable so lets give i3c support to it. > > Signed-off-by: Vitor Soares > --- > drivers/iio/imu/st_lsm6dsx/Kconfig

Re: [PATCH v2 11/19] PM / devfreq: tegra: De-initialize properly on driver's probe error

2019-04-16 Thread Chanwoo Choi
Hi Dmitry, I already replied against patch6 about the exception handling of tegra_devfreq_probe(). This patchset split out the patch related to error handling for probe(). I think that you can squash the patches regarding of exception handling for probe() to one patch instead of split out the

[PATCH V1 3/3] regulator: slg51000: add slg51000 regulator driver

2019-04-16 Thread Eric Jeong
From: Eric Jeong Adding regulator driver for the device Dialog SLG51000. The SLG51000 device contains seven compact and customizable low dropout regulators and is designed for high performance camera modules and other small multi-rail applications. Signed-off-by: Eric Jeong --- This patch

[PATCH V1 0/3] slg51000: regulator driver submission

2019-04-16 Thread Eric Jeong
From: Eric Jeong This patch adds support for the Dialog SLG51000 regulator device. In this patch set the following is provided: [PATCH V1 1/3] MAINTAINERS file update for SLG51000 [PATCH V1 2/3] SLG51000 DT binding [PATCH V1 3/3] SLG51000 regulator driver This patch applies against linux-next

[PATCH V1 2/3] Documentation: devicetree: regulator: add binding for slg51000

2019-04-16 Thread Eric Jeong
From: Eric Jeong Add device tree binding information for slg51000 regulator driver. Signed-off-by: Eric Jeong --- This patch applies against linux-next and next-20190415 .../devicetree/bindings/regulator/slg51000.txt | 88 1 file changed, 88 insertions(+)

[PATCH V1 1/3] MAINTAINERS: slg51000 updates to the Dialog Semiconductor search terms

2019-04-16 Thread Eric Jeong
From: Eric Jeong This patch adds the slg51000 bindings doc and driver to the Dialog Semiconductor support list. Signed-off-by: Eric Jeong --- MAINTAINERS |2 ++ 1 file changed, 2 insertions(+) diff --git a/MAINTAINERS b/MAINTAINERS index 002d564..9783eba 100644 --- a/MAINTAINERS +++

Re: [PATCH 2/3] i3c: Add i3c_get_device_id helper

2019-04-16 Thread Boris Brezillon
On Mon, 15 Apr 2019 21:19:40 +0200 Vitor Soares wrote: > This helper return the i3c_device_id structure in order the client > have access to the driver data. > > Signed-off-by: Vitor Soares > --- > drivers/i3c/device.c | 8 > include/linux/i3c/device.h | 1 + > 2 files changed,

Re: [PATCH 1/3] remap: Add I3C bus support

2019-04-16 Thread Boris Brezillon
Typo in the subject: s/remap/regmap/ On Mon, 15 Apr 2019 21:19:39 +0200 Vitor Soares wrote: > Add basic support for I3C bus. > This is a simple implementation that only give support > for Read and Write commands. > > Signed-off-by: Vitor Soares > --- > drivers/base/regmap/Kconfig | 6

Re: [PATCH 3/3] i3c: dw: Add limited bus mode support

2019-04-16 Thread Boris Brezillon
+Przemek On Mon, 15 Apr 2019 20:46:43 +0200 Vitor Soares wrote: > This patch add limited bus mode support for DesignWare i3c master > > Signed-off-by: Vitor Soares > Cc: Boris Brezillon > Cc: > --- > drivers/i3c/master/dw-i3c-master.c | 1 + > 1 file changed, 1 insertion(+) > > diff --git

Re: [PATCH 4/4] ARM: ep93xx: move private headers out of mach/*

2019-04-16 Thread Lukasz Majewski
On Mon, 15 Apr 2019 21:31:50 +0200 Arnd Bergmann wrote: > gpio-ep93xx.h, hardware.h, and platform.h are only used in > arch/arm/mach-ep93xx, so we can move them one there and no > longer expose them to device drivers. > > Signed-off-by: Arnd Bergmann > --- > arch/arm/mach-ep93xx/adssphere.c

Re: [PATCH 2/3] i3c: add mixed limited bus mode

2019-04-16 Thread Boris Brezillon
Hi Vitor, On Mon, 15 Apr 2019 20:46:42 +0200 Vitor Soares wrote: > The i3c bus spec define a bus configuration where the i2c devices ^defines I2C devices... > doesn't have the 50ns filter yet they allow the SDR max speed. ^don't^ a 50ns

<    5   6   7   8   9   10