Re: [PATCH] mm: Simplify for_each_populated_zone()

2013-04-10 Thread Srivatsa S. Bhat
On 04/11/2013 02:11 AM, David Rientjes wrote: > On Thu, 11 Apr 2013, Srivatsa S. Bhat wrote: > >> diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h >> index ede2749..2489042 100644 >> --- a/include/linux/mmzone.h >> +++ b/include/linux/mmzone.h >> @@ -948,9 +948,7 @@ extern struct zone

Re: [PATCH] mm: Simplify for_each_populated_zone()

2013-04-10 Thread David Rientjes
On Thu, 11 Apr 2013, Srivatsa S. Bhat wrote: > diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h > index ede2749..2489042 100644 > --- a/include/linux/mmzone.h > +++ b/include/linux/mmzone.h > @@ -948,9 +948,7 @@ extern struct zone *next_zone(struct zone *zone); > for (zone =

[PATCH] mm: Simplify for_each_populated_zone()

2013-04-10 Thread Srivatsa S. Bhat
Simplify the if/else block to make it more readable. Cc: KOSAKI Motohiro Cc: KAMEZAWA Hiroyuki Cc: Johannes Weiner Cc: Mel Gorman Cc: Andrew Morton Signed-off-by: Srivatsa S. Bhat --- include/linux/mmzone.h |4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git

Re: [PATCH] mm: Simplify for_each_populated_zone()

2013-04-10 Thread David Rientjes
On Thu, 11 Apr 2013, Srivatsa S. Bhat wrote: diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h index ede2749..2489042 100644 --- a/include/linux/mmzone.h +++ b/include/linux/mmzone.h @@ -948,9 +948,7 @@ extern struct zone *next_zone(struct zone *zone); for (zone =

Re: [PATCH] mm: Simplify for_each_populated_zone()

2013-04-10 Thread Srivatsa S. Bhat
On 04/11/2013 02:11 AM, David Rientjes wrote: On Thu, 11 Apr 2013, Srivatsa S. Bhat wrote: diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h index ede2749..2489042 100644 --- a/include/linux/mmzone.h +++ b/include/linux/mmzone.h @@ -948,9 +948,7 @@ extern struct zone

Re: [PATCH] mm: Simplify for_each_populated_zone()

2012-10-19 Thread Srivatsa S. Bhat
On 10/19/2012 07:24 PM, Johannes Weiner wrote: > On Fri, Oct 19, 2012 at 04:25:47PM +0530, Srivatsa S. Bhat wrote: >> Move the check for populated_zone() to the control statement of the >> 'for' loop and get rid of the odd looking if/else block. >> >> Signed-off-by: Srivatsa S. Bhat >> --- >> >>

Re: [PATCH] mm: Simplify for_each_populated_zone()

2012-10-19 Thread Johannes Weiner
On Fri, Oct 19, 2012 at 04:25:47PM +0530, Srivatsa S. Bhat wrote: > Move the check for populated_zone() to the control statement of the > 'for' loop and get rid of the odd looking if/else block. > > Signed-off-by: Srivatsa S. Bhat > --- > > include/linux/mmzone.h |7 ++- > 1 file

[PATCH] mm: Simplify for_each_populated_zone()

2012-10-19 Thread Srivatsa S. Bhat
Move the check for populated_zone() to the control statement of the 'for' loop and get rid of the odd looking if/else block. Signed-off-by: Srivatsa S. Bhat --- include/linux/mmzone.h |7 ++- 1 file changed, 2 insertions(+), 5 deletions(-) diff --git a/include/linux/mmzone.h

[PATCH] mm: Simplify for_each_populated_zone()

2012-10-19 Thread Srivatsa S. Bhat
Move the check for populated_zone() to the control statement of the 'for' loop and get rid of the odd looking if/else block. Signed-off-by: Srivatsa S. Bhat srivatsa.b...@linux.vnet.ibm.com --- include/linux/mmzone.h |7 ++- 1 file changed, 2 insertions(+), 5 deletions(-) diff --git

Re: [PATCH] mm: Simplify for_each_populated_zone()

2012-10-19 Thread Johannes Weiner
On Fri, Oct 19, 2012 at 04:25:47PM +0530, Srivatsa S. Bhat wrote: Move the check for populated_zone() to the control statement of the 'for' loop and get rid of the odd looking if/else block. Signed-off-by: Srivatsa S. Bhat srivatsa.b...@linux.vnet.ibm.com --- include/linux/mmzone.h |

Re: [PATCH] mm: Simplify for_each_populated_zone()

2012-10-19 Thread Srivatsa S. Bhat
On 10/19/2012 07:24 PM, Johannes Weiner wrote: On Fri, Oct 19, 2012 at 04:25:47PM +0530, Srivatsa S. Bhat wrote: Move the check for populated_zone() to the control statement of the 'for' loop and get rid of the odd looking if/else block. Signed-off-by: Srivatsa S. Bhat