[PATCH v3 03/33] staging: rtl8192e: Mark unaligned memcpy()

2015-05-09 Thread Mateusz Kulikowski
Comment unaligned memcpy() that trigger PREFER_ETHER_ADDR_COPY checkpatch.pl warning. It will prevent accidential "Fix" to ether_addr_copy(). Signed-off-by: Mateusz Kulikowski --- drivers/staging/rtl8192e/rtllib_rx.c | 20 1 file changed, 12 insertions(+), 8 deletions(-)

[PATCH v3 05/33] staging: rtl8192e: Replace memcmp() with ether_addr_equal_unaligned()

2015-05-09 Thread Mateusz Kulikowski
Use dedicated macro to compare ethernet addresses in probe_rq_parse(). Signed-off-by: Mateusz Kulikowski --- drivers/staging/rtl8192e/rtllib_softmac.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/staging/rtl8192e/rtllib_softmac.c

[PATCH v3 10/33] staging: rtl8192e: Simplify rtllib_proces_probe_response()

2015-05-09 Thread Mateusz Kulikowski
- Extract frame_ctl once and use it as variable. - Drop endian conversion in is_beacon() function (used in simplified function only) - Simplify debug messages - Invert STYPE checks in debug messages - it is valid as only BEACON and PROBE_RESP are allowed Signed-off-by: Mateusz Kulikowski ---

[PATCH v3 09/33] staging: rtl8192e: Remove RTLLIB_DEBUG_WX()

2015-05-09 Thread Mateusz Kulikowski
Use netdev_dbg() instead of RTLLIB_DEBUG_WX(). Rewrite some messages to be more readable. Signed-off-by: Mateusz Kulikowski --- drivers/staging/rtl8192e/rtllib.h| 1 - drivers/staging/rtl8192e/rtllib_wx.c | 33 - 2 files changed, 16 insertions(+), 18

[PATCH v3 08/33] staging: rtl8192e: Remove RTLLIB_ERROR() and RTLLIB_WARNING()

2015-05-09 Thread Mateusz Kulikowski
Use pr_* where needed (rtllib init code). Signed-off-by: Mateusz Kulikowski --- drivers/staging/rtl8192e/rtllib.h| 2 -- drivers/staging/rtl8192e/rtllib_module.c | 8 +++- 2 files changed, 3 insertions(+), 7 deletions(-) diff --git a/drivers/staging/rtl8192e/rtllib.h

[PATCH v3 06/33] staging: rtl8192e: Remove rtllib_crypt.[ch]

2015-05-09 Thread Mateusz Kulikowski
It is neither compiled nor used in rtl8192e. Signed-off-by: Mateusz Kulikowski --- drivers/staging/rtl8192e/rtllib_crypt.c | 254 drivers/staging/rtl8192e/rtllib_crypt.h | 34 - 2 files changed, 288 deletions(-) delete mode 100644

[PATCH v3 02/33] staging: rtl8192e: Fix PREFER_ETHER_ADDR_COPY warnings

2015-05-09 Thread Mateusz Kulikowski
Replace memcpy() with ether_addr_copy() where possible to make checkpatch.pl happy. Signed-off-by: Mateusz Kulikowski --- drivers/staging/rtl8192e/rtl8192e/r8192E_dev.c | 2 +- drivers/staging/rtl8192e/rtl819x_BAProc.c | 13 +++--- drivers/staging/rtl8192e/rtllib_crypt_tkip.c | 19

Re: [PATCH] net: fec: add support of ethtool get_regs

2015-05-09 Thread David Miller
From: Russell King - ARM Linux Date: Sat, 9 May 2015 22:17:46 +0100 > On Sat, May 09, 2015 at 10:52:08PM +0200, Philippe Reynes wrote: >> +static void fec_enet_get_regs(struct net_device *ndev, >> + struct ethtool_regs *regs, void *regbuf) >> +{ >> +struct

Re: [PATCH v2] ARM: net fix emit_udiv() for BPF_ALU | BPF_DIV | BPF_K intruction.

2015-05-09 Thread David Miller
From: Nicolas Schichan Date: Wed, 6 May 2015 18:31:56 +0200 > In that case, emit_udiv() will be called with rn == ARM_R0 (r_scratch) > and loading rm first into ARM_R0 will result in jit_udiv() function > being called the same dividend and divisor. Fix that by loading rn > first into ARM_R1 and

Re: [net-next PATCH v3 1/4] devicetree: Add compatible string for Zynq Ultrascale+ MPSoC

2015-05-09 Thread David Miller
From: Harini Katakam Date: Wed, 6 May 2015 22:27:15 +0530 > Add "cdns,zynqmp-gem" to be used for Zynq Ultrascale+ MPSoC. > > Signed-off-by: Harini Katakam > Reviewed-by: Punnaiah Choudary Kalluri Applied. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body

Re: [net-next PATCH v3 2/4] net: macb: Add compatible string for Zynq Ultrascale+ MPSoC

2015-05-09 Thread David Miller
From: Harini Katakam Date: Wed, 6 May 2015 22:27:16 +0530 > Add compatible string and config structure for Zynq Ultrascale+ MPSoC > > Signed-off-by: Harini Katakam > Reviewed-by: Punnaiah Choudary Kalluri Applied. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

Re: [net-next PATCH v3 3/4] net: macb: Add support for jumbo frames

2015-05-09 Thread David Miller
From: Harini Katakam Date: Wed, 6 May 2015 22:27:17 +0530 > Enable jumbo frame support for Zynq Ultrascale+ MPSoC. > Update the NWCFG register and descriptor length masks accordingly. > Jumbo max length register should be set according to support in SoC; it is > set to 10240 for Zynq Ultrascale+

Re: [net-next PATCH v3 4/4] net: macb: Add change_mtu callback with jumbo support

2015-05-09 Thread David Miller
From: Harini Katakam Date: Wed, 6 May 2015 22:27:18 +0530 > Add macb_change_mtu callback; if jumbo frame support is present allow > mtu size changes upto (jumbo max length allowed - headers). > > Signed-off-by: Harini Katakam > Reviewed-by: Punnaiah Choudary Kalluri Applied. -- To

Re: [PATCH v2 00/10] evacuate struct page from the block layer, introduce __pfn_t

2015-05-09 Thread Dave Chinner
On Fri, May 08, 2015 at 11:02:28PM -0400, Rik van Riel wrote: > On 05/08/2015 09:14 PM, Linus Torvalds wrote: > > On Fri, May 8, 2015 at 9:59 AM, Rik van Riel wrote: > >> > >> However, for persistent memory, all of the files will be "in memory". > > > > Yes. However, I doubt you will find a very

[PATCH v2] net: fec: add support of ethtool get_regs

2015-05-09 Thread Philippe Reynes
This enables the ethtool's "-d" and "--register-dump" options for fec devices. Signed-off-by: Philippe Reynes --- drivers/net/ethernet/freescale/fec_main.c | 28 1 files changed, 28 insertions(+), 0 deletions(-) Changelog: v2: (thanks Russell King and David Miler

Re: [PATCH] net: fec: add support of ethtool get_regs

2015-05-09 Thread Fabio Estevam
Philippe, On Sat, May 9, 2015 at 6:17 PM, Russell King - ARM Linux wrote: > Using memcpy_fromio() to copy device registers is not a good idea - > it can use a variable access size which can cause bus faults. An example on how memcpy_fromio() can be avoided in get_regs:

Re: [alsa-devel] [PATCH] ASoC: codecs-ac97: Remove rate constraints

2015-05-09 Thread Maciej S. Szmigiero
Hi Fabio, W dniu 09.05.2015 01:47, Fabio Estevam pisze: > Hi Maciej, > (..) > > Please keep me on Cc when you submit further ac97 patches / udoo dts, > so that I can help testing them. > > Thanks, > > Fabio Estevam Thank you for your kind words, naturally I will keep you CCed. Best regards,

Re: [PATCH v2 5/7] Xen / ACPI / processor: Remove unneeded NULL check in xen_acpi_processor_enable()

2015-05-09 Thread Konrad Rzeszutek Wilk
On Tue, May 05, 2015 at 11:29:05AM +0100, Stefano Stabellini wrote: > CC'ing Konrad and David. > > On Tue, 5 May 2015, Hanjun Guo wrote: > > Before xen_acpi_processor_enable() is called, struct acpi_processor *pr is > > allocated in xen_acpi_processor_add() and checked if it's NULL, so no need >

[PATCH] ASoC: codecs-ac97: Remove rate constraints

2015-05-09 Thread Maciej S. Szmigiero
Remove rate constraints from generic ASoC AC'97 CODEC. Supported rates should be detected and constrained anyway by AC'97 generic code - was tested with VT1613 CODEC and iMX6 SSI controller. This way this driver can be used for platforms which don't need specialized AC'97 CODEC drivers while

[PATCH] ASoC: codecs-ac97: make selectable in config

2015-05-09 Thread Maciej S. Szmigiero
Make generic ASoC AC'97 CODEC selectable in config. This way this driver can be used for platforms which don't need specialized AC'97 CODEC drivers but which are not directly selectable in config themselves (for example DT based ones). Signed-off-by: Maciej Szmigiero ---

Re: [PATCH v2] staging: rtl8192e: Change cpu_to_le16 to le16_to_cpu

2015-05-09 Thread Dan Carpenter
On Sat, May 09, 2015 at 10:27:16PM +0200, Arno Tiemersma wrote: > Since the function auth_parse returns a u16, and > struct rtllib_authentication.status is defined as an __le16, it seems > that > > return cpu_to_le16(a->status); > > should be > > return le16_to_cpu(a->status); > >

Re: [PATCH] net: fec: add support of ethtool get_regs

2015-05-09 Thread Philippe Reynes
Hi Fabio, On 09/05/15 23:59, Fabio Estevam wrote: Philippe, On Sat, May 9, 2015 at 6:17 PM, Russell King - ARM Linux wrote: Using memcpy_fromio() to copy device registers is not a good idea - it can use a variable access size which can cause bus faults. An example on how memcpy_fromio()

Re: [PATCH v3 01/33] staging: rtl8192e: Declare ethernet addresses as __aligned(2)

2015-05-09 Thread Joe Perches
On Sat, 2015-05-09 at 23:18 +0200, Mateusz Kulikowski wrote: > Add __aligned(2) into ethernet addresses allocated on stack or in non-packed > structures. Use ETH_ALEN as array length in places where it was hardcoded to > 6. [] > diff --git a/drivers/staging/rtl8192e/rtl8192e/r8192E_dev.c >

Re: [PATCH v3 20/33] staging: rtl8192e: Fix PREFER_PR_LEVEL warnings

2015-05-09 Thread Joe Perches
On Sat, 2015-05-09 at 23:19 +0200, Mateusz Kulikowski wrote: > Fix most of remaining PREFER_PR_LEVEL warnings in rtllib. > Replace printk() with netdev_* if possible, pr_* in other cases. > All pr_* use __func__ to easily trace message back to rtllib It's more common to use %s: and not %s(): but

[PATCH] PM / tick: Add tracepoints for suspend-to-idle diagnostics

2015-05-09 Thread Rafael J. Wysocki
From: Rafael J. Wysocki Add suspend/resume tracepoints to tick_freeze() and tick_unfreeze() to catch when timekeeping is suspended and resumed during suspend-to-idle so as to be able to check whether or not we enter the "frozen" state and to measure the time spent in it. Signed-off-by: Rafael

[PATCH 3/3] cpuidle: Select a different state on tick_broadcast_enter() failures

2015-05-09 Thread Rafael J. Wysocki
From: Rafael J. Wysocki If tick_broadcast_enter() fails in cpuidle_enter_state(), try to find another idle state to enter instead of invoking default_idle_call() immediately and returning -EBUSY which should increase the chances of saving some energy in those cases. Signed-off-by: Rafael J.

[PATCH 0/3] cpuidle: updates related to tick_broadcast_enter() failures

2015-05-09 Thread Rafael J. Wysocki
On Saturday, May 09, 2015 10:33:05 PM Rafael J. Wysocki wrote: > On Saturday, May 09, 2015 10:11:41 PM Rafael J. Wysocki wrote: > > On Saturday, May 09, 2015 11:19:16 AM Preeti U Murthy wrote: > > > Hi Rafael, > > > > > > On 05/08/2015 07:48 PM, Rafael J. Wysocki wrote: > > > > [cut] > > > > >

[PATCH 1/3] sched / idle: Call idle_set_state() from cpuidle_enter_state()

2015-05-09 Thread Rafael J. Wysocki
From: Rafael J. Wysocki Introduce a wrapper function around idle_set_state() called sched_idle_set_state() that will pass this_rq() to it as the first argument and make cpuidle_enter_state() call the new function before and after entering the target state. At the same time, remove direct

[PATCH 2/3] sched / idle: Call default_idle_call() from cpuidle_enter_state()

2015-05-09 Thread Rafael J. Wysocki
From: Rafael J. Wysocki The check of the cpuidle_enter() return value against -EBUSY made in call_cpuidle() will not be necessary any more if cpuidle_enter_state() calls default_idle_call() directly when it is about to return -EBUSY, so make that happen and eliminate the check. Signed-off-by:

[Resend][PATCH] PM / tick: Add tracepoints for suspend-to-idle diagnostics

2015-05-09 Thread Rafael J. Wysocki
From: Rafael J. Wysocki Add suspend/resume tracepoints to tick_freeze() and tick_unfreeze() to catch when timekeeping is suspended and resumed during suspend-to-idle so as to be able to check whether or not we enter the "frozen" state and to measure the time spent in it. Signed-off-by: Rafael

Re: [PATCH] x86: Fix mkcapflags.sh bash-ism again

2015-05-09 Thread sylvain . bertrand
On Mon, Apr 27, 2015 at 03:21:02PM +, sylvain.bertr...@gmail.com wrote: > While compiling linux, dash shell reports a bash-ism: > > /src/linux-4.0/arch/x86/kernel/cpu/mkcapflags.sh: 9: > /src/linux-4.0/arch/x86/kernel/cpu/mkcapflags.sh: Syntax error: "(" unexpected > > See: >

Re: [Linux-nvdimm] [PATCH v2 08/20] libnd, nd_acpi: regions (block-data-window, persistent memory, volatile memory)

2015-05-09 Thread Dan Williams
On Mon, May 4, 2015 at 1:26 PM, Toshi Kani wrote: > On Tue, 2015-04-28 at 14:24 -0400, Dan Williams wrote: > : >> + >> +static int nd_acpi_register_region(struct acpi_nfit_desc *acpi_desc, >> + struct nfit_spa *nfit_spa) >> +{ >> + static struct nd_mapping

[PATCH] x86: rename eisa_set_level_irq to elcr_set_level_irq

2015-05-09 Thread Paul Gortmaker
This routine has been around for over a decade, but with EISA being dead and abandoned for about twice that long, the name can be kind of confusing. The function is going at the PIC Edge/Level Configuration Registers (ELCR), so rename it as such and mentally decouple it from the long since dead

RE:hello

2015-05-09 Thread beaktfjls
hello buone notizie per voi Portatile, macchina fotografica, cellulare, moto , la spedizione è gratuita samsung s6, 320euro w e b: swewaoo . com N�r��yb�X��ǧv�^�)޺{.n�+{zX����ܨ}���Ơz�:+v���zZ+��+zf���h���~i���z��w���?�&�)ߢf��^jǫy�m��@A�a��� 0��h���i

Re: [PATCH] net: fec: add support of ethtool get_regs

2015-05-09 Thread David Miller
From: Philippe Reynes Date: Sun, 10 May 2015 00:16:21 +0200 > Hi Fabio, > > On 09/05/15 23:59, Fabio Estevam wrote: >> Philippe, >> >> On Sat, May 9, 2015 at 6:17 PM, Russell King - ARM Linux >> wrote: >> >>> Using memcpy_fromio() to copy device registers is not a good idea - >>> it can use a

Re: [PATCH] x86: rename eisa_set_level_irq to elcr_set_level_irq

2015-05-09 Thread Maciej W. Rozycki
On Sat, 9 May 2015, Paul Gortmaker wrote: > This routine has been around for over a decade, but with EISA > being dead and abandoned for about twice that long, the name can > be kind of confusing. The function is going at the PIC Edge/Level > Configuration Registers (ELCR), so rename it as such

Re: [PATCH] net: deinline netif_tx_stop_queue() and netif_tx_stop_all_queues()

2015-05-09 Thread David Miller
From: Denys Vlasenko Date: Thu, 7 May 2015 13:41:10 +0200 > These functions compile to ~60 bytes of machine code each. As others have suggested, just kill the WARN_ON(). -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to

Re: [PATCH v2] ARM: net: add JIT support for loads from struct seccomp_data.

2015-05-09 Thread David Miller
From: Nicolas Schichan Date: Thu, 7 May 2015 15:00:13 +0200 > Signed-off-by: Nicolas Schichan > --- > > This patch was first sent as part of a serie modifying the core > seccomp code to allow the use of the classic BPF JIT. As the core > changes have been submitted to netdev by Daniel

Re: [PATCH 3/3] perf probe: Add --range option to show variable location range

2015-05-09 Thread Masami Hiramatsu
On 2015/05/09 16:41, He Kuang wrote: > > On 2015/5/8 22:08, Masami Hiramatsu wrote: >> On 2015/05/08 21:23, He Kuang wrote: >>> It is not easy for users to get the accurate byte offset or the line >>> number where a local variable can be probed. With '--range' option, >>> local variables in scope

Re: Re: [PATCH perf/core v2 0/4] perf-probe code cleanup and support wildcard for probe points

2015-05-09 Thread Masami Hiramatsu
On 2015/05/09 4:38, Arnaldo Carvalho de Melo wrote: > Em Fri, May 08, 2015 at 10:03:26AM +0900, Masami Hiramatsu escreveu: >> Hi, >> >> Here is a patches for wild card support. I've added two patches to >> reduce API parameters by introducing probe_conf. This simplifies >> --no-inlines option.

Re: [PATCH v2 2/3] perf probe: Add --range option to show variable location range

2015-05-09 Thread Masami Hiramatsu
On 2015/05/09 18:55, He Kuang wrote: > It is not easy for users to get the accurate byte offset or the line > number where a local variable can be probed. With '--range' option, > local variables in scope of the probe point are showed with byte offset > range, and can be added according to this

Re: [PATCH v2 3/3] perf probe: Show better error message when failed to find variable

2015-05-09 Thread Masami Hiramatsu
On 2015/05/09 18:55, He Kuang wrote: > Indicate to check variable location range in error message when we got > failed to find the variable. > > Before this patch: > > $ perf probe --add 'generic_perform_write+118 bytes' > Failed to find the location of bytes at this address. >Perhaps,

Re: [PATCH v2 1/3] perf probe: Remove length limitation for showing available variables

2015-05-09 Thread Masami Hiramatsu
On 2015/05/09 18:55, He Kuang wrote: > Use struct strbuf instead of bare char[] to remove the length limitation > of variables in variable_list, so they will not disappear due to > overlength, and make preparation for adding more description for > variables. > Looks good to me! Acked-by: Masami

Re: [RFC][PATCHSET] non-recursive pathname resolution

2015-05-09 Thread Al Viro
On Wed, May 06, 2015 at 12:59:47AM +0100, Al Viro wrote: > It is passing xfstests and LTP, plus some basic "create a twisted forest > of symlinks and walk it" tests, but yes, it obviously needs more beating. > I'll push everything up to #76 into -next tonight (with the changes you > asked for).

<    1   2   3   4   5