RE: [PATCH v17 3/3] vfio/nvgrace-gpu: Add vfio pci variant module for grace hopper

2024-02-07 Thread Tian, Kevin
> From: Ankit Agrawal > Sent: Thursday, February 8, 2024 3:13 PM > >> > +    * Determine how many bytes to be actually read from the > >> > device memory. > >> > +    * Read request beyond the actual device memory size is > >> > filled with ~0, > >> > +    * while those beyond the actual reported

RE: [PATCH v17 3/3] vfio/nvgrace-gpu: Add vfio pci variant module for grace hopper

2024-02-07 Thread Tian, Kevin
> From: ank...@nvidia.com > Sent: Tuesday, February 6, 2024 7:01 AM > > Note that the usemem memory is added by the VM Nvidia device driver [5] > to the VM kernel as memblocks. Hence make the usable memory size > memblock > aligned. Is memblock size defined in spec or purely a guest

Re: [PATCH v17 3/3] vfio/nvgrace-gpu: Add vfio pci variant module for grace hopper

2024-02-07 Thread Ankit Agrawal
>> > +/* Memory size expected as non cached and reserved by the VM driver >> > */ +#define RESMEM_SIZE 0x4000 >> > +#define MEMBLK_SIZE 0x2000 >> > + >> >> Maybe use SZ_* definitions in linux/size.h > > Good suggestion. Ack. >> >> Better move this part to the place between

Re: [PATCH v17 3/3] vfio/nvgrace-gpu: Add vfio pci variant module for grace hopper

2024-02-07 Thread Ankit Agrawal
>> diff --git a/MAINTAINERS b/MAINTAINERS >> index 8999497011a2..529ec8966f58 100644 >> --- a/MAINTAINERS >> +++ b/MAINTAINERS >> @@ -23103,6 +23103,12 @@ L:   k...@vger.kernel.org >>  S:   Maintained >>  F:   drivers/vfio/platform/ >> >> +VFIO NVIDIA GRACE GPU DRIVER >> +M:   Ankit Agrawal >>

Re: [PATCH v17 2/3] vfio/pci: rename and export range_intesect_range

2024-02-07 Thread Ankit Agrawal
Thanks Kevin. >> range_intesect_range determines an overlap between two ranges. If an > > s/intesect/intersect/ Will fix the typo. >> + * vfio_pci_core_range_intersect_range() - Determine overlap between a >> buffer >> + *  and register offset ranges. >> + *

RE: [PATCH v17 1/3] vfio/pci: rename and export do_io_rw()

2024-02-07 Thread Tian, Kevin
> From: ank...@nvidia.com > Sent: Tuesday, February 6, 2024 7:01 AM > > From: Ankit Agrawal > > do_io_rw() is used to read/write to the device MMIO. The grace hopper > VFIO PCI variant driver require this functionality to read/write to > its memory. > > Rename this as vfio_pci_core functions

RE: [PATCH v17 2/3] vfio/pci: rename and export range_intesect_range

2024-02-07 Thread Tian, Kevin
> From: ank...@nvidia.com > Sent: Tuesday, February 6, 2024 7:01 AM > > From: Ankit Agrawal > > range_intesect_range determines an overlap between two ranges. If an s/intesect/intersect/ > overlap, the helper function returns the overlapping offset and size. > > The VFIO PCI variant driver

Re: [PATCH v17 3/3] vfio/nvgrace-gpu: Add vfio pci variant module for grace hopper

2024-02-07 Thread Alex Williamson
On Tue, 6 Feb 2024 04:31:23 +0530 wrote: > From: Ankit Agrawal > > NVIDIA's upcoming Grace Hopper Superchip provides a PCI-like device > for the on-chip GPU that is the logical OS representation of the > internal proprietary chip-to-chip cache coherent interconnect. > > The device is peculiar

Re: [PATCH v17 3/3] vfio/nvgrace-gpu: Add vfio pci variant module for grace hopper

2024-02-07 Thread Alex Williamson
On Thu, 8 Feb 2024 00:32:10 +0200 Zhi Wang wrote: > On Tue, 6 Feb 2024 04:31:23 +0530 > wrote: > > > From: Ankit Agrawal > > > > NVIDIA's upcoming Grace Hopper Superchip provides a PCI-like device > > for the on-chip GPU that is the logical OS representation of the > > internal proprietary

Re: [PATCH v5] remoteproc: Make rproc_get_by_phandle() work for clusters

2024-02-07 Thread Tanmay Shah
I am sorry, I missed the fact that this patch was picked up and available on for-next branch. Won't be sending new one now. Thanks, Tanmay On 2/7/24 4:18 PM, Tanmay Shah wrote: > Rejected-by: Tanmay Shah > > I will send new v5 with change long included. > > On 1/30/24 9:48 AM, Tanmay Shah

Re: [PATCH v17 3/3] vfio/nvgrace-gpu: Add vfio pci variant module for grace hopper

2024-02-07 Thread Zhi Wang
On Tue, 6 Feb 2024 04:31:23 +0530 wrote: > From: Ankit Agrawal > > NVIDIA's upcoming Grace Hopper Superchip provides a PCI-like device > for the on-chip GPU that is the logical OS representation of the > internal proprietary chip-to-chip cache coherent interconnect. > > The device is peculiar

Re: [PATCH v5] remoteproc: Make rproc_get_by_phandle() work for clusters

2024-02-07 Thread Tanmay Shah
Rejected-by: Tanmay Shah I will send new v5 with change long included. On 1/30/24 9:48 AM, Tanmay Shah wrote: > From: Mathieu Poirier > > Multi-cluster remoteproc designs typically have the following DT > declaration: > > remoteproc-cluster { > compatible =

Re: [PATCH] remoteproc: qcom: Add NOTIFY_FATAL event type to SSR subdevice

2024-02-07 Thread Vignesh Viswanathan
On 11/25/2023 12:24 AM, Vignesh Viswanathan wrote: > > > On 9/4/2023 10:23 PM, Vignesh Viswanathan wrote: >> >> >> On 7/16/2023 1:50 AM, Bjorn Andersson wrote: >>> On Wed, May 03, 2023 at 11:51:46AM +0530, Vignesh Viswanathan wrote: Currently the SSR subdevice notifies the client driver

Re: [PATCH] tracing: use ring_buffer_record_is_set_on() in tracer_tracing_is_on()

2024-02-07 Thread Steven Rostedt
On Wed, 07 Feb 2024 14:33:21 +0100 Sven Schnelle wrote: > My assumption without reading the code is that something like this > happens: > > CPU0 CPU1 > [ringbuffer enabled] > ring_buffer_write() >

Re: [PATCH v5 7/8] selftests/ftrace: add kprobe test cases for VFS type "%pd" and "%pD"

2024-02-07 Thread Google
On Thu, 25 Jan 2024 15:39:22 +0800 Ye Bin wrote: > This patch adds test cases for new print format type "%pd/%pD".The test cases > test the following items: > 1. Test README if add "%pd/%pD" type; > 2. Test "%pd" type for dput(); > 3. Test "%pD" type for vfs_read(); > > This test case require

Re: [PATCH v5 5/8] tracing: add new type "%pd/%pD" in readme_msg[]

2024-02-07 Thread Google
On Thu, 25 Jan 2024 15:39:20 +0800 Ye Bin wrote: > Signed-off-by: Ye Bin > --- > kernel/trace/trace.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/kernel/trace/trace.c b/kernel/trace/trace.c > index 2a7c6fd934e9..13197d3b86bd 100644 > --- a/kernel/trace/trace.c >

Re: [PATCH v5 4/8] tracing/probes: support '%pd/%pD' type for fprobe

2024-02-07 Thread Google
On Thu, 25 Jan 2024 15:39:19 +0800 Ye Bin wrote: > Support print type '%pd/%pD' for print dentry's or file's name. > nit: Looks good to me. but the patch ordering seems a bit strange. This should be next to [2/8]. Acked-by: Masami Hiramatsu (Google) Thank you, > Signed-off-by: Ye Bin >

Re: [PATCH v5 1/8] tracing/probes: add traceprobe_expand_dentry_args() helper

2024-02-07 Thread Google
Hi Ye, On Thu, 25 Jan 2024 15:39:16 +0800 Ye Bin wrote: > Add traceprobe_expand_dentry_args() to expand dentry args. this API is > prepare to support "%pd" print format for kprobe. > > Signed-off-by: Ye Bin > --- > kernel/trace/trace_probe.c | 50 ++ >

Re: [PATCH net-next v5] virtio_net: Support RX hash XDP hint

2024-02-07 Thread Paolo Abeni
On Wed, 2024-02-07 at 10:54 +0800, Liang Chen wrote: > On Tue, Feb 6, 2024 at 6:44 PM Paolo Abeni wrote: > > > > On Sat, 2024-02-03 at 10:56 +0800, Liang Chen wrote: > > > On Sat, Feb 3, 2024 at 12:20 AM Jesper Dangaard Brouer > > > wrote: > > > > On 02/02/2024 13.11, Liang Chen wrote: > >

Re: [PATCH v7 13/36] function_graph: Have the instances use their own ftrace_ops for filtering

2024-02-07 Thread Google
On Wed, 7 Feb 2024 00:09:54 +0900 "Masami Hiramatsu (Google)" wrote: > diff --git a/arch/loongarch/kernel/ftrace_dyn.c > b/arch/loongarch/kernel/ftrace_dyn.c > index 73858c9029cc..81d18b911cc1 100644 > --- a/arch/loongarch/kernel/ftrace_dyn.c > +++ b/arch/loongarch/kernel/ftrace_dyn.c > @@

Re: [PATCH] tracing: use ring_buffer_record_is_set_on() in tracer_tracing_is_on()

2024-02-07 Thread Sven Schnelle
Steven Rostedt writes: > On Wed, 7 Feb 2024 13:07:36 +0100 > Mete Durlu wrote: > >> wouldn't the following scenario explain the behavior we are seeing. >> When using event triggers, trace uses lockless ringbuffer control paths. >> If cmdline update and trace output reading is happening on

Re: [PATCH] tracing: use ring_buffer_record_is_set_on() in tracer_tracing_is_on()

2024-02-07 Thread Steven Rostedt
On Wed, 7 Feb 2024 13:07:36 +0100 Mete Durlu wrote: > wouldn't the following scenario explain the behavior we are seeing. > When using event triggers, trace uses lockless ringbuffer control paths. > If cmdline update and trace output reading is happening on different > cpus, the ordering can get

Re: [PATCH] tracing: use ring_buffer_record_is_set_on() in tracer_tracing_is_on()

2024-02-07 Thread Mete Durlu
On 2/7/24 12:09, Steven Rostedt wrote: On Wed, 07 Feb 2024 06:50:59 +0100 Sven Schnelle wrote: Hi Steven, Not sure whether that is enough, have to test. However, it's not really a fix, it would just require a bit more load and the test would fail again. The fundamental problem is that even

Re: [PATCH v3 0/5] PM: domains: Add helpers for multi PM domains to avoid open-coding

2024-02-07 Thread Ulf Hansson
On Tue, 30 Jan 2024 at 13:39, Ulf Hansson wrote: > > Rafael, my plan is queue up this series via my pmdomain tree. Please let me > know > if you see any issues with that, especially around patch1. > > Updates in v3: > - Added tested-by, reviewed-by and suggested-by tags. No other changes

Re: [PATCH] tracing: use ring_buffer_record_is_set_on() in tracer_tracing_is_on()

2024-02-07 Thread Steven Rostedt
On Wed, 07 Feb 2024 06:50:59 +0100 Sven Schnelle wrote: > Hi Steven, > Not sure whether that is enough, have to test. However, it's not really > a fix, it would just require a bit more load and the test would fail > again. The fundamental problem is that even after disabling tracing > there

Re: [PATCH 0/3] Fairphone 5 PMIC-GLINK support (USB-C, charger, fuel gauge)

2024-02-07 Thread Greg Kroah-Hartman
On Wed, Feb 07, 2024 at 12:20:00AM +0100, Luca Weiss wrote: > On Tue Jan 2, 2024 at 2:53 PM CET, Greg Kroah-Hartman wrote: > > On Tue, Jan 02, 2024 at 02:43:24PM +0100, Luca Weiss wrote: > > > On Tue Jan 2, 2024 at 2:36 PM CET, Greg Kroah-Hartman wrote: > > > > On Thu, Dec 21, 2023 at 02:45:26PM

Re: Re: [PATCH] vhost-vdpa: fail enabling virtqueue in certain conditions

2024-02-07 Thread Stefano Garzarella
On Wed, Feb 07, 2024 at 11:27:14AM +0800, Jason Wang wrote: On Tue, Feb 6, 2024 at 10:52 PM Stefano Garzarella wrote: If VHOST_BACKEND_F_ENABLE_AFTER_DRIVER_OK is not negotiated, we expect the driver to enable virtqueue before setting DRIVER_OK. If the driver tries anyway, better to fail