Re: [PATCH 0/3] syscalls: clean up stub naming convention

2018-04-09 Thread Linus Torvalds
On Sun, Apr 8, 2018 at 11:39 PM, Ingo Molnar wrote: > > I see - so it's _not_ the same function call signature, but a wrapper with a > sign-extended version, which is fair and useful. So on architectures where > this > matters there's type conversion and active code generated. Exactly. Some arch

Re: [PATCH 0/3] syscalls: clean up stub naming convention

2018-04-09 Thread Ingo Molnar
* Dominik Brodowski wrote: > > New suggested naming: > > > > 810f08d0 t kernel_waitid# common C function (see kernel/exit.c) > > > > __do_sys_waitid# inlined helper doing the actual work > > # (takes original parameters as declared) > > > >

Re: [PATCH 0/3] syscalls: clean up stub naming convention

2018-04-09 Thread Dominik Brodowski
On Mon, Apr 09, 2018 at 09:06:11AM +0200, Ingo Molnar wrote: > > * Ingo Molnar wrote: > > > > > * Dominik Brodowski wrote: > > > > > On Sun, Apr 08, 2018 at 10:35:50AM +0200, Ingo Molnar wrote: > > > > - _sys_waitid() # ridiculous number of underscores? > > > > - __sys_waitid()

Re: [PATCH 0/3] syscalls: clean up stub naming convention

2018-04-09 Thread Ingo Molnar
* Ingo Molnar wrote: > > * Dominik Brodowski wrote: > > > On Sun, Apr 08, 2018 at 10:35:50AM +0200, Ingo Molnar wrote: > > > - _sys_waitid() # ridiculous number of underscores? > > > - __sys_waitid() # too generic sounding? > > > > ... and we'd need to rename internal he

Re: [PATCH 0/3] syscalls: clean up stub naming convention

2018-04-08 Thread Dominik Brodowski
On Mon, Apr 09, 2018 at 08:45:11AM +0200, Ingo Molnar wrote: > > * Dominik Brodowski wrote: > > > On Sun, Apr 08, 2018 at 10:35:50AM +0200, Ingo Molnar wrote: > > > - _sys_waitid() # ridiculous number of underscores? > > > - __sys_waitid() # too generic sounding? > > > > ..

Re: [PATCH 0/3] syscalls: clean up stub naming convention

2018-04-08 Thread Dominik Brodowski
On Mon, Apr 09, 2018 at 08:49:45AM +0200, Ingo Molnar wrote: > > * Dominik Brodowski wrote: > > > +emit_stub() { > > +entry="$1" > > +if [ "${entry}" != "${entry#__ia32_sys_}" ]; then > > + # We need a stub named __ia32_sys which is common to 64-bit > > + # except for a different pt_

Re: [PATCH 0/3] syscalls: clean up stub naming convention

2018-04-08 Thread Ingo Molnar
* Dominik Brodowski wrote: > +emit_stub() { > +entry="$1" > +if [ "${entry}" != "${entry#__ia32_sys_}" ]; then > + # We need a stub named __ia32_sys which is common to 64-bit > + # except for a different pt_regs layout. > + stubname=${entry#__ia32_sys_} > + echo "#define

Re: [PATCH 0/3] syscalls: clean up stub naming convention

2018-04-08 Thread Ingo Molnar
* Dominik Brodowski wrote: > On Sun, Apr 08, 2018 at 10:35:50AM +0200, Ingo Molnar wrote: > > - _sys_waitid() # ridiculous number of underscores? > > - __sys_waitid() # too generic sounding? > > ... and we'd need to rename internal helpers in net/ > > > - __inline_sys_wa

Re: [PATCH 0/3] syscalls: clean up stub naming convention

2018-04-08 Thread Ingo Molnar
* Dominik Brodowski wrote: > > One more fundamental question: why do we have the __do_sys_waitid() and > > __inline_sys_waitid() distinction - aren't the function call signatures the > > same > > with no conversion done? > > > > I.e. couldn't we just do a single, static __do_sys_waitid(), whe

Re: [PATCH 0/3] syscalls: clean up stub naming convention

2018-04-08 Thread Dominik Brodowski
On Sun, Apr 08, 2018 at 11:15:36AM +0200, Dominik Brodowski wrote: > On a somewhat related note: I'll try to prepare a patch this evening which > lets us build just the __ia32_sys and __x32_compat_sys stubs we actually > need. We have that information already in entry/syscalls/syscall_{32,64}.tbl,

Re: [PATCH 0/3] syscalls: clean up stub naming convention

2018-04-08 Thread Dominik Brodowski
On Sun, Apr 08, 2018 at 10:35:50AM +0200, Ingo Molnar wrote: > - _sys_waitid() # ridiculous number of underscores? > - __sys_waitid() # too generic sounding? ... and we'd need to rename internal helpers in net/ > - __inline_sys_waitid() # too long? sounds acceptable, thou

Re: [PATCH 0/3] syscalls: clean up stub naming convention

2018-04-08 Thread Ingo Molnar
* Dominik Brodowski wrote: > In short (0x prefix removed, re-ordered): > > 810f0af0 tkernel_waitid # common (32/64) kernel helper > > __in_sys_waitid # inlined helper doing actual work > 810f0be0 t __do_sys_waitid # C func calling inlined helper >