Re: [PATCH] net: smc91x: Add Atari EtherNAT support

2015-01-15 Thread Nicolas Pitre
On Thu, 15 Jan 2015, Geert Uytterhoeven wrote: From: Michael Schmitz schmitz...@gmail.com Add Atari specific code to the smc91x Ethernet driver. This code is used on the EtherNAT adapter card for the Atari Falcon extension port. Signed-off-by: Michael Schmitz schm...@debian.org

Re: [PATCH] net: smc91x: Add Atari EtherNAT support

2015-01-15 Thread David Miller
From: Geert Uytterhoeven ge...@linux-m68k.org Date: Thu, 15 Jan 2015 14:06:15 +0100 From: Michael Schmitz schmitz...@gmail.com Add Atari specific code to the smc91x Ethernet driver. This code is used on the EtherNAT adapter card for the Atari Falcon extension port. Signed-off-by: Michael

[PATCH 07/28] PCI: Pass PCI domain number combined with root bus number

2015-01-15 Thread Yijing Wang
Now we could pass PCI domain combined with bus number in u32 argu. Because in arm/arm64, PCI domain number is assigned by pci_bus_assign_domain_nr(). So we leave pci_scan_root_bus() and pci_create_root_bus() in arm/arm64 unchanged. A new function pci_host_assign_domain_nr() will be introduced for

[PATCH 02/28] PCI: Rip out pci_bus_add_devices() from pci_scan_root_bus()

2015-01-15 Thread Yijing Wang
Just like pci_scan_bus(), we also should rip out pci_bus_add_devices() from pci_scan_root_bus(). Lots platforms first call pci_scan_root_bus(), but after that, they call pci_bus_size_bridges() and pci_bus_assign_resources(). Place pci_bus_add_devices() in pci_scan_root_bus() hurts PCI scan logic.

Re: linux-next: Tree for Jan 12 (build failures: m68k, ppc)

2015-01-15 Thread Geert Uytterhoeven
On Mon, Jan 12, 2015 at 6:59 PM, Guenter Roeck li...@roeck-us.net wrote: Build failures, seen since next-20150109: m68k:allmodconfig powerpc:ppc6xx_defconfig It looks like parisc is also suffering: http://kisskb.ellerman.id.au/kisskb/buildresult/12343847/ Due to:

[git pull] m68k updates for 3.19 (take 2)

2015-01-15 Thread Geert Uytterhoeven
Hi Linus, The following changes since commit b1940cd21c0f4abdce101253e860feff547291b0: Linux 3.19-rc3 (2015-01-05 17:05:20 -0800) are available in the git repository at: git://git.kernel.org/pub/scm/linux/kernel/git/geert/linux-m68k.git for-linus for you to fetch changes up to

Re: [PATCH 0/5] m68k/atari: Remove obsolete IRQ_TYPE_*

2015-01-15 Thread Geert Uytterhoeven
On Mon, Jan 12, 2015 at 9:40 AM, Geert Uytterhoeven ge...@linux-m68k.org wrote: IRQ_TYPE_SLOW, IRQ_TYPE_FAST, and IRQ_TYPE_PRIO are no longer used by the Atari platform interrupt code since commit 734085651c9b80aa ([PATCH] m68k: convert atari irq code) in v2.6.18-rc1, so drop them. Note that

[PATCH] net: smc91x: Add Atari EtherNAT support

2015-01-15 Thread Geert Uytterhoeven
From: Michael Schmitz schmitz...@gmail.com Add Atari specific code to the smc91x Ethernet driver. This code is used on the EtherNAT adapter card for the Atari Falcon extension port. Signed-off-by: Michael Schmitz schm...@debian.org Tested-by: Christian Steigies c...@debian.org [geert: Sort

Re: linux-next: Tree for Jan 12 (build failures: m68k, ppc)

2015-01-15 Thread Guenter Roeck
On 01/15/2015 02:12 AM, Geert Uytterhoeven wrote: On Mon, Jan 12, 2015 at 6:59 PM, Guenter Roeck li...@roeck-us.net wrote: Build failures, seen since next-20150109: m68k:allmodconfig powerpc:ppc6xx_defconfig It looks like parisc is also suffering:

[PATCH 20/28] PCI/Parisc: Use pci_scan_root_bus() for simplicity

2015-01-15 Thread Yijing Wang
From: Yijing Wang wangyijing0...@gmail.com Now pci_bus_add_devices() has been ripped out from pci_scan_root_bus(), we could use pci_scan_root_bus() instead of pci_create_root_bus() + pci_scan_child_bus() for simplicity. Signed-off-by: Yijing Wang wangyij...@huawei.com --- drivers/parisc/dino.c

[PATCH 22/28] PCI/tegra: Remove redundant tegra_pcie_scan_bus()

2015-01-15 Thread Yijing Wang
Now pci_scan_root_bus() is almost simliar to pci_create_root_bus() + pci_scan_child_bus(). So we could use common pci_scan_root_bus() in pci_common_init_dev() to scan pci busses. tegra_pcie_scan_bus() is redundant, remove it. Signed-off-by: Yijing Wang wangyij...@huawei.com ---

[PATCH 21/28] PCI/mvebu: Use pci_common_init_dev() to simplify code

2015-01-15 Thread Yijing Wang
Mvebu_pcie_scan_bus() is not necessary, we could use pci_common_init_dev() instead of pci_common_init(), and pass the device pointer as the parent. Then pci_scan_root_bus() will be called to scan the pci busses. Signed-off-by: Yijing Wang wangyij...@huawei.com --- drivers/pci/host/pci-mvebu.c |

[PATCH 27/28] PCI: Remove platform specific pci_domain_nr()

2015-01-15 Thread Yijing Wang
Now pci_host_bridge holds the domain number, so we could eliminate all platform specific pci_domain_nr(). Signed-off-by: Yijing Wang wangyij...@huawei.com --- arch/alpha/include/asm/pci.h |2 -- arch/ia64/include/asm/pci.h |1 - arch/microblaze/pci/pci-common.c | 11

[PATCH 00/28] Refine PCI scan interfaces and make generic pci host bridge

2015-01-15 Thread Yijing Wang
This series is based on Bjorn's pci-next branch. Patch 1-4 ripped out pci_bus_add_devices() from pci scan interfaces for better pci scan flow. Patch 5-11 make a generic pci_host_bridge to hold pci_host_bridge related informations, and introduce a pci_host_bridge_ops to support platform host

[PATCH 08/28] PCI: Introduce pci_host_assign_domain_nr() to assign domain

2015-01-15 Thread Yijing Wang
Introduce pci_host_assign_domain_nr() to assign domain number for pci_host_bridge. Later we will remove pci_bus_assign_domain_nr(). Signed-off-by: Yijing Wang wangyij...@huawei.com --- drivers/pci/pci.c | 47 +++ include/linux/pci.h |4 2

[PATCH 04/28] PCI: Remove deprecated pci_scan_bus_parented()

2015-01-15 Thread Yijing Wang
No one uses pci_scan_bus_parented() any more, remove it. Signed-off-by: Yijing Wang wangyij...@huawei.com --- drivers/pci/probe.c | 19 --- include/linux/pci.h |2 -- 2 files changed, 0 insertions(+), 21 deletions(-) diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c

[PATCH 05/28] PCI: Rename pci_scan_bus() to pci_scan_bus_legacy()

2015-01-15 Thread Yijing Wang
Pci_scan_bus() is called by legacy pci host drivers, the legacy host drivers mean they use NUll as parent device, use all IO/MEM as default resources. Rename pci_scan_bus() to pci_scan_bus_legacy() for better readability. Signed-off-by: Yijing Wang wangyij...@huawei.com ---

[PATCH 06/28] PCI: Combine PCI domain and bus number in u32 arg

2015-01-15 Thread Yijing Wang
Currently, we use int type for bus number in pci_create_root_bus(), pci_scan_root_bus() and pci_scan_bus_legacy. Because PCI bus number always = 255, so we could change the bus number argument type to u32, and combine PCI domain and bus number in one. Also add a domain member in pci_host_bridge to

[PATCH 01/28] PCI: Rip out pci_bus_add_devices() from pci_scan_bus()

2015-01-15 Thread Yijing Wang
Pci_bus_add_devices() should not be placed in pci_scan_bus(). Now pci device will be added to driver core once its creation. All things left in pci_bus_add_devices() are driver attachment and other trivial sysfs things. Pci_scan_bus() should be the function responsible for scanning PCI devices,

[PATCH 09/28] PCI: Separate pci_host_bridge creation out of pci_create_root_bus()

2015-01-15 Thread Yijing Wang
We want to make a generic pci_host_bridge, then we could place common PCI infos like domain number in it. Ripping out pci_host_bridge creation from pci_create_root_bus() make code more better readability. Further more, we could use the generic pci_host_bridge to hold host bridge specific

[PATCH 15/28] PCI/powerpc: Rename pcibios_root_bridge_prepare() for better readability

2015-01-15 Thread Yijing Wang
Pcibios_root_bridge_prepare() in powerpc is used to set root bus speed. So rename it to pcibios_set_root_bus_speed() for better readability. Signed-off-by: Yijing Wang wangyij...@huawei.com --- arch/powerpc/include/asm/machdep.h |2 +- arch/powerpc/kernel/pci-common.c |4

[PATCH 12/28] PCI: Introduce new scan function pci_scan_root_bridge()

2015-01-15 Thread Yijing Wang
Introduce new scan function pci_scan_root_bridge() to support host bridge drivers that need to provide platform own pci_host_bridge_ops. Signed-off-by: Yijing Wang wangyij...@huawei.com --- drivers/pci/probe.c | 21 + include/linux/pci.h |3 +++ 2 files changed, 24

[PATCH 14/28] PCI/IA64: Refine pci_acpi_scan_root() with generic pci_host_bridge

2015-01-15 Thread Yijing Wang
From: Yijing Wang wangyijing0...@gmail.com Signed-off-by: Yijing Wang wangyij...@huawei.com --- arch/ia64/pci/pci.c | 34 ++ 1 files changed, 18 insertions(+), 16 deletions(-) diff --git a/arch/ia64/pci/pci.c b/arch/ia64/pci/pci.c index e457015..7736c02 100644

[PATCH 11/28] PCI: Introduce pci_host_bridge_ops to setup host bridge

2015-01-15 Thread Yijing Wang
Now we have weak functions like pcibios_root_bridge_prepare() to setup pci host bridge, We could introduce pci_host_bridge_ops which contain host bridge specific ops to setup pci_host_bridge. Then host bridge driver could add pci_host_bridge_ops hooks intead of weak function to setup

[PATCH 19/28] PCI: Introduce pci_bus_child_max_busnr()

2015-01-15 Thread Yijing Wang
Sometimes, we need to know the highest reserved busnr for children bus. Because parent's bus-busn_res could have padding in it. This function return the max child busnr as pci_scan_child_bus(). Signed-off-by: Yijing Wang wangyij...@huawei.com --- drivers/pci/hotplug/acpiphp_glue.c | 29

[PATCH 16/28] PCI/powerpc: Use pci_scan_root_bridge() for simplicity

2015-01-15 Thread Yijing Wang
Now we could use pci_scan_root_bridge() to scan pci buses, provide powerpc specific pci_host_bridge_ops. Signed-off-by: Yijing Wang wangyij...@huawei.com --- arch/powerpc/kernel/pci-common.c | 57 -- 1 files changed, 36 insertions(+), 21 deletions(-) diff

[PATCH 17/28] PCI: Remove weak pcibios_root_bridge_prepare()

2015-01-15 Thread Yijing Wang
Now no one use weak pcibios_root_bridge_prepare(), we could remove it. Signed-off-by: Yijing Wang wangyij...@huawei.com --- drivers/pci/probe.c | 15 --- include/linux/pci.h |2 -- 2 files changed, 0 insertions(+), 17 deletions(-) diff --git a/drivers/pci/probe.c

[PATCH 10/28] PCI: Save sysdata in pci_host_bridge drvdata

2015-01-15 Thread Yijing Wang
Save platform specific sysdata in pci_host_bridge drvdata, host bridge specific operation need to access it before the pci bus creation. Signed-off-by: Yijing Wang wangyij...@huawei.com --- drivers/pci/host-bridge.c |4 +++- drivers/pci/probe.c | 18 --

[PATCH 25/28] PCI: Rename __pci_create_root_bus() to pci_create_root_bus()

2015-01-15 Thread Yijing Wang
Now no one use pci_create_root_bus(), we could remove it and rename __pci_create_root_bus() to pci_create_root_bus(). Signed-off-by: wangyij...@huawei.com --- drivers/pci/probe.c | 27 --- include/linux/pci.h |3 --- 2 files changed, 8 insertions(+), 22 deletions(-)

[PATCH 23/28] PCI/designware: Use pci_scan_root_bus() for simplicity

2015-01-15 Thread Yijing Wang
Use pci_scan_root_bus() instead of pci_create_root_bus() + pci_scan_child_bus() for simplicity. Signed-off-by: Yijing Wang wangyij...@huawei.com --- drivers/pci/host/pcie-designware.c |4 +--- 1 files changed, 1 insertions(+), 3 deletions(-) diff --git a/drivers/pci/host/pcie-designware.c

[PATCH 03/28] xen/PCI: Don't use deprecated function pci_scan_bus_parented()

2015-01-15 Thread Yijing Wang
From: Arnd Bergmann a...@arndb.de Use pci_scan_root_bus() instead of deprecated function pci_scan_bus_parented(). Signed-off-by: Arnd Bergmann a...@arndb.de Signed-off-by: Yijing Wang wangyij...@huawei.com CC: Konrad Rzeszutek Wilk konrad.w...@oracle.com CC: xen-de...@lists.xenproject.org ---

[PATCH 24/28] PCI/xgene: Use pci_scan_root_bus() instead of pci_create_root_bus()

2015-01-15 Thread Yijing Wang
Use pci_scan_root_bus() instead of pci_create_root_bus() + pci_scan_child_bus() for simplicity. Signed-off-by: Yijing Wang wangyij...@huawei.com --- drivers/pci/host/pci-xgene.c |3 +-- 1 files changed, 1 insertions(+), 2 deletions(-) diff --git a/drivers/pci/host/pci-xgene.c

[PATCH 26/28] PCI: Export find_pci_host_bridge()

2015-01-15 Thread Yijing Wang
Export find_pci_host_bridge(). Signed-off-by: Yijing Wang wangyij...@huawei.com --- drivers/pci/host-bridge.c |2 +- include/linux/pci.h |1 + 2 files changed, 2 insertions(+), 1 deletions(-) diff --git a/drivers/pci/host-bridge.c b/drivers/pci/host-bridge.c index ccbf168..74f7572

[PATCH 13/28] PCI/x86: Refine pci_acpi_scan_root() with generic pci_host_bridge

2015-01-15 Thread Yijing Wang
Signed-off-by: Yijing Wang wangyij...@huawei.com --- arch/x86/pci/acpi.c | 36 1 files changed, 20 insertions(+), 16 deletions(-) diff --git a/arch/x86/pci/acpi.c b/arch/x86/pci/acpi.c index 8edea63..f9a55c2 100644 --- a/arch/x86/pci/acpi.c +++