Re: [PATCH] net/smc9194: Remove bogus CONFIG_MAC reference

2018-02-22 Thread David Miller
From: Finn Thain 
Date: Thu, 22 Feb 2018 09:24:59 +1100 (AEDT)

> AFAIK the only version of smc9194.c with Mac support is the one in the
> linux-mac68k CVS repo, which never made it to the mainline.
> 
> Despite that, from v2.3.45, arch/m68k/config.in listed CONFIG_SMC9194
> under CONFIG_MAC. This mistake got carried over into Kconfig in v2.5.55.
> (See pre-git era "[PATCH] add m68k dependencies to net driver config".)
> 
> Signed-off-by: Finn Thain 

Applied, thank you.
--
To unsubscribe from this list: send the line "unsubscribe linux-m68k" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH v3 2/5] m68k: rename UL() to TO_UL()

2018-02-22 Thread Masahiro Yamada
Hi Geert

2018-02-22 22:20 GMT+09:00 Geert Uytterhoeven :
> Hi Yamada-san,
>
> On Thu, Feb 22, 2018 at 1:15 PM, Masahiro Yamada
>  wrote:
>> ARM, ARM64 and UniCore32 define UL(x) like follows:
>>   #define UL(x) _AC(x, UL)
>>
>> While, M68K defines it differently:
>>   #define UL(x) ((unsigned long) (x))
>>
>> I want to move the former to a common header.  Beforehand, this
>> commit renames the latter to avoid name conflict.
>>
>> Signed-off-by: Masahiro Yamada 
>> Acked-by: Geert Uytterhoeven 
>> ---
>> V2: https://patchwork.kernel.org/patch/9498273/
>>
>> Changes in v3: None
>> Changes in v2:
>>  - Split out as a prerequisite patch
>>
>>  arch/m68k/mm/init.c | 6 +++---
>>  1 file changed, 3 insertions(+), 3 deletions(-)
>>
>> diff --git a/arch/m68k/mm/init.c b/arch/m68k/mm/init.c
>> index e85acd1..583a8e5 100644
>> --- a/arch/m68k/mm/init.c
>> +++ b/arch/m68k/mm/init.c
>> @@ -122,9 +122,9 @@ void free_initmem(void)
>>
>>  void __init print_memmap(void)
>>  {
>> -#define UL(x) ((unsigned long) (x))
>> -#define MLK(b, t) UL(b), UL(t), (UL(t) - UL(b)) >> 10
>> -#define MLM(b, t) UL(b), UL(t), (UL(t) - UL(b)) >> 20
>> +#define TO_UL(x) ((unsigned long) (x))
>> +#define MLK(b, t) TO_UL(b), TO_UL(t), (TO_UL(t) - TO_UL(b)) >> 10
>> +#define MLM(b, t) TO_UL(b), TO_UL(t), (TO_UL(t) - TO_UL(b)) >> 20
>>  #define MLK_ROUNDUP(b, t) b, t, DIV_ROUND_UP(((t) - (b)), 1024)
>
> Please note that this code patch is scheduled for removal in v4.17, cfr.
> "[PATCH] m68k/mm: Stop printing the virtual memory layout"
> (https://lkml.org/lkml/2018/2/12/97).
>


I see, but I do not see it in linux-next as of writing.


Without this prerequisite, 3/5 would cause a build error.
So, I needed to include it in this series.

I am hoping this series will be picked up by Andrew Morton.
In my understanding, he applies patches on top of the linux-next.


I think either will happen:

[1] If your patch appears in linux-next first,
my 2/5 will be skipped, and the rest of the series will be applied.

[2] If my series is applied first,
Andrew will drop 2/5 when your patch appears in linux-next
(this is simply detected by patch conflict)


Andrew, please correct me if I am wrong.


Thanks!


-- 
Best Regards
Masahiro Yamada
--
To unsubscribe from this list: send the line "unsubscribe linux-m68k" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH v3 2/5] m68k: rename UL() to TO_UL()

2018-02-22 Thread Geert Uytterhoeven
Hi Yamada-san,

On Thu, Feb 22, 2018 at 1:15 PM, Masahiro Yamada
 wrote:
> ARM, ARM64 and UniCore32 define UL(x) like follows:
>   #define UL(x) _AC(x, UL)
>
> While, M68K defines it differently:
>   #define UL(x) ((unsigned long) (x))
>
> I want to move the former to a common header.  Beforehand, this
> commit renames the latter to avoid name conflict.
>
> Signed-off-by: Masahiro Yamada 
> Acked-by: Geert Uytterhoeven 
> ---
> V2: https://patchwork.kernel.org/patch/9498273/
>
> Changes in v3: None
> Changes in v2:
>  - Split out as a prerequisite patch
>
>  arch/m68k/mm/init.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/arch/m68k/mm/init.c b/arch/m68k/mm/init.c
> index e85acd1..583a8e5 100644
> --- a/arch/m68k/mm/init.c
> +++ b/arch/m68k/mm/init.c
> @@ -122,9 +122,9 @@ void free_initmem(void)
>
>  void __init print_memmap(void)
>  {
> -#define UL(x) ((unsigned long) (x))
> -#define MLK(b, t) UL(b), UL(t), (UL(t) - UL(b)) >> 10
> -#define MLM(b, t) UL(b), UL(t), (UL(t) - UL(b)) >> 20
> +#define TO_UL(x) ((unsigned long) (x))
> +#define MLK(b, t) TO_UL(b), TO_UL(t), (TO_UL(t) - TO_UL(b)) >> 10
> +#define MLM(b, t) TO_UL(b), TO_UL(t), (TO_UL(t) - TO_UL(b)) >> 20
>  #define MLK_ROUNDUP(b, t) b, t, DIV_ROUND_UP(((t) - (b)), 1024)

Please note that this code patch is scheduled for removal in v4.17, cfr.
"[PATCH] m68k/mm: Stop printing the virtual memory layout"
(https://lkml.org/lkml/2018/2/12/97).

Gr{oetje,eeting}s,

Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- ge...@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds
--
To unsubscribe from this list: send the line "unsubscribe linux-m68k" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCH v3 2/5] m68k: rename UL() to TO_UL()

2018-02-22 Thread Masahiro Yamada
ARM, ARM64 and UniCore32 define UL(x) like follows:
  #define UL(x) _AC(x, UL)

While, M68K defines it differently:
  #define UL(x) ((unsigned long) (x))

I want to move the former to a common header.  Beforehand, this
commit renames the latter to avoid name conflict.

Signed-off-by: Masahiro Yamada 
Acked-by: Geert Uytterhoeven 
---
V2: https://patchwork.kernel.org/patch/9498273/

Changes in v3: None
Changes in v2:
 - Split out as a prerequisite patch

 arch/m68k/mm/init.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/arch/m68k/mm/init.c b/arch/m68k/mm/init.c
index e85acd1..583a8e5 100644
--- a/arch/m68k/mm/init.c
+++ b/arch/m68k/mm/init.c
@@ -122,9 +122,9 @@ void free_initmem(void)
 
 void __init print_memmap(void)
 {
-#define UL(x) ((unsigned long) (x))
-#define MLK(b, t) UL(b), UL(t), (UL(t) - UL(b)) >> 10
-#define MLM(b, t) UL(b), UL(t), (UL(t) - UL(b)) >> 20
+#define TO_UL(x) ((unsigned long) (x))
+#define MLK(b, t) TO_UL(b), TO_UL(t), (TO_UL(t) - TO_UL(b)) >> 10
+#define MLM(b, t) TO_UL(b), TO_UL(t), (TO_UL(t) - TO_UL(b)) >> 20
 #define MLK_ROUNDUP(b, t) b, t, DIV_ROUND_UP(((t) - (b)), 1024)
 
pr_notice("Virtual kernel memory layout:\n"
-- 
2.7.4

--
To unsubscribe from this list: send the line "unsubscribe linux-m68k" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCH v3 0/5] linux/const.h: cleanups of macros such as UL(), _BITUL(), BIT() etc.

2018-02-22 Thread Masahiro Yamada

ARM, ARM64, UniCore32 define UL() as a shorthand of _AC(..., UL).
More architectures may introduce it in the future.

UL() is arch-agnostic, and useful. So let's move it to
include/linux/const.h

Currently,  must be included to use UL().
It pulls in more bloats just for defining some bit macros.

I posted V2 one year ago.

The previous posts are:
https://patchwork.kernel.org/patch/9498273/
https://patchwork.kernel.org/patch/9498275/
https://patchwork.kernel.org/patch/9498269/
https://patchwork.kernel.org/patch/9498271/

At that time, what blocked this series was a comment from
David Howells:
  You need to be very careful doing this.  Some userspace stuff
  depends on the guard macro names on the kernel header files.

(https://patchwork.kernel.org/patch/9498275/)

Looking at the code closer, I noticed this is not a problem.

See the following line.
https://github.com/torvalds/linux/blob/v4.16-rc2/scripts/headers_install.sh#L40

scripts/headers_install.sh rips off _UAPI prefix from guard macro names.

I ran "make headers_install" and confirmed the result is what I expect.

So, we can prefix the include guard of include/uapi/linux/const.h,
and add a new include/linux/const.h.



Masahiro Yamada (5):
  linux/const.h: prefix include guard of uapi/linux/const.h with _UAPI
  m68k: rename UL() to TO_UL()
  linux/const.h: move UL() macro to include/linux/const.h
  linux/const.h: refactor _BITUL and _BITULL a bit
  linux/const.h: move BIT(_ULL) to linux/const.h for use in assembly

 arch/arm/include/asm/memory.h   |  6 --
 arch/arm64/include/asm/memory.h |  6 --
 arch/m68k/mm/init.c |  6 +++---
 arch/unicore32/include/asm/memory.h |  6 --
 include/linux/bitops.h  |  3 +--
 include/linux/const.h   | 12 
 include/uapi/linux/const.h  | 13 -
 7 files changed, 24 insertions(+), 28 deletions(-)
 create mode 100644 include/linux/const.h

-- 
2.7.4

--
To unsubscribe from this list: send the line "unsubscribe linux-m68k" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH] m68k: time: stop validating rtc_time in .read_time

2018-02-22 Thread Geert Uytterhoeven
Hi Alexandre,

On Wed, Feb 21, 2018 at 10:37 PM, Alexandre Belloni
 wrote:
> The RTC core is always calling rtc_valid_tm after the read_time callback.
> It is not necessary to call it just before returning from the callback.
>
> Signed-off-by: Alexandre Belloni 

Thank you, will apply and queue for v4.17.

Gr{oetje,eeting}s,

Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- ge...@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds
--
To unsubscribe from this list: send the line "unsubscribe linux-m68k" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html