Re: [PATCH 3/6] [media] pvrusb2: check for allocation failures

2011-03-25 Thread Dan Carpenter
On Fri, Mar 25, 2011 at 11:33:36PM -0500, Mike Isely wrote: > > Acked-By: Mike Isely > I'd need to reformat this one to get it to apply... :/ It doesn't actually fix the bug so it's not worth it. regards, dan carpenter -- To unsubscribe from this list: send the line "unsubscribe linux-media"

Re: [PATCH 6/6] [media] pvrusb2: replace !0 with 1

2011-03-25 Thread Mike Isely
That's an opinion which I as the driver author disagree with. Strongly. How hard is it to read "not false"? Nacked-By: Mike Isely On Sat, 26 Mar 2011, Dan Carpenter wrote: > Using !0 is less readable than just saying 1. > > Signed-off-by: Dan Carpenter > > diff --git a/drivers/media/vid

Re: [PATCH 5/5] [media] pvrusb2: delete generic_standards_cnt

2011-03-25 Thread Mike Isely
Are you actually serious about this? Well it's a small change... Acked-By: Mike Isely On Sat, 26 Mar 2011, Dan Carpenter wrote: > The generic_standards_cnt define is only used in one place and it's > more readable to just call ARRAY_SIZE(generic_standards) directly. > > Signed-off-by: Dan C

Re: [PATCH 4/6] [media] pvrusb2: fix camel case variables

2011-03-25 Thread Mike Isely
It not worth this scale of source code disruption to the source code just to rename a bunch of variables. I'm sorry, but... Nacked-By: Mike Isely On Sat, 26 Mar 2011, Dan Carpenter wrote: > This patch renames some variables to bring them more in line with > kernel CodingStyle. > > arrPtr

Re: [PATCH 3/6] [media] pvrusb2: check for allocation failures

2011-03-25 Thread Mike Isely
Acked-By: Mike Isely On Sat, 26 Mar 2011, Dan Carpenter wrote: > This function returns NULL on failure so lets do that if kzalloc() > fails. There is a separate problem that the caller for this function > doesn't check for errors... > > Signed-off-by: Dan Carpenter > > diff --git a/drivers/

Re: [PATCH 2/6] [media] pvrusb2: fix remaining checkpatch.pl complaints

2011-03-25 Thread Mike Isely
I am OK with the #include change, but NOT the if-statement change. But since it's bundled into one patch... Nacked-By: Mike Isely On Sat, 26 Mar 2011, Dan Carpenter wrote: > * Include instead of . > * Remove unneeded curly braces. > > Signed-off-by: Dan Carpenter > > diff --git a/driver

Re: [PATCH 1/6] [media] pvrusb2: white space changes

2011-03-25 Thread Mike Isely
I vehemently object to this scale of disruption to the pvrusb2 driver source code purely to move around a bunch of braces and whitespace. ESPECIALLY the massive ridiculous changes having to do with if-statement syntax! Nacked-By: Mike Isely On Sat, 26 Mar 2011, Dan Carpenter wrote: > * Br

[PATCH 6/6] [media] pvrusb2: replace !0 with 1

2011-03-25 Thread Dan Carpenter
Using !0 is less readable than just saying 1. Signed-off-by: Dan Carpenter diff --git a/drivers/media/video/pvrusb2/pvrusb2-std.c b/drivers/media/video/pvrusb2/pvrusb2-std.c index 9bebc08..ca4f67b 100644 --- a/drivers/media/video/pvrusb2/pvrusb2-std.c +++ b/drivers/media/video/pvrusb2/pvrusb2-s

[PATCH 5/5] [media] pvrusb2: delete generic_standards_cnt

2011-03-25 Thread Dan Carpenter
The generic_standards_cnt define is only used in one place and it's more readable to just call ARRAY_SIZE(generic_standards) directly. Signed-off-by: Dan Carpenter diff --git a/drivers/media/video/pvrusb2/pvrusb2-std.c b/drivers/media/video/pvrusb2/pvrusb2-std.c index d5a679f..9bebc08 100644 --

[PATCH 4/6] [media] pvrusb2: fix camel case variables

2011-03-25 Thread Dan Carpenter
This patch renames some variables to bring them more in line with kernel CodingStyle. arrPtr => arr arrSize => arr_size bufPtr => buf bufSize => buf_size Signed-off-by: Dan Carpenter diff --git a/drivers/media/video/pvrusb2/pvrusb2-std.c b/drivers/media/video/pvrusb2/pvrusb2-std.c index b214

[PATCH 3/6] [media] pvrusb2: check for allocation failures

2011-03-25 Thread Dan Carpenter
This function returns NULL on failure so lets do that if kzalloc() fails. There is a separate problem that the caller for this function doesn't check for errors... Signed-off-by: Dan Carpenter diff --git a/drivers/media/video/pvrusb2/pvrusb2-std.c b/drivers/media/video/pvrusb2/pvrusb2-std.c in

[PATCH 2/6] [media] pvrusb2: fix remaining checkpatch.pl complaints

2011-03-25 Thread Dan Carpenter
* Include instead of . * Remove unneeded curly braces. Signed-off-by: Dan Carpenter diff --git a/drivers/media/video/pvrusb2/pvrusb2-std.c b/drivers/media/video/pvrusb2/pvrusb2-std.c index a5d4867..370a9ab 100644 --- a/drivers/media/video/pvrusb2/pvrusb2-std.c +++ b/drivers/media/video/pvrusb2

[PATCH 1/6] [media] pvrusb2: white space changes

2011-03-25 Thread Dan Carpenter
* Broke up if statements so that the condition and the body are on separate lines. * Added spaces around commas and other operator characters. * Removed extra blank lines. * Added blank lines after declarations. * Changed C99 comments into kernel style. * Fixed checkpatch complaints where "{" cha

Re: Yet another memory provider: can linaro organize a meeting?

2011-03-25 Thread Clark, Rob
On Wed, Mar 16, 2011 at 3:14 AM, Kyungmin Park wrote: > > Rough schedules. > > 1. Warsaw meetings (3/16~3/18): mostly v4l2 person and some SoC vendors >  Make a consensence at media developers. and share the information. >  Please note that it's v4l2 brainstorming meeting. so memory > management i

Re: [RFC PATCH 1/3] tea575x-tuner: various improvements

2011-03-25 Thread Ondrej Zary
On Tuesday 22 March 2011 20:02:30 Hans Verkuil wrote: > BTW, can you run the v4l2-compliance utility for the two boards that use > this radio tuner? > > This utility is part of the v4l-utils repository > (http://git.linuxtv.org/v4l-utils.git). > > Run as 'v4l2-compliance -r /dev/radioX -v2'. > > I'

Re: S2-3200 switching-timeouts on 2.6.38

2011-03-25 Thread Paul Franke
> Can you guys, (who seem to really need the said patch) please provide > me the STB0899 chipset version on your card ? Sure. For a TechniSat SkyStar HD 2 (1ae4:0003)... > C6L STB0899 VQ940KDA12 22 9BS VQ MLT 22 012 > C2L STB0899 VQ636DSK22 09C VQ MLT 22 656 > C1L STB0899 VQ608FSD22 OPD

[cron job] v4l-dvb daily build: ERRORS

2011-03-25 Thread Hans Verkuil
This message is generated daily by a cron job that builds v4l-dvb for the kernels and architectures in the list below. Results of the daily build of v4l-dvb: date:Fri Mar 25 19:01:05 CET 2011 git hash:b328817a2a391d1e879c4252cd3f11a352d3f3bc gcc version: i686-linux-gcc (GCC) 4.5.

[no subject]

2011-03-25 Thread Vijay
Dear linux-media team, The MSI Digi vox Trio DVB (usb) does not work on my 64bit linux (ubuntu 10.10)PC with kernel version 2.6.35-28-generic. It however works on a windows machine so the device is confirmed to work. The lsusb shows "Bus 001 Device 006: ID eb1a:2885 eMPIA Technology,Inc."

RE: [PATCH 1/4] omap iommu: Check existence of arch_iommu

2011-03-25 Thread Hiremath, Vaibhav
> -Original Message- > From: linux-media-ow...@vger.kernel.org [mailto:linux-media- > ow...@vger.kernel.org] On Behalf Of Sakari Ailus > Sent: Friday, March 25, 2011 8:43 PM > To: linux-media@vger.kernel.org > Cc: laurent.pinch...@ideasonboard.com; david.co...@nokia.com; > hiroshi.d...@noki

[PATCH] saa7134: support MagicPro ProHDTV Pro2 Hybrid DMB-TH PCI card

2011-03-25 Thread Timothy Lee
The attached patch adds support for MagicPro ProHDTV Pro2. Please consider its inclusion into the DVB tree. Thanks. >From 5495d8d9c1f958306846e9c4d2dae90cbf889640 Mon Sep 17 00:00:00 2001 From: Timothy Lee Date: Sat, 26 Mar 2011 01:44:08 +0800 Subject: [PATCH 1/1] saa7134: support MagicPro Pro

Re: S2-3200 switching-timeouts on 2.6.38

2011-03-25 Thread Manu Abraham
On Fri, Mar 25, 2011 at 8:31 PM, Paul Franke wrote: > Hi list, > > Follow up to: [1] > > I did testing with a TechniSat SkyStar HD 2 (1ae4:0003). > > - without a patch: card unuseable, gets locks only rarely > - with Manu's patch: card useable, gets locks, but sometimes this still > needs some sec

Re: [GIT PULL] HVR-900 R2 and PCTV 330e DVB support

2011-03-25 Thread Mauro Carvalho Chehab
Em 25-03-2011 13:09, Devin Heitmueller escreveu: > On Fri, Mar 25, 2011 at 11:50 AM, Mauro Carvalho Chehab > wrote: >> I've added a patch for it at the end of the series. >> >> Could you please double check if everything is ok, for me to move this >> upstream? >> >> Thanks! >> Mauro >> > > Sure,

Re: [GIT PULL] HVR-900 R2 and PCTV 330e DVB support

2011-03-25 Thread Devin Heitmueller
On Fri, Mar 25, 2011 at 11:50 AM, Mauro Carvalho Chehab wrote: > I've added a patch for it at the end of the series. > > Could you please double check if everything is ok, for me to move this > upstream? > > Thanks! > Mauro > Sure, I will find some time this weekend to try out your tree. http:/

Re: [GIT PULL] HVR-900 R2 and PCTV 330e DVB support

2011-03-25 Thread Mauro Carvalho Chehab
Hi Devin, Em 24-03-2011 14:05, Devin Heitmueller escreveu: > This patch series finally merges in Ralph Metzler's drx-d driver and > brings up the PCTV 330e and > HVR-900R2. The patches have been tested for quite some time by users > on the Kernel Labs blog, > and they have been quite happy with t

[RFC/PATCH v2] v4l: Add V4L2_MBUS_FMT_JPEG_1X8 media bus format

2011-03-25 Thread Sylwester Nawrocki
Add V4L2_MBUS_FMT_JPEG_1X8 format and the corresponding Docbook documentation. Signed-off-by: Sylwester Nawrocki Signed-off-by: Kyungmin Park --- Hello, it's a second patch version adding V4L2_MBUS_FMT_JPEG_1X8 format to the list of media bus formats. The requirement of this format had already

Re: [RFC PATCH] HDMI:Support for EDID parsing in kernel.

2011-03-25 Thread K, Mythri P
Hi Florian, > >> So why should this be a common library? Most kernel code doesn't need >> it. Or is there a serious need for video input to parse EDIDs? > > It's true that most kernel code does not need it as it is only useful for > display output systems (and only the ones that can be connected

Re: [PATCH 1/4] omap iommu: Check existence of arch_iommu

2011-03-25 Thread Sakari Ailus
Sakari Ailus wrote: > Check that the arch_iommu has been installed before trying to use it. This > will lead to kernel oops if the arch_iommu isn't there. This was intended to go to linux-omap. Sorry for the noise. -- Sakari Ailus sakari.ai...@maxwell.research.nokia.com -- To unsubscribe from th

[PATCH 2/4] omap iommu: Add module information to struct iommu_functions

2011-03-25 Thread Sakari Ailus
Whichever module that implements the struct, may not be unloaded while it's in use. Prepare to this by adding module reference to the structure. Signed-off-by: Sakari Ailus --- arch/arm/plat-omap/include/plat/iommu.h |1 + 1 files changed, 1 insertions(+), 0 deletions(-) diff --git a/arch/

[PATCH 3/4] omap2 iommu: Set module information in omap2_iommu_ops

2011-03-25 Thread Sakari Ailus
Set omap2_iommu_ops.module to point to THIS_MODULE. Signed-off-by: Sakari Ailus --- arch/arm/mach-omap2/iommu2.c |2 ++ 1 files changed, 2 insertions(+), 0 deletions(-) diff --git a/arch/arm/mach-omap2/iommu2.c b/arch/arm/mach-omap2/iommu2.c index 14ee686..cf0c32a 100644 --- a/arch/arm/mach

[PATCH 1/4] omap iommu: Check existence of arch_iommu

2011-03-25 Thread Sakari Ailus
Check that the arch_iommu has been installed before trying to use it. This will lead to kernel oops if the arch_iommu isn't there. Signed-off-by: Sakari Ailus --- arch/arm/plat-omap/iommu.c |3 +++ 1 files changed, 3 insertions(+), 0 deletions(-) diff --git a/arch/arm/plat-omap/iommu.c b/ar

[PATCH 4/4] omap iommu: Prevent iommu implementations from being unloaded while in use

2011-03-25 Thread Sakari Ailus
Prevent module implementing arch_iommu from being unloaded while the arch_iommu is in use, essentially while the iommu has been acquired using iommu_get() by increasing module use count. This assumes that the arch_iommu has to be uninstalled at module unload time. Signed-off-by: Sakari Ailus ---

Re: S2-3200 switching-timeouts on 2.6.38

2011-03-25 Thread Paul Franke
Hi list, Follow up to: [1] I did testing with a TechniSat SkyStar HD 2 (1ae4:0003). - without a patch: card unuseable, gets locks only rarely - with Manu's patch: card useable, gets locks, but sometimes this still needs some seconds - with the mentioned stb0899 patch: card useable, gets locks,

Re: [RFC PATCH] HDMI:Support for EDID parsing in kernel.

2011-03-25 Thread K, Mythri P
Hi Gunnedi, >> > Dave's point is that we can't ditch the existing code without >> > introducing a lot of risk; it would be better to start a library-ized >> > EDID codebase from the most complete one we have already, i.e. the DRM >> > EDID code. > > Does the DRM EDID-parser also process blocks be

Re: OMAP3 isp single-shot

2011-03-25 Thread Daniel Lundborg
Hi Laurent, > Hi Daniel, > > On Thursday 24 March 2011 11:26:01 Daniel Lundborg wrote: > > > Daniel Lundborg wrote: > > > > > > > > I am successfully using the gumstix overo board together with a camera > > > > sensor Aptina MT9V034 with the kernel 2.6.35 and patches from > > > > http://git.linux

Re: OMAP3 ISP outputs 5555 5555 5555 5555 ...

2011-03-25 Thread Bastian Hecht
2011/3/24 Bastian Hecht : > 2011/3/24 Laurent Pinchart : >> Hi Bastian, >> >> On Thursday 24 March 2011 10:59:01 Bastian Hecht wrote: >>> 2011/3/22 Laurent Pinchart : >>> > On Tuesday 22 March 2011 17:11:04 Bastian Hecht wrote: >>> >> Hello omap isp devs, >>> >> >>> >> maybe you can help me, I am a

Re: [PATCH] omap3isp: implement ENUM_FMT

2011-03-25 Thread Michael Jones
Hi Laurent, On 03/24/2011 11:36 AM, Laurent Pinchart wrote: > Hi, > [snip] > > Padding at end of line can be configured through S_FMT. Other than that, all > other options (width, height, pixelcode) are fixed for a given mbus format > *for the ISP driver*. Other drivers might support different

Re: [PATCH] omap3isp: implement ENUM_FMT

2011-03-25 Thread Michael Jones
Hi Sakari, On 03/24/2011 09:04 AM, Sakari Ailus wrote: > Michael Jones wrote: >> Hi Sakari, > > Hi Michael, > >> On 03/23/2011 10:52 AM, Sakari Ailus wrote: >>> Hi Michael, >>> >>> Thanks for the patch. >>> >>> Michael Jones wrote: From dccbd4a0a717ee72a3271075b1e3456a9c67ca0e Mon Sep 17 00

[PATCH] V4L: mx3_camera: implement .stop_streaming()

2011-03-25 Thread Guennadi Liakhovetski
The .stop_streaming() videobuf2 operation has to be implemented to guarantee, that video buffers are not written to after a STREAMOFF. Signed-off-by: Guennadi Liakhovetski --- drivers/media/video/mx3_camera.c | 30 ++ 1 files changed, 30 insertions(+), 0 deletions(-

[PATCH] V4L: sh_mobile_ceu_camera: implement .stop_streaming()

2011-03-25 Thread Guennadi Liakhovetski
The .stop_streaming() videobuf2 operation has to be implemented to guarantee, that video buffers are not written to after a STREAMOFF. Signed-off-by: Guennadi Liakhovetski --- for 2.6.40 drivers/media/video/sh_mobile_ceu_camera.c | 21 + 1 files changed, 21 insertions(+),

[PATCH] ignore Documentation/DocBook/media/

2011-03-25 Thread Michael Jones
It only contains generated files Signed-off-by: Michael Jones Acked-by: Laurent Pinchart --- Re-sending this because patchwork didn't catch it the first time. Documentation/DocBook/.gitignore |1 + 1 files changed, 1 insertions(+), 0 deletions(-) diff --git a/Documentation/DocBook/.gitig