cron job: media_tree daily build: ERRORS

2017-08-18 Thread Hans Verkuil
This message is generated daily by a cron job that builds media_tree for the kernels and architectures in the list below. Results of the daily build of media_tree: date: Sat Aug 19 05:00:16 CEST 2017 media-tree git hash:ec0c3ec497cabbf3bfa03a9eb5edcc252190a4e0 media_build

[PATCH 1/2] v4l: Add support for V4L2_BUF_TYPE_META_OUTPUT

2017-08-18 Thread Sakari Ailus
The V4L2_BUF_TYPE_META_OUTPUT mirrors the V4L2_BUF_TYPE_META_CAPTURE with the exception that it is an OUTPUT type. The use case for this is to pass buffers to the device that are not image data but metadata. The formats, just as the metadata capture formats, are typically device specific and

[PATCH 2/2] docs-rst: v4l: Document V4L2_BUF_TYPE_META_OUTPUT interface

2017-08-18 Thread Sakari Ailus
Document the interface for metadata output, including V4L2_BUF_TYPE_META_OUTPUT buffer type and V4L2_CAP_META_OUTPUT capability bits. Signed-off-by: Sakari Ailus Acked-by: Hans Verkuil --- Documentation/media/uapi/v4l/buffer.rst |

[PATCH 0/2] Add V4L2_BUF_TYPE_META_OUTPUT buffer type

2017-08-18 Thread Sakari Ailus
Hi folks, Here's a non-RFC version of the META_OUTPUT buffer type patches. The V4L2_BUF_TYPE_META_OUTPUT buffer type complements the metadata buffer types support for OUTPUT buffers, capture being already supported. This is intended for similar cases than V4L2_BUF_TYPE_META_CAPTURE but for

Re: [PATCH 1/2] doc: media/v4l-drivers/qcom_camss: Add abbreviations explanation

2017-08-18 Thread Sakari Ailus
On Fri, Aug 18, 2017 at 11:16:33AM +0300, Todor Tomov wrote: > Add explanations for VFE's PIX and RDI interfaces. > > Signed-off-by: Todor Tomov For both: Acked-by: Sakari Ailus -- Sakari Ailus e-mail: sakari.ai...@iki.fi

[PATCH v2] venus: fix copy/paste error in return_buf_error

2017-08-18 Thread Gustavo A. R. Silva
Call function v4l2_m2m_dst_buf_remove_by_buf() instead of v4l2_m2m_src_buf_remove_by_buf() Addresses-Coverity-ID: 1415317 Cc: Stanimir Varbanov Cc: Hans Verkuil Signed-off-by: Gustavo A. R. Silva --- Changes in v2:

Re: [PATCH] media: venus: fix duplicated code for different branches

2017-08-18 Thread Gustavo A. R. Silva
Hi Stanimir, On 08/18/2017 02:52 AM, Stanimir Varbanov wrote: Hi Gustavo, On 08/18/2017 02:12 AM, Gustavo A. R. Silva wrote: Refactor code in order to avoid identical code for different branches. This issue was detected with the help of Coccinelle. Addresses-Coverity-ID: 1415317

[PATCH 0/2] drivers: make i2c_algorithm const

2017-08-18 Thread Bhumika Goyal
Make these const. Bhumika Goyal (2): i2c: busses: make i2c_algorithm const [media] usb: make i2c_algorithm const drivers/i2c/busses/i2c-pnx.c | 2 +- drivers/i2c/busses/i2c-puv3.c| 2 +- drivers/media/usb/au0828/au0828-i2c.c| 2 +-

[PATCH 1/2] i2c: busses: make i2c_algorithm const

2017-08-18 Thread Bhumika Goyal
Make these const as they are only stored in the algo field of i2c_adapter structure, which is const. Signed-off-by: Bhumika Goyal --- drivers/i2c/busses/i2c-pnx.c | 2 +- drivers/i2c/busses/i2c-puv3.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git

[PATCH 2/2] [media] usb: make i2c_algorithm const

2017-08-18 Thread Bhumika Goyal
Make these const as they are only used in a copy operation or are stored in the algo field of i2c_adapter structure, which is const. Signed-off-by: Bhumika Goyal --- drivers/media/usb/au0828/au0828-i2c.c| 2 +- drivers/media/usb/pvrusb2/pvrusb2-i2c-core.c | 2 +- 2

Re: [PATCH 1/7] media: vb2: add bidirectional flag in vb2_queue

2017-08-18 Thread Stanimir Varbanov
Hi Hans, On 08/18/2017 05:30 PM, Hans Verkuil wrote: > On 08/18/17 16:16, Stanimir Varbanov wrote: >> This change is intended to give to the v4l2 drivers a choice to >> change the default behavior of the v4l2-core DMA mapping direction >> from DMA_TO/FROM_DEVICE (depending on the buffer type

Re: [PATCH 1/7] media: vb2: add bidirectional flag in vb2_queue

2017-08-18 Thread Hans Verkuil
On 08/18/17 16:16, Stanimir Varbanov wrote: > This change is intended to give to the v4l2 drivers a choice to > change the default behavior of the v4l2-core DMA mapping direction > from DMA_TO/FROM_DEVICE (depending on the buffer type CAPTURE or > OUTPUT) to DMA_BIDIRECTIONAL during queue_init

[PATCH 0/7] Venus updates

2017-08-18 Thread Stanimir Varbanov
Hello, Patch 1/7 has been sent already as an RFC but in this patchset it can be found as a regular patch. The RFC version can be found at [1] and also to prove its need look at [2]. Patch 2/7 fixes Venus encoder issue with help of 1/7. The other patches 3/7 to 7/7 can be treated as updates for

[PATCH 1/7] media: vb2: add bidirectional flag in vb2_queue

2017-08-18 Thread Stanimir Varbanov
This change is intended to give to the v4l2 drivers a choice to change the default behavior of the v4l2-core DMA mapping direction from DMA_TO/FROM_DEVICE (depending on the buffer type CAPTURE or OUTPUT) to DMA_BIDIRECTIONAL during queue_init time. Initially the issue with DMA mapping direction

[PATCH 4/7] media: venus: fill missing video_device name

2017-08-18 Thread Stanimir Varbanov
This fills missing (forgotten) video device name with appropriate string so that udev can distinguishes between decoder and encoder devices. Signed-off-by: Stanimir Varbanov --- drivers/media/platform/qcom/venus/vdec.c | 1 +

[PATCH 2/7] media: venus: venc: set correct resolution on compressed stream

2017-08-18 Thread Stanimir Varbanov
This change the alignment restriction for output type of buffers only, also set corect input resolution and fill bidirectional vb2 queue flag in order to map output type buffers read/write. The last is needed by encoder firmware to add padding at the bottom of output (input buffers).

[PATCH 3/7] media: venus: mark venc and vdec PM functions as __maybe_unused

2017-08-18 Thread Stanimir Varbanov
Without PM support gcc could warns about unused functions, thus mark runtime_suspend/resume as __maybe_unused. Signed-off-by: Stanimir Varbanov --- drivers/media/platform/qcom/venus/vdec.c | 6 ++ drivers/media/platform/qcom/venus/venc.c | 6 ++ 2 files

[PATCH 5/7] media: venus: add helper to check supported codecs

2017-08-18 Thread Stanimir Varbanov
Adds a helper function to runtime check supported encoder and decoder codecs depending on venus version and platform. Signed-off-by: Stanimir Varbanov --- drivers/media/platform/qcom/venus/helpers.c | 49 +

[PATCH 6/7] media: venus: use helper function to check supported codecs

2017-08-18 Thread Stanimir Varbanov
Use the helper function in decoder and encoder find_format to runtime check supported codecs. Signed-off-by: Stanimir Varbanov --- drivers/media/platform/qcom/venus/vdec.c | 24 +--- drivers/media/platform/qcom/venus/venc.c | 28

[PATCH 7/7] media: venus: venc: drop VP9 codec support

2017-08-18 Thread Stanimir Varbanov
No one of the supported Venus version has implemented VP9 codec for enconding, so drop it from the list of codecs. Signed-off-by: Stanimir Varbanov --- drivers/media/platform/qcom/venus/venc.c | 4 1 file changed, 4 deletions(-) diff --git

Re: [PATCH v3 0/3] Unified fwnode endpoint parser

2017-08-18 Thread Sakari Ailus
On Fri, Aug 18, 2017 at 02:23:14PM +0300, Sakari Ailus wrote: > Hi folks, > > We have a large influx of new, unmerged, drivers that are now parsing > fwnode endpoints and each one of them is doing this a little bit > differently. The needs are still exactly the same for the graph data > structure

Re: [PATCH 1/4] v4l: async: fix unbind error in v4l2_async_notifier_unregister()

2017-08-18 Thread Sakari Ailus
On Fri, Aug 18, 2017 at 03:42:07PM +0200, Niklas Söderlund wrote: > Hi, > > On 2017-08-18 14:15:26 +0300, Laurent Pinchart wrote: > > Hi Sakari, > > > > On Tuesday 15 Aug 2017 19:16:14 Sakari Ailus wrote: > > > On Mon, Jul 31, 2017 at 12:31:55AM +0200, Niklas Söderlund wrote: > > > > The call to

Re: [PATCH 4/4] v4l: async: add comment about re-probing to v4l2_async_notifier_unregister()

2017-08-18 Thread Niklas Söderlund
Hi Sakari and Laurent, Thanks for your feedback. On 2017-08-18 14:20:08 +0300, Laurent Pinchart wrote: > Hello, > > On Tuesday 15 Aug 2017 19:09:33 Sakari Ailus wrote: > > On Mon, Jul 31, 2017 at 12:31:58AM +0200, Niklas Söderlund wrote: > > > The re-probing of subdevices when unregistering a

Re: [PATCH 1/4] v4l: async: fix unbind error in v4l2_async_notifier_unregister()

2017-08-18 Thread Niklas Söderlund
Hi, On 2017-08-18 14:15:26 +0300, Laurent Pinchart wrote: > Hi Sakari, > > On Tuesday 15 Aug 2017 19:16:14 Sakari Ailus wrote: > > On Mon, Jul 31, 2017 at 12:31:55AM +0200, Niklas Söderlund wrote: > > > The call to v4l2_async_cleanup() will set sd->asd to NULL so passing it > > > to

[GIT PULL FOR v4.14] vsp1: partition algorithm improvements

2017-08-18 Thread Hans Verkuil
Note from Laurent: the series merges cleanly with Dave's drm-next branch (git://people.freedesktop.org/~airlied/linux) that contains a large series of VSP patches. There should thus be no merge conflict (at least none that git won't solve automatically) when merging upstream. Regards,

[PATCH 1/1] dt: bindings: Add a binding for flash devices associated to a sensor

2017-08-18 Thread Sakari Ailus
Camera flash drivers (and LEDs) are separate from the sensor devices in DT. In order to make an association between the two, provide the association information to the software. Signed-off-by: Sakari Ailus --- Hi Rob and Jacek, others, I know I've submitted

Re: [PATCH v2 0/3] Add ZTE zx-irdec remote control driver

2017-08-18 Thread Shawn Guo
On Sun, Jul 30, 2017 at 09:23:10PM +0800, Shawn Guo wrote: > From: Shawn Guo > > The series adds dt-bindings and remote control driver for IRDEC block > found on ZTE ZX family SoCs. > > Changes for v2: > - Add one patch to move generic NEC scancode composing and protocol

[PATCH] [em28xx] add config for em28xx-based board by MAGIX

2017-08-18 Thread panic
Hi, the patch below adds the entries to the config arrays for a capture-only board distributed by MAGIX [0]. The hardware itself (EM2860, SAA7113, EMP202) is already supported. This patch lacks the configuration for the GPIO pin, because I had/have no time yet to figure out how it works. Video

[PATCH v3 2/3] v4l: fwnode: Support generic parsing of graph endpoints in a device

2017-08-18 Thread Sakari Ailus
The current practice is that drivers iterate over their endpoints and parse each endpoint separately. This is very similar in a number of drivers, implement a generic function for the job. Driver specific matters can be taken into account in the driver specific callback. Convert the omap3isp as

[PATCH v3 0/3] Unified fwnode endpoint parser

2017-08-18 Thread Sakari Ailus
Hi folks, We have a large influx of new, unmerged, drivers that are now parsing fwnode endpoints and each one of them is doing this a little bit differently. The needs are still exactly the same for the graph data structure is device independent. This is still a non-trivial task and the majority

[PATCH v3 3/3] v4l: fwnode: Support generic parsing of graph endpoints in a single port

2017-08-18 Thread Sakari Ailus
This is the preferred way to parse the endpoints. Signed-off-by: Sakari Ailus --- drivers/media/v4l2-core/v4l2-fwnode.c | 51 +++ include/media/v4l2-fwnode.h | 7 + 2 files changed, 58 insertions(+) diff --git

[PATCH v3 1/3] omap3isp: Drop redundant isp->subdevs field and ISP_MAX_SUBDEVS

2017-08-18 Thread Sakari Ailus
struct omap3isp.subdevs field and ISP_MAX_SUBDEVS macro are both unused. Remove them. Signed-off-by: Sakari Ailus --- drivers/media/platform/omap3isp/isp.h | 3 --- 1 file changed, 3 deletions(-) diff --git a/drivers/media/platform/omap3isp/isp.h

Re: [PATCH 4/4] v4l: async: add comment about re-probing to v4l2_async_notifier_unregister()

2017-08-18 Thread Laurent Pinchart
Hello, On Tuesday 15 Aug 2017 19:09:33 Sakari Ailus wrote: > On Mon, Jul 31, 2017 at 12:31:58AM +0200, Niklas Söderlund wrote: > > The re-probing of subdevices when unregistering a notifier is tricky to > > understand, and implemented somewhat as a hack. Add a comment trying to > > explain why

Re: [PATCH 1/4] v4l: async: fix unbind error in v4l2_async_notifier_unregister()

2017-08-18 Thread Laurent Pinchart
Hi Sakari, On Tuesday 15 Aug 2017 19:16:14 Sakari Ailus wrote: > On Mon, Jul 31, 2017 at 12:31:55AM +0200, Niklas Söderlund wrote: > > The call to v4l2_async_cleanup() will set sd->asd to NULL so passing it > > to notifier->unbind() have no effect and leaves the notifier confused. > > Call the

Re: [PATCH 1/4] v4l: async: fix unbind error in v4l2_async_notifier_unregister()

2017-08-18 Thread Laurent Pinchart
Hi Niklas, Thank you for the patch. On Monday 31 Jul 2017 00:31:55 Niklas Söderlund wrote: > The call to v4l2_async_cleanup() will set sd->asd to NULL so passing it > to notifier->unbind() have no effect and leaves the notifier confused. > Call the unbind() callback prior to cleaning up the

[GIT PULL for v4l-utils] rc fixes

2017-08-18 Thread Sean Young
Hi Mauro, These are just fixes to ir-keytable and ir-ctl. Please let me know if you have any ideas for improving them. Thanks, Sean The following changes since commit 16c3764b636d647a8b41bc34d34722678220a9ff: cec-ctl: refactor: split the monitor code off into its own function (2017-08-01

Re: [PATCHv2 0/9] omapdrm: hdmi4: add CEC support

2017-08-18 Thread Hans Verkuil
On 08/18/17 11:02, Tomi Valkeinen wrote: > Hi Hans, > > > Texas Instruments Finland Oy, Porkkalankatu 22, 00180 Helsinki. > Y-tunnus/Business ID: 0615521-4. Kotipaikka/Domicile: Helsinki > > On 11/08/17 13:57, Tomi Valkeinen wrote: > >> I'm doing some testing with this series on my panda. One

Re: [PATCH] uvcvideo: Apply flags from device to actual properties

2017-08-18 Thread Edgar Thier
Use flags the device exposes for UVC controls. This allows the device to define which property flags are set. Since some cameras offer auto-adjustments for properties (e.g. auto-gain), the values of other properties (e.g. gain) can change in the camera. Examining the flags ensures that the

[GIT PULL for 4.14] More sensor driver patches

2017-08-18 Thread Sakari Ailus
Hi Mauro, Here are more sensor driver patches for 4.14. Please pull. The following changes since commit ec0c3ec497cabbf3bfa03a9eb5edcc252190a4e0: media: ddbridge: split code into multiple files (2017-08-09 12:17:01 -0400) are available in the git repository at:

Re: [PATCH 3/3] Documentation: subdev-formats: Add Xilinx YCbCr to Vendor specific area

2017-08-18 Thread Laurent Pinchart
Hi Rohit, Thank you for the patch. On Wednesday 09 Aug 2017 11:27:54 Rohit Athavale wrote: > This commit adds the custom Xilinx IP specific 8-bit YCbCr 4:2:0 > to the custom formats area in the subdev-formats documentation. > > Signed-off-by: Rohit Athavale > --- >

Re: [PATCH 1/3] uapi: media-bus-format: Add Xilinx specific YCbCr 4:2:0 media bus format

2017-08-18 Thread Laurent Pinchart
Hi Rohit, Thank you for the patch. On Wednesday 09 Aug 2017 11:27:52 Rohit Athavale wrote: > This commit adds Xilinx Video IP specific 8-bit color depth YCbCr 4:2:0 > to the media bus format uapi. > > Signed-off-by: Rohit Athavale > --- >

Re: [PATCH 2/3] media: xilinx-vip: Add 8-bit YCbCr 4:2:0 to formats table

2017-08-18 Thread Laurent Pinchart
Hi Rohit, Thank you for the patch. On Wednesday 09 Aug 2017 11:27:53 Rohit Athavale wrote: > Add Xilinx YCbCr 4:2:0 to xvip formats table. This commit > will allow driver to setup media pad codes to YUV 420 > via DT properties. > > Signed-off-by: Rohit Athavale > --- >

Re: [PATCHv2 0/9] omapdrm: hdmi4: add CEC support

2017-08-18 Thread Tomi Valkeinen
Hi Hans, Texas Instruments Finland Oy, Porkkalankatu 22, 00180 Helsinki. Y-tunnus/Business ID: 0615521-4. Kotipaikka/Domicile: Helsinki On 11/08/17 13:57, Tomi Valkeinen wrote: > I'm doing some testing with this series on my panda. One issue I see is > that when I unload the display modules,

Re: [PATCH 1/1] et8ek8: Decrease stack usage

2017-08-18 Thread Sakari Ailus
On Thu, Aug 17, 2017 at 11:38:43PM +0200, Pavel Machek wrote: > On Wed 2017-08-16 10:33:45, Sakari Ailus wrote: > > The et8ek8 driver combines I²C register writes to a single array that it > > passes to i2c_transfer(). The maximum number of writes is 48 at once, > > decrease it to 8 and make more

[PATCH 1/2] doc: media/v4l-drivers/qcom_camss: Add abbreviations explanation

2017-08-18 Thread Todor Tomov
Add explanations for VFE's PIX and RDI interfaces. Signed-off-by: Todor Tomov --- Documentation/media/v4l-drivers/qcom_camss.rst | 11 ++- 1 file changed, 6 insertions(+), 5 deletions(-) diff --git a/Documentation/media/v4l-drivers/qcom_camss.rst

[PATCH 2/2] media: camss: Add abbreviations explanation

2017-08-18 Thread Todor Tomov
Add abbreviations explanation at the top header blocks in source files. Signed-off-by: Todor Tomov --- drivers/media/platform/qcom/camss-8x16/camss-csid.c | 2 +- drivers/media/platform/qcom/camss-8x16/camss-csid.h | 2 +-

Re: [PATCH v4 04/21] doc: media/v4l-drivers: Add Qualcomm Camera Subsystem driver document

2017-08-18 Thread Todor Tomov
Hi Hans, On 18.08.2017 10:45, Hans Verkuil wrote: > Hi Todor, > > A few small comments below: > > On 08/08/2017 03:30 PM, Todor Tomov wrote: >> Add a document to describe Qualcomm Camera Subsystem driver. >> >> Signed-off-by: Todor Tomov >> --- >>

Re: [PATCH] media: venus: fix duplicated code for different branches

2017-08-18 Thread Stanimir Varbanov
Hi Gustavo, On 08/18/2017 02:12 AM, Gustavo A. R. Silva wrote: > Refactor code in order to avoid identical code for different branches. > > This issue was detected with the help of Coccinelle. > > Addresses-Coverity-ID: 1415317 > Signed-off-by: Gustavo A. R. Silva > ---

Re: [PATCH v4 04/21] doc: media/v4l-drivers: Add Qualcomm Camera Subsystem driver document

2017-08-18 Thread Hans Verkuil
Hi Todor, A few small comments below: On 08/08/2017 03:30 PM, Todor Tomov wrote: > Add a document to describe Qualcomm Camera Subsystem driver. > > Signed-off-by: Todor Tomov > --- > Documentation/media/v4l-drivers/qcom_camss.rst | 124 > + > 1

Re: [PATCH] [media] mx2_emmaprp: Check for platform_get_irq() error

2017-08-18 Thread Philipp Zabel
Hi Fabio, On Thu, 2017-08-17 at 18:12 -0300, Fabio Estevam wrote: > From: Fabio Estevam > > platform_get_irq() may fail, so we should better check its return > value and propagate it in the case of error. > > Signed-off-by: Fabio Estevam > --- >  

Re: [PATCH] [media] coda/imx-vdoa: Check for platform_get_resource() error

2017-08-18 Thread Philipp Zabel
Hi Fabio, On Wed, 2017-08-16 at 21:14 -0300, Fabio Estevam wrote: > > From: Fabio Estevam > > platform_get_resource() may fail and in this case a NULL dereference > will occur. > > Prevent this from happening by returning an error on > platform_get_resource() failure.  >

[GIT PULL FOR v4.14] Various fixes/improvements

2017-08-18 Thread Hans Verkuil
Lots of constify stuff, some random other fixes. The following changes since commit ec0c3ec497cabbf3bfa03a9eb5edcc252190a4e0: media: ddbridge: split code into multiple files (2017-08-09 12:17:01 -0400) are available in the git repository at: git://linuxtv.org/hverkuil/media_tree.git

[PATCH v1] [media] uvcvideo: mark buffer error where overflow

2017-08-18 Thread Baoyou Xie
Some cameras post inaccurate frame where next frame data overlap it. this results in screen flicker, and it need to be prevented. So this patch marks the buffer error to discard the frame where buffer overflow. Signed-off-by: Baoyou Xie ---

Re: [PATCH] media: venus: fix duplicated code for different branches

2017-08-18 Thread Hans Verkuil
Stanimir, please review this! I suspect that this is the wrong fix and that the first v4l2_m2m_src_buf_remove_by_buf should be v4l2_m2m_dst_buf_remove_by_buf instead. Regards, Hans On 08/18/2017 01:12 AM, Gustavo A. R. Silva wrote: > Refactor code in order to avoid identical code for