Re: [PATCHv4] [media] rcar-vin: add Renesas R-Car VIN driver

2016-04-20 Thread Hans Verkuil
On 04/12/2016 04:33 PM, Niklas Söderlund wrote: > +static void rect_set_min_size(struct v4l2_rect *r, > + const struct v4l2_rect *min_size) > +{ > + if (r->width < min_size->width) > + r->width = min_size->width; > + if (r->height < min_size->height) >

Re: [PATCH] arm64: defconfig: Add Renesas R-Car USB 3.0 driver support

2016-04-20 Thread Simon Horman
arch/arm64/configs/defconfig > > > @@ -1,7 +1,6 @@ > > > # CONFIG_LOCALVERSION_AUTO is not set > > > CONFIG_SYSVIPC=y > > > CONFIG_POSIX_MQUEUE=y > > > -CONFIG_FHANDLE=y > > > CONFIG_AUDIT=y > > > CONFIG_NO_HZ_IDLE=y > > >

Re: [PATCH v2] PCI: rcar-pcie: Remove Gen2 designation from Kconfig

2016-04-20 Thread Simon Horman
On Tue, Apr 19, 2016 at 04:21:14PM -0500, Bjorn Helgaas wrote: > On Tue, Apr 05, 2016 at 01:10:54PM -0500, Bjorn Helgaas wrote: > > Hi Simon, > > > > On Thu, Mar 31, 2016 at 09:35:23AM +0900, Simon Horman wrote: > > > It appears that Gen2 is a misnomer for the R-Car PCIE driver > > > which also su

[PATCH v3] PCI: rcar-pcie: Remove Gen2 designation from Kconfig

2016-04-20 Thread Simon Horman
It appears that Gen2 is a misnomer for the R-Car PCIE driver which also supports Gen 1 and Gen 3 SoCs. Accordingly, drop Gen 2 from the help text and Kconfig symbol. Also, re-arange the Kconfig symbol name to use PCIE as the prefix. This appears to be in keeping with other PCIE Kconfig symbols. R

[PATCH 5/7] soc: renesas: Add r8a7793 SYSC PM Domain Binding Definitions

2016-04-20 Thread Simon Horman
From: Geert Uytterhoeven R-Car M2-N is identical to R-Car M2-W w.r.t. power domains, so reuse the definitions from the latter. Signed-off-by: Geert Uytterhoeven Reviewed-by: Laurent Pinchart Signed-off-by: Simon Horman --- include/dt-bindings/power/r8a7793-sysc.h | 28 +++

[PATCH 6/7] soc: renesas: Add r8a7794 SYSC PM Domain Binding Definitions

2016-04-20 Thread Simon Horman
From: Geert Uytterhoeven Signed-off-by: Geert Uytterhoeven Reviewed-by: Laurent Pinchart Signed-off-by: Simon Horman --- include/dt-bindings/power/r8a7794-sysc.h | 26 ++ 1 file changed, 26 insertions(+) create mode 100644 include/dt-bindings/power/r8a7794-sysc.h dif

[PATCH 7/7] soc: renesas: Add r8a7795 SYSC PM Domain Binding Definitions

2016-04-20 Thread Simon Horman
From: Geert Uytterhoeven Signed-off-by: Geert Uytterhoeven Reviewed-by: Laurent Pinchart Signed-off-by: Simon Horman --- include/dt-bindings/power/r8a7795-sysc.h | 42 1 file changed, 42 insertions(+) create mode 100644 include/dt-bindings/power/r8a7795-sysc.

[PATCH 3/3] ARM: shmobile: timer: Fix preset_lpj leading to too short delays

2016-04-20 Thread Simon Horman
From: Geert Uytterhoeven On all shmobile ARM SoCs, loop-based delays may complete early, which can be after only 1/3 (Cortex A9) or 1/2 (Cortex A7 or A15) of the minimum required time. This is caused by calculating preset_lpj based on incorrect assumptions about the number of clock cycles per lo

[PATCH 4/7] soc: renesas: Add r8a7791 SYSC PM Domain Binding Definitions

2016-04-20 Thread Simon Horman
From: Geert Uytterhoeven Signed-off-by: Geert Uytterhoeven Reviewed-by: Laurent Pinchart Signed-off-by: Simon Horman --- include/dt-bindings/power/r8a7791-sysc.h | 26 ++ 1 file changed, 26 insertions(+) create mode 100644 include/dt-bindings/power/r8a7791-sysc.h dif

[PATCH 1/7] PM / Domains: Add DT bindings for the R-Car System Controller

2016-04-20 Thread Simon Horman
From: Geert Uytterhoeven The Renesas R-Car System Controller provides power management for the CPU cores and various coprocessors, following the generic PM domain bindings in Documentation/devicetree/bindings/power/power_domain.txt. This supports R-Car Gen1 (H1), Gen2, and Gen3. Signed-off-by:

[PATCH 2/7] soc: renesas: Add r8a7779 SYSC PM Domain Binding Definitions

2016-04-20 Thread Simon Horman
From: Geert Uytterhoeven Signed-off-by: Geert Uytterhoeven Reviewed-by: Laurent Pinchart Signed-off-by: Simon Horman --- include/dt-bindings/power/r8a7779-sysc.h | 27 +++ 1 file changed, 27 insertions(+) create mode 100644 include/dt-bindings/power/r8a7779-sysc.h di

[GIT PULL] Renesas ARM Based SoC Fixes for v4.6

2016-04-20 Thread Simon Horman
Hi Olof, Hi Kevin, Hi Arnd, Please consider these Renesas ARM based SoC fixes for v4.6. The following changes since commit f55532a0c0b8bb6148f4e07853b876ef73bc69ca: Linux 4.6-rc1 (2016-03-26 16:03:24 -0700) are available in the git repository at: git://git.kernel.org/pub/scm/linux/kernel/

[PATCH 2/3] Revert "ARM: dts: porter: Enable SCIF_CLK frequency and pins"

2016-04-20 Thread Simon Horman
From: Sjoerd Simons This reverts commit 19417bd9c511 ("ARM: dts: porter: Enable SCIF_CLK frequency and pins") as according to http://elinux.org/File:R-CarM2-KOELSCH_PORTER-B_PORTER_C_Comparison.pdf the external oscillator for SCIF_CLK is not mounted on the porter boards. Signed-off-by: Sjoerd Si

[PATCH 3/7] soc: renesas: Add r8a7790 SYSC PM Domain Binding Definitions

2016-04-20 Thread Simon Horman
From: Geert Uytterhoeven Signed-off-by: Geert Uytterhoeven Reviewed-by: Laurent Pinchart Signed-off-by: Simon Horman --- include/dt-bindings/power/r8a7790-sysc.h | 34 1 file changed, 34 insertions(+) create mode 100644 include/dt-bindings/power/r8a7790-sysc.

[PATCH 1/3] ARM: dts: r8a7791: Don't disable referenced optional clocks

2016-04-20 Thread Simon Horman
From: Sjoerd Simons clk_get on a disabled clock node will return EPROBE_DEFER, which can cause drivers to be deferred forever if such clocks are referenced in their clocks property. Update the various disabled external clock nodes to default to a frequency of 0, but don't disable them to prevent

[GIT PULL] Renesas ARM Based SoC R-Car SYSC Updates for v4.7

2016-04-20 Thread Simon Horman
Hi Olof, Hi Kevin, Hi Arnd, Please consider these Renesas ARM based SoC R-Car SYSC updates for v4.7. The following changes since commit f55532a0c0b8bb6148f4e07853b876ef73bc69ca: Linux 4.6-rc1 (2016-03-26 16:03:24 -0700) are available in the git repository at: git://git.kernel.org/pub/scm/

RE: [PATCH] arm64: defconfig: Add Renesas R-Car USB 3.0 driver support

2016-04-20 Thread Yoshihiro Shimoda
t; > @@ -1,7 +1,6 @@ > > # CONFIG_LOCALVERSION_AUTO is not set > > CONFIG_SYSVIPC=y > > CONFIG_POSIX_MQUEUE=y > > -CONFIG_FHANDLE=y > > CONFIG_AUDIT=y > > CONFIG_NO_HZ_IDLE=y > > CONFIG_HIGH_RES_TIMERS=y > > Is the hunk above intended? > It d

Re: [PATCH v6 00/11] soc: renesas: Add R-Car SYSC PM Domain Support

2016-04-20 Thread Simon Horman
MSSR clock domain, > - Use "renesas,-sysc" instead of "renesas,sysc-", > - Added fallback compatibility strings for R-Car Gen2 and Gen3. > - Changed one-line summary prefix to match current arm-soc practices, > - The L2 cache-controller patches have been

Re: [PATCH v2] ARM: dts: r8a7793: Add MMCIF0

2016-04-20 Thread Simon Horman
On Mon, Apr 18, 2016 at 06:02:40PM +0200, Ulrich Hecht wrote: > Same as on r8a7794. > > Signed-off-by: Ulrich Hecht > --- > This revision adds the missing dma-names and power-domains entires spotted > by Sergei and Simon. Thanks, we are back to one using one dma controller for now so I adjusted

Re: [PATCH v2 2/2] ARM: dts: gose: Enable SDHI controllers

2016-04-20 Thread Simon Horman
On Mon, Apr 18, 2016 at 06:02:57PM +0200, Ulrich Hecht wrote: > Includes regulator and pin assignments. > > Signed-off-by: Ulrich Hecht Thanks, I have queued this up.

Re: [PATCH v2 1/2] ARM: dts: r8a7793: Add SDHI controllers

2016-04-20 Thread Simon Horman
On Mon, Apr 18, 2016 at 06:02:56PM +0200, Ulrich Hecht wrote: > Same as on r8a7791. > > Signed-off-by: Ulrich Hecht > --- > arch/arm/boot/dts/r8a7793.dtsi | 36 > 1 file changed, 36 insertions(+) Thanks. We are back to one DMA controller this week so I upda

Re: [PATCH] arm64: defconfig: Add Renesas R-Car USB 3.0 driver support

2016-04-20 Thread Simon Horman
Hi Shimoda-san, On Wed, Apr 20, 2016 at 05:47:14PM +0900, Yoshihiro Shimoda wrote: > If we doesn't enable this configuration and runs on R-Car Gen3, > xhci host driver will cause timeout in xhci_reset() because > the R-Car Gen3 xHCI controller needs specific initialization. > > [1.565605] xhc

[PATCH 0/2] Renesas R-Car Gen3 DU alpha and z-order support

2016-04-20 Thread Laurent Pinchart
Hello, This patch series implement support for alpha and z-order configuration in the R-Car DU driver for the Gen3 SoCs family. The Gen3 SoCs delegate composition to an external IP core called VSP, supported by a V4L2 driver. The DU driver interfaces with the VSP driver using direct function call

[PATCH 1/2] drm: rcar-du: Add Z-order support for VSP planes

2016-04-20 Thread Laurent Pinchart
Make the Z-order of VSP planes configurable through the zpos property, exactly as for the native DU planes. Signed-off-by: Laurent Pinchart --- drivers/gpu/drm/rcar-du/rcar_du_vsp.c | 16 drivers/gpu/drm/rcar-du/rcar_du_vsp.h | 2 ++ 2 files changed, 14 insertions(+), 4 deletio

[PATCH 2/2] drm: rcar-du: Add alpha support for VSP planes

2016-04-20 Thread Laurent Pinchart
Make the global alpha multiplier of VSP planes configurable through the alpha property, exactly as for the native DU planes. Signed-off-by: Laurent Pinchart --- drivers/gpu/drm/rcar-du/rcar_du_vsp.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/gpu/drm/rc

[PATCH v2] PM / Runtime: Only force-resume device if it has been force-suspended

2016-04-20 Thread Laurent Pinchart
The pm_runtime_force_suspend() and pm_runtime_force_resume() helpers are designed to help driver being RPM-centric by offering an easy way to manage runtime PM state during system suspend and resume. The first function will force the device into runtime suspend at system suspend time, while the sec

Re: [PATCH] PM / Runtime: Only force-resume device if it has been force-suspended

2016-04-20 Thread Laurent Pinchart
Hello, Reviving this old thread. On Monday 07 Mar 2016 11:10:08 Ulf Hansson wrote: > [...] > > >> I agree, that's a better idea. Drivers shouldn't call > >> pm_runtime_force_resume() if they haven't called > >> pm_runtime_force_suspend(), so checking the PM use count should be fine. > >> I'll mo

Re: [git pull] clk: renesas: R-Car SYSC PM Domain Preparation

2016-04-20 Thread Stephen Boyd
On 04/20, Geert Uytterhoeven wrote: > From: Geert Uytterhoeven > > Hi Mike, Stephen, > > The following changes since commit 12a56817b329d8a73ab53bad09aa976aeea46db9: > > clk: renesas: mstp: Clarify cpg_mstp_{at,de}tach_dev() domain parameter > (2016-04-07 17:27:13 +0200) > > are avail

Re: [PATCH v3 6/7] media: rcar-vin: initialize EDID data

2016-04-20 Thread Ulrich Hecht
On Mon, Apr 18, 2016 at 12:13 PM, Hans Verkuil wrote: > Where does this EDID come from? I'm just wondering if it has been > adjusted for the capabilities of the adv. It's from the cobalt driver, with only the vendor ID changed. CU Uli

Re: [PATCH v3 5/7] media: rcar-vin: add DV timings support

2016-04-20 Thread Ulrich Hecht
On Mon, Apr 18, 2016 at 12:04 PM, Hans Verkuil wrote: > Hi Ulrich, > > This isn't right: this just overwrites the adv7180 input with an HDMI input. > > I assume the intention is to have support for both adv7180 and HDMI input and > to use VIDIOC_S_INPUT to select between the two. I'm not quite su

Re: [alsa-devel] [PATCH 0/4] ASoC: add graph base connection on simple-card

2016-04-20 Thread Jean-Francois Moine
On Wed, 20 Apr 2016 02:55:39 + Kuninori Morimoto wrote: > I could understand your idea, > and had read previous some discussions. > I would like to have it on upstream too. > Can you show me about your plan for next step ? Hi Kuninori, I have no plan. My Cubox machine has too many specific

Re: [PATCH v5 03/11] soc: renesas: rcar-sysc: Add DT support for SYSC PM domains

2016-04-20 Thread Ulf Hansson
On 20 April 2016 at 10:24, Geert Uytterhoeven wrote: > Hi Ulf, > > On Mon, Apr 18, 2016 at 4:02 PM, Ulf Hansson wrote: >> On 18 April 2016 at 15:39, Geert Uytterhoeven wrote: >>> On Mon, Apr 18, 2016 at 2:59 PM, Geert Uytterhoeven >>> wrote: On Mon, Apr 18, 2016 at 2:21 PM, Ulf Hansson >

Re: [PATCH v6 03/11] soc: renesas: rcar-sysc: Add DT support for SYSC PM domains

2016-04-20 Thread Laurent Pinchart
Hi Geert, Thank you for the patch. On Wednesday 20 Apr 2016 14:02:38 Geert Uytterhoeven wrote: > Populate the SYSC PM domains from DT, based on the presence of a device > node for the System Controller. The actual power area hiearchy, and > features of specific areas are obtained from tables in t

[PATCH v6 11/11] soc: renesas: rcar-sysc: Add support for R-Car H3 power areas

2016-04-20 Thread Geert Uytterhoeven
Signed-off-by: Geert Uytterhoeven Reviewed-by: Laurent Pinchart --- v6: - No changes, v5: - Add Reviewed-by, - Re-add "always-on" power area, v4: - Remove "always-on" power area, as it's now implicitly handled by the rcar-sysc driver, - Reformat table, v3: - New (converted from

[PATCH v6 04/11] soc: renesas: rcar-sysc: Make rcar_sysc_power_is_off() static

2016-04-20 Thread Geert Uytterhoeven
As of commit b12ff41658171f53 ("ARM: shmobile: r8a7779: Remove legacy PM Domain remainings"), rcar_sysc_power_is_off() is no longer used from SoC-specific code. Signed-off-by: Geert Uytterhoeven Reviewed-by: Laurent Pinchart --- v6: - No changes, v5: - No changes, v4: - Add Reviewed-by,

[PATCH v6 07/11] soc: renesas: rcar-sysc: Add support for R-Car H2 power areas

2016-04-20 Thread Geert Uytterhoeven
Signed-off-by: Geert Uytterhoeven Reviewed-by: Laurent Pinchart --- v6: - No changes, v5: - Add Reviewed-by, - Add "always-on" power area, v4: - Rename R8A7790_PD_SH to R8A7790_PD_SH_4A, "sh" to "sh-4a", - Reformat table, v3: - New (converted from DT to C). --- drivers/soc/renesas

[PATCH v6 05/11] soc: renesas: rcar-sysc: Enable Clock Domain for I/O devices

2016-04-20 Thread Geert Uytterhoeven
On R-Car H3, some power areas (e.g. A3VP) contain I/O devices, which are also part of the CPG/MSSR Clock Domain. On all R-Car SoCs, devices in the "always-on" PM Domain are part of the Clock Domain served by the CPG/MSSR or CPG/MSTP driver. Hook up the CPG/MSTP or CPG/MSSR Clock Domain attach/deta

[PATCH v6 03/11] soc: renesas: rcar-sysc: Add DT support for SYSC PM domains

2016-04-20 Thread Geert Uytterhoeven
Populate the SYSC PM domains from DT, based on the presence of a device node for the System Controller. The actual power area hiearchy, and features of specific areas are obtained from tables in the C code. The SYSCIER and SYSCIMR register values are derived from the power areas present, which wil

[PATCH v6 10/11] soc: renesas: rcar-sysc: Add support for R-Car E2 power areas

2016-04-20 Thread Geert Uytterhoeven
Signed-off-by: Geert Uytterhoeven Reviewed-by: Laurent Pinchart --- v6: - No changes, v5: - Add Reviewed-by, - Add "always-on" power area, v4: - Rename R8A7794_PD_SH to R8A7794_PD_SH_4A, "sh" to "sh-4a", - Reformat table, v3: - New (converted from DT to C). --- drivers/soc/renesas

[PATCH v6 02/11] soc: renesas: rcar-sysc: Improve rcar_sysc_power() debug info

2016-04-20 Thread Geert Uytterhoeven
Print requested power domain state. Signed-off-by: Geert Uytterhoeven Reviewed-by: Laurent Pinchart --- v6: - No changes, v5: - No changes, v4: - No changes, v3: - Add Reviewed-by, v2: - New. --- drivers/soc/renesas/rcar-sysc.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)

[PATCH v6 00/11] soc: renesas: Add R-Car SYSC PM Domain Support

2016-04-20 Thread Geert Uytterhoeven
as-for-v4.7 (which now includes "[PATCH v2 0/4] clk: renesas: R-Car SYSC PM Domain Preparation"; pull request sent), - renesas-devel-20160420-v4.6-rc4 (which already contains series "[PATCH v5 0/7] PM / Domains: Add DT bindings for the R-Car System Controller"). I

[PATCH v6 06/11] soc: renesas: rcar-sysc: Add support for R-Car H1 power areas

2016-04-20 Thread Geert Uytterhoeven
Signed-off-by: Geert Uytterhoeven Reviewed-by: Laurent Pinchart --- v6: - No changes, v5: - Add Reviewed-by, - Add "always-on" power area, v4: - Drop R8A7779_PD_SH, as it's not documented in the datasheet, - Reformat table, v3: - New (converted from DT to C). --- drivers/soc/renes

[PATCH v6 01/11] soc: renesas: Move pm-rcar to drivers/soc/renesas/rcar-sysc

2016-04-20 Thread Geert Uytterhoeven
Move the pm-rcar driver from arch/arm/mach-shmobile/ to drivers/soc/renesas/, and its header file to include/linux/soc/renesas/, so it can be shared between arm32 (R-Car H1 and Gen2) and arm64 (R-Car Gen3). Rename it to rcar-sysc as it's really a driver for the R-Car System Controller (SYSC). Kill

[PATCH v6 09/11] soc: renesas: rcar-sysc: Add support for R-Car M2-N power areas

2016-04-20 Thread Geert Uytterhoeven
R-Car M2-N is identical to R-Car M2-W w.r.t. power domains, so reuse the definitions from the latter. Signed-off-by: Geert Uytterhoeven Reviewed-by: Laurent Pinchart --- v6: - No changes, v5: - Add Reviewed-by, - Reference r8a7791_sysc_info directly for R-Car M2-N in rcar-sysc.c, v4: -

[PATCH v6 08/11] soc: renesas: rcar-sysc: Add support for R-Car M2-W power areas

2016-04-20 Thread Geert Uytterhoeven
Signed-off-by: Geert Uytterhoeven Reviewed-by: Laurent Pinchart --- v6: - No changes, v5: - Add Reviewed-by, - Add "always-on" power area, v4: - Rename R8A7791_PD_SH to R8A7791_PD_SH_4A, "sh" to "sh-4a", - Reformat table, v3: - New (converted from DT to C). --- drivers/soc/renesas

[git pull] clk: renesas: R-Car SYSC PM Domain Preparation

2016-04-20 Thread Geert Uytterhoeven
From: Geert Uytterhoeven Hi Mike, Stephen, The following changes since commit 12a56817b329d8a73ab53bad09aa976aeea46db9: clk: renesas: mstp: Clarify cpg_mstp_{at,de}tach_dev() domain parameter (2016-04-07 17:27:13 +0200) are available in the git repository at: git://git.kernel.org

Re: [PATCH 0/3 v6] drm: Introduce drm_connector_register_all() helper

2016-04-20 Thread Daniel Vetter
On Tue, Apr 19, 2016 at 03:24:50PM +0300, Alexey Brodkin wrote: > As a pair to already existing drm_connector_unplug_all() > (which we'll rename in this series to drm_connector_unregister_all()) > we're adding generic implementation of what is already done in some drivers > for registering all conn

[PATCH] arm64: defconfig: Add Renesas R-Car USB 3.0 driver support

2016-04-20 Thread Yoshihiro Shimoda
If we doesn't enable this configuration and runs on R-Car Gen3, xhci host driver will cause timeout in xhci_reset() because the R-Car Gen3 xHCI controller needs specific initialization. [1.565605] xhci-hcd ee00.usb: xHCI Host Controller [1.570636] xhci-hcd ee00.usb: new USB bus reg

Re: [PATCH v5 03/11] soc: renesas: rcar-sysc: Add DT support for SYSC PM domains

2016-04-20 Thread Geert Uytterhoeven
Hi Ulf, On Mon, Apr 18, 2016 at 4:02 PM, Ulf Hansson wrote: > On 18 April 2016 at 15:39, Geert Uytterhoeven wrote: >> On Mon, Apr 18, 2016 at 2:59 PM, Geert Uytterhoeven >> wrote: >>> On Mon, Apr 18, 2016 at 2:21 PM, Ulf Hansson wrote: [...] > + > +static bool rcar_sysc_activ