Re: [PATCH 2/2] ARM: dts: exynos4: allow i2c0 bus to be configured using pinctrl interface

2012-09-10 Thread Stephen Warren
On 09/06/2012 05:14 AM, Thomas Abraham wrote:
 On 6 September 2012 15:43, Tomasz Figa t.f...@samsung.com wrote:
 Hi Thomas,

 On Thursday 06 of September 2012 14:53:01 Thomas Abraham wrote:
   compatible = samsung,s3c2440-i2c;
   reg = 0x1386 0x100;
   interrupts = 0 58 0;
 + pinctrl-names = default;
 + pinctrl-0 = i2c0_bus;

 If pinctrl-names property is omitted then the state index is used as a name
 (e.g. pinctrl-0 would be named 0). Maybe it would be better to use this
 approach (with respective adjustment in first patch)? What do you think?
 
 I tend to prefer to name the states because it is easier to
 cross-reference code and dts files. i2c was a simple one, but for mmc
 controllers, there will 1-bit state, 4-bit state and 8-bit state, and
 it will be nicer to name then accordingly. So I prefer to use names
 but if there is wider consensus on not using names, we can drop names.

I would only expect to see multiple states defined in a single board
.dts file /if/ runtime muxing is required. Given MMC doesn't runtime
mux, I wouldn't expect there to be multiple states for different bus
widths; it's just that the default state would point at whatever
single configuration is appropriate for the board.

--
To unsubscribe from this list: send the line unsubscribe linux-samsung-soc in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 2/2] ARM: dts: exynos4: allow i2c0 bus to be configured using pinctrl interface

2012-09-06 Thread Tomasz Figa
Hi Thomas,

On Thursday 06 of September 2012 14:53:01 Thomas Abraham wrote:
   compatible = samsung,s3c2440-i2c;
   reg = 0x1386 0x100;
   interrupts = 0 58 0;
 + pinctrl-names = default;
 + pinctrl-0 = i2c0_bus;

If pinctrl-names property is omitted then the state index is used as a name 
(e.g. pinctrl-0 would be named 0). Maybe it would be better to use this 
approach (with respective adjustment in first patch)? What do you think?

Best regards,
-- 
Tomasz Figa
Samsung Poland RD Center

--
To unsubscribe from this list: send the line unsubscribe linux-samsung-soc in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 2/2] ARM: dts: exynos4: allow i2c0 bus to be configured using pinctrl interface

2012-09-06 Thread Thomas Abraham
On 6 September 2012 15:43, Tomasz Figa t.f...@samsung.com wrote:
 Hi Thomas,

 On Thursday 06 of September 2012 14:53:01 Thomas Abraham wrote:
   compatible = samsung,s3c2440-i2c;
   reg = 0x1386 0x100;
   interrupts = 0 58 0;
 + pinctrl-names = default;
 + pinctrl-0 = i2c0_bus;

 If pinctrl-names property is omitted then the state index is used as a name
 (e.g. pinctrl-0 would be named 0). Maybe it would be better to use this
 approach (with respective adjustment in first patch)? What do you think?

I tend to prefer to name the states because it is easier to
cross-reference code and dts files. i2c was a simple one, but for mmc
controllers, there will 1-bit state, 4-bit state and 8-bit state, and
it will be nicer to name then accordingly. So I prefer to use names
but if there is wider consensus on not using names, we can drop names.

Thanks,
Thomas.


 Best regards,
 --
 Tomasz Figa
 Samsung Poland RD Center

--
To unsubscribe from this list: send the line unsubscribe linux-samsung-soc in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html