[GIT PULL] Samsung usb stuff for v3.5

2012-05-17 Thread Kukjin Kim
Hi Greg and Felipe, Please pull Samsung 's3c-hsotg' UDC support for EXYNOS4210 and S5PV210 from: git://git.kernel.org/pub/scm/linux/kernel/git/kgene/linux-samsung.git v3.5-for-usb Since it has a dependency on 'usb: hsotg: samsung ...' patches which have been already in usb tree now, so would

RE: [GIT PULL] Samsung devel-2 for v3.5

2012-05-17 Thread Kukjin Kim
Sachin Kamat wrote: Hi Arnd, Thomas has posted a patch [1] (available on Grant's tree) to fix this problem. [1] http://git.secretlab.ca/?p=linux- 2.6.git;a=commitdiff;h=766644d2df254934d656a0a0628b636212c24f9e;hp=0034102 808e0dbbf3a2394b82b1bb40b5778de9e Yeah, I know that. But in

RE: [PATCH v2] serial: samsung: Fixed wrong comparison for baudclk_rate

2012-05-17 Thread Kukjin Kim
Russell King - ARM Linux wrote: On Tue, May 15, 2012 at 09:37:16PM +0900, Kyoungil Kim wrote: port-baudclk_rate should be compared to the rate of port-baudclk, because port-baudclk_rate was assigned as the rate of port-baudclk previously. So to check that the current baudclk rate is same

RE: [PATCH 0/2] ARM: S3C64xx: cpuidle cleanups

2012-05-17 Thread Kukjin Kim
Daniel Lezcano wrote: These couple of patches use the new cpuidle core api to refactor some part of the code. The first one declares the states directly in the driver declaration and the second one use the timekeeping flag to let the cpuidle core to compute the idle time. Basically, looks

[PATCH 0/3] ADD HSOTG support to SMDK and Origen boards

2012-05-17 Thread Sachin Kamat
This patch series is based on Kukjin Kim's v3.5-for-usb tree. Sachin Kamat (3): ARM: EXYNOS: Add HSOTG support to Origen ARM: EXYNOS: Add HSOTG device to SMDKV310 ARM: S5PV210: Add HSOTG support to SMDKV210 arch/arm/mach-exynos/Kconfig |2 ++

[PATCH 1/3] ARM: EXYNOS: Add HSOTG support to Origen

2012-05-17 Thread Sachin Kamat
S3C-HSOTG device is added to Origen board. Signed-off-by: Sachin Kamat sachin.ka...@linaro.org Signed-off-by: Tushar Behera tushar.beh...@linaro.org --- arch/arm/mach-exynos/Kconfig |1 + arch/arm/mach-exynos/mach-origen.c |6 ++ 2 files changed, 7 insertions(+), 0 deletions(-)

[PATCH 2/3] ARM: EXYNOS: Add HSOTG support to SMDKV310

2012-05-17 Thread Sachin Kamat
S3C-HSOTG device is added to SMDKV310 board. Signed-off-by: Sachin Kamat sachin.ka...@linaro.org --- arch/arm/mach-exynos/Kconfig |1 + arch/arm/mach-exynos/mach-smdkv310.c |6 ++ 2 files changed, 7 insertions(+), 0 deletions(-) diff --git a/arch/arm/mach-exynos/Kconfig

[PATCH 3/3] ARM: S5PV210: Add HSOTG support to SMDKV210

2012-05-17 Thread Sachin Kamat
Adds S3C-HSOTG support to SMDKV210 board. Signed-off-by: Sachin Kamat sachin.ka...@linaro.org --- arch/arm/mach-s5pv210/Kconfig |2 ++ arch/arm/mach-s5pv210/mach-smdkv210.c |8 2 files changed, 10 insertions(+), 0 deletions(-) diff --git a/arch/arm/mach-s5pv210/Kconfig

Re: [PATCH 1/2] ARM: s3c64xx: cpuidle - declare the states with the new api

2012-05-17 Thread Mark Brown
On Mon, May 14, 2012 at 04:06:16PM +0200, Daniel Lezcano wrote: The states are now part of the cpuidle_driver structure, so we can declare the states in this structure directly. That saves us an extra variable declaration and a memcpy. Tested-by: Mark Brown broo...@opensource.wolfsonmicro.com

Re: [PATCH 2/2] ARM: s3c64xx: cpuidle - use timekeeping wrapper

2012-05-17 Thread Mark Brown
On Mon, May 14, 2012 at 04:06:17PM +0200, Daniel Lezcano wrote: The timekeeping is computed from the cpuidle core if we set the .en_core_tk_irqen flag. Let's use it and remove the duplicated code. Tested-by: Mark Brown broo...@opensource.wolfsonmicro.com signature.asc Description: Digital

Re: [PATCH] mmc: dw_mmc: Fixed sdio interrupt mask bit setting bug

2012-05-17 Thread Chris Ball
Hi, On Mon, May 14 2012, Will Newton wrote: On Mon, May 14, 2012 at 9:38 AM, Kyoungil Kim ki0351@samsung.com wrote: The sdio interrupt mask bits are arranged in [31:16]. (1 SDMMC_INT_SDIO(slot-id))) does 16 bits left shift twice. So this patch changes to do 16 bits left shift only one

[PATCH v2 0/2] regulator: Add initial suport for max77686

2012-05-17 Thread Yadwinder Singh Brar
This patch series adds support for max77686 which is a multifunction device which includes regulator (pmic), rtc and charger sub-blocks within it. The support for mfd driver and regulator driver are added by this patch series. This patch series also includes device tree and irqdomain support for

[PATCH v2 2/2] regulator: Add support for MAX77686.

2012-05-17 Thread Yadwinder Singh Brar
Add support for PMIC/regulator portion of MAX77686 multifunction device. MAX77686 provides LDOs[1-26] and BUCKs[1-9]. This is initial release of driver which supports setting and getting the voltage of a regulator with I2C interface. Signed-off-by: Yadwinder Singh Brar yadi.b...@samsung.com ---

[PATCH v2 1/2] mfd: Add support for MAX77686.

2012-05-17 Thread Yadwinder Singh Brar
MAX77686 is a mulitifunction device with PMIC, RTC and Charger on chip. This driver provides common support for accessing the device. This is initial version of this driver that supports to enable the chip with its primary I2C bus.It also includes IRQ and device tree support for MAX77686 chip.

[PATCH v2 0/6] mmc: dw_mmc: add support for device tree based instantiation

2012-05-17 Thread Thomas Abraham
This patch series is the second version of the patches that adds device tree support for Synopsis Designware Mobile Storage Host Controller. The first patch converts the copy of controller device instance into a reference. This is need to allow device resource management api to correctly manage

[PATCH 3/3] ARM: dts: Add nodes for dw_mmc controllers for Samsung Exynos5250 platforms

2012-05-17 Thread Thomas Abraham
Add device nodes for the four instances of dw_mmc controllers in Exynos5250 and enable instance 0 and 2 for the smdk5250 board. Signed-off-by: Thomas Abraham thomas.abra...@linaro.org --- arch/arm/boot/dts/exynos5250-smdk5250.dts | 59 +

Re: [GIT PULL] Samsung usb stuff for v3.5

2012-05-17 Thread Greg KH
On Thu, May 17, 2012 at 03:45:55PM +0900, Kukjin Kim wrote: Hi Greg and Felipe, Please pull Samsung 's3c-hsotg' UDC support for EXYNOS4210 and S5PV210 from: git://git.kernel.org/pub/scm/linux/kernel/git/kgene/linux-samsung.git v3.5-for-usb Since it has a dependency on 'usb: hsotg:

Re: [PATCH v2 6/6] mmc: dw_mmc: add samsung exynos5250 specific extentions

2012-05-17 Thread Jaehoon Chung
Hi Thomas, On 05/18/2012 12:10 AM, Thomas Abraham wrote: The instantiation of the Synopsis Designware controller on Exynos5250 include extension for SDR and DDR specific tx/rx phase shift timing and CIU internal divider. In addition to that, the option to skip the command hold stage is also

[PATCH 1/2] ARM: EXYYNOS: Use EXYNOS4210_GPEx instead of EXYNOS4_GPEx

2012-05-17 Thread Joonyoung Shim
Also use EXYNOS4210_GPIO_Ex instead of EXYNOS4_GPIO_Ex. The GPEx gpios exist only on Exynos4210 and there are no on Exynos4x12. Redefine them to exact SoC name. Signed-off-by: Joonyoung Shim jy0922.s...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p...@samsung.com ---

[PATCH 2/2] gpio/exynos: Add support for Exynos4x12 SoC

2012-05-17 Thread Joonyoung Shim
Exynos4x12 GPIO part1 and part2 layouts are different with that of Exynos4210. So, it needs to support gpios for Exynos4x12 SoC. This doesn't support GPVx Exynos4x12 GPIO part4 yet. In the Exynos4x12 GPIO part1 and part2, the interval of base register offset is 0x20 but GPF0, GPJ0, GPK0 and GPM0

Re: [PATCH v2 1/6] mmc: dw_mmc: convert copy of struct device in struct dw_mci to a reference

2012-05-17 Thread Jaehoon Chung
Hi Thomas, I think that also need to consider for using dw_mci-pci.c. Best Regards, Jaehoon chung On 05/18/2012 12:10 AM, Thomas Abraham wrote: The 'struct dw_mci' maintains a copy of the pdev-dev instance instead of maintaining a reference to that 'struct device' instance. Any resource

Re: [PATCH 1/2] ARM: EXYYNOS: Use EXYNOS4210_GPEx instead of EXYNOS4_GPEx

2012-05-17 Thread Joonyoung Shim
Add to cc Grant Likely and Linus Walleij On 05/18/2012 11:18 AM, Joonyoung Shim wrote: Also use EXYNOS4210_GPIO_Ex instead of EXYNOS4_GPIO_Ex. The GPEx gpios exist only on Exynos4210 and there are no on Exynos4x12. Redefine them to exact SoC name. Signed-off-by: Joonyoung

Re: [PATCH 2/2] gpio/exynos: Add support for Exynos4x12 SoC

2012-05-17 Thread Joonyoung Shim
Add to cc Grant Likely and Linus Walleij On 05/18/2012 11:18 AM, Joonyoung Shim wrote: Exynos4x12 GPIO part1 and part2 layouts are different with that of Exynos4210. So, it needs to support gpios for Exynos4x12 SoC. This doesn't support GPVx Exynos4x12 GPIO part4 yet. In the Exynos4x12 GPIO

[PATCH 0/2] ARM: EXYNOS: G2D clock support to Exynos4

2012-05-17 Thread Sachin Kamat
This patch series moves the SoC specific G2D clock entries from common clock file (clock-exynos4.c) to Exynos4210 specific clock file (clock-exynos4210.c) since G2D clock registers are different in Exynos4210 and Exynos4X12 SoCs and adds support for Exynos4x12 G2D clock. This series is based on

[PATCH 1/2] ARM: EXYNOS: Move G2D clock entries to clock-exynos4210.c file

2012-05-17 Thread Sachin Kamat
G2D clock registers are different in Exynos4210 and Exynos4X12 SoCs. Hence moving the SoC specific G2D clock entries from common clock file (clock-exynos4.c) to Exynos4210 specific clock file (clock-exynos4210.c). Signed-off-by: Sachin Kamat sachin.ka...@linaro.org ---

[PATCH 2/2] ARM: EXYNOS: Add G2D related clock entries for SMDK4X12

2012-05-17 Thread Sachin Kamat
Adds G2D related clock entries for SMDK4X12 boards. Signed-off-by: Sachin Kamat sachin.ka...@linaro.org --- arch/arm/mach-exynos/clock-exynos4212.c | 41 +- 1 files changed, 39 insertions(+), 2 deletions(-) diff --git a/arch/arm/mach-exynos/clock-exynos4212.c