Re: [PATCH v4 23/32] cxlflash: Fix function prolog parameters and return codes

2015-09-28 Thread Andrew Donnellan
On 26/09/15 09:18, Matthew R. Ochs wrote: Several function prologs have incorrect parameter names and return code descriptions. This can lead to confusion when reviewing the source and creates inaccurate documentation. To remedy, update the function prologs to properly reflect parameter names

Re: [PATCH v4 12/32] cxlflash: Fix to avoid spamming the kernel log

2015-09-28 Thread Andrew Donnellan
On 26/09/15 09:15, Matthew R. Ochs wrote: During run-time the driver can be very chatty and spam the system kernel log. Various print statements can be limited and/or moved to development-only mode. Additionally, numerous prints can be converted to trace the corresponding device. The following

Re: [PATCH v4 02/32] cxlflash: Replace magic numbers with literals

2015-09-28 Thread Andrew Donnellan
On 26/09/15 09:12, Matthew R. Ochs wrote: From: Manoj Kumar Magic numbers are not meaningful and can create confusion. As a remedy, replace them with descriptive literals. Replace 512 with literal MAX_SECTOR_UNIT. Replace 5 with literal CMD_RETRIES. Signed-off-by: Matthew

Re: [PATCH v4 11/32] cxlflash: Refine host/device attributes

2015-09-28 Thread Andrew Donnellan
On 26/09/15 09:14, Matthew R. Ochs wrote: Implement the following suggestions and add two new attributes to allow for debugging the port LUN table. - use scnprintf() instead of snprintf() - use DEVICE_ATTR_RO and DEVICE_ATTR_RW Suggested-by: Shane Seymour

[Bug 101011] Kernel Oops when disconnecting a mounted ext4 usb stick

2015-09-28 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=101011 Ronny Standtke changed: What|Removed |Added CC|

Re: [PATCH 1/3] ibmvsci: make parameters max_id and max_channel read-only

2015-09-28 Thread Tyrel Datwyler
On 09/10/2015 02:23 AM, Laurent Vivier wrote: > The value of the parameter is never re-read by the driver, > so a new value is ignored. Let know the user he > can't modify it by removing writable attribute. > > Signed-off-by: Laurent Vivier Acked-by: Tyrel Datwyler

[Bug 101011] Kernel Oops when disconnecting a mounted ext4 usb stick

2015-09-28 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=101011 Theodore Tso changed: What|Removed |Added CC||ty...@mit.edu --- Comment

[Bug 101011] Kernel Oops when disconnecting a mounted ext4 usb stick

2015-09-28 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=101011 Theodore Tso changed: What|Removed |Added Status|NEW |RESOLVED

Re: [PATCH 3/3] ibmvsci: Allow to configure maximum LUN

2015-09-28 Thread Tyrel Datwyler
On 09/10/2015 02:23 AM, Laurent Vivier wrote: > QEMU allows until 32 LUNs. > > Signed-off-by: Laurent Vivier Acked-by: Tyrel Datwyler > --- > drivers/scsi/ibmvscsi/ibmvscsi.c | 5 - > 1 file changed, 4 insertions(+), 1 deletion(-) > > diff

Re: [PATCH 2/3] ibmvcsci: display default value for max_id, max_lun and max_channel.

2015-09-28 Thread Tyrel Datwyler
On 09/10/2015 02:23 AM, Laurent Vivier wrote: > As devices with values greater than that are silently ignored, > this gives some hints to the sys admin to know why he doesn't see > his devices... > > Signed-off-by: Laurent Vivier Acked-by: Tyrel Datwyler

RE: [PATCH V4 1/2] ACPI / EC: Fix broken 64bit big-endian users of 'global_lock'

2015-09-28 Thread David Laight
From: James Bottomley [mailto:james.bottom...@hansenpartnership.com] > Sent: 28 September 2015 15:27 > On Mon, 2015-09-28 at 08:58 +, David Laight wrote: > > From: Rafael J. Wysocki > > > Sent: 27 September 2015 15:09 > > ... > > > > > Say you have three adjacent fields in a structure, x, y,

Re: [PATCH V4 1/2] ACPI / EC: Fix broken 64bit big-endian users of 'global_lock'

2015-09-28 Thread James Bottomley
On Mon, 2015-09-28 at 14:50 +, David Laight wrote: > From: James Bottomley [mailto:james.bottom...@hansenpartnership.com] > > Sent: 28 September 2015 15:27 > > On Mon, 2015-09-28 at 08:58 +, David Laight wrote: > > > From: Rafael J. Wysocki > > > > Sent: 27 September 2015 15:09 > > > ... >

RE: [PATCH V4 1/2] ACPI / EC: Fix broken 64bit big-endian users of 'global_lock'

2015-09-28 Thread David Laight
From: James Bottomley > Sent: 28 September 2015 16:12 > > > > The x86 cpus will also do 32bit wide rmw cycles for the 'bit' > > > > operations. > > > > > > That's different: it's an atomic RMW operation. The problem with the > > > alpha was that the operation wasn't atomic (meaning that it

Re: [PATCH V4 1/2] ACPI / EC: Fix broken 64bit big-endian users of 'global_lock'

2015-09-28 Thread James Bottomley
On Mon, 2015-09-28 at 08:58 +, David Laight wrote: > From: Rafael J. Wysocki > > Sent: 27 September 2015 15:09 > ... > > > > Say you have three adjacent fields in a structure, x, y, z, each one > > > > byte long. > > > > Initially, all of them are equal to 0. > > > > > > > > CPU A writes 1 to

Re: [PATCH v3 4/4] scsi: provide UAPI version of scsi/sg.h and scsi/scsi_ioctl.h

2015-09-28 Thread kbuild test robot
Hi Paolo, [auto build test results on v4.3-rc2 -- if it's inappropriate base, please ignore] config: i386-randconfig-a0-201538 (attached as .config) reproduce: git checkout d88f2083643f6dfacba14b2e95217dc6e0a4be37 # save the attached .config to linux build tree make ARCH=i386 All

Re: [PATCH v3 3/4] scsi: move all obsolete ioctls to scsi_ioctl.h

2015-09-28 Thread Douglas Gilbert
On 15-09-25 11:27 AM, Paolo Bonzini wrote: Some are in scsi.h. Keep them together in preparation for exposing them in UAPI headers. Cc: James Bottomley Cc: Christoph Hellwig Cc: linux-scsi@vger.kernel.org Reviewed-by: Bart Van Assche

Re: [PATCH V4 1/2] ACPI / EC: Fix broken 64bit big-endian users of 'global_lock'

2015-09-28 Thread Arnd Bergmann
On Sunday 27 September 2015 16:10:48 Rafael J. Wysocki wrote: > On Saturday, September 26, 2015 09:33:56 PM Arnd Bergmann wrote: > > On Saturday 26 September 2015 11:40:00 Viresh Kumar wrote: > > > On 25 September 2015 at 15:19, Rafael J. Wysocki > > > wrote: > > > > So if you

Re: [PATCH 15/23] scsi_dh_alua: simplify sense code handling

2015-09-28 Thread Hannes Reinecke
On 09/22/2015 09:10 PM, Ewan Milne wrote: > On Thu, 2015-08-27 at 14:41 +0200, Hannes Reinecke wrote: >> Most sense code is already handled in the generic >> code, so we shouldn't be adding special cases here. >> However, when doing so we need to check for >> unit attention whenever we're sending

Re: [PATCH 16/23] scsi: Add scsi_vpd_lun_id()

2015-09-28 Thread Hannes Reinecke
On 09/22/2015 09:17 PM, Ewan Milne wrote: [ .. ] > > scsi_vpd_lun_id() is an exported function, but does not check if > sdev->vpd_pg83 != NULL > (i.e. no VPD 83 info), and we will crash if it is NULL. Also, why return > -EAGAIN? > What will be different next time? Maybe a different errno

Re: [PATCH v3 2/4] scsi: cleanup scsi/scsi_ioctl.h

2015-09-28 Thread Douglas Gilbert
On 15-09-25 11:27 AM, Paolo Bonzini wrote: SCSI_REMOVAL_* goes together with other SCSI command constants in include/scsi/scsi.h. It is also used outside the implementation of the ioctls (and it is not part of the user API). scsi_fctargaddress/Scsi_FCTargAddress has had no in-tree use since

Re: [PATCH v3 1/4] scsi: remove old-style type names from sg.h

2015-09-28 Thread Douglas Gilbert
On 15-09-25 11:27 AM, Paolo Bonzini wrote: These will not be exported by the new linux/sg.h header, and scsi/sg.h will not have any user API after linux/sg.h is created. Since they have no user in the kernel, they can be zapped. Cc: James Bottomley Cc: Christoph

Re: [PATCH 17/23] scsi_dh_alua: use unique device id

2015-09-28 Thread Hannes Reinecke
On 09/22/2015 09:31 PM, Ewan Milne wrote: > On Thu, 2015-08-27 at 14:41 +0200, Hannes Reinecke wrote: >> Use scsi_vpd_lun_id() to assign a unique device identification >> to the alua port group structure. >> >> Signed-off-by: Hannes Reinecke >> --- >>

Re: [PATCH V4 1/2] ACPI / EC: Fix broken 64bit big-endian users of 'global_lock'

2015-09-28 Thread Rafael J. Wysocki
On Monday, September 28, 2015 10:24:58 AM Arnd Bergmann wrote: > On Sunday 27 September 2015 16:10:48 Rafael J. Wysocki wrote: > > On Saturday, September 26, 2015 09:33:56 PM Arnd Bergmann wrote: > > > On Saturday 26 September 2015 11:40:00 Viresh Kumar wrote: > > > > On 25 September 2015 at

RE: [PATCH V4 1/2] ACPI / EC: Fix broken 64bit big-endian users of 'global_lock'

2015-09-28 Thread David Laight
From: Rafael J. Wysocki > Sent: 27 September 2015 15:09 ... > > > Say you have three adjacent fields in a structure, x, y, z, each one byte > > > long. > > > Initially, all of them are equal to 0. > > > > > > CPU A writes 1 to x and CPU B writes 2 to y at the same time. > > > > > > What's the

Re: [PATCH v4 08/32] cxlflash: Fix to avoid CXL services during EEH

2015-09-28 Thread Brian King
Reviewed-by: Brian King -- Brian King Power Linux I/O IBM Linux Technology Center -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majord...@vger.kernel.org More majordomo info at

Re: [PATCH v4 07/32] cxlflash: Fix context encode mask width

2015-09-28 Thread Daniel Axtens
-BEGIN PGP SIGNED MESSAGE- Hash: SHA512 Looks good to me. Reviewed-by: Daniel Axtens Regards, Daniel "Matthew R. Ochs" writes: > The context encode mask covers more than 32-bits, making it > a long integer. This should be noted by

Re: [PATCH v4 09/32] cxlflash: Correct naming of limbo state and waitq

2015-09-28 Thread Daniel Axtens
-BEGIN PGP SIGNED MESSAGE- Hash: SHA512 "Matthew R. Ochs" writes: Looks good from an EEH point of view: in an error situation, your driver asks to be reset and then is waiting for CXL and EEH to carry that out, so 'reset' matches with that as well.

Re: [PATCH v4 06/32] cxlflash: Fix to avoid sizeof(bool)

2015-09-28 Thread Daniel Axtens
-BEGIN PGP SIGNED MESSAGE- Hash: SHA512 Looks good to me. Reviewed-by: Daniel Axtens Regards, Daniel "Matthew R. Ochs" writes: > Using sizeof(bool) is considered poor form for various reasons and > sparse warns us of that. Correct by

Re: [PATCH v4 08/32] cxlflash: Fix to avoid CXL services during EEH

2015-09-28 Thread Daniel Axtens
You have two versions of check_state() below, which is a bit confusing. It looks like you've moved the function and also added the up/down of the read semaphore. I assume that's all that changed? > > /** > + * check_state() - checks and responds to the current adapter state > + * @cfg:

Re: [PATCH v4 17/32] cxlflash: Remove dual port online dependency

2015-09-28 Thread Daniel Axtens
-BEGIN PGP SIGNED MESSAGE- Hash: SHA512 Hi, > static int afu_set_wwpn(struct afu *afu, int port, u64 *fc_regs, u64 wwpn) > { > - int ret = 0; > + int rc = 0; I realise it's nice to have things consistent, but making this change now makes the rest of the patch quite difficult to

Re: [PATCH v4 32/32] cxlflash: Fix to avoid potential deadlock on EEH

2015-09-28 Thread Brian King
On 09/25/2015 06:19 PM, Matthew R. Ochs wrote: > static int write_same16(struct scsi_device *sdev, > @@ -433,9 +451,20 @@ static int write_same16(struct scsi_device *sdev, > put_unaligned_be32(ws_limit < left ? ws_limit : left, > _cmd[10]); > > +

Re: [PATCH v4 27/32] cxlflash: Fix to prevent stale AFU RRQ

2015-09-28 Thread Daniel Axtens
-BEGIN PGP SIGNED MESSAGE- Hash: SHA512 "Matthew R. Ochs" writes: > Following an adapter reset, the AFU RRQ that resides in host memory > holds stale data. This can lead to a condition where the RRQ interrupt > handler tries to process stale entries and/or

Re: [PATCH v4 29/32] cxlflash: Fix to double the delay each time

2015-09-28 Thread Daniel Axtens
-BEGIN PGP SIGNED MESSAGE- Hash: SHA512 "Matthew R. Ochs" writes: > From: Manoj Kumar > > The operator used to double the delay is incorrect and > does not result in delay doubling. > > To fix, use a left shift instead of the XOR

Re: [PATCH v4 24/32] cxlflash: Fix MMIO and endianness errors

2015-09-28 Thread Andrew Donnellan
On 26/09/15 09:18, Matthew R. Ochs wrote: Sparse uncovered several errors with MMIO operations (accessing directly) and handling endianness. These can cause issues when running in different environments. Introduce __iomem and proper endianness tags/swaps where appropriate to make driver sparse

Re: [PATCH v4 25/32] cxlflash: Fix to prevent EEH recovery failure

2015-09-28 Thread Daniel Axtens
-BEGIN PGP SIGNED MESSAGE- Hash: SHA512 "Matthew R. Ochs" writes: > The process_sense() routine can perform a read capacity which > can take some time to complete. If an EEH occurs while waiting > on the read capacity, the EEH handler is unable to obtain the

Re: [PATCH v4 26/32] cxlflash: Correct spelling, grammar, and alignment mistakes

2015-09-28 Thread Andrew Donnellan
On 26/09/15 09:18, Matthew R. Ochs wrote: There are several spelling and grammar mistakes throughout the driver. Additionally there are a handful of places where there are extra lines and unnecessary variables/statements. These are a nuisance and pollute the driver. Fix spelling and grammar

Re: [PATCH v4 31/32] cxlflash: Correct trace string

2015-09-28 Thread Andrew Donnellan
On 26/09/15 09:19, Matthew R. Ochs wrote: The trace following the failure of alloc_mem() incorrectly identifies which function failed. This can lead to misdiagnosing a failure. Fix the string to correctly indicate that alloc_mem() failed. Reported-by: Brian King