Re: [PATCH 2/6] qla2xxx_nvmet: Added Makefile and Kconfig changes

2018-09-17 Thread Madhani, Himanshu
> On Sep 15, 2018, at 9:53 PM, Bart Van Assche wrote: > > External Email > > On 09/14/18 14:28, Himanshu Madhani wrote: >> diff --git a/drivers/scsi/qla2xxx/Kconfig b/drivers/scsi/qla2xxx/Kconfig >> index 036cc3f217b1..f1539d8b68ef 100644 >> --- a/drivers/scsi/qla2xxx/Kconfig >> +++

Re: [PATCH 3/6] qla2xxx_nvmet: Add FC-NVMe Target LS request handling

2018-09-17 Thread Madhani, Himanshu
> On Sep 16, 2018, at 6:42 AM, Bart Van Assche wrote: > > External Email > > On 09/14/18 14:28, Himanshu Madhani wrote: >> From: Anil Gurumurthy >> >> This patch adds LS handling into driver > > Please make the patch description more clear. What does "LS" stand for? > What is the

Re: [PATCH 2/6] qla2xxx_nvmet: Added Makefile and Kconfig changes

2018-09-17 Thread Bart Van Assche
On 9/17/18 12:07 PM, Madhani, Himanshu wrote: On Sep 15, 2018, at 9:53 PM, Bart Van Assche wrote: External Email On 09/14/18 14:28, Himanshu Madhani wrote: diff --git a/drivers/scsi/qla2xxx/Kconfig b/drivers/scsi/qla2xxx/Kconfig index 036cc3f217b1..f1539d8b68ef 100644 ---

Re: [PATCH 2/6] qla2xxx_nvmet: Added Makefile and Kconfig changes

2018-09-17 Thread Madhani, Himanshu
> On Sep 17, 2018, at 1:03 PM, Bart Van Assche wrote: > > External Email > > On 9/17/18 12:07 PM, Madhani, Himanshu wrote: >> >>> On Sep 15, 2018, at 9:53 PM, Bart Van Assche wrote: >>> >>> External Email >>> >>> On 09/14/18 14:28, Himanshu Madhani wrote: diff --git

[PATCH v5 6/6] scsi: ufs-bsg: Add support for uic commands in ufs_bsg_request()

2018-09-17 Thread Avri Altman
Add support to those uic commands, that are currently supported by ufshcd api: the variants of dme_{peer}_{set_get}. At this point better not to add any new api, as careless uic command may turn the device into a brick. Signed-off-by: Avri Altman --- drivers/scsi/ufs/ufs_bsg.c | 54

[PATCH v5 4/6] scsi: ufs: Add API to execute raw upiu commands

2018-09-17 Thread Avri Altman
The UFS host software uses a combination of a host register set, and Transfer Request Descriptors in system memory to communicate with host controller hardware. In its mmio space, a separate places are assigned to UTP Transfer Request Descriptor ("utrd") list, and to UTP Task Management Request

[PATCH v5 1/6] scsi: ufs: cleanup struct utp_task_req_desc

2018-09-17 Thread Avri Altman
From: Christoph Hellwig Remove the pointless task_req_upiu and task_rsp_upiu indirections, which are __le32 arrays always cast to given structures and just add the members directly. Also clean up variables names in use in the callers a bit to make the code more readable. Signed-off-by:

[PATCH v5 2/6] scsi: ufs: add a low-level __ufshcd_issue_tm_cmd helper

2018-09-17 Thread Avri Altman
From: Christoph Hellwig Add a helper that takes a utp_task_req_desc and issues it, which will be useful for UFS bsg support. Rewrite ufshcd_issue_tm_cmd0x to use this new helper. Signed-off-by: Christoph Hellwig --- drivers/scsi/ufs/ufshcd.c | 141

[PATCH v5 0/6] scsi: Add ufs bsg endpoint

2018-09-17 Thread Avri Altman
Here is a proposal to use a bsg endpoint to manage ufs devices. We will do that by adding a bsg device node to the ufs driver, and use it to send UPIU transactions to the ufs device. It will serve as a ufs device management infrastructure, for device configuration, provisioning, testing and

Re: [PATCH 1/6] qla2xxx_nvmet: Add files for FC-NVMe Target support

2018-09-17 Thread Madhani, Himanshu
Hi Bart, > On Sep 15, 2018, at 9:50 PM, Bart Van Assche wrote: > > External Email > > On 09/14/18 14:28, Himanshu Madhani wrote: >> diff --git a/drivers/scsi/qla2xxx/qla_nvmet.c >> b/drivers/scsi/qla2xxx/qla_nvmet.c >> new file mode 100644 >> [ ... ] >> +#if

Re: [PATCH -next] scsi: lpfc: Remove set but not used variable 'sgl_size'

2018-09-17 Thread Martin K. Petersen
YueHaibing, > Fixes gcc '-Wunused-but-set-variable' warning: > > drivers/scsi/lpfc/lpfc_nvme.c: In function 'lpfc_new_nvme_buf': > drivers/scsi/lpfc/lpfc_nvme.c:2238:24: warning: > variable 'sgl_size' set but not used [-Wunused-but-set-variable] > int bcnt, num_posted, sgl_size; >

Re: [PATCH -next] scsi: aic7xxx: remove set but not used variable 'shared_scb_data'

2018-09-17 Thread Martin K. Petersen
YueHaibing, > Fixes gcc '-Wunused-but-set-variable' warning: > > drivers/scsi/aic7xxx/aic79xx_pci.c: In function 'ahd_pci_config': > drivers/scsi/aic7xxx/aic79xx_pci.c:291:19: warning: > variable 'shared_scb_data' set but not used [-Wunused-but-set-variable] Applied to 4.20/scsi-queue, thank

Re: [PATCH -next] scsi: bnx2fc: Remove set but not used variable 'oxid'

2018-09-17 Thread Martin K. Petersen
YueHaibing, > Fixes gcc '-Wunused-but-set-variable' warning: > > drivers/scsi/bnx2fc/bnx2fc_fcoe.c: In function 'bnx2fc_rcv': > drivers/scsi/bnx2fc/bnx2fc_fcoe.c:435:17: warning: > variable 'oxid' set but not used [-Wunused-but-set-variable] Applied to 4.20/scsi-queue, thanks! -- Martin K.

Re: [PATCH -next] scsi: qla2xxx: Remove set but not used variable 'ptr_dma'

2018-09-17 Thread Martin K. Petersen
YueHaibing, > Fixes gcc '-Wunused-but-set-variable' warning: > > drivers/scsi/qla2xxx/qla_iocb.c: In function 'qla24xx_els_dcmd2_iocb': > drivers/scsi/qla2xxx/qla_iocb.c:2644:13: warning: > variable 'ptr_dma' set but not used [-Wunused-but-set-variable] Applied to 4.20/scsi-queue. Thanks! --

Re: [PATCH -next] scsi: pm80xx: Remove set but not used variable 'page_code'

2018-09-17 Thread Martin K. Petersen
YueHaibing, > Fixes gcc '-Wunused-but-set-variable' warning: > > drivers/scsi/pm8001/pm80xx_hwi.c: In function 'pm8001_set_phy_profile': > drivers/scsi/pm8001/pm80xx_hwi.c:4679:6: warning: > variable 'page_code' set but not used [-Wunused-but-set-variable] Applied to 4.20/scsi-queue, thanks!

RE: [PATCH v4 4/7] scsi: ufs: Add ufs-bsg module

2018-09-17 Thread Avri Altman
> > > @@ -5,6 +5,9 @@ obj-$(CONFIG_SCSI_UFS_DWC_TC_PLATFORM) += tc- > dwc-g210-pltfrm.o ufshcd-dwc.o tc-d > > obj-$(CONFIG_SCSI_UFS_QCOM) += ufs-qcom.o > > obj-$(CONFIG_SCSI_UFSHCD) += ufshcd-core.o > > ufshcd-core-objs := ufshcd.o ufs-sysfs.o > > +ifeq ($(CONFIG_SCSI_UFS_BSG),y) > >

Re: [PATCH -next] scsi: pm80xx: Remove set but not used variable 'device_id'

2018-09-17 Thread Martin K. Petersen
YueHaibing, > Fixes gcc '-Wunused-but-set-variable' warning: > > drivers/scsi/pm8001/pm8001_sas.c: In function > 'pm8001_I_T_nexus_event_handler': > drivers/scsi/pm8001/pm8001_sas.c:1052:6: warning: > variable 'device_id' set but not used [-Wunused-but-set-variable] > >