Re: [PATCH 099/306] mac80211-hwsim: notify user-space about channel change.

2017-02-23 Thread Johannes Berg
> + msg_head = genlmsg_put(skb, 0, 0, _genl_family, 0, > +    HWSIM_CMD_NOTIFY); I think you should use a more specific command name. > + if (nla_put(skb, HWSIM_ATTR_ADDR_TRANSMITTER, > + ETH_ALEN, data->addresses[1].addr)) > + goto

Re: [PATCH 162/306] mac80211-hwsim: add length checks before allocating skb.

2017-02-23 Thread Johannes Berg
And here's the third patch in a row modifying the same code ... johannes

Re: [PATCH 161/306] mac80211-hwsim: Improve logging.

2017-02-23 Thread Johannes Berg
> + static unsigned int cnt = 0; > + /* This is fairly common, and usually not a > bug.  So, print errors > +    rarely. */ > + if (((cnt++ & 0x3FF) == 0x3FF) && net_ratelimit()) > + printk(KERN_DEBUG " hwsim rx-nl: radio %pM >

Re: [Outreachy kernel] [PATCH v3 1/3] staging: wilc1000: Rename struct tstrRSSI to rssi_history_buffer

2017-02-23 Thread Julia Lawall
On Fri, 24 Feb 2017, Tahia Khan wrote: > Rename struct tstrRSSI to rssi_history_buffer for clarity and to remove camel > casing. Here the commit log messge line is definitely too long. julia > > Signed-off-by: Tahia Khan > --- >

Re: [Outreachy kernel] [PATCH v3 2/3] staging: wilc1000: Rename tstrRSSI members and change type of u8Full to bool

2017-02-23 Thread Julia Lawall
On Fri, 24 Feb 2017, Tahia Khan wrote: > Remove Hungarian notation and camel casing from all tstrRSSI members' names. > Additionally, change type of u8Full to bool since it only takes values 1 or 0. Acked-by: Julia Lawall Maybe the second line of the commit message is a

Re: [PATCH 160/306] mac80211-hwsim: add rate-limited debugging for rx-netlink

2017-02-23 Thread Johannes Berg
> + !info->attrs[HWSIM_ATTR_SIGNAL]) { > + if (net_ratelimit()) > + printk(KERN_DEBUG " hwsim rx-nl: Missing > required attribute\n"); I'm not convinced net_ratelimit() is a good idea, that's a global rate limiter. johannes

Re: [PATCH 102/306] mac80211-hwsim: enable better rx-status when using netlink.

2017-02-23 Thread Johannes Berg
> +/** > + * This relates to the ieee80211_rx_status struct in mac80211.h > + * @rx_flags: %RX_FLAG_* (see  mac80211_rx_flags) > + * @vht_flags: %RX_VHT_FLAG_* > + * @vht_nss: number of streams (VHT only) > + * @ampdu_reference: A-MPDU reference number, must be a different > value for > + *

Re: [PATCH 100/306] mac80211-hwsim: remove dmesg spam about get-survey.

2017-02-23 Thread Johannes Berg
On Thu, 2017-02-23 at 16:28 -0800, gree...@candelatech.com wrote: > From: Ben Greear > > This message just fills up dmesg and/or kernel logs and does > not provide any useful information. Fine, but don't just comment it out. johannes

[PATCH v3 2/3] staging: wilc1000: Rename tstrRSSI members and change type of u8Full to bool

2017-02-23 Thread Tahia Khan
Remove Hungarian notation and camel casing from all tstrRSSI members' names. Additionally, change type of u8Full to bool since it only takes values 1 or 0. Signed-off-by: Tahia Khan --- drivers/staging/wilc1000/coreconfigurator.h | 6 +++---

[PATCH v3 3/3] staging: wilc1000: Rename network_info member str_rssi to rssi_history

2017-02-23 Thread Tahia Khan
Change name of str_rssi to rssi_history within the network_info struct for clarity. Signed-off-by: Tahia Khan --- drivers/staging/wilc1000/coreconfigurator.h | 2 +- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 14 +++--- 2 files changed, 8

[PATCH v3 0/3] staging: wilc1000: multiple coding style changes to struct tstrRSSI

2017-02-23 Thread Tahia Khan
Multiple coding style changes to struct tstrRSSI. Initially reported by checkpath.pl: Avoid CamelCase: Avoid CamelCase: Avoid CamelCase: Changes since v2: Renaming tstrRSSI and members with more descriptive names, as suggested by Arend Van Spriel Tahia

Re: [PATCH v2] wireless-regdb: Update rules for Australia (AU) and add 60GHz rules

2017-02-23 Thread Ryan Mounce
On 24 February 2017 at 02:05, Seth Forshee wrote: > On Fri, Feb 24, 2017 at 12:22:53AM +1030, Ryan Mounce wrote: >> Sourced from the current legislation at >> https://www.legislation.gov.au/Details/F2016C00432 >> >> The current rules exceed legal limits between

Re: [PATCH 2/2][RFC] mac80211_hwsim: Report radio addresses in NEW_RADIO/GET_RADIO

2017-02-23 Thread Ben Greear
On 02/23/2017 04:02 PM, Andrew Zaborowski wrote: On 23 February 2017 at 20:01, Benjamin Beichler wrote: Add a HWSIM_ATTR_RADIO_ADDR attribute to those to events/response so that a userspace medium can query the list of addresses in the simulator. When a

[PATCH 100/306] mac80211-hwsim: remove dmesg spam about get-survey.

2017-02-23 Thread greearb
From: Ben Greear This message just fills up dmesg and/or kernel logs and does not provide any useful information. Signed-off-by: Ben Greear --- drivers/net/wireless/mac80211_hwsim.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff

[PATCH 162/306] mac80211-hwsim: add length checks before allocating skb.

2017-02-23 Thread greearb
From: Ben Greear Modify the receive-from-user-space logic to do length and 'is-down' checks before trying to allocate an skb. And, if we are going to ignore the pkt due to radio idle, then do not return an error code to user-space. User-space cannot reliably know

[PATCH 101/306] mac80211-hwsim: Pass rate-ctrl flags and tx-power to user-space

2017-02-23 Thread greearb
From: Ben Greear The flags field allows user-space to properly decode what the rate->idx really means. The tx-power field is useful as well, in case user-space is interested in doing something clever with path-loss calculations. Signed-off-by: Ben Greear

[PATCH 161/306] mac80211-hwsim: Improve logging.

2017-02-23 Thread greearb
From: Ben Greear Signed-off-by: Ben Greear --- drivers/net/wireless/mac80211_hwsim.c | 13 - 1 file changed, 8 insertions(+), 5 deletions(-) diff --git a/drivers/net/wireless/mac80211_hwsim.c

[PATCH 099/306] mac80211-hwsim: notify user-space about channel change.

2017-02-23 Thread greearb
From: Ben Greear The goal is to allow the user-space application to properly filter packets before sending them down to the kernel. This should more closely mimic what a real piece of hardware would do. Signed-off-by: Ben Greear ---

[PATCH 102/306] mac80211-hwsim: enable better rx-status when using netlink.

2017-02-23 Thread greearb
From: Ben Greear This allows proper rx-status reporting for packets received from the netlink api. Signed-off-by: Ben Greear --- drivers/net/wireless/mac80211_hwsim.c | 10 ++ drivers/net/wireless/mac80211_hwsim.h | 18

[PATCH 160/306] mac80211-hwsim: add rate-limited debugging for rx-netlink

2017-02-23 Thread greearb
From: Ben Greear This makes it easier to understand why wmediumd (or similar) is getting errors when sending frames to the kernel. Signed-off-by: Ben Greear --- drivers/net/wireless/mac80211_hwsim.c | 42 ++- 1

Re: [PATCH 1/2] mac80211_hwsim: Make sure NEW_RADIO contains final name

2017-02-23 Thread Andrew Zaborowski
On 23 February 2017 at 13:02, Andrew Zaborowski wrote: > ieee80211_alloc_hw_nm will validate the requested name (if any) before > creating the new device and may use a name different from the one > requested rather than fail. Make sure the HWSIM_CMD_NEW_RADIO >

Re: [PATCH 2/2][RFC] mac80211_hwsim: Report radio addresses in NEW_RADIO/GET_RADIO

2017-02-23 Thread Andrew Zaborowski
On 23 February 2017 at 20:01, Benjamin Beichler wrote: >> Add a HWSIM_ATTR_RADIO_ADDR attribute to those to events/response so >> that a userspace medium can query the list of addresses in the >> simulator. >> >> When a userspace medium needs to handle a

brcmfmac: problem using WPS with wpa_supplicant on BCM43362

2017-02-23 Thread Jörg Krause
Hi, I am using Linux Kernel v4.9.9 and wpa_supplicant 2.6. When running 'wpa_cli wps_pin any', the following messages are printed: """ > wps_pin any  [ 4011.779108] brcmfmac: brcmf_vif_set_mgmt_ie: vndr ie set error : -30 [ 4011.786190] brcmfmac: brcmf_config_ap_mgmt_ie: Set Beacon IE

Re: [PATCH V3 4/9] brcmfmac: add struct brcmf_pub parameter to the __brcmf_err

2017-02-23 Thread Rafał Miłecki
Hey Arend, On 8 February 2017 at 10:54, Arend Van Spriel wrote: > On 2-2-2017 22:33, Rafał Miłecki wrote: >> From: Rafał Miłecki >> >> This will allow getting struct device reference from the passed >> brcmf_pub for the needs of dev_err. More

Re: [PATCH V3 4/9] brcmfmac: add struct brcmf_pub parameter to the __brcmf_err

2017-02-23 Thread Rafał Miłecki
On 8 February 2017 at 10:54, Arend Van Spriel wrote: > On 2-2-2017 22:33, Rafał Miłecki wrote: >> From: Rafał Miłecki >> >> This will allow getting struct device reference from the passed >> brcmf_pub for the needs of dev_err. More detailed

Re: [PATCH 2/2][RFC] mac80211_hwsim: Report radio addresses in NEW_RADIO/GET_RADIO

2017-02-23 Thread Benjamin Beichler
> Add a HWSIM_ATTR_RADIO_ADDR attribute to those to events/response so > that a userspace medium can query the list of addresses in the > simulator. > > When a userspace medium needs to handle a broadcast frame it can't > easily implement the equivalent of what the default kernel medium does >

[PATCH V4 2/2] brcmfmac: don't warn user about NVRAM if fallback to platform one succeeds

2017-02-23 Thread Rafał Miłecki
From: Rafał Miłecki Failing to load NVRAM file isn't critical if we manage to get platform one in the fallback path. It means warnings like: [ 10.801506] brcmfmac :01:00.0: Direct firmware load for brcm/brcmfmac43602-pcie.txt failed with error -2 are unnecessary &

[PATCH V4 1/2] firmware: add more flexible request_firmware_async function

2017-02-23 Thread Rafał Miłecki
From: Rafał Miłecki So far we got only one function for loading firmware asynchronously: request_firmware_nowait. It didn't allow much customization of firmware loading process - there is only one bool uevent argument. Moreover this bool also controls user helper in an unclear

RE:

2017-02-23 Thread Qin's Yanjun
How are you today and your family? I require your attention and honest co-operation about some issues which i will really want to discuss with you which. Looking forward to read from you soon. Qin's __ Sky Silk, http://aknet.kz

[PATCH 0/4] rtlwifi: Various updates

2017-02-23 Thread Larry Finger
These changes implement new phy parameters for RTL8821AE and RTL8812AE devices, and add some new pre-loaded packets to the reserved pages of various devices. Signed-off-by: Larry Finger Larry Finger (1): rtlwifi: Add code to read new versions of firmware Ping-Ke

[PATCH 1/4] rtlwifi: Update 8821ae new phy parameters and its parser.

2017-02-23 Thread Larry Finger
From: Ping-Ke Shih There are new PHY table values for the RTL8821AE. The changes require new parsing code. Signed-off-by: Ping-Ke Shih Signed-off-by: Larry Finger --- .../net/wireless/realtek/rtlwifi/rtl8821ae/phy.c | 377

[PATCH 4/4] rtlwifi: Add QoS-NULL and BT-QoS-NULL to reserved page.

2017-02-23 Thread Larry Finger
From: Ping-Ke Shih Two additional preset responses are added to the reserved page on the wifi device. Signed-off-by: Ping-Ke Shih Signed-off-by: Larry Finger --- .../net/wireless/realtek/rtlwifi/rtl8192ee/fw.c| 64

[PATCH 3/4] rtlwifi: Add code to read new versions of firmware

2017-02-23 Thread Larry Finger
Changes in the drivers for RTL8723BE and RTL8821AE require corresponding changes in the firmware. This new firmware has been accepted into the Linux firmware repo. To handle the case where the kernel has been updated before the firmware, the new versions have been given new names. The code will

[PATCH 2/4] rtlwifi: Update 8812ae new phy parameters and its parser.

2017-02-23 Thread Larry Finger
From: Ping-Ke Shih Update PHY tables for the RTL8812AE. A new parser is also needed. Signed-off-by: Ping-Ke Shih Signed-off-by: Larry Finger --- .../net/wireless/realtek/rtlwifi/rtl8821ae/phy.c |8 +-

[PATCH] wireless/atmel: remove time_t usage

2017-02-23 Thread Alexandre Belloni
last_qual never really holds a time. It only holds jiffies. Make it the same type as jiffies. Signed-off-by: Alexandre Belloni --- drivers/net/wireless/atmel/atmel.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

Re: [PATCH v2] wireless-regdb: Update rules for Australia (AU) and add 60GHz rules

2017-02-23 Thread Seth Forshee
On Fri, Feb 24, 2017 at 12:22:53AM +1030, Ryan Mounce wrote: > Sourced from the current legislation at > https://www.legislation.gov.au/Details/F2016C00432 > > The current rules exceed legal limits between 5250-5330MHz, and permit > illegal operation in 5600-5650MHz (disallowed regardless of

[PATCH v2] wireless-regdb: Update rules for Australia (AU) and add 60GHz rules

2017-02-23 Thread Ryan Mounce
Sourced from the current legislation at https://www.legislation.gov.au/Details/F2016C00432 The current rules exceed legal limits between 5250-5330MHz, and permit illegal operation in 5600-5650MHz (disallowed regardless of DFS). Frequency ranges and EIRP limits for all ranges have been updated to

Re: [Outreachy kernel] Re: [PATCH v2] staging: wilc1000: renames struct tstrRSSI and its members u8Index, u8Full

2017-02-23 Thread Julia Lawall
On Thu, 23 Feb 2017, 'Arend Van Spriel' via outreachy-kernel wrote: > On 23-2-2017 8:08, Julia Lawall wrote: > >> Thanks for the feedback Arend, I really appreciate it. I've decided to go > >> with > >> these changes in my follow-up patch request: > >> > >> - rename tstrRSSI to

Re: [PATCH] wireless-regdb: Update rules for Australia (AU) and add 60GHz rules

2017-02-23 Thread Seth Forshee
On Thu, Feb 23, 2017 at 06:58:45AM +0100, Johannes Berg wrote: > > > The frequency ranges have been "rounded down" to conform with the > > apparent convention of only including ranges used by standard 802.11 > > channels, rather than using the actual frequency ranges as has been > > done for some

[PATCHv2] ath10k: Update available channel list for 5G radio

2017-02-23 Thread c_traja
From: Tamizh chelvam If a 5 GHz radio is calibrated for operation in both the low band (channels 36 to 64) and high band(channels 100 to 169), hardware allows operations in all the listed channels. However, if the chip has been calibrated only for the low/high band and

Re: [PATCH v2] ath10k: Remove return statement from a void function

2017-02-23 Thread Joe Perches
On Wed, 2017-02-22 at 20:54 +0100, Arend Van Spriel wrote: > > On 21-2-2017 11:28, Marcin Rokicki wrote: > > The empty 'return;' statement in a void function should be > > used to return from somewhere else than the end. > > > > Signed-off-by: Marcin Rokicki > > --- >

[PATCH 1/2] mac80211_hwsim: Make sure NEW_RADIO contains final name

2017-02-23 Thread Andrew Zaborowski
ieee80211_alloc_hw_nm will validate the requested name (if any) before creating the new device and may use a name different from the one requested rather than fail. Make sure the HWSIM_CMD_NEW_RADIO event/response generated has the final name or userspace will receive the wrong name. Note that

[PATCH 2/2][RFC] mac80211_hwsim: Report radio addresses in NEW_RADIO/GET_RADIO

2017-02-23 Thread Andrew Zaborowski
Add a HWSIM_ATTR_RADIO_ADDR attribute to those to events/response so that a userspace medium can query the list of addresses in the simulator. When a userspace medium needs to handle a broadcast frame it can't easily implement the equivalent of what the default kernel medium does because it

Re: [PATCH] cfg80211: support 4-way handshake offloading for WPA/WPA2-PSK

2017-02-23 Thread Jithu Jance
On Thu, Feb 23, 2017 at 4:10 PM, Arend Van Spriel wrote: > > Ehm. Looking at the code in wpa_supplicant_event_assoc() it would be > better to use NL80211_CMD_EAPOL_PORT_VALID event to cover both > WPA/WPA2-PSK and 8021X. Yes. IMHO, the assoc/reassoc ind should move

Re: [PATCH] cfg80211: support 4-way handshake offloading for WPA/WPA2-PSK

2017-02-23 Thread Johannes Berg
> So the code in wpa_supplicant_event_assoc() is either lying or the > assoc event should come after driver has completed successfully. To > me it seems worth it to have NL80211_CMD_EAP_COMPLETED event carrying > the result or indeed give the CONNECTED event later in the driver. Sorry - need to

[bug report] NFC Digital: Add target NFC-DEP support

2017-02-23 Thread Dan Carpenter
Hello Thierry Escande, The patch 1c7a4c24fbfd: "NFC Digital: Add target NFC-DEP support" from Sep 19, 2013, leads to the following static checker warning: net/nfc/digital_dep.c:1303 digital_tg_recv_dep_req() error: double free of 'resp' net/nfc/digital_dep.c 1287 1288

Re: [PATCH] cfg80211: support 4-way handshake offloading for WPA/WPA2-PSK

2017-02-23 Thread Arend Van Spriel
On 22-2-2017 13:24, Jithu Jance wrote: > Hi Jouni, Johannes et al., > > On Wed, Feb 22, 2017 at 1:27 AM, Arend Van Spriel > wrote: >> On 21-2-2017 13:37, Johannes Berg wrote: >>> What I am also missing is how to deal with NL80211_CMD_CONNECTED event

Re: [RFC v2 1/2] cfg80211: support 4-way handshake offloading for WPA/WPA2-PSK

2017-02-23 Thread Arend Van Spriel
On 21-2-2017 15:47, Johannes Berg wrote: > >> The .len verifies that it's at least that long. We're thus ignoring >> additional bytes in the PSK case if they're present, which I suppose >> we should fix by checking the exact length in the code separately. >> libnl seems to have the notion of

Re: [Outreachy kernel] Re: [PATCH v2] staging: wilc1000: renames struct tstrRSSI and its members u8Index, u8Full

2017-02-23 Thread Arend Van Spriel
On 23-2-2017 8:08, Julia Lawall wrote: >> Thanks for the feedback Arend, I really appreciate it. I've decided to go >> with >> these changes in my follow-up patch request: >> >> - rename tstrRSSI to 'rssi_history_buffer' as Aren suggested since it makes >> the >> purpose of the struct clear >> -