ath9k: wifi not working with btcoex_enable on AR9462

2017-06-05 Thread Benjamin Wie
Hello, I'm trying to use a bluetooth speaker while connected to a wifi. At first, once I started sending something to the speaker via bluetooth, the wifi connection was slowed down a lot or even disconnected because btcoex_enable was not set. Now I enabled it using: modprobe -r ath9k

Re: ks7010 firmware upload fail

2017-06-05 Thread Tobin C. Harding
On Mon, Jun 05, 2017 at 08:07:40PM -0400, Brian Masney wrote: > On Mon, Jun 05, 2017 at 08:24:44PM +1000, Tobin C. Harding wrote: > > On Mon, Jun 05, 2017 at 09:22:12AM +0200, Wolfram Sang wrote: > > > Tobin, > > > > > > > My question is should I be digging further into the MMC code or be doing >

Re: ks7010 firmware upload fail

2017-06-05 Thread Brian Masney
On Mon, Jun 05, 2017 at 08:24:44PM +1000, Tobin C. Harding wrote: > On Mon, Jun 05, 2017 at 09:22:12AM +0200, Wolfram Sang wrote: > > Tobin, > > > > > My question is should I be digging further into the MMC code or be doing > > > something else with the driver code? > > > > So, you haven't found

[PATCH 12/25] iwlwifi: mvm: check firmware is up in debugfs

2017-06-05 Thread Luca Coelho
From: Johannes Berg Protect various debugfs files that need to communicate with the firmware from being used when the firmware isn't running. Some will just reject getting written to, while others that store some state will simply store it and not apply it immediately.

[PATCH 13/25] iwlwifi: mvm: use schedule_delayed_work()

2017-06-05 Thread Luca Coelho
From: Johannes Berg There's no need to refer to system_wq directly, use the provided wrapper schedule_delayed_work(). Made with the following spatch: @@ expression E,F; @@ -queue_delayed_work(system_wq, E, F); +schedule_delayed_work(E, F);

[PATCH 23/25] iwlwifi: fw-api: cleanup cycle includes

2017-06-05 Thread Luca Coelho
From: Mordechai Goodstein The include in the deleted file are included in the fw-api.h file. Which caused a cycle include in the dependencies. Signed-off-by: Mordechai Goodstein Signed-off-by: Luca Coelho

[PATCH 15/25] iwlwifi: mvm: convert ucode_loaded to a status bit

2017-06-05 Thread Luca Coelho
From: Johannes Berg Convert ucode_loaded to a status bit called FIRMWARE_RUNNING. This will make it easier to clear this earlier, to avoid any spurious accesses while shutting down, for example through debugfs. Signed-off-by: Johannes Berg

[PATCH 20/25] iwlwifi: mvm: document structures used for BEACON_TEMPLATE_CMD

2017-06-05 Thread Luca Coelho
From: Johannes Berg Signed-off-by: Johannes Berg Signed-off-by: Luca Coelho --- drivers/net/wireless/intel/iwlwifi/mvm/fw-api.h | 6 ++ 1 file changed, 6 insertions(+) diff --git

[PATCH 16/25] iwlwifi: mvm: clear firmware running bit earlier

2017-06-05 Thread Luca Coelho
From: Johannes Berg Clear the firmware running bit before flushing the FW (error) dump work, because otherwise debugfs isn't blocked (previous patch) and can cause a new work to be scheduled, which will then run after we actually shut down the device, wreaking havoc.

[PATCH 22/25] iwlwifi: mvm: remove SCAN_GROUP

2017-06-05 Thread Luca Coelho
From: Johannes Berg The firmware no longer uses this command group, so remove it from the driver as well. Signed-off-by: Johannes Berg Signed-off-by: Luca Coelho --- drivers/net/wireless/intel/iwlwifi/mvm/fw-api.h |

[PATCH 14/25] iwlwifi: mvm: add and use iwl_mvm_device_running()

2017-06-05 Thread Luca Coelho
From: Johannes Berg This will help refactor this later. Signed-off-by: Johannes Berg Signed-off-by: Luca Coelho --- drivers/net/wireless/intel/iwlwifi/mvm/debugfs.c | 25 ++-

[PATCH 19/25] iwlwifi: mvm: link queue cmd docs to A000 command structs

2017-06-05 Thread Luca Coelho
From: Johannes Berg Document which structures are used with the command for the A000 hardware flavour. Signed-off-by: Johannes Berg Signed-off-by: Luca Coelho --- drivers/net/wireless/intel/iwlwifi/mvm/fw-api.h | 4

[PATCH 11/25] iwlwifi: mvm: disable prph collection in a000 hw

2017-06-05 Thread Luca Coelho
From: Liad Kaufman Apart from the current list of PRPH that can't be collected in A000 HW, the rest of the debug dump data the driver collects is valid, so there is no need to disable collection only because of this. Disable PRPH collecting in A000 HW, and allow

[PATCH 25/25] iwlwifi: remove unnecessary code in iwl_trans_alloc_tx_cmd

2017-06-05 Thread Luca Coelho
From: Luca Coelho When we removed dev_cmd_headroom, the check for dev_cmd_ptr == NULL became unnecessary, since we just return dev_cmd_ptr anyway. Cleanup the function to avoid useless code. Signed-off-by: Luca Coelho ---

[PATCH 18/25] iwlwifi: split firmware API from iwl-trans.h

2017-06-05 Thread Luca Coelho
From: Johannes Berg In order to more clearly document which parts of this file are firmware API and which are something else, split the firmware API into a separate file to include here. Signed-off-by: Johannes Berg Signed-off-by: Luca Coelho

[PATCH 21/25] iwlwifi: mvm: link to TX commands in documentation

2017-06-05 Thread Luca Coelho
From: Johannes Berg Link from the TX_CMD enum value to the TX command structs. Signed-off-by: Johannes Berg Signed-off-by: Luca Coelho --- drivers/net/wireless/intel/iwlwifi/mvm/fw-api.h | 4 +++- 1 file changed, 3

[PATCH 17/25] iwlwifi: fix a kernel-doc tag

2017-06-05 Thread Luca Coelho
From: Johannes Berg The kernel-doc here is on an enum, so don't tag it as struct but correctly as enum instead, preventing an error. Signed-off-by: Johannes Berg Signed-off-by: Luca Coelho ---

[PATCH 04/25] iwlwifi: cleanup references to 8000 family in NVM code

2017-06-05 Thread Luca Coelho
From: Sara Sharon NVM code is tightly coupled with 8000 family, while it really refers to extended NVM format introduced back then. Separate it to a configuration dependent boolean, and rename defines accordingly. Signed-off-by: Sara Sharon

[PATCH 03/25] iwlwifi: pcie: add AMSDU to gen2

2017-06-05 Thread Luca Coelho
From: Sara Sharon This is essentially the same code as gen1, except that it uses gen2 functions and SW checksum is not included. Signed-off-by: Sara Sharon Signed-off-by: Luca Coelho ---

[PATCH 08/25] iwlwifi: mvm: support init flow debugging

2017-06-05 Thread Luca Coelho
From: Liad Kaufman In case an assert happens on init flow, the current driver powers down the NIC, except if iwlmvm modparam init_dbg=1, and only on very specific flows. Extend this capability to cover most failure cases by keeping track of what init configurations have

[PATCH 07/25] iwlwifi: mvm: add TLV for NAN API differentiation

2017-06-05 Thread Luca Coelho
From: Beni Lev Due to NAN FW API change, add TLV in order to distiguish between the 2 API versions Signed-off-by: Beni Lev Signed-off-by: Luca Coelho --- drivers/net/wireless/intel/iwlwifi/iwl-fw-file.h | 2 ++ 1 file changed,

[PATCH 06/25] iwlwifi: add dbgc_supported to transport configuration

2017-06-05 Thread Luca Coelho
From: Sara Sharon Use transport configuration to determine DBGC support instead of relying on device family. Signed-off-by: Sara Sharon Signed-off-by: Luca Coelho --- drivers/net/wireless/intel/iwlwifi/iwl-8000.c | 3

[PATCH 05/25] iwlwifi: remove references to 8000 B-step devices

2017-06-05 Thread Luca Coelho
From: Sara Sharon We don't have any 8000 B-step right now, and there is no firmware loading code for them anyway. Further more, 9000 B-step devices will hit those code paths. Remove code that was introduced only for 8000 B-step. Signed-off-by: Sara Sharon

[PATCH 01/25] iwlwifi: mvm: add AMSDU flag to offload assist

2017-06-05 Thread Luca Coelho
From: Sara Sharon Enable offload assist for AMSDU when the AMSDU present flag is set. Fixes: a830baba9c2e ("iwlwifi: mvm: support new TX API") Signed-off-by: Sara Sharon Signed-off-by: Luca Coelho ---

[PATCH 02/25] iwlwifi: mvm: document RX structures

2017-06-05 Thread Luca Coelho
From: Johannes Berg Document the structures used in RX and link them to the command ID. Signed-off-by: Johannes Berg Signed-off-by: Luca Coelho --- drivers/net/wireless/intel/iwlwifi/mvm/fw-api-rx.h | 81

[PATCH 09/25] iwlwifi: add 9000 and A000 device families

2017-06-05 Thread Luca Coelho
From: Sara Sharon Add two new device families to differentiate them from 8000. Signed-off-by: Sara Sharon Signed-off-by: Luca Coelho --- drivers/net/wireless/intel/iwlwifi/iwl-9000.c| 2 +-

[PATCH 00/25] iwlwifi: updates intended for v4.13 2017-06-05

2017-06-05 Thread Luca Coelho
From: Luca Coelho Hi, More patches intended for v4.13. These are the changes: * More FW API documentation updates; * More work for the new A000 family; * Bumped the maximum supported FW API to 31. * Improve the differentiation between 8000, 9000 and A000 families; *

[PATCH v2 09/12] NFC: st-nci: Covert to use GPIO descriptor

2017-06-05 Thread Andy Shevchenko
Since we got rid of platform data, the driver may use GPIO descriptor directly. Looking deeply to the use of the GPIO pin it looks like it should be a GPIO based reset control rather than custom GPIO handling. But this is out of scope of the change. Signed-off-by: Andy Shevchenko

[PATCH v2 11/12] NFC: st-nci: Add GPIO ACPI mapping table

2017-06-05 Thread Andy Shevchenko
In order to make GPIO ACPI library stricter prepare users of gpiod_get_index() to correctly behave when there no mapping is provided by firmware. Here we add explicit mapping between _CRS GpioIo() resources and their names used in the driver. Signed-off-by: Andy Shevchenko

Re: [PATCH v1 1/2] NFC: st21nfca: Add GPIO ACPI mapping table

2017-06-05 Thread Andy Shevchenko
On Mon, 2017-05-22 at 21:33 +0300, Andy Shevchenko wrote: > On Mon, 2017-04-24 at 21:41 +0300, Andy Shevchenko wrote: > > In order to make GPIO ACPI library stricter prepare users of > > gpiod_get_index() to correctly behave when there no mapping is > > provided by firmware. > > > > Here we add

[PATCH v2 07/12] NFC: st-nci: Get rid of platform data

2017-06-05 Thread Andy Shevchenko
Legacy platform data must go away. We are on the safe side here since there are no users of it in the kernel. If anyone by any odd reason needs it the GPIO lookup tables and built-in device properties at your service. Signed-off-by: Andy Shevchenko ---

[PATCH v2 12/12] NFC: st-nci: Get rid of code duplication in ->probe()

2017-06-05 Thread Andy Shevchenko
Since OF and ACPI case almost the same get rid of code duplication by moving gpiod_get() calls directly to ->probe(). Signed-off-by: Andy Shevchenko --- drivers/nfc/st-nci/i2c.c | 61 +++--- drivers/nfc/st-nci/spi.c | 63

[PATCH v2 04/12] NFC: fdp: Convert I2C driver to ->probe_new()

2017-06-05 Thread Andy Shevchenko
There is no platform code that uses i2c module table. Remove it altogether and adjust ->probe() to be ->probe_new(). Signed-off-by: Andy Shevchenko --- drivers/nfc/fdp/i2c.c | 12 ++-- 1 file changed, 2 insertions(+), 10 deletions(-) diff --git

[PATCH v2 02/12] NFC: st21nfca: Add GPIO ACPI mapping table

2017-06-05 Thread Andy Shevchenko
In order to make GPIO ACPI library stricter prepare users of gpiod_get_index() to correctly behave when there no mapping is provided by firmware. Here we add explicit mapping between _CRS GpioIo() resources and their names used in the driver. Signed-off-by: Andy Shevchenko

[PATCH v2 03/12] NFC: st21nfca: Get rid of code duplication in ->probe()

2017-06-05 Thread Andy Shevchenko
Since OF and ACPI case almost the same get rid of code duplication by moving gpiod_get() calls directly to ->probe(). Signed-off-by: Andy Shevchenko --- drivers/nfc/st21nfca/i2c.c | 62 -- 1 file changed, 10

[PATCH v2 00/12] NFC: clean up for ACPI GPIO usage

2017-06-05 Thread Andy Shevchenko
This clean up series to NFC drivers that are using GPIOs on ACPI enabled platforms. Since GPIO ACPI library goes stricter about requesting resources we need to amend drivers for that. Here we are for NFC subsystem. While doing above, get rid of legacy and unused platform data as well as some

[PATCH v2 06/12] NFC: fdp: Add GPIO ACPI mapping table

2017-06-05 Thread Andy Shevchenko
In order to make GPIO ACPI library stricter prepare users of gpiod_get_index() to correctly behave when there no mapping is provided by firmware. Here we add explicit mapping between _CRS GpioIo() resources and their names used in the driver. Signed-off-by: Andy Shevchenko

[PATCH v2 05/12] NFC: fdp: Convert to use devres API

2017-06-05 Thread Andy Shevchenko
It looks like there are two leftovers, at least one of which can leak the resource (IRQ). Convert both places to use devm variants of functions. Signed-off-by: Andy Shevchenko --- drivers/nfc/fdp/fdp.c | 15 --- drivers/nfc/fdp/i2c.c | 10

[PATCH v2 01/12] NFC: pn544: Switch to devm_acpi_dev_add_driver_gpios()

2017-06-05 Thread Andy Shevchenko
Switch to use managed variant of acpi_dev_add_driver_gpios() to simplify error path and fix potentially wrong assingment if ->probe() fails. Signed-off-by: Andy Shevchenko --- drivers/nfc/pn544/i2c.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-)

[PATCH v2 10/12] NFC: st-nci: Use unified device property API meaningfully

2017-06-05 Thread Andy Shevchenko
Use unified device property API in meaningful way. Signed-off-by: Andy Shevchenko --- drivers/nfc/st-nci/i2c.c | 30 ++ drivers/nfc/st-nci/spi.c | 29 + 2 files changed, 11 insertions(+), 48 deletions(-)

[PATCH v2 08/12] NFC: st-nci: Get rid of "interesting" use of interrupt polarity

2017-06-05 Thread Andy Shevchenko
I2C and SPI frameworks followed by IRQ framework do set interrupt polarity correctly if it's properly specified in firmware (ACPI or DT). Get rid of the redundant trick when requesting interrupt. Signed-off-by: Andy Shevchenko --- drivers/nfc/st-nci/i2c.c | 8

Re: pull-request: iwlwifi 2017-06-05

2017-06-05 Thread Kalle Valo
Luca Coelho writes: > Here are some fixes for 4.12. More details in the tag description.  As > we agreed, I updated the commit messages on the first two patches. > > I have sent this out before and kbuildbot didn't find any issues. > > Cheers, > Luca. > > > The following changes

Re: [PATCH 05/14] mwifiex: re-register wiphy across reset

2017-06-05 Thread Kalle Valo
Brian Norris writes: > On Thu, Jun 01, 2017 at 12:15:45PM +0300, Kalle Valo wrote: >> Brian Norris writes: >> >> > In general, it's helpful to use the same code for device removal as for >> > device reset, as this tends to have fewer bugs.

[PATCH v2 4/9] rtlwifi: btcoex: hook external PnP notify by chip for wifi driver

2017-06-05 Thread Larry Finger
From: Yan-Hsuan Chuang Hook the chip-specific PnP notify functions for the wifi driver to notify btcoexistence. Signed-off-by: Yan-Hsuan Chuang Signed-off-by: Larry Finger Cc: Ping-Ke Shih Cc: Birming

[PATCH v2 0/9] rtlwifi: btcoex: Further updates

2017-06-05 Thread Larry Finger
This set of 9 patches contain the material that was originally sent as 1 of 7. Each of these now accomplish a single task. Larry Signed-off-by: Yan-Hsuan Chuang Signed-off-by: Larry Finger Cc: Ping-Ke Shih Cc: Birming Chiu

[PATCH v2 1/9] rtlwifi: btcoex: add macros to check chip type

2017-06-05 Thread Larry Finger
From: Yan-Hsuan Chuang For some external functions that have hardware dependency, we need to know the type of the hardware before invoking them. Signed-off-by: Yan-Hsuan Chuang Signed-off-by: Larry Finger Cc: Ping-Ke Shih

[PATCH v2 6/9] rtlwifi: btcoex: hook external functions for newer chips

2017-06-05 Thread Larry Finger
From: Yan-Hsuan Chuang Hook the external functions for newer ICs such as 8821a and 8192e. Rename ex_halbtc8192e2ant_halt_notify to ex_btc8192e2ant_halt_notify. Signed-off-by: Yan-Hsuan Chuang Signed-off-by: Larry Finger

[PATCH v2 3/9] rtlwifi: btcoex: settings before firmware is downloaded

2017-06-05 Thread Larry Finger
From: Yan-Hsuan Chuang The btcoex is sometimes unstable because there are some unexpected behaviors before the firmware has been downloaded successfully. Therefore we force the antenna path settings to avoid this, then let the firmware control the btcoexistence when the

[PATCH v2 2/9] rtlwifi: btcoex: rename ex_halbtc*ant to ex_btc*ant

2017-06-05 Thread Larry Finger
From: Yan-Hsuan Chuang These external functions are for BT-coexistence, so remove the "hal" prefix for consistancy. Signed-off-by: Yan-Hsuan Chuang Signed-off-by: Larry Finger Cc: Ping-Ke Shih Cc:

[PATCH v2 7/9] rtlwifi: btcoex: bind BT coex information with wifi driver

2017-06-05 Thread Larry Finger
From: Yan-Hsuan Chuang When initializing, gather BT information in struct btcoexist and provide them to wifi driver. Signed-off-by: Yan-Hsuan Chuang Signed-off-by: Larry Finger Cc: Ping-Ke Shih Cc:

[PATCH v2 9/9] rtlwifi: btcoex: let btcoex get wifi rssi and link status

2017-06-05 Thread Larry Finger
From: Yan-Hsuan Chuang Instead of rssi status, the btcoex also needs to get the link status of the wifi. In addition, some of the rssi status can be merged into link status. Signed-off-by: Yan-Hsuan Chuang Signed-off-by: Larry Finger

[PATCH v2 8/9] rtlwifi: btcoex: remove unused display functions

2017-06-05 Thread Larry Finger
From: Yan-Hsuan Chuang These display functions are useless and will not be called in the future. Signed-off-by: Yan-Hsuan Chuang Signed-off-by: Larry Finger Cc: Ping-Ke Shih Cc: Birming Chiu

[PATCH v2 5/9] rtlwifi: btcoex: add settings before the hardware is ready

2017-06-05 Thread Larry Finger
From: Yan-Hsuan Chuang When the hardware is turned on and in the initialization stage, the PTA circuit is unstable. Hence we need to force some hardware settings to make sure the PTA circuit work correctly, otherwise it may affect the user's experience. Signed-off-by:

Re: [PATCH 2/9] rtlwifi: btcoex: rename ex_halbtc....YZant to ex_btc.....YZant

2017-06-05 Thread Kalle Valo
(Removing the X letters from the subject to bypass vger filters) Kalle Valo writes: > Larry Finger writes: > >> From: Yan-Hsuan Chuang >> >> These external functions are for BT-coexistence, so remove the "hal" >> prefix

Re: [PATCH 01/14] mwifiex: pcie: properly synchronize, disable interrupts in driver callbacks

2017-06-05 Thread Xinming Hu
Hi Brian, > -Original Message- > From: linux-wireless-ow...@vger.kernel.org > [mailto:linux-wireless-ow...@vger.kernel.org] On Behalf Of Brian Norris > Sent: 2017年6月1日 1:11 > To: Ganapathi Bhat; Nishant Sarmukadam > Cc: linux-ker...@vger.kernel.org; Dmitry Torokhov; Amitkumar Karwar;

Re: ks7010 firmware upload fail

2017-06-05 Thread Tobin C. Harding
On Mon, Jun 05, 2017 at 09:22:12AM +0200, Wolfram Sang wrote: > Tobin, > > > My question is should I be digging further into the MMC code or be doing > > something else with the driver code? > > So, you haven't found any branch that worked? No plain v4.9 or the > gen3-sdio branch from my tree?

pull-request mwifiex-firmware 2017-06-05

2017-06-05 Thread Xinming Hu
The following changes since commit 47afd9950fbcadeb7cefc093b21d6123bdc76f79: linux-firmware: add Marvell USB8997 firmware image (2017-05-02 12:28:34 +0530) are available in the git repository at: git://git.marvell.com/mwifiex-firmware.git for you to fetch changes up to

Re: [PATCH][-next] mwifiex: make function mwifiex_ret_pkt_aggr_ctrl static

2017-06-05 Thread Xinming Hu
Hi Colin, > -Original Message- > From: Colin King [mailto:colin.k...@canonical.com] > Sent: 2017年6月2日 16:57 > To: Amitkumar Karwar; Nishant Sarmukadam; Ganapathi Bhat; Xinming Hu; > Kalle Valo; linux-wireless@vger.kernel.org; net...@vger.kernel.org > Cc: kernel-janit...@vger.kernel.org;

Re: ks7010 firmware upload fail

2017-06-05 Thread Wolfram Sang
Tobin, > My question is should I be digging further into the MMC code or be doing > something else with the driver code? So, you haven't found any branch that worked? No plain v4.9 or the gen3-sdio branch from my tree? Regards, Wolfram signature.asc Description: PGP signature