Re: [PATCH 3/6] firmware: differentiate between signed regulatory.db and other firmware

2018-05-10 Thread Mimi Zohar
On Thu, 2018-05-10 at 23:26 +, Luis R. Rodriguez wrote: > On Wed, May 09, 2018 at 10:00:58PM -0400, Mimi Zohar wrote: > > On Wed, 2018-05-09 at 23:48 +, Luis R. Rodriguez wrote: > > > On Wed, May 09, 2018 at 06:06:57PM -0400, Mimi Zohar wrote: > > > > > > > > Yes, writing regdb as a

Re: [PATCH 3/6] firmware: differentiate between signed regulatory.db and other firmware

2018-05-10 Thread Luis R. Rodriguez
On Wed, May 09, 2018 at 10:00:58PM -0400, Mimi Zohar wrote: > On Wed, 2018-05-09 at 23:48 +, Luis R. Rodriguez wrote: > > On Wed, May 09, 2018 at 06:06:57PM -0400, Mimi Zohar wrote: > > > > > > Yes, writing regdb as a micro/mini LSM sounds reasonable.  The LSM > > > > > would differentiate

Re: pull-request: mac80211-next 2018-05-09

2018-05-10 Thread David Miller
From: Johannes Berg Date: Wed, 09 May 2018 23:29:37 +0200 > Hi, > > Sorry, scratch that. > > I forgot that this commit: > >> Toke Høiland-Jørgensen (3): > >> cfg80211: Expose TXQ stats and parameters to userspace > > caused a bunch of "too much stack"

Re: pull-request: mac80211 2018-05-09

2018-05-10 Thread David Miller
From: Johannes Berg Date: Wed, 9 May 2018 21:36:12 +0200 > We just have a few fixes this time around. > > Please pull and let me know if there's any problem. Pulled, thank you!

[PATCH v7 01/14] firmware: wrap FW_OPT_* into an enum

2018-05-10 Thread Luis R. Rodriguez
From: Andres Rodriguez This should let us associate enum kdoc to these values. While at it, kdocify the fw_opt. Signed-off-by: Andres Rodriguez Reviewed-by: Kees Cook Acked-by: Luis R. Rodriguez [mcgrof: coding

[PATCH v7 02/14] firmware: use () to terminate kernel-doc function names

2018-05-10 Thread Luis R. Rodriguez
From: Andres Rodriguez The kernel-doc spec dictates a function name ends in (). Signed-off-by: Andres Rodriguez Reviewed-by: Kees Cook Acked-by: Randy Dunlap Acked-by: Luis R. Rodriguez

[PATCH v7 00/14] firmware_loader changes for v4.18

2018-05-10 Thread Luis R. Rodriguez
=20180510-firmware_loader_for-v4.18 [1] https://git.kernel.org/pub/scm/linux/kernel/git/mcgrof/linux.git/log/?h=20180510-firmware_loader_for-v4.18 v7: - Annoted Reviewed-by tags. - Installed codespell and am now using checkpatch.sh --codespell to check each patch for spell check and blunders. Edited

[PATCH v7 03/14] firmware: rename fw_sysfs_fallback to firmware_fallback_sysfs()

2018-05-10 Thread Luis R. Rodriguez
From: Andres Rodriguez This is done since this call is now exposed through kernel-doc, and since this also paves the way for different future types of fallback mechanims. Signed-off-by: Andres Rodriguez Reviewed-by: Kees Cook

[PATCH v7 05/14] firmware_loader: enhance Kconfig documentation over FW_LOADER

2018-05-10 Thread Luis R. Rodriguez
If you try to read FW_LOADER today it speaks of old riddles and unless you have been following development closely you will lose track of what is what. Even the documentation for PREVENT_FIRMWARE_BUILD is a bit fuzzy and how it fits into this big picture. Give the FW_LOADER kconfig documentation

[PATCH v7 07/14] firmware_loader: move kconfig FW_LOADER entries to its own file

2018-05-10 Thread Luis R. Rodriguez
This will make it easier to track and easier to understand what components and features are part of the FW_LOADER. There are some components related to firmware which have *nothing* to do with the FW_LOADER, souch as PREVENT_FIRMWARE_BUILD. Reviewed-by: Kees Cook

[PATCH v7 04/14] firmware_loader: document firmware_sysfs_fallback()

2018-05-10 Thread Luis R. Rodriguez
This also sets the expecations for future fallback interfaces, even if they are not exported. Reviewed-by: Kees Cook Signed-off-by: Luis R. Rodriguez --- drivers/base/firmware_loader/fallback.c | 20 1 file changed, 20

[PATCH v7 08/14] firmware_loader: make firmware_fallback_sysfs() print more useful

2018-05-10 Thread Luis R. Rodriguez
If we resort to using the sysfs fallback mechanism we don't print the filename. This can be deceiving given we could have a series of callers intertwined and it'd be unclear exactly for what firmware this was meant for. Additionally, although we don't currently use FW_OPT_NO_WARN when dealing

[PATCH v7 10/14] ath10k: use firmware_request_nowarn() to load firmware

2018-05-10 Thread Luis R. Rodriguez
From: Andres Rodriguez This reduces the unnecessary spew when trying to load optional firmware: "Direct firmware load for ... failed with error -2" Signed-off-by: Andres Rodriguez Reviewed-by: Kees Cook Acked-by: Kalle Valo

[PATCH v7 09/14] firmware: add firmware_request_nowarn() - load firmware without warnings

2018-05-10 Thread Luis R. Rodriguez
From: Andres Rodriguez Currently the firmware loader only exposes one silent path for querying optional firmware, and that is firmware_request_direct(). This function also disables the sysfs fallback mechanism, which might not always be the desired behaviour [0]. This patch

[PATCH v7 14/14] Documentation: clarify firmware_class provenance and why we can't rename the module

2018-05-10 Thread Luis R. Rodriguez
Clarify the provenance of the firmware loader firmware_class module name and why we cannot rename the module in the future. Reviewed-by: Mauro Carvalho Chehab Reviewed-by: Kees Cook Signed-off-by: Luis R. Rodriguez ---

[PATCH v7 11/14] ath10k: re-enable the firmware fallback mechanism for testmode

2018-05-10 Thread Luis R. Rodriguez
From: Andres Rodriguez The ath10k testmode uses request_firmware_direct() in order to avoid producing firmware load warnings. Disabling the fallback mechanism was a side effect of disabling warnings. We now have a new API that allows us to avoid warnings while keeping the

[PATCH v7 13/14] Documentation: remove stale firmware API reference

2018-05-10 Thread Luis R. Rodriguez
It refers to a pending patch, but this was merged eons ago. Reviewed-by: Mauro Carvalho Chehab Reviewed-by: Kees Cook Signed-off-by: Luis R. Rodriguez --- Documentation/dell_rbu.txt | 5 + 1 file changed, 1

[PATCH v7 06/14] firmware_loader: replace ---help--- with help

2018-05-10 Thread Luis R. Rodriguez
As per checkpatch using help is preferred over ---help---. Signed-off-by: Luis R. Rodriguez --- drivers/base/Kconfig | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/base/Kconfig b/drivers/base/Kconfig index db2bbe483927..0c38df32c7fe 100644 ---

[PATCH v7 12/14] Documentation: fix few typos and clarifications for the firmware loader

2018-05-10 Thread Luis R. Rodriguez
Fix a few typos, and clarify a few sentences. Reviewed-by: Kees Cook Signed-off-by: Luis R. Rodriguez --- Documentation/driver-api/firmware/fallback-mechanisms.rst | 5 +++-- Documentation/driver-api/firmware/firmware_cache.rst | 4 ++-- 2 files

Re: [PATCH] mt76x2: add a polling delay in mt76x2_mac_stop routine

2018-05-10 Thread Felix Fietkau
On 2018-05-10 16:06, Lorenzo Bianconi wrote: > Add a usleep_range in mt76x2_mac_stop routine in order to add > a polling delay checking values of MT_MAC_STATUS and IBI_R12 registers > > Signed-off-by: Lorenzo Bianconi Acked-by: Felix Fietkau

Re: [PATCH 4.17 2/2] ssb: make SSB_PCICORE_HOSTMODE depend on SSB = y

2018-05-10 Thread Larry Finger
On 05/10/2018 06:14 AM, Rafał Miłecki wrote: From: Rafał Miłecki SSB_PCICORE_HOSTMODE protects MIPS specific code that calls not exported symbols pcibios_enable_device and register_pci_controller. This code is supposed to be compiled only with ssb builtin. This fixes: ERROR:

[PATCH] rsi: fix spelling mistake: "thead" -> "thread"

2018-05-10 Thread Colin King
From: Colin Ian King Trivial fix to spelling mistake in rsi_dbg debug message text Signed-off-by: Colin Ian King --- drivers/net/wireless/rsi/rsi_91x_core.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

RE: [PATCH v5] wireless-drivers: Dynamically allocate struct station_info

2018-05-10 Thread Toke Høiland-Jørgensen
On 10 May 2018 15:50:23 CEST, Dedy Lansky wrote: >Hi Toke, > >> --- a/drivers/net/wireless/ath/wil6210/wmi.c >> +++ b/drivers/net/wireless/ath/wil6210/wmi.c >> @@ -824,7 +824,7 @@ static void wmi_evt_connect(struct wil6210_vif >*vif, int id, void *d, int len) >>

[PATCH] mt76x2: add a polling delay in mt76x2_mac_stop routine

2018-05-10 Thread Lorenzo Bianconi
Add a usleep_range in mt76x2_mac_stop routine in order to add a polling delay checking values of MT_MAC_STATUS and IBI_R12 registers Signed-off-by: Lorenzo Bianconi --- drivers/net/wireless/mediatek/mt76/mt76x2_init.c | 10 +- 1 file changed, 5

RE: [PATCH v5] wireless-drivers: Dynamically allocate struct station_info

2018-05-10 Thread Dedy Lansky
Hi Toke, > --- a/drivers/net/wireless/ath/wil6210/wmi.c > +++ b/drivers/net/wireless/ath/wil6210/wmi.c > @@ -824,7 +824,7 @@ static void wmi_evt_connect(struct wil6210_vif *vif, int > id, void *d, int len) > struct wireless_dev *wdev = vif_to_wdev(vif); > struct wmi_connect_event

[PATCH] brcmfmac: set WIPHY_FLAG_HAVE_AP_SME flag

2018-05-10 Thread Rafał Miłecki
From: Rafał Miłecki brcmfmac is a FullMAC driver and it implements/uses cfg80211 interface for stations management. At the same time it doesn't receive or pass up management frames. This flag indicates that authenticator doesn't have to subscribe to or handle management

Re: [RESEND PATCH] cfg80211: dynamically allocate per-tid stats for station info

2018-05-10 Thread Toke Høiland-Jørgensen
Arend van Spriel writes: > From: Arend van Spriel > > With the addition of TXQ stats in the per-tid statistics the struct > station_info grew significantly. This resulted in stack limit warnings > like below: > >CC [M]

[PATCH v5] wireless-drivers: Dynamically allocate struct station_info

2018-05-10 Thread Toke Høiland-Jørgensen
Since the addition of the TXQ stats to cfg80211, the station_info struct has grown to be quite large, which results in warnings when allocated on the stack. Fix the affected places to do dynamic allocations instead. Fixes: 52539ca89f36 ("cfg80211: Expose TXQ stats and parameters to userspace")

[RESEND PATCH] cfg80211: dynamically allocate per-tid stats for station info

2018-05-10 Thread Arend van Spriel
From: Arend van Spriel With the addition of TXQ stats in the per-tid statistics the struct station_info grew significantly. This resulted in stack limit warnings like below: CC [M] drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.o

Re: [PATCH 4.17 2/2] ssb: make SSB_PCICORE_HOSTMODE depend on SSB = y

2018-05-10 Thread Matt Redfearn
Hi, On 10/05/18 12:26, Michael Büsch wrote: On Thu, 10 May 2018 13:20:01 +0200 Rafał Miłecki wrote: On 10 May 2018 at 13:17, Michael Büsch wrote: On Thu, 10 May 2018 13:14:01 +0200 Rafał Miłecki wrote: From: Rafał Miłecki

Re: [PATCH 4.17 2/2] ssb: make SSB_PCICORE_HOSTMODE depend on SSB = y

2018-05-10 Thread Rafał Miłecki
On 10 May 2018 at 13:26, Michael Büsch wrote: > On Thu, 10 May 2018 13:20:01 +0200 > Rafał Miłecki wrote: > >> On 10 May 2018 at 13:17, Michael Büsch wrote: >> > On Thu, 10 May 2018 13:14:01 +0200 >> > Rafał Miłecki wrote: >> > >>

Re: [PATCH 4.17 2/2] ssb: make SSB_PCICORE_HOSTMODE depend on SSB = y

2018-05-10 Thread Michael Büsch
On Thu, 10 May 2018 13:20:01 +0200 Rafał Miłecki wrote: > On 10 May 2018 at 13:17, Michael Büsch wrote: > > On Thu, 10 May 2018 13:14:01 +0200 > > Rafał Miłecki wrote: > > > >> From: Rafał Miłecki > >> > >>

Re: [PATCH 4.17 2/2] ssb: make SSB_PCICORE_HOSTMODE depend on SSB = y

2018-05-10 Thread Rafał Miłecki
On 10 May 2018 at 13:17, Michael Büsch wrote: > On Thu, 10 May 2018 13:14:01 +0200 > Rafał Miłecki wrote: > >> From: Rafał Miłecki >> >> SSB_PCICORE_HOSTMODE protects MIPS specific code that calls not exported >> symbols pcibios_enable_device

Re: [PATCH 4.17 2/2] ssb: make SSB_PCICORE_HOSTMODE depend on SSB = y

2018-05-10 Thread Michael Büsch
On Thu, 10 May 2018 13:14:01 +0200 Rafał Miłecki wrote: > From: Rafał Miłecki > > SSB_PCICORE_HOSTMODE protects MIPS specific code that calls not exported > symbols pcibios_enable_device and register_pci_controller. This code is > supposed to be compiled

[PATCH 4.17 1/2] Revert "ssb: Prevent build of PCI host features in module"

2018-05-10 Thread Rafał Miłecki
From: Rafał Miłecki This reverts commit 882164a4a928bcaa53280940436ca476e6b1db8e. Above commit added "SSB = y" dependency to the wrong symbol SSB_DRIVER_PCICORE_POSSIBLE and prevented SSB_DRIVER_PCICORE from being selected when needed. PCI core driver for core running in

[PATCH 4.17 2/2] ssb: make SSB_PCICORE_HOSTMODE depend on SSB = y

2018-05-10 Thread Rafał Miłecki
From: Rafał Miłecki SSB_PCICORE_HOSTMODE protects MIPS specific code that calls not exported symbols pcibios_enable_device and register_pci_controller. This code is supposed to be compiled only with ssb builtin. This fixes: ERROR: "pcibios_enable_device" [drivers/ssb/ssb.ko]

Re: [PATCH v2] drivers/net/wireless/broadcom/b43: fix transmit failure when VT is switched

2018-05-10 Thread Michael Büsch
On Thu, 10 May 2018 19:30:45 +0900 Taketo Kabe wrote: > Signed-off-by: Taketo Kabe > --- > diff -up ./drivers/net/wireless/broadcom/b43/dma.c.b43 > ./drivers/net/wireless/broadcom/b43/dma.c > --- ./drivers/net/wireless/broadcom/b43/dma.c.b43

Re: Regression caused by commit 882164a4a928

2018-05-10 Thread Michael Büsch
On Thu, 10 May 2018 11:24:12 +0100 Matt Redfearn wrote: > > Could you please try this? > > > > config SSB_DRIVER_PCICORE_POSSIBLE > > depends on SSB_PCIHOST > > > > config SSB_PCICORE_HOSTMODE > > depends on SSB_DRIVER_PCICORE && SSB_DRIVER_MIPS && (SSB = y) &&

Re: Regression caused by commit 882164a4a928

2018-05-10 Thread Matt Redfearn
Hi Rafał, On 10/05/18 11:41, Rafał Miłecki wrote: On 7 May 2018 at 17:44, Larry Finger wrote: Although commit 882164a4a928 ("ssb: Prevent build of PCI host features in module") appeared to be harmless, it leads to complete failure of drivers b43. and b43legacy, and

Re: Regression caused by commit 882164a4a928

2018-05-10 Thread Rafał Miłecki
On 10 May 2018 at 12:41, Rafał Miłecki wrote: > On 7 May 2018 at 17:44, Larry Finger wrote: >> Although commit 882164a4a928 ("ssb: Prevent build of PCI host features in >> module") appeared to be harmless, it leads to complete failure of drivers >>

Re: [PATCH] ssb: Fix regression caused by disabling PCI cores on non-MIPS architecture

2018-05-10 Thread Rafał Miłecki
On 9 May 2018 at 18:42, Larry Finger wrote: > Some MPIS-based SoCs use chips driven by b43 for wireless capability. > When ssb is configured as a module, build errors happen on these > platforms as described in the commit 882164a4a928 ("ssb: Prevent build > of PCI host

Re: Regression caused by commit 882164a4a928

2018-05-10 Thread Rafał Miłecki
On 7 May 2018 at 17:44, Larry Finger wrote: > Although commit 882164a4a928 ("ssb: Prevent build of PCI host features in > module") appeared to be harmless, it leads to complete failure of drivers > b43. and b43legacy, and likely affects b44 as well. The problem is that

[PATCH v2] drivers/net/wireless/broadcom/b43: fix transmit failure when VT is switched

2018-05-10 Thread Taketo Kabe
From: Taketo Kabe Fix for b43 wireless card stopping transmission when switching VTs. Setup: Using BCM4306 rev.03 chip based CardBus wireless card. IRQ is shared with yenta (cardbus bridge) and i915 (display) driver. For firmware, installed latest but dated openfwwf 5.2

Re: Regression caused by commit 882164a4a928

2018-05-10 Thread Matt Redfearn
Hi Michael, On 09/05/18 17:27, Michael Büsch wrote: On Wed, 9 May 2018 13:55:43 +0100 Matt Redfearn wrote: Hi Larry On 07/05/18 16:44, Larry Finger wrote: Matt, Although commit 882164a4a928 ("ssb: Prevent build of PCI host features in module") appeared to be

RE: [PATCH v4] wireless-drivers: Dynamically allocate struct station_info

2018-05-10 Thread Toke Høiland-Jørgensen
On 10 May 2018 11:58:17 CEST, Dedy Lansky wrote: >Hi Toke, > >Thanks for taking care of wil6210 part. See comment below. > >> @@ -824,7 +824,7 @@ static void wmi_evt_connect(struct wil6210_vif >*vif, int id, void *d, int len) >> struct wireless_dev *wdev =

RE: [PATCH v4] wireless-drivers: Dynamically allocate struct station_info

2018-05-10 Thread Dedy Lansky
Hi Toke, Thanks for taking care of wil6210 part. See comment below. > @@ -824,7 +824,7 @@ static void wmi_evt_connect(struct wil6210_vif *vif, int > id, void *d, int len) > struct wireless_dev *wdev = vif_to_wdev(vif); > struct wmi_connect_event *evt = d; > int ch; /* channel

Re: [PATCH v4] wireless-drivers: Dynamically allocate struct station_info

2018-05-10 Thread Sergey Matyukevich
> Since the addition of the TXQ stats to cfg80211, the station_info struct > has grown to be quite large, which results in warnings when allocated on > the stack. Fix the affected places to do dynamic allocations instead. > > Fixes: 52539ca89f36 ("cfg80211: Expose TXQ stats and parameters to

[PATCH v4] wireless-drivers: Dynamically allocate struct station_info

2018-05-10 Thread Toke Høiland-Jørgensen
Since the addition of the TXQ stats to cfg80211, the station_info struct has grown to be quite large, which results in warnings when allocated on the stack. Fix the affected places to do dynamic allocations instead. Fixes: 52539ca89f36 ("cfg80211: Expose TXQ stats and parameters to userspace")

Re: [PATCH v2 1/3] wireless-drivers: Dynamically allocate struct station_info

2018-05-10 Thread Toke Høiland-Jørgensen
Sergey Matyukevich writes: > Hello Toke and all, > >> Since the addition of the TXQ stats to cfg80211, the station_info struct >> has grown to be quite large, which results in warnings when allocated on >> the stack. Fix the affected places to do dynamic

Re: [PATCH v2 1/3] wireless-drivers: Dynamically allocate struct station_info

2018-05-10 Thread Sergey Matyukevich
Hello Toke and all, > Since the addition of the TXQ stats to cfg80211, the station_info struct > has grown to be quite large, which results in warnings when allocated on > the stack. Fix the affected places to do dynamic allocations instead. > > Fixes: 52539ca89f36 ("cfg80211: Expose TXQ stats

Re: [PATCH 15/30] staging: wilc1000: use kmemdup instead of kmalloc in add_network_to_shadow()

2018-05-10 Thread Ajay Singh
On Thu, 10 May 2018 08:35:29 +0300 Claudiu Beznea wrote: > On 09.05.2018 22:17, Ajay Singh wrote: > > On Wed, 9 May 2018 16:42:59 +0300 > > Claudiu Beznea wrote: > > > >> On 07.05.2018 11:43, Ajay Singh wrote: > >>> Use kmemdup

[PATCH v3 3/3] net: Dynamically allocate struct station_info

2018-05-10 Thread Toke Høiland-Jørgensen
Since the addition of the TXQ stats to cfg80211, the station_info struct has grown to be quite large, which results in warnings when allocated on the stack. Fix the affected places to do dynamic allocations instead. This patch applies the fix to batman-adv and wext-compat, while a separate patch

[PATCH v3 2/3] staging: Dynamically allocate struct station_info

2018-05-10 Thread Toke Høiland-Jørgensen
Since the addition of the TXQ stats to cfg80211, the station_info struct has grown to be quite large, which results in warnings when allocated on the stack. Fix the affected places to do dynamic allocations instead. This patch applies the fix to the rtl8723bs driver in staging while a separate

[PATCH v3 1/3] wireless-drivers: Dynamically allocate struct station_info

2018-05-10 Thread Toke Høiland-Jørgensen
Since the addition of the TXQ stats to cfg80211, the station_info struct has grown to be quite large, which results in warnings when allocated on the stack. Fix the affected places to do dynamic allocations instead. Fixes: 52539ca89f36 ("cfg80211: Expose TXQ stats and parameters to userspace")