Re: [PATCH v14 2/6] namei: LOOKUP_IN_ROOT: chroot-like path resolution

2019-10-11 Thread Aleksa Sarai
On 2019-10-12, Aleksa Sarai wrote: > On 2019-10-10, Linus Torvalds wrote: > > On Wed, Oct 9, 2019 at 10:42 PM Aleksa Sarai wrote: > > > > > > --- a/fs/namei.c > > > +++ b/fs/namei.c > > > @@ -2277,6 +2277,11 @@ static const char *path_init(struct nameidata *nd, > > > unsigned flags) > > > > >

Re: [PATCH v14 2/6] namei: LOOKUP_IN_ROOT: chroot-like path resolution

2019-10-11 Thread Aleksa Sarai
On 2019-10-10, Linus Torvalds wrote: > On Wed, Oct 9, 2019 at 10:42 PM Aleksa Sarai wrote: > > > > --- a/fs/namei.c > > +++ b/fs/namei.c > > @@ -2277,6 +2277,11 @@ static const char *path_init(struct nameidata *nd, > > unsigned flags) > > > > nd->m_seq = read_seqbegin(_lock); > > > > +

[PATCH] crypto: powerpc - convert SPE AES algorithms to skcipher API

2019-10-11 Thread Eric Biggers
From: Eric Biggers Convert the glue code for the PowerPC SPE implementations of AES-ECB, AES-CBC, AES-CTR, and AES-XTS from the deprecated "blkcipher" API to the "skcipher" API. Tested with: export ARCH=powerpc CROSS_COMPILE=powerpc-linux-gnu- make mpc85xx_defconfig cat

Re: [PATCH 0/2] virtio: Support encrypted memory on powerpc secure guests

2019-10-11 Thread Ram Pai
Hmm.. git-send-email forgot to CC Michael Tsirkin, and Thiago; the original author, who is on vacation. Adding them now. RP On Fri, Oct 11, 2019 at 06:25:17PM -0700, Ram Pai wrote: > **We would like the patches to be merged through the virtio tree. Please > review, and ack merging the DMA

[PATCH 1/2] dma-mapping: Add dma_addr_is_phys_addr()

2019-10-11 Thread Ram Pai
From: Thiago Jung Bauermann In order to safely use the DMA API, virtio needs to know whether DMA addresses are in fact physical addresses and for that purpose, dma_addr_is_phys_addr() is introduced. cc: Benjamin Herrenschmidt cc: David Gibson cc: Michael Ellerman cc: Paul Mackerras cc:

[PATCH 2/2] virtio_ring: Use DMA API if memory is encrypted

2019-10-11 Thread Ram Pai
From: Thiago Jung Bauermann Normally, virtio enables DMA API with VIRTIO_F_IOMMU_PLATFORM, which must be set by both device and guest driver. However, as a hack, when DMA API returns physical addresses, guest driver can use the DMA API; even though device does not set VIRTIO_F_IOMMU_PLATFORM and

[PATCH 0/2] virtio: Support encrypted memory on powerpc secure guests

2019-10-11 Thread Ram Pai
**We would like the patches to be merged through the virtio tree. Please review, and ack merging the DMA mapping change through that tree. Thanks!** The memory of powerpc secure guests can't be accessed by the hypervisor / virtio device except for a few memory regions designated as 'shared'.

Re: [PATCH v8 1/5] kasan: support backing vmalloc space with real shadow memory

2019-10-11 Thread Andrey Ryabinin
On 10/1/19 9:58 AM, Daniel Axtens wrote: > core_initcall(kasan_memhotplug_init); > #endif > + > +#ifdef CONFIG_KASAN_VMALLOC > +static int kasan_populate_vmalloc_pte(pte_t *ptep, unsigned long addr, > + void *unused) > +{ > + unsigned long page; > +

Re: [PATCH v2 -next] ASoC: fsl_mqs: Move static keyword to the front of declarations

2019-10-11 Thread Nicolin Chen
On Fri, Oct 11, 2019 at 10:35:38PM +0800, YueHaibing wrote: > gcc warn about this: > > sound/soc/fsl/fsl_mqs.c:146:1: warning: > static is not at beginning of declaration [-Wold-style-declaration] > > Signed-off-by: YueHaibing Acked-by: Nicolin Chen > --- > v2: Fix patch title > --- >

Re: [PATCH] net/ibmvnic: Fix EOI when running in XIVE mode.

2019-10-11 Thread Thomas Falcon
On 10/11/19 12:52 AM, Cédric Le Goater wrote: pSeries machines on POWER9 processors can run with the XICS (legacy) interrupt mode or with the XIVE exploitation interrupt mode. These interrupt contollers have different interfaces for interrupt management : XICS uses hcalls and XIVE loads and

Re: [PATCH v2 01/29] powerpc: Rename "notes" PT_NOTE to "note"

2019-10-11 Thread Segher Boessenkool
On Fri, Oct 11, 2019 at 09:11:43AM -0700, Kees Cook wrote: > On Fri, Oct 11, 2019 at 03:25:19AM -0500, Segher Boessenkool wrote: > > On Thu, Oct 10, 2019 at 05:05:41PM -0700, Kees Cook wrote: > > > The Program Header identifiers are internal to the linker scripts. In > > > preparation for moving

Re: [PATCH v2 01/29] powerpc: Rename "notes" PT_NOTE to "note"

2019-10-11 Thread Kees Cook
On Fri, Oct 11, 2019 at 03:25:19AM -0500, Segher Boessenkool wrote: > On Thu, Oct 10, 2019 at 05:05:41PM -0700, Kees Cook wrote: > > The Program Header identifiers are internal to the linker scripts. In > > preparation for moving the NOTES segment declaration into RO_DATA, > > standardize the

Re: [PATCH v2 02/29] powerpc: Remove PT_NOTE workaround

2019-10-11 Thread Kees Cook
On Fri, Oct 11, 2019 at 05:07:04PM +1100, Michael Ellerman wrote: > Kees Cook writes: > > In preparation for moving NOTES into RO_DATA, remove the PT_NOTE > > workaround since the kernel requires at least gcc 4.6 now. > > > > Signed-off-by: Kees Cook > > --- > >

[PATCH v2 -next] ASoC: fsl_mqs: Move static keyword to the front of declarations

2019-10-11 Thread YueHaibing
gcc warn about this: sound/soc/fsl/fsl_mqs.c:146:1: warning: static is not at beginning of declaration [-Wold-style-declaration] Signed-off-by: YueHaibing --- v2: Fix patch title --- sound/soc/fsl/fsl_mqs.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

Re: [PATCH -next] ASoC: fsl_mqs: fix old-style function declaration

2019-10-11 Thread Yuehaibing
On 2019/10/11 21:12, Andreas Schwab wrote: > On Okt 11 2019, YueHaibing wrote: > >> gcc warn about this: >> >> sound/soc/fsl/fsl_mqs.c:146:1: warning: >> static is not at beginning of declaration [-Wold-style-declaration] > > It's not a function, though. Oh..., will fix this, thanks! > >

Re: [PATCH v7 7/8] ima: check against blacklisted hashes for files with modsig

2019-10-11 Thread Mimi Zohar
On Mon, 2019-10-07 at 21:14 -0400, Nayna Jain wrote: > Asymmetric private keys are used to sign multiple files. The kernel > currently support checking against the blacklisted keys. However, if the > public key is blacklisted, any file signed by the blacklisted key will > automatically fail

Re: [PATCH v7 8/8] powerpc/ima: update ima arch policy to check for blacklist

2019-10-11 Thread Mimi Zohar
On Mon, 2019-10-07 at 21:14 -0400, Nayna Jain wrote: > This patch updates the arch specific policies for PowernV systems > to add check against blacklisted binary hashes before doing the > verification. This sentence explains how you're doing something.  A simple tweak in the wording provides the

Re: [PATCH v7 6/8] certs: add wrapper function to check blacklisted binary hash

2019-10-11 Thread Mimi Zohar
On Mon, 2019-10-07 at 21:14 -0400, Nayna Jain wrote: > The existing is_hash_blacklisted() function returns -EKEYREJECTED > error code for both the blacklisted keys and binaries. > > This patch adds a wrapper function is_binary_blacklisted() to check > against binary hashes and returns -EPERM.    

Re: [PATCH v7 5/8] ima: make process_buffer_measurement() generic

2019-10-11 Thread Mimi Zohar
[Cc'ing Prakhar Srivastava] On Mon, 2019-10-07 at 21:14 -0400, Nayna Jain wrote: > An additional measurement record is needed to indicate the blacklisted > binary. The record will measure the blacklisted binary hash. > > This patch makes the function process_buffer_measurement() generic to be >

Re: [PATCH v7 2/8] powerpc: add support to initialize ima policy rules

2019-10-11 Thread Mimi Zohar
On Mon, 2019-10-07 at 21:14 -0400, Nayna Jain wrote: > PowerNV systems uses kernel based bootloader, thus its secure boot > implementation uses kernel IMA security subsystem to verify the kernel > before kexec. ^use a Linux based bootloader, which rely on the IMA subsystem to enforce different

Re: [PATCH -next] ASoC: fsl_mqs: fix old-style function declaration

2019-10-11 Thread Andreas Schwab
On Okt 11 2019, YueHaibing wrote: > gcc warn about this: > > sound/soc/fsl/fsl_mqs.c:146:1: warning: > static is not at beginning of declaration [-Wold-style-declaration] It's not a function, though. Andreas. -- Andreas Schwab, sch...@linux-m68k.org GPG Key fingerprint = 7578 EB47 D4E5 4D69

Re: [PATCH v6] numa: make node_to_cpumask_map() NUMA_NO_NODE aware

2019-10-11 Thread Peter Zijlstra
On Fri, Oct 11, 2019 at 11:27:54AM +0800, Yunsheng Lin wrote: > But I failed to see why the above is related to making node_to_cpumask_map() > NUMA_NO_NODE aware? Your initial bug is for hns3, which is a PCI device, which really _MUST_ have a node assigned. It not having one, is a straight up

[PATCH -next] ASoC: fsl_mqs: fix old-style function declaration

2019-10-11 Thread YueHaibing
gcc warn about this: sound/soc/fsl/fsl_mqs.c:146:1: warning: static is not at beginning of declaration [-Wold-style-declaration] Signed-off-by: YueHaibing --- sound/soc/fsl/fsl_mqs.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/sound/soc/fsl/fsl_mqs.c

Re: [PATCH 0/2] ocxl: Move SPA and TL definitions

2019-10-11 Thread christophe lombard
On 11/10/2019 10:06, christophe lombard wrote: On 11/10/2019 00:34, Andrew Donnellan wrote: On 10/10/19 2:11 am, christophe lombard wrote: This series moves the definition and the management of scheduled process area (SPA) and of the templates (Transaction Layer) for an ocxl card, using the

Re: [PATCH 1/3] powernv/iov: Ensure the pdn for VFs always contains a valid PE number

2019-10-11 Thread Michael Ellerman
"Oliver O'Halloran" writes: > On Tue, Oct 1, 2019 at 3:09 AM Bjorn Helgaas wrote: >> On Mon, Sep 30, 2019 at 12:08:46PM +1000, Oliver O'Halloran wrote: >> This is all powerpc, so I assume Michael will handle this. Just >> random things I noticed; ignore if they don't make sense: >> >> > On

Re: [PATCH v2 01/29] powerpc: Rename "notes" PT_NOTE to "note"

2019-10-11 Thread Segher Boessenkool
On Thu, Oct 10, 2019 at 05:05:41PM -0700, Kees Cook wrote: > The Program Header identifiers are internal to the linker scripts. In > preparation for moving the NOTES segment declaration into RO_DATA, > standardize the identifier for the PT_NOTE entry to "note" as used by > all other architectures

Re: [PATCH] spufs: fix a crash in spufs_create_root()

2019-10-11 Thread Michael Ellerman
On Tue, 2019-10-08 at 14:13:42 UTC, Emmanuel Nicolet wrote: > The spu_fs_context was not set in fc->fs_private, this caused a crash > when accessing ctx->mode in spufs_create_root(). > > Signed-off-by: Emmanuel Nicolet Applied to powerpc fixes, thanks.

Re: [PATCH] powerpc/kvm: Fix kvmppc_vcore->in_guest value in kvmhv_switch_to_host

2019-10-11 Thread Michael Ellerman
On Fri, 2019-10-04 at 02:53:17 UTC, Jordan Niethe wrote: > kvmhv_switch_to_host() in arch/powerpc/kvm/book3s_hv_rmhandlers.S needs > to set kvmppc_vcore->in_guest to 0 to signal secondary CPUs to continue. > This happens after resetting the PCR. Before commit 13c7bb3c57dc > ("powerpc/64s: Set

Re: [PATCH] selftests/powerpc: Fix compiling error on tlbie_test due to newer gcc

2019-10-11 Thread Michael Ellerman
On Thu, 2019-10-03 at 21:10:10 UTC, "Desnes A. Nunes do Rosario" wrote: > Newer versions of GCC demand that the size of the string to be copied must > be explicitly smaller than the size of the destination. Thus, the NULL > char has to be taken into account on strncpy. > > This will avoid the

Re: [PATCH] powerpc/pseries: Remove confusing warning message.

2019-10-11 Thread Michael Ellerman
On Tue, 2019-10-01 at 13:29:28 UTC, Laurent Dufour wrote: > Since the commit 1211ee61b4a8 ("powerpc/pseries: Read TLB Block Invalidate > Characteristics"), a warning message is displayed when booting a guest on > top of KVM: > > lpar: arch/powerpc/platforms/pseries/lpar.c >

Re: linux-next: build failure after merge of the powerpc tree

2019-10-11 Thread Michael Ellerman
On Mon, 2019-09-30 at 00:13:42 UTC, Stephen Rothwell wrote: > Hi all, > > After merging the powerpc tree, today's linux-next build (powerpc64 > allnoconfig) failed like this: > > arch/powerpc/mm/book3s64/pgtable.c: In function 'flush_partition': > arch/powerpc/mm/book3s64/pgtable.c:216:3: error:

Re: [PATCH 0/2] ocxl: Move SPA and TL definitions

2019-10-11 Thread christophe lombard
On 11/10/2019 00:34, Andrew Donnellan wrote: On 10/10/19 2:11 am, christophe lombard wrote: This series moves the definition and the management of scheduled process area (SPA) and of the templates (Transaction Layer) for an ocxl card, using the OCAPI interface. The code is now located in the

Re: [PATCH v2 12/29] vmlinux.lds.h: Replace RO_DATA_SECTION with RO_DATA

2019-10-11 Thread Geert Uytterhoeven
On Fri, Oct 11, 2019 at 2:07 AM Kees Cook wrote: > Finish renaming RO_DATA_SECTION to RO_DATA. (Calling this a "section" > is a lie, since it's multiple sections and section flags cannot be > applied to the macro.) > > Signed-off-by: Kees Cook > arch/m68k/kernel/vmlinux-nommu.lds | 2 +- For

Re: [PATCH v2 13/29] vmlinux.lds.h: Replace RW_DATA_SECTION with RW_DATA

2019-10-11 Thread Geert Uytterhoeven
On Fri, Oct 11, 2019 at 2:07 AM Kees Cook wrote: > Rename RW_DATA_SECTION to RW_DATA. (Calling this a "section" is a lie, > since it's multiple sections and section flags cannot be applied to > the macro.) > > Signed-off-by: Kees Cook > arch/m68k/kernel/vmlinux-nommu.lds | 2 +- >

[PATCH V5 2/2] mm/debug: Add tests validating architecture page table helpers

2019-10-11 Thread Anshuman Khandual
This adds tests which will validate architecture page table helpers and other accessors in their compliance with expected generic MM semantics. This will help various architectures in validating changes to existing page table helpers or addition of new ones. Test page table and memory pages

[PATCH V5 1/2] mm/hugetlb: Make alloc_gigantic_page() available for general use

2019-10-11 Thread Anshuman Khandual
alloc_gigantic_page() implements an allocation method where it scans over various zones looking for a large contiguous memory block which could not have been allocated through the buddy allocator. A subsequent patch which tests arch page table helpers needs such a method to allocate PUD_SIZE sized

[PATCH V5 0/2] mm/debug: Add tests validating architecture page table helpers

2019-10-11 Thread Anshuman Khandual
This series adds a test validation for architecture exported page table helpers. Patch in the series adds basic transformation tests at various levels of the page table. Before that it exports gigantic page allocation function from HugeTLB. This test was originally suggested by Catalin during

Re: [PATCH v2 03/29] powerpc: Rename PT_LOAD identifier "kernel" to "text"

2019-10-11 Thread Michael Ellerman
Kees Cook writes: > In preparation for moving NOTES into RO_DATA, rename the linker script > internal identifier for the PT_LOAD Program Header from "kernel" to > "text" to match other architectures. > > Signed-off-by: Kees Cook > --- > arch/powerpc/kernel/vmlinux.lds.S | 12 ++-- > 1

Re: [PATCH v2 02/29] powerpc: Remove PT_NOTE workaround

2019-10-11 Thread Michael Ellerman
Kees Cook writes: > In preparation for moving NOTES into RO_DATA, remove the PT_NOTE > workaround since the kernel requires at least gcc 4.6 now. > > Signed-off-by: Kees Cook > --- > arch/powerpc/kernel/vmlinux.lds.S | 24 ++-- > 1 file changed, 2 insertions(+), 22

Re: [PATCH v2 01/29] powerpc: Rename "notes" PT_NOTE to "note"

2019-10-11 Thread Michael Ellerman
Kees Cook writes: > The Program Header identifiers are internal to the linker scripts. In > preparation for moving the NOTES segment declaration into RO_DATA, > standardize the identifier for the PT_NOTE entry to "note" as used by > all other architectures that emit PT_NOTE. > > Signed-off-by: