Re: [PATCH v3 3/5] powerpc/mm: add radix__create_section_mapping()

2016-12-20 Thread Anshuman Khandual
On 12/19/2016 02:34 PM, Aneesh Kumar K.V wrote: > Reza Arbab writes: > >> > Add the linear page mapping function for radix, used by memory hotplug. >> > This is similar to vmemmap_populate(). >> > > Ok with this patch your first patch becomes useful. Can you merge that > with this and rename mmu_

Re: [PATCH v3 3/5] powerpc/mm: add radix__create_section_mapping()

2016-12-20 Thread Reza Arbab
On Tue, Dec 20, 2016 at 05:28:40PM +1100, Balbir Singh wrote: +#ifdef CONFIG_MEMORY_HOTPLUG +int radix__create_section_mapping(unsigned long start, unsigned long end) +{ + unsigned long page_size = 1 << mmu_psize_defs[mmu_linear_psize].shift; Can we refactor bits from radix_init_pgtable()

Re: [PATCH v3 3/5] powerpc/mm: add radix__create_section_mapping()

2016-12-19 Thread Balbir Singh
+#ifdef CONFIG_MEMORY_HOTPLUG +int radix__create_section_mapping(unsigned long start, unsigned long end) +{ + unsigned long page_size = 1 << mmu_psize_defs[mmu_linear_psize].shift; Can we refactor bits from radix_init_pgtable() and reuse? Balbir

Re: [PATCH v3 3/5] powerpc/mm: add radix__create_section_mapping()

2016-12-19 Thread Reza Arbab
On Mon, Dec 19, 2016 at 02:34:13PM +0530, Aneesh Kumar K.V wrote: Reza Arbab writes: Add the linear page mapping function for radix, used by memory hotplug. This is similar to vmemmap_populate(). Ok with this patch your first patch becomes useful. Can you merge that with this and rename mmu

Re: [PATCH v3 3/5] powerpc/mm: add radix__create_section_mapping()

2016-12-19 Thread Aneesh Kumar K.V
Reza Arbab writes: > Add the linear page mapping function for radix, used by memory hotplug. > This is similar to vmemmap_populate(). > Ok with this patch your first patch becomes useful. Can you merge that with this and rename mmu_linear_psize to mmu_hotplug_psize or even use mmu_virtual_psize.

[PATCH v3 3/5] powerpc/mm: add radix__create_section_mapping()

2016-12-15 Thread Reza Arbab
Add the linear page mapping function for radix, used by memory hotplug. This is similar to vmemmap_populate(). Signed-off-by: Reza Arbab --- arch/powerpc/include/asm/book3s/64/radix.h | 4 arch/powerpc/mm/pgtable-book3s64.c | 2 +- arch/powerpc/mm/pgtable-radix.c| 19 +