[Lldb-commits] [PATCH] D75810: [lldb] Add .clang-tidy with customization to readability-identifier-naming.{Function, Member, Parameter, Variable}Case

2020-03-09 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added a comment.

In D75810#1912248 , @labath wrote:

> Yeah, naming conventions in lldb have always been a controversial topic. Most 
> of the code uses the lldb convention, but some of the new code (particularly 
> if it interfaces with llvm a lot) uses more llvm-like conventions. I think we 
> used to have a description of the naming convention somewhere on the website. 
> That is no longer there, but neither do we have a plan for migration.
>
> I don't really know what that means for this patch...


I would exclude `readability-identifier-naming` from the list of checks.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D75810/new/

https://reviews.llvm.org/D75810



___
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits


[Lldb-commits] [PATCH] D75810: [lldb] Add .clang-tidy with customization to readability-identifier-naming.{Function, Member, Parameter, Variable}Case

2020-03-09 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment.

Yeah, naming conventions in lldb have always been a controversial topic. Most 
of the code uses the lldb convention, but some of the new code (particularly if 
it interfaces with llvm a lot) uses more llvm-like conventions. I think we used 
to have a description of the naming convention somewhere on the website. That 
is no longer there, but neither do we have a plan for migration.

I don't really know what that means for this patch...


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D75810/new/

https://reviews.llvm.org/D75810



___
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits


[Lldb-commits] [PATCH] D75810: [lldb] Add .clang-tidy with customization to readability-identifier-naming.{Function, Member, Parameter, Variable}Case

2020-03-07 Thread Fangrui Song via Phabricator via lldb-commits
MaskRay created this revision.
MaskRay added reviewers: JDevlieghere, jingham, labath.
Herald added subscribers: lldb-commits, aheejin.
Herald added a project: LLDB.
MaskRay added a comment.

https://github.com/google/llvm-premerge-checks/issues/142 This should suppress 
the annoying `clang-tidy linux` diagnostics in `Diff Detail - Build Status`.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D75810

Files:
  lldb/.clang-tidy


Index: lldb/.clang-tidy
===
--- /dev/null
+++ lldb/.clang-tidy
@@ -0,0 +1,21 @@
+# Almost identical to the top-level .clang-tidy, except that
+# - FunctionCase uses CamelCase
+# - {Member,Parameter,Variable}Case use lower_case
+Checks: 
'-*,clang-diagnostic-*,llvm-*,misc-*,-misc-unused-parameters,-misc-non-private-member-variables-in-classes,readability-identifier-naming'
+CheckOptions:
+  - key: readability-identifier-naming.ClassCase
+value:   CamelCase
+  - key: readability-identifier-naming.EnumCase
+value:   CamelCase
+  - key: readability-identifier-naming.FunctionCase
+value:   CamelCase
+  - key: readability-identifier-naming.MemberCase
+value:   lower_case
+  - key: readability-identifier-naming.ParameterCase
+value:   lower_case
+  - key: readability-identifier-naming.UnionCase
+value:   CamelCase
+  - key: readability-identifier-naming.VariableCase
+value:   lower_case
+  - key: readability-identifier-naming.IgnoreMainLikeFunctions
+value:   1


Index: lldb/.clang-tidy
===
--- /dev/null
+++ lldb/.clang-tidy
@@ -0,0 +1,21 @@
+# Almost identical to the top-level .clang-tidy, except that
+# - FunctionCase uses CamelCase
+# - {Member,Parameter,Variable}Case use lower_case
+Checks: '-*,clang-diagnostic-*,llvm-*,misc-*,-misc-unused-parameters,-misc-non-private-member-variables-in-classes,readability-identifier-naming'
+CheckOptions:
+  - key: readability-identifier-naming.ClassCase
+value:   CamelCase
+  - key: readability-identifier-naming.EnumCase
+value:   CamelCase
+  - key: readability-identifier-naming.FunctionCase
+value:   CamelCase
+  - key: readability-identifier-naming.MemberCase
+value:   lower_case
+  - key: readability-identifier-naming.ParameterCase
+value:   lower_case
+  - key: readability-identifier-naming.UnionCase
+value:   CamelCase
+  - key: readability-identifier-naming.VariableCase
+value:   lower_case
+  - key: readability-identifier-naming.IgnoreMainLikeFunctions
+value:   1
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits


[Lldb-commits] [PATCH] D75810: [lldb] Add .clang-tidy with customization to readability-identifier-naming.{Function, Member, Parameter, Variable}Case

2020-03-07 Thread Fangrui Song via Phabricator via lldb-commits
MaskRay added a comment.

https://github.com/google/llvm-premerge-checks/issues/142 This should suppress 
the annoying `clang-tidy linux` diagnostics in `Diff Detail - Build Status`.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D75810/new/

https://reviews.llvm.org/D75810



___
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits