[llvm-commits] Need better way to build bison files

2007-04-26 Thread Jeff Cohen
My nightly tester failed last night for the following reason: cvs update: conflicts found in lib/AsmParser/llvmAsmParser.cpp.cvs C lib/AsmParser/llvmAsmParser.cpp.cvs Needless to say, the tester is not in the business of modifying source code, but it manages to modify a file under cvs

[llvm-commits] CVS: CVSROOT/loginfo

2007-04-26 Thread John Criswell
Changes in directory CVSROOT: loginfo updated: 1.15 - 1.16 --- Log message: Added entry for paper I'm working on. --- Diffs of the changes: (+1 -0) loginfo |1 + 1 files changed, 1 insertion(+) Index: CVSROOT/loginfo diff -u CVSROOT/loginfo:1.15 CVSROOT/loginfo:1.16 ---

Re: [llvm-commits] Need better way to build bison files

2007-04-26 Thread Reid Spencer
On Thu, 26 Apr 2007 07:16:31 -0700 Jeff Cohen [EMAIL PROTECTED] wrote: My nightly tester failed last night for the following reason: cvs update: conflicts found in lib/AsmParser/llvmAsmParser.cpp.cvs C lib/AsmParser/llvmAsmParser.cpp.cvs Needless to say, the tester is not in

[llvm-commits] CVS: llvm/include/llvm/ADT/BitVector.h

2007-04-26 Thread Jeff Cohen
Changes in directory llvm/include/llvm/ADT: BitVector.h updated: 1.21 - 1.22 --- Log message: Rename identifier that GCC uses as a macro, breaking llvm-gcc build. --- Diffs of the changes: (+22 -22) BitVector.h | 44 ++-- 1 files changed, 22

Re: [llvm-commits] Need better way to build bison files

2007-04-26 Thread Chris Lattner
On Apr 26, 2007, at 7:16 AM, Jeff Cohen wrote: My nightly tester failed last night for the following reason: cvs update: conflicts found in lib/AsmParser/llvmAsmParser.cpp.cvs C lib/AsmParser/llvmAsmParser.cpp.cvs Needless to say, the tester is not in the business of modifying source

[llvm-commits] CVS: llvm/lib/Transforms/Scalar/PredicateSimplifier.cpp

2007-04-26 Thread Zhou Sheng
Changes in directory llvm/lib/Transforms/Scalar: PredicateSimplifier.cpp updated: 1.70 - 1.71 --- Log message: Using APInt more efficiently. --- Diffs of the changes: (+4 -5) PredicateSimplifier.cpp |9 - 1 files changed, 4 insertions(+), 5 deletions(-) Index:

[llvm-commits] CVS: llvm/lib/Support/ConstantRange.cpp

2007-04-26 Thread Zhou Sheng
Changes in directory llvm/lib/Support: ConstantRange.cpp updated: 1.44 - 1.45 --- Log message: Using APInt more efficiently. --- Diffs of the changes: (+3 -5) ConstantRange.cpp |8 +++- 1 files changed, 3 insertions(+), 5 deletions(-) Index: llvm/lib/Support/ConstantRange.cpp

[llvm-commits] CVS: llvm/test/Analysis/ScalarEvolution/SolveQuadraticEquation.ll trip-count2.ll

2007-04-26 Thread Zhou Sheng
Changes in directory llvm/test/Analysis/ScalarEvolution: SolveQuadraticEquation.ll added (r1.1) trip-count2.ll added (r1.1) --- Log message: Add two test cases to cover apintification change. --- Diffs of the changes: (+67 -0) SolveQuadraticEquation.ll | 32

[llvm-commits] CVS: llvm/utils/TableGen/DAGISelEmitter.cpp

2007-04-26 Thread Lauro Ramos Venancio
Changes in directory llvm/utils/TableGen: DAGISelEmitter.cpp updated: 1.293 - 1.294 --- Log message: bugfix: remember that ResNode was declared. --- Diffs of the changes: (+3 -2) DAGISelEmitter.cpp |5 +++-- 1 files changed, 3 insertions(+), 2 deletions(-) Index:

[llvm-commits] CVS: llvm-test/GenerateReport.pl TEST.dsgraph.Makefile TEST.dsgraph.gnuplot TEST.dsgraph.report TEST.dsprecision.Makefile TEST.dsprecision.report

2007-04-26 Thread Andrew Lenharth
Changes in directory llvm-test: GenerateReport.pl updated: 1.29 - 1.30 TEST.dsgraph.Makefile (r1.18) removed TEST.dsgraph.gnuplot (r1.1) removed TEST.dsgraph.report (r1.15) removed TEST.dsprecision.Makefile (r1.3) removed TEST.dsprecision.report (r1.5) removed --- Log message: numberic sort

[llvm-commits] CVS: llvm-poolalloc/test/TEST.dsgraph.Makefile TEST.dsgraph.gnuplot TEST.dsgraph.report TEST.dsprecision.Makefile TEST.dsprecision.report

2007-04-26 Thread Andrew Lenharth
Changes in directory llvm-poolalloc/test: TEST.dsgraph.Makefile added (r1.1) TEST.dsgraph.gnuplot added (r1.1) TEST.dsgraph.report added (r1.1) TEST.dsprecision.Makefile added (r1.1) TEST.dsprecision.report added (r1.1) --- Log message: more dsa tests here --- Diffs of the changes: (+545 -0)

[llvm-commits] CVS: llvm-test/configure

2007-04-26 Thread Andrew Lenharth
Changes in directory llvm-test: configure updated: 1.45 - 1.46 --- Log message: removed these from the configure file too --- Diffs of the changes: (+0 -18) configure | 18 -- 1 files changed, 18 deletions(-) Index: llvm-test/configure diff -u llvm-test/configure:1.45

[llvm-commits] CVS: llvm-test/autoconf/configure.ac

2007-04-26 Thread Andrew Lenharth
Changes in directory llvm-test/autoconf: configure.ac updated: 1.43 - 1.44 --- Log message: removed these from the configure file too --- Diffs of the changes: (+0 -3) configure.ac |3 --- 1 files changed, 3 deletions(-) Index: llvm-test/autoconf/configure.ac diff -u

[llvm-commits] CVS: llvm/lib/VMCore/PassManager.cpp

2007-04-26 Thread Devang Patel
Changes in directory llvm/lib/VMCore: PassManager.cpp updated: 1.152 - 1.153 --- Log message: Use toplevel function pass manager as OnTheFly manager. --- Diffs of the changes: (+17 -10) PassManager.cpp | 27 +-- 1 files changed, 17 insertions(+), 10 deletions(-)

[llvm-commits] CVS: llvm/lib/ExecutionEngine/Interpreter/Execution.cpp

2007-04-26 Thread Reid Spencer
Changes in directory llvm/lib/ExecutionEngine/Interpreter: Execution.cpp updated: 1.179 - 1.180 --- Log message: 1. Don't swap byte order in scanf. It isn't necessary and leads to incorrect results (canonicalization was dropped several commits ago). 2. Add support for fscanf. 3. Suppress a

[llvm-commits] CVS: llvm/lib/CodeGen/LiveIntervalAnalysis.cpp LiveVariables.cpp MachineInstr.cpp RegisterScavenging.cpp VirtRegMap.cpp

2007-04-26 Thread Evan Cheng
Changes in directory llvm/lib/CodeGen: LiveIntervalAnalysis.cpp updated: 1.238 - 1.239 LiveVariables.cpp updated: 1.78 - 1.79 MachineInstr.cpp updated: 1.146 - 1.147 RegisterScavenging.cpp updated: 1.15 - 1.16 VirtRegMap.cpp updated: 1.110 - 1.111 --- Log message: Rename findRegisterUseOperand

[llvm-commits] CVS: llvm/include/llvm/CodeGen/MachineInstr.h

2007-04-26 Thread Evan Cheng
Changes in directory llvm/include/llvm/CodeGen: MachineInstr.h updated: 1.216 - 1.217 --- Log message: Rename findRegisterUseOperand to findRegisterUseOperandIdx to avoid confusion. --- Diffs of the changes: (+2 -2) MachineInstr.h |4 ++-- 1 files changed, 2 insertions(+), 2

[llvm-commits] CVS: llvm/lib/Target/ARM/ARMInstrInfo.cpp ARMLoadStoreOptimizer.cpp

2007-04-26 Thread Evan Cheng
Changes in directory llvm/lib/Target/ARM: ARMInstrInfo.cpp updated: 1.21 - 1.22 ARMLoadStoreOptimizer.cpp updated: 1.7 - 1.8 --- Log message: Rename findRegisterUseOperand to findRegisterUseOperandIdx to avoid confusion. --- Diffs of the changes: (+2 -2) ARMInstrInfo.cpp |2 +-

[llvm-commits] CVS: llvm/test/Feature/alignment.ll

2007-04-26 Thread Andrew Lenharth
Changes in directory llvm/test/Feature: alignment.ll updated: 1.3 - 1.4 --- Log message: An example for PR1362: http://llvm.org/PR1362 --- Diffs of the changes: (+1 -0) alignment.ll |1 + 1 files changed, 1 insertion(+) Index: llvm/test/Feature/alignment.ll diff -u

[llvm-commits] CVS: llvm/include/llvm/Target/TargetData.h

2007-04-26 Thread Dan Gohman
Changes in directory llvm/include/llvm/Target: TargetData.h updated: 1.59 - 1.60 --- Log message: Fix a typo in a comment. --- Diffs of the changes: (+1 -1) TargetData.h |2 +- 1 files changed, 1 insertion(+), 1 deletion(-) Index: llvm/include/llvm/Target/TargetData.h diff -u

[llvm-commits] CVS: llvm/lib/CodeGen/SelectionDAG/ScheduleDAGRRList.cpp

2007-04-26 Thread Dan Gohman
Changes in directory llvm/lib/CodeGen/SelectionDAG: ScheduleDAGRRList.cpp updated: 1.29 - 1.30 --- Log message: Fix a typo in a comment. --- Diffs of the changes: (+1 -1) ScheduleDAGRRList.cpp |2 +- 1 files changed, 1 insertion(+), 1 deletion(-) Index:

[llvm-commits] CVS: llvm/utils/TableGen/CodeGenIntrinsics.h

2007-04-26 Thread Dan Gohman
Changes in directory llvm/utils/TableGen: CodeGenIntrinsics.h updated: 1.12 - 1.13 --- Log message: Update a comment to reflect recent changes in the type system. --- Diffs of the changes: (+1 -1) CodeGenIntrinsics.h |2 +- 1 files changed, 1 insertion(+), 1 deletion(-) Index:

[llvm-commits] CVS: llvm-poolalloc/runtime/FL2Allocator/Makefile

2007-04-26 Thread Andrew Lenharth
Changes in directory llvm-poolalloc/runtime/FL2Allocator: Makefile updated: 1.5 - 1.6 --- Log message: fix memalign casting --- Diffs of the changes: (+4 -0) Makefile |4 1 files changed, 4 insertions(+) Index: llvm-poolalloc/runtime/FL2Allocator/Makefile diff -u

[llvm-commits] CVS: llvm-poolalloc/test/TEST.poolalloc.Makefile

2007-04-26 Thread Andrew Lenharth
Changes in directory llvm-poolalloc/test: TEST.poolalloc.Makefile updated: 1.41 - 1.42 --- Log message: fix memalign casting --- Diffs of the changes: (+6 -4) TEST.poolalloc.Makefile | 10 ++ 1 files changed, 6 insertions(+), 4 deletions(-) Index:

[llvm-commits] CVS: llvm-test/MultiSource/Benchmarks/Olden/voronoi/newvor.c

2007-04-26 Thread Andrew Lenharth
Changes in directory llvm-test/MultiSource/Benchmarks/Olden/voronoi: newvor.c updated: 1.11 - 1.12 --- Log message: I think the correct thing to do is decide if malloc.h should be included based on OS, not arch --- Diffs of the changes: (+1 -1) newvor.c |2 +- 1 files changed, 1

[llvm-commits] CVS: llvm-poolalloc/lib/PoolAllocate/Heuristic.cpp TransformFunctionBody.cpp

2007-04-26 Thread Andrew Lenharth
Changes in directory llvm-poolalloc/lib/PoolAllocate: Heuristic.cpp updated: 1.18 - 1.19 TransformFunctionBody.cpp updated: 1.64 - 1.65 --- Log message: fix memalign casting --- Diffs of the changes: (+6 -6) Heuristic.cpp |2 +- TransformFunctionBody.cpp | 10 +-

Re: [llvm-commits] CVS: llvm-test/MultiSource/Benchmarks/Olden/voronoi/newvor.c

2007-04-26 Thread Jeff Cohen
Absolutely true. This change will cause the test to fail on the BSDs, which will complain that malloc.h has been replaced by stdlib.h. Please use a different test. Andrew Lenharth wrote: Changes in directory llvm-test/MultiSource/Benchmarks/Olden/voronoi: newvor.c updated: 1.11 - 1.12 ---

[llvm-commits] CVS: llvm-test/MultiSource/Benchmarks/Olden/voronoi/newvor.c

2007-04-26 Thread Andrew Lenharth
Changes in directory llvm-test/MultiSource/Benchmarks/Olden/voronoi: newvor.c updated: 1.12 - 1.13 --- Log message: test os rather than arch --- Diffs of the changes: (+1 -1) newvor.c |2 +- 1 files changed, 1 insertion(+), 1 deletion(-) Index:

[llvm-commits] CVS: llvm/test/CodeGen/X86/2007-04-27-BitTestsBadMask.ll

2007-04-26 Thread Anton Korobeynikov
Changes in directory llvm/test/CodeGen/X86: 2007-04-27-BitTestsBadMask.ll added (r1.1) --- Log message: Fixx off-by-one bug, which prevents llvm-gcc bootstrap on ppc32 --- Diffs of the changes: (+18 -0) 2007-04-27-BitTestsBadMask.ll | 18 ++ 1 files changed, 18

[llvm-commits] CVS: llvm/test/CodeGen/X86/2007-04-27-BitTestsBadMask.ll

2007-04-26 Thread LLVM
Changes in directory llvm/test/CodeGen/X86: 2007-04-27-BitTestsBadMask.ll (r1.1) removed --- Log message: Add test to proper place. Also, XFAIL until ppc bootstrap will be ok. --- Diffs of the changes: (+0 -0) 0 files changed ___ llvm-commits

[llvm-commits] CVS: llvm/test/CodeGen/Generic/2007-04-27-BitTestsBadMask.ll

2007-04-26 Thread Anton Korobeynikov
Changes in directory llvm/test/CodeGen/Generic: 2007-04-27-BitTestsBadMask.ll added (r1.1) --- Log message: Add test to proper place. Also, XFAIL until ppc bootstrap will be ok. --- Diffs of the changes: (+21 -0) 2007-04-27-BitTestsBadMask.ll | 21 + 1 files changed,

[llvm-commits] CVS: llvm-www/Users.html

2007-04-26 Thread Bill Wendling
Changes in directory llvm-www: Users.html updated: 1.16 - 1.17 --- Log message: Use an HTML entity instead of the non-Latin character. Please use entities for non-Latin characters in the future. That way all browsers will be able to render it correctly. --- Diffs of the changes: (+2 -2)

[llvm-commits] CVS: llvm/test/CodeGen/X86/dollar-name.ll

2007-04-26 Thread Dan Gohman
Changes in directory llvm/test/CodeGen/X86: dollar-name.ll added (r1.1) --- Log message: testcase for PR1339: http://llvm.org/PR1339 : http://llvm.org/PR1339: http://llvm.org/PR1339 --- Diffs of the changes: (+17 -0) dollar-name.ll | 17 + 1 files changed, 17

[llvm-commits] CVS: llvm/include/llvm/Pass.h

2007-04-26 Thread Devang Patel
Changes in directory llvm/include/llvm: Pass.h updated: 1.84 - 1.85 --- Log message: Delete Analysis Resolver. --- Diffs of the changes: (+1 -1) Pass.h |2 +- 1 files changed, 1 insertion(+), 1 deletion(-) Index: llvm/include/llvm/Pass.h diff -u llvm/include/llvm/Pass.h:1.84

[llvm-commits] CVS: llvm/lib/Target/X86/X86InstrX86-64.td

2007-04-26 Thread Bill Wendling
Changes in directory llvm/lib/Target/X86: X86InstrX86-64.td updated: 1.14 - 1.15 --- Log message: Have MMX registers clobbered in x86-64 too. --- Diffs of the changes: (+1 -0) X86InstrX86-64.td |1 + 1 files changed, 1 insertion(+) Index: llvm/lib/Target/X86/X86InstrX86-64.td diff

[llvm-commits] CVS: llvm/lib/Target/X86/X86ATTAsmPrinter.cpp

2007-04-26 Thread Dan Gohman
Changes in directory llvm/lib/Target/X86: X86ATTAsmPrinter.cpp updated: 1.102 - 1.103 --- Log message: Fix PR1339: http://llvm.org/PR1339 and CodeGen/X86/dollar-name.ll --- Diffs of the changes: (+32 -3) X86ATTAsmPrinter.cpp | 35 --- 1 files changed, 32

[llvm-commits] CVS: llvm/lib/CodeGen/SelectionDAG/SelectionDAGISel.cpp

2007-04-26 Thread Chris Lattner
Changes in directory llvm/lib/CodeGen/SelectionDAG: SelectionDAGISel.cpp updated: 1.429 - 1.430 --- Log message: enable Anton's shift/and switch lowering stuff! It now passes ppc bootstrap successfully! woohoo... --- Diffs of the changes: (+0 -1) SelectionDAGISel.cpp |1 - 1 files

Re: [llvm-commits] CVS: llvm-test/MultiSource/Benchmarks/Olden/voronoi/newvor.c

2007-04-26 Thread Chris Lattner
On Apr 26, 2007, at 1:11 PM, Jeff Cohen wrote: Absolutely true. This change will cause the test to fail on the BSDs, which will complain that malloc.h has been replaced by stdlib.h. Please use a different test. Better yet, just unconditionally #include stdlib.h and eliminate malloc.h

Re: [llvm-commits] CVS: llvm/include/llvm/Pass.h

2007-04-26 Thread Chris Lattner
From IRC: heisenbug: /gdm/llvm/include/llvm/Pass.h: In destructor 'virtual llvm::Pass::~Pass()': heisenbug: /gdm/llvm/include/llvm/Pass.h:91: warning: possible problem detected in invocation of delete operator: heisenbug: /gdm/llvm/include/llvm/Pass.h:91: warning: invalid use of undefined

[llvm-commits] CVS: llvm/test/CodeGen/Generic/2007-04-14-BitTestsBadMask.ll 2007-04-27-BitTestsBadMask.ll

2007-04-26 Thread Anton Korobeynikov
Changes in directory llvm/test/CodeGen/Generic: 2007-04-14-BitTestsBadMask.ll updated: 1.4 - 1.5 2007-04-27-BitTestsBadMask.ll updated: 1.1 - 1.2 --- Log message: Unxfail tests --- Diffs of the changes: (+0 -6) 2007-04-14-BitTestsBadMask.ll |3 --- 2007-04-27-BitTestsBadMask.ll |3

Re: [llvm-commits] CVS: llvm/lib/Target/X86/X86ATTAsmPrinter.cpp

2007-04-26 Thread Chris Lattner
Fix PR1339: http://llvm.org/PR1339 and CodeGen/X86/dollar-name.ll Nice, thanks Dan! -Chris --- Diffs of the changes: (+32 -3) X86ATTAsmPrinter.cpp | 35 --- 1 files changed, 32 insertions(+), 3 deletions(-) Index:

Re: [llvm-commits] CVS: llvm-test/MultiSource/Benchmarks/Olden/voronoi/newvor.c

2007-04-26 Thread Jeff Cohen
Chris Lattner wrote: On Apr 26, 2007, at 1:11 PM, Jeff Cohen wrote: Absolutely true. This change will cause the test to fail on the BSDs, which will complain that malloc.h has been replaced by stdlib.h. Please use a different test. Better yet, just unconditionally #include stdlib.h and

Re: [llvm-commits] CVS: llvm-test/MultiSource/Benchmarks/Olden/voronoi/newvor.c

2007-04-26 Thread Jeff Cohen
Chris Lattner wrote: On Apr 26, 2007, at 2:23 PM, Jeff Cohen wrote: Chris Lattner wrote: On Apr 26, 2007, at 1:11 PM, Jeff Cohen wrote: Absolutely true. This change will cause the test to fail on the BSDs, which will complain that malloc.h has been replaced by stdlib.h. Please use a

[llvm-commits] CVS: llvm/lib/VMCore/Pass.cpp

2007-04-26 Thread Devang Patel
Changes in directory llvm/lib/VMCore: Pass.cpp updated: 1.86 - 1.87 --- Log message: Move ~Pass() from Pass.h into Pass.cpp --- Diffs of the changes: (+5 -0) Pass.cpp |5 + 1 files changed, 5 insertions(+) Index: llvm/lib/VMCore/Pass.cpp diff -u llvm/lib/VMCore/Pass.cpp:1.86

[llvm-commits] CVS: llvm/include/llvm/Pass.h

2007-04-26 Thread Devang Patel
Changes in directory llvm/include/llvm: Pass.h updated: 1.85 - 1.86 --- Log message: Move ~Pass() from Pass.h into Pass.cpp --- Diffs of the changes: (+1 -1) Pass.h |2 +- 1 files changed, 1 insertion(+), 1 deletion(-) Index: llvm/include/llvm/Pass.h diff -u

Re: [llvm-commits] CVS: llvm-test/MultiSource/Benchmarks/Olden/voronoi/newvor.c

2007-04-26 Thread Andrew Lenharth
I need it because it isn't defined by stdlib.h on linux. I need it because it is defaulting to: int memalign(...), lacking any other definition. It happens to work in most usage this way, but it isn't correct. Andrew On 4/26/07, Jeff Cohen [EMAIL PROTECTED] wrote: Chris Lattner wrote: On

Re: [llvm-commits] CVS: llvm-test/MultiSource/Benchmarks/Olden/voronoi/newvor.c

2007-04-26 Thread Chris Lattner
On Apr 26, 2007, at 2:42 PM, Andrew Lenharth wrote: I need it because it isn't defined by stdlib.h on linux. I need it because it is defaulting to: int memalign(...), lacking any other definition. It happens to work in most usage this way, but it isn't correct. Easy solution. In that

Re: [llvm-commits] [126488] Fix PR1352 and CFrontend/2007-04-24-VolatileStructCopy.c

2007-04-26 Thread Chris Lattner
On Apr 24, 2007, at 11:48 PM, Duncan Sands wrote: Hi Chris, // Non-bitfield aggregate value. -Emit(TREE_OPERAND(exp, 1), LV.Ptr); -if (DestLoc) +if (DestLoc) { + Emit(TREE_OPERAND(exp, 1), LV.Ptr); EmitAggregateCopy(DestLoc, LV.Ptr, TREE_TYPE(exp),

[llvm-commits] CVS: llvm/lib/CodeGen/SelectionDAG/SelectionDAGISel.cpp

2007-04-26 Thread Chris Lattner
Changes in directory llvm/lib/CodeGen/SelectionDAG: SelectionDAGISel.cpp updated: 1.430 - 1.431 --- Log message: improve EH global handling, patch by Duncan Sands. --- Diffs of the changes: (+10 -6) SelectionDAGISel.cpp | 16 ++-- 1 files changed, 10 insertions(+), 6

Re: [llvm-commits] Handle global variables in eh_selector lowering

2007-04-26 Thread Chris Lattner
On Apr 14, 2007, at 8:34 AM, Duncan Sands wrote: The eh_selector intrinsic wants global variables for its extra arguments, but wasn't expecting to get... global variables! Only bitcasts of global variables. Discovered by the Ada f-e, fix attached. Maybe it can be done more neatly, but I

[llvm-commits] CVS: llvm-www/pubs/2007-07-CAV-StructuralAbstraction.html 2007-07-CAV-StructuralAbstraction.pdf index.html

2007-04-26 Thread Chris Lattner
Changes in directory llvm-www/pubs: 2007-07-CAV-StructuralAbstraction.html added (r1.1) 2007-07-CAV-StructuralAbstraction.pdf added (r1.1) index.html updated: 1.47 - 1.48 --- Log message: Add Domagoj's paper --- Diffs of the changes: (+87 -0) 2007-07-CAV-StructuralAbstraction.html | 81

[llvm-commits] CVS: llvm-www/pubs/2007-07-CAV-StructuralAbstraction.html

2007-04-26 Thread Chris Lattner
Changes in directory llvm-www/pubs: 2007-07-CAV-StructuralAbstraction.html updated: 1.1 - 1.2 --- Log message: remove some spaces --- Diffs of the changes: (+1 -3) 2007-07-CAV-StructuralAbstraction.html |4 +--- 1 files changed, 1 insertion(+), 3 deletions(-) Index: