[lng-odp] [Bug 1457] odp_timer: data race

2015-04-23 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1457 --- Comment #2 from Mike Holmes mike.hol...@linaro.org --- I will run this against the scheduler performance test and double check if it appears there. -- You are receiving this mail because: You are on the CC list for the bug.

[lng-odp] [PATCH] validation: tests for module odp_ver_abt_log_dbg

2015-04-23 Thread Christophe Milard
Created directory for module odp_ver_abt_log_dbg, populated with file odp_errno.c and odp_system.c which, despite its confusing name is not testing the system module but the sys* function of the odp_ver_abt_log_dbg module. Signed-off-by: Christophe Milard christophe.mil...@linaro.org --- Applies

[lng-odp] [Bug 1455] The blkallocs stat is not properly incremented when allocating a block from a pool

2015-04-23 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1455 Mike Holmes mike.hol...@linaro.org changed: What|Removed |Added CC||mike.hol...@linaro.org

[lng-odp] [Bug 1455] The blkallocs stat is not properly incremented when allocating a block from a pool

2015-04-23 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1455 --- Comment #3 from Mike Holmes mike.hol...@linaro.org --- (In reply to Mike Holmes from comment #2) commit 64fd29 commit 72963e -- You are receiving this mail because: You are on the CC list for the bug.

[lng-odp] [Bug 1450] odp_timer_test: unstable results

2015-04-23 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1450 Maxim Uvarov maxim.uva...@linaro.org changed: What|Removed |Added CC||maxim.uva...@linaro.org

Re: [lng-odp] [PATCH] validation: odp_pool: add double destroy

2015-04-23 Thread Ola Liljedahl
On 22 April 2015 at 13:29, Mike Holmes mike.hol...@linaro.org wrote: On 22 April 2015 at 07:26, Bill Fischofer bill.fischo...@linaro.org wrote: Good points. I agree it's better to leave this behavior undefined. If that is consensus I will send a patch for the docs to add. Deleting an

[lng-odp] [API-NEXT PATCH 6/7] linux-generic: add ipc pktio support

2015-04-23 Thread Maxim Uvarov
Signed-off-by: Maxim Uvarov maxim.uva...@linaro.org --- platform/linux-generic/Makefile.am | 2 + .../linux-generic/include/odp_buffer_internal.h| 3 + .../linux-generic/include/odp_packet_io_internal.h | 15 + .../include/odp_packet_io_ipc_internal.h | 47 ++

[lng-odp] [API-NEXT PATCH 5/7] linux-generic: ipc init odp ring

2015-04-23 Thread Maxim Uvarov
Signed-off-by: Maxim Uvarov maxim.uva...@linaro.org --- platform/linux-generic/odp_init.c | 6 ++ 1 file changed, 6 insertions(+) diff --git a/platform/linux-generic/odp_init.c b/platform/linux-generic/odp_init.c index bf36e68..630aa99 100644 --- a/platform/linux-generic/odp_init.c +++

[lng-odp] [API-NEXT PATCH 0/7] IPC version v4

2015-04-23 Thread Maxim Uvarov
Since nobody replayed on rfc patch I did clean up and splitting it on several patches. Please consider this version for review. Thanks, Maxim. Maxim Uvarov (7): linux-generic: zero params for pool create api: ipc: shared memory add no create flag api ipc: update ring with shm proc

Re: [lng-odp] ODP Docs Execution Objects EOs

2015-04-23 Thread Mike Holmes
On 23 April 2015 at 13:54, Ola Liljedahl ola.liljed...@linaro.org wrote: On 23 April 2015 at 19:34, Mike Holmes mike.hol...@linaro.org wrote: On 23 April 2015 at 13:13, Ola Liljedahl ola.liljed...@linaro.org wrote: On 23 April 2015 at 12:14, Taras Kondratiuk taras.kondrat...@linaro.org

[lng-odp] [API-NEXT PATCH 3/7] api ipc: update ring with shm proc argument

2015-04-23 Thread Maxim Uvarov
Signed-off-by: Maxim Uvarov maxim.uva...@linaro.org --- helper/include/odp/helper/ring.h | 2 ++ helper/ring.c| 9 - 2 files changed, 10 insertions(+), 1 deletion(-) diff --git a/helper/include/odp/helper/ring.h b/helper/include/odp/helper/ring.h index

Re: [lng-odp] [PATCH v2 1/2] linux-generic: pool: initialize atomics during odp_pool_init_global

2015-04-23 Thread Maxim Uvarov
Merged, Maxim. On 04/22/15 11:01, Nicolas Morey-Chaisemartin wrote: Signed-off-by: Nicolas Morey-Chaisemartin nmo...@kalray.eu --- platform/linux-generic/odp_pool.c | 12 1 file changed, 12 insertions(+) diff --git a/platform/linux-generic/odp_pool.c

Re: [lng-odp] ODP Docs Execution Objects EOs

2015-04-23 Thread Mike Holmes
On 23 April 2015 at 13:13, Ola Liljedahl ola.liljed...@linaro.org wrote: On 23 April 2015 at 12:14, Taras Kondratiuk taras.kondrat...@linaro.org wrote: On 04/22/2015 09:21 PM, Mike Holmes wrote: We have mentioned EOs in only one place and not defined them any where in the API doc /**

Re: [lng-odp] Atomics

2015-04-23 Thread Ola Liljedahl
On 22 April 2015 at 13:24, Maxim Uvarov maxim.uva...@linaro.org wrote: On 04/22/15 14:20, Maxim Uvarov wrote: On 04/22/15 13:34, Nicolas Morey-Chaisemartin wrote: On 04/22/2015 11:39 AM, Maxim Uvarov wrote: In that case what you need is. That is odp API: ./include/odp/api/atomic.h

[lng-odp] [API-NEXT PATCH 1/7] linux-generic: zero params for pool create

2015-04-23 Thread Maxim Uvarov
Adding more params to pool create breaks original work. Make sure that not set params are zero. Signed-off-by: Maxim Uvarov maxim.uva...@linaro.org --- platform/linux-generic/odp_schedule.c | 1 + test/validation/odp_queue.c | 1 + 2 files changed, 2 insertions(+) diff --git

[lng-odp] [API-NEXT PATCH 2/7] api: ipc: shared memory add no create flag

2015-04-23 Thread Maxim Uvarov
Flag is needed to map process one shm block to process two. Signed-off-by: Maxim Uvarov maxim.uva...@linaro.org --- include/odp/api/shared_memory.h| 1 + platform/linux-generic/odp_shared_memory.c | 9 +++-- 2 files changed, 8 insertions(+), 2 deletions(-) diff --git

Re: [lng-odp] ODP Docs Execution Objects EOs

2015-04-23 Thread Ola Liljedahl
On 23 April 2015 at 19:34, Mike Holmes mike.hol...@linaro.org wrote: On 23 April 2015 at 13:13, Ola Liljedahl ola.liljed...@linaro.org wrote: On 23 April 2015 at 12:14, Taras Kondratiuk taras.kondrat...@linaro.org wrote: On 04/22/2015 09:21 PM, Mike Holmes wrote: We have mentioned EOs

[lng-odp] [Bug 1440] Documentation: odp_pktio_open to mention the pool is only used by the default CoS

2015-04-23 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1440 --- Comment #2 from Bill Fischofer bill.fischo...@linaro.org --- V2 of patch posted at http://patches.opendataplane.org/patch/1476/ -- You are receiving this mail because: You are on the CC list for the bug.

[lng-odp] [API-NEXT PATCHv2] api: pktio: Clarify doc on default pool usage on odp_pktio_open

2015-04-23 Thread Bill Fischofer
Signed-off-by: Bill Fischofer bill.fischo...@linaro.org --- Changes for v2: Correct grammatical ambiguities throughout doc for odp_pktio_open(). include/odp/api/packet_io.h | 22 +++--- 1 file changed, 15 insertions(+), 7 deletions(-) diff --git a/include/odp/api/packet_io.h

Re: [lng-odp] [PATCHv4] example: ODP classifier example

2015-04-23 Thread Mike Holmes
On 23 April 2015 at 06:37, bala.manoha...@linaro.org wrote: From: Balasubramanian Manoharan bala.manoha...@linaro.org ODP Classifier example This programs gets pmr rules as command-line parameter and configures the classification engine in the system. This initial version supports the

Re: [lng-odp] [PATCH v2 2/2] linux-generic: pool: fix initialization of odp_buffer_hdr ref_count

2015-04-23 Thread Bill Fischofer
Both parts should be applied. On Thu, Apr 23, 2015 at 8:02 AM, Nicolas Morey-Chaisemartin nmo...@kalray.eu wrote: Thanks. Is there a reason why you did not apply the first patch of the serie? Nicolas On 04/23/2015 10:33 AM, Maxim Uvarov wrote: Merged, Maxim. On 04/22/15 11:01,

[lng-odp] [API-NEXT PATCH 7/7] ipc: example app

2015-04-23 Thread Maxim Uvarov
Simple example app creates one packet i/o to external interface and one ipc pktio to other process. Then transfer packet from external interface to other process and back thought ipc queue. Signed-off-by: Maxim Uvarov maxim.uva...@linaro.org --- configure.ac| 1 +

Re: [lng-odp] [API-NEXT PATCH 1/4] api: packet: rename user_data to user_area

2015-04-23 Thread Bill Fischofer
On Thu, Apr 23, 2015 at 7:23 AM, Petri Savolainen petri.savolai...@nokia.com wrote: Term area highlights better that the per packet user area is fixed in size and position. E.g. odp_packet_data(), odp_packet_seg_data() return pointers which are (likely) modified during packet processing.

Re: [lng-odp] [API-NEXT PATCH 3/4] style: pool_param doxygen comments

2015-04-23 Thread Bill Fischofer
I disagree that this style is more readable. It's hard to see the definitions when they are stacked like this. Having the comments on the right makes it very clear what they are associated with and doesn't obscure the variables. This sort of stylistic change really has nothing to do with the

[lng-odp] [API-NEXT PATCH v2 2/4] api: packet: removed odp_packet_user_u64

2015-04-23 Thread Petri Savolainen
Simplified the API by removing user_u64 option. User has now room for a pointer (or upto intptr_t sized variable) and a configurable sized user_area. Both can be used at the same time. User has to use the user_area when more space than sizeof(intptr_t) bytes is needed. Signed-off-by: Petri

[lng-odp] [API-NEXT PATCH v2 1/4] api: packet: rename user_data to user_area

2015-04-23 Thread Petri Savolainen
Term area highlights better that the per packet user area is fixed in size and position. E.g. odp_packet_data(), odp_packet_seg_data() return pointers which are (likely) modified during packet processing. Signed-off-by: Petri Savolainen petri.savolai...@nokia.com --- include/odp/api/packet.h |

[lng-odp] [API-NEXT PATCH v2 4/4] style: moved pool type first in pool_param

2015-04-23 Thread Petri Savolainen
Type + union highlights the usage better than union + type. Less packed structure is likely not an issue, since pools are few. Signed-off-by: Petri Savolainen petri.savolai...@nokia.com --- include/odp/api/pool.h | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git

Re: [lng-odp] [PATCH v2 2/2] linux-generic: pool: fix initialization of odp_buffer_hdr ref_count

2015-04-23 Thread Maxim Uvarov
Merged, Maxim. On 04/22/15 11:01, Nicolas Morey-Chaisemartin wrote: Signed-off-by: Nicolas Morey-Chaisemartin nmo...@kalray.eu --- platform/linux-generic/odp_pool.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/platform/linux-generic/odp_pool.c

Re: [lng-odp] [PATCHv3] example: ODP classifier example

2015-04-23 Thread Bala Manoharan
On 21 April 2015 at 16:57, Maxim Uvarov maxim.uva...@linaro.org wrote: Bala, one more comment. Please do parsing arguments before odp init. Sorry missed this comment. parsing argument uses odp shared memory and we cannot call it before odp init() function. Regards, Bala About this code Mike

Re: [lng-odp] [PATCH] validation: thread: add odp_thread sunnyday tests

2015-04-23 Thread Christophe Milard
On 2015-04-21 17:26, Mike Holmes wrote: Add test cases for APIs in the logical ODP THREAD grouping Signed-off-by: Mike Holmes mike.hol...@linaro.org --- test/validation/.gitignore | 1 + test/validation/Makefile.am | 4 +++- test/validation/odp_thread.c | 41

Re: [lng-odp] [PATCH] validation: thread: add odp_thread sunnyday tests

2015-04-23 Thread Christophe Milard
Forget my previous comment. I was just confused. What you intend to put there is limited to the ODP API (excluding helper) right? In that case, you get my blessing... :-) On 23 April 2015 at 09:36, Christophe Milard christophe.mil...@linaro.org wrote: On 2015-04-21 17:26, Mike Holmes wrote:

Re: [lng-odp] [PATCH] validation: thread: add odp_thread sunnyday tests

2015-04-23 Thread Christophe Milard
On 2015-04-21 17:26, Mike Holmes wrote: Add test cases for APIs in the logical ODP THREAD grouping Signed-off-by: Mike Holmes mike.hol...@linaro.org Reviewed-by: Christophe Milard christophe.mil...@linaro.org --- test/validation/.gitignore | 1 + test/validation/Makefile.am | 4 +++-

[lng-odp] [API-NEXT PATCH v2 5/5] api: packet_io: added start and stop

2015-04-23 Thread Petri Savolainen
Packet IO start and stop enable a controlled setup and tear down phases. Interface control sequence: * odp_pktio_open() creates a pktio interface object * potential interface configurations (classification, input queues, etc) * odp_pktio_start() enables packet input/output * receive / transmit

[lng-odp] [API-NEXT PATCH v2 1/5] api: packet_io: change word instance to interface

2015-04-23 Thread Petri Savolainen
Signed-off-by: Petri Savolainen petri.savolai...@nokia.com --- include/odp/api/packet_io.h | 11 ++- 1 file changed, 6 insertions(+), 5 deletions(-) diff --git a/include/odp/api/packet_io.h b/include/odp/api/packet_io.h index e960f10..5446999 100644 --- a/include/odp/api/packet_io.h +++

[lng-odp] [API-NEXT PATCH v2 2/5] api: packet_io: remove excess references to ODP

2015-04-23 Thread Petri Savolainen
All handles are ODP types, no need to repeat that. Signed-off-by: Petri Savolainen petri.savolai...@nokia.com --- include/odp/api/packet_io.h | 32 1 file changed, 16 insertions(+), 16 deletions(-) diff --git a/include/odp/api/packet_io.h

[lng-odp] [PATCHv4] example: ODP classifier example

2015-04-23 Thread bala . manoharan
From: Balasubramanian Manoharan bala.manoha...@linaro.org ODP Classifier example This programs gets pmr rules as command-line parameter and configures the classification engine in the system. This initial version supports the following * ODP_PMR_SIP_ADDR pmr term * PMR term MATCH and RANGE

Re: [lng-odp] [PATCHv3] example: ODP classifier example

2015-04-23 Thread Maxim Uvarov
On 04/23/15 12:08, Bala Manoharan wrote: On 21 April 2015 at 16:57, Maxim Uvarov maxim.uva...@linaro.org wrote: Bala, one more comment. Please do parsing arguments before odp init. Sorry missed this comment. parsing argument uses odp shared memory and we cannot call it before odp init()

[lng-odp] [API-NEXT PATCH v2 3/5] api: packet_io: added odp_pktio_param_t

2015-04-23 Thread Petri Savolainen
Packet IO interface level parameters are needed e.g. to select input mode. User must select and use one input mode (sched, poll or recv) per pktio interface. Signed-off-by: Petri Savolainen petri.savolai...@nokia.com --- example/generator/odp_generator.c | 6 +++-

[lng-odp] [API-NEXT PATCH 1/4] api: packet: rename user_data to user_area

2015-04-23 Thread Petri Savolainen
Term area highlights better that the per packet user area is fixed in size and position. E.g. odp_packet_data(), odp_packet_seg_data() return pointers which are (likely) modified during packet processing. Signed-off-by: Petri Savolainen petri.savolai...@nokia.com --- include/odp/api/packet.h |

[lng-odp] [API-NEXT PATCH 2/4] api: packet: removed odp_packet_user_u64

2015-04-23 Thread Petri Savolainen
Simplified the API by removing user_u64 option. User has now room for a pointer (or upto intptr_t sized variable) and a configurable sized user_area. Both can be used at the same time. User has to use the user_area when more space than sizeof(intptr_t) bytes is needed. Signed-off-by: Petri

[lng-odp] [API-NEXT PATCH 3/4] style: pool_param doxygen comments

2015-04-23 Thread Petri Savolainen
Moved comments into separate lines for better readability (more chars per line). Signed-off-by: Petri Savolainen petri.savolai...@nokia.com --- include/odp/api/pool.h | 55 -- 1 file changed, 26 insertions(+), 29 deletions(-) diff --git

[lng-odp] [API-NEXT PATCH 4/4] style: moved pool type first in pool_param

2015-04-23 Thread Petri Savolainen
Type + union highlights the usage better than union + type. Less packed structure is likely not an issue, since pools are few. Signed-off-by: Petri Savolainen petri.savolai...@nokia.com --- include/odp/api/pool.h | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git

Re: [lng-odp] [API-NEXT PATCH 3/4] style: pool_param doxygen comments

2015-04-23 Thread Savolainen, Petri (Nokia - FI/Espoo)
I sent out v2 with extra line feeds between the struct members. I think it’s very well readable now. The series touch the same lines in pool.h. Those patches apply easier back-to-back, than mixed with (potential) other patches. -Petri From: ext Bill Fischofer

Re: [lng-odp] [PATCH] validation: odp_pool: add double destroy

2015-04-23 Thread Maxim Uvarov
On 04/23/15 13:09, Taras Kondratiuk wrote: On 04/22/2015 08:54 PM, Maxim Uvarov wrote: On 04/22/15 19:06, Ciprian Barbu wrote: On Wed, Apr 22, 2015 at 5:13 PM, Maxim Uvarov maxim.uva...@linaro.org wrote: On 04/22/15 15:53, Bill Fischofer wrote: It does that, but as Taras points out there is

Re: [lng-odp] [PATCH] validation: odp_pool: add double destroy

2015-04-23 Thread Bala Manoharan
On 23 April 2015 at 16:56, Maxim Uvarov maxim.uva...@linaro.org wrote: On 04/23/15 13:09, Taras Kondratiuk wrote: On 04/22/2015 08:54 PM, Maxim Uvarov wrote: On 04/22/15 19:06, Ciprian Barbu wrote: On Wed, Apr 22, 2015 at 5:13 PM, Maxim Uvarov maxim.uva...@linaro.org wrote: On 04/22/15