Re: [lng-odp] [PATCH 1/2] linux-gen: ipc: use hdr to handle conversion function

2017-02-27 Thread Savolainen, Petri (Nokia - FI/Espoo)
> -Original Message- > From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of Maxim > Uvarov > Sent: Monday, February 27, 2017 6:10 PM > To: lng-odp@lists.linaro.org > Subject: Re: [lng-odp] [PATCH 1/2] linux-gen: ipc: use hdr to handle > conversion function > > On

Re: [lng-odp] [PATCH 1/2] linux-gen: packet: remove unnecessary packet reparsing

2017-02-27 Thread Elo, Matias (Nokia - FI/Espoo)
Ping. > On 15 Feb 2017, at 18:01, Matias Elo wrote: > > Previously the highest already parsed layer was unnecessarily reparsed on > the following packet_parse_common() calls. > > Signed-off-by: Matias Elo > --- > platform/linux-generic/odp_packet.c

[lng-odp] [PATCH 2/2 v3] example: introducing multi-threaded traffic management case

2017-02-27 Thread forrest.shi
From: Xuelin Shi introduce a new example of traffic management with following features: - multiple TM threads: one TM thread for each pktio - for small system less than 4 cores, only one TM thread created. - receiving packets from multiple pktios other than

[lng-odp] [PATCH 1/2 v3] linux-gen: traffic_mgmr: support termination in barrier.

2017-02-27 Thread forrest.shi
From: Xuelin Shi While the tm_group(thread) is waiting for enquing at barrier, it may receive destroy call. In this case, need a mechanism to exit. This patch adds a variant of odp_barrier_wait to enable it. Signed-off-by: Xuelin Shi ---

[lng-odp] Canceled Event: OpenDataPlane (ODP) Public Call @ Tue Mar 7, 2017 9am - 10am (CST) (lng-odp@lists.linaro.org)

2017-02-27 Thread Bill Fischofer
This event has been canceled and removed from your calendar. Title: OpenDataPlane (ODP) Public Call Meeting notes document: https://docs.google.com/a/linaro.org/document/d/1KjcdpidVqMCDa6FXURSxrTwFjkmb1_pKz54m7eYvVMo/edit Note: Effective June 2nd we are moving this conference to Blue Jeans.

Re: [lng-odp] Compilation error of ODP on Linux x86_64 platform

2017-02-27 Thread Maxim Uvarov
On 02/27/17 19:05, Marco Varlese wrote: > On Mon, 2017-02-27 at 18:52 +0300, Maxim Uvarov wrote: > > [nip] >> maybe just define it as: >> >> #define ODP_CPUMASK_SIZE __CPU_SETSIZE >> ? > First of all, I don't think it's appropriate to set it to __CPU_SETSIZE but it > should be (at most) the one

Re: [lng-odp] [PATCH 1/2] linux-gen: ipc: use hdr to handle conversion function

2017-02-27 Thread Maxim Uvarov
On 02/27/17 19:02, Bill Fischofer wrote: > On Mon, Feb 27, 2017 at 9:57 AM, Petri Savolainen < > petri.savolai...@linaro.org> wrote: > >> Use conversion function instead of casting. >> >> Signed-off-by: Petri Savolainen >> --- >>

Re: [lng-odp] Compilation error of ODP on Linux x86_64 platform

2017-02-27 Thread Marco Varlese
On Mon, 2017-02-27 at 18:52 +0300, Maxim Uvarov wrote: [nip] > maybe just define it as: > > #define ODP_CPUMASK_SIZE __CPU_SETSIZE > ? First of all, I don't think it's appropriate to set it to __CPU_SETSIZE but it should be (at most) the one exposed by one level up header (e.g. sched.h).

Re: [lng-odp] Compilation error of ODP on Linux x86_64 platform

2017-02-27 Thread Maxim Uvarov
after some thinking and looking to that link: https://www.sourceware.org/ml/libc-alpha/2016-08/msg00236.html I see that we do not know how many cpus will be there. And the more clean fix will be dynamic allocation instead of static arrays. Maxim. On 02/27/17 18:42, Marco Varlese wrote: > Cool.

Re: [lng-odp] [PATCH 1/2] linux-gen: ipc: use hdr to handle conversion function

2017-02-27 Thread Bill Fischofer
On Mon, Feb 27, 2017 at 9:57 AM, Petri Savolainen < petri.savolai...@linaro.org> wrote: > Use conversion function instead of casting. > > Signed-off-by: Petri Savolainen > --- > platform/linux-generic/include/odp_packet_internal.h | 6 ++ >

Re: [lng-odp] [PATCH 1/2] linux-gen: ipc_pktio: fix conversion from hdr to pkt

2017-02-27 Thread Savolainen, Petri (Nokia - FI/Espoo)
> -Original Message- > From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of Maxim > Uvarov > Sent: Monday, February 27, 2017 5:21 PM > To: lng-odp@lists.linaro.org > Subject: [lng-odp] [PATCH 1/2] linux-gen: ipc_pktio: fix conversion from > hdr to pkt > > commit: >

[lng-odp] [PATCH 2/2] linux-gen: tm: use handle conversion function

2017-02-27 Thread Petri Savolainen
Use (from buffer to packet handle) conversion function instead of casting. Signed-off-by: Petri Savolainen --- platform/linux-generic/odp_traffic_mngr.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/platform/linux-generic/odp_traffic_mngr.c

[lng-odp] [PATCH 1/2] linux-gen: ipc: use hdr to handle conversion function

2017-02-27 Thread Petri Savolainen
Use conversion function instead of casting. Signed-off-by: Petri Savolainen --- platform/linux-generic/include/odp_packet_internal.h | 6 ++ platform/linux-generic/odp_packet.c | 5 - platform/linux-generic/pktio/ipc.c | 2

Re: [lng-odp] Compilation error of ODP on Linux x86_64 platform

2017-02-27 Thread Maxim Uvarov
On 02/27/17 18:42, Marco Varlese wrote: > Cool. I posted here because it appeared strange to me to get that error... > > On my system I checked that: > CPU_SETSIZE is 4096 as first defined as __CPU_SETSIZE in bits/sched.h and then > as CPU_SETSIZE in sched.h > bits/sched.h:# define __CPU_SETSIZE

Re: [lng-odp] Compilation error of ODP on Linux x86_64 platform

2017-02-27 Thread Marco Varlese
Cool. I posted here because it appeared strange to me to get that error... On my system I checked that: CPU_SETSIZE is 4096 as first defined as __CPU_SETSIZE in bits/sched.h and then as CPU_SETSIZE in sched.h bits/sched.h:# define __CPU_SETSIZE 4096 sched.h:# define CPU_SETSIZE __CPU_SETSIZE

[lng-odp] [PATCH 2/2] linux-gen: remove pktio ipc option from configure

2017-02-27 Thread Maxim Uvarov
Options becomes stable and not need any entry in main configure for platform specific pktio. Signed-off-by: Maxim Uvarov --- configure.ac | 1 - platform/linux-generic/Makefile.am | 1 + platform/linux-generic/m4/configure.m4 | 1 -

[lng-odp] [PATCH 1/2] linux-gen: ipc_pktio: fix conversion from hdr to pkt

2017-02-27 Thread Maxim Uvarov
commit: 5ebc1243 linux-gen: packet: packet handle is hdr pointer Changes odp_packet_t as it's relation to packet header. This needed to be adjusted in ipc pktio also. Signed-off-by: Maxim Uvarov --- platform/linux-generic/pktio/ipc.c | 2 +- 1 file changed, 1

Re: [lng-odp] [PATCH] api: ipsec: make IPSEC protocol consistent with other types

2017-02-27 Thread Bill Fischofer
On Mon, Feb 27, 2017 at 7:02 AM, Andriy Berestovskyy < andriy.berestovs...@cavium.com> wrote: > Oops, sorry. > Shall I resend the patch then? > Probably not necessary right now. Let's get some feedback on this. If a v2 is needed, then yes, please post it as an API-NEXT patch. Thanks. > >

Re: [lng-odp] Compilation error of ODP on Linux x86_64 platform

2017-02-27 Thread Bill Fischofer
Thanks. I'm not sure if ODP has been tested in that environment. My guess is it's something simple. That assert is testing sizeof(cpu_set_t) and it sounds like that's different in Suse then, say, Ubuntu. On Mon, Feb 27, 2017 at 8:47 AM, Marco Varlese wrote: > OS:

Re: [lng-odp] Compilation error of ODP on Linux x86_64 platform

2017-02-27 Thread Marco Varlese
OS: openSUSE Leap 42.2  Compiler: gcc-6 Kernel: 4.10.0-rc4-1.g4f824f1-default Cheers, Marco On Mon, 2017-02-27 at 08:44 -0600, Bill Fischofer wrote: > What environment are you running in (OS, compiler, service levels, etc.)?  > > > On Mon, Feb 27, 2017 at 8:35 AM, Marco Varlese

Re: [lng-odp] Compilation error of ODP on Linux x86_64 platform

2017-02-27 Thread Bill Fischofer
What environment are you running in (OS, compiler, service levels, etc.)? On Mon, Feb 27, 2017 at 8:35 AM, Marco Varlese wrote: > Hi, > > I've pulled latest code from the git repo and got into a compile-time > error. > > I followed the steps provided in the README file

[lng-odp] Compilation error of ODP on Linux x86_64 platform

2017-02-27 Thread Marco Varlese
Hi, I've pulled latest code from the git repo and got into a compile-time error. I followed the steps provided in the README file under platform/linux-generic which are: ./bootstrap ./configure ./make Please, see below the output of the compilation.   CC   _fdserver.lo   CC   _ishm.lo  

Re: [lng-odp] [API-NEXT PATCH 16/21] drv: complement parameters to the driver probe() function

2017-02-27 Thread Christophe Milard
On 23 February 2017 at 00:00, Bill Fischofer wrote: > > > On Wed, Feb 22, 2017 at 6:55 AM, Christophe Milard > wrote: >> >> Of course, when probing a driver, the latter should be given the devio >> handle to be used. This is what this

Re: [lng-odp] [API-NEXT PATCH 15/21] drv: adding driver remove function

2017-02-27 Thread Christophe Milard
On 22 February 2017 at 23:56, Bill Fischofer wrote: > > > On Wed, Feb 22, 2017 at 6:55 AM, Christophe Milard > wrote: >> >> The remove function, as for other driver items (such as enumeratos...) is > > > Typo: enumerators => V2 > >> >>

Re: [lng-odp] [API-NEXT PATCH 13/21] linux-gen: drv: devio registration

2017-02-27 Thread Christophe Milard
On 22 February 2017 at 23:54, Bill Fischofer wrote: > > > On Wed, Feb 22, 2017 at 6:55 AM, Christophe Milard > wrote: >> >> devios (dev IO) provide a interface for drivers to access a device: >> Devices enumerated by enumerators may be

Re: [lng-odp] [API-NEXT PATCH 11/21] test: drv: device creation and destruction

2017-02-27 Thread Christophe Milard
On 22 February 2017 at 23:40, Bill Fischofer wrote: > > > On Wed, Feb 22, 2017 at 6:55 AM, Christophe Milard > wrote: >> >> Testing that devices can be created and removed from ODP. >> >> Signed-off-by: Christophe Milard

Re: [lng-odp] [PATCH v2 3/5] linux-gen: packet: packet handle is hdr pointer

2017-02-27 Thread Maxim Uvarov
that commit broke IPC: --enable-pktio_ipc-support Maxim. On 02/08/17 15:17, Petri Savolainen wrote: > Changed packet handle (odp_packet_t) to store pointer to the packet > header, instead a bit field structure of pool and index. Buffer and > event handles are not changed. > > Pointer as handle

Re: [lng-odp] [API-NEXT PATCH 2/4] api: deprecated: add ODP_DEPRECATED configure option

2017-02-27 Thread Savolainen, Petri (Nokia - FI/Espoo)
> > /** > > * Deprecated API definitions > > * > > * Some API definitions may be deprecated by this or a previous API > version. > > * This macro controls if those are enabled (and visible to the > application) > > * or disabled. > > * > > * * 0: Deprecated API definitions are disabled > >

Re: [lng-odp] [API-NEXT PATCH 10/21] linux-gen: drv: driver: adding device querry function

2017-02-27 Thread Christophe Milard
hmmm, Sure it is applicable here, but while most function using this strategy would be happy to have some part of the job done, this one won't: for instance: receiving N packets always makes sense, even if M>N packet are waiting to be received. In this case, getting half of an anwer does not

Re: [lng-odp] [PATCH] api: ipsec: make IPSEC protocol consistent with other types

2017-02-27 Thread Andriy Berestovskyy
Oops, sorry. Shall I resend the patch then? Andriy On 27.02.2017 13:55, Bill Fischofer wrote: Thanks Andriy, Please note that all API changes should specify --subject-prefix="API-NEXT PATCH" as we use the api-next branch to accumulate all API changes. On Mon, Feb 27, 2017 at 5:24 AM, Andriy

Re: [lng-odp] [API-NEXT PATCH 08/21] linux-gen: drv: device creation and deletion

2017-02-27 Thread Christophe Milard
On 22 February 2017 at 23:28, Bill Fischofer wrote: > > > On Wed, Feb 22, 2017 at 6:55 AM, Christophe Milard > wrote: >> >> Functions to create and remove devices are populated to do >> more proper things. >> >> Signed-off-by: Christophe

Re: [lng-odp] [API-NEXT PATCH 07/21] drv: driver: add callback function for device destruction

2017-02-27 Thread Christophe Milard
On 22 February 2017 at 23:20, Bill Fischofer wrote: > > > On Wed, Feb 22, 2017 at 6:55 AM, Christophe Milard > wrote: >> >> When a device is destroyed by an enumerator, odpdrv_device_destroy() is >> called. >> However, the complete device

Re: [lng-odp] [PATCH] api: ipsec: make IPSEC protocol consistent with other types

2017-02-27 Thread Bill Fischofer
Thanks Andriy, Please note that all API changes should specify --subject-prefix="API-NEXT PATCH" as we use the api-next branch to accumulate all API changes. On Mon, Feb 27, 2017 at 5:24 AM, Andriy Berestovskyy < andriy.berestovs...@cavium.com> wrote: > - rename odp_ipsec_protocol_t to

[lng-odp] [PATCH v3 1/3] linux-gen: dpdk: improve pmd driver linking

2017-02-27 Thread Matias Elo
Previously each dpdk pmd driver had to be individually referred in the odp code to ensure proper gcc constructor linking. Using the -—whole-archive option when linking the drivers removes this need. After this patch new dpdk pmd drivers are automatically linked. Signed-off-by: Matias Elo

[lng-odp] [PATCH v3 2/3] linux-gen: dpdk: disable pci devices when running make check

2017-02-27 Thread Matias Elo
Disable pci devices during DPDK pktio validation test. If the system has pci devices mapped to DPDK pmd drivers they may overlap with the test vdev device indices, which will cause the validation test to fail. Signed-off-by: Matias Elo ---

[lng-odp] [PATCH v3 3/3] linux-gen: dpdk: bump target dpdk version to 17.02

2017-02-27 Thread Matias Elo
Signed-off-by: Matias Elo --- V3: - Update travis config (Maxim) .travis.yml | 2 +- DEPENDENCIES | 2 +- scripts/build-pktio-dpdk | 2 +- 3 files changed, 3 insertions(+), 3 deletions(-) diff --git a/.travis.yml b/.travis.yml index

[lng-odp] [API-NEXT PATCH v2 1/2] validation: packet: increase test pool size

2017-02-27 Thread Matias Elo
Previously packet_test_concatsplit() could fail on some pool implementations as the pool ran out of buffers. Increase default pools size and use capability to make sure the value is valid. Signed-off-by: Matias Elo --- V2: - Add define PACKET_POOL_NUM for test packet pool

[lng-odp] [API-NEXT PATCH v2 2/2] validation: packet: remove invalid check from packet_test_alloc_segmented()

2017-02-27 Thread Matias Elo
One can't assume that the packet should be segmented as this test is using a different pool with different parameters than the default test pool. Signed-off-by: Matias Elo --- test/common_plat/validation/api/packet/packet.c | 3 --- 1 file changed, 3 deletions(-) diff

Re: [lng-odp] [API-NEXT PATCH 1/2] validation: packet: increase test pool size

2017-02-27 Thread Elo, Matias (Nokia - FI/Espoo)
> IMO, It is better for the above num value to be a #define rather than > a local variable so that its easy to modify for multiple platforms if > required. > True, will fix this. -Matias

[lng-odp] [PATCH] api: ipsec: make IPSEC protocol consistent with other types

2017-02-27 Thread Andriy Berestovskyy
- rename odp_ipsec_protocol_t to odp_ipsec_proto_t - rename ODP_IPSEC_AH to ODP_IPSEC_PROTO_AH - rename ODP_IPSEC_ESP to ODP_IPSEC_PROTO_ESP Signed-off-by: Andriy Berestovskyy --- include/odp/api/spec/ipsec.h | 10 +- 1 file changed, 5 insertions(+), 5

Re: [lng-odp] [API-NEXT PATCH 06/21] drv: driver: change drv unbind function name and pass correct parameter

2017-02-27 Thread Christophe Milard
On 22 February 2017 at 23:14, Bill Fischofer wrote: > > > On Wed, Feb 22, 2017 at 6:55 AM, Christophe Milard > wrote: >> >> The driver removal function expects a device, of course... >> Also unbind seems a better name to disconnect from a

Re: [lng-odp] [API-NEXT PATCH 05/21] test: drv: enumerator registration tests

2017-02-27 Thread Christophe Milard
will fix all these in V2, Christophe. On 22 February 2017 at 22:52, Bill Fischofer wrote: > > > On Wed, Feb 22, 2017 at 6:55 AM, Christophe Milard > wrote: >> >> making sure that enumerators are probed. >> >> Signed-off-by: Christophe

Re: [lng-odp] [API-NEXT PATCH 04/21] linux-gen: drv: enumerator registration

2017-02-27 Thread Christophe Milard
On 22 February 2017 at 22:46, Bill Fischofer wrote: > > > On Wed, Feb 22, 2017 at 6:55 AM, Christophe Milard > wrote: >> >> The enumerator registration functions for the linux-gen ODP >> implementation. >> >> Signed-off-by: Christophe

Re: [lng-odp] [API-NEXT PATCH 03/21] test: drv: enumerator_class registration tests

2017-02-27 Thread Christophe Milard
On 22 February 2017 at 22:13, Bill Fischofer wrote: > > > On Wed, Feb 22, 2017 at 6:55 AM, Christophe Milard > wrote: >> >> Testing that enumerators classes can register properly. >> Saddly restricted to statically linked enumerators

Re: [lng-odp] [API-NEXT PATCH 00/21] driver items registration and probing

2017-02-27 Thread Christophe Milard
Hi all, Maxim, are you saying you prefer a pull request? Last time I did one, you required the patch to be sent on the list, so I am not sure what to do next time. Thx, Christophe. On 27 February 2017 at 10:15, Maxim Uvarov wrote: > for big serries of patches >20

Re: [lng-odp] [API-NEXT PATCH 00/21] driver items registration and probing

2017-02-27 Thread Maxim Uvarov
for big serries of patches >20 it's good to provide some git link to download all of that. That Might be Linaro's people git or github. Maxim. On 25 February 2017 at 01:03, Mike Holmes wrote: > I did make a ticket for IT to look into this > > On 24 February 2017 at