Re: [lng-odp] [API-NEXT PATCH 0/7] IPC version v4

2015-04-27 Thread Benoît Ganne
We are also interested by IPC and I also think that pktio is the way to go. What is transferred is opaque, it is application-dependent. We think it will be useful for control plane/data plane communication, but might also be used to implement pipelines between ODP data-plane processes. I think t

Re: [lng-odp] [PATCH] perfromance: .gitignore: add odp_pktio_perf

2015-04-27 Thread Bill Fischofer
On Mon, Apr 27, 2015 at 1:59 PM, Mike Holmes wrote: > Signed-off-by: Mike Holmes > Reviewed-by: Bill Fischofer > --- > test/performance/.gitignore | 1 + > 1 file changed, 1 insertion(+) > > diff --git a/test/performance/.gitignore b/test/performance/.gitignore > index d41d1e1..03ab978 1006

Re: [lng-odp] [lng-odp-dpdk] [PATCH-dpdk-master 2/3] dpdk: provide args to init dpdk internals

2015-04-27 Thread Bill Fischofer
Setup for things like hugepages, driver mounts, etc. would be the responsibility of the wrapper script or other external configuration. I don't think that's the sort of thing you'd expect the ODP application to do. Note that this includes launching the app via sudo since DPDK seems to require tha

Re: [lng-odp] [PATCH API-NEXT 4/5] api: packet_io: added parse mode

2015-04-27 Thread Bill Fischofer
This is one of the reasons I suggested that as a first-order approximation we simply support parse none or all. OVS clearly wants the former (for now) and my concern is that trying to get overly fancy with selectable parsing options isn't going to buy much since the SW will be spending nearly as m

Re: [lng-odp] [API-NEXT PATCH 0/7] IPC version v4

2015-04-27 Thread Bill Fischofer
IPCs should be short messages used either as "shoulder taps" or for brief communication. If a larger data structure is needed, a pointer to it can be passed as the IPC message, so again the interpretation of the IPC message contents would generally be up to the application, with perhaps some basic

Re: [lng-odp] [PATCH] test: helper: add process and thread tests

2015-04-27 Thread Anders Roxell
On 2015-04-21 16:26, Mike Holmes wrote: > The helpers need to be tested independently from the ODP API, create a > folder to contain helper tests, adding tests for process and thread > creation. > > Signed-off-by: Mike Holmes > --- > configure.ac | 15 + > test/Makefile.am

[lng-odp] [PATCH] perfromance: .gitignore: add odp_pktio_perf

2015-04-27 Thread Mike Holmes
Signed-off-by: Mike Holmes --- test/performance/.gitignore | 1 + 1 file changed, 1 insertion(+) diff --git a/test/performance/.gitignore b/test/performance/.gitignore index d41d1e1..03ab978 100644 --- a/test/performance/.gitignore +++ b/test/performance/.gitignore @@ -3,3 +3,4 @@ odp_atomic o

Re: [lng-odp] [lng-odp-dpdk] [PATCH-dpdk-master 2/3] dpdk: provide args to init dpdk internals

2015-04-27 Thread Maxim Uvarov
On 04/27/15 19:20, Zoltan Kiss wrote: On 24/04/15 20:45, Bill Fischofer wrote: There are two aspects to consider: 1. Configuration info that is needed by the underlying ODP implementation 2. ODP implementation-independent parameters that the application may wish to specify The latter can b

Re: [lng-odp] [PATCH API-NEXT 4/5] api: packet_io: added parse mode

2015-04-27 Thread Ola Liljedahl
On 27 April 2015 at 19:29, Zoltan Kiss wrote: > > > On 20/04/15 13:10, Petri Savolainen wrote: > >> Application can indicate which packet parsing results it is >> interested in (all, none or selected). >> >> Signed-off-by: Petri Savolainen >> --- >> include/odp/api/packet_flags.h | 26

Re: [lng-odp] [PATCH API-NEXT 4/5] api: packet_io: added parse mode

2015-04-27 Thread Zoltan Kiss
On 20/04/15 13:10, Petri Savolainen wrote: Application can indicate which packet parsing results it is interested in (all, none or selected). Signed-off-by: Petri Savolainen --- include/odp/api/packet_flags.h | 26 ++ include/odp/api/packet_io.h| 19

[lng-odp] [PATCH 2/2] performance: pktio: fix check for pktio_tx

2015-04-27 Thread Stuart Haslam
A typo in the error check means we don't correctly guard against failing to open the transmit pktio (when not using a loopback interface). Signed-off-by: Stuart Haslam --- test/performance/odp_pktio_perf.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/test/performance/odp_p

[lng-odp] [PATCH 1/2] performance: pktio: test return value of odp_pktio_close()

2015-04-27 Thread Stuart Haslam
Coverity complains that the return value of odp_pktio_close() isn't being checked. This fixes https://bugs.linaro.org/show_bug.cgi?id=1513 Signed-off-by: Stuart Haslam --- test/performance/odp_pktio_perf.c | 15 --- 1 file changed, 12 insertions(+), 3 deletions(-) diff --git a/test

Re: [lng-odp] [lng-odp-dpdk] [PATCH-dpdk-master 2/3] dpdk: provide args to init dpdk internals

2015-04-27 Thread Zoltan Kiss
On 24/04/15 20:45, Bill Fischofer wrote: There are two aspects to consider: 1. Configuration info that is needed by the underlying ODP implementation 2. ODP implementation-independent parameters that the application may wish to specify The latter can be handled via arguments to odp_global_ini

[lng-odp] [PATCH v2] example: timer: remove global variables to share the data between workers

2015-04-27 Thread Jerin Jacob
use the odp_shared_memory allocater instead of global variables to enable the timer example to run on baremetal/linux process execution environments Signed-off-by: Jerin Jacob --- Changes in v2 - rebased - added an error check for odp_shm_reserve() example/timer/odp_timer_test.c | 128

[lng-odp] [PATCHv2 2/2] validation: init tests using common main

2015-04-27 Thread Christophe Milard
The 3 init tests (init, abort,log) now links with common/odp_cunit_common, as other tests. In main, ODP init is now performed via weak functions which are overloaded (to do nothing) by the 3 init tests. Signed-off-by: Christophe Milard --- test/validation/Makefile.am |

[lng-odp] [PATCHv2 1/2] validation: init src files in single directory

2015-04-27 Thread Christophe Milard
The 3 tests for initialisation still generate 3 executables, but their sources are simply gathered in a single directory called as the module itself, init. Signed-off-by: Christophe Milard --- test/validation/Makefile.am | 6 +++--- test/validation/{ => init}/odp_init.c | 0

[lng-odp] [PATCHv2 0/2] validation: init tests gathered and using common main

2015-04-27 Thread Christophe Milard
The first patch has already been reviewed by Mike. There was comments on the second patch, hoppefully addressed here. Christophe Milard (2): validation: init src files in single directory validation: init tests using common main test/validation/Makefile.am | 6 ++-- test/val

[lng-odp] Adding test attributes

2015-04-27 Thread Christophe Milard
Hi, As a complement to the hierachy need described in http://sourceforge.net/p/cunit/mailman/message/33749732/, I can also foresee a need for having test attributes. As a first approach, the attributes could simply be a bitmask, with bits as "DEFAULT", "EXCLUDE", "SLOW", "REQUIRES_INTERACTION", ..

Re: [lng-odp] [API-NEXT PATCH 7/7] ipc: example app

2015-04-27 Thread Stuart Haslam
On Mon, Apr 27, 2015 at 04:45:44PM +0300, Maxim Uvarov wrote: > On 04/27/15 15:50, Stuart Haslam wrote: > >I don't get it, you're receiving packets from the network then > >overwriting the first few bytes with a timestamp string and forwarding > >it over the ipc interface. Isn't this corrupting the

Re: [lng-odp] [API-NEXT PATCHv2] api: pktio: Clarify doc on default pool usage on odp_pktio_open

2015-04-27 Thread Maxim Uvarov
Merged to api-next with replacing v1. Maxim. On 04/27/15 17:16, Mike Holmes wrote: On 23 April 2015 at 16:36, Bill Fischofer > wrote: Signed-off-by: Bill Fischofer mailto:bill.fischo...@linaro.org>> Reviewed-by: Mike Holmes

Re: [lng-odp] [API-NEXT PATCH 0/7] IPC version v4

2015-04-27 Thread Ola Liljedahl
I am also interested in IPC (between control and dataplane) but not for packets but for messages (so more like buffers). I don't see that these IPC messages should be parsed and classified like packets and I don't need the packet_flags.h API either. However pktio seems like the only abstraction th

Re: [lng-odp] [API-NEXT PATCHv2] api: pktio: Clarify doc on default pool usage on odp_pktio_open

2015-04-27 Thread Mike Holmes
On 23 April 2015 at 16:36, Bill Fischofer wrote: > Signed-off-by: Bill Fischofer > Reviewed-by: Mike Holmes > --- > > Changes for v2: Correct grammatical ambiguities throughout doc for > odp_pktio_open(). > > include/odp/api/packet_io.h | 22 +++--- > 1 file changed, 15 inse

Re: [lng-odp] [API-NEXT PATCHv4 0/6] Add packet user metadata support

2015-04-27 Thread Maxim Uvarov
as discussed on meeting merged to api-next. Petri will do all required renames. Best regards, Maxim. On 04/10/15 18:52, Bill Fischofer wrote: v4 changes: - Removed RFC status, patch is now ready for API-NEXT - Added implementation of approved APIs - Added user metadata tests to packet validati

Re: [lng-odp] [API-NEXT PATCH 6/7] linux-generic: add ipc pktio support

2015-04-27 Thread Ola Liljedahl
On 27 April 2015 at 15:03, Stuart Haslam wrote: > On Thu, Apr 23, 2015 at 08:47:04PM +0300, Maxim Uvarov wrote: > > Signed-off-by: Maxim Uvarov > > --- > > platform/linux-generic/Makefile.am | 2 + > > .../linux-generic/include/odp_buffer_internal.h| 3 + > > .../linux-g

Re: [lng-odp] [API-NEXT PATCH 7/7] ipc: example app

2015-04-27 Thread Maxim Uvarov
On 04/27/15 15:50, Stuart Haslam wrote: I don't get it, you're receiving packets from the network then overwriting the first few bytes with a timestamp string and forwarding it over the ipc interface. Isn't this corrupting the packet? Yes, that corrupts original packet but it was most visible tes

Re: [lng-odp] [API-NEXT PATCH 2/2] api: init: added thread type to local init

2015-04-27 Thread Ola Liljedahl
On 27 April 2015 at 14:38, Petri Savolainen wrote: > User needs to select the thread type (worker or control) of > the initialized thread. Implementation may reserve HW direct access > only to worker threads, while control threads share HW access, etc. > Why wasn't this description in a cover-let

Re: [lng-odp] [API-NEXT PATCH 1/2] api: thread: added thread type

2015-04-27 Thread Ola Liljedahl
It would be good to know what problem we are attempting to solve with this new API. Who are supposed to use these calls and definitions? -- Ola On 27 April 2015 at 14:38, Petri Savolainen wrote: > Two thread types are defined: worker and control threads. API calls from > a worker thread should

Re: [lng-odp] [PATCH 2/2] validation: init tests using common main

2015-04-27 Thread Christophe Milard
On 24 April 2015 at 20:39, Mike Holmes wrote: > > > On 24 April 2015 at 08:54, Christophe Milard > wrote: > >> The 3 init tests (init, abort,log) now links with common/odp_cunit_common, >> as other tests. In main, ODP init is now performed via weak functions >> which are overloaded (to do nothin

Re: [lng-odp] [API-NEXT PATCH 6/7] linux-generic: add ipc pktio support

2015-04-27 Thread Stuart Haslam
On Thu, Apr 23, 2015 at 08:47:04PM +0300, Maxim Uvarov wrote: > Signed-off-by: Maxim Uvarov > --- > platform/linux-generic/Makefile.am | 2 + > .../linux-generic/include/odp_buffer_internal.h| 3 + > .../linux-generic/include/odp_packet_io_internal.h | 15 + > .../include

Re: [lng-odp] [API-NEXT PATCH 7/7] ipc: example app

2015-04-27 Thread Stuart Haslam
On Thu, Apr 23, 2015 at 08:47:05PM +0300, Maxim Uvarov wrote: > Simple example app creates one packet i/o to external interface > and one ipc pktio to other process. Then transfer packet from > external interface to other process and back thought ipc queue. > > Signed-off-by: Maxim Uvarov > --- >

Re: [lng-odp] [API-NEXT PATCH 4/7] linux-generic: reflect shm flags and add mode debug prints

2015-04-27 Thread Stuart Haslam
On Thu, Apr 23, 2015 at 08:47:02PM +0300, Maxim Uvarov wrote: > In case if shm was not specified pool_creat() has to allocate > memory for itself using shared memory flags. > > Signed-off-by: Maxim Uvarov > --- > include/odp/api/pool.h| 1 + > platform/linux-generic/odp_pool.c | 16

Re: [lng-odp] Threads & Thread Safety

2015-04-27 Thread Nicolas Morey-Chaisemartin
On 04/27/2015 02:29 PM, Mike Holmes wrote: > > > On 24 April 2015 at 08:30, Nicolas Morey-Chaisemartin > wrote: > > Hi everyone, > > I'm currently trying to get all the ODP validation tests running on our > MPPA platform and ran across an issue: > It appears

[lng-odp] [API-NEXT PATCH 2/2] api: init: added thread type to local init

2015-04-27 Thread Petri Savolainen
User needs to select the thread type (worker or control) of the initialized thread. Implementation may reserve HW direct access only to worker threads, while control threads share HW access, etc. Signed-off-by: Petri Savolainen --- example/generator/odp_generator.c | 2 +- example/ipsec/

[lng-odp] [API-NEXT PATCH 1/2] api: thread: added thread type

2015-04-27 Thread Petri Savolainen
Two thread types are defined: worker and control threads. API calls from a worker thread should be throughput and latency optimized, while the second one is not so sensitive to call overheads and latency. Signed-off-by: Petri Savolainen --- include/odp/api/thread.h | 38 +

Re: [lng-odp] Threads & Thread Safety

2015-04-27 Thread Mike Holmes
On 24 April 2015 at 08:30, Nicolas Morey-Chaisemartin wrote: > Hi everyone, > > I'm currently trying to get all the ODP validation tests running on our > MPPA platform and ran across an issue: > It appears CUnit (2.1-3) is *not* thread safe ! > > It isn't a very big issue but it creates unexpecte

Re: [lng-odp] [PATCH] validation: pktio: don't pass invalid handles

2015-04-27 Thread Maxim Uvarov
Merged, Maxim. On 04/27/15 12:59, Savolainen, Petri (Nokia - FI/Espoo) wrote: Reviewed-by: Petri Savolainen -Original Message- From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of ext Stuart Haslam Sent: Thursday, April 23, 2015 6:47 PM To: lng-odp@lists.linaro.org Su

Re: [lng-odp] [API-NEXT PATCH 6/7] linux-generic: add ipc pktio support

2015-04-27 Thread Ciprian Barbu
On Thu, Apr 23, 2015 at 8:47 PM, Maxim Uvarov wrote: > Signed-off-by: Maxim Uvarov > --- > platform/linux-generic/Makefile.am | 2 + > .../linux-generic/include/odp_buffer_internal.h| 3 + > .../linux-generic/include/odp_packet_io_internal.h | 15 + > .../include/odp_pac

[lng-odp] [Bug 1513] New: CID 90143: CHECKED_RETURN: odp_pktio_perf.c

2015-04-27 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1513 Bug ID: 1513 Summary: CID 90143: CHECKED_RETURN: odp_pktio_perf.c Product: OpenDataPlane Version: 1.0.3 Hardware: Other OS: Linux Status: UNCONFIRMED Severity:

[lng-odp] [Bug 1512] New: CID 90144: STRING_OVERFLOW: odp_classifier.c

2015-04-27 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1512 Bug ID: 1512 Summary: CID 90144: STRING_OVERFLOW: odp_classifier.c Product: OpenDataPlane Version: 1.0.3 Hardware: Other OS: Linux Status: UNCONFIRMED Severity:

Re: [lng-odp] [API-NEXT PATCH v2] timer: Add missing platform handles to u64 conversion functions

2015-04-27 Thread Maxim Uvarov
On 27 April 2015 at 11:03, Savolainen, Petri (Nokia - FI/Espoo) < petri.savolai...@nokia.com> wrote: > Yes, implementation and tests are needed before the general release. > Should we postpone the general release until those are there? Does api-next > have to have all implemented before merge to

Re: [lng-odp] [PATCH] validation: pktio: don't pass invalid handles

2015-04-27 Thread Savolainen, Petri (Nokia - FI/Espoo)
Reviewed-by: Petri Savolainen > -Original Message- > From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of ext > Stuart Haslam > Sent: Thursday, April 23, 2015 6:47 PM > To: lng-odp@lists.linaro.org > Subject: [lng-odp] [PATCH] validation: pktio: don't pass invalid handle

Re: [lng-odp] [PATCH] linux-generic: support running with restricted cpu set

2015-04-27 Thread Stuart Haslam
On Mon, Apr 06, 2015 at 02:04:08PM -0400, Mike Holmes wrote: > I think odph is named odph precisely becasue they are not core APIs. > I think it is a valid separate question if some of the odph members should > be in the full API. > So that's a separate discussion which is now continuing in anoth

[lng-odp] [PATCHv4 2/2] validation: tests for module odp_ver_abt_log_dbg

2015-04-27 Thread Christophe Milard
Created directory for module odp_ver_abt_log_dbg, populated with file odp_errno.c and odp_system.c which, despite its confusing name is not testing the system module but the sys* function of the odp_ver_abt_log_dbg module. Signed-off-by: Christophe Milard --- v3/v4 delta: fixed bootstrap warning

[lng-odp] [PATCHv4 1/2] validation: rename executable to match modules

2015-04-27 Thread Christophe Milard
Just the executables whose contents already matched a module have been renamed. Module names are taken from doxygens defgroup Signed-off-by: Christophe Milard --- v3/v4 delta: fixed odp_scheduler.c warnings (had too old version of check-odp... thanks Mike) test/validation/.gitignore

Re: [lng-odp] [API-NEXT PATCH v2] timer: Add missing platform handles to u64 conversion functions

2015-04-27 Thread Savolainen, Petri (Nokia - FI/Espoo)
Yes, implementation and tests are needed before the general release. Should we postpone the general release until those are there? Does api-next have to have all implemented before merge to master? A new API definition does not break anything before someone tries to use it. -Petri From: lng-od

Re: [lng-odp] [API-NEXT PATCH v2] timer: Add missing platform handles to u64 conversion functions

2015-04-27 Thread Savolainen, Petri (Nokia - FI/Espoo)
I can see only your API changes merged into the api-next. My patches renamed those (everything that’s in the repo). Just wonder what happened to the implementation patches? Lost during merge? -Petri From: ext Bill Fischofer [mailto:bill.fischo...@linaro.org] Sent: Friday, April 24, 2015 5:15 PM