Re: lyx compiling (SVN)

2009-05-05 Thread Guenter Milde
On 2009-05-04, Wolfgang Engelmann wrote:
 in compiling lyx I am told zlib.h is missing.
 I can't find this under 'search' of synaptics (debian lenny)
 How do I get it?
 Wolfgang

Here is my recepy to build LyX-svn on Debian:

 * Update sources `svn update` 
   
   (eventually switch to a another branch, 
   `svn switch svn://svn.lyx.org/lyx/lyx-devel/branches/BRANCH_1_6_X`)
 
 * Install all the dependencies with `apt-get build-dep lyx`
   (after installing build-dep via `apt-get install build-dep`).
 
 * Configuration/Automake:
 
   pre-configuration with `autogen.sh`
   
   Without debug-symbols (otherwise the memory on my machine will run out), 
   use suffix (lyx - lyx16)::
   
./configure --with-version-suffix=16 --enable-build-type=release 

 * make, make install

 * optional: crate a binary tarball::

 Use make DESTDIR=/tmp/lyx-svn install and then make an archive of
 everything in /tmp/lyx-svn.


Günter



Re: lyx compiling (SVN)

2009-05-05 Thread Wolfgang Engelmann
Am Monday 04 May 2009 20:20:54 schrieb Wolfgang Engelmann:
 Am Monday 04 May 2009 19:21:12 schrieben Sie:
  Wolfgang Engelmann wrote:
   in compiling lyx I am told zlib.h is missing.
   I can't find this under 'search' of synaptics (debian lenny)
 
  In think you need zlib devel, or something like that.
 
  rh

 I choose zlib1g and zlib1g-dev and zlibc
 and was asked to accept apt-build
 however I did not, since I am completely unexperienced

 fortunately ./configure worked.
 Will see how make and install behaves. Its running

 thanks for all the help (its a very kind and patient list, I must say!)

 Wolfgang

 ps I made it. Good

However, today in trying to use LyX:

the history:
==

1-under Debian lenny I upgraded to Lyx1.6.2 (using a debian Lyx1.6.2 package).
Running a document (koma book) I got this error:
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript
(this message is constantly repeated)

2-I was adviced to replace Ghostscript 8.62 by Ghostscript 8.64.
Since it was not available under lenny, I used Debian squeeze, but things got 
worse because I muddled up my debian lenny linux.

3-Therefore I installed  LyX 1.6.3 hoping that this would help. It did not. In 
running my document I get again:
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript 
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript 
GPL Ghostscript 8.62: Unrecoverable error, exit code 1

and after a long run lyx disappears and I get:
lyx: SIGSEGV signal caught
Sorry, you have found a bug in LyX. Please read the bug-reporting instructions 
in Help-Introduction and send us a bug report, if necessary. Thanks !
Bye.

the situation:

I will now run it again under  bug-reporting and report on it.
Before I do it I have tested the Introduction to LyX under help and get
wolfg...@wolfgang:~/Desktop$ lyx -dbg Intro-x.lyx
Setting debug level to Intro-x.lyx
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript 
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript 
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript 
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript 
GPL Ghostscript 8.62: Unrecoverable error, exit code 1

In contrast to my document it stops putting out these errors (only those shown 
above) and LyX does not break down.
There is no output in Latex protocoll. Where would I find the debug report?


the question:

is there anybody in the list who uses Debian lenny and LyX either 1.6.2 or 
later svn versions successfully? Is she/he using Ghostscript 8.64 and from 
where can I get a Debian package?

Thanks for your attention

Wolfgang


Re: lyx compiling (SVN)

2009-05-05 Thread Guenter Milde
On 2009-05-05, Wolfgang Engelmann wrote:

 However, today in trying to use LyX:

 the history:
==

 1-under Debian lenny I upgraded to Lyx1.6.2 (using a debian Lyx1.6.2 package).
 Running a document (koma book) I got this error:
 GPL Ghostscript 8.62: Unrecoverable error, exit code 1
 dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript
 (this message is constantly repeated)

 2-I was adviced to replace Ghostscript 8.62 by Ghostscript 8.64.
 Since it was not available under lenny, I used Debian squeeze, but things got 
 worse because I muddled up my debian lenny linux.

...

 the question:

 is there anybody in the list who uses Debian lenny and LyX either 1.6.2 or 
 later svn versions successfully? Is she/he using Ghostscript 8.64 and from 
 where can I get a Debian package?

I use LyX 1.6.2 and Ghostscript 8.64 from Debian/testing.
You might try to add testing to your sources.list and issue
``apt-get update``
``apt-get install ghostscript``.
Or download just the ghostscript package and install with dpkg.

Günter



Re: lyx compiling (SVN)

2009-05-05 Thread Guenter Milde
On 2009-05-04, Wolfgang Engelmann wrote:
 in compiling lyx I am told zlib.h is missing.
 I can't find this under 'search' of synaptics (debian lenny)
 How do I get it?
 Wolfgang

Here is my recepy to build LyX-svn on Debian:

 * Update sources `svn update` 
   
   (eventually switch to a another branch, 
   `svn switch svn://svn.lyx.org/lyx/lyx-devel/branches/BRANCH_1_6_X`)
 
 * Install all the dependencies with `apt-get build-dep lyx`
   (after installing build-dep via `apt-get install build-dep`).
 
 * Configuration/Automake:
 
   pre-configuration with `autogen.sh`
   
   Without debug-symbols (otherwise the memory on my machine will run out), 
   use suffix (lyx - lyx16)::
   
./configure --with-version-suffix=16 --enable-build-type=release 

 * make, make install

 * optional: crate a binary tarball::

 Use make DESTDIR=/tmp/lyx-svn install and then make an archive of
 everything in /tmp/lyx-svn.


Günter



Re: lyx compiling (SVN)

2009-05-05 Thread Wolfgang Engelmann
Am Monday 04 May 2009 20:20:54 schrieb Wolfgang Engelmann:
 Am Monday 04 May 2009 19:21:12 schrieben Sie:
  Wolfgang Engelmann wrote:
   in compiling lyx I am told zlib.h is missing.
   I can't find this under 'search' of synaptics (debian lenny)
 
  In think you need zlib devel, or something like that.
 
  rh

 I choose zlib1g and zlib1g-dev and zlibc
 and was asked to accept apt-build
 however I did not, since I am completely unexperienced

 fortunately ./configure worked.
 Will see how make and install behaves. Its running

 thanks for all the help (its a very kind and patient list, I must say!)

 Wolfgang

 ps I made it. Good

However, today in trying to use LyX:

the history:
==

1-under Debian lenny I upgraded to Lyx1.6.2 (using a debian Lyx1.6.2 package).
Running a document (koma book) I got this error:
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript
(this message is constantly repeated)

2-I was adviced to replace Ghostscript 8.62 by Ghostscript 8.64.
Since it was not available under lenny, I used Debian squeeze, but things got 
worse because I muddled up my debian lenny linux.

3-Therefore I installed  LyX 1.6.3 hoping that this would help. It did not. In 
running my document I get again:
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript 
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript 
GPL Ghostscript 8.62: Unrecoverable error, exit code 1

and after a long run lyx disappears and I get:
lyx: SIGSEGV signal caught
Sorry, you have found a bug in LyX. Please read the bug-reporting instructions 
in Help-Introduction and send us a bug report, if necessary. Thanks !
Bye.

the situation:

I will now run it again under  bug-reporting and report on it.
Before I do it I have tested the Introduction to LyX under help and get
wolfg...@wolfgang:~/Desktop$ lyx -dbg Intro-x.lyx
Setting debug level to Intro-x.lyx
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript 
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript 
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript 
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript 
GPL Ghostscript 8.62: Unrecoverable error, exit code 1

In contrast to my document it stops putting out these errors (only those shown 
above) and LyX does not break down.
There is no output in Latex protocoll. Where would I find the debug report?


the question:

is there anybody in the list who uses Debian lenny and LyX either 1.6.2 or 
later svn versions successfully? Is she/he using Ghostscript 8.64 and from 
where can I get a Debian package?

Thanks for your attention

Wolfgang


Re: lyx compiling (SVN)

2009-05-05 Thread Guenter Milde
On 2009-05-05, Wolfgang Engelmann wrote:

 However, today in trying to use LyX:

 the history:
==

 1-under Debian lenny I upgraded to Lyx1.6.2 (using a debian Lyx1.6.2 package).
 Running a document (koma book) I got this error:
 GPL Ghostscript 8.62: Unrecoverable error, exit code 1
 dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript
 (this message is constantly repeated)

 2-I was adviced to replace Ghostscript 8.62 by Ghostscript 8.64.
 Since it was not available under lenny, I used Debian squeeze, but things got 
 worse because I muddled up my debian lenny linux.

...

 the question:

 is there anybody in the list who uses Debian lenny and LyX either 1.6.2 or 
 later svn versions successfully? Is she/he using Ghostscript 8.64 and from 
 where can I get a Debian package?

I use LyX 1.6.2 and Ghostscript 8.64 from Debian/testing.
You might try to add testing to your sources.list and issue
``apt-get update``
``apt-get install ghostscript``.
Or download just the ghostscript package and install with dpkg.

Günter



Re: lyx compiling (SVN)

2009-05-05 Thread Guenter Milde
On 2009-05-04, Wolfgang Engelmann wrote:
> in compiling lyx I am told zlib.h is missing.
> I can't find this under 'search' of synaptics (debian lenny)
> How do I get it?
> Wolfgang

Here is my recepy to build LyX-svn on Debian:

 * Update sources `svn update` 
   
   (eventually switch to a another branch, 
   `svn switch svn://svn.lyx.org/lyx/lyx-devel/branches/BRANCH_1_6_X`)
 
 * Install all the dependencies with `apt-get build-dep lyx`
   (after installing build-dep via `apt-get install build-dep`).
 
 * Configuration/Automake:
 
   pre-configuration with `autogen.sh`
   
   Without debug-symbols (otherwise the memory on my machine will run out), 
   use suffix (lyx -> lyx16)::
   
./configure --with-version-suffix=16 --enable-build-type=release 

 * make, make install

 * optional: crate a binary tarball::

 Use "make DESTDIR=/tmp/lyx-svn install" and then make an archive of
 everything in /tmp/lyx-svn.


Günter



Re: lyx compiling (SVN)

2009-05-05 Thread Wolfgang Engelmann
Am Monday 04 May 2009 20:20:54 schrieb Wolfgang Engelmann:
> Am Monday 04 May 2009 19:21:12 schrieben Sie:
> > Wolfgang Engelmann wrote:
> > > in compiling lyx I am told zlib.h is missing.
> > > I can't find this under 'search' of synaptics (debian lenny)
> >
> > In think you need zlib devel, or something like that.
> >
> > rh
>
> I choose zlib1g and zlib1g-dev and zlibc
> and was asked to accept apt-build
> however I did not, since I am completely unexperienced
>
> fortunately ./configure worked.
> Will see how make and install behaves. Its running
>
> thanks for all the help (its a very kind and patient list, I must say!)
>
> Wolfgang
>
> ps I made it. Good

However, today in trying to use LyX:

the history:
==

1-under Debian lenny I upgraded to Lyx1.6.2 (using a debian Lyx1.6.2 package).
Running a document (koma book) I got this error:
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript
(this message is constantly repeated)

2-I was adviced to replace Ghostscript 8.62 by Ghostscript 8.64.
Since it was not available under lenny, I used Debian squeeze, but things got 
worse because I muddled up my debian lenny linux.

3-Therefore I installed  LyX 1.6.3 hoping that this would help. It did not. In 
running my document I get again:
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript 
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript 
GPL Ghostscript 8.62: Unrecoverable error, exit code 1

and after a long run lyx disappears and I get:
lyx: SIGSEGV signal caught
Sorry, you have found a bug in LyX. Please read the bug-reporting instructions 
in Help->Introduction and send us a bug report, if necessary. Thanks !
Bye.

the situation:

I will now run it again under  bug-reporting and report on it.
Before I do it I have tested the Introduction to LyX under help and get
wolfg...@wolfgang:~/Desktop$ lyx -dbg Intro-x.lyx
Setting debug level to Intro-x.lyx
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript 
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript 
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript 
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript 
GPL Ghostscript 8.62: Unrecoverable error, exit code 1

In contrast to my document it stops putting out these errors (only those shown 
above) and LyX does not break down.
There is no output in Latex protocoll. Where would I find the debug report?


the question:

is there anybody in the list who uses Debian lenny and LyX either 1.6.2 or 
later svn versions successfully? Is she/he using Ghostscript 8.64 and from 
where can I get a Debian package?

Thanks for your attention

Wolfgang


Re: lyx compiling (SVN)

2009-05-05 Thread Guenter Milde
On 2009-05-05, Wolfgang Engelmann wrote:

> However, today in trying to use LyX:

> the history:
>==

> 1-under Debian lenny I upgraded to Lyx1.6.2 (using a debian Lyx1.6.2 package).
> Running a document (koma book) I got this error:
> GPL Ghostscript 8.62: Unrecoverable error, exit code 1
> dvipng warning: No GhostScript pngalpha output, cannot render raw PostScript
> (this message is constantly repeated)

> 2-I was adviced to replace Ghostscript 8.62 by Ghostscript 8.64.
> Since it was not available under lenny, I used Debian squeeze, but things got 
> worse because I muddled up my debian lenny linux.

...

> the question:
>
> is there anybody in the list who uses Debian lenny and LyX either 1.6.2 or 
> later svn versions successfully? Is she/he using Ghostscript 8.64 and from 
> where can I get a Debian package?

I use LyX 1.6.2 and Ghostscript 8.64 from Debian/testing.
You might try to add "testing" to your sources.list and issue
``apt-get update``
``apt-get install ghostscript``.
Or download just the ghostscript package and install with dpkg.

Günter



lyx compiling (SVN)

2009-05-04 Thread Wolfgang Engelmann
in compiling lyx I am told zlib.h is missing.
I can't find this under 'search' of synaptics (debian lenny)
How do I get it?
Wolfgang


Re: lyx compiling (SVN)

2009-05-04 Thread rgheck

Wolfgang Engelmann wrote:

in compiling lyx I am told zlib.h is missing.
I can't find this under 'search' of synaptics (debian lenny)

  

In think you need zlib devel, or something like that.

rh



Re: lyx compiling (SVN)

2009-05-04 Thread Wolfgang Engelmann
Am Monday 04 May 2009 19:21:12 schrieben Sie:
 Wolfgang Engelmann wrote:
  in compiling lyx I am told zlib.h is missing.
  I can't find this under 'search' of synaptics (debian lenny)

 In think you need zlib devel, or something like that.

 rh

I choose zlib1g and zlib1g-dev and zlibc
and was asked to accept apt-build
however I did not, since I am completely unexperienced 

fortunately ./configure worked. 
Will see how make and install behaves. Its running

thanks for all the help (its a very kind and patient list, I must say!)

Wolfgang

ps I made it. Good


lyx compiling (SVN)

2009-05-04 Thread Wolfgang Engelmann
in compiling lyx I am told zlib.h is missing.
I can't find this under 'search' of synaptics (debian lenny)
How do I get it?
Wolfgang


Re: lyx compiling (SVN)

2009-05-04 Thread rgheck

Wolfgang Engelmann wrote:

in compiling lyx I am told zlib.h is missing.
I can't find this under 'search' of synaptics (debian lenny)

  

In think you need zlib devel, or something like that.

rh



Re: lyx compiling (SVN)

2009-05-04 Thread Wolfgang Engelmann
Am Monday 04 May 2009 19:21:12 schrieben Sie:
 Wolfgang Engelmann wrote:
  in compiling lyx I am told zlib.h is missing.
  I can't find this under 'search' of synaptics (debian lenny)

 In think you need zlib devel, or something like that.

 rh

I choose zlib1g and zlib1g-dev and zlibc
and was asked to accept apt-build
however I did not, since I am completely unexperienced 

fortunately ./configure worked. 
Will see how make and install behaves. Its running

thanks for all the help (its a very kind and patient list, I must say!)

Wolfgang

ps I made it. Good


lyx compiling (SVN)

2009-05-04 Thread Wolfgang Engelmann
in compiling lyx I am told zlib.h is missing.
I can't find this under 'search' of synaptics (debian lenny)
How do I get it?
Wolfgang


Re: lyx compiling (SVN)

2009-05-04 Thread rgheck

Wolfgang Engelmann wrote:

in compiling lyx I am told zlib.h is missing.
I can't find this under 'search' of synaptics (debian lenny)

  

In think you need zlib devel, or something like that.

rh



Re: lyx compiling (SVN)

2009-05-04 Thread Wolfgang Engelmann
Am Monday 04 May 2009 19:21:12 schrieben Sie:
> Wolfgang Engelmann wrote:
> > in compiling lyx I am told zlib.h is missing.
> > I can't find this under 'search' of synaptics (debian lenny)
>
> In think you need zlib devel, or something like that.
>
> rh

I choose zlib1g and zlib1g-dev and zlibc
and was asked to accept apt-build
however I did not, since I am completely unexperienced 

fortunately ./configure worked. 
Will see how make and install behaves. Its running

thanks for all the help (its a very kind and patient list, I must say!)

Wolfgang

ps I made it. Good