Re: [matplotlib-devel] API additions

2007-10-04 Thread Michael Droettboom
James, In principle, I'm not against adding a new API for this as long as the old one doesn't break. I just have the usual concerns that callers of get_xlim/get_ylim don't break because of this. The things I've tried so far seem to be working, but all calls to get_xlim/get_ylim should be test

Re: [matplotlib-devel] py2exe wisdom

2007-10-04 Thread Paul Kienzle
On Tue, Oct 02, 2007 at 10:42:13AM -0400, Paul Kienzle wrote: > As I was building a py2exe distribution of matplotlib, I noticed the > function get_py2exe_datafiles() in __init__.py that is not noted on > the FAQ. Before I update the FAQ, can you all tell me your best > practices recommendations f

Re: [matplotlib-devel] API additions

2007-10-04 Thread Ted Drain
John, I think that the problem isn't doing the inversion - it's keeping it. Calling set_xlim() to invert is fine - but it never seems to stay that way. There is a lot of code (resizing, autoscaling, labelling, etc) that has a tendency to flip the axis back to it's 'un-inverted' state. The id

Re: [matplotlib-devel] API additions

2007-10-04 Thread John Hunter
On 10/4/07, Michael Droettboom <[EMAIL PROTECTED]> wrote: > def invert_xaxis(self, invert=True): > > "Invert the x-axis if 'invert' is True." > I like this approach over a state flag (I agree with Eric that it would be nice to avoid if we can since it complicates communication betwe

Re: [matplotlib-devel] API additions

2007-10-04 Thread John Hunter
On 10/4/07, Ted Drain <[EMAIL PROTECTED]> wrote: > John, > I think that the problem isn't doing the inversion - it's keeping > it. Calling set_xlim() to invert is fine - but it never seems to > stay that way. There is a lot of code (resizing, autoscaling, > labelling, etc) that has a tendency to

Re: [matplotlib-devel] API additions

2007-10-04 Thread Ted Drain
John, I think keeping the existing API is probably a good idea. What about something like this: - Keep xlim and viewlim as they are. - Add xbound() (or maybe a better name) that returns (x1,x2) where x1 < x2. - Add set_xbound(x1,x2) that takes x1On 10/4/07, Ted Drain <[EMAIL PROTECTED]> wrote:

Re: [matplotlib-devel] API additions

2007-10-04 Thread Eric Firing
Ted Drain wrote: > John, > I think keeping the existing API is probably a good idea. What about > something like this: > > - Keep xlim and viewlim as they are. > > - Add xbound() (or maybe a better name) that returns (x1,x2) where x1 < x2. > > - Add set_xbound(x1,x2) that takes x1 then calls s

Re: [matplotlib-devel] API additions

2007-10-04 Thread Eric Firing
Ted Drain wrote: > John, > I think that the problem isn't doing the inversion - it's keeping it. > Calling set_xlim() to invert is fine - but it never seems to stay that > way. There is a lot of code (resizing, autoscaling, labelling, etc) > that has a tendency to flip the axis back to it's 'u

Re: [matplotlib-devel] API additions

2007-10-04 Thread Eric Firing
Ted Drain wrote: > John, > I think keeping the existing API is probably a good idea. What about > something like this: > > - Keep xlim and viewlim as they are. > > - Add xbound() (or maybe a better name) that returns (x1,x2) where x1 < x2. > > - Add set_xbound(x1,x2) that takes x1 then calls s

Re: [matplotlib-devel] API additions

2007-10-04 Thread Ted Drain
Sounds fine - I don't think we care too much about the "how". I talked w/ James and as far as we know, the aspect code is the only area that's having a problem right now (James is going to submit a patch to that to handle x1>x2 today). Since we do these plots all the time, we've just seen a nu

Re: [matplotlib-devel] API additions

2007-10-04 Thread James Evans
All, Based on what everyone has been saying I have submitted an update to axes.py that reverts the get/set xlim/ylim methods to their original state with their original interface. I have removed the state flag that keeps track of inverted axes. Currently I have added the method get/set xbound/