[Mesa-dev] [PATCH] i965: Enable ES 3.2 on Skylake.

2016-09-20 Thread Kenneth Graunke
It's already advertised because the version.c extension checks are fulfilled, but we didn't actually claim support, so trying to create a ES 3.2 context would fail. It's all done, and the CTS results look good, so let's turn it on. Signed-off-by: Kenneth Graunke ---

[Mesa-dev] [Bug 97260] R9 290 low performance in Linux 4.7

2016-09-20 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=97260 --- Comment #56 from Michel Dänzer --- Created attachment 126687 --> https://bugs.freedesktop.org/attachment.cgi?id=126687=edit Use 4 buffers for flipping (In reply to Xavier Sellier from comment #52) > We are experiencing

[Mesa-dev] [Bug 97260] R9 290 low performance in Linux 4.7

2016-09-20 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=97260 --- Comment #55 from Xavier Sellier --- Created attachment 126686 --> https://bugs.freedesktop.org/attachment.cgi?id=126686=edit Unigine valley benchmark (Kernel 4.8.0-rc5) -- You are receiving this mail because: You are

[Mesa-dev] [Bug 97260] R9 290 low performance in Linux 4.7

2016-09-20 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=97260 Xavier Sellier changed: What|Removed |Added Resolution|--- |WONTFIX

[Mesa-dev] [Bug 97260] R9 290 low performance in Linux 4.7

2016-09-20 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=97260 --- Comment #53 from Xavier Sellier --- Created attachment 126685 --> https://bugs.freedesktop.org/attachment.cgi?id=126685=edit Unigine valley benchmark (Kernel 4.6.0-1) -- You are receiving this mail because: You are

[Mesa-dev] [Bug 97260] R9 290 low performance in Linux 4.7

2016-09-20 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=97260 Xavier Sellier changed: What|Removed |Added Resolution|WONTFIX |---

[Mesa-dev] [Bug 97260] R9 290 low performance in Linux 4.7

2016-09-20 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=97260 Michel Dänzer changed: What|Removed |Added Summary|[bisected] R9 290 low |R9 290 low

[Mesa-dev] [Bug 97879] [amdgpu] Rocket League: long hangs (several seconds) when loading assets (models/textures/shaders?)

2016-09-20 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=97879 Michel Dänzer changed: What|Removed |Added Component|Drivers/Gallium/radeonsi|glsl-compiler

Re: [Mesa-dev] [PATCH 1/3] anv: device: calculate compute thread numbers using subslices numbers

2016-09-20 Thread Lionel Landwerlin
On Tue, 2016-09-20 at 16:48 -0700, Kenneth Graunke wrote: > On Friday, September 9, 2016 11:45:07 AM PDT Lionel Landwerlin wrote: > [snip] > > > > diff --git a/src/intel/vulkan/anv_private.h > > b/src/intel/vulkan/anv_private.h > > index 99b3acf..aa9be69 100644 > > ---

Re: [Mesa-dev] [PATCH v3] *** Decode fields spanning across two DWords correctly ***

2016-09-20 Thread Gandikota, Sirisha
>-Original Message- >From: mesa-dev [mailto:mesa-dev-boun...@lists.freedesktop.org] On Behalf Of >Kenneth Graunke >Sent: Tuesday, September 20, 2016 4:28 PM >To: mesa-dev@lists.freedesktop.org >Subject: Re: [Mesa-dev] [PATCH v3] *** Decode fields spanning across two >DWords correctly ***

Re: [Mesa-dev] [PATCH 1/3] anv: device: calculate compute thread numbers using subslices numbers

2016-09-20 Thread Kenneth Graunke
On Friday, September 9, 2016 11:45:07 AM PDT Lionel Landwerlin wrote: [snip] > diff --git a/src/intel/vulkan/anv_private.h b/src/intel/vulkan/anv_private.h > index 99b3acf..aa9be69 100644 > --- a/src/intel/vulkan/anv_private.h > +++ b/src/intel/vulkan/anv_private.h > @@ -569,6 +569,20 @@ struct

Re: [Mesa-dev] [PATCH 07/12] anv/image: Memset hiz surfaces to 0 when binding memory

2016-09-20 Thread Nanley Chery
On Fri, Sep 02, 2016 at 12:46:30PM -0700, Chad Versace wrote: > On Thu 01 Sep 2016, Jason Ekstrand wrote: > > > > > > On Wed, Aug 31, 2016 at 8:29 PM, Nanley Chery wrote: > > > > From: Jason Ekstrand > > > > Nanley Chery (amend): > >

[Mesa-dev] [Bug 97879] [amdgpu] Rocket League: long hangs (several seconds) when loading assets (models/textures/shaders?)

2016-09-20 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=97879 Kenneth Graunke changed: What|Removed |Added QA Contact|mesa-dev@lists.freedesktop.

Re: [Mesa-dev] [PATCH v3] *** Decode fields spanning across two DWords correctly ***

2016-09-20 Thread Kenneth Graunke
On Tuesday, September 20, 2016 3:59:27 PM PDT Sirisha Gandikota wrote: > From: Sirisha Gandikota > > The first version of aubinator did not take into account the fields > spanning across 2 DWords. Hence fields like 64bit address/offset and > int were not decoded

Re: [Mesa-dev] [PATCH v2] mesa: Implement ARB_shader_viewport_layer_array for i965

2016-09-20 Thread Kenneth Graunke
On Monday, September 19, 2016 3:36:09 PM PDT Dylan Baker wrote: > This extension is a combination of AMD_vertex_shader_viewport_index and > AMD_vertex_shader_layer, making it rather trivial to implement. > > For gallium I *think* this needs a new cap because of the addition of > support in

[Mesa-dev] [PATCH V6] nir: Add a loop analysis pass

2016-09-20 Thread Timothy Arceri
From: Thomas Helland This pass detects induction variables and calculates the trip count of loops to be used for loop unrolling. I've removed support for float induction values for now, for the simple reason that they don't appear in my shader-db collection, and so I

Re: [Mesa-dev] [PATCH v3] aubinator: Fix the decoding of values that span two Dwords

2016-09-20 Thread Anuj Phogat
On Tue, Sep 20, 2016 at 3:59 PM, Sirisha Gandikota wrote: > From: Sirisha Gandikota > > Fixed the way the values that span two Dwords are decoded. > Based on the start and end indices of the field, the Dwords > are fetched and decoded

[Mesa-dev] [PATCH v3] aubinator: Fix the decoding of values that span two Dwords

2016-09-20 Thread Sirisha Gandikota
From: Sirisha Gandikota Fixed the way the values that span two Dwords are decoded. Based on the start and end indices of the field, the Dwords are fetched and decoded accordingly. v2: rename dw to qw in gen_field_iterator_next and remove extra white space (Anuj)

[Mesa-dev] [PATCH v3] *** Decode fields spanning across two DWords correctly ***

2016-09-20 Thread Sirisha Gandikota
From: Sirisha Gandikota The first version of aubinator did not take into account the fields spanning across 2 DWords. Hence fields like 64bit address/offset and int were not decoded correctly. This patch should fix that issue. v2: Aptly renamed dw to qw in the

Re: [Mesa-dev] [PATCH v2] aubinator: Fix the decoding of values that span two Dwords

2016-09-20 Thread Anuj Phogat
On Tue, Sep 20, 2016 at 3:31 PM, Sirisha Gandikota wrote: > From: Sirisha Gandikota > > Fixed the way the values that span two Dwords are decoded. > Based on the start and end indices of the field, the Dwords > are fetched and decoded

[Mesa-dev] [PATCH v2] *** Decode fields spanning to two DWords correctly ***

2016-09-20 Thread Sirisha Gandikota
From: Sirisha Gandikota The first version of aubinator did not take into account the fields spanning to 2 DWords. Hence fields like 64bit address/offset and int were not decoded correctly. This patch should fix that issue. v2: Aptly renamed dw to qw in the method

[Mesa-dev] [PATCH v2] aubinator: Fix the decoding of values that span two Dwords

2016-09-20 Thread Sirisha Gandikota
From: Sirisha Gandikota Fixed the way the values that span two Dwords are decoded. Based on the start and end indices of the field, the Dwords are fetched and decoded accordingly. v2: rename dw to qw in gen_field_iterator_next() and remove extra white space in the

[Mesa-dev] [Bug 97260] [bisected] R9 290 low performance in Linux 4.7

2016-09-20 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=97260 --- Comment #50 from Clésio Luiz --- I opened the bug, but a couple weeks ago my card died, so I cannot provide info anymore. -- You are receiving this mail because: You are the assignee for the bug. You are the QA

Re: [Mesa-dev] [PATCH] aubinator: Fix the decoding of values that span two Dwords

2016-09-20 Thread Anuj Phogat
On Tue, Sep 20, 2016 at 12:35 PM, Sirisha Gandikota wrote: > From: Sirisha Gandikota > > Fixed the way the values that span two Dwords are decoded. > Based on the start and end indices of the field, the Dwords > are fetched and decoded

Re: [Mesa-dev] [PATCH 1/2] i965: Rename __DRIScreen pointers to "dri_screen".

2016-09-20 Thread Anuj Phogat
On Tue, Sep 20, 2016 at 12:15 PM, Kenneth Graunke wrote: > I want to use "screen" as the variable name for a struct intel_screen > pointer. This means that we can't use it for __DRIscreen pointers. > > Sometimes we called it "screen", sometimes "sPriv", sometimes >

[Mesa-dev] [Bug 97260] [bisected] R9 290 low performance in Linux 4.7

2016-09-20 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=97260 Xavier Sellier changed: What|Removed |Added CC||xsell...@gmail.com

[Mesa-dev] [Bug 97879] [amdgpu] Rocket League: long hangs (several seconds) when loading assets (models/textures/shaders?)

2016-09-20 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=97879 Bug ID: 97879 Summary: [amdgpu] Rocket League: long hangs (several seconds) when loading assets (models/textures/shaders?) Product: Mesa Version: 12.0 Hardware: x86-64

[Mesa-dev] [PATCH 1/3] st/va: Return more useful config attributes

2016-09-20 Thread Mark Thompson
--- On 20/09/16 10:55, Christian König wrote: >> +if (profile == VAProfileHEVCMain10) >> + value = VA_RT_FORMAT_YUV420_10BPP; > We actually don't support that yet. Main10 profiles dither down the 10bit > output to 8bits before writing it to the VA-API surface at the

[Mesa-dev] [PATCH] *** Decode fields spanning to two DWords correctly ***

2016-09-20 Thread Sirisha Gandikota
From: Sirisha Gandikota The first version of aubinator did not take into account the fields spanning to 2 DWords. Hence fields like 64bit address/offset and int were not decoded correctly. This patch should fix that issue. Sirisha Gandikota (1): aubinator: Fix the

[Mesa-dev] [PATCH] aubinator: Fix the decoding of values that span two Dwords

2016-09-20 Thread Sirisha Gandikota
From: Sirisha Gandikota Fixed the way the values that span two Dwords are decoded. Based on the start and end indices of the field, the Dwords are fetched and decoded accordingly. Earlier, 64-bit fields (such as most pointers on Gen8+) weren't decoded correctly.

[Mesa-dev] [PATCH] swr: replace mesa->swr format enum conversion

2016-09-20 Thread Tim Rowley
Replace old string comparison with a mapping table. --- src/gallium/drivers/swr/swr_screen.cpp | 344 - 1 file changed, 293 insertions(+), 51 deletions(-) diff --git a/src/gallium/drivers/swr/swr_screen.cpp b/src/gallium/drivers/swr/swr_screen.cpp index

[Mesa-dev] [PATCH 1/2] i965: Rename __DRIScreen pointers to "dri_screen".

2016-09-20 Thread Kenneth Graunke
I want to use "screen" as the variable name for a struct intel_screen pointer. This means that we can't use it for __DRIscreen pointers. Sometimes we called it "screen", sometimes "sPriv", sometimes "driScrnPriv", and sometimes "psp" (Pointer to Screen Private?). The last one is particularly

[Mesa-dev] [PATCH 2/2] i965: Rename intelScreen to screen.

2016-09-20 Thread Kenneth Graunke
"intelScreen" is wordy and also doesn't fit our style guidelines. "screen" is shorter, which is nice, because we use it fairly often. Signed-off-by: Kenneth Graunke --- src/mesa/drivers/dri/i965/brw_blorp.c| 2 +- src/mesa/drivers/dri/i965/brw_clip.c

Re: [Mesa-dev] [PATCH] i965/ir: Test thread dispatch packing assumptions.

2016-09-20 Thread Jason Ekstrand
On Sep 20, 2016 12:49 AM, "Francisco Jerez" wrote: > > Not intended for upstream. If we're going to upstream this, we should remove the content saying we won't. Otherwise r-b > Should cause a GPU hang if some thread is > executed with a non-contiguous dispatch mask

Re: [Mesa-dev] [PATCH] anv: Check for VK_WHOLE_SIZE in anv_CmdFillBuffer

2016-09-20 Thread Jason Ekstrand
Seems reasonable Reviewed-by: Jason Ekstrand This reminds me that we really need to convert CmdFillBuffer over to using blorp... On Sep 20, 2016 6:37 PM, "Nicolas Koch" wrote: > Vulkan spec: > Size is the number of bytes to fill, and must be either

[Mesa-dev] [PATCH] anv: Check for VK_WHOLE_SIZE in anv_CmdFillBuffer

2016-09-20 Thread Nicolas Koch
Vulkan spec: Size is the number of bytes to fill, and must be either a multiple of 4, or VK_WHOLE_SIZE to fill the range from offset to the end of the buffer. If VK_WHOLE_SIZE is used and the remaining size of the buffer is not a multiple of 4, then the nearest smaller multiple is used. ---

Re: [Mesa-dev] [PATCH] st/va: Make VAAPI_DISABLE_INTERLACE default true

2016-09-20 Thread Andy Furniss
Andy Furniss wrote: Hi @Andy, could you update your patch to move that debug env flag to radeon ? Thx I don't know mesa code that well so maybe I misunderstand, but, if I default to true and test in there it will affect vdpau decode as well which I guess will disable de-interlace and maybe

Re: [Mesa-dev] [PATCH] radeon/vce: add firmware support for version 52.8.3

2016-09-20 Thread Christian König
Am 20.09.2016 um 16:11 schrieb Leo Liu: Signed-off-by: Leo Liu Reviewed-by: Christian König --- src/gallium/drivers/radeon/radeon_vce.c | 3 +++ 1 file changed, 3 insertions(+) diff --git a/src/gallium/drivers/radeon/radeon_vce.c

[Mesa-dev] [PATCH] radeon/vce: add firmware support for version 52.8.3

2016-09-20 Thread Leo Liu
Signed-off-by: Leo Liu --- src/gallium/drivers/radeon/radeon_vce.c | 3 +++ 1 file changed, 3 insertions(+) diff --git a/src/gallium/drivers/radeon/radeon_vce.c b/src/gallium/drivers/radeon/radeon_vce.c index 92cb8ce..8504d93 100644 ---

Re: [Mesa-dev] [PATCH] st/va: Make VAAPI_DISABLE_INTERLACE default true

2016-09-20 Thread Andy Furniss
Julien Isorce wrote: On 16 September 2016 at 08:43, Christian König wrote: Am 15.09.2016 um 23:07 schrieb Julien Isorce: On 15 September 2016 at 16:02, Leo Liu wrote: On 09/15/2016 10:43 AM, Andy Furniss wrote: Since bf901a2 st/va: also

Re: [Mesa-dev] [PATCH 1/3] vl/dri3: handle the case of different GPU(v4.2)

2016-09-20 Thread Mike Lothian
I'm running libva-1.7.2 but I notice this commit in git https://cgit.freedesktop.org/vaapi/libva/commit/?id=a55ea7cb3143d57c8dba1b76ccea3511ea69adf2 but that looks like it might only work with wayland On Tue, 20 Sep 2016 at 14:40 Christian König wrote: > Sounds like

Re: [Mesa-dev] [PATCH 1/3] vl/dri3: handle the case of different GPU(v4.2)

2016-09-20 Thread Christian König
Sounds like your version of libva ignores the DRI_PRIME environment parameter. Not sure what to do with this, but clearly a loader and not a driver problem. Regards, Christian. Am 20.09.2016 um 15:36 schrieb Mike Lothian: Here's what I currently have: fireburn@axion ~ $ DRI_PRIME=1 vainfo

Re: [Mesa-dev] [PATCH 1/3] vl/dri3: handle the case of different GPU(v4.2)

2016-09-20 Thread Mike Lothian
Here's what I currently have: fireburn@axion ~ $ DRI_PRIME=1 vainfo libva info: VA-API version 0.39.3 libva info: va_getDriverName() returns 0 libva info: Trying to open /usr/lib64/va/drivers/i965_drv_video.so libva info: Found init function __vaDriverInit_0_39 libva info: va_openDriver() returns

Re: [Mesa-dev] [PATCH 1/3] vl/dri3: handle the case of different GPU(v4.2)

2016-09-20 Thread Nayan Deshmukh
Hi Mike, On Tue, Sep 20, 2016 at 5:45 PM, Mike Lothian wrote: > Hi > > I've just confirmed this works for getting details from vainfo and > vdpauinfo using DRI_PRIME=1 without needing to set up offloading with xrandr > > I do however need to specify the driver still, is

Re: [Mesa-dev] [PATCH 1/3] vl/dri3: handle the case of different GPU(v4.2)

2016-09-20 Thread Mike Lothian
Hi I've just confirmed this works for getting details from vainfo and vdpauinfo using DRI_PRIME=1 without needing to set up offloading with xrandr I do however need to specify the driver still, is that something being worked on? It would be great if it autoselected based on the card running at

[Mesa-dev] st/omx/dec/h265: Correct the timestamping (derived from commit 3b6bda665a5a890f2c98e19d2939d7de92b8cb4c)

2016-09-20 Thread Das, Indrajit-kumar
From: Indrajit Das Reviewed-by: Christian König Reviewed-by: Nishanth Peethambaran Signed-off-by: Indrajit Das --- src/gallium/state_trackers/omx/vid_dec_h265.c | 13

Re: [Mesa-dev] [PATCH 3/3] st/va: flush the context before calling flush_frontbuffer(v2)

2016-09-20 Thread Nayan Deshmukh
Thanks for the push Christian. Cheers, Nayan. On Tue, Sep 20, 2016 at 2:49 PM, Christian König wrote: > I've just pushed this version of the patchset. > > Thanks for the help, > Christian. > > > Am 20.09.2016 um 06:52 schrieb Nayan Deshmukh: > >> so that the texture is

Re: [Mesa-dev] [PATCH] st/va: Make VAAPI_DISABLE_INTERLACE default true

2016-09-20 Thread Julien Isorce
On 16 September 2016 at 08:43, Christian König wrote: > Am 15.09.2016 um 23:07 schrieb Julien Isorce: > > > > On 15 September 2016 at 16:02, Leo Liu wrote: > >> >> >> On 09/15/2016 10:43 AM, Andy Furniss wrote: >> >>> Since bf901a2 >>> st/va: also

Re: [Mesa-dev] [PATCH 1/3] st/va: Return more useful config attributes

2016-09-20 Thread Christian König
+if (profile == VAProfileHEVCMain10) + value = VA_RT_FORMAT_YUV420_10BPP; We actually don't support that yet. Main10 profiles dither down the 10bit output to 8bits before writing it to the VA-API surface at the moment. Apart from that the set looks good to me,

[Mesa-dev] [Bug 97863] [BXT] Webglc is failing a lot of tests related to extensions, textures, uniforms and more

2016-09-20 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=97863 --- Comment #3 from Alejandro Piñeiro (freenode IRC: apinheiro) --- (In reply to Elio from comment #2) > Forgot to include the website: > > www.khronos.org/registry/webgl/conformance-suites/1.0.3/webgl-conformance- >

Re: [Mesa-dev] [PATCH 3/3] st/va: flush the context before calling flush_frontbuffer(v2)

2016-09-20 Thread Christian König
I've just pushed this version of the patchset. Thanks for the help, Christian. Am 20.09.2016 um 06:52 schrieb Nayan Deshmukh: so that the texture is rendered to back buffer before calling flush_frontbuffer and can be copied to a different buffer in the function v2: change comment style

Re: [Mesa-dev] [PATCH v2] st/vdpau: fix argument type to vlVdpOutputSurfaceDMABuf

2016-09-20 Thread Christian König
Done. Christian. Am 20.09.2016 um 08:49 schrieb Nayan Deshmukh: It hasn't been committed yet. Ilia, Christian can someone push this. Regards, Nayan. On Thu, Sep 15, 2016 at 12:55 PM, Christian König > wrote: Am 15.09.2016 um

Re: [Mesa-dev] [PATCH v3 0/3] Make eglExportDMABUFImageMESA return corresponding offset.

2016-09-20 Thread Weng, Chuanbo
Hi Emil, What you mentioned about style issue in last round is: Please move the variable declaration in local scope and add space between ){ I think I have fixed these issue in this version. Maybe I have misunderstood your meaning. Do you expect the style like

Re: [Mesa-dev] [PATCH v2] st/vdpau: fix argument type to vlVdpOutputSurfaceDMABuf

2016-09-20 Thread Nayan Deshmukh
It hasn't been committed yet. Ilia, Christian can someone push this. Regards, Nayan. On Thu, Sep 15, 2016 at 12:55 PM, Christian König wrote: > Am 15.09.2016 um 01:16 schrieb Ilia Mirkin: > >> Signed-off-by: Ilia Mirkin >> > > Reviewed-by: