Re: [Mesa-dev] [PATCH] vulkan: simplify VK_USE_PLATFORM_*_KHR handling

2018-03-13 Thread Emil Velikov
On 9 March 2018 at 16:53, Eric Engestrom wrote: > On Friday, 2018-03-09 15:24:18 +, Emil Velikov wrote: >> From: Emil Velikov >> >> Instead of having multiple guards littered through the code, simply >> introduce static inline no-op

Re: [Mesa-dev] [PATCH 2/2] autotools: add -I/src/egl to tizonia

2018-03-13 Thread Emil Velikov
On 7 March 2018 at 23:13, Dylan Baker wrote: > meson got the same fix. > > cc: Emil Veliov > Signed-off-by: Dylan Baker > --- > > I don't know hat the "right" fix is here Emil, I just picked one and applied > it > to both

[Mesa-dev] [Bug 105436] Blinking textures in UT2004 [bisected]

2018-03-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=105436 Michel Dänzer changed: What|Removed |Added CC|

[Mesa-dev] [Bug 105436] Blinking textures in UT2004 [bisected]

2018-03-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=105436 almos changed: What|Removed |Added Assignee|dri-devel@lists.freedesktop

[Mesa-dev] [PATCH] spirv: Handle doubles when multiplying a mat by a scalar

2018-03-13 Thread Neil Roberts
The code to handle mat multipication by a scalar tries to pick either imul or fmul depending on whether the matrix is float or integer. However it was doing this by checking whether the base type is float. This was making it choose the int path for doubles (and presumably float16s). --- This was

Re: [Mesa-dev] [PATCH 2/2] anv/entrypoints: VkGetDeviceProcAddr returns NULL for core instance commands

2018-03-13 Thread Jason Ekstrand
On Tue, Mar 13, 2018 at 8:33 AM, Emil Velikov wrote: > On 13 March 2018 at 15:02, Jason Ekstrand wrote: > > On Tue, Mar 13, 2018 at 7:56 AM, Emil Velikov > > wrote: > >> > >> On 12 March 2018 at 08:40, Iago Toral Quiroga

Re: [Mesa-dev] [RFC] Mesa 17.3.x release problems and process improvements

2018-03-13 Thread Mark Janes
Daniel Vetter writes: > On Mon, Mar 12, 2018 at 11:54:45PM -0700, Kenneth Graunke wrote: >> On Friday, March 9, 2018 12:12:28 PM PDT Mark Janes wrote: >> [snip] >> > I've been doing this for Intel. Developers are on the hook to fix their >> > bugs, but you can't make them do

Re: [Mesa-dev] [Mesa-stable] [PATCH] [RFC] gallivm: Use new LLVM fast-math-flags API

2018-03-13 Thread Marek Olšák
Piglit+CTS+dEQP look good on Polaris12 with Mesa 17.3 and LLVM 6.0. Marek On Thu, Mar 8, 2018 at 6:22 AM, Emil Velikov wrote: > [Adding Andres, Juan since they'll be doing the next 17.3] > > On 7 March 2018 at 16:35, Marek Olšák wrote: >> I can test

Re: [Mesa-dev] [PATCH v4 1/2] gallium/winsys/kms: Fix possible leak in map/unmap.

2018-03-13 Thread Emil Velikov
On 13 March 2018 at 11:46, Tomasz Figa wrote: > On Thu, Mar 8, 2018 at 7:39 AM, Lepton Wu wrote: >> If user calls map twice for kms_sw_displaytarget, the first mapped >> buffer could get leaked. Instead of calling mmap every time, just >> reuse previous

Re: [Mesa-dev] [PATCH] fixup! i965: perf: reduce i965 binary size

2018-03-13 Thread Lionel Landwerlin
Thanks Emil, I'll include this in the next version :) On 13/03/18 15:17, Emil Velikov wrote: From: Emil Velikov Cc: Lionel Landwerlin --- src/mesa/drivers/dri/i965/Android.mk | 11 +---

Re: [Mesa-dev] [PATCH 2/2] anv/entrypoints: VkGetDeviceProcAddr returns NULL for core instance commands

2018-03-13 Thread Emil Velikov
On 13 March 2018 at 15:02, Jason Ekstrand wrote: > On Tue, Mar 13, 2018 at 7:56 AM, Emil Velikov > wrote: >> >> On 12 March 2018 at 08:40, Iago Toral Quiroga wrote: >> > af5f2322d0c64 addressed this for extension commands, but

Re: [Mesa-dev] [PATCH 2/2] i965: perf: reduce i965 binary size

2018-03-13 Thread Emil Velikov
On 13 March 2018 at 14:44, Lionel Landwerlin wrote: > Performance metric numbers are calculated the following way : > >- out of the 256 bytes long OA reports, we accumulate the deltas > into an array of uint64_t > >- the equations' generated code reads

[Mesa-dev] [PATCH] fixup! i965: perf: reduce i965 binary size

2018-03-13 Thread Emil Velikov
From: Emil Velikov Cc: Lionel Landwerlin --- src/mesa/drivers/dri/i965/Android.mk | 11 +--- src/mesa/drivers/dri/i965/Makefile.am | 24 -- src/mesa/drivers/dri/i965/Makefile.sources | 40

Re: [Mesa-dev] [PATCH 2/2] anv/entrypoints: VkGetDeviceProcAddr returns NULL for core instance commands

2018-03-13 Thread Jason Ekstrand
On Tue, Mar 13, 2018 at 7:56 AM, Emil Velikov wrote: > On 12 March 2018 at 08:40, Iago Toral Quiroga wrote: > > af5f2322d0c64 addressed this for extension commands, but the spec > mandates > > this behavior also for core API commands. From the Vulkan

Re: [Mesa-dev] [PATCH 2/2] anv/entrypoints: VkGetDeviceProcAddr returns NULL for core instance commands

2018-03-13 Thread Emil Velikov
On 12 March 2018 at 08:40, Iago Toral Quiroga wrote: > af5f2322d0c64 addressed this for extension commands, but the spec mandates > this behavior also for core API commands. From the Vulkan spec, > Table 2. vkGetDeviceProcAddr behavior: > > device pname

Re: [Mesa-dev] [PATCH] meson: don't use compiler.has_header

2018-03-13 Thread Eric Engestrom
On Monday, 2018-03-12 11:23:23 -0700, Dylan Baker wrote: > Meson's compiler.has_header is completely useless, it only checks that a > header exists, not whether it's usable. This creates problems if a > header contains a conditional #error declaration, like so: > > > #if __x86_64__ > > # error

[Mesa-dev] [PATCH 1/2] i965: perf: fix a counter return type on hsw

2018-03-13 Thread Lionel Landwerlin
The equation code computes a float (percentage) yet the return type was an uint64_t. Signed-off-by: Lionel Landwerlin --- src/mesa/drivers/dri/i965/brw_oa_hsw.xml | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[Mesa-dev] [PATCH 2/2] i965: perf: reduce i965 binary size

2018-03-13 Thread Lionel Landwerlin
Performance metric numbers are calculated the following way : - out of the 256 bytes long OA reports, we accumulate the deltas into an array of uint64_t - the equations' generated code reads the accumulated uint64_t deltas and normalizes them for a particular platforms Our

[Mesa-dev] [PATCH 0/2] i965: reduce driver binary size through metrics code reuse

2018-03-13 Thread Lionel Landwerlin
Hi all, While adding new metrics for newer generations I wondered how much code we could save by reusing the identical equation functions across metrics & generations. Turns out quite a bit, the saving in patch 2 is about 4Mb. We might be able to improve further by sharing similar register

Re: [Mesa-dev] [PATCH] [rfc] dri3: allow building against older xcb

2018-03-13 Thread Michel Dänzer
On 2018-03-12 08:05 PM, Dave Airlie wrote: > On 13 March 2018 at 03:59, Marek Olšák wrote: >> This is good, though some older distros only have libxcb 1.11. > > On those distros you likely just want to --disable-dri3 anyways. Why would you? DRI3 has been working fine with XCB

Re: [Mesa-dev] [PATCH v3 2/2] anv/entrypoints: VkGetDeviceProcAddr returns NULL for core instance commands

2018-03-13 Thread Jason Ekstrand
both are Reviewed-by: Jason Ekstrand On Tue, Mar 13, 2018 at 4:12 AM, Iago Toral Quiroga wrote: > af5f2322d0c64 addressed this for extension commands, but the spec mandates > this behavior also for core API commands. From the Vulkan spec, > Table 2.

Re: [Mesa-dev] [PATCH] [rfc] dri3: allow building against older xcb

2018-03-13 Thread Marek Olšák
On Mon, Mar 12, 2018 at 4:20 PM, Dave Airlie wrote: > On 13 March 2018 at 05:58, Marek Olšák wrote: >> On Mon, Mar 12, 2018 at 3:05 PM, Dave Airlie wrote: >>> On 13 March 2018 at 03:59, Marek Olšák wrote: This is

Re: [Mesa-dev] [PATCH 6/6] ac/nir: rename radeon_llvm_reg_index_soa() to ac_llvm_reg_index_soa()

2018-03-13 Thread Bas Nieuwenhuizen
Reviewed-by: Bas Nieuwenhuizen for the series. On Tue, Mar 13, 2018 at 3:06 PM, Samuel Pitoiset wrote: > Signed-off-by: Samuel Pitoiset > --- > src/amd/common/ac_nir_to_llvm.c | 6 +++--- >

[Mesa-dev] [PATCH 3/6] ac/nir: move ac_nir_compiler_options and friends to radv folder

2018-03-13 Thread Samuel Pitoiset
Also replace ac_ by radv_. Signed-off-by: Samuel Pitoiset --- src/amd/common/ac_nir_to_llvm.h | 72 -- src/amd/vulkan/radv_nir_to_llvm.c | 10 +++--- src/amd/vulkan/radv_pipeline.c| 6 ++-- src/amd/vulkan/radv_private.h |

[Mesa-dev] [PATCH 5/6] ac/nir: remove some unnecessary includes and declarations

2018-03-13 Thread Samuel Pitoiset
Signed-off-by: Samuel Pitoiset --- src/amd/common/ac_nir_to_llvm.c | 4 src/amd/common/ac_nir_to_llvm.h | 6 +- 2 files changed, 1 insertion(+), 9 deletions(-) diff --git a/src/amd/common/ac_nir_to_llvm.c b/src/amd/common/ac_nir_to_llvm.c index

[Mesa-dev] [PATCH 6/6] ac/nir: rename radeon_llvm_reg_index_soa() to ac_llvm_reg_index_soa()

2018-03-13 Thread Samuel Pitoiset
Signed-off-by: Samuel Pitoiset --- src/amd/common/ac_nir_to_llvm.c | 6 +++--- src/amd/common/ac_nir_to_llvm.h | 2 +- src/amd/vulkan/radv_nir_to_llvm.c | 16 3 files changed, 12 insertions(+), 12 deletions(-) diff --git

[Mesa-dev] [PATCH 2/6] ac: move ac_shader_info to radv folder

2018-03-13 Thread Samuel Pitoiset
This is RADV specific code. Signed-off-by: Samuel Pitoiset --- src/amd/Makefile.sources | 2 - src/amd/common/ac_nir_to_llvm.h| 1 - src/amd/common/ac_shader_info.h| 76 --

[Mesa-dev] [PATCH 4/6] ac/nir: drop radv prefix from radv_lower_gather4_integer()

2018-03-13 Thread Samuel Pitoiset
Signed-off-by: Samuel Pitoiset --- src/amd/common/ac_nir_to_llvm.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/src/amd/common/ac_nir_to_llvm.c b/src/amd/common/ac_nir_to_llvm.c index 3a9cb7b920..dff3bca713 100644 ---

[Mesa-dev] [PATCH 1/6] ac/nir: move ac_shader_variant_info and friends to radv folder

2018-03-13 Thread Samuel Pitoiset
Also replace ac_ by radv_. Signed-off-by: Samuel Pitoiset --- src/amd/common/ac_nir_to_llvm.h | 97 --- src/amd/vulkan/radv_cmd_buffer.c | 14 ++--- src/amd/vulkan/radv_nir_to_llvm.c| 29 ++-

Re: [Mesa-dev] [RFC] Mesa 17.3.x release problems and process improvements

2018-03-13 Thread Daniel Vetter
On Mon, Mar 12, 2018 at 11:54:45PM -0700, Kenneth Graunke wrote: > On Friday, March 9, 2018 12:12:28 PM PDT Mark Janes wrote: > [snip] > > I've been doing this for Intel. Developers are on the hook to fix their > > bugs, but you can't make them do it. They have many pressures on them, > > and a

Re: [Mesa-dev] [PATCH 1/2] nir: add nir_opt_move_load_ubo() optimization pass

2018-03-13 Thread Samuel Pitoiset
On 03/12/2018 05:21 PM, Marek Olšák wrote: On Mon, Mar 12, 2018 at 6:18 AM, Samuel Pitoiset wrote: On 03/11/2018 04:41 PM, Marek Olšák wrote: On Thu, Mar 8, 2018 at 5:48 PM, Ian Romanick wrote: On 03/08/2018 06:50 AM, Samuel Pitoiset

Re: [Mesa-dev] [PATCH v4 1/2] anv/cmd_buffer: consider multiview masks for tracking pending clear aspects

2018-03-13 Thread Iago Toral
Hi Jason, can you have a look at these two? We have some tests failing because of this. Iago On Wed, 2018-03-07 at 10:33 +0100, Iago Toral wrote: > This patches are still waiting for review. > > On Wed, 2018-02-28 at 09:57 +0100, Iago Toral Quiroga wrote: > > When multiview is active a subpass

[Mesa-dev] [PATCH v3 2/2] spirv: fix OpUConvert when the source is signed

2018-03-13 Thread Samuel Iglesias Gonsálvez
From: Iago Toral Quiroga In this case we don't want to do sign-extension, since the value is interpreted as unsigned. If we want sign-extension, OpSConvert should be used. v2: - Use src/dst bitsize to get the proper conversion opcode. (Jason) --- src/compiler/spirv/vtn_alu.c

[Mesa-dev] [PATCH v3 1/2] spirv: fix OpSConvert when the source is unsigned

2018-03-13 Thread Samuel Iglesias Gonsálvez
OpSConvert interprets the MSB of the unsigned value as the sign bit and extends it to the new type. If we want to preserve the value, we need to use OpUConvert opcode. v2: - No need to check dst type. - Fix typo in comment. v3: - Use src/dst bitsize to get the proper conversion opcode. (Jason)

Re: [Mesa-dev] [PATCH 2/2] vulkan/wsi/x11: correct DRI3 version in comment

2018-03-13 Thread Daniel Stone
Hi Emil, On 13 March 2018 at 11:40, Emil Velikov wrote: > During development the version was bumped, yet the comment did not get > an update. > > Cc: Daniel Stone > Fixes: c80c08e2260 ("vulkan/wsi/x11: Add support for DRI3 v1.2") > Signed-off-by:

Re: [Mesa-dev] [PATCH v4 1/2] gallium/winsys/kms: Fix possible leak in map/unmap.

2018-03-13 Thread Tomasz Figa
On Thu, Mar 8, 2018 at 7:39 AM, Lepton Wu wrote: > If user calls map twice for kms_sw_displaytarget, the first mapped > buffer could get leaked. Instead of calling mmap every time, just > reuse previous mapping. Since user could map same displaytarget with > different flags,

[Mesa-dev] [PATCH 1/2] vulkan/wsi/x11: use ARRAY_SIZE where applicable

2018-03-13 Thread Emil Velikov
From: Emil Velikov Use the handy macro instead of hard coded numbers. Cc: Daniel Stone Fixes: c80c08e2260 ("vulkan/wsi/x11: Add support for DRI3 v1.2") Signed-off-by: Emil Velikov ---

[Mesa-dev] [PATCH 2/2] vulkan/wsi/x11: correct DRI3 version in comment

2018-03-13 Thread Emil Velikov
From: Emil Velikov During development the version was bumped, yet the comment did not get an update. Cc: Daniel Stone Fixes: c80c08e2260 ("vulkan/wsi/x11: Add support for DRI3 v1.2") Signed-off-by: Emil Velikov ---

Re: [Mesa-dev] [PATCH v4 1/2] gallium/winsys/kms: Fix possible leak in map/unmap.

2018-03-13 Thread Tomasz Figa
On Tue, Mar 13, 2018 at 3:10 AM, Emil Velikov wrote: > On 12 March 2018 at 17:45, Lepton Wu wrote: >> Ping. Any more comments or missing stuff to get this commited into master? >> > As things have changed a bit (the original map/unmap behaviour is

Re: [Mesa-dev] [PATCH 1/2] anv/entrypoints: dispatches to VkQueue are device-level

2018-03-13 Thread Iago Toral
I was surprised that missing that didn't cause any trouble. It seems that the way the trampoline code was setup would still generate trampoline functions, but interpreting the dispatch object as a command buffer, and both anv_queue and anv_cmd_buffer have their device pointer field at exactly the

[Mesa-dev] [PATCH v3 2/2] anv/entrypoints: VkGetDeviceProcAddr returns NULL for core instance commands

2018-03-13 Thread Iago Toral Quiroga
af5f2322d0c64 addressed this for extension commands, but the spec mandates this behavior also for core API commands. From the Vulkan spec, Table 2. vkGetDeviceProcAddr behavior: device pnamereturn -- (..)

[Mesa-dev] [PATCH v3 1/2] anv/entrypoints: dispatches to VkQueue are device-level

2018-03-13 Thread Iago Toral Quiroga
v2: - Add trampoline functions (Jason) - Add an assertion for unhandled trampoline cases --- src/intel/vulkan/anv_entrypoints_gen.py | 9 +++-- 1 file changed, 7 insertions(+), 2 deletions(-) diff --git a/src/intel/vulkan/anv_entrypoints_gen.py b/src/intel/vulkan/anv_entrypoints_gen.py

[Mesa-dev] [Bug 105425] 3D & games produce periodic GPU crashes (Radeon R7 370)

2018-03-13 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=105425 Michel Dänzer changed: What|Removed |Added Component|Mesa core

Re: [Mesa-dev] [PATCH v2 1/2] spirv: fix OpSConvert when the source is unsigned

2018-03-13 Thread Samuel Iglesias Gonsálvez
On 12/03/18 20:42, Jason Ekstrand wrote: > On Mon, Mar 5, 2018 at 10:21 PM, Samuel Iglesias Gonsálvez > > wrote: > > OpSConvert interprets the MSB of the unsigned value as the sign > bit and > extends it to the new type. If we want

Re: [Mesa-dev] [PATCH 1/3] wayland-drm: Expose server-side xbgr2101010 and abgr2101010 formats.

2018-03-13 Thread Daniel Stone
Hi Mario, On 12 March 2018 at 20:45, Mario Kleiner wrote: > This way the wayland server can signal support for these formats > to wayland EGL clients. This is currently used by nouveau for 10 > bpc support. > > Tested with glmark2-wayland and glmark2-es2-wayland under

Re: [Mesa-dev] soft fp64 support - main body (glsl/gallium)

2018-03-13 Thread Elie Tournier
On Tue, Mar 13, 2018 at 02:28:04PM +1000, Dave Airlie wrote: > On 13 March 2018 at 14:24, Dave Airlie wrote: > > This is the main code for the soft fp64 work. It's mostly Elie's > > code with a bunch of changes by me. > > > > All the patches are in my tree here, along with

Re: [Mesa-dev] [RFC] Mesa 17.3.x release problems and process improvements

2018-03-13 Thread Mark Janes
Kenneth Graunke writes: > On Friday, March 9, 2018 12:12:28 PM PDT Mark Janes wrote: > [snip] >> I've been doing this for Intel. Developers are on the hook to fix their >> bugs, but you can't make them do it. They have many pressures on them, >> and a maintainer can't

Re: [Mesa-dev] [RFC] Mesa 17.3.x release problems and process improvements

2018-03-13 Thread Kenneth Graunke
On Friday, March 9, 2018 12:12:28 PM PDT Mark Janes wrote: [snip] > I've been doing this for Intel. Developers are on the hook to fix their > bugs, but you can't make them do it. They have many pressures on them, > and a maintainer can't make the call as to whether a rendering bug is > more

Re: [Mesa-dev] [PATCH 2/2] anv/entrypoints: VkGetDeviceProcAddr returns NULL for core instance commands

2018-03-13 Thread Iago Toral
On Mon, 2018-03-12 at 07:37 -0700, Jason Ekstrand wrote: > On Mon, Mar 12, 2018 at 1:40 AM, Iago Toral Quiroga m> wrote: > > af5f2322d0c64 addressed this for extension commands, but the spec > > mandates > > > > this behavior also for core API commands. From the Vulkan spec, >

<    1   2