Re: cmac

2018-02-19 Thread Niels Möller
Nikos Mavrogiannopoulos writes: > While using that code, I realized that the CMAC128_UPDATE was misusing > the 'data' field. In the attached patch I've renamed it to 'src' to > avoid ambiguities. Pushed to a branch "cmac-support", together with ChangeLog and some cleanups:

Re: TMP_DECL_ALIGN

2018-02-19 Thread Niels Möller
Nikos Mavrogiannopoulos writes: > On Mon, 2018-02-19 at 15:27 +0100, Niels Möller wrote: >> I think I'd prefer allocating a uint64_t array (largest type used in >> nettle context structs), and leave to the compiler to figure out what >> alignment is needed and how to get it. > >

Re: TMP_DECL_ALIGN

2018-02-19 Thread Nikos Mavrogiannopoulos
On Mon, 2018-02-19 at 15:27 +0100, Niels Möller wrote: > Nikos Mavrogiannopoulos writes: > > > #define ALIGN16(x) \ > > ((void > > *)(((ptrdiff_t)(x)+(ptrdiff_t)0x0f)&~((ptrdiff_t)0x0f))) > > I think I'd prefer allocating a uint64_t array (largest type used in > nettle

Re: TMP_DECL_ALIGN

2018-02-19 Thread Niels Möller
Nikos Mavrogiannopoulos writes: > #define ALIGN16(x) \ > ((void *)(((ptrdiff_t)(x)+(ptrdiff_t)0x0f)&~((ptrdiff_t)0x0f))) I think I'd prefer allocating a uint64_t array (largest type used in nettle context structs), and leave to the compiler to figure out what alignment

Re: TMP_DECL_ALIGN (was: Re: [PATCH v2 1/2] Implement PSS encoding functions)

2018-02-19 Thread Nikos Mavrogiannopoulos
On Sun, 2018-02-18 at 22:30 +0100, Niels Möller wrote: > ni...@lysator.liu.se (Niels Möller) writes: > > > For now, I think I'll fix this, and add a TMP_ALIGN_DECL, > > TMP_ALIGN_ALLOC. > > Below patch seems to work. Other options? > > Regards, > /Niels > > diff --git a/nettle-internal.h

Re: [PATCH v2 1/2] Implement PSS encoding functions

2018-02-19 Thread Nikos Mavrogiannopoulos
On Sat, 2018-02-17 at 23:55 +0100, Niels Möller wrote: > ni...@lysator.liu.se (Niels Möller) writes: > > > Daiki Ueno writes: > > > > > I have incorporated the suggested changes here: > > > https://gitlab.com/dueno/nettle/commits/wip/dueno/rsa-padding > > > > Thanks! > > > >