Re: [NTG-context] ZapfDingbats Unicode differences MKIV vs LMTX

2020-09-21 Thread Christoph Reller
On Mon, Sep 21, 2020 at 3:27 PM Hans Hagen wrote: > On 9/21/2020 2:55 PM, Christoph Reller wrote: > > > \definefontsynonym[ZapfDingbats][file:ZapfDingbats][features=dingbats] > > I don't know what the previous line does ... but it works ok here when > you remove it. Thi

Re: [NTG-context] ZapfDingbats Unicode differences MKIV vs LMTX

2020-09-21 Thread Christoph Reller
On Sat, Sep 19, 2020 at 12:04 PM Hans Hagen wrote: > On 9/19/2020 6:18 AM, Christoph Reller wrote: > > On Fri, Sep 18, 2020 at 4:17 PM Hans Hagen > <mailto:j.ha...@xs4all.nl>> wrote: > > > > On 9/18/2020 11:23 AM, Christoph Reller wrote: >

Re: [NTG-context] ZapfDingbats Unicode differences MKIV vs LMTX

2020-09-18 Thread Christoph Reller
On Fri, Sep 18, 2020 at 4:17 PM Hans Hagen wrote: > On 9/18/2020 11:23 AM, Christoph Reller wrote: > > Dear List, > > > > I have the following MWE: > > > > \definefontsynonym[ZapfDingbats][file:ZapfDingbats][features=dingbats] > > \usemodule [fnt-10]

[NTG-context] ZapfDingbats Unicode differences MKIV vs LMTX

2020-09-18 Thread Christoph Reller
Dear List, I have the following MWE: \definefontsynonym[ZapfDingbats][file:ZapfDingbats][features=dingbats] \usemodule [fnt-10] \starttext (1) \getglyphdirect{ZapfDingbats}{61491}\crlf % MKIV log: char  (U+0F033) in font 'ZapfDingbats-4' with id 8: missing (2)

Re: [NTG-context] Access violation

2020-09-10 Thread Christoph Reller
On Thu, Sep 10, 2020 at 8:43 PM Hans Hagen wrote: > On 9/9/2020 2:44 PM, Christoph Reller wrote: > > Does this help or do you really need a MWE? > A wme would help indeed (no need to be real minimal, as you need enough > to trigger bumping node mem so just make somethign tha

[NTG-context] Access violation

2020-09-09 Thread Christoph Reller
Dear developers, I am using ConTeXt LMTX version 2020.09.05 21:18 on Windows 46bit. I have a large project for which I can reproduce an access violation: mtx-context | fatal error: return code: -1073741819 Unfortunately, the error vanishes as soon as I alter any detail in the project's

[NTG-context] Input file name containing full stop "."

2020-09-09 Thread Christoph Reller
Dear list, I am using ConTeXt LMTX Version 2020.09.05 21:18 with an input file named, e.g., "test.test.tex". When compiling, ConTeXt generates files "test.log", "test.tua", "test.pdf". ConTeXt MKIV used to produce files "test.test.log", "test.test.tua", "test.test.pdf". Is there a way for

Re: [NTG-context] MKIV - LMTX difference: stripping of leading white space in verbatim text

2020-09-03 Thread Christoph Reller
On Thu, Sep 3, 2020 at 5:53 AM Wolfgang Schuster < wolfgang.schuster.li...@gmail.com> wrote: > Christoph Reller schrieb am 03.09.2020 um 05:29: > > Dear List, > > > > I am using ConTeXt LMTX 2018.05.19 21:46. Consider the following MWE: > > > > \st

[NTG-context] MKIV - LMTX difference: stripping of leading white space in verbatim text

2020-09-02 Thread Christoph Reller
Dear List, I am using ConTeXt LMTX 2018.05.19 21:46. Consider the following MWE: \starttext \startLUA whatever \stopLUA \stoptext In contrast to ConTeXt MKIV, the leading four spaces in front of "whatever" are not removed when processing the verbatim text: MKIV output: whatever LMTX

Re: [NTG-context] PNG image inclusion resolution

2020-09-02 Thread Christoph Reller
On Wed, Sep 2, 2020 at 4:36 PM Hans Hagen wrote: > On 9/2/2020 3:35 PM, Christoph Reller wrote: > > Dear List, > > > > I am using ConTeXt LMTX 2020.08.31 22:16. Consider the following MWE: > > > >\starttext > >\externalfigure[resolutionTest.png]

[NTG-context] PNG image inclusion resolution

2020-09-02 Thread Christoph Reller
Dear List, I am using ConTeXt LMTX 2020.08.31 22:16. Consider the following MWE: \starttext \externalfigure[resolutionTest.png] \stoptext When comparing the output with ConTeXt MKIV, then the image size is extremely small. gimp reports the resolution of resolutionTest.png as 71.984 DPI.

Re: [NTG-context] Verbatim typing and compound breakpoints

2020-09-01 Thread Christoph Reller
On Tue, Sep 1, 2020 at 10:50 AM Christoph Reller wrote: > I am using ConTeXt LMTX 2020.08.28 13:58 with the following M(N)WE: > > \definetype[typeLUA][option=LUA] > \setbreakpoints[compound] > \starttext > \typeLUA{function(argument)} > \stoptext > > Sadly, it d

[NTG-context] Verbatim typing and compound breakpoints

2020-09-01 Thread Christoph Reller
Dear List, I am using ConTeXt LMTX 2020.08.28 13:58 with the following M(N)WE: \definetype[typeLUA][option=LUA] \setbreakpoints[compound] \starttext \typeLUA{function(argument)} \stoptext Sadly, it does not compile. The problem seems to be the simultaneous use of compound breakpoints and

Re: [NTG-context] follow up

2019-04-02 Thread Christoph Reller
My two cents: I don't believe that it is the CIDSet. Both fun.pdf and fun1.pdf have no CIDSet (which is good). The (relevant) differences between the two PDFs are: - Different ToUnicode - Different embedded font stream - Minor differences in the font descriptor It could be the ToUnicode: If

[NTG-context] \reference not working with reference prefix and focus=standard

2018-06-25 Thread Christoph Reller
Hi, Thank you, Hans, for supporting the focus=standard option in interactive PDFs. I stumbled over the following problem: \setupinteraction[state=start, focus=standard] \starttext \pushreferenceprefix{parent} \reference[label]{Text}Bla \page \about[label] \popreferenceprefix \stoptext The

Re: [NTG-context] Using goto in lua

2018-06-22 Thread Christoph Reller
On Fri, 22 Jun 2018 13:57:05 +0200 Wolfgang Schuster wrote: > > Hans gave a solution to this a while ago: > https://mailman.ntg.nl/pipermail/ntg-context/2018/090833.html > > Wolfgang Thank you Wolfgang for pointing me to this solution! Cheers, Christoph

[NTG-context] Using goto in lua

2018-06-22 Thread Christoph Reller
Hi, As mentioned in cld-mkiv.pdf, the entire ConTeXt interface can be called from lua: This is great! Unfortunately the ConTeXt command \goto is a little problematic because goto is a lua keyword. Therefore, the following leads to a lua error: context.goto("text", { "label" }) I guess the

Re: [NTG-context] Defining command with optional and mandatory arguments

2018-05-24 Thread Christoph Reller
On Thu, 24 May 2018 14:50:36 +0200, Hans Hagen <j.ha...@xs4all.nl> wrote: > On 5/24/2018 11:21 AM, Christoph Reller wrote: >> On Wed, 23 May 2018 16:01:05 +0200, Hans Hagen <j.ha...@xs4all.nl> wrote: >>> On 5/23/2018 3:39 PM, Christoph Reller wrote: >>>

Re: [NTG-context] Defining command with optional and mandatory arguments

2018-05-24 Thread Christoph Reller
Defining command with optional and > mandatory arguments > Message-ID: <a21d40d2-e607-47a4-bab0-c437dc915...@fiee.net> > Content-Type: text/plain; charset=windows-1252 > > Am 2018-05-23 um 16:01 schrieb Hans Hagen <j.ha...@xs4all.nl>: > >> On 5/23/2018 3:39 PM, C

[NTG-context] Defining command with optional and mandatory arguments

2018-05-24 Thread Christoph Reller
On Wed, 23 May 2018 16:01:05 +0200, Hans Hagen <j.ha...@xs4all.nl> wrote: > > On 5/23/2018 3:39 PM, Christoph Reller wrote: >> Hi, >> >> What is the right way to define a command with both mandatory and >> optional arguments, e.g: >> >> \MyCommand[o

[NTG-context] Defining command with optional and mandatory arguments

2018-05-23 Thread Christoph Reller
Hi, What is the right way to define a command with both mandatory and optional arguments, e.g: \MyCommand[optional][mandatory] Consider the following MWE: \unexpanded\def\MyCommand[#1]{ \dosingleempty{\doMyCommand[#1]}} \def\doMyCommand[#1][#2]{ \doifsomething{#1}{number 1: #1\par}

Re: [NTG-context] roadmap

2018-05-18 Thread Christoph Reller
On Tue, 15 May 2018 16:51:13 +0200 luigi scarso <luigi.sca...@gmail.com> wrote: > > On Tue, May 15, 2018 at 4:46 PM, Christoph Reller < > christoph.rel...@gmail.com> wrote: > > > On Tue, 15 May 2018 08:23:04 +0200 luigi scarso <luigi.sca...@gmail.com> > >

Re: [NTG-context] roadmap

2018-05-15 Thread Christoph Reller
On Tue, 15 May 2018 08:23:04 +0200 luigi scarso <luigi.sca...@gmail.com> wrote: > > On Tue, May 15, 2018 at 8:15 AM, Christoph Reller < > christoph.rel...@gmail.com> wrote: > > > > > Our company is producing (and weekly updating) 67 manuals and > > tech

Re: [NTG-context] roadmap

2018-05-15 Thread Christoph Reller
On Tue, May 15, 2018 at 12:53 AM, wrote: > > > Message: 3 > Date: Mon, 14 May 2018 23:26:28 +0200 > From: Hans Hagen > To: Henning Hraban Ramm , mailing list for ConTeXt > users > Subject: Re:

Re: [NTG-context] links don’t work with focus=standard

2018-04-16 Thread Christoph Reller
On Sun, 15 Apr 2018 18:45:40 +0200 , Pablo Rodriguez wrote: > > > I’m afraid that links with "focus=standard" are broken after beta from > 2018.04.13 14:53. > > In version 2018.04.15 23:11 everything seems to work fine. > > I think that all links that worked fine before the latest

[NTG-context] Reference links with focus=standard

2018-04-13 Thread Christoph Reller
On Fri, 13 Apr 2018 10:45:39 +0100, Lawrence Bell <lawrence.matthew.b...@gmail.com> wrote: > On 13/04/18 07:31, Henri Menke wrote: >> >> On Fri, 2018-04-13 at 08:13 +0200, Christoph Reller wrote: >>> >>> Please, Hans, I kindly ask you to reconsider. I am

Re: [NTG-context] Reference links with focus=standard option

2018-04-13 Thread Christoph Reller
Fri, 13 Apr 2018 11:48:28 +0200, Hans Hagen <j.ha...@xs4all.nl> wrote: > On 4/13/2018 8:13 AM, Christoph Reller wrote: >> >> This is a long standing feature request reported multiple times by >> myself and others with MWEs in >> https://www.mail-archive.com

Re: [NTG-context] Reference links with focus=standard option

2018-04-13 Thread Christoph Reller
> On Wed, 11 Apr 2018 20:27:15 +0100, Lawrence Bell > wrote: > > Thanks very much for your replies. It's reassuring to see (it seems) > that I've not overlooked some extra option that magically does the job > :) Worst case scenario I'll hack something together,

Re: [NTG-context] option for printing range

2018-02-27 Thread Christoph Reller
On Tue, Feb 27, 2018 at 10:05 PM, Hans Hagen <pra...@wxs.nl> wrote: > On 2/27/2018 7:47 PM, Christoph Reller wrote: > > anyway, i normally test pdf with an old acrobat X pro (i don't want to lock > into some subscription and i don't really need a more modern version) and i >

Re: [NTG-context] option for printing range

2018-02-27 Thread Christoph Reller
On Tue, 27 Feb 2018 09:15:37 +0100 Hans Hagen wrote: > On 2/26/2018 8:02 PM, Pablo Rodriguez wrote: >> On 02/25/2018 10:51 PM, Hans Hagen wrote: >>> On 2/25/2018 9:12 PM, Pablo Rodriguez wrote: [...] The print range for Acrobat is "3,6,9-11" when it should be "2,5,8-10"

Re: [NTG-context] type and typing comments for TeX and Lua

2017-12-27 Thread Christoph Reller
On Wed, 27 Dec 2017 19:53:58 +0100, Pablo Rodriguez wrote: > could you enable issues in your Bitbucket repository? Issues are enabled now. Cheers, Christoph ___ If your question is of interest to others

Re: [NTG-context] type and typing comments for TeX and Lua

2017-12-21 Thread Christoph Reller
On Thu, 21 Dec 2017 21:16:45 +0100, Pablo Rodriguez <oi...@gmx.es> wrote: > On 12/21/2017 05:04 PM, Christoph Reller wrote: >> Dear Pablo, >> >> At least for XML you could use my module highlight-xml: >> >> \usemodule[highlight-xml] >> \definetyp

Re: [NTG-context] type and typing comments for TeX and Lua

2017-12-21 Thread Christoph Reller
On Tue, Mon, 18 Dec 2017 23:50:09 +0100, Pablo Rodriguez wrote: > I have the following sample: > > \definetype[context][option=tex] > \definetype[lua][option=lua] > \starttext > \startTEXpage[offset=2em] > > a \TEX\ inline comment: \context{ag%befe} > > \Lua\

Re: [NTG-context] TikZ modules are missing \startmodule

2017-12-11 Thread Christoph Reller
Hi Christian, Thank you for your support. I think you should insert a line \startmodule[] after \unprotect in the following files \tex\texmf-modules\tex\context\pgf\basiclayer\t-pgf.tex \tex\texmf-modules\tex\context\pgf\basiclayer\t-pgfbim.tex

Re: [NTG-context] TikZ modules are missing \startmodule

2017-12-08 Thread Christoph Reller
On Fri, Dec 8, 2017 at 9:04 AM, Mojca Miklavec <mojca.miklavec.li...@gmail.com> wrote: > Dear Christoph, > > On 8 December 2017 at 08:38, Christoph Reller wrote: >> Hi, >> >> Since a module nesting check has been introduced in file-mod.mkvi, the TikZ >>

[NTG-context] TikZ modules are missing \startmodule

2017-12-07 Thread Christoph Reller
Hi, Since a module nesting check has been introduced in file-mod.mkvi, the TikZ modules provoke "module wrapping error" messages in the log file. May I kindly ask the maintainer of the TikZ modules to insert the missing \startmodule command in the following files:

Re: [NTG-context] \startitemize[columns] and footnote

2017-12-05 Thread Christoph Reller
On Fri, 1 Dec 2017 12:49:33 +0100 luigi scarso <luigi.sca...@gmail.com> wrote: > On Fri, Dec 1, 2017 at 10:14 AM, Christoph Reller > <christoph.rel...@gmail.com> wrote: > > \starttext > > Text \footnote{Bla} > > \startitemize[columns] > >

[NTG-context] \startitemize[columns] and footnote

2017-12-01 Thread Christoph Reller
Hi, Consider the following MWE: \starttext Text \footnote{Bla} \startitemize[columns] \item Item \stopitemize \stoptext In the rendered output, the footnote is drawn on top of the item (see attached output.png). I am afraid this looks like a bug. Please consider fixing this or tell me how to

[NTG-context] Tagging nested itemize with interaction

2017-10-31 Thread Christoph Reller
Dear Hans, Consider the following MWE with nested multi-column itemize and item label: \setuptagging[state=start] \setupinteraction[state=start] \starttext \startitemize[n] \item[label] First \startitemize[a, columns] \item Second \item Third \stopitemize \stopitemize\crlf Bla

Re: [NTG-context] ntg-context Digest, Vol 160, Issue 40

2017-10-24 Thread Christoph Reller
On Tue, 24 Oct 2017 18:31:24 +0200 Pablo Rodriguez <oi...@gmx.es> wrote: > > On 10/24/2017 07:05 AM, Christoph Reller wrote: > > [...] > > Thank you Pablo for confirming this! > > > > Does anybody know whether this is a bug or whether it is the wrong

Re: [NTG-context] Quotation with method=font produces error

2017-10-23 Thread Christoph Reller
Mon, 23 Oct 2017 17:21:25 +0200, Pablo Rodriguez <oi...@gmx.es> wrote: > On 10/23/2017 09:03 AM, Christoph Reller wrote: >> [...] >> Could you please confirm (or deny) that the following MWE produces an >> error with the currently latest version of ConTeXt: >&g

Re: [NTG-context] Quotation with method=font produces error

2017-10-23 Thread Christoph Reller
On Thu, Oct 19, 2017 at 1:59 PM Christoph Reller <christoph.rel...@gmail.com> wrote: > On Thu, 19 Oct 2017 11:53:56 +0200 Floris van Manen <v...@klankschap.nl > > wrote: > >> >> > On 19 Oct 2017, at 11:33, Christoph Reller <christoph.rel...@gmail.com>

Re: [NTG-context] Caption location in floatcombination

2017-10-23 Thread Christoph Reller
On Tue, Oct 17, 2017 at 11:00 AM Christoph Reller < christoph.rel...@gmail.com> wrote: > On Mon, Sep 18, 2017 at 7:19 AM Christoph Reller < > christoph.rel...@gmail.com> wrote: > >> On Sun, Sep 17, 2017 at 6:03 PM Hans Hagen <pra...@wxs.nl> wrote: >> >

Re: [NTG-context] Quotation with method=font produces error

2017-10-19 Thread Christoph Reller
On Thu, 19 Oct 2017 11:53:56 +0200 Floris van Manen <v...@klankschap.nl > wrote: > > > On 19 Oct 2017, at 11:33, Christoph Reller <christoph.rel...@gmail.com> > wrote: > > > > \setupquotation[method=font] > > what is the intension of the method=f

Re: [NTG-context] ntg-context Digest, Vol 160, Issue 26

2017-10-19 Thread Christoph Reller
On Tue, 17 Oct 2017 13:38:37 + Christoph Reller < christoph.rel...@gmail.com> wrote: > > In previous versions of ConTeXt the following MWE worked: > > \setupquotation[method=font] > \starttext > \quotation{A} > \stoptext > > In more recent versions, the abo

[NTG-context] Quotation with method=font produces error

2017-10-17 Thread Christoph Reller
Hi, In previous versions of ConTeXt the following MWE worked: \setupquotation[method=font] \starttext \quotation{A} \stoptext In more recent versions, the above produces an error: ! Extra }, or forgotten \endgroup l.3 \quotation{A} Is this a bug? Regards, Christoph

Re: [NTG-context] Caption location in floatcombination

2017-10-17 Thread Christoph Reller
On Mon, Sep 18, 2017 at 7:19 AM Christoph Reller <christoph.rel...@gmail.com> wrote: > On Sun, Sep 17, 2017 at 6:03 PM Hans Hagen <pra...@wxs.nl> wrote: > >> On 9/13/2017 8:30 AM, Christoph Reller wrote: >> > It seems to me that the location given to \setupcapti

Re: [NTG-context] Module Update from GIT URL Fails

2017-09-28 Thread Christoph Reller
On Wed, 27 Sep 2017 11:55:06 +0200 Taco Hoekwater wrote: > > Alright, I think I have this figured out now. You *have to* use the https > protocol, but then it should work. > >https://bitbucket.org/philexander/context-highlight.git > > You cannot use any git protocol

Re: [NTG-context] Module Update from GIT URL Fails

2017-09-26 Thread Christoph Reller
On Mon, 25 Sep 2017 10:57:48 +0200 Taco Hoekwater wrote: > > I don't seem to be able to update my ConTeXt module "high". I try to > create a new version by entering the URL of my git repository > (g...@bitbucket.org:philexander/context-highlight.git) into the GIT URL > field

[NTG-context] Module Update from GIT URL Fails

2017-09-22 Thread Christoph Reller
Dear Taco, Moica has told me that you are the maintainer of modules.contextgarden.net. Is this correct? I don't seem to be able to update my ConTeXt module "high". I try to create a new version by entering the URL of my git repository (g...@bitbucket.org:philexander/context-highlight.git) into

Re: [NTG-context] Caption location in floatcombination

2017-09-17 Thread Christoph Reller
On Sun, Sep 17, 2017 at 6:03 PM Hans Hagen <pra...@wxs.nl> wrote: > On 9/13/2017 8:30 AM, Christoph Reller wrote: > > Hi, > > > > It seems to me that the location given to \setupcaptions is not honored > > correctly in floatcombinations anymore. Consider the foll

Re: [NTG-context] Who is maintaining the modules website?

2017-09-14 Thread Christoph Reller
On Thu, 14 Sep 2017 11:50:03 +0200 Mojca Miklavec < mojca.miklavec.li...@gmail.com> wrote: > On 13 September 2017 at 15:06, Christoph Reller wrote: > > I tried to send an email to modu...@contextgarden.net and got the below > > reply. On https://modules.contextgarden.net/

[NTG-context] Who is maintaining the modules website?

2017-09-13 Thread Christoph Reller
Hi, I am unsure whether this mailing list is the correct one to ask this question. So please excuse the noise. I tried to send an email to modu...@contextgarden.net and got the below reply. On https://modules.contextgarden.net/help.html, this email address is mentioned as the primary contact

[NTG-context] Caption location in floatcombination

2017-09-13 Thread Christoph Reller
Hi, It seems to me that the location given to \setupcaptions is not honored correctly in floatcombinations anymore. Consider the following MWE: \setupcaptions[location=top, number=no] \starttext \placetable[][]{One}{ \bTABLE \bTR \bTD First \eTD \eTR \eTABLE} \placefloat[][]{}{

Re: [NTG-context] Hyphenation with dashes in natural table

2017-09-13 Thread Christoph Reller
Dear Pablo, Rik, and Thomas Thank you so much for your quick help! This gives me much more insight into the matter. And you provide various solutions with their pros and cons. For the moment I will stick to Thomas' suggestion \setupbreakpoints[compound] because I don't want to change the source

[NTG-context] Hyphenation with dashes in natural table

2017-09-11 Thread Christoph Reller
Hi, It seems that the hyphenation algorithm for long words with dashes when typeset in a natural table has changed. MWE: \starttext \bTABLE[width=5cm] \bTR \bTD super-cali-fragi-listic-expi-ali-docious \eTD \bTD The longest word known to me that ever had an appearance in a musical. \eTD \eTR

Re: [NTG-context] Tagging and Math Matrix

2017-09-06 Thread Christoph Reller
On Wed, 6 Sep 2017 11:25:51 +0200 Hans Hagen <pra...@wxs.nl> wrote: > On 9/6/2017 9:55 AM, Christoph Reller wrote: > > On Tue, 5 Sep 2017 16:29:52 +0200 Hans Hagen <pra...@wxs.nl > > <mailto:pra...@wxs.nl>> wrote: > > > > On 8/30/2017 9:45 AM, C

Re: [NTG-context] Tagging and Math Matrix

2017-09-06 Thread Christoph Reller
On Tue, 5 Sep 2017 16:29:52 +0200 Hans Hagen <pra...@wxs.nl> wrote: > On 8/30/2017 9:45 AM, Christoph Reller wrote: > > On Mon, Dec 28, 2015 at 3:45 PM Christoph Reller > > <christoph.rel...@gmail.com <mailto:christoph.rel...@gmail.com > >> wrote:

Re: [NTG-context] Error with tagging and lohi alignment in table

2017-08-30 Thread Christoph Reller
On Wed, 30 Aug 2017 10:35:56 +0200 Hans Hagen <pra...@wxs.nl> wrote: > On 8/30/2017 9:22 AM, Christoph Reller wrote: > > The following MWE now yields an error: > > > > \setuptagging[state=start] > > \starttext > > \bTABLE > > \setupTABLE[c][1

Re: [NTG-context] Tagging and Math Matrix

2017-08-30 Thread Christoph Reller
On Mon, Dec 28, 2015 at 3:45 PM Christoph Reller <christoph.rel...@gmail.com > wrote: > There seems to be a problem with the structure information added when using > \startmatrix: > > \setuptagging[state=start] > \starttext > \math{ > \startmatrix >

[NTG-context] Error with tagging and lohi alignment in table

2017-08-30 Thread Christoph Reller
Hi, The following MWE now yields an error: \setuptagging[state=start] \starttext \bTABLE \setupTABLE[c][1][align=lohi] \bTR \bTD test \eTD \eTR \eTABLE \stoptext I'm afraid but this may be a bug. Many thanks in advance for all your effort. Cheers, Christoph

Re: [NTG-context] Scite module and escape does not work anymore

2017-08-30 Thread Christoph Reller
On Tue, 29 Aug 2017 13:29:59 +0200 Hans Hagen <pra...@wxs.nl> wrote: > On 8/29/2017 9:31 AM, Christoph Reller wrote: > > Hi, > > > > I noticed that the scite module (m-scite.mkiv) has undergone some > > changes recently. When using this module to highlight

[NTG-context] Scite module and escape does not work anymore

2017-08-29 Thread Christoph Reller
Hi, I noticed that the scite module (m-scite.mkiv) has undergone some changes recently. When using this module to highlight source code, then the escape mechanism does not seem to work anymore. MWE: \enabletrackers[buffers.visualize] \usemodule[scite] \setuptyping[TEX][escape={[[,]]}] \starttext

Re: [NTG-context] Log message "Unknown filter 'DCTDecode'"

2017-06-21 Thread Christoph Reller
On Mon, 19 Jun 2017 12:21:00 +0200 luigi scarso wrote: > With poppler 0.55, > I am able to reproduce it with > > $ convert -size 100x100 radial-gradient: rgradient.jpg; convert > rgradient.jpg rgradient.pdf > $ cat test.tex > > \starttext >

[NTG-context] Log message "Unknown filter 'DCTDecode'"

2017-06-16 Thread Christoph Reller
Hi, In recent versions of ConTeXt/luatex, I observe the following log entry: Syntax Error (77727): Unknown filter 'DCTDecode' This happens if the document includes JPEG images, e.g: \starttext \externalfigure[hacker.jpg] \stoptext The output PDF looks, however, fine. Does this message have

[NTG-context] \setupinteraction[focus=standard] not working

2017-01-20 Thread Christoph Reller
Dear List, First of all: Thank you Hans and folks for supporting focus=standard for many things. There are, however, some major places where focus=standard does not work correctly yet. I pick out the simplest and in my opinion most severe one: Floats.

Re: [NTG-context] ntg-context Digest, Vol 151, Issue 18

2017-01-18 Thread Christoph Reller
On Tue, 17 Jan 2017 20:31:20 +0100, Hans Hagen wrote: > > On 1/17/2017 8:13 PM, Henri Menke wrote: >> Bump >> >> On 01/09/2017 01:49 PM, Henri Menke wrote: >>> Dear list, >>> >>> I cannot seem to find the documentation for the parameters which you can >>> set in the first line of

[NTG-context] JPEG images resolution and externalfigure size

2017-01-12 Thread Christoph Reller
Hi, When using the currently latest version of ConTeXt to include a JPEG image as in the MWE below, the resulting image size in the PDF is half the size when compared with earlier versions. \setupexternalfigures[location={local,global,default}] \starttext \externalfigure[hacker.jpg][scale=1000]

Re: [NTG-context] floatcombination alignment has changed?

2017-01-04 Thread Christoph Reller
Hi, I have come up with a simpler MWE which shows the problem more explicitly: \setupcaptions[number=no] \starttext \startplacefigure[location=right] \startfloatcombination \placefigure{A Cow}{\externalfigure[cow.pdf]} \placefigure{Another Cow}{\externalfigure[cow.pdf]}

Re: [NTG-context] floatcombination alignment has changed?

2016-12-28 Thread Christoph Reller
Dear List, Consider the following MWE: \startplacefigure \startfloatcombination \startplacetable[title={Table I}] % <- shifted %\startplacetable % <- not shifted \bTABLE \bTR \bTD Foo \eTD \bTD Text. \eTD \eTR \eTABLE \stopplacetable

[NTG-context] references.bookmarks.preroll and quotation

2016-12-20 Thread Christoph Reller
Hi, I have the following MWE: \setupinteraction[state=start] \placebookmarks[chapter] \enabledirectives[references.bookmarks.preroll] \starttext \startchapter[title=B \quotation{C} D] \input ward \stopchapter \stoptext The generated bookmark has wrongly placed spaces: B“ C ” D Without the

Re: [NTG-context] floatcombination alignment has changed?

2016-12-09 Thread Christoph Reller
On Thu, 08 Dec 2016 20:27:12 +0900, Jeong Dal wrote: > I don’t know how to put figures horizontally using “\startfloatcombination”. > Is there any reason to use “\startfloatcombination”? Dear Dalyoung, Thank you for your feedback. Indeed, \startcombinantion produces centered

[NTG-context] floatcombination alignment has changed?

2016-12-07 Thread Christoph Reller
Hi, In recent versions of ConTeXt, floatcombinations are not placed centered by default anymore. Consider the following MWE in which two cows are placed side by side: \placefigure{}{ \startfloatcombination \placefigure{}{\externalfigure[cow.pdf]}

Re: [NTG-context] Nested modes and itemizations

2016-11-17 Thread Christoph Reller
On Thu, Nov 17, 2016 at 13:14:49 +0100 Hans Hagen <pra...@wxs.nl> wrote: > > On 11/17/2016 11:21 AM, Christoph Reller wrote: > > Hi, > > > > I have the following minimal not-working example: > > > > \starttext > > \startitemize >

[NTG-context] Nested modes and itemizations

2016-11-17 Thread Christoph Reller
Hi, I have the following minimal not-working example: \starttext \startitemize \item One \startmode[modeA] \item Two \startitemize \startmode[modeB] % <- this \item Two A % <- does \stopmode % <- not work % \doifmode{modeB}{\item Two A} % <- this

Re: [NTG-context] TikZ node and color

2016-07-06 Thread Christoph Reller
On Tue, 5 Jul 2016 10:21:48 +0200, Hans Hagen <pra...@wxs.nl> wrote: > On 7/5/2016 9:25 AM, Christoph Reller wrote: >> Dear List, >> >> I use the latest version of ConTeXt and I have the following MWE: >> >> \usemodule[tikz] >> \starttext >>

[NTG-context] TikZ node and color

2016-07-05 Thread Christoph Reller
Dear List, I use the latest version of ConTeXt and I have the following MWE: \usemodule[tikz] \starttext \starttikzpicture \node {\color[red]{red}}; \node[xshift=30] {\color[red]{not red}}; \stoptikzpicture \stoptext Can anybody tell me why the second node is not colored red?

[NTG-context] placetable with location=split produces error

2016-06-20 Thread Christoph Reller
>> Christoph Reller <mailto:christoph.rel...@gmail.com> >> 16. Juni 2016 um 15:31 >> This is a long standing issue and I would very much appreciate any >> comment on this. > The problem has been fixed. > > Wolfgang Indeed this error is gone now. Ta

Re: [NTG-context] ntg-context Digest, Vol 144, Issue 16

2016-06-16 Thread Christoph Reller
On Thu, 9 Jun 2016 10:43:50, Christoph Reller <christoph.rel...@gmail.com> wrote: > ... > > Hence, the check mark cannot be copy pasted from the PDF. > > I fear this may be a bug. Or am I missing something? Any feedback is > welcome. Thank you very much for having fixed t

[NTG-context] placetable with location=split produces error

2016-06-16 Thread Christoph Reller
On Fri, 10 Jun 2016 14:00:01, Christoph Reller <christoph.rel...@gmail.com> wrote: > On Thu, 09 Jun 2016 10:08:24, Christoph Reller > <christoph.rel...@gmail.com> wrote: >> \starttext >> \dorecurse{9}{\input ward} >> \startplacetable[location=split] >

[NTG-context] placetable with location=split produces error (Christoph Reller)

2016-06-10 Thread Christoph Reller
On Thu, 09 Jun 2016 10:08:24, Christoph Reller <christoph.rel...@gmail.com> wrote: > \starttext > \dorecurse{9}{\input ward} > \startplacetable[location=split] > \bTABLE > \bTR \bTD \input tufte \eTD \eTR > \eTABLE > \stopplacetable > \

[NTG-context] placetable with location=split produces error

2016-06-09 Thread Christoph Reller
Hi, Can anybody tell me why the following MWE does not work: \starttext \dorecurse{9}{\input ward} \startplacetable[location=split] \bTABLE \bTR \bTD \input tufte \eTD \eTR \eTABLE \stopplacetable \stoptext The error message is: ! Undefined control sequence ...ixednumber

[NTG-context] Wrong ToUnicode table for ZapfDingbats font

2016-06-09 Thread Christoph Reller
Hi, Consider the following MWE, that displays a ZapfDingbats check mark: \definefontsynonym[ZapfDingbats][file:ZapfDingbats][features=dingbats] \definefont[zapfdingbats][ZapfDingbats] \starttext \getnamedglyphdirect{ZapfDingbats*dingbats}{a19} \stoptext In earlier versions, e.g., 2016.03.13,

Re: [NTG-context] Questions about Scite lexers

2016-04-13 Thread Christoph Reller
On Wed, Apr 13, 2016 at 10:39 PM Christoph Reller < christoph.rel...@gmail.com> wrote: > Nicola <nvitacolo...@gmail.com> wrote on Wed., 13. Apr. 2016 19:36: > >> >> I have found an old document of mine, which uses a >> (slightly customized) pret-c.lua,

Re: [NTG-context] Questions about Scite lexers

2016-04-13 Thread Christoph Reller
Nicola wrote on Wed., 13. Apr. 2016 19:36: > > I have found an old document of mine, which uses a > (slightly customized) pret-c.lua, located inside the project's folder. > It compiles, but I don't get syntax highlighting. Is it because pret-c > is not searched in the

Re: [NTG-context] Tagging and startitemize[columns]

2016-03-23 Thread Christoph Reller
On Tue, 22 Mar 2016 14:53:05 +0100, Hans Hagen <pra...@wxs.nl> wrote: > > On 3/22/2016 9:19 AM, Christoph Reller wrote: > > \setuptagging[state=start] > > \starttext > > > >\startsectionlevel[title=Chapter] > > Text. > > \startit

[NTG-context] Tagging and startitemize[columns]

2016-03-22 Thread Christoph Reller
Hi, Stil ConTeXt is the only TeX-based typesetting system that can produce tagged PDF - this is a unique feature, thank you Hans! I have, however, found that the following MWE produces wrongly nested tagging information. Specifically: - The itemization with columns (\startitemize[columns]) is

Re: [NTG-context] PDF Inclusion Regression

2016-02-24 Thread Christoph Reller
On Wed, Feb 24, 2016 at 4:38 PM Hans Hagen <pra...@wxs.nl> wrote: > > On 2/24/2016 2:23 PM, Christoph Reller wrote: > > I am afraid but this might be a bug in newer versions of luatex. I would > > greatly appreciate if this would be addressed. > > fixed in next l

[NTG-context] PDF Inclusion Regression

2016-02-24 Thread Christoph Reller
Hi, I have found the following problem when including an external PDF with \externalfigure: Some (or all?) values in PDF arrays that are between -1.0 and 0.0 loose their minus sign. E.g: -0.1 turns into 0.1. This can lead to significant visual differences. This problem did not exist in earlier

Re: [NTG-context] two issues with interactive hyperlinks (please comment)

2016-02-23 Thread Christoph Reller
Hi Hans, First and foremost: Thank you for uploading the Beta! This solves the problem I have reported with \reference and focus=standard: https://www.mail-archive.com/ntg-context%40ntg.nl/msg79620.html On Tue, Feb 23, 2016 at 12:00 PM Hans Hagen wrote: > > On 2/23/2016 12:21

[NTG-context] Tagging and Math Matrix

2015-12-28 Thread Christoph Reller
Hi, There seems to be a problem with the structure information added when using \startmatrix: \setuptagging[state=start] \starttext \math{ \startmatrix \NC A \NR \NC B \NR \stopmatrix} \stoptext The log reports an open chain: document>1 => mtr>1 => mtd>1 => mtr>2 => mtd>2 => mtr>3

[NTG-context] Hyphenation, OTF font and tagging

2015-11-08 Thread Christoph Reller
Hi, I have a strange behavior with the latest beta: - OpenType Font "Myriad" - Tagging enabled Result: Hyphenation is not working, i.e., the hyphens disappear. Example output correct (when disabling tagging): [...] If I had not partici- pated fully [...] Example output defect (when enabling

Re: [NTG-context] PDF/UA Support

2015-10-20 Thread Christoph Reller
le "PDF Accessibility Checker". (Just google for it.) Nevertheless, ConTeXt is the only TeX-based option that supports PDF tagging and it does a good job - thank you Hans for your efforts. Regards, Christoph Reller _

Re: [NTG-context] \reference and \setupinteraction[focus=...] not working

2015-10-08 Thread Christoph Reller
of reference links (Henning Hraban Ramm) >5. Re: \reference and \setupinteraction[focus=...] not working > (Christoph Reller) >6. Re: formatting of reference links (Wolfgang Schuster) > > > -- > > Mess

Re: [NTG-context] \reference and \setupinteraction[focus=...] not working

2015-09-18 Thread Christoph Reller
Hi, Any news on this? Is this a luatex problem or a ConTeXt problem? I am glad to help if you can point me to the location in the source code where things go astray. Cheers, Christoph On Mon, 14 Sep 2015 14:40:43 +0200, wrote: > Hi, > > In the following MWE, the

[NTG-context] \reference and \setupinteraction[focus=...] not working

2015-09-14 Thread Christoph Reller
Hi, In the following MWE, the interactive link work only when setting focus=fit. The resulting PDF differs as follows: - focus=fit: This PDF has no named destinations. The link annotations on page 3 include destinations directly, and these destinations are correct. - focus=: This PDF has named

Re: [NTG-context] Expansion in bookmarks

2015-07-09 Thread Christoph Reller
On Wed, 08 Jul 2015 21:01:21 +0200, Hans Hagen pra...@wxs.nl wrote: On 7/8/2015 4:18 PM, Christoph Reller wrote: Dear all! I want to define a command that is to be used in a section title. Also I want to use \autoinsertnextspace with this command. In the following MWE, why do

[NTG-context] Expansion in bookmarks

2015-07-08 Thread Christoph Reller
Dear all! I want to define a command that is to be used in a section title. Also I want to use \autoinsertnextspace with this command. In the following MWE, why do \This and \AName not work, while \TEX does work? I appreciate any feedback, Christoph MWE: \setupinteraction[state=start]

Re: [NTG-context] Accessibility and Tagged PDFs: Bugs and Feature Requests

2015-07-03 Thread Christoph Reller
On Wed, 01 Jul 2015 19:02:08 +0200 Hans Hagen pra...@wxs.nl wrote: So, it's not that difficult to add features, more a matter of priorities and motivation (apart from the fact that my acrobat is a bit old by now so I cannot really test). Dear Hans, You can use the PDF Accessibility Checker

Re: [NTG-context] Accessibility and Tagged PDFs: Bugs and Feature Requests

2015-07-01 Thread Christoph Reller
On Tue, Jun 30, 2015 at 10:33 AM,luigi scarso luigi.sca...@gmail.com wrote: On Sun, Jun 28, 2015 at 12:59 PM, Dr. Dominik Klein dominik.kl...@outlook.com wrote: Context is the only Tex-based system that allows to properly tag a pdf. Tagged PDFs are one major requirement for

  1   2   >