Re: [Oiio-dev] iv - tests and more thoughts

2012-07-04 Thread Chris Foster
On Wed, Jul 4, 2012 at 1:23 PM, Larry Gritz l...@larrygritz.com wrote: I dunno, I'm tempted to think that in exchange for that conceptual cleanliness, you're paying with a second type to juggle and understand when each is applicable. Right. After looking back at the code, I think the way we

Re: [Oiio-dev] iv - tests and more thoughts

2012-07-03 Thread Larry Gritz
On Jun 26, 2012, at 12:32 PM, Brent Davis wrote: As an aside, what do you think about TiledIterator instead of UnorderedIterator as a more descriptive name? I think that TiledIterator could imply that Iterator doesn't use tiles, even though it does (when using the cache, anyway). So I

Re: [Oiio-dev] iv - tests and more thoughts

2012-07-03 Thread Larry Gritz
On Jun 26, 2012, at 2:24 PM, Chris Foster wrote: Side note: If we have TiledIterator, should we make it part of the interface that Iterator visits pixels in scanline order? If not, there doesn't seem much merit in even having a distinction. It does beg the question about whether, if

Re: [Oiio-dev] iv - tests and more thoughts

2012-06-29 Thread Brent Davis
Side note: If we have TiledIterator, should we make it part of the interface that Iterator visits pixels in scanline order? If not, there doesn't seem much merit in even having a distinction. Sorry about the late reply, I assumed this was more directed at the devs as a group rather than at

Re: [Oiio-dev] iv - tests and more thoughts

2012-06-18 Thread Larry Gritz
I think it should be ok to have pos(). It doesn't need to know the full history of iteration; if you ++ after a pos(), it just iterates as it would have if it naturally reached that position. Since different images will have different tile sizes -- but note that it was always the case that

Re: [Oiio-dev] iv - tests and more thoughts

2012-06-16 Thread Chris Foster
Hi Brent, On Sat, Jun 16, 2012 at 6:00 AM, Brent Davis btda...@coe.edu wrote: Second, I added an UnorderedIterator. Cool! I've thought this was a good idea for quite a while but was too lazy/busy to implement it myself ;-) The main differences between this and the normal iterator are: (1)

Re: [Oiio-dev] iv - tests and more thoughts

2012-06-16 Thread Larry Gritz
I'm not sure I understand why there can't be a pos() for an UnorderedIterator. Can you explain? On Jun 15, 2012, at 1:00 PM, Brent Davis wrote: Alright, I've got something working now; I'll try to walk through what changes I've made to ImageBuf. --- First, I carved out an IteratorBase

Re: [Oiio-dev] iv - tests and more thoughts

2012-06-05 Thread Larry Gritz
Hi, Brent. Dan Wexler is hitting a bit of a busy patch, so I'm going to be pitching in a bit more with mentoring duties. On Jun 4, 2012, at 6:09 PM, Brent Davis wrote: Do you know how Boost's futures compare to C++11? From what I understand, C++11's threads library is modeled directly

Re: [Oiio-dev] iv - tests and more thoughts

2012-06-04 Thread Brent Davis
There is a copy_pixels in the ImageBuf (actually, I *just* renamed it to get_pixels which seemed more in line with naming and doesn't conflict with a slightly different copy_pixels from IB to IB). Ah, I didn't notice that, I'll take a look. Do you know how Boost's futures compare to C++11?

Re: [Oiio-dev] iv - tests and more thoughts

2012-06-03 Thread Larry Gritz
On May 23, 2012, at 12:36 PM, Brent Davis wrote: Retile is getting called 8640 times (which happens to be ceil(1920/256)*1080) with this image; optimally we would have to retile 40 times at this tile size (ie, ceil(1920/256)*ceil(1080/256)). On large images this is compounded: on my