Re: [devel] changing saAmfSGNumPrefActiveSUs for N+1 SG w/out bringing it down

2014-04-22 Thread Hans Feldt
Please do, that would be great. Thanks, Hans On 11 April 2014 17:37, Alex Jones ajo...@genband.com wrote: I notice that dynamically changing saAmfSGNumPrefActiveSUs for an N+1 service group is not supported, unless the service group is not unlocked. This prevents in-service capacity addition

Re: [devel] [PATCH 1 of 1] amfd: use db_template for the SU db [#713]

2014-04-22 Thread Hans Feldt
One goal of refactoring I would say is to reduce code duplication with the help of good interfaces. In this case it is just a matter of having two insert methods, one that can fail and one that cannot, let's call it insert_unique. By using insert_unique asserts on the client side can be

[devel] [PATCH 1 of 1] amfd: use db_template for the apptype db V1 [#713]

2014-04-22 Thread Hans Nordeback
osaf/services/saf/amf/amfd/apptype.cc| 31 ++- osaf/services/saf/amf/amfd/include/app.h | 4 2 files changed, 10 insertions(+), 25 deletions(-) diff --git a/osaf/services/saf/amf/amfd/apptype.cc b/osaf/services/saf/amf/amfd/apptype.cc ---

Re: [devel] [PATCH 1 of 1] amfd: use db_template for the apptype db V1 [#713]

2014-04-22 Thread Hans Feldt
Ack with minor comment assert needed after insert :-) Please consider db as I suggested. Thanks, HansF -Original Message- From: Hans Nordebäck Sent: den 22 april 2014 10:03 To: Hans Feldt; praveen.malv...@oracle.com; nagendr...@oracle.com Cc: opensaf-devel@lists.sourceforge.net

Re: [devel] [PATCH 1 of 1] amfd: Respond with TRY_AGAIN to admin ops during a controller switch-over [#821]

2014-04-22 Thread Nagendra Kumar
Few comments: 1. report_admin_op_error could be used instead of avd_saImmOiAdminOperationResult stating appropriate reason. 2. The below code should be removed now from avd_sg_2n_siswap_func: if (susi-si-sg_of_si-sg_ncs_spec) { if (true == avd_cb-swap_switch ) {

[devel] [PATCH 0 of 5] Review Request for AMF SU refactoring #713

2014-04-22 Thread Hans Feldt
Summary: amfd SU refactoring Review request for Trac Ticket(s): 713 Peer Reviewer(s): AMF developers Pull request to: LIST THE PERSON WITH PUSH ACCESS HERE Affected branch(es): default Development branch: IF ANY GIVE THE REPO URL Impacted area Impact y/n

[devel] [PATCH 1 of 5] amfd: cleanup SU [#713]

2014-04-22 Thread Hans Feldt
osaf/services/saf/amf/amfd/ckpt_dec.cc | 28 + osaf/services/saf/amf/amfd/ckpt_updt.cc | 1 - osaf/services/saf/amf/amfd/include/su.h | 38 + osaf/services/saf/amf/amfd/su.cc| 41

[devel] [PATCH 4 of 5] amfd: add and use SU methods add_comp/remove_comp [#713]

2014-04-22 Thread Hans Feldt
osaf/services/saf/amf/amfd/comp.cc | 11 ++- osaf/services/saf/amf/amfd/include/su.h | 8 +--- osaf/services/saf/amf/amfd/su.cc| 6 ++ 3 files changed, 13 insertions(+), 12 deletions(-) diff --git a/osaf/services/saf/amf/amfd/comp.cc

[devel] [PATCH 2 of 5] amfd: add and use SU method set_pres_state [#713]

2014-04-22 Thread Hans Feldt
osaf/services/saf/amf/amfd/include/su.h | 2 +- osaf/services/saf/amf/amfd/ndproc.cc| 2 +- osaf/services/saf/amf/amfd/sgproc.cc| 4 ++-- osaf/services/saf/amf/amfd/su.cc| 30 ++ 4 files changed, 18 insertions(+), 20 deletions(-) diff --git

[devel] [PATCH 3 of 5] amfd: add and use SU method set_admin_state [#713]

2014-04-22 Thread Hans Feldt
osaf/services/saf/amf/amfd/include/su.h | 3 +- osaf/services/saf/amf/amfd/sg_2n_fsm.cc | 14 +++--- osaf/services/saf/amf/amfd/sg_nored_fsm.cc | 16 osaf/services/saf/amf/amfd/sg_npm_fsm.cc | 16 osaf/services/saf/amf/amfd/sg_nway_fsm.cc| 20 +-

[devel] [PATCH 0 of 1] Review Request for amfd: use db_template for the apptype db V2 [#713]

2014-04-22 Thread Hans Nordeback
Summary: amfd: use db_template for the apptype db V2 Review request for Trac Ticket(s): #713 Peer Reviewer(s): Nagu, Praveen Pull request to: Affected branch(es): default Development branch: default Impacted area Impact y/n

[devel] [PATCH 1 of 1] amfd: use db_template for the apptype db V2 [#713]

2014-04-22 Thread Hans Nordeback
osaf/services/saf/amf/amfd/apptype.cc| 27 +-- osaf/services/saf/amf/amfd/include/app.h | 4 2 files changed, 9 insertions(+), 22 deletions(-) diff --git a/osaf/services/saf/amf/amfd/apptype.cc b/osaf/services/saf/amf/amfd/apptype.cc ---

Re: [devel] [PATCH 1 of 1] amfd: use db_template for the apptype db V2 [#713]

2014-04-22 Thread Nagendra Kumar
Ack Thanks -Nagu -Original Message- From: Hans Nordeback [mailto:hans.nordeb...@ericsson.com] Sent: 22 April 2014 16:32 To: Praveen Malviya; Nagendra Kumar Cc: opensaf-devel@lists.sourceforge.net Subject: [PATCH 1 of 1] amfd: use db_template for the apptype db V2 [#713]

Re: [devel] [PATCH 1 of 5] amfd: cleanup SU [#713]

2014-04-22 Thread Hans Nordebäck
ack, code review only/BR HansN On 04/22/14 12:58, Hans Feldt wrote: osaf/services/saf/amf/amfd/ckpt_dec.cc | 28 + osaf/services/saf/amf/amfd/ckpt_updt.cc | 1 - osaf/services/saf/amf/amfd/include/su.h | 38 +

[devel] [PATCH 0 of 1] Review Request for AMF #868

2014-04-22 Thread Hans Feldt
Summary: AMF job queue fix Review request for Trac Ticket(s): 868 Peer Reviewer(s): Nags Pull request to: LIST THE PERSON WITH PUSH ACCESS HERE Affected branch(es): all Development branch: 4.3 Impacted area Impact y/n Docs

[devel] [PATCH 1 of 1] amfd: fix imm job update [#868]

2014-04-22 Thread Hans Feldt
osaf/services/saf/avsv/avd/avd_imm.c | 2 +- 1 files changed, 1 insertions(+), 1 deletions(-) Ugly logs from amfd like: Apr 19 19:55:18 SC-1 osafamfd[469]: ER exec: update FAILED 12 When an IMM update job is executed and for some reason the object does not exist, the job remains in the

[devel] [PATCH 0 of 1] Review Request for IMMTOOLS: revert old way of parsing default values and add a flag for more strict parsing values in immcfg [#861]

2014-04-22 Thread Zoran Milinkovic
Summary: IMMTOOLS: revert old way of parsing default values and add a flag for more strict parsing values in immcfg [#861] Review request for Trac Ticket(s): 861 Peer Reviewer(s): Neelakanta Pull request to: Zoran Affected branch(es): opensaf-4.4.x, default(4.5) Development branch: opensaf-4.4.x

[devel] [PATCH 1 of 1] IMMTOOLS: revert old way of parsing default values and add a flag for more strict parsing values in immcfg [#861]

2014-04-22 Thread Zoran Milinkovic
osaf/tools/safimm/immcfg/imm_cfg.c | 13 + osaf/tools/safimm/immcfg/imm_import.cc | 34 ++ 2 files changed, 31 insertions(+), 16 deletions(-) For backwards compatibility, it's needed to revert the code for old way of parsing default values.

Re: [devel] changing saAmfSGNumPrefActiveSUs for N+1 SG w/out bringing it down

2014-04-22 Thread Alex Jones
Some preliminary requirements and proposals for discussion: 1. I've created ticket 871 for this 2. This will only support N+M service group. 3. There must be a currently instantiated spare SU for the modification to succeed. The idea is that we can do an immediate REALIGN of the SG

[devel] [PATCH 0 of 1] Review Request for amfd: Respond with TRY_AGAIN to admin ops during a controller switch-over V2 [#821]

2014-04-22 Thread Gary Lee
Summary: amfd: Respond with TRY_AGAIN to admin ops during a controller switch-over [#821] Review request for Trac Ticket(s): 821 Peer Reviewer(s): Hans N, Nagendra, Praveen, Hans F Pull request to: Affected branch(es): default, 4.4 Development branch: default

Re: [devel] [PATCH 1 of 1] amfd: Respond with TRY_AGAIN to admin ops during a controller switch-over [#821]

2014-04-22 Thread Gary Lee
Thanks Nagendra... I'm wondering if we should convert report_admin_op_error to use the job queue as well. Though it's less likely 'users' will be querying IMM immediately after an admin op fails, in contrast with the success case. Thanks Gary On 22/04/14 20:13, Nagendra Kumar wrote: Few

Re: [devel] [PATCH 1 of 1] amfd: fix imm job update [#868]

2014-04-22 Thread Nagendra Kumar
Ack. SA_AIS_ERR_EXIST is not even a valid return of saImmOiRtObjectUpdate_2(). Thanks -Nagu -Original Message- From: Hans Feldt [mailto:osafde...@gmail.com] Sent: 22 April 2014 19:37 To: Nagendra Kumar Cc: opensaf-devel@lists.sourceforge.net Subject: [PATCH 1 of 1] amfd: fix imm