[devel] [PATCH 1 of 1] amfnd: queue PG track action msgs [#2115]

2016-10-12 Thread Gary Lee
osaf/services/saf/amf/amfnd/di.cc | 8 ++-- 1 files changed, 2 insertions(+), 6 deletions(-) After SC absence, active amfd will reject messages from 'veteran' amfnds until its local amfnd has started. During this period, if a PG track action msg is sent and rejected by amfd, it will cause

[devel] [PATCH 1 of 1] smf: balanced upgrade, missing removal of exectrl copy [#2114]

2016-10-12 Thread Rafael Odzakow
osaf/services/saf/smfsv/smfd/SmfExecControlHdl.cc | 69 ++--- osaf/services/saf/smfsv/smfd/SmfExecControlHdl.h | 13 +-- osaf/services/saf/smfsv/smfd/SmfUpgradeCampaign.cc | 1 + 3 files changed, 51 insertions(+), 32 deletions(-) diff --git

[devel] [PATCH 0 of 1] Review Request for smf: balanced upgrade, missing removal of exectrl copy [#2114]

2016-10-12 Thread Rafael Odzakow
Summary: smf: balanced upgrade, missing removal of exectrl copy Review request for Trac Ticket(s): #2114 Peer Reviewer(s): lennart Pull request to: <> Affected branch(es): <> Development branch: <> Impacted area Impact y/n

Re: [devel] [PATCH 1 of 1] smf: reading of IMM longdn attribute at the camapign admin operation [#2087]

2016-10-12 Thread Anders Widell
Hi! Build fails on the opensaf-5.0.x branch after ticket [#2087] was pushed: CXX osafsmfd-SmfCampaignInit.o SmfCampaignInit.cc:230:2: error: ‘upActiter’ does not name a type upActiter = m_campInitAction.begin(); ^ SmfCampaignInit.cc:231:2: error: expected unqualified-id before

Re: [devel] [PATCH 1 of 1] imm: Return error string when object is being created in another CCB [#2111]

2016-10-12 Thread Zoran Milinkovic
Hi Hung, Reviewed the patch. Ack from me. Thanks, Zoran -Original Message- From: Hung Nguyen [mailto:hung.d.ngu...@dektech.com.au] Sent: den 12 oktober 2016 05:02 To: Zoran Milinkovic ; reddy.neelaka...@oracle.com Cc: opensaf-devel@lists.sourceforge.net

Re: [devel] [PATCH 1 of 1] smfd: handle failed si-swap of middleware [#1605]

2016-10-12 Thread Rafael Odzakow
ACK On 10/10/2016 01:46 PM, Neelakanta Reddy wrote: > Hi Alex, > > Reviewed and tested the patch. > Ack. > > /Neel. > > On 2016/10/07 11:10 PM, Alex Jones wrote: >> osaf/services/saf/smfsv/smfd/SmfStepState.cc| 13 >> osaf/services/saf/smfsv/smfd/SmfUpgradeProcedure.cc | 68 >>

Re: [devel] [PATCH 1 of 1] immtool: Don't finalize admo if it hasn't been initialized [#2107]

2016-10-12 Thread Neelakanta Reddy
Hi Hung, Reviewed and tested the patch. Ack. /Neel. On 2016/10/11 09:27 AM, Hung Nguyen wrote: > osaf/tools/safimm/immcfg/imm_cfg.c | 2 +- > 1 files changed, 1 insertions(+), 1 deletions(-) > > > Don't finalize admo if it hasn't been initialized. > > diff --git

Re: [devel] [PATCH 1 of 1] log: fix saLogStreamOpen_2 returns SA_AIS_ERR_BAD_OPERATION during si-swap [#2093]

2016-10-12 Thread A V Mahesh
Ok ACK , not tested. -AVM On 10/12/2016 12:42 PM, Vu Minh Nguyen wrote: > Hi Mahesh, > > I added one comment in "PATCH 0 of 1", telling reason why not using ha > state. > Here it is. > //> > Previous fix is not correct as ha state in cb is not changed > when entering QUIESED state. So,

Re: [devel] [PATCH 1 of 1] log: fix failure to create directory when changing logRootDirectory [#2054]

2016-10-12 Thread A V Mahesh
Hi Vu, If possible use global `lgs_conf.logRootDirectory` after the call `lgs_rootpathconf_set(new_logRootDirectory)` instead of passed `new_logRootDirectory` parameter. -AVM On 10/12/2016 12:39 PM, Vu Minh Nguyen wrote: > Hi Mahesh, > > See my comment inline. > > Regards, Vu > >>

Re: [devel] [PATCH 1 of 1] log: fix saLogStreamOpen_2 returns SA_AIS_ERR_BAD_OPERATION during si-swap [#2093]

2016-10-12 Thread Vu Minh Nguyen
Hi Mahesh, I added one comment in "PATCH 0 of 1", telling reason why not using ha state. Here it is. //> Previous fix is not correct as ha state in cb is not changed when entering QUIESED state. So, basing on ha_state variable is not correct. Using is_quiesced_set flag instead. //< Regards,

Re: [devel] [PATCH 1 of 1] log: fix saLogStreamOpen_2 returns SA_AIS_ERR_BAD_OPERATION during si-swap [#2093]

2016-10-12 Thread A V Mahesh
Hi Vu, Can we use (cb->ha_state != SA_AMF_HA_ACTIVE) instead of `cb->is_quiesced_set == true` as if this is a agent response, so it will have more readability . -AVM On 10/11/2016 10:36 AM, Vu Minh Nguyen wrote: > osaf/services/saf/logsv/lgs/lgs_evt.cc | 12 +++- >

Re: [devel] [PATCH 1 of 1] log: fix failure to create directory when changing logRootDirectory [#2054]

2016-10-12 Thread Vu Minh Nguyen
Hi Mahesh, See my comment inline. Regards, Vu > -Original Message- > From: A V Mahesh [mailto:mahesh.va...@oracle.com] > Sent: Wednesday, October 12, 2016 1:52 PM > To: Lennart Lund ; Vu Minh Nguyen > > Cc:

Re: [devel] [PATCH 1 of 1] log: write_log_record_hdl get bad file descriptor [#2028]

2016-10-12 Thread A V Mahesh
Ok, ACK. -AVM On 10/12/2016 12:27 PM, Vu Minh Nguyen wrote: > Hi Mahesh, > > In README file, there is a note on this. Refer to "Note on memory handling > for writting log record" > > And caller here means the one that call the function `log_stream_write_h`, > not log client. > > Regards, Vu >

Re: [devel] [PATCH 1 of 1] log: write_log_record_hdl get bad file descriptor [#2028]

2016-10-12 Thread Vu Minh Nguyen
Hi Mahesh, In README file, there is a note on this. Refer to "Note on memory handling for writting log record" And caller here means the one that call the function `log_stream_write_h`, not log client. Regards, Vu > -Original Message- > From: A V Mahesh [mailto:mahesh.va...@oracle.com]

Re: [devel] [PATCH 1 of 1] log: fix failure to create directory when changing logRootDirectory [#2054]

2016-10-12 Thread A V Mahesh
Hi VU, ACK with following : Not an issue but It is good to use lgs_conf.logRootDirectory insted of new_logRootDirectory for the remaining part of logRootDirectory_filemove() , because mutex_unlocked for lgs_conf.logRootDirectory -AVM On 10/10/2016 4:48 PM, Lennart Lund wrote: > Hi Vu > >

Re: [devel] [PATCH 1 of 1] log: write_log_record_hdl get bad file descriptor [#2028]

2016-10-12 Thread A V Mahesh
Hi Vu, `Return (-1) to inform that it is caller's responsibility to free the allocated mem` is this existing practices for application ? or new , if new do we need to document it . -AVM On 10/12/2016 10:14 AM, A V Mahesh wrote: > ACK > > -AVM > > > On 9/13/2016 4:19 PM, Vu Minh Nguyen wrote: