Re: [openstack-dev] [Openstack-stable-maint] Stable/grizzly

2013-10-10 Thread Thierry Carrez
Alan Pevec wrote: 2013/10/10 Gary Kotton gkot...@vmware.com: The problem seems to be with the boto python library. I am not really familiar with this but I have seen this is the last – we may need to update the requirements again to exclude a specific version. Yeah, it's bad boto update

Re: [openstack-dev] [Openstack-stable-maint] Stable/grizzly

2013-10-10 Thread Gary Kotton
Trunk - https://review.openstack.org/50904 Stable/Grizzly - https://review.openstack.org/#/c/50905/ There is an alternative patch - https://review.openstack.org/#/c/50873/7 I recall seeing the same problem a few month ago and the bot version was excluded - not sure why the calling code was not

Re: [openstack-dev] [Openstack-stable-maint] Stable/grizzly

2013-10-10 Thread Sean Dague
On 10/10/2013 06:00 AM, Thierry Carrez wrote: Alan Pevec wrote: 2013/10/10 Gary Kotton gkot...@vmware.com: The problem seems to be with the boto python library. I am not really familiar with this but I have seen this is the last – we may need to update the requirements again to exclude a

Re: [openstack-dev] [Openstack-stable-maint] Stable/grizzly

2013-10-10 Thread Alan Pevec
2013/10/10 Sean Dague s...@dague.net: Hmph. So boto changed their connection function signatures to have a 3rd argument, and put it second, and nothing has defaults. So isn't that a boto bug? Not sure what their backward-compatibility statement is but it is silly to break API just like that[1]

Re: [openstack-dev] [Openstack-stable-maint] Stable/grizzly

2013-10-10 Thread Adam Gandelman
On 10/10/2013 04:42 AM, Gary Kotton wrote: Trunk - https://review.openstack.org/50904 Stable/Grizzly - https://review.openstack.org/#/c/50905/ There is an alternative patch - https://review.openstack.org/#/c/50873/7 I recall seeing the same problem a few month ago and the bot version was