commit sblim-sfcb for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package sblim-sfcb for openSUSE:Factory 
checked in at 2018-02-09 15:53:24

Comparing /work/SRC/openSUSE:Factory/sblim-sfcb (Old)
 and  /work/SRC/openSUSE:Factory/.sblim-sfcb.new (New)


Package is "sblim-sfcb"

Fri Feb  9 15:53:24 2018 rev:53 rq:574591 version:1.4.9

Changes:

--- /work/SRC/openSUSE:Factory/sblim-sfcb/sblim-sfcb.changes2017-12-08 
12:56:55.782678268 +0100
+++ /work/SRC/openSUSE:Factory/.sblim-sfcb.new/sblim-sfcb.changes   
2018-02-09 15:53:26.710679142 +0100
@@ -1,0 +2,12 @@
+Fri Feb  9 10:02:14 UTC 2018 - adam.ma...@suse.de
+
+- Fix misapplied 0022-Fix-crash-caused-by-NULL-content_type.patch
+  (bnc#1079937, CVE-2018-6644)
+
+---
+Thu Feb  8 14:25:07 UTC 2018 - adam.ma...@suse.de
+
+- 0023-Alias-sblim-sfcb-service-to-sfcb-and-sfcbd.patch: use correct
+  alias names for services. (bsc#1072448)
+
+---



Other differences:
--
++ sblim-sfcb.spec ++
--- /var/tmp/diff_new_pack.u0OL2Y/_old  2018-02-09 15:53:27.710643223 +0100
+++ /var/tmp/diff_new_pack.u0OL2Y/_new  2018-02-09 15:53:27.710643223 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package sblim-sfcb
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed

++ 0022-Fix-crash-caused-by-NULL-content_type.patch ++
--- /var/tmp/diff_new_pack.u0OL2Y/_old  2018-02-09 15:53:27.790640349 +0100
+++ /var/tmp/diff_new_pack.u0OL2Y/_new  2018-02-09 15:53:27.790640349 +0100
@@ -10,11 +10,11 @@
  cimXmlParser.c | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/cimXmlParser.c b/cimXmlParser.c
-index e5586e63b0b6..9ce87c547b83 100644
 a/cimXmlParser.c
-+++ b/cimXmlParser.c
-@@ -1738,7 +1738,7 @@ scanCimXmlRequest(CimRequestContext *ctx, char *xmlData, 
int *rc)
+Index: sblim-sfcb-1.4.9/cimXmlParser.c
+===
+--- sblim-sfcb-1.4.9.orig/cimXmlParser.c
 sblim-sfcb-1.4.9/cimXmlParser.c
+@@ -1738,7 +1738,7 @@ scanCimXmlRequest(CimRequestContext *ctx
control.MQs = 0;
control.MPQs = 0;
  
@@ -23,6 +23,16 @@
  *rc=1;
  return control.reqHdr;
}
--- 
-2.15.0
-
+Index: sblim-sfcb-1.4.9/httpAdapter.c
+===
+--- sblim-sfcb-1.4.9.orig/httpAdapter.c
 sblim-sfcb-1.4.9/httpAdapter.c
+@@ -1048,7 +1048,7 @@ doHttpRequest(CommHndl conn_fd)
+ 
+   inBuf.authorization = "";
+   inBuf.protocol = "HTTP/1.1";
+-  inBuf.content_type = NULL;
++  inBuf.content_type = "application/xml";
+   inBuf.content_length = UINT_MAX;
+   inBuf.host = NULL;
+   inBuf.useragent = "";

++ 0023-Alias-sblim-sfcb-service-to-sfcb-and-sfcbd.patch ++
--- /var/tmp/diff_new_pack.u0OL2Y/_old  2018-02-09 15:53:27.802639919 +0100
+++ /var/tmp/diff_new_pack.u0OL2Y/_new  2018-02-09 15:53:27.802639919 +0100
@@ -15,8 +15,8 @@
  
  [Install]
  WantedBy=multi-user.target
-+Alias=sfcbd
-+Alias=sfcb
++Alias=sfcbd.service
++Alias=sfcb.service
 -- 
 2.15.0
 




commit mlmmj for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package mlmmj for openSUSE:Factory checked 
in at 2018-02-09 15:53:32

Comparing /work/SRC/openSUSE:Factory/mlmmj (Old)
 and  /work/SRC/openSUSE:Factory/.mlmmj.new (New)


Package is "mlmmj"

Fri Feb  9 15:53:32 2018 rev:30 rq:574631 version:1.2.19.0

Changes:

--- /work/SRC/openSUSE:Factory/mlmmj/mlmmj.changes  2017-07-26 
13:05:49.869558626 +0200
+++ /work/SRC/openSUSE:Factory/.mlmmj.new/mlmmj.changes 2018-02-09 
15:53:33.850422684 +0100
@@ -1,0 +2,6 @@
+Fri Feb  9 10:41:35 UTC 2018 - suse-b...@cboltz.de
+
+- drop iconv call to avoid double-utf8-encoding of the mail templates
+  (poo#31546)
+
+---



Other differences:
--
++ mlmmj.spec ++
--- /var/tmp/diff_new_pack.7eIRio/_old  2018-02-09 15:53:34.766389782 +0100
+++ /var/tmp/diff_new_pack.7eIRio/_new  2018-02-09 15:53:34.766389782 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package mlmmj
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -43,10 +43,6 @@
 %install
 make DESTDIR=%{buildroot} install
 mkdir -p %{buildroot}%{_datadir}/%{name}/contrib
-find %{buildroot}%{_datadir}/%{name}/text.skel -type f |while read file; do
-  iconv -f ISO-8859-1 -t UTF-8 ${file} > ${file}.utf8
-  mv ${file}.utf8 ${file}
-done
 mkdir -p %{buildroot}%{_defaultdocdir}/%{name}/examples
 cp -a contrib/{amime-receive,web} 
%{buildroot}%{_defaultdocdir}/%{name}/examples/
 cp -a contrib/receivestrip/README README.receivestrip




commit eventstat for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package eventstat for openSUSE:Factory 
checked in at 2018-02-09 15:53:27

Comparing /work/SRC/openSUSE:Factory/eventstat (Old)
 and  /work/SRC/openSUSE:Factory/.eventstat.new (New)


Package is "eventstat"

Fri Feb  9 15:53:27 2018 rev:5 rq:574630 version:0.04.03

Changes:

--- /work/SRC/openSUSE:Factory/eventstat/eventstat.changes  2017-10-30 
21:19:00.798044294 +0100
+++ /work/SRC/openSUSE:Factory/.eventstat.new/eventstat.changes 2018-02-09 
15:53:32.246480297 +0100
@@ -1,0 +2,10 @@
+Thu Feb  1 12:58:11 UTC 2018 - mar...@gmx.de
+
+- Update to version 4.04.03
+  * Makefile: bump version
+  * re-format some overly wide source lines
+  * Don't force wide display unless long mode is used
+  * eventstat: add some more UNLIKELY/LIKELY annotations
+  * Update copyright dates
+
+---

Old:

  eventstat-0.04.02.tar.gz

New:

  eventstat-0.04.03.tar.gz



Other differences:
--
++ eventstat.spec ++
--- /var/tmp/diff_new_pack.DnCb8O/_old  2018-02-09 15:53:33.134448402 +0100
+++ /var/tmp/diff_new_pack.DnCb8O/_new  2018-02-09 15:53:33.134448402 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package eventstat
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 # Copyright (c) 2017, Martin Hauke 
 #
 # All modifications and additions to the file contributed by third parties
@@ -18,7 +18,7 @@
 
 
 Name:   eventstat
-Version:0.04.02
+Version:0.04.03
 Release:0
 Summary:Kernel event states monitoring tool
 License:GPL-2.0+

++ eventstat-0.04.02.tar.gz -> eventstat-0.04.03.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/eventstat-0.04.02/Makefile 
new/eventstat-0.04.03/Makefile
--- old/eventstat-0.04.02/Makefile  2017-10-18 23:15:10.0 +0200
+++ new/eventstat-0.04.03/Makefile  2018-02-01 11:09:48.0 +0100
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2011-2017 Canonical, Ltd.
+# Copyright (C) 2011-2018 Canonical, Ltd.
 #
 # This program is free software; you can redistribute it and/or
 # modify it under the terms of the GNU General Public License
@@ -16,7 +16,7 @@
 # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, 
USA.
 #
 
-VERSION=0.04.02
+VERSION=0.04.03
 
 CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -O2
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/eventstat-0.04.02/eventstat.8 
new/eventstat-0.04.03/eventstat.8
--- old/eventstat-0.04.02/eventstat.8   2017-10-18 23:15:10.0 +0200
+++ new/eventstat-0.04.03/eventstat.8   2018-02-01 11:09:48.0 +0100
@@ -2,7 +2,7 @@
 .\" First parameter, NAME, should be all caps
 .\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
 .\" other parameters are allowed: see man(7), man(1)
-.TH EVENTSTAT 8 "August 14, 2018"
+.TH EVENTSTAT 8 "August 14, 2017"
 .\" Please adjust this date whenever revising the manpage.
 .\"
 .\" Some roff macros, for reference:
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/eventstat-0.04.02/eventstat.c 
new/eventstat-0.04.03/eventstat.c
--- old/eventstat-0.04.02/eventstat.c   2017-10-18 23:15:10.0 +0200
+++ new/eventstat-0.04.03/eventstat.c   2018-02-01 11:09:48.0 +0100
@@ -1,5 +1,5 @@
 /*
- * Copyright (C) 2011-2017 Canonical
+ * Copyright (C) 2011-2018 Canonical
  *
  * This program is free software; you can redistribute it and/or
  * modify it under the terms of the GNU General Public License
@@ -261,7 +261,7 @@
const int min_digits = 5;
char buf[32];
 
-   if (max_digits)
+   if (LIKELY(max_digits))
goto ret;
 
max_digits = default_digits;
@@ -621,7 +621,7 @@
timer_info_t *const *info1 = (timer_info_t *const *)item1;
timer_info_t *const *info2 = (timer_info_t *const *)item2;
 
-   if ((*info2)->total_events == (*info1)->total_events)
+   if (UNLIKELY((*info2)->total_events == (*info1)->total_events))
return 0;
 
return ((*info2)->total_events > (*info1)->total_events) ? 1 : -1;
@@ -679,7 +679,7 @@
const pid_t pgid = id == 0 ? 0 : getpgid(id);
 
/* We are either in a container, or with a task with a NULL cmdline */
-   if (g_sane_procs || (id >= 0))
+   if (LIKELY(g_sane_procs || (id >= 0)))
return (pgid == 0);
 
/* Can't get pgid on that pid, so make a guess */
@@ -798,7 +798,8 @@
 
(void)fprintf(fp, ",Total:");
for (i = 0; i < n; i++)
-   

commit alevt for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package alevt for openSUSE:Factory checked 
in at 2018-02-09 15:53:41

Comparing /work/SRC/openSUSE:Factory/alevt (Old)
 and  /work/SRC/openSUSE:Factory/.alevt.new (New)


Package is "alevt"

Fri Feb  9 15:53:41 2018 rev:20 rq:574645 version:1.6.2

Changes:

--- /work/SRC/openSUSE:Factory/alevt/alevt.changes  2012-01-09 
15:16:06.0 +0100
+++ /work/SRC/openSUSE:Factory/.alevt.new/alevt.changes 2018-02-09 
15:53:48.005914220 +0100
@@ -1,0 +2,5 @@
+Fri Feb  9 12:39:22 UTC 2018 - crrodrig...@opensuse.org
+
+- BuildRequire pkgconfig(x11) not xorg-x11-devel 
+
+---



Other differences:
--
++ alevt.spec ++
--- /var/tmp/diff_new_pack.n2G2Nj/_old  2018-02-09 15:53:49.685853876 +0100
+++ /var/tmp/diff_new_pack.n2G2Nj/_new  2018-02-09 15:53:49.689853733 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package alevt
 #
-# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -26,7 +26,7 @@
 BuildRequires:  libpng-devel
 BuildRequires:  pkgconfig
 BuildRequires:  update-desktop-files
-BuildRequires:  xorg-x11-devel
+BuildRequires:  pkgconfig(x11)
 Url:http://www.goron.de/~froese/
 Summary:Teletext and Videotext Decoder for the BTTV Driver
 License:GPL-2.0+





commit obs-service-product_converter for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package obs-service-product_converter for 
openSUSE:Factory checked in at 2018-02-09 15:53:19

Comparing /work/SRC/openSUSE:Factory/obs-service-product_converter (Old)
 and  /work/SRC/openSUSE:Factory/.obs-service-product_converter.new (New)


Package is "obs-service-product_converter"

Fri Feb  9 15:53:19 2018 rev:4 rq:574547 version:1.1.2

Changes:

--- 
/work/SRC/openSUSE:Factory/obs-service-product_converter/obs-service-product_converter.changes
  2018-02-01 21:31:49.266245624 +0100
+++ 
/work/SRC/openSUSE:Factory/.obs-service-product_converter.new/obs-service-product_converter.changes
 2018-02-09 15:53:24.550756725 +0100
@@ -1,0 +2,6 @@
+Wed Feb  7 14:26:40 UTC 2018 - adr...@suse.de
+
+- update to 1.1.2
+  * skip repos which only provide a URL for installed prod file
+
+---

Old:

  obs-service-product_converter-1.1.1.obscpio

New:

  obs-service-product_converter-1.1.2.obscpio



Other differences:
--
++ obs-service-product_converter.spec ++
--- /var/tmp/diff_new_pack.HVfBOR/_old  2018-02-09 15:53:25.550720806 +0100
+++ /var/tmp/diff_new_pack.HVfBOR/_new  2018-02-09 15:53:25.554720663 +0100
@@ -19,7 +19,7 @@
 %define service product_converter
 
 Name:   obs-service-%service
-Version:1.1.1
+Version:1.1.2
 Release:0
 Summary:An OBS source service: create product media build descriptions
 License:GPL-2.0+
@@ -29,9 +29,6 @@
 BuildArch:  noarch
 BuildRequires:  perl(XML::Structured)
 Requires:   perl(XML::Structured)
-# temp workaround for broken provides of obs-server
-BuildRequires:  perl-XML-Structured
-Requires:   perl-XML-Structured
 # workaround for missing requires of perl-XML-structured
 BuildRequires:  perl-XML-Parser
 Requires:   perl-XML-Parser

++ _service ++
--- /var/tmp/diff_new_pack.HVfBOR/_old  2018-02-09 15:53:25.590719370 +0100
+++ /var/tmp/diff_new_pack.HVfBOR/_new  2018-02-09 15:53:25.590719370 +0100
@@ -2,8 +2,8 @@
   
 https://github.com/openSUSE/obs-service-product_converter.git
 git
-1.1.1
-1.1.1
+1.1.2
+1.1.2
   
   
   

++ obs-service-product_converter-1.1.1.obscpio -> 
obs-service-product_converter-1.1.2.obscpio ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/obs-service-product_converter-1.1.1/Build 
new/obs-service-product_converter-1.1.2/Build
--- old/obs-service-product_converter-1.1.1/Build   2018-02-09 
15:53:25.682716065 +0100
+++ new/obs-service-product_converter-1.1.2/Build   1970-01-01 
01:00:00.0 +0100
@@ -1 +0,0 @@
-symbolic link to /usr/lib/build/Build
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/obs-service-product_converter-1.1.1/create_single_product 
new/obs-service-product_converter-1.1.2/create_single_product
--- old/obs-service-product_converter-1.1.1/create_single_product   
2018-02-01 17:55:35.0 +0100
+++ new/obs-service-product_converter-1.1.2/create_single_product   
2018-02-07 15:23:19.0 +0100
@@ -1278,6 +1278,7 @@
 push @r, { 'type' => 'update', "repoid" => $obsurl };
 };
 foreach my $repo ( @{$product->{register}->{pool}->{repository}} ) {
+next unless defined($repo->{name});
 my $obsurl = "obsrepository://$obsname/$repo->{project}/$repo->{name}";
 if ($repo->{zypp}) {
die("400 zypp lacks alias attribute") unless $repo->{zypp}->{alias};

++ obs-service-product_converter.obsinfo ++
--- /var/tmp/diff_new_pack.HVfBOR/_old  2018-02-09 15:53:25.718714772 +0100
+++ /var/tmp/diff_new_pack.HVfBOR/_new  2018-02-09 15:53:25.718714772 +0100
@@ -1,5 +1,5 @@
 name: obs-service-product_converter
-version: 1.1.1
-mtime: 1517504016
-commit: 353bfb7934872e1daee14e645d6b3a412a8c48f8
+version: 1.1.2
+mtime: 1518013399
+commit: 7925b320302acb575d6a3e1c2c0b8916ffbd1127
 




commit vapoursynth for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package vapoursynth for openSUSE:Factory 
checked in at 2018-02-09 15:53:09

Comparing /work/SRC/openSUSE:Factory/vapoursynth (Old)
 and  /work/SRC/openSUSE:Factory/.vapoursynth.new (New)


Package is "vapoursynth"

Fri Feb  9 15:53:09 2018 rev:2 rq:574529 version:43

Changes:

--- /work/SRC/openSUSE:Factory/vapoursynth/vapoursynth.changes  2017-12-19 
10:51:40.301092005 +0100
+++ /work/SRC/openSUSE:Factory/.vapoursynth.new/vapoursynth.changes 
2018-02-09 15:53:15.267090189 +0100
@@ -1,0 +2,7 @@
+Fri Feb  9 08:32:43 UTC 2018 - mplus...@suse.com
+
+- Update to version 43:
+  * Mostly bugfixes and internal changes (see provided ChangeLog
+for details)
+
+---

Old:

  vapoursynth-R40.tar.gz

New:

  vapoursynth-R43.tar.gz



Other differences:
--
++ vapoursynth.spec ++
--- /var/tmp/diff_new_pack.RtXgpF/_old  2018-02-09 15:53:16.187057144 +0100
+++ /var/tmp/diff_new_pack.RtXgpF/_new  2018-02-09 15:53:16.191057001 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package vapoursynth
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   vapoursynth
-Version:40
+Version:43
 Release:0
 Summary:A video processing framework
 License:LGPL-2.1 AND OFL-1.1

++ vapoursynth-R40.tar.gz -> vapoursynth-R43.tar.gz ++
 4919 lines of diff (skipped)

++ vapoursynth-version.patch ++
--- /var/tmp/diff_new_pack.RtXgpF/_old  2018-02-09 15:53:16.427048524 +0100
+++ /var/tmp/diff_new_pack.RtXgpF/_new  2018-02-09 15:53:16.427048524 +0100
@@ -9,10 +9,10 @@
  Makefile.am |2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-Index: vapoursynth-R40/Makefile.am
+Index: vapoursynth-R43/Makefile.am
 ===
 vapoursynth-R40.orig/Makefile.am
-+++ vapoursynth-R40/Makefile.am
+--- vapoursynth-R43.orig/Makefile.am
 vapoursynth-R43/Makefile.am
 @@ -82,7 +82,7 @@ noinst_HEADERS = include/asm/x86/x86inc.
  
  pkgconfig_DATA += pc/vapoursynth.pc




commit redis for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package redis for openSUSE:Factory checked 
in at 2018-02-09 15:52:42

Comparing /work/SRC/openSUSE:Factory/redis (Old)
 and  /work/SRC/openSUSE:Factory/.redis.new (New)


Package is "redis"

Fri Feb  9 15:52:42 2018 rev:39 rq:574511 version:4.0.8

Changes:

--- /work/SRC/openSUSE:Factory/redis/redis.changes  2018-01-28 
20:33:44.833981955 +0100
+++ /work/SRC/openSUSE:Factory/.redis.new/redis.changes 2018-02-09 
15:52:54.871822767 +0100
@@ -1,0 +2,7 @@
+Thu Feb  8 23:23:58 UTC 2018 - i...@ilya.pp.ua
+
+- Update to 4.0.8
+  * Release notes: 
https://raw.githubusercontent.com/antirez/redis/4.0/00-RELEASENOTES
+  * Fix crash Redis Cluster instances during deletions.
+
+---

Old:

  redis-4.0.7.tar.gz

New:

  redis-4.0.8.tar.gz



Other differences:
--
++ redis.spec ++
--- /var/tmp/diff_new_pack.4jMKDt/_old  2018-02-09 15:52:57.091743031 +0100
+++ /var/tmp/diff_new_pack.4jMKDt/_new  2018-02-09 15:52:57.091743031 +0100
@@ -19,7 +19,7 @@
 %define _log_dir%{_localstatedir}/log/%{name}
 %define _conf_dir   %{_sysconfdir}/%{name}
 Name:   redis
-Version:4.0.7
+Version:4.0.8
 Release:0
 Summary:Persistent key-value database
 License:BSD-3-Clause

++ redis-4.0.7.tar.gz -> redis-4.0.8.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/redis-4.0.7/00-RELEASENOTES 
new/redis-4.0.8/00-RELEASENOTES
--- old/redis-4.0.7/00-RELEASENOTES 2018-01-24 11:16:18.0 +0100
+++ new/redis-4.0.8/00-RELEASENOTES 2018-02-02 17:39:14.0 +0100
@@ -11,6 +11,31 @@
 

 
 

+Redis 4.0.8 Released Fri Feb 2 11:17:40 CET 2018
+
+
+Upgrade urgency CRITICAL ONLY for Redis Cluster users. Otherwise no reason
+to upgrade at all.
+
+Redis 4.0.8 fixes a single critical bug in the radix tree data structure
+used for Redis Cluster keys slot tracking. The problem was actually fixed
+10 months ago into unstable, but it was fixed in a commit related to Streams
+so it was never backported (for error) into the 4.0 branch.
+
+The problem will crash Redis Cluster instances during deletions, but it is
+very hard to trigger: only when the node removed is in the edge of a memory
+mapped area there are the conditions to create an issue, because otherwise
+the code just accesses an out of range word in read-only way in an allocated
+structure: this is almost always harmless.
+
+The single commit in this release:
+
+f603940f Rax updated to latest antirez/rax commit. (Salvatore Sanfilippo)
+
+Cheers,
+Salvatore
+
+
 Redis 4.0.7 Released Wed Jan 24 11:01:40 CET 2018
 

 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/redis-4.0.7/src/rax.c new/redis-4.0.8/src/rax.c
--- old/redis-4.0.7/src/rax.c   2018-01-24 11:16:18.0 +0100
+++ new/redis-4.0.8/src/rax.c   2018-02-02 17:39:14.0 +0100
@@ -131,7 +131,7 @@
 }
 
 /* 
- * Radis tree implementation
+ * Radix tree implementation
  * --*/
 
 /* Allocate a new non compressed node with the specified number of children.
@@ -186,10 +186,10 @@
 void raxSetData(raxNode *n, void *data) {
 n->iskey = 1;
 if (data != NULL) {
+n->isnull = 0;
 void **ndata = (void**)
 ((char*)n+raxNodeCurrentLength(n)-sizeof(void*));
 memcpy(ndata,,sizeof(data));
-n->isnull = 0;
 } else {
 n->isnull = 1;
 }
@@ -396,6 +396,7 @@
   position to 0 to signal this node represents
   the searched key. */
 }
+debugnode("Lookup stop node is",h);
 if (stopnode) *stopnode = h;
 if (plink) *plink = parentlink;
 if (splitpos && h->iscompr) *splitpos = j;
@@ -424,18 +425,21 @@
  * our key. We have just to reallocate the node and make space for the
  * data pointer. */
 if (i == len && (!h->iscompr || j == 0 /* not in the middle if j is 0 */)) 
{
+debugf("### Insert: node representing key exists\n");
+if (!h->iskey || h->isnull) {
+h = raxReallocForData(h,data);
+if (h) 

commit nagios for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package nagios for openSUSE:Factory checked 
in at 2018-02-09 15:53:34

Comparing /work/SRC/openSUSE:Factory/nagios (Old)
 and  /work/SRC/openSUSE:Factory/.nagios.new (New)


Package is "nagios"

Fri Feb  9 15:53:34 2018 rev:6 rq:574641 version:4.3.4

Changes:

--- /work/SRC/openSUSE:Factory/nagios/nagios.changes2017-12-06 
09:00:45.524220157 +0100
+++ /work/SRC/openSUSE:Factory/.nagios.new/nagios.changes   2018-02-09 
15:53:35.662357599 +0100
@@ -1,0 +2,6 @@
+Tue Jan 30 09:16:07 UTC 2018 - o...@botter.cc
+
+- fix upstream issue #455, memleak introduced with 4.3.3
+  nagios-4.3.4-fix_memleak_4.3.3.diff
+
+---

New:

  nagios-4.3.4-fix_memleak_4.3.3.diff



Other differences:
--
++ nagios.spec ++
--- /var/tmp/diff_new_pack.OptTCK/_old  2018-02-09 15:53:37.010309181 +0100
+++ /var/tmp/diff_new_pack.OptTCK/_new  2018-02-09 15:53:37.010309181 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package nagios
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -64,6 +64,8 @@
 Patch17:nagios-4.1.0-add_KOHANNA.conf
 # PATCH-FIX-UPSTREAM allow ppc64le builds in contrib Makefile
 Patch18:nagios-4.2.2-enable-ppc64le.patch
+# PATCH-FIX-UPSTREAM fix memleak in macros.c introduced with 4.3.3
+Patch19:nagios-4.3.4-fix_memleak_4.3.3.diff
 BuildRequires:  doxygen
 # yes: we still build for SLE10
 %if 0%{?suse_version} > 1020
@@ -237,6 +239,7 @@
 %patch16 -p1
 %patch17 -p1
 %patch18 -p1
+%patch19 -p1
 find -name ".gitignore" | xargs rm
 # fixing permissions the dirty way
 chmod 644 Changelog LEGAL LICENSE README sample-config/README 
sample-config/template-object/README

++ nagios-4.3.4-fix_memleak_4.3.3.diff ++
diff --git a/common/macros.c b/common/macros.c
index c864939c..b98c9d43 100644
--- a/common/macros.c
+++ b/common/macros.c
@@ -2954,6 +2954,7 @@ int clear_service_macros_r(nagios_macros *mac) {
my_free(mac->x[MACRO_SERVICEACTIONURL]);
my_free(mac->x[MACRO_SERVICENOTESURL]);
my_free(mac->x[MACRO_SERVICENOTES]);
+   my_free(mac->x[MACRO_SERVICEINFOURL]);
 
my_free(mac->x[MACRO_SERVICEGROUPNAMES]);
 
@@ -2977,6 +2978,7 @@ int clear_host_macros_r(nagios_macros *mac) {
my_free(mac->x[MACRO_HOSTACTIONURL]);
my_free(mac->x[MACRO_HOSTNOTESURL]);
my_free(mac->x[MACRO_HOSTNOTES]);
+   my_free(mac->x[MACRO_HOSTINFOURL]);
 
/* numbers or by necessity autogenerated strings */
my_free(mac->x[MACRO_HOSTGROUPNAMES]);



commit python-kerberos for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package python-kerberos for openSUSE:Factory 
checked in at 2018-02-09 15:53:17

Comparing /work/SRC/openSUSE:Factory/python-kerberos (Old)
 and  /work/SRC/openSUSE:Factory/.python-kerberos.new (New)


Package is "python-kerberos"

Fri Feb  9 15:53:17 2018 rev:3 rq:574530 version:1.2.5

Changes:

--- /work/SRC/openSUSE:Factory/python-kerberos/python-kerberos.changes  
2015-07-21 13:29:10.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-kerberos.new/python-kerberos.changes 
2018-02-09 15:53:19.018955425 +0100
@@ -1,0 +2,9 @@
+Wed Dec 20 09:43:38 UTC 2017 - dmuel...@suse.com
+
+- update to 1.2.5
+  * no changelog available
+- convert to singlespec
+- drop 0001-Initialise-pydelegatestate-variable-to-NULL.patch:
+  already upstream
+
+---

Old:

  0001-Initialise-pydelegatestate-variable-to-NULL.patch
  kerberos-1.2.2.tar.gz

New:

  kerberos-1.2.5.tar.gz



Other differences:
--
++ python-kerberos.spec ++
--- /var/tmp/diff_new_pack.zde6TF/_old  2018-02-09 15:53:19.906923529 +0100
+++ /var/tmp/diff_new_pack.zde6TF/_new  2018-02-09 15:53:19.906923529 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-kerberos
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,22 +16,22 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
+%bcond_without test
 Name:   python-kerberos
-Version:1.2.2
+Version:1.2.5
 Release:0
 Summary:Kerberos high-level interface
 License:Apache-2.0
 Group:  Development/Languages/Python
 Url:http://www.calendarserver.org/
-Source: 
https://pypi.python.org/packages/source/k/kerberos/kerberos-%{version}.tar.gz
-Patch1: 0001-Initialise-pydelegatestate-variable-to-NULL.patch
-BuildRequires:  krb5-devel
-BuildRequires:  python-devel
-BuildRequires:  python-setuptools
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110
-%{!?python_sitearch: %global python_sitearch %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
-%endif
+Source: 
https://files.pythonhosted.org/packages/source/k/kerberos/kerberos-%{version}.tar.gz
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module setuptools}
+BuildRequires:  fdupes
+BuildRequires:  krb5-mini-devel
+BuildRequires:  python-rpm-macros
+%python_subpackages
 
 %description
 A high-level wrapper for Kerberos (GSSAPI) operations.
@@ -42,17 +42,18 @@
 
 %prep
 %setup -q -n kerberos-%{version}
-%patch1 -p1
 
 %build
-CFLAGS="%{optflags}" python setup.py build
+export CFLAGS="%{optflags}"
+%python_build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+%python_install
+%python_expand %fdupes %{buildroot}%{$python_sitearch}
 
-%files
+%files %{python_files}
 %defattr(-,root,root,-)
-%doc LICENSE README.rst
+%doc README.rst
 %{python_sitearch}/*
 
 %changelog

++ kerberos-1.2.2.tar.gz -> kerberos-1.2.5.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kerberos-1.2.2/LICENSE new/kerberos-1.2.5/LICENSE
--- old/kerberos-1.2.2/LICENSE  2015-03-26 19:31:17.0 +0100
+++ new/kerberos-1.2.5/LICENSE  1970-01-01 01:00:00.0 +0100
@@ -1,202 +0,0 @@
-
- Apache License
-   Version 2.0, January 2004
-http://www.apache.org/licenses/
-
-   TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
-
-   1. Definitions.
-
-  "License" shall mean the terms and conditions for use, reproduction,
-  and distribution as defined by Sections 1 through 9 of this document.
-
-  "Licensor" shall mean the copyright owner or entity authorized by
-  the copyright owner that is granting the License.
-
-  "Legal Entity" shall mean the union of the acting entity and all
-  other entities that control, are controlled by, or are under common
-  control with that entity. For the purposes of this definition,
-  "control" means (i) the power, direct or indirect, to cause the
-  direction or management of such entity, whether by contract or
-  otherwise, or (ii) ownership of fifty percent (50%) or more of the
-  outstanding shares, or (iii) beneficial ownership of such entity.
-
-  "You" (or "Your") shall mean an individual or Legal Entity
-  

commit python-repoze.who for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package python-repoze.who for 
openSUSE:Factory checked in at 2018-02-09 15:52:34

Comparing /work/SRC/openSUSE:Factory/python-repoze.who (Old)
 and  /work/SRC/openSUSE:Factory/.python-repoze.who.new (New)


Package is "python-repoze.who"

Fri Feb  9 15:52:34 2018 rev:3 rq:574452 version:2.3

Changes:

--- /work/SRC/openSUSE:Factory/python-repoze.who/python-repoze.who.changes  
2017-07-11 08:27:15.467494402 +0200
+++ /work/SRC/openSUSE:Factory/.python-repoze.who.new/python-repoze.who.changes 
2018-02-09 15:52:34.412557634 +0100
@@ -1,0 +2,5 @@
+Fri Feb  9 05:28:37 UTC 2018 - tbecht...@suse.com
+
+- Add missing BuildRequires for doc build
+
+---



Other differences:
--
++ python-repoze.who.spec ++
--- /var/tmp/diff_new_pack.fDTJvQ/_old  2018-02-09 15:52:35.208529044 +0100
+++ /var/tmp/diff_new_pack.fDTJvQ/_new  2018-02-09 15:52:35.208529044 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-repoze.who
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -32,6 +32,7 @@
 BuildRequires:  %{python_module WebOb}
 BuildRequires:  %{python_module devel}
 BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module repoze.sphinx.autointerface}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  %{python_module zope.interface}
 BuildRequires:  fdupes




commit python-node-semver for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package python-node-semver for 
openSUSE:Factory checked in at 2018-02-09 15:52:57

Comparing /work/SRC/openSUSE:Factory/python-node-semver (Old)
 and  /work/SRC/openSUSE:Factory/.python-node-semver.new (New)


Package is "python-node-semver"

Fri Feb  9 15:52:57 2018 rev:2 rq:574520 version:0.3.0

Changes:

--- /work/SRC/openSUSE:Factory/python-node-semver/python-node-semver.changes
2018-01-10 23:33:17.453308301 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-node-semver.new/python-node-semver.changes   
2018-02-09 15:53:04.535475659 +0100
@@ -1,0 +2,7 @@
+Fri Feb  9 08:22:03 UTC 2018 - mplus...@suse.com
+
+- Update to version 0.3.0:
+  * drop python2.x support
+  * bug fix, Add sort key function #14
+
+---

Old:

  python-node-semver-0.2.0.tar.gz

New:

  python-node-semver-0.3.0.tar.gz



Other differences:
--
++ python-node-semver.spec ++
--- /var/tmp/diff_new_pack.jvbUHX/_old  2018-02-09 15:53:06.031421926 +0100
+++ /var/tmp/diff_new_pack.jvbUHX/_new  2018-02-09 15:53:06.035421783 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-node-semver
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,16 +16,17 @@
 #
 
 
+%define skip_python2 1
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-node-semver
-Version:0.2.0
+Version:0.3.0
 Release:0
 Summary:Port of node-semver
 License:MIT
 Group:  Development/Languages/Python
-Url:https://github.com/podhmo/python-semver
+URL:https://github.com/podhmo/python-semver
 Source: 
https://github.com/podhmo/python-semver/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
-BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module base}
 BuildRequires:  %{python_module pytest}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes

++ python-node-semver-0.2.0.tar.gz -> python-node-semver-0.3.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/python-semver-0.2.0/.travis.yml 
new/python-semver-0.3.0/.travis.yml
--- old/python-semver-0.2.0/.travis.yml 2017-09-13 18:29:36.0 +0200
+++ new/python-semver-0.3.0/.travis.yml 2018-01-13 04:53:03.0 +0100
@@ -1,6 +1,5 @@
 language: python
 python:
-  - "2.7"
   - "3.4"
   - "3.5"
   - "3.6"
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/python-semver-0.2.0/CHANGES.txt 
new/python-semver-0.3.0/CHANGES.txt
--- old/python-semver-0.2.0/CHANGES.txt 2017-09-13 18:29:36.0 +0200
+++ new/python-semver-0.3.0/CHANGES.txt 2018-01-13 04:53:03.0 +0100
@@ -1 +1,4 @@
+0.3.0
 
+- drop python2.x support
+- bug fix, Add sort key function #14
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/python-semver-0.2.0/README.rst 
new/python-semver-0.3.0/README.rst
--- old/python-semver-0.2.0/README.rst  2017-09-13 18:29:36.0 +0200
+++ new/python-semver-0.3.0/README.rst  2018-01-13 04:53:03.0 +0100
@@ -6,7 +6,17 @@
 
 python version of [node-semver](https://github.com/isaacs/node-semver)
 
-.. code:: python
+install
+
+
+.. code-block:: console
+
+   pip install node-semver
+
+examples
+
+
+.. code-block:: python
 
# -*- coding:utf-8 -*-
from semver import max_satisfying
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/python-semver-0.2.0/demo.py 
new/python-semver-0.3.0/demo.py
--- old/python-semver-0.2.0/demo.py 2017-09-13 18:29:36.0 +0200
+++ new/python-semver-0.3.0/demo.py 1970-01-01 01:00:00.0 +0100
@@ -1,16 +0,0 @@
-# -*- coding:utf-8 -*-
-from semver import max_satisfying
-
-versions = ['1.2.3', '1.2.4', '1.2.5', '1.2.6', '2.0.1']
-range_ = '~1.2.3'
-assert max_satisfying(versions, range_, loose=False) == '1.2.6'
-
-
-versions = ['1.1.0', '1.2.0', '1.2.1', '1.3.0', '2.0.0b1', '2.0.0b2', 
'2.0.0b3', '2.0.0', '2.1.0']
-range_ = '~2.0.0'
-assert max_satisfying(versions, range_, loose=True) == '2.0.0'
-
-try:
-(max_satisfying(versions, range_, loose=False) == '2.0.0')
-except ValueError as e:
-assert e.args[0] == "Invalid Version: 2.0.0b1"
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 

commit python-restkit for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package python-restkit for openSUSE:Factory 
checked in at 2018-02-09 15:52:23

Comparing /work/SRC/openSUSE:Factory/python-restkit (Old)
 and  /work/SRC/openSUSE:Factory/.python-restkit.new (New)


Package is "python-restkit"

Fri Feb  9 15:52:23 2018 rev:12 rq:574450 version:4.2.2

Changes:

--- /work/SRC/openSUSE:Factory/python-restkit/python-restkit.changes
2013-11-25 16:03:41.0 +0100
+++ /work/SRC/openSUSE:Factory/.python-restkit.new/python-restkit.changes   
2018-02-09 15:52:32.160638519 +0100
@@ -1,0 +2,5 @@
+Fri Feb  9 05:26:03 UTC 2018 - tbecht...@suse.com
+
+- Set PYTHONPATH to fix doc build
+
+---



Other differences:
--
++ python-restkit.spec ++
--- /var/tmp/diff_new_pack.iOsvCe/_old  2018-02-09 15:52:33.956574012 +0100
+++ /var/tmp/diff_new_pack.iOsvCe/_new  2018-02-09 15:52:33.960573868 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-restkit
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -55,6 +55,7 @@
 %build
 python setup.py build
 cd doc
+export PYTHONPATH=../
 make html && rm -r _build/html/.buildinfo
 
 %install




commit pan for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package pan for openSUSE:Factory checked in 
at 2018-02-09 15:53:06

Comparing /work/SRC/openSUSE:Factory/pan (Old)
 and  /work/SRC/openSUSE:Factory/.pan.new (New)


Package is "pan"

Fri Feb  9 15:53:06 2018 rev:3 rq:574522 version:0.144

Changes:

--- /work/SRC/openSUSE:Factory/pan/pan.changes  2018-01-22 16:20:48.395512652 
+0100
+++ /work/SRC/openSUSE:Factory/.pan.new/pan.changes 2018-02-09 
15:53:07.287376814 +0100
@@ -1,0 +2,5 @@
+Thu Feb  8 09:34:12 UTC 2018 - ok...@suse.com
+
+- Adapt license file location according to new suggestion around %license
+
+---



Other differences:
--
++ pan.spec ++
--- /var/tmp/diff_new_pack.T4WCoU/_old  2018-02-09 15:53:08.215343482 +0100
+++ /var/tmp/diff_new_pack.T4WCoU/_new  2018-02-09 15:53:08.219343338 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package pan
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -22,7 +22,7 @@
 Summary:A Newsreader for GNOME
 License:GPL-2.0+
 Group:  Productivity/Networking/News/Clients
-URL:http://pan.rebelbase.com/
+Url:http://pan.rebelbase.com/
 Source0:
http://pan.rebelbase.com/download/releases/%{version}/source/%{name}-%{version}.tar.bz2
 
 BuildRequires:  fdupes
@@ -68,7 +68,8 @@
 %fdupes %{buildroot}/%{_prefix}
 
 %files
-%doc AUTHORS COPYING COPYING-DOCS NEWS README
+%license COPYING COPYING-DOCS
+%doc AUTHORS NEWS README
 %doc %{_datadir}/help/C/%{name}/
 %{_mandir}/man?/pan.?%{ext_man}
 %{_bindir}/%{name}




commit python-pathtools for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package python-pathtools for 
openSUSE:Factory checked in at 2018-02-09 15:52:18

Comparing /work/SRC/openSUSE:Factory/python-pathtools (Old)
 and  /work/SRC/openSUSE:Factory/.python-pathtools.new (New)


Package is "python-pathtools"

Fri Feb  9 15:52:18 2018 rev:8 rq:574449 version:0.1.2

Changes:

--- /work/SRC/openSUSE:Factory/python-pathtools/python-pathtools.changes
2017-04-28 10:52:19.563241398 +0200
+++ /work/SRC/openSUSE:Factory/.python-pathtools.new/python-pathtools.changes   
2018-02-09 15:52:23.904935048 +0100
@@ -1,0 +2,5 @@
+Fri Feb  9 05:23:46 UTC 2018 - tbecht...@suse.com
+
+- Do not require the Flask sphinx theme for doc build
+
+---



Other differences:
--
++ python-pathtools.spec ++
--- /var/tmp/diff_new_pack.8NlZvU/_old  2018-02-09 15:52:24.568911200 +0100
+++ /var/tmp/diff_new_pack.8NlZvU/_new  2018-02-09 15:52:24.568911200 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-pathtools
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -40,6 +40,7 @@
 %prep
 %setup -q -n pathtools-%{version}
 sed -i "1d" pathtools/path.py pathtools/patterns.py
+sed -i "s/^html_theme.*/#html_theme/" docs/source/conf.py
 
 %build
 %python_build




commit adminer for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package adminer for openSUSE:Factory checked 
in at 2018-02-09 15:52:15

Comparing /work/SRC/openSUSE:Factory/adminer (Old)
 and  /work/SRC/openSUSE:Factory/.adminer.new (New)


Package is "adminer"

Fri Feb  9 15:52:15 2018 rev:13 rq:574448 version:4.6.1

Changes:

--- /work/SRC/openSUSE:Factory/adminer/adminer.changes  2018-02-06 
16:49:27.363220786 +0100
+++ /work/SRC/openSUSE:Factory/.adminer.new/adminer.changes 2018-02-09 
15:52:17.997147244 +0100
@@ -1,0 +2,62 @@
+Fri Feb 09 04:23:08 UTC 2018 - ji...@boombatower.com
+
+- Update to version 4.6.1:
+  * Release 4.6.1
+  * Round 9.2 to 9.2
+  * MariaDB: Links to documentation in syntax highlighting
+  * Display notification about performing action after relogin
+  * Reorder changes
+  * Allow specifying server name displayed in breadcrumbs
+  * MariaDB: Links to documentation
+  * Reorder changes
+  * Remove .lcZ from timeFormat (bug #593)
+  * Add todo
+  * Add more system tables help links
+  * Respect empty tableName in tablesPrint
+  * Use tableName() in table.inc.php
+  * Avoid qsl in a loop
+  * Support Shift+click in server export
+  * Avoid qsl in a loop
+  * Sticky position of table actions
+  * Document regression
+  * Avoid qsl in check[]
+  * Avoid qsl in a loop
+  * Mark optional parameter
+  * SQLite: Support ` in PRIMARY KEY
+  * Avoid Invalid credentials with no credentials
+  * SQLite: Allow deleting PRIMARY KEY from tables with auto increment
+  * Do not wrap alter table thead
+  * Add version() to use in plugins
+  * Select original if nothing else is selected
+  * Remove nested array
+  * Support connecting to MySQL via SSL
+  * Display Invalid credentials if connection error is empty
+  * Delete unused functions
+  * Ignore functions in Min_Driver
+  * Remove unnecessary quotes
+  * Add truncate_sql to PostgreSQL
+  * PostgreSQL: Unescape bytea fields
+  * Save bytes
+  * Add missing function to compile.php
+  * PostgreSQL: Upload binary files to bytea fields
+  * Allow using number_type() as pattern
+  * Translate thousands separator in JS
+  * Editor: Use type=search for Search tables
+  * Move tableCheck() below 
+  * Pass operator from db.inc.php
+  * PostgreSQL: Cast to string when searching using LIKE (bug #325)
+  * MySQL: Support non-utf8 charset in search in column
+  * Use ST_GeomFromText in MySQL 8 (bug #574)
+  * Do not modify $_GET["where"]
+  * Display empty operator as LIKE %%
+  * Fix whitespace
+  * Avoid deprecated each()
+  * PostgreSQL: Fix condition for selecting no rows
+  * Fix error display in Search tables
+  * PostgreSQL: Don't treat interval type as number (bug #474)
+  * Pass required parameter
+  * Use existing variable
+  * Add class to use in designs
+  * Use primary key instead of LIMIT 1 if available
+
+---

Old:

  adminer-4.6.0.tar.xz

New:

  adminer-4.6.1.tar.xz



Other differences:
--
++ adminer.spec ++
--- /var/tmp/diff_new_pack.AJfoJF/_old  2018-02-09 15:52:19.561091071 +0100
+++ /var/tmp/diff_new_pack.AJfoJF/_new  2018-02-09 15:52:19.565090926 +0100
@@ -22,7 +22,7 @@
 %bcond_with mongodb
 %bcond_with mssql
 Name:   adminer
-Version:4.6.0
+Version:4.6.1
 Release:0
 Summary:Database management in a single PHP file
 License:GPL-2.0 OR Apache-2.0

++ _service ++
--- /var/tmp/diff_new_pack.AJfoJF/_old  2018-02-09 15:52:19.601089634 +0100
+++ /var/tmp/diff_new_pack.AJfoJF/_new  2018-02-09 15:52:19.605089491 +0100
@@ -2,7 +2,7 @@
   
 @PARENT_TAG@
 v(.*)
-refs/tags/v4.6.0
+refs/tags/v4.6.1
 https://github.com/vrana/adminer.git
 git
 enable

++ _servicedata ++
--- /var/tmp/diff_new_pack.AJfoJF/_old  2018-02-09 15:52:19.629088628 +0100
+++ /var/tmp/diff_new_pack.AJfoJF/_new  2018-02-09 15:52:19.629088628 +0100
@@ -1,6 +1,6 @@
 
   
 https://github.com/vrana/adminer.git
-d2ed0f7810e4f05a2fc6348286b622abf6464751
+800fbb9b9e4a617a94307a2e83cca85c871c0fbd
   
 

++ adminer-4.6.0.tar.xz -> adminer-4.6.1.tar.xz ++
 1924 lines of diff (skipped)




commit digikam for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2018-02-09 15:51:52

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Fri Feb  9 15:51:52 2018 rev:168 rq:574411 version:5.8.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2018-01-30 
15:42:56.186714767 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2018-02-09 
15:51:54.749982225 +0100
@@ -1,0 +2,13 @@
+Thu Feb  8 13:19:01 UTC 2018 - stefan.bru...@rwth-aachen.de
+
+- Drop xorg-x11-devel BuildRequires, all x11 dependencies are
+  via Qt and covered by the Qt5* BuildRequires
+- Drop BuildRequires on gphoto binary, the version is discovered
+  using pkgconfig now.
+
+---
+Thu Feb  8 13:08:46 UTC 2018 - stefan.bru...@rwth-aachen.de
+
+- Rebase 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.elXO5n/_old  2018-02-09 15:51:57.517882810 +0100
+++ /var/tmp/diff_new_pack.elXO5n/_new  2018-02-09 15:51:57.517882810 +0100
@@ -65,10 +65,7 @@
 BuildRequires:  libexiv2-devel >= 0.26
 BuildRequires:  libexpat-devel
 BuildRequires:  libgcrypt-devel
-BuildRequires:  libgphoto2-devel >= 2.4.0
-# It invokes "gphoto2" for determining the API version
 BuildRequires:  QtAV-devel >= 1.11
-BuildRequires:  gphoto
 BuildRequires:  libgpod-devel
 BuildRequires:  libjasper-devel
 BuildRequires:  libkdcraw-devel >= 15.12.0
@@ -91,7 +88,6 @@
 BuildRequires:  opencv-devel
 BuildRequires:  threadweaver-devel >= 5.1.0
 BuildRequires:  update-desktop-files
-BuildRequires:  xorg-x11-devel
 BuildRequires:  cmake(KF5CalendarCore)
 BuildRequires:  pkgconfig(Qt5Concurrent)
 BuildRequires:  pkgconfig(Qt5Core) >= 5.6.0
@@ -102,6 +98,7 @@
 BuildRequires:  pkgconfig(Qt5WebKitWidgets)
 BuildRequires:  pkgconfig(Qt5X11Extras)
 BuildRequires:  pkgconfig(Qt5XmlPatterns)
+BuildRequires:  pkgconfig(libgphoto2) >= 2.4.0
 Requires:   kipi-plugins >= %{version}
 Recommends: %{name}-doc
 Recommends: %{name}-lang

++ 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch ++
--- /var/tmp/diff_new_pack.elXO5n/_old  2018-02-09 15:51:57.537882092 +0100
+++ /var/tmp/diff_new_pack.elXO5n/_new  2018-02-09 15:51:57.537882092 +0100
@@ -21,7 +21,7 @@
 index cd482ea..bc3772b 100644
 --- a/core/CMakeLists.txt
 +++ b/core/CMakeLists.txt
-@@ -278,7 +278,7 @@ find_package(Marble)
+@@ -290,7 +290,7 @@ find_package(Marble)
  find_package(PkgConfig)
  find_package(Jasper)
  find_package(Eigen3)   # For Refocus tool.




commit sysdig for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package sysdig for openSUSE:Factory checked 
in at 2018-02-09 15:51:50

Comparing /work/SRC/openSUSE:Factory/sysdig (Old)
 and  /work/SRC/openSUSE:Factory/.sysdig.new (New)


Package is "sysdig"

Fri Feb  9 15:51:50 2018 rev:18 rq:574405 version:0.20.0

Changes:

--- /work/SRC/openSUSE:Factory/sysdig/sysdig.changes2017-10-10 
11:42:32.500643852 +0200
+++ /work/SRC/openSUSE:Factory/.sysdig.new/sysdig.changes   2018-02-09 
15:51:51.526098018 +0100
@@ -1,0 +2,16 @@
+Thu Feb  8 21:05:25 UTC 2018 - mplus...@suse.com
+
+- Update to version 0.20.0:
+  * Use dithered boxes to increase the number of available colors for 
spectrogram/subsecoffset views [#961] [#963] [#966]
+  * Add the ability to log json parse errors to a separate log file [#975] 
[#981] [#990]
+  * Update the embedded jsonpp implementation to 0.10.6 [#975] [#982]
+  * Reduce inactive container scan time from 20 minutes to 30 seconds [#985]
+  * Added the ability to parse and represent RAW sockets [#991]
+  * Handle finit_module syscall [#996] [#1001]
+  * Add error message when scap_open() is called with incorrect mode [#997]
+  * Use explicit versions for all Docker API Endpoints [#1000]
+  * Report more detailed errors when PPM_IOCTL_GET_N_TRACEPOINT_HIT fails 
[#1016]
+  * Add support for bpf/seccomp syscalls [#1031] [#1033]
+  * When trying to build the kernel module using dkms fails, include dkms.log 
output along with the failure [#1038]
+
+---

Old:

  sysdig-0.19.1.tar.gz

New:

  sysdig-0.20.0.tar.gz



Other differences:
--
++ sysdig.spec ++
--- /var/tmp/diff_new_pack.EH6UgV/_old  2018-02-09 15:51:52.626058511 +0100
+++ /var/tmp/diff_new_pack.EH6UgV/_new  2018-02-09 15:51:52.630058367 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package sysdig
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   sysdig
-Version:0.19.1
+Version:0.20.0
 Release:0
 Summary:System-level exploration
 License:GPL-2.0

++ sysdig-0.19.1.tar.gz -> sysdig-0.20.0.tar.gz ++
 8240 lines of diff (skipped)




commit 389-ds for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package 389-ds for openSUSE:Factory checked 
in at 2018-02-09 15:52:09

Comparing /work/SRC/openSUSE:Factory/389-ds (Old)
 and  /work/SRC/openSUSE:Factory/.389-ds.new (New)


Package is "389-ds"

Fri Feb  9 15:52:09 2018 rev:14 rq:57 version:1.4.0.3

Changes:

--- /work/SRC/openSUSE:Factory/389-ds/389-ds.changes2018-01-31 
19:54:27.522314643 +0100
+++ /work/SRC/openSUSE:Factory/.389-ds.new/389-ds.changes   2018-02-09 
15:52:14.073288180 +0100
@@ -1,0 +2,5 @@
+Fri Feb  2 01:31:25 UTC 2018 - mrueck...@suse.de
+
+- switch lib389 to use the python3-ldap subpackage
+
+---
@@ -27,0 +33,5 @@
+
+---
+Sun Jan 14 02:59:15 UTC 2018 - mrueck...@suse.de
+
+- add tw.patch to fix potential buffer overflow

New:

  tw.patch



Other differences:
--
++ 389-ds.spec ++
--- /var/tmp/diff_new_pack.y7TvW4/_old  2018-02-09 15:52:15.921221807 +0100
+++ /var/tmp/diff_new_pack.y7TvW4/_new  2018-02-09 15:52:15.925221663 +0100
@@ -57,6 +57,7 @@
 Patch2: 0002-use-python2-for-selinux-detection.patch
 Patch3: 0003-fix-rm-non-existent-man-pages.patch
 Patch4: simplify-lib389-setup-py.patch
+Patch5: tw.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  autoconf
 BuildRequires:  automake
@@ -78,6 +79,7 @@
 BuildRequires:  %{python_module devel}
 BuildRequires:  %{python_module setuptools}
 %if %{with lib389}
+BuildRequires:  %{python_module ldap >= 3.0}
 BuildRequires:  %{python_module pyasn1-modules}
 BuildRequires:  %{python_module pyasn1}
 BuildRequires:  %{python_module python-dateutil}
@@ -154,7 +156,6 @@
 Group:  System/Daemons
 Requires:   %{name} = %{version}
 
-# upgrade path from monolithic %{name} (including -libs & -devel) to %{name} + 
%{name}-snmp
 Obsoletes:  %{name} <= 1.3.6.2
 
 %description  snmp
@@ -164,9 +165,9 @@
 %package -n lib389
 Summary:Python library for interacting with the 389 Directory Server
 Group:  Development/Languages/Python
+Requires:   %{use_python}-ldap >= 3.0
 Requires:   %{use_python}-pyasn1
 Requires:   %{use_python}-pyasn1-modules
-Requires:   %{use_python}-pyldap
 Requires:   %{use_python}-python-dateutil
 Requires:   %{use_python}-six
 Requires:   krb5
@@ -187,6 +188,7 @@
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %build
 # Make sure python3 is used in shebangs
@@ -196,7 +198,7 @@
 # TODO:
 # seems to have no effect --enable-perl \
 # warning that it might lead to instabilities --with-journald \
-
+touch docs/custom.css
 autoreconf -fi
 export CFLAGS="%{optflags}" # -std=gnu99"
 %configure \

++ tw.patch ++
diff --git a/src/libsds/sds/bpt/map.c b/src/libsds/sds/bpt/map.c
index 096a38bcc..ab7d38a42 100644
--- a/src/libsds/sds/bpt/map.c
+++ b/src/libsds/sds/bpt/map.c
@@ -332,7 +332,7 @@ sds_bptree_display(sds_bptree_instance *binst)
 {
 sds_result result = SDS_SUCCESS;
 
-char *path = malloc(sizeof(char) * 20);
+char *path = malloc(sizeof(char) * 32);
 #ifdef SDS_DEBUG
 sds_log("sds_bptree_display", "Writing step %03d\n", binst->print_iter);
 #endif



commit sbd for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package sbd for openSUSE:Factory checked in 
at 2018-02-09 15:52:03

Comparing /work/SRC/openSUSE:Factory/sbd (Old)
 and  /work/SRC/openSUSE:Factory/.sbd.new (New)


Package is "sbd"

Fri Feb  9 15:52:03 2018 rev:22 rq:574442 version:1.3.1+20180202.cc3e4cb

Changes:

--- /work/SRC/openSUSE:Factory/sbd/sbd.changes  2018-02-06 16:48:56.360671447 
+0100
+++ /work/SRC/openSUSE:Factory/.sbd.new/sbd.changes 2018-02-09 
15:52:04.245641167 +0100
@@ -1,0 +2,6 @@
+Mon Feb  5 20:29:02 UTC 2018 - jeng...@inai.de
+
+- Combine %service_* calls to reduce amount of generated code.
+- Use %make_install, and make sure directories are owned.
+
+---



Other differences:
--
++ sbd.spec ++
--- /var/tmp/diff_new_pack.xnmhNL/_old  2018-02-09 15:52:05.929580683 +0100
+++ /var/tmp/diff_new_pack.xnmhNL/_new  2018-02-09 15:52:05.933580539 +0100
@@ -49,7 +49,6 @@
 %{?systemd_requires}
 
 %description
-
 This package contains the storage-based death functionality.
 
 %prep
@@ -61,7 +60,7 @@
 make %{?_smp_mflags}
 
 %install
-make DESTDIR=%{buildroot} LIBDIR=%{_libdir} install
+%make_install LIBDIR=%{_libdir}
 install -D -m 0755 src/sbd.sh %{buildroot}%{_datadir}/sbd/sbd.sh
 install -D -m 0644 src/sbd.service %{buildroot}/%{_unitdir}/sbd.service
 install -D -m 0644 src/sbd_remote.service 
%{buildroot}/%{_unitdir}/sbd_remote.service
@@ -71,28 +70,24 @@
 install -m 0644 src/sbd.sysconfig %{buildroot}%{_fillupdir}/sysconfig.sbd
 
 %post
-%service_add_post sbd.service
-%service_add_post sbd_remote.service
+%service_add_post sbd.service sbd_remote.service
 
 if [ ! -e %{_sysconfdir}/sysconfig/sbd ]; then
 %fillup_only sbd
 fi
 
 %pre
-%service_add_pre sbd.service
-%service_add_pre sbd_remote.service
+%service_add_pre sbd.service sbd_remote.service
 
 %preun
-%service_del_preun -n sbd.service
-%service_del_preun -n sbd_remote.service
+%service_del_preun -n sbd.service sbd_remote.service
 
 %postun
-%service_del_postun -n sbd.service
-%service_del_postun -n sbd_remote.service
+%service_del_postun -n sbd.service sbd_remote.service
 
 %files
 %defattr(-,root,root)
-%{_libdir}/stonith/plugins/external/sbd
+%{_libdir}/stonith/
 %{_sbindir}/sbd
 %{_sbindir}/rcsbd
 %{_sbindir}/rcsbd_remote




commit python-humanfriendly for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package python-humanfriendly for 
openSUSE:Factory checked in at 2018-02-09 15:51:56

Comparing /work/SRC/openSUSE:Factory/python-humanfriendly (Old)
 and  /work/SRC/openSUSE:Factory/.python-humanfriendly.new (New)


Package is "python-humanfriendly"

Fri Feb  9 15:51:56 2018 rev:4 rq:574413 version:4.8

Changes:

--- 
/work/SRC/openSUSE:Factory/python-humanfriendly/python-humanfriendly.changes
2017-09-11 16:18:02.428731047 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-humanfriendly.new/python-humanfriendly.changes
   2018-02-09 15:52:02.221713860 +0100
@@ -1,0 +2,103 @@
+Thu Feb  8 21:59:46 UTC 2018 - adrian.glaub...@suse.com
+
+- Update to version 4.8
+  * Add coerce_pattern() function
+  * Improve code consistency
+- From version 4.7
+  * Support background colors and 256 color mode
+  * Tests for output(), message() and warning()
+- From version 4.6
+  * Support for bright terminal colors
+- From version 4.5
+  * Extend byte ranges, add RAM output to command line
+- From version 4.4.2
+  * Reduce clock source sensitivity* (MacOS on Travis CI)
+  * Fix `Double requirement given' error
+  * Try to fix Python 2.6 tests on Travis CI
+  * Change Sphinx documentation theme
+  * Bump copyright
+  * Try to enable MacOS builds on Travis CI
+  * Fix ImportError exception on Windows
+- From version 4.4.1
+  * Include docs to sdist
+  * PEP-8 fail
+  * Change cli test from 1.05 mm to 1.05 km
+  * Another correction to test_cli
+  * Corrected CLI format_length test
+  * Aim for more CLI coverage
+  * Add CLI tests for format-byte
+  * Added size test cases
+  * Size 1z is now valid
+- From version 4.4
+  * Add touch() to __all__
+  * Make touch() create intermediate directories
+  * Add humanfriendly.testing.touch() function
+- From version 4.3
+  * Don't log duplicate output in run_cli()
+- From version 4.2
+  * Reconfigure logging in run_cli()
+- From version 4.1
+  * Always log stderr as well in run_cli()
+- From version 4.0
+  * Improve humanfriendly.testing.run_cli() (backwards incompatible)
+- From version 3.8
+  * Make it easy to mock the $HOME directory
+- From version 3.7
+  * Customizable skipping of tests
+  * Added .pyc to .gitignore
+  * Added Exa, Zetta & Yotta prefixes and tests
+  * Added -S --format-bytes option to use powers of 1024 rather than 1000 from 
command line.
+- From version 3.6.1
+  * Improve robustness of Patched{Attribute,Item}
+- From version 3.6
+  * Make retry limit configurable
+  * Refactor makefile and Travis CI configuration
+- From version 3.5
+  * Bug fix for TestCase.assertRaises()
+  * Enhance TestCase.assertRaises()
+- From version 3.4.1
+  * Bug fix for Python 3 syntax incompatibility
+- From version 3.4
+  * Promote command line test function to public API
+- From version 3.3
+  * Add humanfriendly.testing module (unittest helpers)
+  * Add humanfriendly.text.random_string() function
+  * Define humanfriendly.text.__all__
+  * Reorder functions in humanfriendly.text alphabetically
+- From version 3.2
+  * Auto-encode terminal output to avoid encoding errors
+  * Remove unused import
+- From version 3.1
+  * Improve usage message parsing and rendering
+- From version 3.0
+  * Add Python 3.6 to tested versions
+  * Silence flake8 complaints
+  * Add min, mins tests
+  * Support min, mins abbreviations for minutes
+- From version 2.4
+  * Restore Python 3 compatibility
+  * Make usage() and show_pager() more user friendly
+  * Remove redundant :py: prefixes in docstrings
+  * Improve docstrings in setup.py
+- From version 2.3.2
+  * Bug fix: Don't hard code conditional dependencies in wheels
+- From version 2.3.1
+  * Fix parse_usage() tripping up on commas in option labels
+  * Break test suite to reproduce parse_usage() bug
+- From version 2.3
+  * Switch to monotonic clock for timers
+  * Bump copyright
+  * Minor improvements to setup script
+  * Improve intersphinx references
+  * s/readthedocs.org/readthedocs.io/g
+- From version 2.2.1
+  * Fix timers being awkward as context managers
+  * Reproduce timers being awkward as context managers
+  * Minor improvements to reStructuredText in docstrings
+- From version 2.2
+  * Fix parse_date() choking on Unicode strings
+  * Reproduce parse_date() bug in test suite
+  * Fix flake8 warning
+  * Only use readline hints in prompts when stdin is tty
+
+---

Old:

  humanfriendly-4.4.1.tar.gz

New:

  humanfriendly-4.8.tar.gz



Other differences:
--
++ python-humanfriendly.spec ++
--- /var/tmp/diff_new_pack.WvfYGp/_old  2018-02-09 15:52:03.501667888 +0100
+++ /var/tmp/diff_new_pack.WvfYGp/_new  2018-02-09 15:52:03.505667744 +0100
@@ -1,7 +1,7 @@
 #
 

commit php7-APCu for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package php7-APCu for openSUSE:Factory 
checked in at 2018-02-09 15:51:43

Comparing /work/SRC/openSUSE:Factory/php7-APCu (Old)
 and  /work/SRC/openSUSE:Factory/.php7-APCu.new (New)


Package is "php7-APCu"

Fri Feb  9 15:51:43 2018 rev:2 rq:574336 version:5.1.9

Changes:

--- /work/SRC/openSUSE:Factory/php7-APCu/php7-APCu.changes  2017-04-20 
20:50:27.804092845 +0200
+++ /work/SRC/openSUSE:Factory/.php7-APCu.new/php7-APCu.changes 2018-02-09 
15:51:48.890192692 +0100
@@ -1,0 +2,15 @@
+Tue Jan 30 13:01:32 UTC 2018 - crrodrig...@opensuse.org
+
+- Build with -fvisibility=hidden, PHP process namespace 
+  pollution must be heavily limited to avoid symbol clashes.
+- Use SOURCE_DATE_EPOCH if set instead of custom build hack.
+- Update to version 5.1.9
+- fix gh#234 mmap disabled when configure is called with --enable-apcu-mmap
+- fix gh#226 Warning: apcu_fetch(): apc_fetch() expects a string or array of 
strings.
+- mitigate gh#223 Fatal error when starting php on windows
+- add support for PCRE2 in 7.3
+- use row formatting for information in phpinfo() tables
+- set IS_STR_PERSISTENT so refcounting failures are reported by -DRC_DEBUG=1
+- fix gh#266 refcounting errors in APCIterator 
+
+---

Old:

  apcu-5.1.8.tgz

New:

  apcu-5.1.9.tgz



Other differences:
--
++ php7-APCu.spec ++
--- /var/tmp/diff_new_pack.yNJ4Ds/_old  2018-02-09 15:51:50.750125889 +0100
+++ /var/tmp/diff_new_pack.yNJ4Ds/_new  2018-02-09 15:51:50.754125745 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package php7-APCu
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,7 +18,7 @@
 
 %define pkg_name apcu
 Name:   php7-APCu
-Version:5.1.8
+Version:5.1.9
 Release:0
 Summary:APCu - APC User Cache
 License:PHP-3.01
@@ -41,13 +41,15 @@
 
 %prep
 %setup -q -n %{pkg_name}-%{version}
-# remove build time references so build-compare can do its work
+if [ -z "$SOURCE_DATE_EPOCH" ]; then
 FAKE_BUILDTIME=$(LC_ALL=C date -u -r php_apc.c '+%%H:%%M')
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r php_apc.c '+%%b %%e %%Y')
 sed -e "s/__TIME__/\"$FAKE_BUILDTIME\"/g" -i php_apc.c
 sed -e "s/__DATE__/\"$FAKE_BUILDDATE\"/g" -i php_apc.c
+fi
 
 %build
+export CFLAGS="%optflags -fvisibility=hidden"
 %{_bindir}/phpize
 %configure --enable-apcu
 make %{?_smp_mflags}

++ apcu-5.1.8.tgz -> apcu-5.1.9.tgz ++
 55330 lines of diff (skipped)




commit yast2-ftp-server for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package yast2-ftp-server for 
openSUSE:Factory checked in at 2018-02-09 15:51:40

Comparing /work/SRC/openSUSE:Factory/yast2-ftp-server (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-ftp-server.new (New)


Package is "yast2-ftp-server"

Fri Feb  9 15:51:40 2018 rev:56 rq:574332 version:4.0.1

Changes:

--- /work/SRC/openSUSE:Factory/yast2-ftp-server/yast2-ftp-server.changes
2018-02-03 15:42:51.972352049 +0100
+++ /work/SRC/openSUSE:Factory/.yast2-ftp-server.new/yast2-ftp-server.changes   
2018-02-09 15:51:43.902371840 +0100
@@ -1,0 +2,9 @@
+Thu Feb  8 15:07:37 UTC 2018 - jreidin...@suse.com
+
+- convert starting on demand from Xinetd to systemd sockets due
+  to drop of Xinetd (fate#323373)
+- Drop pure-ftp as it does not provide systemd socket and we want
+  to support only one backend to reduce the maintenance cost
+- 4.0.1
+
+---

Old:

  yast2-ftp-server-4.0.0.tar.bz2

New:

  yast2-ftp-server-4.0.1.tar.bz2



Other differences:
--
++ yast2-ftp-server.spec ++
--- /var/tmp/diff_new_pack.XUT4H9/_old  2018-02-09 15:51:44.802339516 +0100
+++ /var/tmp/diff_new_pack.XUT4H9/_new  2018-02-09 15:51:44.802339516 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-ftp-server
-Version:4.0.0
+Version:4.0.1
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -25,7 +25,6 @@
 
 # SuSEFirewall2 replace by firewalld (fate#323460)
 Requires:   yast2 >= 4.0.39
-Requires:   yast2-inetd
 BuildRequires:  update-desktop-files
 # SuSEFirewall2 replace by firewalld (fate#323460)
 BuildRequires:  yast2 >= 4.0.39
@@ -43,7 +42,7 @@
 
 %description
 This package contains the YaST2 component for FTP configuration. It can
-configure two daemons: pure-ftpd and vsftpd.
+configure vsftpd.
 
 %prep
 %setup -n %{name}-%{version}

++ yast2-ftp-server-4.0.0.tar.bz2 -> yast2-ftp-server-4.0.1.tar.bz2 ++
 7203 lines of diff (skipped)




commit yast2-instserver for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package yast2-instserver for 
openSUSE:Factory checked in at 2018-02-09 15:51:23

Comparing /work/SRC/openSUSE:Factory/yast2-instserver (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-instserver.new (New)


Package is "yast2-instserver"

Fri Feb  9 15:51:23 2018 rev:51 rq:574255 version:4.0.2

Changes:

--- /work/SRC/openSUSE:Factory/yast2-instserver/yast2-instserver.changes
2018-02-06 16:49:10.352016767 +0100
+++ /work/SRC/openSUSE:Factory/.yast2-instserver.new/yast2-instserver.changes   
2018-02-09 15:51:26.430999355 +0100
@@ -1,0 +2,7 @@
+Thu Feb  8 11:54:52 UTC 2018 - knut.anders...@suse.com
+
+- Drop xinetd configuration and use systemd sockets instead.
+  (fate#323373)
+- 4.0.2
+
+---

Old:

  yast2-instserver-4.0.1.tar.bz2

New:

  yast2-instserver-4.0.2.tar.bz2



Other differences:
--
++ yast2-instserver.spec ++
--- /var/tmp/diff_new_pack.UyMkGf/_old  2018-02-09 15:51:26.994979099 +0100
+++ /var/tmp/diff_new_pack.UyMkGf/_new  2018-02-09 15:51:26.994979099 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-instserver
-Version:4.0.1
+Version:4.0.2
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ yast2-instserver-4.0.1.tar.bz2 -> yast2-instserver-4.0.2.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-instserver-4.0.1/package/yast2-instserver.changes 
new/yast2-instserver-4.0.2/package/yast2-instserver.changes
--- old/yast2-instserver-4.0.1/package/yast2-instserver.changes 2018-02-05 
15:00:46.0 +0100
+++ new/yast2-instserver-4.0.2/package/yast2-instserver.changes 2018-02-08 
14:54:20.0 +0100
@@ -1,4 +1,11 @@
 ---
+Thu Feb  8 11:54:52 UTC 2018 - knut.anders...@suse.com
+
+- Drop xinetd configuration and use systemd sockets instead.
+  (fate#323373)
+- 4.0.2
+
+---
 Mon Feb  5 13:39:28 UTC 2018 - knut.anders...@suse.com
 
 - Replace SuSEFirewall2 by firewalld (fate#323460)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-instserver-4.0.1/package/yast2-instserver.spec 
new/yast2-instserver-4.0.2/package/yast2-instserver.spec
--- old/yast2-instserver-4.0.1/package/yast2-instserver.spec2018-02-05 
15:00:46.0 +0100
+++ new/yast2-instserver-4.0.2/package/yast2-instserver.spec2018-02-08 
14:54:20.0 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-instserver
-Version:4.0.1
+Version:4.0.2
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-instserver-4.0.1/src/modules/Instserver.rb 
new/yast2-instserver-4.0.2/src/modules/Instserver.rb
--- old/yast2-instserver-4.0.1/src/modules/Instserver.rb2018-02-05 
15:00:46.0 +0100
+++ new/yast2-instserver-4.0.2/src/modules/Instserver.rb2018-02-08 
14:54:20.0 +0100
@@ -23,6 +23,7 @@
   Yast.import "Package"
   Yast.import "Call"
   Yast.import "Service"
+  Yast.import "SystemdSocket"
   Yast.import "IP"
   Yast.import "Message"
   Yast.import "String"
@@ -311,7 +312,7 @@
 "The FTP installation server requires an FTP server package. The 
vsftpd package\nwill now be installed.\n"
   )
   if !Package.InstalledAll(
-  ["xinetd", "vsftpd", "openslp-server", "yast2-inetd"]
+  ["vsftpd", "openslp-server"]
 )
 Builtins.y2milestone("some packages are not installed")
   else
@@ -319,7 +320,7 @@
   end
 
   if !Package.InstallAll(
-  ["xinetd", "vsftpd", "openslp-server", "yast2-inetd"]
+  ["vsftpd", "openslp-server"]
 )
 Report.Error(Message.CannotContinueWithoutPackagesInstalled)
 Builtins.y2error("Error while installing packages")
@@ -370,60 +371,10 @@
 else
   Service.Start("vsftpd")
 end
-  else
-Builtins.y2milestone("Configuring FTP service in xinetd mode")
-# read the current configuration
-resource = Convert.to_map(ReadServiceSettings("inetd_auto"))
-netdconf = []
-
-# replace vsftpd config
-ftpdenabled = false
-servicefound = false
-Builtins.foreach(Ops.get_list(resource, "netd_conf", [])) do |conf|
-  # the service is ftp with vsftpd server
-  if Ops.get_string(conf, "service", "") == "ftp" &&
-  Ops.get_string(conf, "script", "") == "vsftpd"
-

commit catfish for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package catfish for openSUSE:Factory checked 
in at 2018-02-09 15:51:37

Comparing /work/SRC/openSUSE:Factory/catfish (Old)
 and  /work/SRC/openSUSE:Factory/.catfish.new (New)


Package is "catfish"

Fri Feb  9 15:51:37 2018 rev:2 rq:574309 version:1.4.4

Changes:

--- /work/SRC/openSUSE:Factory/catfish/catfish.changes  2017-08-08 
11:58:53.566954531 +0200
+++ /work/SRC/openSUSE:Factory/.catfish.new/catfish.changes 2018-02-09 
15:51:38.790555441 +0100
@@ -1,0 +2,18 @@
+Tue Jan 30 19:53:07 UTC 2018 - avvi...@yandex.by
+
+- Update to 1.4.4:
+  * Installer cleanup
+  * Updated appdata requirements
+  * Add Keywords to desktop file (lintian), extend Categories 
+with GTK (desktop-file-validate)
+  * Catfish 1.4.3:
+  * pycodestyle improvements
+  * Improve search speed by discarding .cache and .gvfs when 
+possible, add --basename to locate query
+  * Stop all search methods when engine is stopped, improve error 
+handling with thumbnails 
+- Update the sourceurl
+- Use appdata instead of metainfo
+- Fix: non-executable-script
+
+---

Old:

  catfish-1.4.2.tar.bz2

New:

  catfish-1.4.4.tar.gz



Other differences:
--
++ catfish.spec ++
--- /var/tmp/diff_new_pack.kp42a2/_old  2018-02-09 15:51:39.506529725 +0100
+++ /var/tmp/diff_new_pack.kp42a2/_new  2018-02-09 15:51:39.510529581 +0100
@@ -18,13 +18,13 @@
 %define series 1.4
 
 Name:   catfish
-Version:1.4.2
+Version:1.4.4
 Release:0
 License:GPL-2.0
 Summary:Versatile File Searching Tool
 Url:http://www.twotoasts.de/index.php/catfish/
 Group:  Productivity/File utilities
-Source: 
https://launchpad.net/catfish-search/%{series}/%{version}/+download/%{name}-%{version}.tar.bz2
+Source: 
https://launchpad.net/catfish-search/%{series}/%{version}/+download/%{name}-%{version}.tar.gz
 BuildRequires:  fdupes
 BuildRequires:  hicolor-icon-theme
 BuildRequires:  intltool
@@ -66,7 +66,7 @@
 %setup -q
 
 %build
-python3 ./setup.py build
+python3 ./setup.py build -g
 
 %install
 python3 ./setup.py install -O1 \
@@ -74,22 +74,26 @@
 --root="%{buildroot}" \
 --record-rpm=files.lst
 rm -rf %{buildroot}%{_datadir}/doc/%{name}
-grep -rl '^#!' %{buildroot}%{python3_sitelib}/%{name}*/ | xargs chmod 0755
+# Fix: non-executable-script
+pushd %{buildroot}
+for _file in $(grep -rl '^\#\!\/'); do
+  find -name ${_file##*/} -type f -perm -644 -exec sed '/^\#\!/d' -i {} \+
+  find -name ${_file##*/} -type f -perm -755 -exec sed '1 
s|^|\#\!%{_bindir}/python3\n|' -i {} \+
+done
+%py3_compile -O .%{python3_sitelib}
+popd
 sed -i "s/\(Exec=\).*/\1%{name}/" 
%{buildroot}%{_datadir}/applications/%{name}.desktop
 for i in 16 24 32 48; do
 install -dm 0755 %{buildroot}%{_datadir}/icons/hicolor/$i\x$i/apps
 rsvg-convert -h $i -w $i data/media/catfish.svg -o 
%{buildroot}%{_datadir}/icons/hicolor/$i\x$i/apps/%{name}.png
 done
-%suse_update_desktop_file -r %{name} GNOME Utility Filesystem
+mkdir -p %{buildroot}%{_datadir}/appdata
+mv %{buildroot}%{_datadir}/{metainfo,appdata}/%{name}.appdata.xml
 
+%suse_update_desktop_file -r %{name} GNOME Utility Filesystem
+%fdupes %{buildroot}%{python3_sitelib}
 %find_lang %{name}
 
-# Python byte compile.
-pushd %{buildroot}%{python3_sitelib}/%{name}_lib/__pycache__
-%py3_compile -O ..
-popd
-%fdupes %{buildroot}%{python3_sitelib}/%{name}_lib/__pycache__/
-
 %post
 %icon_theme_cache_post
 
@@ -101,7 +105,6 @@
 %doc AUTHORS ChangeLog COPYING README
 %{_bindir}/%{name}
 %{_datadir}/%{name}/
-%dir %{_datadir}/appdata
 %{_datadir}/appdata/%{name}.appdata.xml
 %{_datadir}/applications/%{name}.desktop
 %{_datadir}/icons/hicolor/*/apps/%{name}.??g




commit doomsday for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package doomsday for openSUSE:Factory 
checked in at 2018-02-09 15:51:28

Comparing /work/SRC/openSUSE:Factory/doomsday (Old)
 and  /work/SRC/openSUSE:Factory/.doomsday.new (New)


Package is "doomsday"

Fri Feb  9 15:51:28 2018 rev:21 rq:574287 version:2.0.3

Changes:

--- /work/SRC/openSUSE:Factory/doomsday/doomsday.changes2018-01-17 
21:56:14.385035937 +0100
+++ /work/SRC/openSUSE:Factory/.doomsday.new/doomsday.changes   2018-02-09 
15:51:28.766915457 +0100
@@ -1,0 +2,5 @@
+Thu Feb  8 14:37:03 UTC 2018 - jeng...@inai.de
+
+- Get rid of BuildRequires: xorg-x11-devel.
+
+---



Other differences:
--
++ doomsday.spec ++
--- /var/tmp/diff_new_pack.f64djZ/_old  2018-02-09 15:51:30.270861440 +0100
+++ /var/tmp/diff_new_pack.f64djZ/_new  2018-02-09 15:51:30.274861297 +0100
@@ -42,7 +42,6 @@
 %endif
 BuildRequires:  libpng-devel
 BuildRequires:  ncurses-devel
-BuildRequires:  xorg-x11-devel
 BuildRequires:  zlib-devel
 BuildRequires:  pkgconfig(Qt5Core)
 BuildRequires:  pkgconfig(Qt5Gui)
@@ -59,6 +58,7 @@
 BuildRequires:  pkgconfig(sdl2)
 BuildRequires:  pkgconfig(x11)
 BuildRequires:  pkgconfig(xext)
+BuildRequires:  pkgconfig(xrandr)
 BuildRequires:  pkgconfig(zzip-zlib-config)
 # Doomsday uses a modified version of assimp, so no pkgconfig(assimp) here :-(
 Provides:   bundled(assimp) = 3.1.1




commit haproxy for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package haproxy for openSUSE:Factory checked 
in at 2018-02-09 15:51:18

Comparing /work/SRC/openSUSE:Factory/haproxy (Old)
 and  /work/SRC/openSUSE:Factory/.haproxy.new (New)


Package is "haproxy"

Fri Feb  9 15:51:18 2018 rev:55 rq:574250 version:1.8.4

Changes:

--- /work/SRC/openSUSE:Factory/haproxy/haproxy.changes  2018-01-17 
21:57:17.878063647 +0100
+++ /work/SRC/openSUSE:Factory/.haproxy.new/haproxy.changes 2018-02-09 
15:51:23.679098193 +0100
@@ -1,0 +2,59 @@
+Thu Feb 08 13:15:17 UTC 2018 - kgronl...@suse.com
+
+- Update to version 1.8.4 (bsc#1080069):
+  * BUG/MINOR: config: don't emit a warning when global stats is incompletely 
configured
+  * DOC: Mention -Ws in the list of available options
+  * DOC: Describe routing impact of using interface keyword on bind lines
+  * MINOR: init: emit warning when -sf/-sd cannot parse argument
+  * BUG/MEDIUM: standard: Fix memory leak in str2ip2()
+  * BUG/MINOR: time/threads: ensure the adjusted time is always correct
+  * BUG/MEDIUM: spoe: Allow producer to read and to forward shutdown on 
request side
+  * BUG/MEDIUM: spoe: Always try to receive or send the frame to detect 
shutdowns
+  * BUG/MINOR: epoll/threads: only call epoll_ctl(DEL) on polled FDs
+  * BUG/MINOR: threads: Update labels array because of changes in lock_label 
enum
+  * BUG/MINOR: cli: use global.maxsock and not maxfd to list all FDs
+  * CLEANUP: Fix typo in ARGT_MSK6 comment
+  * BUG/MINOR: sample: Fix output type of c_ipv62ip
+  * CLEANUP: sample: Fix outdated comment about sample casts functions
+  * CLEANUP: sample: Fix comment encoding of sample.c
+  * BUILD: kqueue/threads: Add test on MAX_THREADS to avoid warnings when 
complied without threads
+  * BUILD: epoll/threads: Add test on MAX_THREADS to avoid warnings when 
complied without threads
+  * MINOR: threads: Use __decl_hathreads instead of #ifdef/#endif
+  * BUG/MINOR: kqueue/threads: Don't forget to close kqueue_fd[tid] on each 
thread
+  * BUG/MEDIUM: checks: Don't try to release undefined conn_stream when a 
check is freed
+  * BUG/MEDIUM: threads/server: Fix deadlock in 
srv_set_stopping/srv_set_admin_flag
+  * BUG/MINOR: threads: always set an owner to the thread_sync pipe
+  * MINOR: threads: Fix build when we're not compiling with threads.
+  * BUG/MINOR: mworker: only write to pidfile if it exists
+  * BUG/MEDIUM: threads/mworker: fix a race on startup
+  * BUG/MEDIUM: kqueue/threads: use one kqueue_fd per thread
+  * BUG/MEDIUM: epoll/threads: use one epoll_fd per thread
+  * MINOR: fd: add a bitmask to indicate that an FD is known by the poller
+  * BUG/MEDIUM: fd: maintain a per-thread update mask
+  * BUG/MEDIUM: threads/polling: Use fd_cache_mask instead of fd_cache_num
+  * MINOR: threads/fd: Use a bitfield to know if there are FDs for a thread in 
the FD cache
+  * MINOR: global: add some global activity counters to help debugging
+  * MINOR: threads: add a MAX_THREADS define instead of LONGBITS
+  * MINOR: global/threads: move cpu_map at the end of the global struct
+  * MINOR: servers: Don't report duplicate dyncookies for disabled servers.
+  * BUG/MEDIUM: peers: fix expire date wasn't updated if entry is modified 
remotely.
+  * BUG/MINOR: poll: too large size allocation for FD events
+  * CONTRIB: debug: fix a few flags definitions
+  * DOC: clarify the scope of ssl_fc_is_resumed
+  * BUG/MEDIUM: stream: properly handle client aborts during redispatch
+  * BUILD/MINOR: ancient gcc versions atomic fix
+  * BUG/MEDIUM: mworker: execvp failure depending on argv[0]
+  * MINOR: dns: Handle SRV record weight correctly.
+  * BUG/MINOR: lua: Fix return value of Socket.settimeout
+  * BUG/MEDIUM: lua: Fix IPv6 with separate port support for Socket.connect
+  * DOC: lua: Fix typos in comments of hlua_socket_receive
+  * BUG/MINOR: lua: Fix default value for pattern in Socket.receive
+  * BUG/MEDIUM: ssl: cache doesn't release shctx blocks
+  * BUG/MEDIUM: h2: properly handle the END_STREAM flag on empty DATA frames
+
+---
+Thu Feb  8 07:21:58 UTC 2018 - kgronl...@suse.com
+
+- Add dependency on apparmor-profiles (bsc#1079985) 
+
+---

Old:

  haproxy-1.8.3.tar.gz

New:

  haproxy-1.8.4.tar.gz



Other differences:
--
++ haproxy.spec ++
--- /var/tmp/diff_new_pack.vvza4t/_old  2018-02-09 15:51:24.927053371 +0100
+++ /var/tmp/diff_new_pack.vvza4t/_new  2018-02-09 15:51:24.931053228 +0100
@@ -40,13 +40,14 @@
 %bcond_without  apparmor
 
 Name:   haproxy
-Version:1.8.3
+Version:1.8.4
 Release:0
 #
 #
 BuildRoot:  

commit xfs for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package xfs for openSUSE:Factory checked in 
at 2018-02-09 15:51:34

Comparing /work/SRC/openSUSE:Factory/xfs (Old)
 and  /work/SRC/openSUSE:Factory/.xfs.new (New)


Package is "xfs"

Fri Feb  9 15:51:34 2018 rev:14 rq:574302 version:1.2.0

Changes:

--- /work/SRC/openSUSE:Factory/xfs/xfs.changes  2017-11-30 12:45:16.206183321 
+0100
+++ /work/SRC/openSUSE:Factory/.xfs.new/xfs.changes 2018-02-09 
15:51:35.438675830 +0100
@@ -1,0 +2,5 @@
+Thu Feb  8 14:28:46 UTC 2018 - sndir...@suse.com
+
+- fixed build (looks like a manual page has been dropped)
+
+---



Other differences:
--
++ xfs.spec ++
--- /var/tmp/diff_new_pack.sdw8Ms/_old  2018-02-09 15:51:36.254646522 +0100
+++ /var/tmp/diff_new_pack.sdw8Ms/_new  2018-02-09 15:51:36.254646522 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package xfs
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -62,9 +62,6 @@
 install -D -m0755 %{SOURCE2} %{buildroot}%{_sysconfdir}/init.d/xfs
 mkdir -p %{buildroot}%{_sbindir}
 ln -s %{_sysconfdir}/init.d/xfs %{buildroot}%{_sbindir}/rcxfs
-# missing manual page
-mkdir -p %{buildroot}%{_mandir}/man8
-ln -s ../man7/init.d.7%{?ext_man} 
%{buildroot}%{_mandir}/man8/rcxfs.8%{?ext_man}
 
 %post
 %fillup_and_insserv xfs
@@ -85,6 +82,5 @@
 %{_bindir}/xfs
 %{_sbindir}/rcxfs
 %{_mandir}/man1/xfs.1%{?ext_man}
-%{_mandir}/man8/rcxfs.8%{?ext_man}
 
 %changelog




commit tachyon for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package tachyon for openSUSE:Factory checked 
in at 2018-02-09 15:51:26

Comparing /work/SRC/openSUSE:Factory/tachyon (Old)
 and  /work/SRC/openSUSE:Factory/.tachyon.new (New)


Package is "tachyon"

Fri Feb  9 15:51:26 2018 rev:7 rq:574286 version:0.99~b6

Changes:

--- /work/SRC/openSUSE:Factory/tachyon/tachyon.changes  2014-02-05 
16:35:17.0 +0100
+++ /work/SRC/openSUSE:Factory/.tachyon.new/tachyon.changes 2018-02-09 
15:51:27.378965307 +0100
@@ -1,0 +2,5 @@
+Thu Feb  8 14:50:50 UTC 2018 - jeng...@inai.de
+
+- Remove old SLES BuildRequires.
+
+---



Other differences:
--
++ tachyon.spec ++
--- /var/tmp/diff_new_pack.SFepQU/_old  2018-02-09 15:51:28.630920342 +0100
+++ /var/tmp/diff_new_pack.SFepQU/_new  2018-02-09 15:51:28.630920342 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package tachyon
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -32,15 +32,9 @@
 BuildRequires:  automake >= 1.10
 BuildRequires:  libjpeg-devel
 BuildRequires:  libtool >= 2
-%if 0%{?sles_version}
-BuildRequires:  Mesa-devel
-BuildRequires:  libpng-devel
-BuildRequires:  xorg-x11-devel
-%else
 BuildRequires:  pkgconfig(gl)
 BuildRequires:  pkgconfig(libpng)
 BuildRequires:  pkgconfig(x11)
-%endif
 
 %description
 A high performance parallel ray tracing system supporting MPI and
@@ -92,18 +86,18 @@
 %patch -P 1 -p1
 
 %build
-autoreconf -fi;
+autoreconf -fi
 %configure --disable-static
-make %{?_smp_mflags};
+make %{?_smp_mflags}
 
 %install
-b="%buildroot";
-mkdir -p "$b/%_includedir/tachyon";
+b="%buildroot"
+mkdir -p "$b/%_includedir/tachyon"
 for i in tachyon.h tachyon_dep.h hash.h macros.h render.h quadric.h texture.h 
light.h util.h; do
-   install -pm 0644 "src/$i" "$b/%_includedir/tachyon/$i";
-done;
-make install DESTDIR="$b";
-rm -f "$b/%_libdir"/*.la;
+   install -pm 0644 "src/$i" "$b/%_includedir/tachyon/$i"
+done
+%make_install
+rm -f "$b/%_libdir"/*.la
 
 %files
 %defattr(-,root,root)




commit velum for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package velum for openSUSE:Factory checked 
in at 2018-02-09 15:51:13

Comparing /work/SRC/openSUSE:Factory/velum (Old)
 and  /work/SRC/openSUSE:Factory/.velum.new (New)


Package is "velum"

Fri Feb  9 15:51:13 2018 rev:5 rq:574233 
version:3.0.0+dev+git_r644_b0361e81be2d64b10de6b8c676dce394044f164a

Changes:

--- /work/SRC/openSUSE:Factory/velum/velum.changes  2018-02-02 
22:23:26.734616949 +0100
+++ /work/SRC/openSUSE:Factory/.velum.new/velum.changes 2018-02-09 
15:51:17.803309230 +0100
@@ -1,0 +2,47 @@
+Thu Feb  8 12:28:28 UTC 2018 - containers-bugow...@suse.de
+
+- Commit b12fdf4 by Kiall Mac Innes ki...@macinnes.ie
+ Add manual kubeconfig setup instructions
+ 
+ Add instructions for manually adding a cluster to a pre-existing kubeconfig
+ file.
+
+
+---
+Wed Feb  7 17:25:39 UTC 2018 - containers-bugow...@suse.de
+
+- Commit 2db24eb by Kiall Mac Innes ki...@macinnes.ie
+ Use separate Dex clients for each actual client
+ 
+ Previously Velum, CaaSP CLI, and Kubernetes all shared a single Dex client.
+ From a security perspective, this was far from ideal.
+ 
+ Update Velum to:
+ 
+ * Generate a unique secret for the Velum and Kubernetes client during setup
+ * Add a migration to generate secrets during upgrade
+ * Use the Velum client to auth with Dex
+ * Request a token from Dex which is valid for the kubernetes client
+
+
+---
+Tue Feb  6 17:55:27 UTC 2018 - containers-bugow...@suse.de
+
+- Commit 48188f1 by Chris Olstrom ch...@olstrom.com
+ Add fallback link to fetch kubeconfig if redirect fails
+
+
+---
+Tue Feb  6 17:03:32 UTC 2018 - containers-bugow...@suse.de
+
+- Commit 01453e3 by James Mason jma...@suse.com
+ Update login feature spec
+ 
+ I had issues with a failing test that used inconsitent access to the 'Log in'
+ button, so I've updated it to match the rest of the spec.
+ 
+ Additionally, the descriptions didn't make sense in documentation format so I
+ reworded them.
+
+
+---



Other differences:
--
++ velum.spec ++
--- /var/tmp/diff_new_pack.fsQMng/_old  2018-02-09 15:51:18.727276045 +0100
+++ /var/tmp/diff_new_pack.fsQMng/_new  2018-02-09 15:51:18.731275901 +0100
@@ -23,7 +23,7 @@
 # Version:  1.0.0
 # %%define branch 1.0.0
 
-Version:3.0.0+dev+git_r636_348aa62ece758fd9933ade7f585ec04e8d8d32a4
+Version:3.0.0+dev+git_r644_b0361e81be2d64b10de6b8c676dce394044f164a
 Release:0
 %define branch master
 Summary:Dashboard for CaasP
@@ -96,7 +96,7 @@
 %description
 velum is the dashboard for CaasP to manage and deploy kubernetes clusters on 
top of MicroOS
 
-This package has been built with commit 
348aa62ece758fd9933ade7f585ec04e8d8d32a4 from branch master on date Fri, 02 Feb 
2018 11:59:01 +
+This package has been built with commit 
b0361e81be2d64b10de6b8c676dce394044f164a from branch master on date Thu, 08 Feb 
2018 12:27:49 +
 
 %prep
 %setup -q -n velum-%{branch}

++ master.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/velum-master/app/controllers/oidc_controller.rb 
new/velum-master/app/controllers/oidc_controller.rb
--- old/velum-master/app/controllers/oidc_controller.rb 2018-02-02 
13:00:11.0 +0100
+++ new/velum-master/app/controllers/oidc_controller.rb 2018-02-08 
13:27:18.0 +0100
@@ -30,7 +30,11 @@
   end
 
   def client_id
-"caasp-cli"
+"velum"
+  end
+
+  def client_secret
+Pillar.value(pillar: :dex_client_secrets_velum)
   end
 
   def index
@@ -57,24 +61,27 @@
 id_token.verify!(
   issuer:issuer,
   client_id: client_id,
-  nonce: stored_nonce
+  nonce: stored_nonce,
+  audience:  "kubernetes"
 )
 
-email = id_token.raw_attributes["email"]
-client_id = access_token.client.identifier
-client_secret = access_token.client.secret
-idp_issuer_url = id_token.iss
-refresh_token = access_token.refresh_token
-
-@redirect_target = oidc_kubeconfig_url email:  email,
-   client_id:  client_id,
-   client_secret:  client_secret,
-   id_token:   
access_token.id_token,
-   idp_issuer_url: idp_issuer_url,
-   refresh_token:  refresh_token
+@email = id_token.raw_attributes["email"]
+@client_id = 

commit linuxptp for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package linuxptp for openSUSE:Factory 
checked in at 2018-02-09 15:51:05

Comparing /work/SRC/openSUSE:Factory/linuxptp (Old)
 and  /work/SRC/openSUSE:Factory/.linuxptp.new (New)


Package is "linuxptp"

Fri Feb  9 15:51:05 2018 rev:4 rq:574231 version:1.8+git65.g303b08c

Changes:

--- /work/SRC/openSUSE:Factory/linuxptp/linuxptp.changes2017-11-25 
08:42:15.323140037 +0100
+++ /work/SRC/openSUSE:Factory/.linuxptp.new/linuxptp.changes   2018-02-09 
15:51:09.663601578 +0100
@@ -1,0 +2,21 @@
+Thu Feb  8 12:08:37 UTC 2018 - jbo...@suse.com
+
+- change the versioning scheme, resulting in version
+  1.8+git65.g303b08c 
+
+---
+Thu Feb  8 08:51:50 UTC 2018 - mplus...@suse.com
+
+- Update to version v1.8+git.20180101 (bsc#1050682):
+  * clock: Don't forward management requests to UDS port.
+  * Add an acknowledgment in the readme for Meinberg.
+  * phc2sys: update '-s' option
+  * sk: don't leak socket when reading of IB GUID fails.
+  * Add compile time sanity check for interface name lengths.
+  * phc_ctl: fix adj command to accept negative offset.
+  * port: return timestamping iface in port properties
+  * phc2sys: re-create clock clkid and servo when phc index changed
+  * phc2sys: split servo_add from function clock_add
+  * transport: pass struct interface to transport_open
+
+---

Old:

  linuxptp-1.8.tgz

New:

  _service
  _servicedata
  linuxptp-1.8+git65.g303b08c.tar.xz



Other differences:
--
++ linuxptp.spec ++
--- /var/tmp/diff_new_pack.vG8iWp/_old  2018-02-09 15:51:10.587568392 +0100
+++ /var/tmp/diff_new_pack.vG8iWp/_new  2018-02-09 15:51:10.587568392 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package linuxptp
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,17 +18,16 @@
 
 #Compat macro for new _fillupdir macro introduced in Nov 2017
 %if ! %{defined _fillupdir}
-  %define _fillupdir /var/adm/fillup-templates
+  %define _fillupdir %{_localstatedir}/adm/fillup-templates
 %endif
-
 Name:   linuxptp
-Version:1.8
+Version:1.8+git65.g303b08c
 Release:0
 Summary:Precision Time Protocol v2 daemon
 License:GPL-2.0+
 Group:  Productivity/Networking/Other
-Url:http://linuxptp.sourceforge.net/
-Source0:
https://sourceforge.net/projects/linuxptp/files/v%{version}/linuxptp-%{version}.tgz
+URL:http://linuxptp.sourceforge.net/
+Source0:%{name}-%{version}.tar.xz
 Source1:ptp4l.service
 Source2:sysconfig.ptp4l
 Source3:linuxptp.firewall
@@ -84,7 +83,6 @@
 %service_del_postun ptp4l.service phc2sys.service
 
 %files
-%defattr(-,root,root)
 %doc README.org COPYING linuxptp-howto.txt
 %{_unitdir}/ptp4l.service
 %{_unitdir}/phc2sys.service

++ _service ++

  
git://git.code.sf.net/p/linuxptp/code
git
enable
linuxptp
@PARENT_TAG@+git@TAG_OFFSET@.g%h
v(.*)
  
  
*.tar
xz
  
  

++ _servicedata ++


git://git.code.sf.net/p/linuxptp/code
  303b08cbf55096aba55bd08a314e0701e5c33482



commit hdf5 for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package hdf5 for openSUSE:Factory checked in 
at 2018-02-09 15:51:00

Comparing /work/SRC/openSUSE:Factory/hdf5 (Old)
 and  /work/SRC/openSUSE:Factory/.hdf5.new (New)


Package is "hdf5"

Fri Feb  9 15:51:00 2018 rev:41 rq:574225 version:1.10.1

Changes:

--- /work/SRC/openSUSE:Factory/hdf5/hdf5.changes2018-01-16 
09:33:50.821624171 +0100
+++ /work/SRC/openSUSE:Factory/.hdf5.new/hdf5.changes   2018-02-09 
15:51:03.675816635 +0100
@@ -1,0 +2,5 @@
+Thu Feb  8 11:37:06 UTC 2018 - e...@suse.com
+
+- Disable %check stage for mpich builds on s390(x) (bsc#1080022).
+
+---



Other differences:
--
++ hdf5.spec ++
--- /var/tmp/diff_new_pack.WAuGZL/_old  2018-02-09 15:51:06.031732020 +0100
+++ /var/tmp/diff_new_pack.WAuGZL/_new  2018-02-09 15:51:06.035731877 +0100
@@ -804,11 +804,13 @@
 export HDF5_Make_Ignore=yes
 %endif
 %{?with_hpc:%hpc_setup}
-%ifarch ppc ppc64 ppc64le
-make %{?_smp_mflags} check || { echo "Ignore transient make check failures for 
PowerPC. boo#1058563"; }
-%else
-make %{?_smp_mflags} check
-%endif
+ %ifarch ppc ppc64 ppc64le
+  make %{?_smp_mflags} check || { echo "Ignore transient make check failures 
for PowerPC. boo#1058563"; }
+ %else
+  %if "%{?mpi_flavor}" != "mpich" || ("%_arch" != "s390" && "%_arch" != 
"s390x")
+make %{?_smp_mflags} check
+  %endif
+ %endif
 %endif
 
 %if %{without mpi}




commit trinity for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package trinity for openSUSE:Factory checked 
in at 2018-02-09 15:51:10

Comparing /work/SRC/openSUSE:Factory/trinity (Old)
 and  /work/SRC/openSUSE:Factory/.trinity.new (New)


Package is "trinity"

Fri Feb  9 15:51:10 2018 rev:49 rq:574232 version:1.9+git.20180206

Changes:

--- /work/SRC/openSUSE:Factory/trinity/trinity.changes  2018-01-10 
23:38:28.554711365 +0100
+++ /work/SRC/openSUSE:Factory/.trinity.new/trinity.changes 2018-02-09 
15:51:10.867558336 +0100
@@ -1,0 +2,12 @@
+Thu Feb  8 12:27:26 UTC 2018 - mplus...@suse.com
+
+- Update to version 1.9+git.20180206:
+  * trinity: Add support for readdir svc
+  * trinity: Add support for copy_file_range svc
+  * trinity: Add support for mlock2 svc
+  * trinity: Add support for statx svc
+  * trinity: Add support for preadv2/pwritev2 svcs
+  * trinity: Update and comment on s390 system call table
+  * trinity: Fix compile error on linux 4.15 kernel
+
+---

Old:

  trinity-1.9+git.20171219.tar.xz

New:

  trinity-1.9+git.20180206.tar.xz



Other differences:
--
++ trinity.spec ++
--- /var/tmp/diff_new_pack.R38PgM/_old  2018-02-09 15:51:11.599532047 +0100
+++ /var/tmp/diff_new_pack.R38PgM/_new  2018-02-09 15:51:11.603531903 +0100
@@ -16,9 +16,9 @@
 #
 
 
-%define version_unconverted 1.9+git.20171219
+%define version_unconverted 1.9+git.20180206
 Name:   trinity
-Version:1.9+git.20171219
+Version:1.9+git.20180206
 Release:0
 Summary:A Linux System call fuzz tester
 License:GPL-2.0

++ _servicedata ++
--- /var/tmp/diff_new_pack.R38PgM/_old  2018-02-09 15:51:11.643530467 +0100
+++ /var/tmp/diff_new_pack.R38PgM/_new  2018-02-09 15:51:11.647530323 +0100
@@ -1,4 +1,4 @@
 
 
 git://github.com/kernelslacker/trinity
-  00a1a514288e645690a46afaad87c1080da4960f
\ No newline at end of file
+  b9a7bd002a384513f230ffa21cc785e7dbf32fdb
\ No newline at end of file

++ trinity-1.9+git.20171219.tar.xz -> trinity-1.9+git.20180206.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/trinity-1.9+git.20171219/include/syscalls-s390.h 
new/trinity-1.9+git.20180206/include/syscalls-s390.h
--- old/trinity-1.9+git.20171219/include/syscalls-s390.h2017-12-19 
21:41:13.0 +0100
+++ new/trinity-1.9+git.20180206/include/syscalls-s390.h2018-02-06 
16:06:28.0 +0100
@@ -7,7 +7,7 @@
 #include "syscalls/syscalls.h"
 
 struct syscalltable syscalls_s390[] = {
-   { .entry = _ni_syscall },
+   { .entry = _ni_syscall },   /* No 0 unused system call */
{ .entry = _exit },
{ .entry = _fork },
{ .entry = _read },
@@ -24,8 +24,8 @@
{ .entry = _mknod },
{ .entry = _chmod },
{ .entry = _lchown16 },
-   { .entry = _ni_syscall },
-   { .entry = _ni_syscall },
+   { .entry = _ni_syscall },   /* No 17 unused system call */
+   { .entry = _ni_syscall },   /* No 18 unused system call */
{ .entry = _lseek },
{ .entry = _getpid },
{ .entry = _mount },
@@ -35,14 +35,14 @@
{ .entry = _stime },
{ .entry = _ptrace },
{ .entry = _alarm },
-   { .entry = _ni_syscall },
+   { .entry = _ni_syscall },   /* No 28 unused system call */
{ .entry = _pause },
{ .entry = _utime },
-   { .entry = _ni_syscall },
-   { .entry = _ni_syscall },
+   { .entry = _ni_syscall },   /* No 31 unused system call */
+   { .entry = _ni_syscall },   /* No 32 unused system call */
{ .entry = _access },
{ .entry = _nice },
-   { .entry = _ni_syscall },
+   { .entry = _ni_syscall },   /* No 35 unused system call */
{ .entry = _sync },
{ .entry = _kill },
{ .entry = _rename },
@@ -51,7 +51,7 @@
{ .entry = _dup },
{ .entry = _pipe },
{ .entry = _times },
-   { .entry = _ni_syscall },
+   { .entry = _ni_syscall },   /* No 44 unused system call */
{ .entry = _brk },
{ .entry = _setgid16 },
{ .entry = _getgid16 },
@@ -60,13 +60,13 @@
{ .entry = _getegid16 },
{ .entry = _acct },
{ .entry = _umount },
-   { .entry = _ni_syscall },
+   { .entry = _ni_syscall },   /* No 53 unused system call */
{ .entry = _ioctl },
{ .entry = _fcntl },
-   { .entry = _ni_syscall },
+   { .entry = _ni_syscall },   /* No 56 unused system call */
{ .entry = _setpgid },
-   { .entry = _ni_syscall },
-   { .entry = _ni_syscall },
+   { .entry = _ni_syscall 

commit ghc-bootstrap for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package ghc-bootstrap for openSUSE:Factory 
checked in at 2018-02-09 15:48:22

Comparing /work/SRC/openSUSE:Factory/ghc-bootstrap (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-bootstrap.new (New)


Package is "ghc-bootstrap"

Fri Feb  9 15:48:22 2018 rev:7 rq:574222 version:7.8.3

Changes:

--- /work/SRC/openSUSE:Factory/ghc-bootstrap/ghc-bootstrap.changes  
2017-03-08 01:14:50.675292352 +0100
+++ /work/SRC/openSUSE:Factory/.ghc-bootstrap.new/ghc-bootstrap.changes 
2018-02-09 15:48:29.445355652 +0100
@@ -1,0 +2,6 @@
+Thu Feb  8 10:51:10 UTC 2018 - ptromm...@icloud.com
+
+- don't override debug packages handling
+  * fixes build for Leap 15
+
+---



Other differences:
--
++ ghc-bootstrap.spec ++
--- /var/tmp/diff_new_pack.dyWYzS/_old  2018-02-09 15:48:50.212609856 +0100
+++ /var/tmp/diff_new_pack.dyWYzS/_new  2018-02-09 15:48:50.216609712 +0100
@@ -55,8 +55,6 @@
 
 %global without_hscolour 1
 
-%global debug_package %{nil}
-
 Name:   ghc-bootstrap
 Version:7.8.3
 Release:0




commit salt for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package salt for openSUSE:Factory checked in 
at 2018-02-09 15:48:16

Comparing /work/SRC/openSUSE:Factory/salt (Old)
 and  /work/SRC/openSUSE:Factory/.salt.new (New)


Package is "salt"

Fri Feb  9 15:48:16 2018 rev:71 rq:574155 version:2017.7.2

Changes:

--- /work/SRC/openSUSE:Factory/salt/salt.changes2018-01-28 
20:33:23.790964908 +0100
+++ /work/SRC/openSUSE:Factory/.salt.new/salt.changes   2018-02-09 
15:48:21.625636471 +0100
@@ -1,0 +2,17 @@
+Wed Feb 07 13:23:51 UTC 2018 - Mihai Dinca 
+
+- Prevent queryformat pattern from expanding (bsc#1079048)
+
+---
+Thu Feb 01 12:38:12 UTC 2018 - jbre...@suse.de
+
+- Fix epoch handling for Rhel 6 and 7 (bsc#1068566)
+- Reverting to current API for split_input
+
+- Added:
+  * yumpkg-don-t-use-diff_attr-when-determining-install-.patch
+
+- Removed:
+  * fix-for-wrong-version-processing.patch
+
+---
@@ -4 +21 @@
-- Fix for wrong version processing during yum pkg install
+- Fix for wrong version processing during yum pkg install (bsc#1068566)
@@ -115 +132 @@
-- Older logrotate need su directive
+- Older logrotate need su directive (bsc#1071322)

Old:

  fix-for-wrong-version-processing.patch

New:

  yumpkg-don-t-use-diff_attr-when-determining-install-.patch



Other differences:
--
++ salt.spec ++
--- /var/tmp/diff_new_pack.f3ZNoq/_old  2018-02-09 15:48:22.869591799 +0100
+++ /var/tmp/diff_new_pack.f3ZNoq/_new  2018-02-09 15:48:22.873591656 +0100
@@ -77,17 +77,17 @@
 Patch10:   fix-for-delete_deployment-in-kubernetes-module.patch
 Patch11:   catching-error-when-pidfile-cannot-be-deleted.patch
 Patch12:   avoid-excessive-syslogging-by-watchdog-cronjob-58.patch
-Patch13:   fix-for-wrong-version-processing.patch
-Patch14:   older-logrotate-need-su-directive.patch
-Patch15:   fix-salt-master-for-old-psutil.patch
-Patch16:   split-only-strings-if-they-are-such.patch
-Patch17:   cherrypy-read-reads-bytes-from-the-wire-and-write-th.patch
-Patch19:   python3-compatibility-fix-got-bytes-instead-of-strin.patch
-Patch20:   feat-add-grain-for-all-fqdns.patch
-Patch21:   fix-bsc-1065792.patch
-Patch22:   set-shell-environment-variable-64.patch
-Patch23:   bugfix-the-logic-according-to-the-exact-described-pu.patch
-Patch24:   return-error-when-gid_from_name-and-group-does-not-e.patch
+Patch13:   older-logrotate-need-su-directive.patch
+Patch14:   fix-salt-master-for-old-psutil.patch
+Patch15:   split-only-strings-if-they-are-such.patch
+Patch16:   cherrypy-read-reads-bytes-from-the-wire-and-write-th.patch
+Patch17:   python3-compatibility-fix-got-bytes-instead-of-strin.patch
+Patch19:   feat-add-grain-for-all-fqdns.patch
+Patch20:   fix-bsc-1065792.patch
+Patch21:   set-shell-environment-variable-64.patch
+Patch22:   bugfix-the-logic-according-to-the-exact-described-pu.patch
+Patch23:   return-error-when-gid_from_name-and-group-does-not-e.patch
+Patch24:   yumpkg-don-t-use-diff_attr-when-determining-install-.patch
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  logrotate
@@ -904,7 +904,7 @@
   true
 fi
 %if %{with systemd}
-if [ `rpm -q systemd --queryformat="%{VERSION}"` -lt 228 ]; then
+if [ `rpm -q systemd --queryformat="%%{VERSION}"` -lt 228 ]; then
   # On systemd < 228 the 'TasksTask' attribute is not available.
   # Removing TasksMax from salt-master.service on SLE12SP1 LTSS (bsc#985112)
   sed -i '/TasksMax=infinity/d' %{_unitdir}/salt-master.service

++ activate-all-beacons-sources-config-pillar-grains.patch ++
--- /var/tmp/diff_new_pack.f3ZNoq/_old  2018-02-09 15:48:22.941589214 +0100
+++ /var/tmp/diff_new_pack.f3ZNoq/_new  2018-02-09 15:48:22.941589214 +0100
@@ -21,6 +21,6 @@
  return self.beacons.process(b_conf, self.opts['grains'])  # 
pylint: disable=no-member
  return []
 -- 
-2.15.1
+2.13.6
 
 

++ avoid-excessive-syslogging-by-watchdog-cronjob-58.patch ++
--- /var/tmp/diff_new_pack.f3ZNoq/_old  2018-02-09 15:48:22.957588639 +0100
+++ /var/tmp/diff_new_pack.f3ZNoq/_new  2018-02-09 15:48:22.957588639 +0100
@@ -1,4 +1,4 @@
-From a94f7d5739fd38529ebf23a89e6afc164739dd8d Mon Sep 17 00:00:00 2001
+From 35984b8055beccc94b3bd92b637c5435db822cc9 Mon Sep 17 00:00:00 2001
 From: Hubert Mantel 
 Date: Mon, 27 Nov 2017 13:55:13 +0100
 Subject: [PATCH] avoid excessive syslogging by watchdog cronjob (#58)
@@ -21,6 +21,6 @@
  /usr/bin/salt-daemon-watcher --with-init & disown
  fi
 -- 
-2.15.1
+2.13.6
 
 

++ 

commit yast2-firstboot for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package yast2-firstboot for openSUSE:Factory 
checked in at 2018-02-09 15:48:13

Comparing /work/SRC/openSUSE:Factory/yast2-firstboot (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-firstboot.new (New)


Package is "yast2-firstboot"

Fri Feb  9 15:48:13 2018 rev:70 rq:574130 version:4.0.3

Changes:

--- /work/SRC/openSUSE:Factory/yast2-firstboot/yast2-firstboot.changes  
2018-01-19 11:53:15.639504020 +0100
+++ /work/SRC/openSUSE:Factory/.yast2-firstboot.new/yast2-firstboot.changes 
2018-02-09 15:48:14.829880518 +0100
@@ -1,0 +2,6 @@
+Thu Feb  8 08:38:38 UTC 2018 - jsr...@suse.cz
+
+- adapted to changes in the Language module (bsc#1079852)
+- 4.0.3
+
+---

Old:

  yast2-firstboot-4.0.2.tar.bz2

New:

  yast2-firstboot-4.0.3.tar.bz2



Other differences:
--
++ yast2-firstboot.spec ++
--- /var/tmp/diff_new_pack.yRjCAU/_old  2018-02-09 15:48:15.529855380 +0100
+++ /var/tmp/diff_new_pack.yRjCAU/_new  2018-02-09 15:48:15.533855237 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-firstboot
-Version:4.0.2
+Version:4.0.3
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ yast2-firstboot-4.0.2.tar.bz2 -> yast2-firstboot-4.0.3.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-firstboot-4.0.2/package/yast2-firstboot.changes 
new/yast2-firstboot-4.0.3/package/yast2-firstboot.changes
--- old/yast2-firstboot-4.0.2/package/yast2-firstboot.changes   2018-01-16 
09:53:29.0 +0100
+++ new/yast2-firstboot-4.0.3/package/yast2-firstboot.changes   2018-02-08 
11:12:40.0 +0100
@@ -1,4 +1,10 @@
 ---
+Thu Feb  8 08:38:38 UTC 2018 - jsr...@suse.cz
+
+- adapted to changes in the Language module (bsc#1079852)
+- 4.0.3
+
+---
 Tue Jan 16 09:12:23 CET 2018 - sch...@suse.de
 
 - Do not initialize firstboot in AutoYaST upgrade mode.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-firstboot-4.0.2/package/yast2-firstboot.spec 
new/yast2-firstboot-4.0.3/package/yast2-firstboot.spec
--- old/yast2-firstboot-4.0.2/package/yast2-firstboot.spec  2018-01-16 
09:53:29.0 +0100
+++ new/yast2-firstboot-4.0.3/package/yast2-firstboot.spec  2018-02-08 
11:12:40.0 +0100
@@ -16,7 +16,7 @@
 #
 
 Name:   yast2-firstboot
-Version:4.0.2
+Version:4.0.3
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-firstboot-4.0.2/src/clients/firstboot_language_keyboard.rb 
new/yast2-firstboot-4.0.3/src/clients/firstboot_language_keyboard.rb
--- old/yast2-firstboot-4.0.2/src/clients/firstboot_language_keyboard.rb
2018-01-16 09:53:29.0 +0100
+++ new/yast2-firstboot-4.0.3/src/clients/firstboot_language_keyboard.rb
2018-02-08 11:12:40.0 +0100
@@ -258,7 +258,7 @@
 
 # install language dependent packages now
 # Language::PackagesModified () does not work here as _on_entry 
variables are not set
-if @language != Language.ReadSysconfigLanguage
+if @language != Language.ReadLocaleConfLanguage
   if !Language.PackagesInit([@language])
 # error message
 Report.Error(




commit perl-Spreadsheet-Read for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package perl-Spreadsheet-Read for 
openSUSE:Factory checked in at 2018-02-09 15:47:52

Comparing /work/SRC/openSUSE:Factory/perl-Spreadsheet-Read (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Spreadsheet-Read.new (New)


Package is "perl-Spreadsheet-Read"

Fri Feb  9 15:47:52 2018 rev:13 rq:574017 version:0.78

Changes:

--- 
/work/SRC/openSUSE:Factory/perl-Spreadsheet-Read/perl-Spreadsheet-Read.changes  
2018-01-23 13:53:11.617041770 +0100
+++ 
/work/SRC/openSUSE:Factory/.perl-Spreadsheet-Read.new/perl-Spreadsheet-Read.changes
 2018-02-09 15:47:59.654425487 +0100
@@ -1,0 +2,6 @@
+Thu Feb  8 06:09:34 UTC 2018 - co...@suse.com
+
+- updated to 0.78
+   see /usr/share/doc/packages/perl-Spreadsheet-Read/
+
+---

Old:

  Spreadsheet-Read-0.74.tgz

New:

  Spreadsheet-Read-0.78.tgz



Other differences:
--
++ perl-Spreadsheet-Read.spec ++
--- /var/tmp/diff_new_pack.bnEF8T/_old  2018-02-09 15:48:00.750386130 +0100
+++ /var/tmp/diff_new_pack.bnEF8T/_new  2018-02-09 15:48:00.754385986 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Spreadsheet-Read
-Version:0.74
+Version:0.78
 Release:0
 %define cpan_name Spreadsheet-Read
 Summary:Read the data from a spreadsheet

++ Spreadsheet-Read-0.74.tgz -> Spreadsheet-Read-0.78.tgz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Spreadsheet-Read-0.74/Changes 
new/Spreadsheet-Read-0.78/Changes
--- old/Spreadsheet-Read-0.74/Changes   2017-08-27 15:45:47.0 +0200
+++ new/Spreadsheet-Read-0.78/Changes   2018-01-29 17:40:14.0 +0100
@@ -1,3 +1,25 @@
+0.78   - 29 Jan 2018, H.Merijn Brand
+* Spreadsheet::ParseExcel supports the active flag as of version 0.61
+* Fix typo in docs (SPROUT, RT#124214)
+
+0.77   - 22 Jan 2018, H.Merijn Brand
+* Note possible name clashes with example/tool files
+* Clipping and stripping more efficient
+
+0.76   - 01 Jan 2018, H.Merijn Brand
+* Allow streaming in xlscat
+* Add --dump to xlscat
+* Add error for opening ODS/SXC from reference
+* It's 2018
+
+0.75   - 09 Nov 2017, H.Merijn Brand
+* Windows does not like an exec with arguments that have spaces (PR#15)
+  Three fixes by Andrew Gregory ). Thanks!
+* Fix column clipping
+* Manually generate cells to delete when clipping
+* Skip cell deletion if they were never generated
+* File names cannot have \0 in newer perls
+
 0.74   - 27 Aug 2017, H.Merijn Brand
 * Re-enable opening files with bad characters in the filename (issue#14)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Spreadsheet-Read-0.74/MANIFEST 
new/Spreadsheet-Read-0.78/MANIFEST
--- old/Spreadsheet-Read-0.74/MANIFEST  2017-08-27 15:46:33.0 +0200
+++ new/Spreadsheet-Read-0.78/MANIFEST  2018-01-29 17:40:46.0 +0100
@@ -34,6 +34,7 @@
 files/perc.xls
 files/perc.xlsx
 files/test.csv
+files/test.gnumeric
 files/test_m.csv
 files/test_m.txt
 files/test.ods
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Spreadsheet-Read-0.74/META.json 
new/Spreadsheet-Read-0.78/META.json
--- old/Spreadsheet-Read-0.74/META.json 2017-08-27 15:46:34.0 +0200
+++ new/Spreadsheet-Read-0.78/META.json 2018-01-29 17:40:46.0 +0100
@@ -1,134 +1,134 @@
 {
"abstract" : "Meta-Wrapper for reading spreadsheet data",
-   "generated_by" : "Author",
"name" : "Spreadsheet-Read",
"prereqs" : {
+  "configure" : {
+ "requires" : {
+"ExtUtils::MakeMaker" : "0"
+ }
+  },
   "test" : {
  "requires" : {
 "Test::Harness" : "0",
-"Test::More" : "0.88",
-"Test::NoWarnings" : "0"
+"Test::NoWarnings" : "0",
+"Test::More" : "0.88"
  },
  "recommends" : {
-"Test::More" : "1.302086"
+"Test::More" : "1.302120"
  }
   },
   "runtime" : {
  "requires" : {
-"Exporter" : "0",
-"File::Temp" : "0.22",
 "Data::Dumper" : "0",
+"Data::Peek" : "0",
+"Exporter" : "0",
+"Carp" : "0",
 "perl" : "5.008001",
 "Encode" : "0",
-"Data::Peek" : "0",
-"Carp" : "0"
+"File::Temp" : "0.22"
  },
  "recommends" : {
-"Data::Peek" : "0.47",
 "IO::Scalar" : "0",
-"File::Temp" : "0.2304"
- }
-  },
-  "configure" : {
- "requires" : {
-

commit liboop for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package liboop for openSUSE:Factory checked 
in at 2018-02-09 15:48:09

Comparing /work/SRC/openSUSE:Factory/liboop (Old)
 and  /work/SRC/openSUSE:Factory/.liboop.new (New)


Package is "liboop"

Fri Feb  9 15:48:09 2018 rev:17 rq:574112 version:1.0.1

Changes:

--- /work/SRC/openSUSE:Factory/liboop/liboop.changes2012-02-07 
14:46:12.0 +0100
+++ /work/SRC/openSUSE:Factory/.liboop.new/liboop.changes   2018-02-09 
15:48:10.894021859 +0100
@@ -1,0 +2,9 @@
+Thu Feb  8 08:04:14 UTC 2018 - aloi...@gmx.com
+
+- Update to version 1.0.1
+  * no changelog supplied
+  * new maintainer and homepage
+
+- Spec cleanup
+
+---

Old:

  liboop.tar.bz2

New:

  liboop-1.0.1.tar.gz
  liboop-1.0.1.tar.gz.sig



Other differences:
--
++ liboop.spec ++
--- /var/tmp/diff_new_pack.AqoWA7/_old  2018-02-09 15:48:11.829988248 +0100
+++ /var/tmp/diff_new_pack.AqoWA7/_new  2018-02-09 15:48:11.833988104 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package liboop
 #
-# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,16 +16,16 @@
 #
 
 
-Name:   liboop
 %define lname  liboop4
-Version:1.0
+Name:   liboop
+Version:1.0.1
 Release:0
-Url:http://liboop.org/
 Summary:Low-Level Event Loop Management Library
 License:LGPL-2.1+
 Group:  Development/Libraries/C and C++
-Source: http://download.ofb.net/liboop/liboop.tar.bz2
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+Url:https://www.lysator.liu.se/liboop
+Source: https://ftp.lysator.liu.se/pub/liboop/liboop-%{version}.tar.gz
+Source1:
https://ftp.lysator.liu.se/pub/liboop/liboop-%{version}.tar.gz.sig
 BuildRequires:  pkgconfig
 
 %description
@@ -37,16 +37,10 @@
 processes use these mechanisms for almost all external communication,
 liboop can be used as the basis for almost any application.
 
-
-
-Authors:
-
-Dan Egnor 
-
 %package -n %lname
 Summary:Low-Level Event Loop Management Library
-Group:  System/Libraries
 #O/P added for 12.1
+Group:  System/Libraries
 Obsoletes:  liboop < %version-%release
 Provides:   liboop = %version-%release
 
@@ -68,12 +62,6 @@
 This package contains the static libraries and header files needed to
 develop programs which make use of the liboop programming interface.
 
-
-
-Authors:
-
-Dan Egnor 
-
 %prep
 %setup -q
 
@@ -85,7 +73,7 @@
 make check %{?_smp_mflags}
 
 %install
-%{__make} DESTDIR=${RPM_BUILD_ROOT} install
+make DESTDIR=%{buildroot} install
 
 %post -n %lname -p /sbin/ldconfig
 




commit bcc for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package bcc for openSUSE:Factory checked in 
at 2018-02-09 15:48:05

Comparing /work/SRC/openSUSE:Factory/bcc (Old)
 and  /work/SRC/openSUSE:Factory/.bcc.new (New)


Package is "bcc"

Fri Feb  9 15:48:05 2018 rev:17 rq:574060 version:0.5.0

Changes:

--- /work/SRC/openSUSE:Factory/bcc/bcc.changes  2018-01-20 11:27:50.397208880 
+0100
+++ /work/SRC/openSUSE:Factory/.bcc.new/bcc.changes 2018-02-09 
15:48:05.902201122 +0100
@@ -1,0 +2,6 @@
+Thu Feb  8 04:43:53 UTC 2018 - g...@suse.com
+
+- Update bcc-python3.patch to make python3 default for all the
+  python scripts (bsc#1079961)
+
+---



Other differences:
--
++ bcc-python3.patch ++
 2280 lines (skipped)
 between /work/SRC/openSUSE:Factory/bcc/bcc-python3.patch
 and /work/SRC/openSUSE:Factory/.bcc.new/bcc-python3.patch




commit crmsh for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package crmsh for openSUSE:Factory checked 
in at 2018-02-09 15:48:01

Comparing /work/SRC/openSUSE:Factory/crmsh (Old)
 and  /work/SRC/openSUSE:Factory/.crmsh.new (New)


Package is "crmsh"

Fri Feb  9 15:48:01 2018 rev:140 rq:574058 version:4.0.0+git.1518073467.76fb6a0b

Changes:

--- /work/SRC/openSUSE:Factory/crmsh/crmsh.changes  2018-02-07 
18:42:51.896104819 +0100
+++ /work/SRC/openSUSE:Factory/.crmsh.new/crmsh.changes 2018-02-09 
15:48:02.158335569 +0100
@@ -1,0 +2,6 @@
+Thu Feb 08 07:05:28 UTC 2018 - kgronl...@suse.com
+
+- Update to version 4.0.0+git.1518073467.76fb6a0b:
+  * high: crm_script: Python2->3 string conversion crash in wizards 
(bsc#1074835)
+
+---

Old:

  crmsh-4.0.0+git.1518010150.a58fa637.tar.bz2

New:

  crmsh-4.0.0+git.1518073467.76fb6a0b.tar.bz2



Other differences:
--
++ crmsh.spec ++
--- /var/tmp/diff_new_pack.ODpf6s/_old  2018-02-09 15:48:02.970306410 +0100
+++ /var/tmp/diff_new_pack.ODpf6s/_new  2018-02-09 15:48:02.974306266 +0100
@@ -36,7 +36,7 @@
 Summary:High Availability cluster command-line interface
 License:GPL-2.0+
 Group:  %{pkg_group}
-Version:4.0.0+git.1518010150.a58fa637
+Version:4.0.0+git.1518073467.76fb6a0b
 Release:0
 Url:http://crmsh.github.io
 Source0:%{name}-%{version}.tar.bz2

++ _servicedata ++
--- /var/tmp/diff_new_pack.ODpf6s/_old  2018-02-09 15:48:03.010304973 +0100
+++ /var/tmp/diff_new_pack.ODpf6s/_new  2018-02-09 15:48:03.010304973 +0100
@@ -1,4 +1,4 @@
 
 
 git://github.com/ClusterLabs/crmsh.git
-  a58fa637efb583995c31c62d3fa3894b875e2f3a
\ No newline at end of file
+  76fb6a0be7c121e971907d98af7e4b3bbc6f9548
\ No newline at end of file

++ crmsh-4.0.0+git.1518010150.a58fa637.tar.bz2 -> 
crmsh-4.0.0+git.1518073467.76fb6a0b.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/crmsh-4.0.0+git.1518010150.a58fa637/utils/crm_script.py 
new/crmsh-4.0.0+git.1518073467.76fb6a0b/utils/crm_script.py
--- old/crmsh-4.0.0+git.1518010150.a58fa637/utils/crm_script.py 2018-02-07 
14:29:10.0 +0100
+++ new/crmsh-4.0.0+git.1518073467.76fb6a0b/utils/crm_script.py 2018-02-08 
08:04:27.0 +0100
@@ -22,6 +22,16 @@
 break
 
 
+def decode_utf8(s):
+"""
+Convert the given byte sequence to a
+utf8 string.
+"""
+if s is None or isinstance(s, str):
+return s
+return s.decode('utf-8', 'ignore')
+
+
 def host():
 return os.uname()[1]
 
@@ -96,7 +106,7 @@
 debug("crm_script(call): %s" % (cmd))
 p = proc.Popen(cmd, shell=shell, stdin=None, stdout=proc.PIPE, 
stderr=proc.PIPE)
 out, err = p.communicate()
-return p.returncode, out.decode('utf-8').strip(), 
err.decode('utf-8').strip()
+return p.returncode, decode_utf8(out).strip(), decode_utf8(err).strip()
 
 
 def use_sudo():
@@ -131,7 +141,7 @@
 rc, out, err = sudo_call(['./crm_pkg.py', '-n', name, '-s', state])
 if rc != 0:
 raise IOError("%s / %s" % (out, err))
-outp = json.loads(out.decode('utf-8'))
+outp = json.loads(decode_utf8(out))
 if isinstance(outp, dict) and 'rc' in outp:
 rc = int(outp['rc'])
 if rc != 0:




commit perl-Future for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package perl-Future for openSUSE:Factory 
checked in at 2018-02-09 15:47:35

Comparing /work/SRC/openSUSE:Factory/perl-Future (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Future.new (New)


Package is "perl-Future"

Fri Feb  9 15:47:35 2018 rev:6 rq:573989 version:0.38

Changes:

--- /work/SRC/openSUSE:Factory/perl-Future/perl-Future.changes  2017-12-08 
13:01:47.736134241 +0100
+++ /work/SRC/openSUSE:Factory/.perl-Future.new/perl-Future.changes 
2018-02-09 15:47:38.315191794 +0100
@@ -1,0 +2,13 @@
+Wed Feb  7 16:32:52 UTC 2018 - co...@suse.com
+
+- updated to 0.38
+   see /usr/share/doc/packages/perl-Future/Changes
+
+  0.382017-12-18 01:41:52
+  [CHANGES]
+   * Added counting ability to Future::Mutex (RT123876)
+  
+  [BUGFIXES]
+   * Support perl 5.8.1 again (thanks ilmari)
+
+---

Old:

  Future-0.37.tar.gz

New:

  Future-0.38.tar.gz



Other differences:
--
++ perl-Future.spec ++
--- /var/tmp/diff_new_pack.ittctq/_old  2018-02-09 15:47:39.207159763 +0100
+++ /var/tmp/diff_new_pack.ittctq/_new  2018-02-09 15:47:39.211159620 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Future
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Future
-Version:0.37
+Version:0.38
 Release:0
 %define cpan_name Future
 Summary:Represent an Operation Awaiting Completion

++ Future-0.37.tar.gz -> Future-0.38.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Future-0.37/Changes new/Future-0.38/Changes
--- old/Future-0.37/Changes 2017-11-28 16:41:25.0 +0100
+++ new/Future-0.38/Changes 2017-12-18 02:44:55.0 +0100
@@ -1,5 +1,12 @@
 Revision history for Future
 
+0.382017-12-18 01:41:52
+[CHANGES]
+ * Added counting ability to Future::Mutex (RT123876)
+
+[BUGFIXES]
+ * Support perl 5.8.1 again (thanks ilmari)
+
 0.372017/11/28 15:39:22
 [CHANGES]
  * Finally got around to removing the old Makefile.PL
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Future-0.37/META.json new/Future-0.38/META.json
--- old/Future-0.37/META.json   2017-11-28 16:41:25.0 +0100
+++ new/Future-0.38/META.json   2017-12-18 02:44:55.0 +0100
@@ -39,19 +39,19 @@
"provides" : {
   "Future" : {
  "file" : "lib/Future.pm",
- "version" : "0.37"
+ "version" : "0.38"
   },
   "Future::Mutex" : {
  "file" : "lib/Future/Mutex.pm",
- "version" : "0.37"
+ "version" : "0.38"
   },
   "Future::Utils" : {
  "file" : "lib/Future/Utils.pm",
- "version" : "0.37"
+ "version" : "0.38"
   },
   "Test::Future" : {
  "file" : "lib/Test/Future.pm",
- "version" : "0.37"
+ "version" : "0.38"
   }
},
"release_status" : "stable",
@@ -61,6 +61,6 @@
   ],
   "x_IRC" : "irc://irc.perl.org/#io-async"
},
-   "version" : "0.37",
+   "version" : "0.38",
"x_serialization_backend" : "JSON::PP version 2.94"
 }
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Future-0.37/META.yml new/Future-0.38/META.yml
--- old/Future-0.37/META.yml2017-11-28 16:41:25.0 +0100
+++ new/Future-0.38/META.yml2017-12-18 02:44:55.0 +0100
@@ -19,16 +19,16 @@
 provides:
   Future:
 file: lib/Future.pm
-version: '0.37'
+version: '0.38'
   Future::Mutex:
 file: lib/Future/Mutex.pm
-version: '0.37'
+version: '0.38'
   Future::Utils:
 file: lib/Future/Utils.pm
-version: '0.37'
+version: '0.38'
   Test::Future:
 file: lib/Test/Future.pm
-version: '0.37'
+version: '0.38'
 requires:
   Carp: '1.25'
   Test::Builder::Module: '0'
@@ -37,5 +37,5 @@
 resources:
   IRC: irc://irc.perl.org/#io-async
   license: http://dev.perl.org/licenses/
-version: '0.37'
+version: '0.38'
 x_serialization_backend: 'CPAN::Meta::YAML version 0.018'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Future-0.37/lib/Future/Mutex.pm 
new/Future-0.38/lib/Future/Mutex.pm
--- old/Future-0.37/lib/Future/Mutex.pm 2017-11-28 16:41:25.0 +0100
+++ new/Future-0.38/lib/Future/Mutex.pm 2017-12-18 02:44:55.0 +0100
@@ -1,14 +1,14 

commit perl-Log-Any for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package perl-Log-Any for openSUSE:Factory 
checked in at 2018-02-09 15:47:29

Comparing /work/SRC/openSUSE:Factory/perl-Log-Any (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Log-Any.new (New)


Package is "perl-Log-Any"

Fri Feb  9 15:47:29 2018 rev:22 rq:573985 version:1.705

Changes:

--- /work/SRC/openSUSE:Factory/perl-Log-Any/perl-Log-Any.changes
2018-01-09 14:51:15.445247368 +0100
+++ /work/SRC/openSUSE:Factory/.perl-Log-Any.new/perl-Log-Any.changes   
2018-02-09 15:47:30.291479928 +0100
@@ -1,0 +2,23 @@
+Wed Feb  7 16:44:12 UTC 2018 - co...@suse.com
+
+- updated to 1.705
+   see /usr/share/doc/packages/perl-Log-Any/Changes
+
+  1.705 2018-01-17 13:49:22-06:00 America/Chicago
+  
+  [Fixed]
+  
+  - Fixed the `binmode` attribute of the File adapter not working
+properly. Thanks @MadLord80! [Github #71]
+  
+  1.704 2017-12-17 18:13:33-06:00 America/Chicago
+  
+  [Fixed]
+  
+  - Fixed some invalid POD and added a test to ensure POD validity
+before release. Thanks @shlomif! [Github #67][Github #68]
+  
+  - Improved performance when no work needed to be done. Thanks
+@mephinet! [Github #70]
+
+---

Old:

  Log-Any-1.703.tar.gz

New:

  Log-Any-1.705.tar.gz



Other differences:
--
++ perl-Log-Any.spec ++
--- /var/tmp/diff_new_pack.Xlyxuc/_old  2018-02-09 15:47:31.159448759 +0100
+++ /var/tmp/diff_new_pack.Xlyxuc/_new  2018-02-09 15:47:31.159448759 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Log-Any
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Log-Any
-Version:1.703
+Version:1.705
 Release:0
 %define cpan_name Log-Any
 Summary:Bringing loggers and listeners together

++ Log-Any-1.703.tar.gz -> Log-Any-1.705.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Log-Any-1.703/Changes new/Log-Any-1.705/Changes
--- old/Log-Any-1.703/Changes   2017-11-29 17:56:37.0 +0100
+++ new/Log-Any-1.705/Changes   2018-01-17 20:49:43.0 +0100
@@ -2,6 +2,23 @@
 
 ** denotes an incompatible change
 
+1.705 2018-01-17 13:49:22-06:00 America/Chicago
+
+[Fixed]
+
+- Fixed the `binmode` attribute of the File adapter not working
+  properly. Thanks @MadLord80! [Github #71]
+
+1.704 2017-12-17 18:13:33-06:00 America/Chicago
+
+[Fixed]
+
+- Fixed some invalid POD and added a test to ensure POD validity
+  before release. Thanks @shlomif! [Github #67][Github #68]
+
+- Improved performance when no work needed to be done. Thanks
+  @mephinet! [Github #70]
+
 1.703 2017-11-29 10:56:17-06:00 America/Chicago
 
 [Fixed]
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Log-Any-1.703/MANIFEST new/Log-Any-1.705/MANIFEST
--- old/Log-Any-1.703/MANIFEST  2017-11-29 17:56:37.0 +0100
+++ new/Log-Any-1.705/MANIFEST  2018-01-17 20:49:43.0 +0100
@@ -30,6 +30,7 @@
 t/00-report-prereqs.t
 t/TestAdapters.pm
 t/adapter-import.t
+t/author-pod-syntax.t
 t/context.t
 t/default-adapter-env.t
 t/default-adapter-params.t
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Log-Any-1.703/META.json new/Log-Any-1.705/META.json
--- old/Log-Any-1.703/META.json 2017-11-29 17:56:37.0 +0100
+++ new/Log-Any-1.705/META.json 2018-01-17 20:49:43.0 +0100
@@ -36,6 +36,11 @@
 "ExtUtils::MakeMaker" : "0"
  }
   },
+  "develop" : {
+ "requires" : {
+"Test::Pod" : "1.41"
+ }
+  },
   "runtime" : {
  "requires" : {
 "B" : "0",
@@ -70,63 +75,63 @@
"provides" : {
   "Log::Any" : {
  "file" : "lib/Log/Any.pm",
- "version" : "1.703"
+ "version" : "1.705"
   },
   "Log::Any::Adapter" : {
  "file" : "lib/Log/Any/Adapter.pm",
- "version" : "1.703"
+ "version" : "1.705"
   },
   "Log::Any::Adapter::Base" : {
  "file" : "lib/Log/Any/Adapter/Base.pm",
- "version" : "1.703"
+ "version" : "1.705"
   },
   "Log::Any::Adapter::File" : {
  "file" : "lib/Log/Any/Adapter/File.pm",
- "version" : "1.703"
+ "version" : "1.705"
   },
   "Log::Any::Adapter::Null" : {
  "file" : 

commit perl-CPAN-Perl-Releases for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package perl-CPAN-Perl-Releases for 
openSUSE:Factory checked in at 2018-02-09 15:47:46

Comparing /work/SRC/openSUSE:Factory/perl-CPAN-Perl-Releases (Old)
 and  /work/SRC/openSUSE:Factory/.perl-CPAN-Perl-Releases.new (New)


Package is "perl-CPAN-Perl-Releases"

Fri Feb  9 15:47:46 2018 rev:55 rq:573995 version:3.46

Changes:

--- 
/work/SRC/openSUSE:Factory/perl-CPAN-Perl-Releases/perl-CPAN-Perl-Releases.changes
  2017-12-11 18:56:52.433501646 +0100
+++ 
/work/SRC/openSUSE:Factory/.perl-CPAN-Perl-Releases.new/perl-CPAN-Perl-Releases.changes
 2018-02-09 15:47:47.730853672 +0100
@@ -1,0 +2,6 @@
+Wed Feb  7 16:11:29 UTC 2018 - co...@suse.com
+
+- updated to 3.46
+   see /usr/share/doc/packages/perl-CPAN-Perl-Releases/Changes
+
+---

Old:

  CPAN-Perl-Releases-3.42.tar.gz

New:

  CPAN-Perl-Releases-3.46.tar.gz



Other differences:
--
++ perl-CPAN-Perl-Releases.spec ++
--- /var/tmp/diff_new_pack.6Z11t8/_old  2018-02-09 15:47:49.510789753 +0100
+++ /var/tmp/diff_new_pack.6Z11t8/_new  2018-02-09 15:47:49.510789753 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-CPAN-Perl-Releases
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   perl-CPAN-Perl-Releases
-Version:3.42
+Version:3.46
 Release:0
 %define cpan_name CPAN-Perl-Releases
 Summary:Mapping Perl releases on CPAN to the location of the tarballs

++ CPAN-Perl-Releases-3.42.tar.gz -> CPAN-Perl-Releases-3.46.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/CPAN-Perl-Releases-3.42/Changes 
new/CPAN-Perl-Releases-3.46/Changes
--- old/CPAN-Perl-Releases-3.42/Changes 2017-11-21 00:27:15.0 +0100
+++ new/CPAN-Perl-Releases-3.46/Changes 2018-01-20 12:10:07.0 +0100
@@ -1,8 +1,28 @@
 ==
-Changes from 2012-11-21 00:00:00 + to present.
+Changes from 2013-01-21 00:00:00 + to present.
 ==
 
 -
+version 3.46 at 2018-01-20 11:07:29 +
+-
+
+  Change: f56297606d2b5f0d4a73182943f1eb3bda46b0a4
+  Author: Chris 'BinGOs' Williams 
+  Date : 2018-01-20 11:07:29 +
+
+Updated for v5.27.8 
+
+-
+version 3.44 at 2017-12-20 22:36:14 +
+-
+
+  Change: 507f8355e9dad418d5dae235d0c0a3c8cc47760d
+  Author: Chris 'BinGOs' Williams 
+  Date : 2017-12-20 22:36:14 +
+
+Updated for v5.27.7 
+
+-
 version 3.42 at 2017-11-20 23:24:42 +
 -
 
@@ -1319,26 +1339,6 @@
 
 Updated for v5.17.9 
 
--
-version 0.94 at 2013-01-20 18:11:42 +
--
-
-  Change: 607edea3b9be79d7856f37aae2f23f3a8e842f1e
-  Author: Chris 'BinGOs' Williams 
-  Date : 2013-01-20 18:11:42 +
-
-Updated for v5.17.8 
-
--
-version 0.92 at 2012-12-18 18:41:33 +
--
-
-  Change: 21ab9dce1d13e232b16b47fecb4777b6e3d643f5
-  Author: Chris 'BinGOs' Williams 
-  Date : 2012-12-18 18:41:33 +
-
-Updated for v5.17.7 
-
 =
-Plus 44 releases after 2012-11-21 00:00:00 +.
+Plus 46 releases after 2013-01-21 00:00:00 +.
 =
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/CPAN-Perl-Releases-3.42/LICENSE 
new/CPAN-Perl-Releases-3.46/LICENSE
--- old/CPAN-Perl-Releases-3.42/LICENSE 2017-11-21 00:27:15.0 +0100
+++ new/CPAN-Perl-Releases-3.46/LICENSE 2018-01-20 12:10:07.0 +0100
@@ -1,4 +1,4 @@
-This software is copyright (c) 2017 by Chris Williams.
+This software is copyright (c) 2018 by Chris Williams.
 
 This is free software; you can redistribute it and/or modify it under
 the same terms as the Perl 5 programming language system itself.
@@ -12,7 +12,7 @@
 
 --- The GNU General Public License, Version 1, February 1989 ---
 
-This software is Copyright (c) 2017 by Chris Williams.
+This software is Copyright (c) 

commit perl-Module-Install for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package perl-Module-Install for 
openSUSE:Factory checked in at 2018-02-09 15:47:26

Comparing /work/SRC/openSUSE:Factory/perl-Module-Install (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Module-Install.new (New)


Package is "perl-Module-Install"

Fri Feb  9 15:47:26 2018 rev:16 rq:573984 version:1.19

Changes:

--- /work/SRC/openSUSE:Factory/perl-Module-Install/perl-Module-Install.changes  
2017-04-11 12:43:42.390943116 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-Module-Install.new/perl-Module-Install.changes 
2018-02-09 15:47:29.051524455 +0100
@@ -1,0 +2,10 @@
+Wed Feb  7 16:50:47 UTC 2018 - co...@suse.com
+
+- updated to 1.19
+   see /usr/share/doc/packages/perl-Module-Install/Changes
+
+  1.19  2017-12-19
+- remove use of INIT phase in Module::Install::DSL, to fix issues on perl
+  5.27.7 (see cpan RT#123867 and perl RT#132577)
+
+---

Old:

  Module-Install-1.18.tar.gz

New:

  Module-Install-1.19.tar.gz



Other differences:
--
++ perl-Module-Install.spec ++
--- /var/tmp/diff_new_pack.SuRCN4/_old  2018-02-09 15:47:30.023489552 +0100
+++ /var/tmp/diff_new_pack.SuRCN4/_new  2018-02-09 15:47:30.027489409 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Module-Install
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Module-Install
-Version:1.18
+Version:1.19
 Release:0
 %define cpan_name Module-Install
 Summary:Standalone, extensible Perl module installer

++ Module-Install-1.18.tar.gz -> Module-Install-1.19.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Module-Install-1.18/.travis.yml 
new/Module-Install-1.19/.travis.yml
--- old/Module-Install-1.18/.travis.yml 2017-04-04 21:03:06.0 +0200
+++ new/Module-Install-1.19/.travis.yml 2017-12-20 00:27:31.0 +0100
@@ -1,5 +1,8 @@
 language: perl
 perl:
+  - blead   # builds perl from git
+  - dev # latest point release
+  - '5.26'
   - '5.24'
   - '5.22'
   - '5.20'
@@ -9,6 +12,16 @@
   - '5.12'
   - '5.10'
   - '5.8'
+before_install:
+  - git clone git://github.com/travis-perl/helpers ~/travis-perl-helpers
+  - source ~/travis-perl-helpers/init
+  - build-perl
+  - perl -V
+  - build-dist
+  - cd $BUILD_DIR
 install:
+  - cpan-install YAML::Tiny File::Remove Module::Build Module::ScanDeps 
Parse::CPAN::Meta
+script:
   - perl Makefile.PL
-  - cpanm --quiet --installdeps --notest .
+  - make
+  - prove -b -r -s -j1 $(test-files)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Module-Install-1.18/Changes 
new/Module-Install-1.19/Changes
--- old/Module-Install-1.18/Changes 2017-04-04 21:16:32.0 +0200
+++ new/Module-Install-1.19/Changes 2017-12-20 00:29:13.0 +0100
@@ -1,5 +1,9 @@
 Changes for Perl programming language extension Module-Install
 
+1.19  2017-12-19
+  - remove use of INIT phase in Module::Install::DSL, to fix issues on perl
+5.27.7 (see cpan RT#123867 and perl RT#132577)
+
 1.18  2017-04-04
   - fix tests to no longer rely on . being in @INC (Graham Ollis, PR#58)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Module-Install-1.18/MANIFEST.SKIP 
new/Module-Install-1.19/MANIFEST.SKIP
--- old/Module-Install-1.18/MANIFEST.SKIP   2017-04-04 21:29:13.0 
+0200
+++ new/Module-Install-1.19/MANIFEST.SKIP   2017-04-04 21:30:51.0 
+0200
@@ -1,70 +1,4 @@
-
-#!start included 
/Volumes/amaretto/Users/ether/perl5/perlbrew/perls/25.10/lib/5.25.10/ExtUtils/MANIFEST.SKIP
-# Avoid version control files.
-\bRCS\b
-\bCVS\b
-\bSCCS\b
-,v$
-\B\.svn\b
-\B\.git\b
-\B\.gitignore\b
-\b_darcs\b
-\B\.cvsignore$
-
-# Avoid VMS specific MakeMaker generated files
-\bDescrip.MMS$
-\bDESCRIP.MMS$
-\bdescrip.mms$
-
-# Avoid Makemaker generated and utility files.
-\bMANIFEST\.bak
-\bMakefile$
-\bblib/
-\bMakeMaker-\d
-\bpm_to_blib\.ts$
-\bpm_to_blib$
-\bblibdirs\.ts$ # 6.18 through 6.25 generated this
-\b_eumm/# 7.05_05 and above
-
-# Avoid Module::Build generated and utility files.
-\bBuild$
-\b_build/
-\bBuild.bat$
-\bBuild.COM$
-\bBUILD.COM$
-\bbuild.com$
-
-# and Module::Build::Tiny generated files
-\b_build_params$
-
-# Avoid temp and backup files.
-~$
-\.old$
-\#$
-\b\.#
-\.bak$
-\.tmp$
-\.#
-\.rej$
-\..*\.sw.?$
-
-# Avoid OS-specific 

commit perl-Devel-OverloadInfo for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package perl-Devel-OverloadInfo for 
openSUSE:Factory checked in at 2018-02-09 15:47:43

Comparing /work/SRC/openSUSE:Factory/perl-Devel-OverloadInfo (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Devel-OverloadInfo.new (New)


Package is "perl-Devel-OverloadInfo"

Fri Feb  9 15:47:43 2018 rev:3 rq:573993 version:0.005

Changes:

--- 
/work/SRC/openSUSE:Factory/perl-Devel-OverloadInfo/perl-Devel-OverloadInfo.changes
  2015-08-27 08:56:33.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-Devel-OverloadInfo.new/perl-Devel-OverloadInfo.changes
 2018-02-09 15:47:46.442899924 +0100
@@ -1,0 +2,9 @@
+Wed Feb  7 16:23:31 UTC 2018 - co...@suse.com
+
+- updated to 0.005
+   see /usr/share/doc/packages/perl-Devel-OverloadInfo/Changes
+
+  0.005 2018-01-22 00:45:49+00:00 Europe/London
+- Add overload_op_info() function for info about a single op
+
+---

Old:

  Devel-OverloadInfo-0.004.tar.gz

New:

  Devel-OverloadInfo-0.005.tar.gz



Other differences:
--
++ perl-Devel-OverloadInfo.spec ++
--- /var/tmp/diff_new_pack.0ER2cb/_old  2018-02-09 15:47:47.182873351 +0100
+++ /var/tmp/diff_new_pack.0ER2cb/_new  2018-02-09 15:47:47.182873351 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Devel-OverloadInfo
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,14 +17,14 @@
 
 
 Name:   perl-Devel-OverloadInfo
-Version:0.004
+Version:0.005
 Release:0
 %define cpan_name Devel-OverloadInfo
 Summary:Introspect Overloaded Operators
 License:Artistic-1.0 or GPL-1.0+
 Group:  Development/Libraries/Perl
 Url:http://search.cpan.org/dist/Devel-OverloadInfo/
-Source0:
http://www.cpan.org/authors/id/I/IL/ILMARI/%{cpan_name}-%{version}.tar.gz
+Source0:
https://cpan.metacpan.org/authors/id/I/IL/ILMARI/%{cpan_name}-%{version}.tar.gz
 Source1:cpanspec.yml
 BuildArch:  noarch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -42,9 +42,9 @@
 %{perl_requires}
 
 %description
-Devel::OverloadInfo returns information about overload operators for a
+Devel::OverloadInfo returns information about overloaded operators for a
 given class (or object), including where in the inheritance hierarchy the
-overloads are declared and where the code implementing it is.
+overloads are declared and where the code implementing them is.
 
 %prep
 %setup -q -n %{cpan_name}-%{version}
@@ -63,6 +63,7 @@
 
 %files -f %{name}.files
 %defattr(-,root,root,755)
-%doc Changes LICENSE README
+%doc Changes README
+%license LICENSE
 
 %changelog

++ Devel-OverloadInfo-0.004.tar.gz -> Devel-OverloadInfo-0.005.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Devel-OverloadInfo-0.004/Changes 
new/Devel-OverloadInfo-0.005/Changes
--- old/Devel-OverloadInfo-0.004/Changes2015-08-13 18:35:34.0 
+0200
+++ new/Devel-OverloadInfo-0.005/Changes2018-01-22 01:45:50.0 
+0100
@@ -1,5 +1,8 @@
 Revision history for Devel-OverloadInfo
 
+0.005 2018-01-22 00:45:49+00:00 Europe/London
+  - Add overload_op_info() function for info about a single op
+
 0.004 2015-08-13 17:35:32+01:00 Europe/London
   - Document that existence of undef 'fallback' varies between perl versions
   - Add tests for empty, inherited-only and no overloading
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Devel-OverloadInfo-0.004/MANIFEST 
new/Devel-OverloadInfo-0.005/MANIFEST
--- old/Devel-OverloadInfo-0.004/MANIFEST   2015-08-13 18:35:34.0 
+0200
+++ new/Devel-OverloadInfo-0.005/MANIFEST   2018-01-22 01:45:50.0 
+0100
@@ -1,4 +1,4 @@
-# This file was automatically generated by Dist::Zilla::Plugin::Manifest 
v5.039.
+# This file was automatically generated by Dist::Zilla::Plugin::Manifest 
v6.009.
 Changes
 LICENSE
 MANIFEST
@@ -9,6 +9,6 @@
 dist.ini
 lib/Devel/OverloadInfo.pm
 t/author-pod-spell.t
+t/author-pod-syntax.t
 t/basic.t
-t/release-pod-syntax.t
 t/rt106379-inheritance-corruption.t
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Devel-OverloadInfo-0.004/META.json 
new/Devel-OverloadInfo-0.005/META.json
--- old/Devel-OverloadInfo-0.004/META.json  2015-08-13 18:35:34.0 
+0200
+++ new/Devel-OverloadInfo-0.005/META.json  2018-01-22 01:45:50.0 
+0100
@@ -1,10 

commit perl-File-Path-Tiny for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package perl-File-Path-Tiny for 
openSUSE:Factory checked in at 2018-02-09 15:47:39

Comparing /work/SRC/openSUSE:Factory/perl-File-Path-Tiny (Old)
 and  /work/SRC/openSUSE:Factory/.perl-File-Path-Tiny.new (New)


Package is "perl-File-Path-Tiny"

Fri Feb  9 15:47:39 2018 rev:10 rq:573990 version:0.9

Changes:

--- /work/SRC/openSUSE:Factory/perl-File-Path-Tiny/perl-File-Path-Tiny.changes  
2016-02-17 12:19:48.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.perl-File-Path-Tiny.new/perl-File-Path-Tiny.changes 
2018-02-09 15:47:40.455114948 +0100
@@ -1,0 +2,13 @@
+Wed Feb  7 16:31:14 UTC 2018 - co...@suse.com
+
+- updated to 0.9
+   see /usr/share/doc/packages/perl-File-Path-Tiny/Changes
+
+  0.9  2017-12-29 16:17:42
+  - Do chdir() for security reasons by default
+  - Stop emptying/removing a path if it is changed out from underneath us
+  - rt 96843: Add SEE ALSO section
+  - prereq and unit test fixups
+  - Unit tests for symlink toggling protection
+
+---

Old:

  File-Path-Tiny-0.8.tar.gz

New:

  File-Path-Tiny-0.9.tar.gz



Other differences:
--
++ perl-File-Path-Tiny.spec ++
--- /var/tmp/diff_new_pack.axmMiY/_old  2018-02-09 15:47:41.251086365 +0100
+++ /var/tmp/diff_new_pack.axmMiY/_new  2018-02-09 15:47:41.255086221 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-File-Path-Tiny
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,19 +17,21 @@
 
 
 Name:   perl-File-Path-Tiny
-Version:0.8
+Version:0.9
 Release:0
 %define cpan_name File-Path-Tiny
 Summary:Recursive Versions of Mkdir() and Rmdir() Without As Much 
Overhead As Fi[cut]
 License:Artistic-1.0 or GPL-1.0+
 Group:  Development/Libraries/Perl
 Url:http://search.cpan.org/dist/File-Path-Tiny/
-Source0:
http://www.cpan.org/authors/id/D/DM/DMUEY/%{cpan_name}-%{version}.tar.gz
+Source0:
https://cpan.metacpan.org/authors/id/D/DM/DMUEY/%{cpan_name}-%{version}.tar.gz
 Source1:cpanspec.yml
 BuildArch:  noarch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  perl
 BuildRequires:  perl-macros
+BuildRequires:  perl(Test::Exception)
+Requires:   perl(Test::Exception)
 %{perl_requires}
 
 %description
@@ -53,14 +55,20 @@
 
 * * chdir()s
 
-It does a ton of chdir()s which could leave you somewhere you're not
+It forces a ton of chdir()s which could leave you somewhere you're not
 planning on being and requires much more overhead to do.
 
+This module provides a way to disable that if you know it is safe to do so
+in your circumstance.
+
 * * can croak not allowing you to detect and handle failure
 
 Just let me handle errors how I want. Don't make my entire app die or have
 to wrap it in an eval
 
+The exception here is the security checks can croak, which is what you
+want. See DIAGNOSTICS for more info.
+
 * * A well intentioned output system
 
 Just let me do the output how I want. (Nothing, As HTML, print to a

++ File-Path-Tiny-0.8.tar.gz -> File-Path-Tiny-0.9.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/File-Path-Tiny-0.8/Changes 
new/File-Path-Tiny-0.9/Changes
--- old/File-Path-Tiny-0.8/Changes  2016-01-26 21:48:41.0 +0100
+++ new/File-Path-Tiny-0.9/Changes  2017-12-29 23:18:10.0 +0100
@@ -1,5 +1,12 @@
 Revision history for File-Path-Tiny
 
+0.9  2017-12-29 16:17:42
+- Do chdir() for security reasons by default
+- Stop emptying/removing a path if it is changed out from underneath us
+- rt 96843: Add SEE ALSO section
+- prereq and unit test fixups
+- Unit tests for symlink toggling protection
+
 0.8  2016-01-26 14:44:57
 - rt 88849: allow multiple processes to operate on the same paths (thanks 
HELENA!)
 - Add github to POD
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/File-Path-Tiny-0.8/MANIFEST 
new/File-Path-Tiny-0.9/MANIFEST
--- old/File-Path-Tiny-0.8/MANIFEST 2013-09-27 01:44:41.0 +0200
+++ new/File-Path-Tiny-0.9/MANIFEST 2017-12-29 15:44:23.0 +0100
@@ -5,6 +5,7 @@
 lib/File/Path/Tiny.pm
 lib/File/Path/Tiny.pod
 t/00.load.t
+t/01.symtogsafe.t
 t/perlcritic.t
 t/perltidy.t
 t/pkg-changes.t
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/File-Path-Tiny-0.8/META.json 

commit perl-Getopt-Long-Descriptive for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package perl-Getopt-Long-Descriptive for 
openSUSE:Factory checked in at 2018-02-09 15:47:34

Comparing /work/SRC/openSUSE:Factory/perl-Getopt-Long-Descriptive (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Getopt-Long-Descriptive.new (New)


Package is "perl-Getopt-Long-Descriptive"

Fri Feb  9 15:47:34 2018 rev:17 rq:573987 version:0.101

Changes:

--- 
/work/SRC/openSUSE:Factory/perl-Getopt-Long-Descriptive/perl-Getopt-Long-Descriptive.changes
2016-07-20 09:19:09.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-Getopt-Long-Descriptive.new/perl-Getopt-Long-Descriptive.changes
   2018-02-09 15:47:37.167233018 +0100
@@ -1,0 +2,9 @@
+Wed Feb  7 16:34:51 UTC 2018 - co...@suse.com
+
+- updated to 0.101
+   see /usr/share/doc/packages/perl-Getopt-Long-Descriptive/Changes
+
+  0.101 2018-01-21 19:32:11-05:00 America/New_York
+  - escape some unescaped braces in regex
+
+---

Old:

  Getopt-Long-Descriptive-0.100.tar.gz

New:

  Getopt-Long-Descriptive-0.101.tar.gz



Other differences:
--
++ perl-Getopt-Long-Descriptive.spec ++
--- /var/tmp/diff_new_pack.F0DHF8/_old  2018-02-09 15:47:38.127198545 +0100
+++ /var/tmp/diff_new_pack.F0DHF8/_new  2018-02-09 15:47:38.131198401 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Getopt-Long-Descriptive
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,14 +17,14 @@
 
 
 Name:   perl-Getopt-Long-Descriptive
-Version:0.100
+Version:0.101
 Release:0
 %define cpan_name Getopt-Long-Descriptive
 Summary:Getopt::Long, but simpler and more powerful
 License:Artistic-1.0 or GPL-1.0+
 Group:  Development/Libraries/Perl
 Url:http://search.cpan.org/dist/Getopt-Long-Descriptive/
-Source0:
http://www.cpan.org/authors/id/R/RJ/RJBS/%{cpan_name}-%{version}.tar.gz
+Source0:
https://cpan.metacpan.org/authors/id/R/RJ/RJBS/%{cpan_name}-%{version}.tar.gz
 Source1:cpanspec.yml
 BuildArch:  noarch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -68,6 +68,7 @@
 
 %files -f %{name}.files
 %defattr(-,root,root,755)
-%doc Changes LICENSE README
+%doc Changes README
+%license LICENSE
 
 %changelog

++ Getopt-Long-Descriptive-0.100.tar.gz -> 
Getopt-Long-Descriptive-0.101.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Getopt-Long-Descriptive-0.100/Changes 
new/Getopt-Long-Descriptive-0.101/Changes
--- old/Getopt-Long-Descriptive-0.100/Changes   2016-07-12 04:21:29.0 
+0200
+++ new/Getopt-Long-Descriptive-0.101/Changes   2018-01-22 01:32:16.0 
+0100
@@ -1,5 +1,8 @@
 Revision history for Getopt-Long-Descriptive
 
+0.101 2018-01-21 19:32:11-05:00 America/New_York
+- escape some unescaped braces in regex
+
 0.100 2016-07-11 22:21:26-04:00 America/New_York
 - show off "shortcircuit" in synopsis (thanks, Zhenyi Zhou)
 - Fix rendering of complex types ('i@' → 'INT...', etc)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Getopt-Long-Descriptive-0.100/MANIFEST 
new/Getopt-Long-Descriptive-0.101/MANIFEST
--- old/Getopt-Long-Descriptive-0.100/MANIFEST  2016-07-12 04:21:29.0 
+0200
+++ new/Getopt-Long-Descriptive-0.101/MANIFEST  2018-01-22 01:32:16.0 
+0100
@@ -1,4 +1,4 @@
-# This file was automatically generated by Dist::Zilla::Plugin::Manifest 
v6.006.
+# This file was automatically generated by Dist::Zilla::Plugin::Manifest 
v6.010.
 Changes
 LICENSE
 MANIFEST
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Getopt-Long-Descriptive-0.100/META.json 
new/Getopt-Long-Descriptive-0.101/META.json
--- old/Getopt-Long-Descriptive-0.100/META.json 2016-07-12 04:21:29.0 
+0200
+++ new/Getopt-Long-Descriptive-0.101/META.json 2018-01-22 01:32:16.0 
+0100
@@ -5,7 +5,7 @@
   "Ricardo Signes "
],
"dynamic_config" : 0,
-   "generated_by" : "Dist::Zilla version 6.006, CPAN::Meta::Converter version 
2.150005",
+   "generated_by" : "Dist::Zilla version 6.010, CPAN::Meta::Converter version 
2.150005",
"license" : [
   "perl_5"
],
@@ -22,6 +22,7 @@
   },
   "develop" : {
  "requires" : {
+"Encode" : "0",
 "Test::More" : "0",
 "Test::Pod" : "1.41"
  }
@@ -68,10 +69,10 @@
   

commit perl-PPIx-Regexp for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package perl-PPIx-Regexp for 
openSUSE:Factory checked in at 2018-02-09 15:47:16

Comparing /work/SRC/openSUSE:Factory/perl-PPIx-Regexp (Old)
 and  /work/SRC/openSUSE:Factory/.perl-PPIx-Regexp.new (New)


Package is "perl-PPIx-Regexp"

Fri Feb  9 15:47:16 2018 rev:35 rq:573960 version:0.054

Changes:

--- /work/SRC/openSUSE:Factory/perl-PPIx-Regexp/perl-PPIx-Regexp.changes
2017-11-15 16:53:35.605281152 +0100
+++ /work/SRC/openSUSE:Factory/.perl-PPIx-Regexp.new/perl-PPIx-Regexp.changes   
2018-02-09 15:47:17.443941284 +0100
@@ -1,0 +2,17 @@
+Wed Feb  7 17:05:47 UTC 2018 - co...@suse.com
+
+- updated to 0.054
+   see /usr/share/doc/packages/perl-PPIx-Regexp/Changes
+
+  0.0542018-01-29  T. R. Wyant
+  Add support for (+script_run:...). This is an experimental feature
+  added in Perl 5.27.8. It imposes on any matches it contains the
+  additional restriction that everything matched has to belong to the
+  same Unicode script. This support will be retracted if the
+  functionality does not make it into Perl 5.28.
+  
+  Add method scontent().  This returns significant content only. That
+  is, if called on the parse of '/ f u b a r /x', it returns
+  '/fubar/x'.
+
+---

Old:

  PPIx-Regexp-0.053.tar.gz

New:

  PPIx-Regexp-0.054.tar.gz



Other differences:
--
++ perl-PPIx-Regexp.spec ++
--- /var/tmp/diff_new_pack.n3roOm/_old  2018-02-09 15:47:18.779893310 +0100
+++ /var/tmp/diff_new_pack.n3roOm/_new  2018-02-09 15:47:18.779893310 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-PPIx-Regexp
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   perl-PPIx-Regexp
-Version:0.053
+Version:0.054
 Release:0
 %define cpan_name PPIx-Regexp
 Summary:Represent a regular expression of some sort

++ PPIx-Regexp-0.053.tar.gz -> PPIx-Regexp-0.054.tar.gz ++
 2497 lines of diff (skipped)




commit perl-Perl-Critic-Pulp for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package perl-Perl-Critic-Pulp for 
openSUSE:Factory checked in at 2018-02-09 15:47:19

Comparing /work/SRC/openSUSE:Factory/perl-Perl-Critic-Pulp (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Perl-Critic-Pulp.new (New)


Package is "perl-Perl-Critic-Pulp"

Fri Feb  9 15:47:19 2018 rev:5 rq:573961 version:96

Changes:

--- 
/work/SRC/openSUSE:Factory/perl-Perl-Critic-Pulp/perl-Perl-Critic-Pulp.changes  
2017-10-10 11:43:30.558095694 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-Perl-Critic-Pulp.new/perl-Perl-Critic-Pulp.changes
 2018-02-09 15:47:21.179807129 +0100
@@ -1,0 +2,10 @@
+Wed Feb  7 17:07:22 UTC 2018 - co...@suse.com
+
+- updated to 96
+   see /usr/share/doc/packages/perl-Perl-Critic-Pulp/Changes
+
+  Version 96, December 2017
+  - ProhibitUnknownBackslash allow for non-ascii in strings, as
+reported by Mark Fowler RT#123922
+
+---

Old:

  Perl-Critic-Pulp-95.tar.gz

New:

  Perl-Critic-Pulp-96.tar.gz



Other differences:
--
++ perl-Perl-Critic-Pulp.spec ++
--- /var/tmp/diff_new_pack.VbAtpi/_old  2018-02-09 15:47:22.211770072 +0100
+++ /var/tmp/diff_new_pack.VbAtpi/_new  2018-02-09 15:47:22.215769928 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Perl-Critic-Pulp
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Perl-Critic-Pulp
-Version:95
+Version:96
 Release:0
 #Upstream: GPL-1.0+
 %define cpan_name Perl-Critic-Pulp

++ Perl-Critic-Pulp-95.tar.gz -> Perl-Critic-Pulp-96.tar.gz ++
 1686 lines of diff (skipped)




commit perl-Mojolicious-Plugin-AssetPack for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package perl-Mojolicious-Plugin-AssetPack 
for openSUSE:Factory checked in at 2018-02-09 15:47:22

Comparing /work/SRC/openSUSE:Factory/perl-Mojolicious-Plugin-AssetPack (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Mojolicious-Plugin-AssetPack.new 
(New)


Package is "perl-Mojolicious-Plugin-AssetPack"

Fri Feb  9 15:47:22 2018 rev:37 rq:573983 version:2.02

Changes:

--- 
/work/SRC/openSUSE:Factory/perl-Mojolicious-Plugin-AssetPack/perl-Mojolicious-Plugin-AssetPack.changes
  2017-11-15 16:54:39.582937055 +0100
+++ 
/work/SRC/openSUSE:Factory/.perl-Mojolicious-Plugin-AssetPack.new/perl-Mojolicious-Plugin-AssetPack.changes
 2018-02-09 15:47:23.335729710 +0100
@@ -1,0 +2,6 @@
+Wed Feb  7 16:52:44 UTC 2018 - co...@suse.com
+
+- updated to 2.02
+   see /usr/share/doc/packages/perl-Mojolicious-Plugin-AssetPack/Changes
+
+---

Old:

  Mojolicious-Plugin-AssetPack-2.01.tar.gz

New:

  Mojolicious-Plugin-AssetPack-2.02.tar.gz



Other differences:
--
++ perl-Mojolicious-Plugin-AssetPack.spec ++
--- /var/tmp/diff_new_pack.YscRvQ/_old  2018-02-09 15:47:24.275695956 +0100
+++ /var/tmp/diff_new_pack.YscRvQ/_new  2018-02-09 15:47:24.279695813 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Mojolicious-Plugin-AssetPack
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,14 +17,14 @@
 
 
 Name:   perl-Mojolicious-Plugin-AssetPack
-Version:2.01
+Version:2.02
 Release:0
 %define cpan_name Mojolicious-Plugin-AssetPack
 Summary:Compress and convert css, less, sass, javascript and 
coffeescript files
 License:Artistic-2.0
 Group:  Development/Libraries/Perl
 Url:http://search.cpan.org/dist/Mojolicious-Plugin-AssetPack/
-Source0:
https://cpan.metacpan.org/authors/id/M/MR/MRAMBERG/%{cpan_name}-%{version}.tar.gz
+Source0:
https://cpan.metacpan.org/authors/id/J/JH/JHTHORSEN/%{cpan_name}-%{version}.tar.gz
 Source1:cpanspec.yml
 BuildArch:  noarch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ Mojolicious-Plugin-AssetPack-2.01.tar.gz -> 
Mojolicious-Plugin-AssetPack-2.02.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Mojolicious-Plugin-AssetPack-2.01/Changes 
new/Mojolicious-Plugin-AssetPack-2.02/Changes
--- old/Mojolicious-Plugin-AssetPack-2.01/Changes   2017-11-06 
13:02:45.0 +0100
+++ new/Mojolicious-Plugin-AssetPack-2.02/Changes   2018-01-28 
13:12:59.0 +0100
@@ -1,10 +1,13 @@
 Revision history for perl distribution Mojolicious-Plugin-AssetPack
 
-2.01 2017-11-06T13:02:45+0100
+2.02 2018-01-28T13:12:59+0100
+ - Add EXPERIMENTAL support for fetching assets from helpers
 
+2.01 2017-11-06T13:02:45+0100
  - Up version number to try to fix pause indexing issues
+ - NOTE: 2.00 was a mistake. There are no major changes
 
-1.48 2017-10-29T10:20:51+0800
+2.00 2017-10-29T10:08:37+0800
  - Fix RollupJs package name #130
  - load_module() confess on error
  - Removed EXPERIMENTAL Reloader pipe
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Mojolicious-Plugin-AssetPack-2.01/MANIFEST 
new/Mojolicious-Plugin-AssetPack-2.02/MANIFEST
--- old/Mojolicious-Plugin-AssetPack-2.01/MANIFEST  2017-11-06 
13:02:45.0 +0100
+++ new/Mojolicious-Plugin-AssetPack-2.02/MANIFEST  2018-01-28 
13:13:01.0 +0100
@@ -72,6 +72,7 @@
 t/fetch-hash.t
 t/fetch-source-map.t
 t/font-awesome.t
+t/from-helper.t
 t/google-font.t
 t/Helper.pm
 t/jpeg.t
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Mojolicious-Plugin-AssetPack-2.01/META.json 
new/Mojolicious-Plugin-AssetPack-2.02/META.json
--- old/Mojolicious-Plugin-AssetPack-2.01/META.json 2017-11-06 
13:02:45.0 +0100
+++ new/Mojolicious-Plugin-AssetPack-2.02/META.json 2018-01-28 
13:13:01.0 +0100
@@ -1,10 +1,10 @@
 {
"abstract" : "Compress and convert css, less, sass, javascript and 
coffeescript files",
"author" : [
-  "Marcus Ramberg "
+  "Jan Henning Thorsen "
],
-   "dynamic_config" : 1,
-   "generated_by" : "ExtUtils::MakeMaker version 7.24, CPAN::Meta::Converter 
version 2.150005",
+   "dynamic_config" : 0,
+   "generated_by" : "ExtUtils::MakeMaker version 7.24, CPAN::Meta::Converter 
version 2.150010",

commit perl-Proc-ProcessTable for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package perl-Proc-ProcessTable for 
openSUSE:Factory checked in at 2018-02-09 15:47:12

Comparing /work/SRC/openSUSE:Factory/perl-Proc-ProcessTable (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Proc-ProcessTable.new (New)


Package is "perl-Proc-ProcessTable"

Fri Feb  9 15:47:12 2018 rev:11 rq:573957 version:0.55

Changes:

--- 
/work/SRC/openSUSE:Factory/perl-Proc-ProcessTable/perl-Proc-ProcessTable.changes
2015-08-29 20:04:41.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-Proc-ProcessTable.new/perl-Proc-ProcessTable.changes
   2018-02-09 15:47:13.916067969 +0100
@@ -1,0 +2,6 @@
+Wed Feb  7 17:10:15 UTC 2018 - co...@suse.com
+
+- updated to 0.55
+   see /usr/share/doc/packages/perl-Proc-ProcessTable/Changes
+
+---

Old:

  Proc-ProcessTable-0.53.tar.gz

New:

  Proc-ProcessTable-0.55.tar.gz



Other differences:
--
++ perl-Proc-ProcessTable.spec ++
--- /var/tmp/diff_new_pack.QqrD3o/_old  2018-02-09 15:47:14.640041972 +0100
+++ /var/tmp/diff_new_pack.QqrD3o/_new  2018-02-09 15:47:14.640041972 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Proc-ProcessTable
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Proc-ProcessTable
-Version:0.53
+Version:0.55
 Release:0
 #Upstream: Artistic-1.0 or GPL-1.0+
 %define cpan_name Proc-ProcessTable
@@ -25,7 +25,7 @@
 License:(Artistic-1.0 or GPL-1.0+) and GPL-2.0
 Group:  Development/Libraries/Perl
 Url:http://search.cpan.org/dist/Proc-ProcessTable/
-Source0:
http://www.cpan.org/authors/id/J/JW/JWB/%{cpan_name}-%{version}.tar.gz
+Source0:
https://cpan.metacpan.org/authors/id/J/JW/JWB/%{cpan_name}-%{version}.tar.gz
 Source1:cpanspec.yml
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  perl
@@ -37,7 +37,7 @@
 
 %prep
 %setup -q -n %{cpan_name}-%{version}
-find . -type f -print0 | xargs -0 chmod 644
+find . -type f ! -name \*.pl -print0 | xargs -0 chmod 644
 
 %build
 %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
@@ -53,6 +53,6 @@
 
 %files -f %{name}.files
 %defattr(-,root,root,755)
-%doc Changes PORTING README README.aix README.bsdi README.cygwin README.darwin 
README.dec_osf README.freebsd-kvm README.freebsd-procfs README.hpux 
README.linux README.netbsd README.openbsd README.solaris README.sunos 
README.unixware TODO
+%doc Changes PORTING README README.aix README.bsdi README.cygwin README.darwin 
README.dec_osf README.freebsd-kvm README.freebsd-procfs README.hpux 
README.linux README.netbsd README.openbsd README.solaris README.sunos 
README.unixware
 
 %changelog

++ Proc-ProcessTable-0.53.tar.gz -> Proc-ProcessTable-0.55.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Proc-ProcessTable-0.53/Killall.pm 
new/Proc-ProcessTable-0.55/Killall.pm
--- old/Proc-ProcessTable-0.53/Killall.pm   2015-08-23 11:57:06.0 
+0200
+++ new/Proc-ProcessTable-0.55/Killall.pm   2017-02-21 01:03:40.0 
+0100
@@ -49,7 +49,7 @@
$self = 0 unless defined $self;
my $nkilled = 0;
croak("killall: Unsupported signal: $signal") unless is_sig($signal);
-   my $t = new Proc::ProcessTable;
+   my $t = Proc::ProcessTable->new;
my $BANG = undef;
foreach my $p (@{$t->table}) {
  my $cmndline = $p->{cmndline} || $p->{fname};
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Proc-ProcessTable-0.53/MANIFEST 
new/Proc-ProcessTable-0.55/MANIFEST
--- old/Proc-ProcessTable-0.53/MANIFEST 2015-08-24 21:35:47.0 +0200
+++ new/Proc-ProcessTable-0.55/MANIFEST 2018-02-01 23:02:42.0 +0100
@@ -24,6 +24,7 @@
 Process/Process.pm
 hints/linux.pl
 hints/solaris.pl
+hints/dragonfly.pl
 hints/aix.pl
 hints/aix_4_2.pl
 hints/aix_4_3.pl
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Proc-ProcessTable-0.53/META.json 
new/Proc-ProcessTable-0.55/META.json
--- old/Proc-ProcessTable-0.53/META.json2015-08-24 21:35:47.0 
+0200
+++ new/Proc-ProcessTable-0.55/META.json2018-02-01 23:02:41.0 
+0100
@@ -4,7 +4,7 @@
   "Jonathan Swartz "
],
"dynamic_config" : 1,
-   "generated_by" : "ExtUtils::MakeMaker version 6.98, CPAN::Meta::Converter 
version 2.150001",
+   

commit bindfs for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package bindfs for openSUSE:Factory checked 
in at 2018-02-09 15:46:50

Comparing /work/SRC/openSUSE:Factory/bindfs (Old)
 and  /work/SRC/openSUSE:Factory/.bindfs.new (New)


Package is "bindfs"

Fri Feb  9 15:46:50 2018 rev:17 rq:573921 version:1.13.9

Changes:

--- /work/SRC/openSUSE:Factory/bindfs/bindfs.changes2017-11-09 
14:07:48.145242950 +0100
+++ /work/SRC/openSUSE:Factory/.bindfs.new/bindfs.changes   2018-02-09 
15:46:52.708829510 +0100
@@ -1,0 +2,6 @@
+Wed Feb  7 23:07:49 UTC 2018 - jeng...@inai.de
+
+- Update to new upstream release 1.13.9
+  * Added options --delete-deny and --rename-deny
+
+---

Old:

  bindfs-1.13.8.tar.gz

New:

  bindfs-1.13.9.tar.gz



Other differences:
--
++ bindfs.spec ++
--- /var/tmp/diff_new_pack.U2ad9x/_old  2018-02-09 15:46:53.424803800 +0100
+++ /var/tmp/diff_new_pack.U2ad9x/_new  2018-02-09 15:46:53.428803656 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package bindfs
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   bindfs
-Version:1.13.8
+Version:1.13.9
 Release:0
 Summary:Mount Directories to other Locations and alter Permission Bits
 License:GPL-2.0+

++ bindfs-1.13.8.tar.gz -> bindfs-1.13.9.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/bindfs-1.13.8/ChangeLog new/bindfs-1.13.9/ChangeLog
--- old/bindfs-1.13.8/ChangeLog 2017-10-26 17:00:28.0 +0200
+++ new/bindfs-1.13.9/ChangeLog 2017-11-30 11:30:07.0 +0100
@@ -1,3 +1,8 @@
+2017-11-30  Martin Pärtel 
+
+   * Added options --delete-deny and --rename-deny as suggested by @roojs.
+   * Released 1.13.9
+
 2017-10-26  Martin Pärtel 
 
* Released 1.13.8
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/bindfs-1.13.8/README.md new/bindfs-1.13.9/README.md
--- old/bindfs-1.13.8/README.md 2017-10-26 17:00:28.0 +0200
+++ new/bindfs-1.13.9/README.md 2017-11-30 11:30:07.0 +0100
@@ -1,7 +1,7 @@
 
 ## Overview ##
 
-bindfs  -  http://bindfs.org/
+bindfs  -  https://bindfs.org/
 
 bindfs is a FUSE filesystem for mirroring a directory to another
 directory, similarly to `mount --bind`. The permissions of the mirrored
@@ -20,7 +20,10 @@
 
 ## Installation ##
 
-Make sure FUSE 2.6.0 or above is installed (http://fuse.sf.net/).
+Make sure FUSE 2.6.0 or above is installed 
(https://github.com/libfuse/libfuse).
+
+Download a [release](https://bindfs.org/downloads/) or clone this repository.
+
 Then compile and install as usual:
 
 ./configure
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/bindfs-1.13.8/configure new/bindfs-1.13.9/configure
--- old/bindfs-1.13.8/configure 2017-10-26 17:00:32.0 +0200
+++ new/bindfs-1.13.9/configure 2017-11-30 11:30:11.0 +0100
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for bindfs 1.13.8.
+# Generated by GNU Autoconf 2.69 for bindfs 1.13.9.
 #
 # Report bugs to .
 #
@@ -590,8 +590,8 @@
 # Identity of this package.
 PACKAGE_NAME='bindfs'
 PACKAGE_TARNAME='bindfs'
-PACKAGE_VERSION='1.13.8'
-PACKAGE_STRING='bindfs 1.13.8'
+PACKAGE_VERSION='1.13.9'
+PACKAGE_STRING='bindfs 1.13.9'
 PACKAGE_BUGREPORT='martin.par...@gmail.com'
 PACKAGE_URL=''
 
@@ -1340,7 +1340,7 @@
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat <<_ACEOF
-\`configure' configures bindfs 1.13.8 to adapt to many kinds of systems.
+\`configure' configures bindfs 1.13.9 to adapt to many kinds of systems.
 
 Usage: $0 [OPTION]... [VAR=VALUE]...
 
@@ -1411,7 +1411,7 @@
 
 if test -n "$ac_init_help"; then
   case $ac_init_help in
- short | recursive ) echo "Configuration of bindfs 1.13.8:";;
+ short | recursive ) echo "Configuration of bindfs 1.13.9:";;
esac
   cat <<\_ACEOF
 
@@ -1531,7 +1531,7 @@
 test -n "$ac_init_help" && exit $ac_status
 if $ac_init_version; then
   cat <<\_ACEOF
-bindfs configure 1.13.8
+bindfs configure 1.13.9
 generated by GNU Autoconf 2.69
 
 Copyright (C) 2012 Free Software Foundation, Inc.
@@ -1809,7 +1809,7 @@
 This file contains any messages produced by compilers while
 running configure, to aid debugging if 

commit perl-Task-Weaken for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package perl-Task-Weaken for 
openSUSE:Factory checked in at 2018-02-09 15:47:06

Comparing /work/SRC/openSUSE:Factory/perl-Task-Weaken (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Task-Weaken.new (New)


Package is "perl-Task-Weaken"

Fri Feb  9 15:47:06 2018 rev:20 rq:573950 version:1.05

Changes:

--- /work/SRC/openSUSE:Factory/perl-Task-Weaken/perl-Task-Weaken.changes
2017-10-03 23:19:48.793070524 +0200
+++ /work/SRC/openSUSE:Factory/.perl-Task-Weaken.new/perl-Task-Weaken.changes   
2018-02-09 15:47:07.784288159 +0100
@@ -1,0 +2,6 @@
+Wed Feb  7 17:21:27 UTC 2018 - co...@suse.com
+
+- updated to 1.05
+   see /usr/share/doc/packages/perl-Task-Weaken/Changes
+
+---

Old:

  Task-Weaken-1.04.tar.gz

New:

  Task-Weaken-1.05.tar.gz



Other differences:
--
++ perl-Task-Weaken.spec ++
--- /var/tmp/diff_new_pack.aUC97T/_old  2018-02-09 15:47:08.524261587 +0100
+++ /var/tmp/diff_new_pack.aUC97T/_new  2018-02-09 15:47:08.524261587 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Task-Weaken
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,14 +17,14 @@
 
 
 Name:   perl-Task-Weaken
-Version:1.04
+Version:1.05
 Release:0
 %define cpan_name Task-Weaken
 Summary:Ensure that a platform has weaken support
 License:Artistic-1.0 or GPL-1.0+
 Group:  Development/Libraries/Perl
 Url:http://search.cpan.org/dist/Task-Weaken/
-Source0:
https://cpan.metacpan.org/authors/id/A/AD/ADAMK/%{cpan_name}-%{version}.tar.gz
+Source0:
https://cpan.metacpan.org/authors/id/E/ET/ETHER/%{cpan_name}-%{version}.tar.gz
 Source1:cpanspec.yml
 BuildArch:  noarch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -36,7 +36,7 @@
 One recurring problem in modules that use Scalar::Util's 'weaken' function
 is that it is not present in the pure-perl variant.
 
-While this isn't necesarily always a problem in a straight CPAN-based Perl
+While this isn't necessarily always a problem in a straight CPAN-based Perl
 environment, some operating system distributions only include the pure-Perl
 versions, don't include the XS version, and so weaken is then "missing"
 from the platform, *despite* passing a dependency on Scalar::Util
@@ -76,7 +76,7 @@
 
 %files -f %{name}.files
 %defattr(-,root,root,755)
-%doc Changes README
+%doc Changes CONTRIBUTING Makefile.footer Makefile.header README
 %license LICENSE
 
 %changelog

++ Task-Weaken-1.04.tar.gz -> Task-Weaken-1.05.tar.gz ++
 5983 lines of diff (skipped)




commit zimg for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package zimg for openSUSE:Factory checked in 
at 2018-02-09 15:46:57

Comparing /work/SRC/openSUSE:Factory/zimg (Old)
 and  /work/SRC/openSUSE:Factory/.zimg.new (New)


Package is "zimg"

Fri Feb  9 15:46:57 2018 rev:26 rq:573932 version:2.7.4

Changes:

--- /work/SRC/openSUSE:Factory/zimg/zimg.changes2018-02-01 
21:29:28.912811948 +0100
+++ /work/SRC/openSUSE:Factory/.zimg.new/zimg.changes   2018-02-09 
15:46:59.572583038 +0100
@@ -1,0 +2,7 @@
+Thu Feb  8 03:29:33 UTC 2018 - 9+suse@cirno.systems
+
+- Update to 2.7.4
+  * x86: fix crash on Yorkfield (Core 2 Quad) processors
+(introduced in 2.7)
+
+---

Old:

  release-2.7.3.tar.gz

New:

  release-2.7.4.tar.gz



Other differences:
--
++ zimg.spec ++
--- /var/tmp/diff_new_pack.Ov4AVl/_old  2018-02-09 15:47:00.384553880 +0100
+++ /var/tmp/diff_new_pack.Ov4AVl/_new  2018-02-09 15:47:00.384553880 +0100
@@ -18,7 +18,7 @@
 
 %define sover 2
 Name:   zimg
-Version:2.7.3
+Version:2.7.4
 Release:0
 Summary:Scaling, colorspace conversion, and dithering library
 License:WTFPL

++ release-2.7.3.tar.gz -> release-2.7.4.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/zimg-release-2.7.3/ChangeLog 
new/zimg-release-2.7.4/ChangeLog
--- old/zimg-release-2.7.3/ChangeLog2018-01-31 17:41:43.0 +0100
+++ new/zimg-release-2.7.4/ChangeLog2018-02-07 23:06:44.0 +0100
@@ -1,3 +1,6 @@
+2.7.4:
+x86: fix crash on Yorkfield (Core 2 Quad) processors (introduced in 2.7)
+
 2.7.3
 resize: fix performance drop in certain resampling ratios
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/zimg-release-2.7.3/configure.ac 
new/zimg-release-2.7.4/configure.ac
--- old/zimg-release-2.7.3/configure.ac 2018-01-31 17:41:43.0 +0100
+++ new/zimg-release-2.7.4/configure.ac 2018-02-07 23:06:44.0 +0100
@@ -1,4 +1,4 @@
-AC_INIT([zimg], [2.7.3], [https://github.com/sekrit-twc/zimg/pulls], [zimg], 
[https://github.com/sekrit-twc/zimg])
+AC_INIT([zimg], [2.7.4], [https://github.com/sekrit-twc/zimg/pulls], [zimg], 
[https://github.com/sekrit-twc/zimg])
 AC_CONFIG_MACRO_DIR([m4])
 
 : ${CFLAGS=""}
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/zimg-release-2.7.3/src/zimg/api/zimg.cpp 
new/zimg-release-2.7.4/src/zimg/api/zimg.cpp
--- old/zimg-release-2.7.3/src/zimg/api/zimg.cpp2018-01-31 
17:41:43.0 +0100
+++ new/zimg-release-2.7.4/src/zimg/api/zimg.cpp2018-02-07 
23:06:44.0 +0100
@@ -36,7 +36,7 @@
 thread_local zimg_error_code_e g_last_error = ZIMG_ERROR_SUCCESS;
 thread_local std::string g_last_error_msg;
 
-constexpr unsigned VERSION_INFO[] = { 2, 7, 3 };
+constexpr unsigned VERSION_INFO[] = { 2, 7, 4 };
 
 
 template 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/zimg-release-2.7.3/src/zimg/common/x86/cpuinfo_x86.cpp 
new/zimg-release-2.7.4/src/zimg/common/x86/cpuinfo_x86.cpp
--- old/zimg-release-2.7.3/src/zimg/common/x86/cpuinfo_x86.cpp  2018-01-31 
17:41:43.0 +0100
+++ new/zimg-release-2.7.4/src/zimg/common/x86/cpuinfo_x86.cpp  2018-02-07 
23:06:44.0 +0100
@@ -174,9 +174,9 @@
 
// Detect logical processor count on x2APIC systems.
if (max_feature >= 0x0B) {
-   unsigned l1d_threads = 0;
-   unsigned l2_threads = 0;
-   unsigned l3_threads = 0;
+   unsigned l1d_threads = cache.l1d_threads;
+   unsigned l2_threads = cache.l2_threads;
+   unsigned l3_threads = cache.l3_threads;
 
for (int i = 0; i < 8; ++i) {
unsigned logical_processors;
@@ -200,7 +200,7 @@
cache.l3_threads = l3_threads;
}
 
-   cache.valid = true;
+   cache.valid = cache.l1d && cache.l1d_threads && !(cache.l2 && 
!cache.l2_threads) && !(cache.l3 && !cache.l3_threads);
return cache;
 }
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/zimg-release-2.7.3/test/resize/resize_impl_test.cpp 
new/zimg-release-2.7.4/test/resize/resize_impl_test.cpp
--- old/zimg-release-2.7.3/test/resize/resize_impl_test.cpp 2018-01-31 
17:41:43.0 +0100
+++ new/zimg-release-2.7.4/test/resize/resize_impl_test.cpp 2018-02-07 
23:06:44.0 +0100
@@ -102,7 +102,7 @@
const char *expected_sha1_f32[][3] = {
{ "0f09d60179f3b4771dd800c9650dd3acee2b6360" },
{ 

commit perl-Test-CheckManifest for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package perl-Test-CheckManifest for 
openSUSE:Factory checked in at 2018-02-09 15:47:00

Comparing /work/SRC/openSUSE:Factory/perl-Test-CheckManifest (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Test-CheckManifest.new (New)


Package is "perl-Test-CheckManifest"

Fri Feb  9 15:47:00 2018 rev:2 rq:573949 version:1.33

Changes:

--- 
/work/SRC/openSUSE:Factory/perl-Test-CheckManifest/perl-Test-CheckManifest.changes
  2017-06-26 15:52:11.124320030 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-Test-CheckManifest.new/perl-Test-CheckManifest.changes
 2018-02-09 15:47:00.748540810 +0100
@@ -1,0 +2,16 @@
+Wed Feb  7 17:23:23 UTC 2018 - co...@suse.com
+
+- updated to 1.33
+   see /usr/share/doc/packages/perl-Test-CheckManifest/Changes
+
+  1.33  2018-01-26
+  
+[INTERNAL]
+* Auto generate META.json using dzil plugin [MetaJSON] (github #8, 
thanks to manwar)
+  
+  1.32  2018-01-26
+  
+[BUGFIX]
+* ok_manifest reports duplicate files on internal symlinks (github #7)
+
+---

Old:

  Test-CheckManifest-1.31.tar.gz

New:

  Test-CheckManifest-1.33.tar.gz



Other differences:
--
++ perl-Test-CheckManifest.spec ++
--- /var/tmp/diff_new_pack.yrI1At/_old  2018-02-09 15:47:01.400517397 +0100
+++ /var/tmp/diff_new_pack.yrI1At/_new  2018-02-09 15:47:01.400517397 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Test-CheckManifest
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Test-CheckManifest
-Version:1.31
+Version:1.33
 Release:0
 %define cpan_name Test-CheckManifest
 Summary:Check if your Manifest matches your distro

++ Test-CheckManifest-1.31.tar.gz -> Test-CheckManifest-1.33.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Test-CheckManifest-1.31/Changes 
new/Test-CheckManifest-1.33/Changes
--- old/Test-CheckManifest-1.31/Changes 2017-04-21 16:08:36.0 +0200
+++ new/Test-CheckManifest-1.33/Changes 2018-01-26 13:42:10.0 +0100
@@ -1,6 +1,16 @@
 Revision history for Perl extension Test::CheckManifest.
 
 
+1.33  2018-01-26
+
+  [INTERNAL]
+  * Auto generate META.json using dzil plugin [MetaJSON] (github #8, 
thanks to manwar)
+
+1.32  2018-01-26
+
+  [BUGFIX]
+  * ok_manifest reports duplicate files on internal symlinks (github #7)
+
 1.31  2017-04-21
 
   [IMPROVEMENT]
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Test-CheckManifest-1.31/LICENSE 
new/Test-CheckManifest-1.33/LICENSE
--- old/Test-CheckManifest-1.31/LICENSE 2017-04-21 16:08:36.0 +0200
+++ new/Test-CheckManifest-1.33/LICENSE 2018-01-26 13:42:10.0 +0100
@@ -1,4 +1,4 @@
-This software is Copyright (c) 2015 by Renee Baecker.
+This software is Copyright (c) 2018 by Renee Baecker.
 
 This is free software, licensed under:
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Test-CheckManifest-1.31/MANIFEST 
new/Test-CheckManifest-1.33/MANIFEST
--- old/Test-CheckManifest-1.31/MANIFEST2017-04-21 16:08:36.0 
+0200
+++ new/Test-CheckManifest-1.33/MANIFEST2018-01-26 13:42:10.0 
+0100
@@ -1,7 +1,8 @@
-# This file was automatically generated by Dist::Zilla::Plugin::Manifest 
v5.043.
+# This file was automatically generated by Dist::Zilla::Plugin::Manifest 
v6.010.
 Changes
 LICENSE
 MANIFEST
+META.json
 META.yml
 Makefile.PL
 README
@@ -12,3 +13,4 @@
 't/file with whitespaces.txt'
 t/testrules.yml
 t/xt/02_issue1.t
+t/xt/03_issue7.t
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Test-CheckManifest-1.31/META.json 
new/Test-CheckManifest-1.33/META.json
--- old/Test-CheckManifest-1.31/META.json   1970-01-01 01:00:00.0 
+0100
+++ new/Test-CheckManifest-1.33/META.json   2018-01-26 13:42:10.0 
+0100
@@ -0,0 +1,53 @@
+{
+   "abstract" : "Check if your Manifest matches your distro",
+   "author" : [
+  "Renee Baecker "
+   ],
+   "dynamic_config" : 0,
+   "generated_by" : "Dist::Zilla version 6.010, CPAN::Meta::Converter version 
2.150005",
+   "license" : [
+  "artistic_2"
+   ],
+   "meta-spec" : {
+  "url" : "http://search.cpan.org/perldoc?CPAN::Meta::Spec;,
+  "version" : "2"
+ 

commit gap-atlasrep for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package gap-atlasrep for openSUSE:Factory 
checked in at 2018-02-09 15:46:53

Comparing /work/SRC/openSUSE:Factory/gap-atlasrep (Old)
 and  /work/SRC/openSUSE:Factory/.gap-atlasrep.new (New)


Package is "gap-atlasrep"

Fri Feb  9 15:46:53 2018 rev:2 rq:573922 version:1.5.1

Changes:

--- /work/SRC/openSUSE:Factory/gap-atlasrep/gap-atlasrep.changes
2017-10-08 20:05:57.100464000 +0200
+++ /work/SRC/openSUSE:Factory/.gap-atlasrep.new/gap-atlasrep.changes   
2018-02-09 15:46:54.824753529 +0100
@@ -1,0 +2,5 @@
+Sat Sep 17 19:32:56 UTC 2017 - jeng...@inai.de
+
+- Switch from ftp to https.
+
+---



Other differences:
--
++ gap-atlasrep.spec ++
--- /var/tmp/diff_new_pack.fIGiRj/_old  2018-02-09 15:46:55.900714892 +0100
+++ /var/tmp/diff_new_pack.fIGiRj/_new  2018-02-09 15:46:55.904714748 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gap-atlasrep
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,14 +17,14 @@
 
 
 Name:   gap-atlasrep
-Summary:GAP: Interface to the Atlas of Group Representations
 Version:1.5.1
 Release:0
+Summary:GAP: Interface to the Atlas of Group Representations
 License:GPL-3.0+
 Group:  Productivity/Scientific/Math
-URL:http://nickerson.org.uk/groups
+Url:http://nickerson.org.uk/groups
 
-Source: 
ftp://ftp.gap-system.org/pub/gap/gap4/tar.bz2/packages/atlasrep1r5p1.tar.bz2
+Source: 
https://www.gap-system.org/pub/gap/gap4/tar.bz2/packages/atlasrep1r5p1.tar.bz2
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch
 BuildRequires:  fdupes




commit virt-manager for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package virt-manager for openSUSE:Factory 
checked in at 2018-02-09 15:46:19

Comparing /work/SRC/openSUSE:Factory/virt-manager (Old)
 and  /work/SRC/openSUSE:Factory/.virt-manager.new (New)


Package is "virt-manager"

Fri Feb  9 15:46:19 2018 rev:171 rq:573846 version:1.5.0

Changes:

--- /work/SRC/openSUSE:Factory/virt-manager/virt-manager.changes
2018-01-25 12:41:22.460328085 +0100
+++ /work/SRC/openSUSE:Factory/.virt-manager.new/virt-manager.changes   
2018-02-09 15:46:19.854009285 +0100
@@ -1,0 +2,82 @@
+Wed Feb  7 08:58:09 MST 2018 - carn...@suse.com
+
+- Update to virt-manager 1.5.0 (bsc#1027942)
+  virt-manager-1.5.0.tar.bz2
+  * python3 prep work (Radostin Stoyanov, Cole Robinson, Cédric Bosdonnat)
+  * Switch –location ISO to use isoinfo (Andrew Wong)
+  * virt-install: add –cpu numa distance handling (Menno Lageman)
+  * virt-install: fix –disk for rbd volumes with auth (Rauno Väli)
+  * virt-install: add –cputune vcpupin handling (Wim ten Have)
+  * details ui: Showing attached scsi devices per controller (Lin Ma)
+  * network ui: Show details about SR-IOV VF pool (Lin Ma)
+  * Greatly expand UI test suite coverage
+- Dropped patches
+  0001-Improve-container-image-url-example.patch
+  0001-py3-store-exception-variables-for-use-outside-except.patch
+  0002-create-wizard-fix-alignment-in-os-container-page.patch
+  0003-oscontainer-ask-root-password-in-the-wizard.patch
+  0004-Harmonize-invisible_char-values.patch
+  083dfcc8-Show-details-about-the-network-of-SR-IOV-VF-pool.patch
+  08a58d61-pycodestyle-remove-description-of-fixed-errors.patch
+  0c6bcb09-fix-bytes-string-mess-in-serial-console.patch
+  0e812e3c-dont-skip-authentication-for-listen-type-none-with-fixed-QEMU.patch
+  23aaf852-network-Set-bridge-name-to-None-instead-of-blank.patch
+  2d276ebe-progress-dont-overwrite-format.patch
+  2eb455c9-correctly-calculate-virtio-scsi-controller-index.patch
+  374a3779-urlfetcher-write-test-file-as-binary-content.patch
+  37ea5207-replace-StandardError-with-Exception.patch
+  3b769643-dont-add-URI-into-params-for-tunneled-migration.patch
+  3be78d1f-addhardware-dont-allow-panic-option-where-not-supported.patch
+  44de92b7-use-reload-from-imp-module.patch
+  63fce081-pycodestyle-Use-isinstance-for-type-checking.patch
+  67122615-python2to3-division-compatability.patch
+  69c84bea-import-reduce-from-functools-module.patch
+  6dfc4de1-add-support-for-parsing-formatting-SR-IOV-VFs.patch
+  
6e6f59e7-diskbackend-get-a-proper-size-of-existing-block-device-while-cloning.patch
+  73de8285-systray-remove-redundant-variable-assignment.patch
+  75210ed3-replace-StringIO-with-io.patch
+  7f1b4cee-pycodestyle-fix-all-E125-warnings.patch
+  7fc7e94f-fix-virtio-scsi-controller-target-calculation.patch
+  91c0669c-cli-Fix-OrderedDict-mutated-during-iteration-on-python3.patch
+  9617d126-systray-Use-APPLICATION_STATUS-for-appindicator.patch
+  999dbb36-cli-Make-VirtCLIArgument-instantiation-less-crazy.patch
+  9a9f9ecd-ignore-comments-in-keymap-conf-files.patch
+  a2bcd6c4-dont-compare-between-None-and-int.patch
+  b5b2433a-baseclass-Fix-UI-file-loading-on-py3.patch
+  b8fa0c6b-xmlnsqemu-order-XML-output-like-libvirt-does.patch
+  b9bc3b60-undefine-only-persistent-domain.patch
+  bc3c9a9d-progress-remove-unused-import.patch
+  bc8c5b07-append--attach-to-virt-viewer-if-graphics-has-listen-type-none.patch
+  c174b550-connection-Another-py3-exception-variable-fix.patch
+  d1e1cf64-progress-remove-trailing-white-space.patch
+  d2648d81-virtconv-dont-implicitly-depend-on-dict-hash-order.patch
+  d82022bd-manager-drop-python2-only-cmp-usage.patch
+  dff00d4f-remove-deprecated-statvfs-module.patch
+  e2ad4b2f-convert-iteritems-to-items.patch
+  e73abe5a-diskbackend-convert-to-long-the-calculated-size.patch
+  f41aafc7-Use-enumerate-instead-of-range-and-len.patch
+  f7c8cf9f-devicepanic-dont-return-empty-model-list.patch
+  f836e47b-virtinst-Fix-URLFetcher-for-reading-files.patch
+
+---
+Tue Feb  6 11:57:54 MST 2018 - carn...@suse.com
+
+- Upstream bug fixes (bsc#1027942)
+  b5b2433a-baseclass-Fix-UI-file-loading-on-py3.patch
+  0c6bcb09-fix-bytes-string-mess-in-serial-console.patch
+  bc8c5b07-append--attach-to-virt-viewer-if-graphics-has-listen-type-none.patch
+  0e812e3c-dont-skip-authentication-for-listen-type-none-with-fixed-QEMU.patch
+  67122615-python2to3-division-compatability.patch
+- Dropped in favor of upstream version
+  0001-virtinst-python3-terminal-width-should-be-int.patch
+  python3-fix-bytes-string-mess-in-serial-console.patch
+
+---
+Mon Feb  5 16:26:48 MST 2018 - carn...@suse.com
+
+- Default to sles15 and opensuse15 as the 'preferred_distros' for
+  this 

commit vm-install for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package vm-install for openSUSE:Factory 
checked in at 2018-02-09 15:46:37

Comparing /work/SRC/openSUSE:Factory/vm-install (Old)
 and  /work/SRC/openSUSE:Factory/.vm-install.new (New)


Package is "vm-install"

Fri Feb  9 15:46:37 2018 rev:163 rq:573911 version:0.10.02

Changes:

--- /work/SRC/openSUSE:Factory/vm-install/vm-install.changes2018-01-28 
20:33:36.182386086 +0100
+++ /work/SRC/openSUSE:Factory/.vm-install.new/vm-install.changes   
2018-02-09 15:46:39.533302630 +0100
@@ -1,0 +2,9 @@
+Mon Jan 29 15:02:25 MST 2018 - carn...@suse.com
+
+- A few miscellaneous python3 and Gtk3 fixes to GUI components.
+  bsc#1047602
+- Mount does not work for reiserfs on SLE15. Default to kernel-xen
+  and initrd-xen if the guest is sles10.
+- Version 0.10.02
+
+---

Old:

  vm-install-0.10.01.tar.bz2

New:

  vm-install-0.10.02.tar.bz2



Other differences:
--
++ vm-install.spec ++
--- /var/tmp/diff_new_pack.gPNO97/_old  2018-02-09 15:46:40.145280655 +0100
+++ /var/tmp/diff_new_pack.gPNO97/_new  2018-02-09 15:46:40.145280655 +0100
@@ -27,12 +27,12 @@
 %endif
 # For directory ownership:
 BuildRequires:  yast2
-Version:0.10.01
+Version:0.10.02
 Release:0
 Summary:Tool to Define a Virtual Machine and Install Its Operating 
System
 License:GPL-2.0
 Group:  System/Emulators/PC
-Source0:%{name}-0.10.01.tar.bz2
+Source0:%{name}-0.10.02.tar.bz2
 Source1:vm-install.conf
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Requires:   kdump

++ vm-install-0.10.01.tar.bz2 -> vm-install-0.10.02.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/vm-install-0.10.01/Makefile 
new/vm-install-0.10.02/Makefile
--- old/vm-install-0.10.01/Makefile 2018-01-26 23:43:47.208724753 +0100
+++ new/vm-install-0.10.02/Makefile 2018-01-30 17:22:39.150401330 +0100
@@ -1,5 +1,5 @@
 PACKAGE = vm-install
-VER = 0.10.01
+VER = 0.10.02
 
 default:
@echo "Run 'make install DESTDIR=$destdir' to install."
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/vm-install-0.10.01/glade/vmm-create.xml 
new/vm-install-0.10.02/glade/vmm-create.xml
--- old/vm-install-0.10.01/glade/vmm-create.xml 2018-01-23 15:48:33.271312545 
+0100
+++ new/vm-install-0.10.02/glade/vmm-create.xml 2018-02-02 00:13:13.701734770 
+0100
@@ -1402,18 +1402,18 @@
   
 
 
-  
+  
 True
 False
 
-  
+  
 True
 False
 0.1000149011612
 0.1000149011612
 5
 
-  
+  
 True
 False
 0.5
@@ -1431,7 +1431,7 @@
   
 
 
-  
+  
 True
 False
 3
@@ -1445,7 +1445,7 @@
 True
 True
 0
-0.5
+0.1
   
 
   
@@ -1460,8 +1460,6 @@
 2
 8
 9
-GTK_FILL
-GTK_FILL
   
 
 
@@ -2213,12 +2211,6 @@
   
 True
 False
-
-  
-  
-0
-  
-
   
   
 1
@@ -2316,12 +2308,6 @@
   
  

commit openSUSE-release-tools for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package openSUSE-release-tools for 
openSUSE:Factory checked in at 2018-02-09 15:46:40

Comparing /work/SRC/openSUSE:Factory/openSUSE-release-tools (Old)
 and  /work/SRC/openSUSE:Factory/.openSUSE-release-tools.new (New)


Package is "openSUSE-release-tools"

Fri Feb  9 15:46:40 2018 rev:52 rq:573915 version:20180207.878b87b

Changes:

--- 
/work/SRC/openSUSE:Factory/openSUSE-release-tools/openSUSE-release-tools.changes
2018-02-07 18:42:05.994254052 +0100
+++ 
/work/SRC/openSUSE:Factory/.openSUSE-release-tools.new/openSUSE-release-tools.changes
   2018-02-09 15:46:47.217026716 +0100
@@ -1,0 +2,25 @@
+Wed Feb 07 22:26:00 UTC 2018 - opensuse-releaset...@opensuse.org
+
+- Update to version 20180207.878b87b:
+  * osc-staging: select: reword documentation to include XML reference.
+  * osc-staging: select: mention additional supplemented request values.
+  * osc-staging: select: mention quick strategy in documentation.
+  * osc-staging: select: add filter-by example using hashtag in description.
+
+---
+Wed Feb 07 03:15:11 UTC 2018 - opensuse-releaset...@opensuse.org
+
+- Update to version 20180206.56df1cf:
+  * osclib/conf: include Leap for Factory during pkglistgen.
+  * pkglistgen: include some hints about the difference between solv files.
+  * pkglistgen: integrate drop list creation into update_and_solve.
+  * pkglistgen: do_dump_solv(): handle old-style product repo format.
+  * pkglistgen: do_create_droplist(): print to file when output_dir available.
+  * pkglistgen: provide update_merge() to combine free and nonfree solv.
+  * osclib/util: provide project_list_family* and project_version().
+  * osclib/stagingapi: get_staging_projects(): utilize project_list_prefix().
+  * osclib/core: provide project_list_prefix().
+  * osclib/conf: add download-baseurl for Leap and Factory.
+  * osclib/conf: support version in project pattern as value replacement.
+
+---

Old:

  openSUSE-release-tools-20180206.faa028a.obscpio

New:

  openSUSE-release-tools-20180207.878b87b.obscpio



Other differences:
--
++ openSUSE-release-tools.spec ++
--- /var/tmp/diff_new_pack.6jVX9f/_old  2018-02-09 15:46:48.600977019 +0100
+++ /var/tmp/diff_new_pack.6jVX9f/_new  2018-02-09 15:46:48.600977019 +0100
@@ -20,7 +20,7 @@
 %define source_dir osc-plugin-factory
 %define announcer_filename factory-package-news
 Name:   openSUSE-release-tools
-Version:20180206.faa028a
+Version:20180207.878b87b
 Release:0
 Summary:Tools to aid in staging and release work for openSUSE/SUSE
 License:GPL-2.0+ AND MIT

++ _servicedata ++
--- /var/tmp/diff_new_pack.6jVX9f/_old  2018-02-09 15:46:48.648975296 +0100
+++ /var/tmp/diff_new_pack.6jVX9f/_new  2018-02-09 15:46:48.652975152 +0100
@@ -1,6 +1,6 @@
 
   
 https://github.com/openSUSE/osc-plugin-factory.git
-faa028a805bdebf740dda3e38ac261e9e4f4f489
+b2c2fee6f5b0a0e812eccff9dd1e446a489025e9
   
 

++ openSUSE-release-tools-20180206.faa028a.obscpio -> 
openSUSE-release-tools-20180207.878b87b.obscpio ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/openSUSE-release-tools-20180206.faa028a/osc-staging.py 
new/openSUSE-release-tools-20180207.878b87b/osc-staging.py
--- old/openSUSE-release-tools-20180206.faa028a/osc-staging.py  2018-02-07 
04:01:04.0 +0100
+++ new/openSUSE-release-tools-20180207.878b87b/osc-staging.py  2018-02-07 
23:20:07.0 +0100
@@ -237,12 +237,19 @@
 Requests may either be the target package or the request ID.
 
 When using --filter-by or --group-by the xpath will be applied to the
-request node as returned by OBS. Several values will supplement the
-normal request node.
+request node as returned by OBS. Use the following on a current request
+to see the XML structure.
+
+osc api /request/1337
+
+A number of additional values will supplement the normal request node.
 
 - ./action/target/@devel_project: the devel project for the package
+- ./action/target/@devel_project_super: super devel project if relevant
 - ./action/target/@ring: the ring to which the package belongs
-- ./@ignored: either false or the provided message
+- ./@aged: either True or False based on splitter-request-age-threshold
+- ./@nonfree: set to nonfree if targetting nonfree sub project
+- ./@ignored: either False or the provided message
 
 Some useful examples:
 
@@ -250,6 +257,7 @@
 --filter-by 

commit python-pymod2pkg for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package python-pymod2pkg for 
openSUSE:Factory checked in at 2018-02-09 15:46:15

Comparing /work/SRC/openSUSE:Factory/python-pymod2pkg (Old)
 and  /work/SRC/openSUSE:Factory/.python-pymod2pkg.new (New)


Package is "python-pymod2pkg"

Fri Feb  9 15:46:15 2018 rev:11 rq:573799 version:0.13.0

Changes:

--- /work/SRC/openSUSE:Factory/python-pymod2pkg/python-pymod2pkg.changes
2018-01-02 16:35:09.453076940 +0100
+++ /work/SRC/openSUSE:Factory/.python-pymod2pkg.new/python-pymod2pkg.changes   
2018-02-09 15:46:16.442131799 +0100
@@ -1,0 +2,8 @@
+Wed Feb  7 16:35:08 UTC 2018 - cloud-de...@suse.de
+
+- update to version 0.13.0
+  - Add packages needed for freezer
+  - Add freezer-api and freezer-dr services
+  - Updated from global requirements
+
+---

Old:

  pymod2pkg-0.11.0.tar.gz

New:

  pymod2pkg-0.13.0.tar.gz



Other differences:
--
++ python-pymod2pkg.spec ++
--- /var/tmp/diff_new_pack.S9I8Jo/_old  2018-02-09 15:46:17.506093594 +0100
+++ /var/tmp/diff_new_pack.S9I8Jo/_new  2018-02-09 15:46:17.506093594 +0100
@@ -18,7 +18,7 @@
 
 %global sname pymod2pkg
 Name:   python-pymod2pkg
-Version:0.11.0
+Version:0.13.0
 Release:0
 Summary:OpenStack Packaging - python module name to package name map
 License:Apache-2.0

++ pymod2pkg-0.11.0.tar.gz -> pymod2pkg-0.13.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pymod2pkg-0.11.0/ChangeLog 
new/pymod2pkg-0.13.0/ChangeLog
--- old/pymod2pkg-0.11.0/ChangeLog  2017-12-21 23:53:13.0 +0100
+++ new/pymod2pkg-0.13.0/ChangeLog  2018-02-07 17:10:56.0 +0100
@@ -1,6 +1,17 @@
 CHANGES
 ===
 
+0.13.0
+--
+
+* Add freezer-api and freezer-dr services
+
+0.12.0
+--
+
+* Add packages needed for freezer
+* Updated from global requirements
+
 0.11.0
 --
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pymod2pkg-0.11.0/PKG-INFO 
new/pymod2pkg-0.13.0/PKG-INFO
--- old/pymod2pkg-0.11.0/PKG-INFO   2017-12-21 23:53:13.0 +0100
+++ new/pymod2pkg-0.13.0/PKG-INFO   2018-02-07 17:10:57.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: pymod2pkg
-Version: 0.11.0
+Version: 0.13.0
 Summary: python module name to package name map
 Home-page: https://docs.openstack.org/pymod2pkg/latest/
 Author: OpenStack
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pymod2pkg-0.11.0/pymod2pkg/__init__.py 
new/pymod2pkg-0.13.0/pymod2pkg/__init__.py
--- old/pymod2pkg-0.11.0/pymod2pkg/__init__.py  2017-12-21 23:51:08.0 
+0100
+++ new/pymod2pkg-0.13.0/pymod2pkg/__init__.py  2018-02-07 17:08:31.0 
+0100
@@ -215,17 +215,20 @@
 # OpenStack services
 MultiRule(
 # keep lists in alphabetic order
-mods=['aodh', 'barbican', 'ceilometer', 'cinder', 'cloudkitty',
-  'designate', 'ec2-api', 'freezer', 'glance', 'heat',
+mods=['aodh', 'barbican', 'ceilometer', 'cinder',
+  'cloudkitty', 'designate', 'ec2-api', 'freezer',
+  'freezer-api', 'freezer-dr', 'glance', 'heat',
   'heat-templates', 'ironic', 'ironic-discoverd',
-  'ironic-inspector', 'ironic-python-agent', 'karbor', 'keystone',
-  'magnum', 'manila', 'masakari', 'masakari-monitors', 'mistral',
-  'monasca-agent', 'monasca-api', 'monasca-ceilometer',
-  'monasca-log-api', 'monasca-notification', 'monasca-persister',
-  'monasca-transform', 'murano', 'neutron', 'neutron-fwaas',
-  'neutron-lbaas', 'neutron-vpnaas', 'nova', 'octavia', 'rally',
-  'sahara', 'swift', 'Tempest', 'tripleo-common', 'trove',
-  'tuskar', 'vitrage', 'zaqar'],
+  'ironic-inspector', 'ironic-python-agent', 'karbor',
+  'keystone', 'magnum', 'manila', 'masakari',
+  'masakari-monitors', 'mistral', 'monasca-agent',
+  'monasca-api', 'monasca-ceilometer', 'monasca-log-api',
+  'monasca-notification', 'monasca-persister',
+  'monasca-transform', 'murano', 'neutron',
+  'neutron-fwaas', 'neutron-lbaas', 'neutron-vpnaas',
+  'nova', 'octavia', 'rally', 'sahara', 'swift',
+  'Tempest', 'tripleo-common', 'trove', 'tuskar',
+  'vitrage', 'zaqar'],
 pkgfun=openstack_prefix_tr),
 # Horizon plugins (normalized to openstack--ui)
 RegexRule(pattern=r'\w+-(dashboard|ui)', pkgfun=rdo_horizon_plugins_tr),
@@ -243,37 +246,41 @@
 # OpenStack 

commit mgp for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package mgp for openSUSE:Factory checked in 
at 2018-02-09 15:46:33

Comparing /work/SRC/openSUSE:Factory/mgp (Old)
 and  /work/SRC/openSUSE:Factory/.mgp.new (New)


Package is "mgp"

Fri Feb  9 15:46:33 2018 rev:27 rq:573908 version:1.13a

Changes:

--- /work/SRC/openSUSE:Factory/mgp/mgp.changes  2017-11-15 16:59:59.219228019 
+0100
+++ /work/SRC/openSUSE:Factory/.mgp.new/mgp.changes 2018-02-09 
15:46:35.485447984 +0100
@@ -1,0 +2,5 @@
+Wed Feb  7 21:09:39 UTC 2018 - meiss...@suse.com
+
+- the "requires freetype" no longer seems necessary.
+
+---



Other differences:
--
++ mgp.spec ++
--- /var/tmp/diff_new_pack.YHgKIR/_old  2018-02-09 15:46:36.325417821 +0100
+++ /var/tmp/diff_new_pack.YHgKIR/_new  2018-02-09 15:46:36.329417678 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package mgp
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -44,7 +44,6 @@
 BuildRequires:  bison
 BuildRequires:  emacs-nox
 BuildRequires:  flex
-BuildRequires:  freetype
 BuildRequires:  freetype2-devel
 BuildRequires:  giflib-devel
 BuildRequires:  imlib2-devel
@@ -53,7 +52,6 @@
 BuildRequires:  pkgconfig
 BuildRequires:  sharutils
 BuildRequires:  xorg-x11-devel
-Requires:   freetype
 Requires:   perl
 Requires:   sharutils
 Recommends: imlib2




commit perl-Mojolicious for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package perl-Mojolicious for 
openSUSE:Factory checked in at 2018-02-09 15:46:21

Comparing /work/SRC/openSUSE:Factory/perl-Mojolicious (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Mojolicious.new (New)


Package is "perl-Mojolicious"

Fri Feb  9 15:46:21 2018 rev:87 rq:573896 version:7.64

Changes:

--- /work/SRC/openSUSE:Factory/perl-Mojolicious/perl-Mojolicious.changes
2018-01-20 11:25:39.367336355 +0100
+++ /work/SRC/openSUSE:Factory/.perl-Mojolicious.new/perl-Mojolicious.changes   
2018-02-09 15:46:24.149855028 +0100
@@ -1,0 +2,19 @@
+Wed Feb  7 16:52:18 UTC 2018 - co...@suse.com
+
+- updated to 7.64
+   see /usr/share/doc/packages/perl-Mojolicious/Changes
+
+  7.64  2018-02-07
+- Fixed a bug in Mojo::Log where short log messages spanning multiple lines
+  would not be formatted properly for systemd.
+  
+  7.63  2018-02-06
+- Improved Mojo::Log to use native systemd log levels.
+  
+  7.62  2018-02-01
+- Added -u option to get command. (jberger)
+- Added dont_use_nlink option to list_tree method in Mojo::File.
+- Added reverse proxy section to Mojolicious::Guides::Cookbook. (polettix)
+- Fixed a promise resolution bug in Mojo::Promise.
+
+---

Old:

  Mojolicious-7.61.tar.gz

New:

  Mojolicious-7.64.tar.gz



Other differences:
--
++ perl-Mojolicious.spec ++
--- /var/tmp/diff_new_pack.K1Cqbh/_old  2018-02-09 15:46:24.909827739 +0100
+++ /var/tmp/diff_new_pack.K1Cqbh/_new  2018-02-09 15:46:24.913827595 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Mojolicious
-Version:7.61
+Version:7.64
 Release:0
 %define cpan_name Mojolicious
 Summary:Real-time web framework

++ Mojolicious-7.61.tar.gz -> Mojolicious-7.64.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Mojolicious-7.61/Changes new/Mojolicious-7.64/Changes
--- old/Mojolicious-7.61/Changes2018-01-08 18:26:40.0 +0100
+++ new/Mojolicious-7.64/Changes2018-02-07 10:47:46.0 +0100
@@ -1,4 +1,17 @@
 
+7.64  2018-02-07
+  - Fixed a bug in Mojo::Log where short log messages spanning multiple lines
+would not be formatted properly for systemd.
+
+7.63  2018-02-06
+  - Improved Mojo::Log to use native systemd log levels.
+
+7.62  2018-02-01
+  - Added -u option to get command. (jberger)
+  - Added dont_use_nlink option to list_tree method in Mojo::File.
+  - Added reverse proxy section to Mojolicious::Guides::Cookbook. (polettix)
+  - Fixed a promise resolution bug in Mojo::Promise.
+
 7.61  2018-01-08
   - Increased default upgrade_timeout from 60 to 180 seconds in
 Mojo::Server::Hypnotoad.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Mojolicious-7.61/META.json 
new/Mojolicious-7.64/META.json
--- old/Mojolicious-7.61/META.json  2018-01-15 16:34:27.0 +0100
+++ new/Mojolicious-7.64/META.json  2018-02-07 11:16:36.0 +0100
@@ -58,6 +58,6 @@
   },
   "x_IRC" : "irc://irc.perl.org/#mojo"
},
-   "version" : "7.61",
+   "version" : "7.64",
"x_serialization_backend" : "JSON::PP version 2.97001"
 }
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Mojolicious-7.61/META.yml 
new/Mojolicious-7.64/META.yml
--- old/Mojolicious-7.61/META.yml   2018-01-15 16:34:27.0 +0100
+++ new/Mojolicious-7.64/META.yml   2018-02-07 11:16:36.0 +0100
@@ -31,5 +31,5 @@
   homepage: http://mojolicious.org
   license: http://www.opensource.org/licenses/artistic-license-2.0
   repository: https://github.com/kraih/mojo.git
-version: '7.61'
+version: '7.64'
 x_serialization_backend: 'CPAN::Meta::YAML version 0.018'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Mojolicious-7.61/lib/Mojo/File.pm 
new/Mojolicious-7.64/lib/Mojo/File.pm
--- old/Mojolicious-7.61/lib/Mojo/File.pm   2018-01-03 13:49:48.0 
+0100
+++ new/Mojolicious-7.64/lib/Mojo/File.pm   2018-02-01 22:25:08.0 
+0100
@@ -54,6 +54,9 @@
   # This may break in the future, but is worth it for performance
   local $File::Find::skip_pattern = qr/^\./ unless $options->{hidden};
 
+  # The File::Find documentation lies, this is needed for CIFS
+  local $File::Find::dont_use_nlink = 1 if $options->{dont_use_nlink};
+
   my %all;
   my $wanted = {wanted => sub { $all{$File::Find::name}++ }, no_chdir => 1};
   $wanted->{postprocess} = sub { delete $all{$File::Find::dir} }
@@ -320,6 +323,12 @@
 
 Include directories.
 
+=item dont_use_nlink
+
+  dont_use_nlink => 1
+
+Force L to 

commit golang-org-x-crypto for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package golang-org-x-crypto for 
openSUSE:Factory checked in at 2018-02-09 15:46:04

Comparing /work/SRC/openSUSE:Factory/golang-org-x-crypto (Old)
 and  /work/SRC/openSUSE:Factory/.golang-org-x-crypto.new (New)


Package is "golang-org-x-crypto"

Fri Feb  9 15:46:04 2018 rev:5 rq:558768 version:1.5.2+git20171021.edd5e9b

Changes:

--- /work/SRC/openSUSE:Factory/golang-org-x-crypto/golang-org-x-crypto.changes  
2017-09-14 21:13:09.623932403 +0200
+++ 
/work/SRC/openSUSE:Factory/.golang-org-x-crypto.new/golang-org-x-crypto.changes 
2018-02-09 15:46:06.194499772 +0100
@@ -1,0 +2,15 @@
+Mon Oct 23 14:06:07 UTC 2017 - opensuse-packag...@opensuse.org
+
+- Update to version 1.5.2+git20171021.edd5e9b:
+  * acme: reword the godoc to be more human readable
+  * ssh: remove unused buffer.eof return value
+  * blake2b: fix typo in error message
+  * acme/autocert: add Cache to Manager example
+  * scrypt: update recommended parameters for 2017
+  * scrypt: add missing license header
+  * ssh: add support for banners
+  * acme: fill Subject CN field in the tls-sni challenge certs
+  * acme, acme/autocert: add missing articles
+  * ocsp: remove incorrect iota and update docs on CreateRequest
+
+---

Old:

  crypto-1.5.2+git20161212.9a6f0a0.tar.xz

New:

  crypto-1.5.2+git20171021.edd5e9b.tar.xz



Other differences:
--
++ golang-org-x-crypto.spec ++
--- /var/tmp/diff_new_pack.ECVLfv/_old  2018-02-09 15:46:06.830476935 +0100
+++ /var/tmp/diff_new_pack.ECVLfv/_new  2018-02-09 15:46:06.830476935 +0100
@@ -24,7 +24,7 @@
 %global import_path golang.org/x/crypto
 
 Name:   golang-org-x-%{repo}
-Version:1.5.2+git20161212.9a6f0a0
+Version:1.5.2+git20171021.edd5e9b
 Release:0
 Summary:Go supplementary cryptography libraries
 License:BSD-3-Clause
@@ -39,6 +39,8 @@
 
 BuildRequires:  golang-org-x-net-context
 Requires:   golang-org-x-net-context
+BuildRequires:  golang(golang.org/x/sys/unix)
+Requires:   golang(golang.org/x/sys/unix)
 
 %{go_nostrip}
 %{go_provides}
@@ -60,6 +62,6 @@
 
 %files -f file.lst
 %defattr(-,root,root,-)
-%doc README LICENSE PATENTS AUTHORS CONTRIBUTORS
+%doc README.md LICENSE PATENTS AUTHORS CONTRIBUTORS
 
 %changelog

++ crypto-1.5.2+git20161212.9a6f0a0.tar.xz -> 
crypto-1.5.2+git20171021.edd5e9b.tar.xz ++
 19352 lines of diff (skipped)




commit grub2 for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package grub2 for openSUSE:Factory checked 
in at 2018-02-09 15:45:30

Comparing /work/SRC/openSUSE:Factory/grub2 (Old)
 and  /work/SRC/openSUSE:Factory/.grub2.new (New)


Package is "grub2"

Fri Feb  9 15:45:30 2018 rev:176 rq:574507 version:2.02

Changes:

--- /work/SRC/openSUSE:Factory/grub2/grub2.changes  2018-02-02 
22:19:59.808277231 +0100
+++ /work/SRC/openSUSE:Factory/.grub2.new/grub2.changes 2018-02-09 
15:45:33.219683812 +0100
@@ -1,0 +2,19 @@
+Wed Feb  7 09:58:26 UTC 2018 - mch...@suse.com
+
+- Fix disappeared snapshot menu entry (bsc#1078481)
+  * 80_suse_btrfs_snapshot 
+
+---
+Tue Feb  6 09:44:26 UTC 2018 - mch...@suse.com
+
+- Fix unquoted string error and add some more checks (bsc#1079330) 
+  * grub2-check-default.sh
+
+---
+Mon Feb  5 08:52:20 UTC 2018 - o...@aepfle.de
+
+- The %prep section applies patches, the %build section builds.
+  Remove mixup of patching and building from %prep for quilt setup
+  Related to bsc#1065703
+
+---



Other differences:
--
++ grub2.spec ++
--- /var/tmp/diff_new_pack.mBHEUe/_old  2018-02-09 15:45:36.379570350 +0100
+++ /var/tmp/diff_new_pack.mBHEUe/_new  2018-02-09 15:45:36.383570206 +0100
@@ -544,6 +544,8 @@
 %patch420 -p1
 %patch421 -p1
 %patch430 -p1
+
+%build
 # patches above may update the timestamp of grub.texi
 # and via build-aux/mdate-sh they end up in grub2.info, breaking build-compare
 [ -z "$SOURCE_DATE_EPOCH" ] ||\
@@ -574,7 +576,6 @@
 mkdir build-emu
 %endif
 
-%build
 export PYTHON=%{_bindir}/python3
 # autogen calls autoreconf -vi
 ./autogen.sh

++ 80_suse_btrfs_snapshot ++
--- /var/tmp/diff_new_pack.mBHEUe/_old  2018-02-09 15:45:36.499566042 +0100
+++ /var/tmp/diff_new_pack.mBHEUe/_new  2018-02-09 15:45:36.499566042 +0100
@@ -1,10 +1,22 @@
 #! /bin/sh
 set -e
+SNAPSHOTS="/.snapshots"
 if [ "x${SUSE_BTRFS_SNAPSHOT_BOOTING}" = "xtrue" ] &&
-   [ "x${GRUB_FS}" = "xbtrfs" ] ; then
+   [ "x${GRUB_FS}" = "xbtrfs" ] && 
+   [ -f "${SNAPSHOTS}/grub-snapshot.cfg" ]; then
+  SNAPSHOT_RID=`btrfs inspect-internal rootid ${SNAPSHOTS}`
+  ROOT_RID=`btrfs inspect-internal rootid /`
+  if [ -n "${SNAPSHOT_RID}" -a "${SNAPSHOT_RID}" != "${ROOT_RID}" ]; then
+SNAPSHOT_SUBVOL=`btrfs inspect-internal subvolid-resolve ${SNAPSHOT_RID} /`
+ROOT_SUBVOL=`btrfs inspect-internal subvolid-resolve ${ROOT_RID} /`
+INODE=`stat -c '%i' ${SNAPSHOTS}`
+if [ "x${INODE}" = "x256" -a "x${ROOT_SUBVOL}${SNAPSHOTS}" != 
"x${SNAPSHOT_SUBVOL}" ]; then
+  echo "btrfs-mount-subvol (\$root) ${SNAPSHOTS} ${SNAPSHOT_SUBVOL}"
+fi
+  fi
 cat 

commit protobuf-c for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package protobuf-c for openSUSE:Factory 
checked in at 2018-02-09 15:45:14

Comparing /work/SRC/openSUSE:Factory/protobuf-c (Old)
 and  /work/SRC/openSUSE:Factory/.protobuf-c.new (New)


Package is "protobuf-c"

Fri Feb  9 15:45:14 2018 rev:12 rq:573409 version:1.3.0

Changes:

--- /work/SRC/openSUSE:Factory/protobuf-c/protobuf-c.changes2017-12-29 
18:47:37.141600215 +0100
+++ /work/SRC/openSUSE:Factory/.protobuf-c.new/protobuf-c.changes   
2018-02-09 15:45:17.512247815 +0100
@@ -1,0 +2,5 @@
+Fri Dec 22 14:29:07 UTC 2017 - jeng...@inai.de
+
+- Drop %__-type macro indirections.
+
+---



Other differences:
--
++ protobuf-c.spec ++
--- /var/tmp/diff_new_pack.026hEG/_old  2018-02-09 15:45:18.304219378 +0100
+++ /var/tmp/diff_new_pack.026hEG/_new  2018-02-09 15:45:18.308219234 +0100
@@ -78,12 +78,12 @@
 -DCMAKE_BUILD_WITH_INSTALL_RPATH=FALSE \
 -DCMAKE_STRIP="/usr/bin/touch" \
 ..
-%__make %{?_smp_flags}
+make %{?_smp_flags}
 popd #build
 %else
 autoreconf -fvi
 %configure
-%__make %{?_smp_flags}
+make %{?_smp_flags}
 %endif
 
 %install
@@ -92,10 +92,10 @@
 %makeinstall
 popd #build
 %else
-%makeinstall
+%make_install
 %endif
-%__rm "%{buildroot}%{_libdir}"/*.a
-%__rm "%{buildroot}%{_libdir}"/*.la
+rm "%{buildroot}/%{_libdir}"/*.a
+rm "%{buildroot}/%{_libdir}"/*.la
 
 %post   -n libprotobuf-c%{soname} -p /sbin/ldconfig
 %postun -n libprotobuf-c%{soname} -p /sbin/ldconfig




commit zziplib for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package zziplib for openSUSE:Factory checked 
in at 2018-02-09 15:45:22

Comparing /work/SRC/openSUSE:Factory/zziplib (Old)
 and  /work/SRC/openSUSE:Factory/.zziplib.new (New)


Package is "zziplib"

Fri Feb  9 15:45:22 2018 rev:26 rq:573678 version:0.13.67

Changes:

--- /work/SRC/openSUSE:Factory/zziplib/zziplib.changes  2018-01-30 
15:38:12.243971109 +0100
+++ /work/SRC/openSUSE:Factory/.zziplib.new/zziplib.changes 2018-02-09 
15:45:22.196079635 +0100
@@ -1,0 +2,25 @@
+Tue Feb  6 14:55:03 UTC 2018 - josef.moell...@suse.com
+
+- If an extension block is too small to hold an extension,
+  do not use the information therein.
+- If the End of central directory record (EOCD) contains an
+  Offset of start of central directory which is beyond the end of
+  the file, reject the file.
+  [CVE-2018-6540, bsc#1079096, CVE-2018-6540.patch]
+
+---
+Fri Feb  2 09:31:49 UTC 2018 - josef.moell...@suse.com
+
+- Reject the ZIP file and report it as corrupt if the size of the
+  central directory and/or the offset of start of central directory
+  point beyond the end of the ZIP file.
+  [CVE-2018-6484, boo#1078701, CVE-2018-6484.patch]
+
+---
+Thu Feb  1 10:49:56 UTC 2018 - josef.moell...@suse.com
+
+- If a file is uncompressed, compressed and uncompressed sizes
+  should be identical.
+  [CVE-2018-6381, bsc#1078497, CVE-2018-6381.patch]
+
+---

New:

  CVE-2018-6381.patch
  CVE-2018-6484.patch
  CVE-2018-6540.patch



Other differences:
--
++ zziplib.spec ++
--- /var/tmp/diff_new_pack.3ajViQ/_old  2018-02-09 15:45:23.312039564 +0100
+++ /var/tmp/diff_new_pack.3ajViQ/_new  2018-02-09 15:45:23.316039421 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package zziplib
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -29,6 +29,9 @@
 Patch0: zziplib-0.13.62.patch
 Patch1: zziplib-0.13.62-wronglinking.patch
 Patch2: zziplib-largefile.patch
+Patch3: CVE-2018-6381.patch
+Patch4: CVE-2018-6484.patch
+Patch5: CVE-2018-6540.patch
 BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  fdupes
@@ -66,6 +69,9 @@
 %patch0
 %patch1
 %patch2
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
 # do not bother with html docs saving us python2 dependency
 sed -i -e 's:docs ::g' Makefile.am
 

++ CVE-2018-6381.patch ++
Index: zziplib-0.13.67/zzip/memdisk.c
===
--- zziplib-0.13.67.orig/zzip/memdisk.c
+++ zziplib-0.13.67/zzip/memdisk.c
@@ -209,6 +209,14 @@ zzip_mem_entry_new(ZZIP_DISK * disk, ZZI
 item->zz_diskstart = zzip_disk_entry_get_diskstart(entry);
 item->zz_filetype = zzip_disk_entry_get_filetype(entry);
 
+/*
+ * If the file is uncompressed, zz_csize and zz_usize should be the same
+ * If they are not, we cannot guarantee that either is correct, so ...
+ */
+if (item->zz_compr == ZZIP_IS_STORED && item->zz_csize != item->zz_usize)
+{
+goto error;
+}
 /* zz_comment and zz_name are empty strings if not present on disk */
 if (! item->zz_comment || ! item->zz_name)
 {
++ CVE-2018-6484.patch ++
Index: zziplib-0.13.67/zzip/zip.c
===
--- zziplib-0.13.67.orig/zzip/zip.c
+++ zziplib-0.13.67/zzip/zip.c
@@ -320,6 +320,12 @@ __zzip_fetch_disk_trailer(int fd, zzip_o
 #  endif
 
 __fixup_rootseek(offset + tail - mapped, trailer);
+   /*
+* "extract data from files archived in a single zip file."
+* So the file offsets must be within the current ZIP 
archive!
+*/
+   if (trailer->zz_rootseek >= filesize || 
(trailer->zz_rootseek + trailer->zz_rootsize) >= filesize)
+   return(ZZIP_CORRUPTED);
 { return(0); }
 } else if ((*tail == 'P') &&
end - tail >=
@@ -338,6 +344,12 @@ __zzip_fetch_disk_trailer(int fd, zzip_o
 zzip_disk64_trailer_finalentries(orig);
 trailer->zz_rootseek = zzip_disk64_trailer_rootseek(orig);
 trailer->zz_rootsize = zzip_disk64_trailer_rootsize(orig);
+   /*
+  

commit kwayland for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package kwayland for openSUSE:Factory 
checked in at 2018-02-09 15:44:57

Comparing /work/SRC/openSUSE:Factory/kwayland (Old)
 and  /work/SRC/openSUSE:Factory/.kwayland.new (New)


Package is "kwayland"

Fri Feb  9 15:44:57 2018 rev:45 rq:573390 version:5.42.0

Changes:

--- /work/SRC/openSUSE:Factory/kwayland/kwayland.changes2018-01-22 
16:03:37.795727344 +0100
+++ /work/SRC/openSUSE:Factory/.kwayland.new/kwayland.changes   2018-02-09 
15:44:58.740921823 +0100
@@ -1,0 +2,7 @@
+Tue Feb  6 16:00:45 UTC 2018 - lbeltr...@kde.org
+
+- Add 0001-server-Don-t-crash-when-a-subsurface-gets-commited-w.patch
+  * Upstream fix to prevent kwin from crashing when opening
+systemsettings (kde#389231)
+
+---

New:

  0001-server-Don-t-crash-when-a-subsurface-gets-commited-w.patch



Other differences:
--
++ kwayland.spec ++
--- /var/tmp/diff_new_pack.GxHNWe/_old  2018-02-09 15:44:59.552892668 +0100
+++ /var/tmp/diff_new_pack.GxHNWe/_new  2018-02-09 15:44:59.552892668 +0100
@@ -30,6 +30,8 @@
 Url:http://www.kde.org
 Source: 
http://download.kde.org/stable/frameworks/%{_tar_path}/%{name}-%{version}.tar.xz
 Source1:baselibs.conf
+# PATCH-FIX-UPSTREAM
+Patch0: 0001-server-Don-t-crash-when-a-subsurface-gets-commited-w.patch
 BuildRequires:  cmake >= 3.0
 BuildRequires:  extra-cmake-modules >= %{_kf5_bugfix_version}
 BuildRequires:  fdupes
@@ -69,6 +71,7 @@
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
   %cmake_kf5 -d build

++ 0001-server-Don-t-crash-when-a-subsurface-gets-commited-w.patch ++
>From abfd8c2f896bf38c703755952bb3c955ff83a8f1 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Martin=20Fl=C3=B6ser?= 
Date: Tue, 6 Feb 2018 16:57:59 +0100
Subject: [PATCH] [server] Don't crash when a subsurface gets commited whose
 parent surface got destroyed

Summary:
Qt seems to damage and commit child subsurfaces although their parent
got destroyed. This actually doesn't make any sense as without a parent
surface they cannot be shown. But nevertheless we should not crash in
such a situation.

This change guards the places in the commit handling code where the
parent gets accessed.

BUG: 389231

Test Plan: New test case which exposes the problem

Reviewers: #frameworks, #kwin, #plasma, davidedmundson

Reviewed By: #plasma, davidedmundson

Subscribers: plasma-devel

Tags: #frameworks, #plasma_on_wayland

Differential Revision: https://phabricator.kde.org/D10300
---
 autotests/client/test_wayland_subsurface.cpp | 47 
 src/server/subcompositor_interface.cpp   |  3 ++
 src/server/surface_interface.cpp |  7 +++--
 3 files changed, 55 insertions(+), 2 deletions(-)

diff --git a/autotests/client/test_wayland_subsurface.cpp 
b/autotests/client/test_wayland_subsurface.cpp
index 42c326a..dc53a1b 100644
--- a/autotests/client/test_wayland_subsurface.cpp
+++ b/autotests/client/test_wayland_subsurface.cpp
@@ -59,6 +59,7 @@ private Q_SLOTS:
 void testMappingOfSurfaceTree();
 void testSurfaceAt();
 void testDestroyAttachedBuffer();
+void testDestroyParentSurface();
 
 private:
 KWayland::Server::Display *m_display;
@@ -1041,5 +1042,51 @@ void TestSubSurface::testDestroyAttachedBuffer()
 QVERIFY(destroySpy.wait());
 }
 
+void TestSubSurface::testDestroyParentSurface()
+{
+// this test verifies that destroying a parent surface does not create 
problems
+// see BUG 389231
+using namespace KWayland::Client;
+using namespace KWayland::Server;
+// create surface
+QSignalSpy serverSurfaceCreated(m_compositorInterface, 
::surfaceCreated);
+QVERIFY(serverSurfaceCreated.isValid());
+QScopedPointer parent(m_compositor->createSurface());
+QVERIFY(serverSurfaceCreated.wait());
+SurfaceInterface *serverParentSurface = 
serverSurfaceCreated.last().first().value();
+QScopedPointer child(m_compositor->createSurface());
+QVERIFY(serverSurfaceCreated.wait());
+SurfaceInterface *serverChildSurface = 
serverSurfaceCreated.last().first().value();
+QScopedPointer grandChild(m_compositor->createSurface());
+QVERIFY(serverSurfaceCreated.wait());
+SurfaceInterface *serverGrandChildSurface = 
serverSurfaceCreated.last().first().value();
+// create sub-surface in desynchronized mode as Qt uses them
+auto sub1 = m_subCompositor->createSubSurface(child.data(), parent.data());
+sub1->setMode(SubSurface::Mode::Desynchronized);
+auto sub2 = m_subCompositor->createSubSurface(grandChild.data(), 

commit xinetd for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package xinetd for openSUSE:Factory checked 
in at 2018-02-09 15:45:05

Comparing /work/SRC/openSUSE:Factory/xinetd (Old)
 and  /work/SRC/openSUSE:Factory/.xinetd.new (New)


Package is "xinetd"

Fri Feb  9 15:45:05 2018 rev:39 rq:573405 version:2.3.15.3

Changes:

--- /work/SRC/openSUSE:Factory/xinetd/xinetd.changes2017-11-30 
12:40:04.017533520 +0100
+++ /work/SRC/openSUSE:Factory/.xinetd.new/xinetd.changes   2018-02-09 
15:45:07.264615770 +0100
@@ -1,0 +2,6 @@
+Tue Feb  6 15:24:36 UTC 2018 - ku...@suse.com
+
+- Move /etc/xinet.d directory from filesystem package to this one,
+  as this is no standard package anymore.
+
+---



Other differences:
--
++ xinetd.spec ++
--- /var/tmp/diff_new_pack.g9nwEq/_old  2018-02-09 15:45:08.324577711 +0100
+++ /var/tmp/diff_new_pack.g9nwEq/_new  2018-02-09 15:45:08.324577711 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package xinetd
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -90,6 +90,7 @@
 %doc README.md CHANGELOG COPYRIGHT README.SUSE logrotate
 %{_mandir}/man5/*
 %{_mandir}/man8/*
+%dir %{_sysconfdir}/xinetd.d
 %config(noreplace) %{_sysconfdir}/xinetd.d/*
 %config(noreplace) %{_sysconfdir}/%{name}.conf
 %{_sbindir}/xinetd




commit mupdf for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package mupdf for openSUSE:Factory checked 
in at 2018-02-09 15:44:40

Comparing /work/SRC/openSUSE:Factory/mupdf (Old)
 and  /work/SRC/openSUSE:Factory/.mupdf.new (New)


Package is "mupdf"

Fri Feb  9 15:44:40 2018 rev:33 rq:573349 version:1.12.0

Changes:

--- /work/SRC/openSUSE:Factory/mupdf/mupdf.changes  2018-02-05 
10:49:22.142534534 +0100
+++ /work/SRC/openSUSE:Factory/.mupdf.new/mupdf.changes 2018-02-09 
15:44:47.757316198 +0100
@@ -1,0 +2,5 @@
+Tue Feb  6 14:36:54 UTC 2018 - meiss...@suse.com
+
+- use freetype2-devel explictily as buildrequires
+
+---



Other differences:
--
++ mupdf.spec ++
--- /var/tmp/diff_new_pack.VatteD/_old  2018-02-09 15:44:50.537216384 +0100
+++ /var/tmp/diff_new_pack.VatteD/_new  2018-02-09 15:44:50.541216240 +0100
@@ -33,7 +33,7 @@
 Patch4: CVE-2018-6187.patch
 Patch5: CVE-2018-6192.patch
 Patch6: CVE-2018-6544.patch
-BuildRequires:  freetype-devel
+BuildRequires:  freetype2-devel
 BuildRequires:  gcc-c++
 BuildRequires:  jbig2dec-devel
 BuildRequires:  libcurl-devel





commit ethtool for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package ethtool for openSUSE:Factory checked 
in at 2018-02-09 15:44:32

Comparing /work/SRC/openSUSE:Factory/ethtool (Old)
 and  /work/SRC/openSUSE:Factory/.ethtool.new (New)


Package is "ethtool"

Fri Feb  9 15:44:32 2018 rev:49 rq:573299 version:4.15

Changes:

--- /work/SRC/openSUSE:Factory/ethtool/ethtool.changes  2017-11-01 
11:06:53.791782531 +0100
+++ /work/SRC/openSUSE:Factory/.ethtool.new/ethtool.changes 2018-02-09 
15:44:33.653822591 +0100
@@ -1,0 +2,10 @@
+Fri Feb  2 10:15:20 UTC 2018 - mkube...@suse.cz
+
+- Update to new updstream release 4.15
+  * Feature: Support for FEC encoding control
+  * Feature: Add extended compliance codes parsing to sfp modules
+  * Feature: Add ETHTOOL_RESET support via --reset command
+  * Fix: Revert "ethtool: Add DMA Coalescing support"
+  * Fix: fix MFLCN register dump for 82599 and newer
+
+---

Old:

  ethtool-4.13.tar.sign
  ethtool-4.13.tar.xz

New:

  ethtool-4.15.tar.sign
  ethtool-4.15.tar.xz



Other differences:
--
++ ethtool.spec ++
--- /var/tmp/diff_new_pack.tpUj9O/_old  2018-02-09 15:44:34.481792862 +0100
+++ /var/tmp/diff_new_pack.tpUj9O/_new  2018-02-09 15:44:34.481792862 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package ethtool
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   ethtool
-Version:4.13
+Version:4.15
 Release:0
 Summary:Examine and Tune Ethernet-Based Network Interfaces
 License:GPL-2.0

++ ethtool-4.13.tar.xz -> ethtool-4.15.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/ethtool-4.13/NEWS new/ethtool-4.15/NEWS
--- old/ethtool-4.13/NEWS   2017-10-27 20:04:48.0 +0200
+++ new/ethtool-4.15/NEWS   2018-02-01 19:34:54.0 +0100
@@ -1,3 +1,13 @@
+Version 4.15 - February 1, 2018
+
+   * Feature: Support for FEC encoding control
+   * Fix: Fix coding style warnings and errors reported by checkpatch
+   * Feature: Add extended compliance codes parsing to sfp modules
+   * Fix: Revert "ethtool: Add DMA Coalescing support"
+   * Feature: Add ETHTOOL_RESET support via --reset command
+   * Fix: fix MFLCN register dump for 82599 and newer
+
+
 Version 4.13 - October 27, 2017
 
* Fix: Do not return error code if no changes were attempted.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/ethtool-4.13/configure new/ethtool-4.15/configure
--- old/ethtool-4.13/configure  2017-10-27 20:11:24.0 +0200
+++ new/ethtool-4.15/configure  2018-02-01 19:36:22.0 +0100
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for ethtool 4.13.
+# Generated by GNU Autoconf 2.69 for ethtool 4.15.
 #
 # Report bugs to .
 #
@@ -580,8 +580,8 @@
 # Identity of this package.
 PACKAGE_NAME='ethtool'
 PACKAGE_TARNAME='ethtool'
-PACKAGE_VERSION='4.13'
-PACKAGE_STRING='ethtool 4.13'
+PACKAGE_VERSION='4.15'
+PACKAGE_STRING='ethtool 4.15'
 PACKAGE_BUGREPORT='net...@vger.kernel.org'
 PACKAGE_URL=''
 
@@ -1237,7 +1237,7 @@
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat <<_ACEOF
-\`configure' configures ethtool 4.13 to adapt to many kinds of systems.
+\`configure' configures ethtool 4.15 to adapt to many kinds of systems.
 
 Usage: $0 [OPTION]... [VAR=VALUE]...
 
@@ -1303,7 +1303,7 @@
 
 if test -n "$ac_init_help"; then
   case $ac_init_help in
- short | recursive ) echo "Configuration of ethtool 4.13:";;
+ short | recursive ) echo "Configuration of ethtool 4.15:";;
esac
   cat <<\_ACEOF
 
@@ -1398,7 +1398,7 @@
 test -n "$ac_init_help" && exit $ac_status
 if $ac_init_version; then
   cat <<\_ACEOF
-ethtool configure 4.13
+ethtool configure 4.15
 generated by GNU Autoconf 2.69
 
 Copyright (C) 2012 Free Software Foundation, Inc.
@@ -1645,7 +1645,7 @@
 This file contains any messages produced by compilers while
 running configure, to aid debugging if configure makes a mistake.
 
-It was created by ethtool $as_me 4.13, which was
+It was created by ethtool $as_me 4.15, which was
 generated by GNU Autoconf 2.69.  Invocation command line was
 
   $ $0 $@
@@ -2510,7 +2510,7 @@
 
 # Define the identity of the package.
  

commit obs-service-source_validator for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package obs-service-source_validator for 
openSUSE:Factory checked in at 2018-02-09 15:44:24

Comparing /work/SRC/openSUSE:Factory/obs-service-source_validator (Old)
 and  /work/SRC/openSUSE:Factory/.obs-service-source_validator.new (New)


Package is "obs-service-source_validator"

Fri Feb  9 15:44:24 2018 rev:45 rq:573284 version:0.13

Changes:

--- 
/work/SRC/openSUSE:Factory/obs-service-source_validator/obs-service-source_validator.changes
2018-01-28 00:38:55.726906755 +0100
+++ 
/work/SRC/openSUSE:Factory/.obs-service-source_validator.new/obs-service-source_validator.changes
   2018-02-09 15:44:25.094129928 +0100
@@ -1,0 +2,14 @@
+Tue Feb 06 10:33:40 UTC 2018 - adr...@suse.de
+
+- Update to version 0.13:
+  * move multibuild or multi spec in front
+  * add glibc testcase using multibuild
+  * support _multibuild files when validating sources
+
+---
+Tue Feb  6 10:33:07 UTC 2018 - adr...@suse.de
+
+- Update to version 0.13
+  * do not use "--no-conditionals" for baselibs check
+
+---

Old:

  obs-service-source_validator-0.12.tar.bz2

New:

  obs-service-source_validator-0.13.tar.bz2



Other differences:
--
++ obs-service-source_validator.spec ++
--- /var/tmp/diff_new_pack.DTnvyy/_old  2018-02-09 15:44:26.346084976 +0100
+++ /var/tmp/diff_new_pack.DTnvyy/_new  2018-02-09 15:44:26.346084976 +0100
@@ -21,7 +21,7 @@
 License:GPL-2.0+
 Group:  Development/Tools/Building
 Url:https://github.com/openSUSE/obs-service-source_validator
-Version:0.12
+Version:0.13
 Release:0
 # use osc service dr to update
 Source: %{name}-%{version}.tar.bz2

++ _service ++
--- /var/tmp/diff_new_pack.DTnvyy/_old  2018-02-09 15:44:26.374083971 +0100
+++ /var/tmp/diff_new_pack.DTnvyy/_new  2018-02-09 15:44:26.374083971 +0100
@@ -8,8 +8,8 @@
 0.7+git%cd.%h
 master
 -->
-0.12
-0.12
+0.13
+0.13
 enable
   
 

++ _servicedata ++
--- /var/tmp/diff_new_pack.DTnvyy/_old  2018-02-09 15:44:26.390083396 +0100
+++ /var/tmp/diff_new_pack.DTnvyy/_new  2018-02-09 15:44:26.390083396 +0100
@@ -1,4 +1,4 @@
 
 
 git://github.com/openSUSE/obs-service-source_validator.git
-  74f67d76f95090350ea2770407d664a455eb48cc
\ No newline at end of file
+  e27c7138d5b5d951254808d0b4860e6f03fa19ac
\ No newline at end of file

++ debian.dsc ++
--- /var/tmp/diff_new_pack.DTnvyy/_old  2018-02-09 15:44:26.414082535 +0100
+++ /var/tmp/diff_new_pack.DTnvyy/_new  2018-02-09 15:44:26.418082392 +0100
@@ -1,6 +1,6 @@
 Format: 1.0
 Source: obs-service-source-validator
-Version: 0.12-0
+Version: 0.13-0
 Binary: obs-service-source-validator
 Maintainer: Hib Eris 
 Architecture: all

++ obs-service-source_validator-0.12.tar.bz2 -> 
obs-service-source_validator-0.13.tar.bz2 ++
 1626 lines of diff (skipped)




commit python-numpy for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package python-numpy for openSUSE:Factory 
checked in at 2018-02-09 15:44:14

Comparing /work/SRC/openSUSE:Factory/python-numpy (Old)
 and  /work/SRC/openSUSE:Factory/.python-numpy.new (New)


Package is "python-numpy"

Fri Feb  9 15:44:14 2018 rev:64 rq:573260 version:1.14.0

Changes:

--- /work/SRC/openSUSE:Factory/python-numpy/python-numpy.changes
2018-01-21 15:48:26.575402924 +0100
+++ /work/SRC/openSUSE:Factory/.python-numpy.new/python-numpy.changes   
2018-02-09 15:44:17.214412848 +0100
@@ -1,0 +2,6 @@
+Tue Feb  6 09:26:56 UTC 2018 - e...@suse.com
+
+- The HPC of python-numpy expects openBLAS. OpenBLAS is not availble
+  for sc390: disable buidling on s390 for HPC (bsc#1079513).
+
+---



Other differences:
--
++ python-numpy.spec ++
--- /var/tmp/diff_new_pack.VDphns/_old  2018-02-09 15:44:17.982385274 +0100
+++ /var/tmp/diff_new_pack.VDphns/_new  2018-02-09 15:44:17.982385274 +0100
@@ -48,6 +48,10 @@
  %define c_f_ver 7
 %endif
 
+%ifarch s390
+%{?with_openblas:ExclusiveArch:  do_not_build}
+%endif
+
 %if %{without hpc}
 %define package_name %{pname}
 %define p_python_sitearch %python_sitearch





commit meson for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package meson for openSUSE:Factory checked 
in at 2018-02-09 15:44:05

Comparing /work/SRC/openSUSE:Factory/meson (Old)
 and  /work/SRC/openSUSE:Factory/.meson.new (New)


Package is "meson"

Fri Feb  9 15:44:05 2018 rev:27 rq:573240 version:0.44.0

Changes:

--- /work/SRC/openSUSE:Factory/meson/meson-testsuite.changes2017-11-30 
12:34:45.733107022 +0100
+++ /work/SRC/openSUSE:Factory/.meson.new/meson-testsuite.changes   
2018-02-09 15:44:07.698754504 +0100
@@ -1,0 +2,25 @@
+Mon Feb  5 15:06:54 UTC 2018 - dims...@opensuse.org
+
+- Update to version 0.44.0:
+  + New features:
+- Added warning function.
+- Adds support for additional Qt5-Module keyword
+  moc_extra_arguments.
+- Prefix-dependent defaults for sysconfdir, localstatedir and
+  sharedstatedir.
+- An array type for user options.
+- LLVM dependency supports both dynamic and static linking.
+- Added if_found to subdir.
+- get_unquoted() method for the configuration data object.
+- Added disabler object.
+- Config-Tool based dependencies gained a method to get
+  arbitrary options.
+- Embedded Python in Windows MSI packages.
+- Rebase meson-suse-ify-macros.patch, meson-fix-gcc48.patch and
+  meson-test-installed-bin.patch.
+- Testsuite changes:
+  + Disable tests for static llvm: we don't ship the static libs.
+  + Add cmake(Qt5LinguistTools), libwmf-devel BuildRequires and
+zlib-devel-static: new dependencies for various tests.
+
+---
meson.changes: same change

Old:

  meson-0.43.0.tar.gz
  meson-0.43.0.tar.gz.asc

New:

  meson-0.44.0.tar.gz
  meson-0.44.0.tar.gz.asc



Other differences:
--
++ meson-testsuite.spec ++
--- /var/tmp/diff_new_pack.3P64Yb/_old  2018-02-09 15:44:08.374730234 +0100
+++ /var/tmp/diff_new_pack.3P64Yb/_new  2018-02-09 15:44:08.374730234 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package meson-testsuite
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -24,7 +24,7 @@
 %endif
 %define _name   mesonbuild
 Name:   meson%{name_ext}
-Version:0.43.0
+Version:0.44.0
 Release:0
 Summary:Python-based build system
 License:Apache-2.0
@@ -56,8 +56,9 @@
 BuildRequires:  gtk-doc
 BuildRequires:  itstool
 BuildRequires:  libpcap-devel
+BuildRequires:  libwmf-devel
 BuildRequires:  llvm-devel
-BuildRequires:  meson >= %{version}
+BuildRequires:  meson = %{version}
 BuildRequires:  ncurses-devel
 BuildRequires:  ninja
 BuildRequires:  openmpi-devel
@@ -67,8 +68,10 @@
 BuildRequires:  python3-setuptools
 BuildRequires:  vala
 BuildRequires:  vulkan-devel
+BuildRequires:  zlib-devel-static
 BuildRequires:  cmake(Qt5Core)
 BuildRequires:  cmake(Qt5Gui)
+BuildRequires:  cmake(Qt5LinguistTools)
 BuildRequires:  cmake(Qt5Widgets)
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(gobject-introspection-1.0)
@@ -125,6 +128,9 @@
 # Remove static boost tests from test cases/frameworks/1 boost (can't use 
patch due to spaces in dirname)
 sed -i "/static/d" test\ cases/frameworks/1\ boost/meson.build
 
+# Disable test of llvm-static libs: openSUSE does not package/ship them
+sed -i "s/foreach static : \[true, false\]/foreach static : \[false\]/" test\ 
cases/frameworks/15\ llvm/meson.build
+
 # We do not have gmock available at this moment - can't run the test suite for 
it
 rm -rf "test cases/frameworks/3 gmock" \
"test cases/objc/2 nsstring"
@@ -138,7 +144,9 @@
 python3 setup.py build
 %else
 # When running the test suite, we want to be sure to use the installed meson 
version
-rm -rf meson.py mesonbuild
+# For now, the only supported test suite is against the source directory, 
https://github.com/mesonbuild/meson/issues/3015
+# and there is so much weird code now in mesonlibs, that patching it to not 
require it became a nightmare - let's do what upstream wants for now
+echo "Prefereably we would do 'rm -rf meson.py mesonbuild' here, but we can't"
 %endif
 
 %install
@@ -150,11 +158,11 @@
 install -Dpm 0644 data/macros.meson \
   %{buildroot}%{_rpmconfigdir}/macros.d/macros.meson
 
-install -Dpm 0644 syntax-highlighting/vim/ftdetect/meson.vim \
+install -Dpm 0644 data/syntax-highlighting/vim/ftdetect/meson.vim \
   -t %{buildroot}%{vim_data_dir}/site/ftdetect
-install -Dpm 0644 syntax-highlighting/vim/indent/meson.vim \
+install -Dpm 0644 data/syntax-highlighting/vim/indent/meson.vim \
   -t 

commit python-kiwi for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package python-kiwi for openSUSE:Factory 
checked in at 2018-02-09 15:43:32

Comparing /work/SRC/openSUSE:Factory/python-kiwi (Old)
 and  /work/SRC/openSUSE:Factory/.python-kiwi.new (New)


Package is "python-kiwi"

Fri Feb  9 15:43:32 2018 rev:18 rq:573218 version:9.12.8

Changes:

--- /work/SRC/openSUSE:Factory/python-kiwi/python-kiwi.changes  2018-01-30 
15:38:55.953930381 +0100
+++ /work/SRC/openSUSE:Factory/.python-kiwi.new/python-kiwi.changes 
2018-02-09 15:43:33.875968878 +0100
@@ -1,0 +2,145 @@
+Mon Feb  5 17:02:19 CET 2018 - m...@suse.de
+
+- Bump version: 9.12.7 → 9.12.8
+  
+---
+Mon Feb  5 15:56:26 CET 2018 - m...@suse.de
+  
+- Exclude install source device from target list
+  
+---
+Mon Feb  5 15:29:25 CET 2018 - m...@suse.de
+  
+- Fixed kiwi-dump timing issue
+  
+  The install code needs to wait in the pre-udev phase for
+  the device containing the installation data to become ready
+  before proceeding with the actual installation code.
+  
+---
+Mon Feb  5 15:28:12 CET 2018 - m...@suse.de
+  
+- Fixed dialog size of install confirmation dialog
+  
+  The size was too small to show device names which causes a
+  line break to be displayed in the next line
+  
+---
+Sun Feb  4 20:19:45 CET 2018 - m...@suse.de
+  
+- Cleanup misleading method name
+  
+---
+Sun Feb  4 18:46:09 CET 2018 - m...@suse.de
+  
+- Fixed coverage report setup
+  
+  Latest version of the coverage module requires a report setup
+  
+---
+Sun Feb  4 15:52:06 CET 2018 - m...@suse.de
+  
+- Fixed target path name for gce format
+  
+  get_target_name_for_format in case of the gce format does
+  not return a path spec which leads to an incomplete result
+  information for a later bundle command. This patch fixes
+  this. In a follow up pull request we will also update
+  the method name from the misleading get_target_name_for_format
+  function name to get_target_path_name_for_format
+  
+---
+Sat Feb  3 13:12:48 CET 2018 - cyber...@cyberorg.info
+  
+- Use live-grub-stick
+  
+---
+Fri Feb  2 18:16:28 CET 2018 - dcass...@suse.com
+  
+- Fix packages file generation
+  
+  This commit checks the %_dbpath value of the image rpm tool. This is
+  needed since recent rpm versions switched the default database path,
+  thus running rpm queries to different roots might lead to errors.
+  
+  Fixes #605
+  
+---
+Thu Feb  1 14:31:31 CET 2018 - m...@suse.de
+  
+- Bump version: 9.12.6 → 9.12.7
+  
+---
+Thu Feb  1 10:29:30 CET 2018 - m...@suse.de
+  
+- Update per review by Tom
+  
+---
+Thu Feb  1 09:55:08 CET 2018 - m...@suse.de
+  
+- Update per review by David
+  
+---
+Wed Jan 31 15:43:07 CET 2018 - m...@suse.de
+  
+- Update per review by Tom
+  
+---
+Tue Jan 30 15:37:21 CET 2018 - m...@suse.de
+  
+- Added chapter for live-fat-stick deployment
+  
+  With the support for the iso-scan feature in KIWI live
+  ISO image, also the ability to deploy file based on
+  FAT32 usb sticks via the live-fat-stick tool exists.
+  This chapter describes how to do it and Fixes #521
+  
+---
+Tue Jan 30 14:35:06 CET 2018 - m...@suse.de
+  
+- Update pre review by Tom
+  
+---
+Tue Jan 30 14:29:43 CET 2018 - m...@suse.de
+  
+- Update per review by Tom
+  
+---
+Tue Jan 30 14:25:08 CET 2018 - m...@suse.de
+  
+- Update per review by Tom
+  
+---
+Tue Jan 30 14:20:45 CET 2018 - dcass...@suse.com
+  
+- Remove vmdk metadata update procedure
+  
+  This commit removes the method _update_vmdk_descriptor from
+  DiskFormatVmdk class. The code part causes vmdk format issues
+  in current up to date hipervisors such as VMWarePlayer 14 or
+  Virtualbox 5.2. Removing this code does not produce any failure,
+  at most can only imply loosing some features provided by 

commit patterns-fonts for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package patterns-fonts for openSUSE:Factory 
checked in at 2018-02-09 15:43:42

Comparing /work/SRC/openSUSE:Factory/patterns-fonts (Old)
 and  /work/SRC/openSUSE:Factory/.patterns-fonts.new (New)


Package is "patterns-fonts"

Fri Feb  9 15:43:42 2018 rev:3 rq:573231 version:20170319

Changes:

--- /work/SRC/openSUSE:Factory/patterns-fonts/patterns-fonts.changes
2017-05-20 10:06:12.811040612 +0200
+++ /work/SRC/openSUSE:Factory/.patterns-fonts.new/patterns-fonts.changes   
2018-02-09 15:43:43.871609998 +0100
@@ -1,0 +2,5 @@
+Wed Jan 24 13:07:02 UTC 2018 - pgaj...@suse.com
+
+- do not recommend liberation2-fonts, it is dead [bsc#1077375] [rh#856239]
+
+---



Other differences:
--
++ patterns-fonts.spec ++
--- /var/tmp/diff_new_pack.fbk0cn/_old  2018-02-09 15:43:44.531586303 +0100
+++ /var/tmp/diff_new_pack.fbk0cn/_new  2018-02-09 15:43:44.535586159 +0100
@@ -1,7 +1,7 @@
 #
-# spec file for package patterns-openSUSE
+# spec file for package patterns-fonts
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -29,7 +29,6 @@
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  patterns-rpm-macros
 
-
 %description
 This is an internal package that is used to create the patterns as part
 of the installation source setup.  Installation of this package does
@@ -54,7 +53,7 @@
 Recommends: google-roboto-fonts
 Recommends: dejavu-fonts
 Recommends: intlfonts-euro-bitmap-fonts
-Recommends: liberation2-fonts
+Recommends: liberation-fonts
 # needed for instsys
 Suggests:   ipa-gothic-fonts
 Suggests:   ipa-mincho-fonts




commit libpng16 for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package libpng16 for openSUSE:Factory 
checked in at 2018-02-09 15:43:21

Comparing /work/SRC/openSUSE:Factory/libpng16 (Old)
 and  /work/SRC/openSUSE:Factory/.libpng16.new (New)


Package is "libpng16"

Fri Feb  9 15:43:21 2018 rev:38 rq:573091 version:1.6.34

Changes:

--- /work/SRC/openSUSE:Factory/libpng16/libpng16.changes2018-02-01 
21:26:05.706310202 +0100
+++ /work/SRC/openSUSE:Factory/.libpng16.new/libpng16.changes   2018-02-09 
15:43:22.996359494 +0100
@@ -1,0 +2,6 @@
+Mon Feb  5 15:35:46 UTC 2018 - pgaj...@suse.com
+
+- %{libname} package provides libpng = %{version} again 
+  [bsc#1079342]
+
+---



Other differences:
--
++ libpng16.spec ++
--- /var/tmp/diff_new_pack.sw0GC0/_old  2018-02-09 15:43:23.768331777 +0100
+++ /var/tmp/diff_new_pack.sw0GC0/_new  2018-02-09 15:43:23.772331633 +0100
@@ -42,6 +42,7 @@
 %package -n %{libname}
 Summary:Library for the Portable Network Graphics Format (PNG)
 Group:  System/Libraries
+Provides:   libpng = %{version}
 
 %package devel
 Summary:Development tools for applications which will use libpng






commit python for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package python for openSUSE:Factory checked 
in at 2018-02-09 15:43:50

Comparing /work/SRC/openSUSE:Factory/python (Old)
 and  /work/SRC/openSUSE:Factory/.python.new (New)


Package is "python"

Fri Feb  9 15:43:50 2018 rev:129 rq:573233 version:2.7.14

Changes:

--- /work/SRC/openSUSE:Factory/python/python-base.changes   2018-02-05 
10:48:19.925447249 +0100
+++ /work/SRC/openSUSE:Factory/.python.new/python-base.changes  2018-02-09 
15:43:53.919249248 +0100
@@ -1,0 +2,6 @@
+Mon Feb  5 16:01:59 UTC 2018 - norm...@linux.vnet.ibm.com
+
+- exclude test_socket & test_subprocess for PowerPC boo#1078485
+  (same ref as previous change)
+
+---
python.changes: same change



Other differences:
--
++ python-base.spec ++
--- /var/tmp/diff_new_pack.rCd2R7/_old  2018-02-09 15:43:55.747183618 +0100
+++ /var/tmp/diff_new_pack.rCd2R7/_new  2018-02-09 15:43:55.751183475 +0100
@@ -239,7 +239,7 @@
 # bypass boo#1078485
 # many flaky tests if osc build in loop on ppc64le
 %ifarch ppc ppc64 ppc64le
-EXCLUDE="$EXCLUDE test_asynchat test_asyncore test_dircache 
test_multiprocessing test_nntplib test_queue test_signal test_telnetlib 
test_xmlrpc "
+EXCLUDE="$EXCLUDE test_asynchat test_asyncore test_dircache 
test_multiprocessing test_nntplib test_queue test_signal test_socket 
test_subprocess test_telnetlib test_xmlrpc "
 %endif
 
 # Limit virtual memory to avoid spurious failures

python.spec: same change





commit zypper for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package zypper for openSUSE:Factory checked 
in at 2018-02-09 15:43:13

Comparing /work/SRC/openSUSE:Factory/zypper (Old)
 and  /work/SRC/openSUSE:Factory/.zypper.new (New)


Package is "zypper"

Fri Feb  9 15:43:13 2018 rev:278 rq:572981 version:1.14.2

Changes:

--- /work/SRC/openSUSE:Factory/zypper/zypper.changes2017-12-08 
21:47:29.534800551 +0100
+++ /work/SRC/openSUSE:Factory/.zypper.new/zypper.changes   2018-02-09 
15:43:14.720656617 +0100
@@ -1,0 +2,6 @@
+Mon Feb  5 12:07:07 CET 2018 - m...@suse.de
+
+- do not recommend cron (bsc#1079334)
+- version 1.14.2
+
+---

Old:

  zypper-1.14.1.tar.bz2

New:

  zypper-1.14.2.tar.bz2



Other differences:
--
++ zypper.spec ++
--- /var/tmp/diff_new_pack.YBs1pD/_old  2018-02-09 15:43:15.432631055 +0100
+++ /var/tmp/diff_new_pack.YBs1pD/_new  2018-02-09 15:43:15.436630911 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package zypper
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -32,13 +32,13 @@
 Requires:   procps
 %if 0%{?suse_version}
 %requires_gelibzypp
-Recommends: logrotate cron zypper-log
+Recommends: logrotate zypper-log
 %endif
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Summary:Command line software manager using libzypp
 License:GPL-2.0+
 Group:  System/Packages
-Version:1.14.1
+Version:1.14.2
 Release:0
 Source: %{name}-%{version}.tar.bz2
 Source1:%{name}-rpmlintrc

++ zypper-1.14.1.tar.bz2 -> zypper-1.14.2.tar.bz2 ++
/work/SRC/openSUSE:Factory/zypper/zypper-1.14.1.tar.bz2 
/work/SRC/openSUSE:Factory/.zypper.new/zypper-1.14.2.tar.bz2 differ: char 11, 
line 1




commit libisofs for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package libisofs for openSUSE:Factory 
checked in at 2018-02-09 15:42:16

Comparing /work/SRC/openSUSE:Factory/libisofs (Old)
 and  /work/SRC/openSUSE:Factory/.libisofs.new (New)


Package is "libisofs"

Fri Feb  9 15:42:16 2018 rev:5 rq:574401 version:1.4.8

Changes:

--- /work/SRC/openSUSE:Factory/libisofs/libisofs.changes2017-02-26 
17:05:37.184998272 +0100
+++ /work/SRC/openSUSE:Factory/.libisofs.new/libisofs.changes   2018-02-09 
15:42:18.266683436 +0100
@@ -1,0 +2,23 @@
+Thu Feb  8 20:12:14 UTC 2018 - asterios.dra...@gmail.com
+
+- Update to 1.4.8:
+  * Bug fix: iso_read_opts_set_no_rockridge() did not prevent
+reading of root SUSP.
+  * Bug fix: Non-SUSP data in System Use Area prevented image
+loading if Rock Ridge was enabled.
+  * Bug fix: Protective MBR for GPT could emerge with boot flag
+set.
+  * Bug fix: Appended partitions of size >= 4 GiB led to abort with
+error message "FATAL : ISO overwrite".
+  * Bug fix: Bit 15 of iso_write_opts_set_system_area did not work
+with generic MBR.
+  * Bug fix: Keeping and patching of loaded boot images failed.
+Regression by version 1.4.4.
+  * Bug fix: Program crashes by intentionally wrong ISO image
+input. Debian bug reports: deb#872372, deb#872475, deb#872545,
+deb#872590, deb#872761.
+  * New API calls el_torito_set_full_load(),
+el_torito_get_full_load().
+  * New API call iso_write_opts_set_iso_mbr_part_type().
+
+---

Old:

  libisofs-1.4.6.tar.gz

New:

  libisofs-1.4.8.tar.gz



Other differences:
--
++ libisofs.spec ++
--- /var/tmp/diff_new_pack.CeO9j7/_old  2018-02-09 15:42:18.842662757 +0100
+++ /var/tmp/diff_new_pack.CeO9j7/_new  2018-02-09 15:42:18.842662757 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libisofs
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,22 +18,21 @@
 
 %define so_ver 6
 Name:   libisofs
-Version:1.4.6
+Version:1.4.8
 Release:0
 Summary:Library for Creating ISO-9660 Filesystems
-License:GPL-2.0+ and LGPL-2.0+
+License:GPL-2.0+ AND LGPL-2.0+
 Group:  Productivity/Multimedia/CD/Record
 Url:http://libburnia-project.org/
 Source0:
http://files.libburnia-project.org/releases/%{name}-%{version}.tar.gz
 BuildRequires:  doxygen
 BuildRequires:  fdupes
 BuildRequires:  libacl-devel
+BuildRequires:  pkgconfig
+BuildRequires:  zlib-devel
 %if 0%{?suse_version} > 1320 || (0%{?is_opensuse} && 0%{?sle_version} >= 
120300)
 BuildRequires:  libjte-devel
 %endif
-BuildRequires:  pkg-config
-BuildRequires:  zlib-devel
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 Libisofs is a library for creating ISO-9660 filesystems with extensions like
@@ -85,6 +84,9 @@
 # Remove build time references so build-compare can do its work
 echo "HTML_TIMESTAMP = NO" >> doc/doxygen.conf.in
 
+# Fix rpmlint error "spurious-executable-perm"
+chmod 644 doc/Tutorial
+
 %build
 %configure --disable-static
 make %{?_smp_mflags}
@@ -99,27 +101,24 @@
 # Remove documentation (will be added in /usr/share/doc/packages/)
 rm -rf %{buildroot}%{_datadir}/doc/%{name}-*
 
-# Install devel docs (do it manually to fix also rpmlint warning 
"files-duplicate" with %%fdupes)
+# Install devel docs
 mkdir -p %{buildroot}%{_docdir}/%{name}-devel
-install -pm 0644 AUTHORS COPYING COPYRIGHT ChangeLog NEWS README Roadmap TODO 
%{buildroot}%{_docdir}/%{name}-devel/
-install -pm 0644 
doc/{Tutorial,checksums.txt,susp_aaip_2_0.txt,susp_aaip_isofs_names.txt,zisofs_format.txt}
 %{buildroot}%{_docdir}/%{name}-devel/
 cp -a doc/html/ %{buildroot}%{_docdir}/%{name}-devel/
 
 %fdupes -s %{buildroot}%{_docdir}/%{name}-devel/
 
 %post -n libisofs%{so_ver} -p /sbin/ldconfig
-
 %postun -n libisofs%{so_ver} -p /sbin/ldconfig
 
 %files devel
-%defattr(-,root,root,-)
-%doc %{_docdir}/%{name}-devel/
+%doc AUTHORS COPYING COPYRIGHT ChangeLog NEWS README Roadmap TODO
+%doc 
doc/{Tutorial,checksums.txt,susp_aaip_2_0.txt,susp_aaip_isofs_names.txt,zisofs_format.txt}
+%doc %{_docdir}/%{name}-devel/html/
 %{_includedir}/libisofs/
 %{_libdir}/pkgconfig/libisofs-1.pc
 %{_libdir}/libisofs.so
 
 %files -n libisofs%{so_ver}
-%defattr(-,root,root,-)
 %{_libdir}/libisofs.so.%{so_ver}*
 
 %changelog

++ libisofs-1.4.6.tar.gz -> libisofs-1.4.8.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 

commit libsigsegv for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package libsigsegv for openSUSE:Factory 
checked in at 2018-02-09 15:43:05

Comparing /work/SRC/openSUSE:Factory/libsigsegv (Old)
 and  /work/SRC/openSUSE:Factory/.libsigsegv.new (New)


Package is "libsigsegv"

Fri Feb  9 15:43:05 2018 rev:7 rq:572935 version:2.12

Changes:

--- /work/SRC/openSUSE:Factory/libsigsegv/libsigsegv.changes2017-06-01 
16:28:50.048121130 +0200
+++ /work/SRC/openSUSE:Factory/.libsigsegv.new/libsigsegv.changes   
2018-02-09 15:43:09.712836412 +0100
@@ -1,0 +2,7 @@
+Thu Feb  1 20:16:44 UTC 2018 - astie...@suse.com
+
+- update to 2.12:
+  * updates for platform other than GNU/Linux
+  * Reliability improvements
+
+---

Old:

  libsigsegv-2.11.tar.gz
  libsigsegv-2.11.tar.gz.sig

New:

  libsigsegv-2.12.tar.gz
  libsigsegv-2.12.tar.gz.sig



Other differences:
--
++ libsigsegv.spec ++
--- /var/tmp/diff_new_pack.ULcELE/_old  2018-02-09 15:43:10.664802234 +0100
+++ /var/tmp/diff_new_pack.ULcELE/_new  2018-02-09 15:43:10.664802234 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libsigsegv
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -19,7 +19,7 @@
 %define somajor2
 %define lnamelibsigsegv%{somajor}
 Name:   libsigsegv
-Version:2.11
+Version:2.12
 Release:0
 Summary:Library for Handling Page Faults in User Mode
 License:GPL-2.0+
@@ -88,15 +88,12 @@
 %postun -n %{lname} -p /sbin/ldconfig
 
 %files doc
-%defattr(-,root,root)
 %doc AUTHORS COPYING ChangeLog* NEWS PORTING README
 
 %files -n %{lname}
-%defattr(-,root,root)
 %{_libdir}/libsigsegv.so.%{somajor}*
 
 %files devel
-%defattr(-,root,root)
 %{_includedir}/sigsegv.h
 %{_libdir}/libsigsegv.so
 %{_libdir}/libsigsegv.a

++ libsigsegv-2.11.tar.gz -> libsigsegv-2.12.tar.gz ++
 3671 lines of diff (skipped)





commit libburn for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package libburn for openSUSE:Factory checked 
in at 2018-02-09 15:42:08

Comparing /work/SRC/openSUSE:Factory/libburn (Old)
 and  /work/SRC/openSUSE:Factory/.libburn.new (New)


Package is "libburn"

Fri Feb  9 15:42:08 2018 rev:4 rq:574400 version:1.4.8

Changes:

--- /work/SRC/openSUSE:Factory/libburn/libburn.changes  2017-02-03 
17:47:09.384402294 +0100
+++ /work/SRC/openSUSE:Factory/.libburn.new/libburn.changes 2018-02-09 
15:42:09.423000934 +0100
@@ -1,0 +2,10 @@
+Thu Feb  8 20:25:18 UTC 2018 - asterios.dra...@gmail.com
+
+- Update to 1.4.8:
+  * Bug fix: Option -dummy did not affect writing by
+direct_write_amount=
+  * New API call burn_drive_reset_simulate()
+  * New API call burn_drive_get_bd_r_pow()
+  * Refusing to write to BD-R if formatted to Pseudo Overwrite
+
+---

Old:

  libburn-1.4.6.tar.gz

New:

  libburn-1.4.8.tar.gz



Other differences:
--
++ libburn.spec ++
--- /var/tmp/diff_new_pack.idXtCy/_old  2018-02-09 15:42:10.074977528 +0100
+++ /var/tmp/diff_new_pack.idXtCy/_new  2018-02-09 15:42:10.078977384 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libburn
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,7 +18,7 @@
 
 %define so_ver 4
 Name:   libburn
-Version:1.4.6
+Version:1.4.8
 Release:0
 Summary:Library for Writing Preformatted Data onto Optical Media
 License:GPL-2.0+
@@ -27,8 +27,7 @@
 Source0:
http://files.libburnia-project.org/releases/%{name}-%{version}.tar.gz
 BuildRequires:  doxygen
 BuildRequires:  fdupes
-BuildRequires:  pkg-config
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+BuildRequires:  pkgconfig
 
 %description
 Libburn is a library for writing preformatted data onto optical media such as
@@ -74,34 +73,30 @@
 # Remove libtool config files
 find %{buildroot} -type f -name "*.la" -delete -print
 
-# Install devel docs (do it manually to fix also rpmlint warning 
"files-duplicate" with %%fdupes)
+# Install devel docs
 mkdir -p %{buildroot}%{_docdir}/%{name}-devel
-install -pm 0644 AUTHORS CONTRIBUTORS COPYING COPYRIGHT ChangeLog README 
%{buildroot}%{_docdir}/%{name}-devel/
-install -pm 0644 doc/{cdtext.txt,cookbook.txt,mediainfo.txt} 
%{buildroot}%{_docdir}/%{name}-devel/
 cp -a doc/html/ %{buildroot}%{_docdir}/%{name}-devel/
 
 %fdupes -s %{buildroot}%{_docdir}/%{name}-devel/
 
 %post -n libburn%{so_ver} -p /sbin/ldconfig
-
 %postun -n libburn%{so_ver} -p /sbin/ldconfig
 
 %files devel
-%defattr(-,root,root,-)
-%doc %{_docdir}/%{name}-devel/
+%doc AUTHORS CONTRIBUTORS COPYING COPYRIGHT ChangeLog README
+%doc doc/{cdtext.txt,cookbook.txt,mediainfo.txt}
+%doc %{_docdir}/%{name}-devel/html/
 %{_includedir}/libburn/
 %{_libdir}/pkgconfig/libburn-1.pc
 %{_libdir}/libburn.so
 
 %files -n cdrskin
-%defattr(-,root,root,-)
 %doc COPYING COPYRIGHT
 %doc cdrskin/{README,cdrskin_eng.html,changelog.txt,wiki_plain.txt}
 %{_bindir}/cdrskin
 %{_mandir}/man1/cdrskin.1*
 
 %files -n libburn%{so_ver}
-%defattr(-,root,root,-)
 %{_libdir}/libburn.so.%{so_ver}*
 
 %changelog

++ libburn-1.4.6.tar.gz -> libburn-1.4.8.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libburn-1.4.6/COPYRIGHT new/libburn-1.4.8/COPYRIGHT
--- old/libburn-1.4.6/COPYRIGHT 2016-09-16 12:48:51.0 +0200
+++ new/libburn-1.4.8/COPYRIGHT 2017-01-27 12:04:44.0 +0100
@@ -1,7 +1,7 @@
 Derek Foreman  and Ben Jansens 
 Copyright (C) 2002-2006  Derek Foreman and Ben Jansens
 Mario Danic , Thomas Schmitt 
-Copyright (C) 2006-2014 Mario Danic, Thomas Schmitt
+Copyright (C) 2006-2017 Mario Danic, Thomas Schmitt
 
 
 This program is free software; you can redistribute it and/or modify
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libburn-1.4.6/ChangeLog new/libburn-1.4.8/ChangeLog
--- old/libburn-1.4.6/ChangeLog 2016-09-16 14:14:24.0 +0200
+++ new/libburn-1.4.8/ChangeLog 2017-09-12 13:39:09.0 +0200
@@ -1,8 +1,15 @@
+libburn-1.4.8.tar.gz Tue Sep 12 2017
+===
+* Bug fix: Option -dummy did not affect writing by direct_write_amount=
+* New API call burn_drive_reset_simulate()
+* New API call burn_drive_get_bd_r_pow()
+* Refusing to write to BD-R if formatted 

commit util-linux for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package util-linux for openSUSE:Factory 
checked in at 2018-02-09 15:41:15

Comparing /work/SRC/openSUSE:Factory/util-linux (Old)
 and  /work/SRC/openSUSE:Factory/.util-linux.new (New)


Package is "util-linux"

Fri Feb  9 15:41:15 2018 rev:225 rq:571531 version:2.31.1

Changes:

--- /work/SRC/openSUSE:Factory/util-linux/python-libmount.changes   
2018-01-26 13:33:45.661376327 +0100
+++ /work/SRC/openSUSE:Factory/.util-linux.new/python-libmount.changes  
2018-02-09 15:41:16.832888933 +0100
@@ -1,0 +2,21 @@
+Wed Jan 31 20:34:56 CET 2018 - sbra...@suse.com
+
+- Update to version 2.31.1:
+  * blkid: Add support for LUKS2 and new LABEL attributes.
+  * move rfkill to /usr/sbin (boo#1076134).
+  * fsck.cramfs: Fix bus error on broken file system.
+  * hwclock: add iso-8601 overflow check
+  * libmount:
+* Allow MNT_FORCE and MNT_DETACH at umount
+* add nsfs between pseudo filesystems
+  * lscpu: Treat read failure on Xen Hypervisor properties as
+non-fatal
+  * sha1: endian fixes (affects util_linux_bigendian.patch)
+  * documentation updates
+  * other fixes and improvements
+- Fix regressions in 2.31.1:
+  * sha1 on s390* (update util_linux_bigendian.patch)
+  * fsck.cramfs on ppc64le (util-linux-cramfs.patch)
+  * fincore/count (disable, util-linux-fincore-count.patch)
+
+---
util-linux-systemd.changes: same change
util-linux.changes: same change

Old:

  util-linux-2.31.tar.sign
  util-linux-2.31.tar.xz

New:

  util-linux-2.31.1.tar.sign
  util-linux-2.31.1.tar.xz
  util-linux-cramfs.patch
  util-linux-fincore-count.patch



Other differences:
--
++ python-libmount.spec ++
--- /var/tmp/diff_new_pack.grcn1P/_old  2018-02-09 15:41:18.448830922 +0100
+++ /var/tmp/diff_new_pack.grcn1P/_new  2018-02-09 15:41:18.452830778 +0100
@@ -73,7 +73,7 @@
 %endif
 Summary:%main_summary
 License:GPL-2.0+
-Group:  %group_pl
+Group:  %main_group
 BuildRequires:  audit-devel
 BuildRequires:  bc
 BuildRequires:  binutils-devel
@@ -116,7 +116,7 @@
 %endif
 %endif
 #END SECOND STAGE DEPENDENCIES
-Version:2.31
+Version:2.31.1
 Release:0
 # util-linux is a base package and uuidd pre-requiring pwdutils pulls
 # that into the core build cycle.  pwdutils also pulls in the whole
@@ -125,7 +125,7 @@
 # these tools as well
 #!BuildIgnore:  pwdutils
 Url:https://www.kernel.org/pub/linux/utils/util-linux/
-Source: 
https://www.kernel.org/pub/linux/utils/util-linux/v%{version}/util-linux-%{version}.tar.xz
+Source: 
https://www.kernel.org/pub/linux/utils/util-linux/v2.31/util-linux-%{version}.tar.xz
 Source1:util-linux-rpmlintrc
 Source4:raw.service
 Source5:etc.raw
@@ -135,7 +135,7 @@
 Source9:remote.pamd
 Source10:   su.pamd
 Source11:   su.default
-Source12:   
https://www.kernel.org/pub/linux/utils/util-linux/v%{version}/util-linux-%{version}.tar.sign
+Source12:   
https://www.kernel.org/pub/linux/utils/util-linux/v2.31/util-linux-%{version}.tar.sign
 Source13:   %{_name}.keyring
 Source14:   runuser.pamd
 # klogconsole, http://opensuse.github.com/kiwi, 7.02.25, git 859dc050
@@ -166,6 +166,10 @@
 Patch3: util-linux-lsmem-memory-zone-3.patch
 # Add four commits from upstream to pass tests on ppc64
 Patch4: util_linux_bigendian.patch
+# PATCH-FIX-UPSTREAM util-linux-cramfs.patch sbra...@suse.com -- Fix 
fsck.cramfs failure on ppc64le.
+Patch5: util-linux-cramfs.patch
+# PATCH-FIX-UPSTREAM util-linux-fincore-count.patch sbra...@suse.com -- 
Disable bad test fincore/count.
+Patch6: util-linux-fincore-count.patch
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 #
@@ -390,7 +394,6 @@
 %if %build_util_linux
 %package -n python-libmount
 Summary:%summary_pl
-License:GPL-2.0+
 Group:  %group_pl
 
 %description -n python-libmount
@@ -408,6 +411,8 @@
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
+%patch6 -p1
 #
 # setctsid
 cp -p %{S:22} %{S:23} .
@@ -645,7 +650,6 @@
 popd
 install -Dm644 %{SOURCE41} %{buildroot}%{_unitdir}/rfkill-block@.service
 install -Dm644 %{SOURCE42} %{buildroot}%{_unitdir}/rfkill-unblock@.service
-ln -s "../bin/rfkill" %{buildroot}%{_sbindir}/rfkill
 %endif
 #
 # util-linux install
@@ -985,8 +989,6 @@
 %{_bindir}/rename
 %{_bindir}/renice
 %{_bindir}/rev
-%{_bindir}/rfkill
-%{_sbindir}/rfkill
 %{_bindir}/script
 %{_bindir}/scriptreplay
 %{_bindir}/setarch
@@ -1037,6 +1039,7 @@
 %{_sbindir}/raw
 %{_sbindir}/rcraw
 %{_sbindir}/resizepart
+%{_sbindir}/rfkill
 %{_sbindir}/rtcwake
 %{_sbindir}/runuser
 %{_sbindir}/setctsid

++ 

commit libunwind for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package libunwind for openSUSE:Factory 
checked in at 2018-02-09 15:41:38

Comparing /work/SRC/openSUSE:Factory/libunwind (Old)
 and  /work/SRC/openSUSE:Factory/.libunwind.new (New)


Package is "libunwind"

Fri Feb  9 15:41:38 2018 rev:37 rq:572004 version:1.2.1

Changes:

--- /work/SRC/openSUSE:Factory/libunwind/libunwind.changes  2016-07-09 
09:17:45.0 +0200
+++ /work/SRC/openSUSE:Factory/.libunwind.new/libunwind.changes 2018-02-09 
15:41:40.996021481 +0100
@@ -1,0 +2,14 @@
+Fri Feb  2 11:52:05 UTC 2018 - tchva...@suse.com
+
+- Update keyring
+
+---
+Wed Jan 24 04:05:11 UTC 2018 - avin...@opensuse.org
+
+- Upgrade to 1.2.1
+  * minor package fixes for tilegx, mips, others
+  * fix missing include file issues
+- cleanup with spec-cleaner
+- do not ship static libraries
+
+---

Old:

  libunwind-1.2-rc1.tar.gz
  libunwind-1.2-rc1.tar.gz.sig

New:

  libunwind-1.2.1.tar.gz
  libunwind-1.2.1.tar.gz.sig



Other differences:
--
++ libunwind.spec ++
--- /var/tmp/diff_new_pack.SyAWFW/_old  2018-02-09 15:41:41.807992331 +0100
+++ /var/tmp/diff_new_pack.SyAWFW/_new  2018-02-09 15:41:41.811992187 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libunwind
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,23 +16,22 @@
 #
 
 
-%define realver 1.2-rc1
+%define realver 1.2.1
 Name:   libunwind
-Version:1.2~rc1
+Version:1.2.1
 Release:0
 Summary:Unwind Library
 License:MIT
 Group:  System/Base
 Url:http://savannah.nongnu.org/projects/libunwind/
-Source0:
http://download.savannah.gnu.org/releases/libunwind/libunwind-%{realver}.tar.gz
-Source1:
http://download.savannah.gnu.org/releases/libunwind/libunwind-%{realver}.tar.gz.sig
+Source0:
http://download.savannah.gnu.org/releases/%{name}/%{name}-%{realver}.tar.gz
+Source1:
http://download.savannah.gnu.org/releases/%{name}/%{name}-%{realver}.tar.gz.sig
 Source2:%{name}.keyring
 Source3:baselibs.conf
 BuildRequires:  gcc-c++
 BuildRequires:  lzma-devel
 BuildRequires:  pkgconfig
 BuildRequires:  pkgconfig(atomic_ops)
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 ExclusiveArch:  %{ix86} ia64 x86_64 %{arm} ppc ppc64 ppc64le aarch64
 
 %description
@@ -63,21 +62,18 @@
 %endif
 
 %install
-make %{?_smp_mflags} DESTDIR=%{buildroot} install
-find %{buildroot} -type f -name "*.la" -delete -print
+%make_install
+find %{buildroot} -iregex '.*\.l?a$' -delete -print
 
 %post -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
 %files
-%defattr(-, root, root)
 %{_libdir}/lib*.so.*
 
 %files devel
-%defattr(-, root, root)
 %{_includedir}/*
-%{_libdir}/libunwind*.a
-%{_libdir}/libunwind*.so
-%{_libdir}/pkgconfig/libunwind*.pc
+%{_libdir}/%{name}*.so
+%{_libdir}/pkgconfig/%{name}*.pc
 
 %changelog

++ libunwind-1.2-rc1.tar.gz -> libunwind-1.2.1.tar.gz ++
 3 lines of diff (skipped)

++ libunwind.keyring ++
--- /var/tmp/diff_new_pack.SyAWFW/_old  2018-02-09 15:41:42.247976535 +0100
+++ /var/tmp/diff_new_pack.SyAWFW/_new  2018-02-09 15:41:42.247976535 +0100
@@ -1,5 +1,15 @@
+pub   rsa2048 2012-05-09 [SC]
+  5C96BDEAF5F47FB02BD4F6B965D98560914F3F48
+uid   [ unknown] Arun Sharma 
+uid   [ unknown] Arun Sharma 
+sub   rsa2048 2012-05-09 [E]
+
+pub   rsa4096 2017-01-06 [SC] [expires: 2021-01-06]
+  1675C8DA2EF907FB116EB709EC52B396E6874AF2
+uid   [ unknown] Dave Watson 
+sub   rsa4096 2017-01-06 [E] [expires: 2021-01-06]
+
 -BEGIN PGP PUBLIC KEY BLOCK-
-Version: GnuPG v2
 
 mQENBE+p9PIBCADThJtMfDqEv862ks3xPS5yyvPxNdab8o37yuUOsajvED09O3RV
 s3+aJVmLQMBp5qUxwyqO4FSgoRiGx/PoWKOLMo62xfpWIGWKlmC6t0aKuAZwf+cr
@@ -32,6 +42,53 @@
 USWxlvo05cvLhzCsPdcLwrsyyofAi5XBQTuLTmGJn0xHfsFRQxSDk3HrSEWZi5wr
 6C1aITcZfPxUQZfRXGw0LO+qpEhqGpAJCZGBNjxaJ49M6Vq/e/fiCaYa5Lvu1Xev
 T0X1wek3JAlCWe0GLoCjJcY7Xo8ozvV5zxFIo8qVzwMTKD1PfgdGH/nOItNVrRMq
-xpQkwtukj/bXrq3Jk3B3Vxy8ZN0obbIr+EtW2qhFPciXEuR/9n78zgojUy4q6g==
-=f57A
+xpQkwtukj/bXrq3Jk3B3Vxy8ZN0obbIr+EtW2qhFPciXEuR/9n78zgojUy4q6pkC
+DQRYcCeYARAA0tXH11cyJKvFbZmWcir3onQ/PrC388+bBqsjmwTELRzVpco5C5+U
+aaWEGBgUEArutctRaOL8KPb7mn2Bup5KM63YYXT8hxZMdpBsbyngxKFeDTt/6s9y
+JnixOFav2Wi04YCk89aosb4zyEbmHTIDdI4dr0vi0dqw4HpozT7Z0slqwU9Wtgxo

commit isl for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package isl for openSUSE:Factory checked in 
at 2018-02-09 15:41:06

Comparing /work/SRC/openSUSE:Factory/isl (Old)
 and  /work/SRC/openSUSE:Factory/.isl.new (New)


Package is "isl"

Fri Feb  9 15:41:06 2018 rev:14 rq:571371 version:0.18

Changes:

--- /work/SRC/openSUSE:Factory/isl/isl.changes  2017-02-05 18:35:30.214062349 
+0100
+++ /work/SRC/openSUSE:Factory/.isl.new/isl.changes 2018-02-09 
15:41:07.277231975 +0100
@@ -1,0 +2,11 @@
+Wed Jan 31 12:50:45 UTC 2018 - jeng...@inai.de
+
+- Set shared library RPM group. Use %make_install.
+
+---
+Mon Jan 29 14:43:34 UTC 2018 - m...@suse.com
+
+- Include pkgconfig files in isl-devel package.
+- Do not build static libraries (instead of deleting them after).
+
+---



Other differences:
--
++ isl.spec ++
--- /var/tmp/diff_new_pack.pJetmL/_old  2018-02-09 15:41:08.021205267 +0100
+++ /var/tmp/diff_new_pack.pJetmL/_new  2018-02-09 15:41:08.025205123 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package isl
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -27,6 +27,7 @@
 Source: http://isl.gforge.inria.fr/isl-%{version}.tar.xz
 Source1:baselibs.conf
 BuildRequires:  gmp-devel
+BuildRequires:  pkgconfig
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -44,27 +45,28 @@
 
 %package -n libisl%{islsover}
 Summary:The ISL shared library
-Group:  Development/Languages/C and C++
+Group:  System/Libraries
 
 %description -n libisl%{islsover}
 The shared library for the ISL.
 
+ISL is a library for manipulating sets and relations of integer points
+bounded by linear constraints.
+
 %prep
 %setup -q
 
 %build
-%configure
+%configure --disable-static
 make %{?_smp_mflags} V=1
 
 %check
 make %{?_smp_mflags} check
 
 %install
-make DESTDIR=%{buildroot} install %{?_smp_mflags}
+%make_install
 rm -f  %{buildroot}%{_libdir}/*.la
-rm -rf %{buildroot}%{_libdir}/pkgconfig
 rm -f  %{buildroot}%{_libdir}/libisl.so.*-gdb.py
-rm -f  %{buildroot}%{_libdir}/libisl.a
 
 %post -n libisl%{islsover} -p /sbin/ldconfig
 %postun -n libisl%{islsover} -p /sbin/ldconfig
@@ -77,5 +79,6 @@
 %defattr(-,root,root,-)
 %{_includedir}/isl
 %{_libdir}/libisl.so
+%{_libdir}/pkgconfig/%{name}.pc
 
 %changelog




commit libatomic_ops for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package libatomic_ops for openSUSE:Factory 
checked in at 2018-02-09 15:40:56

Comparing /work/SRC/openSUSE:Factory/libatomic_ops (Old)
 and  /work/SRC/openSUSE:Factory/.libatomic_ops.new (New)


Package is "libatomic_ops"

Fri Feb  9 15:40:56 2018 rev:10 rq:571364 version:7.6.2

Changes:

--- /work/SRC/openSUSE:Factory/libatomic_ops/libatomic_ops.changes  
2016-04-14 12:59:29.0 +0200
+++ /work/SRC/openSUSE:Factory/.libatomic_ops.new/libatomic_ops.changes 
2018-02-09 15:40:59.169523034 +0100
@@ -1,0 +2,28 @@
+Mon Jan 29 11:04:41 UTC 2018 - jeng...@inai.de
+
+- Update to new upstream release 7.6.2
+  * Fix GCC 5.x compatibility for AArch64 double-wide primitives
+  * Implement fetch-CAS for s390[x] (gcc)
+  * Support n32 ABI for mips64
+  * Use LLD and SCD instructions on mips64
+  * Use generalized double-wide load/store if
+AO_PREFER_GENERALIZED (gcc/x86)
+  * Use GCC atomic intrinsics for PowerPC 32/64 (GCC 4.8+ and
+clang 3.8+)
+  * Use GCC atomic intrinsics for x86, x64, ARM, MIPS (gcc 4.9+,
+clang 3.5+)
+  * Relax shareability domain for dmb st in AO_nop_write
+(ARM/AArch64)
+  * Implement AO_CLEAR using C11 atomic intrinsic (GCC)
+  * Implement CAS_acquire/release/full using
+__atomic_compare_exchange_n (gcc)
+  * Implement compiler_barrier using C11 __atomic_signal_fence
+(GCC)
+  * Add initial nios2 architecture support
+  * Add asm-based and/or/xor implementation for char/short/int
+(gcc/x86)
+  * Add asm-based char/short/int CAS implementation for
+gcc/x86[_64]
+- Remove aarch64-gcc5.patch (no longer applies)
+
+---

Old:

  aarch64-gcc5.patch
  libatomic_ops-7.4.2.tar.gz

New:

  libatomic_ops-7.6.2.tar.gz



Other differences:
--
++ libatomic_ops.spec ++
--- /var/tmp/diff_new_pack.bhtequ/_old  2018-02-09 15:40:59.913496326 +0100
+++ /var/tmp/diff_new_pack.bhtequ/_new  2018-02-09 15:40:59.913496326 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libatomic_ops
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   libatomic_ops
-Version:7.4.2
+Version:7.6.2
 Release:0
 Summary:A portable library for atomic memory operations
 License:GPL-2.0+ and MIT
@@ -26,13 +26,11 @@
 
 #Git-Clone:git://github.com/ivmai/libatomic_ops
 Source: http://www.ivmaisoft.com/_bin/atomic_ops/%name-%version.tar.gz
-Patch2: libatomic_ops-ppc64.patch
-Patch3: aarch64-gcc5.patch
+Patch1: libatomic_ops-ppc64.patch
 BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  libtool
 BuildRequires:  pkg-config
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 Provides implementations for atomic memory update operations on a
@@ -44,8 +42,8 @@
 %package devel
 Summary:A portable library for atomic memory operations
 Group:  Development/Languages/C and C++
-Obsoletes:  libatomic-ops-devel < %{version}-%{release}
-Provides:   libatomic-ops-devel = %{version}-%{release}
+Obsoletes:  libatomic-ops-devel < %version-%release
+Provides:   libatomic-ops-devel = %version-%release
 
 %description devel
 Provides implementations for atomic memory update operations on a
@@ -56,19 +54,17 @@
 
 %prep
 %setup -q
-%patch2 -p1
-%patch3 -p1
+%patch -P 1 -p1
 
 %build
-autoreconf -fvi
-%configure
+autoreconf -fiv
+%configure --docdir="%_docdir/%name"
 make %{?_smp_mflags}
 
 %install
 %make_install
 rm -f "%buildroot/%_libdir"/*.la
-# remove unnecessary documents
-rm -Rf "%{buildroot}/%{_datadir}/libatomic_ops"
+cp -a ChangeLog "%buildroot/%_docdir/%name/"
 
 %check
 %if !0%{?qemu_user_space_build:1}
@@ -77,11 +73,10 @@
 
 %files devel
 %defattr(-,root,root)
-%doc README.md COPYING AUTHORS ChangeLog
-%doc doc/*.txt
-%{_libdir}/libatomic_ops*.a
-%{_includedir}/atomic_ops/
-%{_includedir}/atomic_ops*.h
-%{_libdir}/pkgconfig/atomic_ops.pc
+%_libdir/libatomic_ops*.a
+%_includedir/atomic_ops/
+%_includedir/atomic_ops*.h
+%_libdir/pkgconfig/atomic_ops.pc
+%_docdir/%name/
 
 %changelog

++ libatomic_ops-7.4.2.tar.gz -> libatomic_ops-7.6.2.tar.gz ++
 21272 lines of diff (skipped)