Re: [OpenWrt-Devel] [PATCH] Give WiFi modules more time to settle

2015-05-15 Thread Rafał Miłecki
On 15 May 2015 at 09:02, Arend van Spriel ar...@broadcom.com wrote:
 On 05/12/15 12:25, Hante Meuleman wrote:

 It is a bit more than just changing request_firmware_nowait into
 request_firmware. The worker in core.c needs to be removed. The
 function brcmf_pcie_setup needs to be updated as it cannot call
 device_release_driver during probe. As a result
 brcmf_fw_get_firmwares_pcie has to return the error, which means
 the api for brcmf_fw_get_firmwares_pcie will change, that will
 mean usb and sdio needs to patched as well. So it isn't going to be
 a small patch, but it can be done. I just wonder if it is worth the
 effort.
 The patch needs to be maintained as well.


 I think it kinda sucks that a driver is restricted to use a kernel API
 because of some user-space app behaviour.

I agree.


 Is the app detecting the wiphy instances dynamically (through
 /sys/class/ieee80211?) or does it have some expectation of the number of
 available wiphy instances. On the first run with OpenWRT it probably can not
 have such expectation so is that what we are trying to deal with here?

I pointed you to the responsible files.

1) /etc/init.d/boot
http://git.openwrt.org/?p=openwrt.git;a=blob;f=package/base-files/files/etc/init.d/boot;hb=HEAD
As you already noticed, it calls wifi detect

2) /sbin/wifi
http://git.openwrt.org/?p=openwrt.git;a=blob;f=package/base-files/files/sbin/wifi;hb=HEAD
It calls driver specific (e.g. mac80211 which is really a cfg80211)
function to detect wifi.

3) /lib/wifi/mac80211.sh
http://git.openwrt.org/?p=openwrt.git;a=blob;f=package/kernel/mac80211/files/lib/wifi/mac80211.sh;hb=HEAD
It implements detect_mac80211 which uses /sys/class/ieee80211/ and
generates wifi config
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH] Give WiFi modules more time to settle

2015-05-15 Thread Arend van Spriel

On 05/12/15 12:25, Hante Meuleman wrote:

It is a bit more than just changing request_firmware_nowait into
request_firmware. The worker in core.c needs to be removed. The
function brcmf_pcie_setup needs to be updated as it cannot call
device_release_driver during probe. As a result
brcmf_fw_get_firmwares_pcie has to return the error, which means
the api for brcmf_fw_get_firmwares_pcie will change, that will
mean usb and sdio needs to patched as well. So it isn't going to be
a small patch, but it can be done. I just wonder if it is worth the effort.
The patch needs to be maintained as well.


I think it kinda sucks that a driver is restricted to use a kernel API 
because of some user-space app behaviour. So can we dive a bit deeper 
into that. Is the app detecting the wiphy instances dynamically (through 
/sys/class/ieee80211?) or does it have some expectation of the number of 
available wiphy instances. On the first run with OpenWRT it probably can 
not have such expectation so is that what we are trying to deal with here?


Regards,
Arend


-Original Message-
From: Felix Fietkau [mailto:n...@openwrt.org]

On 2015-05-12 11:33, Hante Meuleman wrote:

Understood, what is wifi detect using as input? Do the netdevs have to
be up? Where is the information that wifi app is reading coming from?

It looks for registered cfg80211 wiphys. It does not care about netdevs.


brcmfmac uses different method for firmware loading. It is not as
easily patched as the ath10k driver. But I would like to know exactly
what wifi detect uses as input. As in case of brcmfmac I expect that
firmware loading will not be the only asynchronous problem.

It should be enough to rework the request_firmware_nowait calls into
request_firmware calls.


What would be easy is adding a delay of 2 seconds to the function
brcmfmac_module_init in core.c, but that won't guarantee it will work.

Still seems more fragile and hackish.

- Felix
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH] bcm53xx: Add functions to get/release copies of nvram contents.

2015-05-15 Thread Rafał Miłecki
On 12 May 2015 at 19:31, Rafał Miłecki zaj...@gmail.com wrote:
 On 12 May 2015 at 15:10, Hante Meuleman meule...@broadcom.com wrote:
 Added two functions to the bcm47xx_nvram module to get and release copies
 of the complete nvram contents. This can be used by for example brcmfmac
 to get complete nvram contents which will after some parsing be sent to
 device.

 2) You modify OpenWrt's copy of mainline driver code. I'm pretty sure
 I explained it to you. I don't want these driver to start differ
 again. I want to submit all change to mainline version and just copy
 most recent version to bcm53xx. So instead of this patch against
 OpenWrt's copy, please send a patch against mainline's nvram.c in the
 first place.

Hante, can I expect you to provide appropriate against MIPS upstream-sft tree?
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] External (public) IP forwarded to internal LAN [SOLVED]

2015-05-15 Thread Angelo Corsaro


Hi Lars,
following your directions I played with the buttons, options but I 
haven't found the solution.
I left the checkbutton MASQUERADE only for the internal lan, but always 
I haven't the right  behaviour.


On 15/05/2015 00:45, openwrt-devel-requ...@lists.openwrt.org wrote:

Here is the lan postrouting taken from the above:

Chain zone_lan_postrouting (1 references)
  pkts bytes target prot opt in out source destination
12 860  postrouting_lan_rule  all  --  * * 0.0.0.0/0 0.0.0.0/0
12 860  MASQUERADEall  --  * * 0.0.0.0/0 0.0.0.0/0

The last line should be the problem: every packet heading for the lan zone
(e.g. your webserver) will be masqueraded (SNAT).
Maybe you enabled the masquerading checkbox in the firewall config for this
interface?

The content of /etc/config/firewall would probably show the root cause (in case
my above guess is wrong).

cheers,
lars




Checking another firewall script, I found an interesting rule:

Chain POSTROUTING (policy ACCEPT 98070 packets, 12M bytes)
 pkts bytes target prot opt in out source destination
 215K   17M MASQUERADE  all  --  * *eth1* 0.0.0.0/00.0.0.0/0

so all address are masquerade only for the destination eth1.

So I issued
iptables -t nat -D zone_lan_postrouting -j MASQUERADE
iptables -t nat -A zone_lan_postrouting -j MASQUERADE -o pppoa-wan

and my webserver is logging the source address.

Doest this is an error or normal behaviour  of fw3 ?

Cheers
Angelo

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] WAN dhcp client doesnt recognize unplugged cable and doesnt request new IP on replugged

2015-05-15 Thread Hans Dedecker
On Thu, May 14, 2015 at 10:45 PM, Jakub Jančo kub...@gmail.com wrote:
 No I havent, I thought it is Bring on boot but it is another option. So my
 problem persist.
 config interface 'wan'
 option ifname 'eth0'
 option proto 'dhcp'
 option metric '1'

 config interface 'wan6'
 option ifname '@wan'
 option proto 'dhcpv6'

 This is my wan config, and after turn off and on lan port on remote site, no
 logs entries.
netifd relies on events from the kernel to detect link changes; when
the cable is unplugged the NO_CARRIER flag of eth0 needs to be set
which can be checked via the ip utility (ip link show) or ifconfig
(RUNNING flag not set in this case). Further the cmd ubus call
network.device status dumps the netifd status of the devices
(including the link state).

Hans


 2015-05-14 22:29 GMT+02:00 Hans Dedecker dedec...@gmail.com:

 On Thu, May 14, 2015 at 8:23 PM, Jakub Jančo kub...@gmail.com wrote:
  Thank you for explanation.
 
  Why does openwrt use force_link on WAN, when it can break internet
  connection and remote access?
  Or what are advantages of force_link?
 I don't see any added value of using force_link on a WAN interface
 unless you would use a static IP address.
 You verified force_link is enabled on the WAN interface for your board ?

 Hans
 
  Thanks.
 
 
  --
  S pozdravom Jakub Janco
 
  2015-05-14 17:32 GMT+02:00 Hans Dedecker dedec...@gmail.com:
 
  On Wed, May 13, 2015 at 12:35 PM, Conor O'Gorman i...@conorogorman.net
  wrote:
   On 12/05/15 17:57, Jakub Jančo wrote:
  
   Hello,
  
   I have tplink 1043nd with BB
  
   Problem is that I have dhcp client on WAN and if I unplug cable from
   WAN, it doesnt change status, give up dhcp address.
  
   Even worse is that if I plug cable with another end point with
   another
   network, WAN dhcp client doesnt  pull new IP, I must click on
   Connect
   to refresh dhcp client, then new ip is assigned and internet works.
   Or
   restart device.
  
  
   Have a look at ifpugd.
  
   But maybe netifd should/could/might do something for this scenario?
  
   Conor
   ___
   openwrt-devel mailing list
   openwrt-devel@lists.openwrt.org
   https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
  netifd has support for link state changes; the network interface will
  be brought up/down
  if the link is active/inactive. However if the force_link parameter is
  enabled for a network
  interface netifd will ignore link state changes.
 
  Hans
  ___
  openwrt-devel mailing list
  openwrt-devel@lists.openwrt.org
  https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
 
 


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] WAN dhcp client doesnt recognize unplugged cable and doesnt request new IP on replugged

2015-05-15 Thread Jakub Jančo
Hello,
After I unplug cable:

ifconfig
eth0  Link encap:Ethernet  HWaddr 14:CC:20:4D:3D:B5
  inet addr:10.1.5.246  Bcast:10.1.5.255  Mask:255.255.255.0
  inet6 addr: fe80::16cc:20ff:fe4d:3db5/64 Scope:Link
  UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
  RX packets:747 errors:0 dropped:0 overruns:0 frame:0
  TX packets:896 errors:0 dropped:0 overruns:0 carrier:0
  collisions:0 txqueuelen:1000
  RX bytes:84708 (82.7 KiB)  TX bytes:487679 (476.2 KiB)
  Interrupt:4

ip link
2: eth0: BROADCAST,MULTICAST,UP,LOWER_UP mtu 1500 qdisc fq_codel state UP
mode DEFAULT group default qlen 1000
link/ether 14:cc:20:4d:3d:b5 brd ff:ff:ff:ff:ff:ff

After plug in cable, no change, no logs.

ModelTP-Link TL-WR1043N/ND v2 Firmware Version OpenWrt Barrier Breaker
14.07 / LuCI Trunk (svn-r10472) Kernel Version3.10.49



--
S pozdravom Jakub Janco

2015-05-15 9:34 GMT+02:00 Hans Dedecker dedec...@gmail.com:

 On Thu, May 14, 2015 at 10:45 PM, Jakub Jančo kub...@gmail.com wrote:
  No I havent, I thought it is Bring on boot but it is another option.
 So my
  problem persist.
  config interface 'wan'
  option ifname 'eth0'
  option proto 'dhcp'
  option metric '1'
 
  config interface 'wan6'
  option ifname '@wan'
  option proto 'dhcpv6'
 
  This is my wan config, and after turn off and on lan port on remote
 site, no
  logs entries.
 netifd relies on events from the kernel to detect link changes; when
 the cable is unplugged the NO_CARRIER flag of eth0 needs to be set
 which can be checked via the ip utility (ip link show) or ifconfig
 (RUNNING flag not set in this case). Further the cmd ubus call
 network.device status dumps the netifd status of the devices
 (including the link state).

 Hans
 
 
  2015-05-14 22:29 GMT+02:00 Hans Dedecker dedec...@gmail.com:
 
  On Thu, May 14, 2015 at 8:23 PM, Jakub Jančo kub...@gmail.com wrote:
   Thank you for explanation.
  
   Why does openwrt use force_link on WAN, when it can break internet
   connection and remote access?
   Or what are advantages of force_link?
  I don't see any added value of using force_link on a WAN interface
  unless you would use a static IP address.
  You verified force_link is enabled on the WAN interface for your board ?
 
  Hans
  
   Thanks.
  
  
   --
   S pozdravom Jakub Janco
  
   2015-05-14 17:32 GMT+02:00 Hans Dedecker dedec...@gmail.com:
  
   On Wed, May 13, 2015 at 12:35 PM, Conor O'Gorman i...@conorogorman.net
 
   wrote:
On 12/05/15 17:57, Jakub Jančo wrote:
   
Hello,
   
I have tplink 1043nd with BB
   
Problem is that I have dhcp client on WAN and if I unplug cable
 from
WAN, it doesnt change status, give up dhcp address.
   
Even worse is that if I plug cable with another end point with
another
network, WAN dhcp client doesnt  pull new IP, I must click on
Connect
to refresh dhcp client, then new ip is assigned and internet
 works.
Or
restart device.
   
   
Have a look at ifpugd.
   
But maybe netifd should/could/might do something for this scenario?
   
Conor
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
   netifd has support for link state changes; the network interface will
   be brought up/down
   if the link is active/inactive. However if the force_link parameter
 is
   enabled for a network
   interface netifd will ignore link state changes.
  
   Hans
   ___
   openwrt-devel mailing list
   openwrt-devel@lists.openwrt.org
   https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
  
  
 
 

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] WAN dhcp client doesnt recognize unplugged cable and doesnt request new IP on replugged

2015-05-15 Thread Conor O'Gorman

On 15/05/15 10:48, Jakub Jančo wrote:

Hello,
After I unplug cable:

ifconfig
eth0  Link encap:Ethernet  HWaddr 14:CC:20:4D:3D:B5
   inet addr:10.1.5.246  Bcast:10.1.5.255  Mask:255.255.255.0
   inet6 addr: fe80::16cc:20ff:fe4d:3db5/64 Scope:Link
   UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
   RX packets:747 errors:0 dropped:0 overruns:0 frame:0
   TX packets:896 errors:0 dropped:0 overruns:0 carrier:0
   collisions:0 txqueuelen:1000
   RX bytes:84708 (82.7 KiB)  TX bytes:487679 (476.2 KiB)
   Interrupt:4

ip link
2: eth0: BROADCAST,MULTICAST,UP,LOWER_UP mtu 1500 qdisc fq_codel state
UP mode DEFAULT group default qlen 1000
 link/ether 14:cc:20:4d:3d:b5 brd ff:ff:ff:ff:ff:ff

After plug in cable, no change, no logs.

ModelTP-Link TL-WR1043N/ND v2 Firmware Version OpenWrt Barrier Breaker
14.07 / LuCI Trunk (svn-r10472) Kernel Version3.10.49


Do you have the switch configured correctly? You can use swconfig to 
check the physical port status.

http://wiki.openwrt.org/toh/tp-link/tl-wr1043nd
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] WAN dhcp client doesnt recognize unplugged cable and doesnt request new IP on replugged

2015-05-15 Thread Jakub Jančo
This is my original switch config:

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0t 1 2 3 4'
option vid '1'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0t'
option vid '3'

config switch_vlan
option device 'switch0'
option vlan '3'
option ports '0t'
option vid '2'

config switch_vlan
option device 'switch0'
option vlan '4'
option vid '4'
option ports '0t'

config switch_vlan
option device 'switch0'
option vlan '5'
option vid '5'
option ports '5 6'

But in wiki they say that wan must be vlan2, but I didnt notice difference
if it is on vlan5.

Anyway I revert switch to original config and add force_link=0 for wan:
config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'
option metric '1'
option force_link '0'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '0 1 2 3 4'

config switch_vlan
option device 'switch0'
option vlan '2'
option vid '2'
option ports '5 6'




It seems that switch noticed link down on port 5:



$swconfig dev switch0 port 5 show
Port 5:
mib: Port 5 MIB counters
RxBroad : 65
RxPause : 0
RxMulti : 47
RxFcsErr: 0
RxAlignErr  : 0
RxRunt  : 0
RxFragment  : 0
Rx64Byte: 310
Rx128Byte   : 960
Rx256Byte   : 101
Rx512Byte   : 16
Rx1024Byte  : 62
Rx1518Byte  : 1
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 149935
RxBadByte   : 0
RxOverFlow  : 0
Filtered: 0
TxBroad : 322
TxPause : 0
TxMulti : 0
TxUnderRun  : 0
Tx64Byte: 668
Tx128Byte   : 493
Tx256Byte   : 135
Tx512Byte   : 9
Tx1024Byte  : 12
Tx1518Byte  : 494
TxMaxByte   : 0
TxOverSize  : 0
TxByte  : 715736
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer : 0
TxLateCol   : 0

pvid: 2
link: port:5 link:down


Link port 6 stays ON, probably because it is cpu.



--
S pozdravom Jakub Janco

2015-05-15 12:28 GMT+02:00 Conor O'Gorman i...@conorogorman.net:

 On 15/05/15 10:48, Jakub Jančo wrote:

 Hello,
 After I unplug cable:

 ifconfig
 eth0  Link encap:Ethernet  HWaddr 14:CC:20:4D:3D:B5
inet addr:10.1.5.246  Bcast:10.1.5.255  Mask:255.255.255.0
inet6 addr: fe80::16cc:20ff:fe4d:3db5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
RX packets:747 errors:0 dropped:0 overruns:0 frame:0
TX packets:896 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:84708 (82.7 KiB)  TX bytes:487679 (476.2 KiB)
Interrupt:4

 ip link
 2: eth0: BROADCAST,MULTICAST,UP,LOWER_UP mtu 1500 qdisc fq_codel state
 UP mode DEFAULT group default qlen 1000
  link/ether 14:cc:20:4d:3d:b5 brd ff:ff:ff:ff:ff:ff

 After plug in cable, no change, no logs.

 ModelTP-Link TL-WR1043N/ND v2 Firmware Version OpenWrt Barrier Breaker
 14.07 / LuCI Trunk (svn-r10472) Kernel Version3.10.49


 Do you have the switch configured correctly? You can use swconfig to check
 the physical port status.
 http://wiki.openwrt.org/toh/tp-link/tl-wr1043nd
 ___
 openwrt-devel mailing list
 openwrt-devel@lists.openwrt.org
 https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] Help required for RT2860 Wireless Driver Configuration

2015-05-15 Thread Anil Kumar Maguluri
Hi All, 

Currently i am working on Open WRT with RT2860 Wireless Device Driver (MT7620 
Chipset). 

My current scenario is the STA ( WLAN and P2P Concurrent) is part of AP BSS, 
P2P BSS Simultaneously. 
I am able to connect Concurrency and able to transmit Unicast packet (using 
PING). 

But, i have the few queries based on the RT2860 Wireless Driver: 
1. I would like to disable hardware security (Encryption and Decryption), but 
couldnt find any register where i can configure, is there any register where i 
can disable HW Security? 

2. Is there any document to understand Multiple BSSID Concept? Is the above 
scenario will be part of MBSSID? 
a. In the above scenario, Which BSSID should i write in BSSID register? Is the 
WLAN BSSID or P2P BSSID? As per my understanding based on the code, they are 
updating the P2P Interface Address while P2P link up, but not updating P2P 
BSSID after connecting with P2P GO, is my understanding correct? Is yes, how 
WLAN BSSID packets will receive? 
b. In case of Security, based on the code the Security registers are updated 
when P2P Device connect with P2P GO, then how WLAN BSSID packets will be 
decrypted at Hardware? 

Please help me to understand the Code better.Thanks for your support. 

Thanks and Regards, 
Anil Kumar Maguluri 
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] Managed WiFi and IPv4/IPv6

2015-05-15 Thread Cristian Morales Vega
Since a wifi-iface can only have one network, how are you supposed
to link it to both the wan and wan6 interfaces?

The closest I have achieved is creating 2 wifi-iface for 1
wifi-device. Both udhcpc and odhcp6c start, but I get 2 wpa_supplicant
processes.


-- 
Cristian Morales Vega

Email crist...@samknows.com
Office +44 (0) 20 3111 4330
Web:  www.samknows.com


This email is sent for and on behalf of SamKnows Limited.

This email and any attachments are confidential, legally privileged
and protected by copyright. If you are not the intended recipient
dissemination or copying of this email is prohibited. If you have
received this in error, please notify the sender by replying by email
and then delete the email completely from your system.

SamKnows Limited, Registered Number: 06510477, Registered Office: Hill
House, 1 Little New Street, London, EC4A 3TR. Registered in England
and Wales. Trade Mark 2507103
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [PATCH] lantiq: Fix initialization of the PCI IRQs when PCIe is also enabled

2015-05-15 Thread Martin Blumenstingl
There are already ifx_pcie_bios_{map_irq,plat_dev_init} hooks defined in
ifxmips_pcie.c. Instead of defining a new hook we simply re-use the
existing ones (this is basically what the lantiq BSP code does).

Signed-off-by: Martin Blumenstingl martin.blumensti...@googlemail.com
---
 .../0001-MIPS-lantiq-add-pcie-driver.patch | 37 +++---
 1 file changed, 19 insertions(+), 18 deletions(-)

diff --git 
a/target/linux/lantiq/patches-3.18/0001-MIPS-lantiq-add-pcie-driver.patch 
b/target/linux/lantiq/patches-3.18/0001-MIPS-lantiq-add-pcie-driver.patch
index 26f262c..040eb1f 100644
--- a/target/linux/lantiq/patches-3.18/0001-MIPS-lantiq-add-pcie-driver.patch
+++ b/target/linux/lantiq/patches-3.18/0001-MIPS-lantiq-add-pcie-driver.patch
@@ -174,26 +174,34 @@ Signed-off-by: John Crispin blo...@openwrt.org
 + ifx_pcie_rc_class_early_fixup);
 --- a/arch/mips/pci/fixup-lantiq.c
 +++ b/arch/mips/pci/fixup-lantiq.c
-@@ -11,11 +11,12 @@
+@@ -8,12 +8,18 @@
+ 
+ #include linux/of_irq.h
+ #include linux/of_pci.h
++#include ifxmips_pci_common.h
  
  int (*ltq_pci_plat_arch_init)(struct pci_dev *dev) = NULL;
  int (*ltq_pci_plat_dev_init)(struct pci_dev *dev) = NULL;
-+int (*ltq_pci_map_irq)(const struct pci_dev *dev, u8 slot, u8 pin);
  
  int pcibios_plat_dev_init(struct pci_dev *dev)
  {
++#ifdef CONFIG_PCIE_LANTIQ
++  if (pci_find_capability(dev, PCI_CAP_ID_EXP))
++  ifx_pcie_bios_plat_dev_init(dev);
++#endif
++
if (ltq_pci_plat_arch_init)
--  return ltq_pci_plat_arch_init(dev);
-+  ltq_pci_plat_arch_init(dev);
+   return ltq_pci_plat_arch_init(dev);
  
-   if (ltq_pci_plat_dev_init)
-   return ltq_pci_plat_dev_init(dev);
-@@ -25,5 +26,7 @@ int pcibios_plat_dev_init(struct pci_dev
+@@ -25,5 +31,10 @@
  
  int __init pcibios_map_irq(const struct pci_dev *dev, u8 slot, u8 pin)
  {
-+  if (ltq_pci_map_irq)
-+  return ltq_pci_map_irq(dev, slot, pin);
++#ifdef CONFIG_PCIE_LANTIQ
++  if (pci_find_capability(dev, PCI_CAP_ID_EXP))
++  return ifx_pcie_bios_map_irq(dev, slot, pin);
++#endif
++
return of_irq_parse_and_map_pci(dev, slot, pin);
  }
 --- /dev/null
@@ -249,7 +257,7 @@ Signed-off-by: John Crispin blo...@openwrt.org
 +extern int ifx_pci_bios_plat_dev_init(struct pci_dev *dev);
 +#endif /* COFNIG_IFX_PCI */
 +
-+#ifdef CONFIG_IFX_PCIE
++#ifdef CONFIG_PCIE_LANTIQ
 +extern int ifx_pcie_bios_map_irq(IFX_PCI_CONST struct pci_dev *dev, u8 slot, 
u8 pin);
 +extern int ifx_pcie_bios_plat_dev_init(struct pci_dev *dev);
 +#endif
@@ -258,7 +266,7 @@ Signed-off-by: John Crispin blo...@openwrt.org
 +
 --- /dev/null
 +++ b/arch/mips/pci/ifxmips_pcie.c
-@@ -0,0 +1,1099 @@
+@@ -0,0 +1,1092 @@
 +/*
 + *  This program is free software; you can redistribute it and/or modify it
 + *  under the terms of the GNU General Public License version 2 as published
@@ -1306,19 +1314,12 @@ Signed-off-by: John Crispin blo...@openwrt.org
 +  return 0;
 +}
 +
-+extern int (*ltq_pci_plat_arch_init)(struct pci_dev *dev);
-+extern int (*ltq_pci_map_irq)(const struct pci_dev *dev, u8 slot, u8 pin);
-+
 +static int __init ifx_pcie_bios_init(void)
 +{
 +void __iomem *io_map_base;
 +int pcie_port;
 +int startup_port;
 +
-+
-+  ltq_pci_map_irq = ifx_pcie_bios_map_irq;
-+  ltq_pci_plat_arch_init = ifx_pcie_bios_plat_dev_init;
-+
 +/* Enable AHB Master/ Slave */
 +pcie_ahb_pmu_setup();
 +
-- 
2.4.1
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH] lantiq: Fix initialization of the PCI IRQs when PCIe is also enabled

2015-05-15 Thread Martin Blumenstingl
This patch plus my previous one (see [0]) make PCIe and PCI work
at the same time (at least on the device I'm testing with).
Unfortunately I have no other lantiq device with PCIe - so it would be
nice if someone else could test that this doesn't break any existing
devices.

Regards,
Martin


[0] https://patchwork.ozlabs.org/patch/471002/
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] External (public) IP forwarded to internal LAN [SOLVED]

2015-05-15 Thread Lars Kruse
Hi Angelo,

 [..] 
 Doest this is an error or normal behaviour  of fw3 ?

Could you add the network and the firewall configuration files?

Lars
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] ralink target, ehci not working, all the devices get detected at ohci controller

2015-05-15 Thread hackru
Hello,

I'm using fresh openwrt trunk, device is NEXX WT3020H, any device i'm trying to 
connect gets usb 1.1 speeds, what's wrong?
This thing confuses me most:
Fri May 15 14:48:18 2015 kern.info kernel: [  300.52] usb 1-1: new 
high-speed USB device number 2 using ehci-platform
Fri May 15 14:48:18 2015 kern.info kernel: [  300.94] usb 2-1: new 
full-speed USB device number 2 using ohci-platform

Looks like some race condition between usb-controllers, maybe i'm wrong. I 
rebooted router 5 times, always the same result.


Some diagnostics info:

Fri May 15 14:48:18 2015 kern.info kernel: [  300.52] usb 1-1: new 
high-speed USB device number 2 using ehci-platform
Fri May 15 14:48:18 2015 kern.info kernel: [  300.94] usb 2-1: new 
full-speed USB device number 2 using ohci-platform
Fri May 15 14:48:19 2015 kern.info kernel: [  301.45] usb 2-1: not running 
at top speed; connect to a high speed hub
Fri May 15 14:48:19 2015 kern.debug kernel: [  301.47] usb 2-1: no of_node; 
not parsing pinctrl DT
Fri May 15 14:48:19 2015 kern.debug kernel: [  301.47] hub 2-1:1.0: no 
of_node; not parsing pinctrl DT
Fri May 15 14:48:19 2015 kern.info kernel: [  301.47] hub 2-1:1.0: USB hub 
found
Fri May 15 14:48:19 2015 kern.info kernel: [  301.48] hub 2-1:1.0: 4 ports 
detected
# lsusb -t
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ohci-platform/1p, 12M
|__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 12M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-platform/1p, 480M

# lsusb -v -d 1a40:0101

Bus 002 Device 002: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
Device Descriptor:
  bLength18
  bDescriptorType 1
  bcdUSB   2.00
  bDeviceClass9 Hub
  bDeviceSubClass 0 Unused
  bDeviceProtocol 0 Full speed (or root) hub
  bMaxPacketSize064
  idVendor   0x1a40 Terminus Technology Inc.
  idProduct  0x0101 4-Port HUB
  bcdDevice1.11
  iManufacturer   0
  iProduct1 USB 2.0 Hub
  iSerial 0
  bNumConfigurations  1
  Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength   25
bNumInterfaces  1
bConfigurationValue 1
iConfiguration  0
bmAttributes 0xe0
  Self Powered
  Remote Wakeup
MaxPower  100mA
Interface Descriptor:
  bLength 9
  bDescriptorType 4
  bInterfaceNumber0
  bAlternateSetting   0
  bNumEndpoints   1
  bInterfaceClass 9 Hub
  bInterfaceSubClass  0 Unused
  bInterfaceProtocol  0 Full speed (or root) hub
  iInterface  0
  Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x81  EP 1 IN
bmAttributes3
  Transfer TypeInterrupt
  Synch Type   None
  Usage Type   Data
wMaxPacketSize 0x0001  1x 1 bytes
bInterval 255
Hub Descriptor:
  bLength   9
  bDescriptorType  41
  nNbrPorts 4
  wHubCharacteristic 0x
Ganged power switching
Ganged overcurrent protection
  bPwrOn2PwrGood   50 * 2 milli seconds
  bHubContrCurrent100 milli Ampere
  DeviceRemovable0x00
  PortPwrCtrlMask0xff
 Hub Port Status:
   Port 1: .0100 power
   Port 2: .0100 power
   Port 3: .0100 power
   Port 4: .0100 power
Device Qualifier (for other device speed):
  bLength10
  bDescriptorType 6
  bcdUSB   2.00
  bDeviceClass9 Hub
  bDeviceSubClass 0 Unused
  bDeviceProtocol 1 Single TT
  bMaxPacketSize064
  bNumConfigurations  1
Device Status: 0x0001
  Self Powered
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [PATCH] buildroot: improve git submodule handling for packages

2015-05-15 Thread Darik Horn
Move the `--recursive` switch from `git clone` to `git submodule`
so that submodules are cloned for upstream branches where the
PKG_SOURCE_VERSION commit-ish has a different .gitmodules
configuration than the repository default.

This is, for example, required when the master branch for a source
package does not use submodules, but its topic branch for OpenWRT
does.

This changes the buildroot dependency from git-1.6.2 to git 1.7.12.2,
which was released September 2012.

Signed-off-by: Darik Horn dajh...@vanadac.com
---
 include/download.mk | 5 +++--
 include/prereq-build.mk | 4 ++--
 2 files changed, 5 insertions(+), 4 deletions(-)

diff --git a/include/download.mk b/include/download.mk
index adaa2e6..d593344 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -88,8 +88,9 @@ define DownloadMethod/git
  cd $(TMP_DIR)/dl  \
  rm -rf $(SUBDIR)  \
  [ \! -d $(SUBDIR) ]  \
- git clone $(URL) $(SUBDIR) --recursive  \
- (cd $(SUBDIR)  git checkout $(VERSION)  git submodule update)  \
+ git clone $(URL) $(SUBDIR)  \
+ (cd $(SUBDIR)  git checkout $(VERSION)  \
+  git submodule update --init --recursive)  \
  echo Packing checkout...  \
  rm -rf $(SUBDIR)/.git  \
  $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR))  \
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 211201a..c06adaf 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -144,8 +144,8 @@ $(eval $(call SetupHostCommand,python,Please
install Python 2.x, \
 $(eval $(call SetupHostCommand,svn,Please install the Subversion client, \
  svn --version | grep Subversion))

-$(eval $(call SetupHostCommand,git,Please install Git (git-core) = 1.6.5, \
- git clone 21 | grep -- --recursive))
+$(eval $(call SetupHostCommand,git,Please install Git (git-core) = 1.7.12.2, \
+ git submodule update --help 21 | grep -- --recursive))

 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
  file --version 21 | grep file))
-- 
1.9.1


0001-buildroot-improve-git-submodule-handling-for-package.patch
Description: Binary data
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH] Give WiFi modules more time to settle

2015-05-15 Thread Felix Fietkau
On 2015-05-15 09:02, Arend van Spriel wrote:
 On 05/12/15 12:25, Hante Meuleman wrote:
 It is a bit more than just changing request_firmware_nowait into
 request_firmware. The worker in core.c needs to be removed. The
 function brcmf_pcie_setup needs to be updated as it cannot call
 device_release_driver during probe. As a result
 brcmf_fw_get_firmwares_pcie has to return the error, which means
 the api for brcmf_fw_get_firmwares_pcie will change, that will
 mean usb and sdio needs to patched as well. So it isn't going to be
 a small patch, but it can be done. I just wonder if it is worth the effort.
 The patch needs to be maintained as well.
 
 I think it kinda sucks that a driver is restricted to use a kernel API 
 because of some user-space app behaviour. So can we dive a bit deeper 
 into that. Is the app detecting the wiphy instances dynamically (through 
 /sys/class/ieee80211?) or does it have some expectation of the number of 
 available wiphy instances. On the first run with OpenWRT it probably can 
 not have such expectation so is that what we are trying to deal with here?
Here's some context on this issue:
At boot time, a script looks for cfg80211 interfaces and creates a
default config. This needs to happen before the uci-defaults scripts
run, as they are allowed to make changes to the default config of wifi
interfaces.
As far as I know, there is no way for a script or utility to block until
all device probing actions have been completed.
We don't have a fancy per-wifi-device defaults override, and we don't
have any hotplug based config modifications yet (this might also lead to
some interesting race conditions), so we currently rely on core devices
having been probed after kernel modules are loaded.

- Felix
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Managed WiFi and IPv4/IPv6

2015-05-15 Thread Felix Fietkau
On 2015-05-15 17:28, Cristian Morales Vega wrote:
 Since a wifi-iface can only have one network, how are you supposed
 to link it to both the wan and wan6 interfaces?
It can have multiple networks. Use 'list' instead of 'option'.

- Felix
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel