Re: [ovs-dev] [PATCH 1/3] datapath: compat: Fix build on RHEL 7.3

2017-01-13 Thread Han Zhou
Should this one be applied to stable branches such as ovs2.6? Now I got the compile error while compiling ovs2.6 with kernel version 3.10.0-514.2.2.el7.x86_64 (CentOS 7.3): ovs/datapath/linux/compat/include/linux/netdevice.h:125:34: error: conflicting types for 'netdev_notifier_info_to_dev'

[ovs-dev] [PATCH] Use PRIu32 format for ofp_port_t

2017-01-13 Thread Shu Shen
Although ofp_port_t uses a 16-bit range, it is defined as a 32-bit type. The format strings throughout the code base were using PRIu16 for ofp_port_t which leads to the compiler to throw Wformat message on platforms that don't promote 16-bit to 32-bit integers, e.g., on macOS. Signed-off-by: Shu

[ovs-dev] [PATCH v9 3/3] ovn: introduce distributed gateway port

2017-01-13 Thread Mickey Spiegel
Currently OVN distributed logical routers achieve reachability to physical networks by passing through a "join" logical switch to a centralized gateway router, which then connects to another logical switch that has a localnet port connecting to the physical network. This patch adds logical port

[ovs-dev] [PATCH v9 2/3] ovn: add is_chassis_resident match expression component

2017-01-13 Thread Mickey Spiegel
This patch introduces a new match expression component is_chassis_resident(). Unlike match expression comparisons, is_chassis_resident is not pushed down to OpenFlow. It is a conditional that is evaluated in the controller during expr_simplify(), when it is replaced by a boolean expression. The

[ovs-dev] [PATCH v9 1/3] ovn: document logical routers and logical patch ports in ovn-architecture

2017-01-13 Thread Mickey Spiegel
This patch adds a description of logical routers and logical patch ports, including gateway routers, to ovn/ovn-architecture.7.xml. Signed-off-by: Mickey Spiegel --- ovn/ovn-architecture.7.xml | 148 ++--- 1 file changed, 140

Re: [ovs-dev] [PATCH v3 13/18] ovs-numa: Add new dump types.

2017-01-13 Thread Ben Pfaff
On Sun, Jan 08, 2017 at 07:15:11PM -0800, Daniele Di Proietto wrote: > They will be used by a future commit. > > This patch introduces some code duplication which will be removed in a > future commit. > > Signed-off-by: Daniele Di Proietto The hexit_value() function

Re: [ovs-dev] [PATCH v3 08/18] dpif-netdev: Block pmd threads if there are no ports.

2017-01-13 Thread Ben Pfaff
On Sun, Jan 08, 2017 at 07:15:06PM -0800, Daniele Di Proietto wrote: > +if (!poll_cnt) { > +while (seq_read(pmd->reload_seq) == pmd->last_reload_seq) { > +seq_wait(pmd->reload_seq, pmd->last_reload_seq); > +poll_block(); > +} > +lc = 1025; 1025

[ovs-dev] USA Global Youths Conference 2017

2017-01-13 Thread Rhonda Watkins
Dear Sir / Madam, It is my great privilege for me to invite you to 2017 Global Youths conferences which will be held from 21st - 25th of February 2017 at the {Atlanta Georgia Convention Center United States of America, The organizing committee is responsible for all visa arrangements to the

Re: [ovs-dev] [PATCH v3 01/18] dpif-netdev: Fix memory leak.

2017-01-13 Thread Ben Pfaff
On Sun, Jan 08, 2017 at 07:14:59PM -0800, Daniele Di Proietto wrote: > We keep all the per-port classifiers around, since they can be reused, > but when a pmd thread is destroyed we should free them. > > Found using valgrind. > > Fixes: 3453b4d62a98("dpif-netdev: dpcls per in_port with sorted >

Re: [ovs-dev] [PATCH v7 3/7] ovn: Introduce "chassisredirect" port binding

2017-01-13 Thread Mickey Spiegel
On Fri, Jan 13, 2017 at 4:21 PM, Ben Pfaff wrote: > On Fri, Jan 13, 2017 at 02:19:21PM -0800, Mickey Spiegel wrote: > > On Thu, Jan 12, 2017 at 5:12 PM, Mickey Spiegel > > wrote: > > > > > > > > On Sun, Jan 8, 2017 at 10:30 PM, Mickey Spiegel

Re: [ovs-dev] [PATCH v7 3/7] ovn: Introduce "chassisredirect" port binding

2017-01-13 Thread Ben Pfaff
On Fri, Jan 13, 2017 at 02:19:21PM -0800, Mickey Spiegel wrote: > On Thu, Jan 12, 2017 at 5:12 PM, Mickey Spiegel > wrote: > > > > > On Sun, Jan 8, 2017 at 10:30 PM, Mickey Spiegel > > wrote: > > > >> > >> On Fri, Jan 6, 2017 at 8:31 PM, Mickey

[ovs-dev] [PATCH 3/3] xlate: Generate of datapath clone action when supported

2017-01-13 Thread Andy Zhou
Add logic to detect whether datapath support clone. Enhance the xlate logic to make use of it. Added logic to turn on/off clone support for testing. Signed-off-by: Andy Zhou --- ofproto/ofproto-dpif-xlate.c | 44 ++--

[ovs-dev] [PATCH 1/3] lib: Add nl_msg_end_non_empty_nested()

2017-01-13 Thread Andy Zhou
Later patch will make use of this function. Signed-off-by: Andy Zhou --- lib/netlink.c | 13 + lib/netlink.h | 1 + 2 files changed, 14 insertions(+) diff --git a/lib/netlink.c b/lib/netlink.c index 4715d68..ad7d35a 100644 --- a/lib/netlink.c +++ b/lib/netlink.c @@

Re: [ovs-dev] [PATCH v7 1/7] ovn: specify addresses of type "router" lsps as "router"

2017-01-13 Thread Ben Pfaff
On Fri, Jan 06, 2017 at 12:00:28PM -0800, Mickey Spiegel wrote: > Currently in OVN, when a logical switch port of type "router" is > created, the MAC and optionally IP addresses of the peer logical > router port must be specified again as the addresses of the logical > switch port. > > This patch

Re: [ovs-dev] [PATCH v7 3/7] ovn: Introduce "chassisredirect" port binding

2017-01-13 Thread Mickey Spiegel
On Thu, Jan 12, 2017 at 5:12 PM, Mickey Spiegel wrote: > > On Sun, Jan 8, 2017 at 10:30 PM, Mickey Spiegel > wrote: > >> >> On Fri, Jan 6, 2017 at 8:31 PM, Mickey Spiegel >> wrote: >> >>> >>> On Fri, Jan 6, 2017 at 4:21 PM,

[ovs-dev] [PATCH v2] packet: proper return type for vlan_tci_to_pcp()

2017-01-13 Thread Shu Shen
The return type of vlan_tci_to_pcp() was int where it's expected to be uint8_t and causing implicit truncation when the function is used. On some platforms such as macOS, where PRIu8 is defined as "hhx" and no promotion of short to int is done, the compiler might throw out Wformat message for

Re: [ovs-dev] [PATCH] ovn-controller: Provide the option to set Encap.options:csum

2017-01-13 Thread Ben Pfaff
On Tue, Jan 10, 2017 at 11:34:42AM +0530, Numan Siddique wrote: > ovn-controller by default enables UDP checksums for geneve > tunnels. With this patch user can set the desired value in > Open_vSwitch.external_ids:ovn_encap_csum. > > Signed-off-by: Numan Siddique I don't

[ovs-dev] [PATCH] packet: proper return type for vlan_tci_to_pcp()

2017-01-13 Thread Shu Shen
The return type of vlan_tci_to_pcp() was int where it's expected to be uint_8 and causing implicit truncation when the function is used. On some platforms such as macOS, where PRIu8 is defined as "hhx" and no promotion of short to int is done, the compiler might throw out Wformat message for

Re: [ovs-dev] [PATCH] ovn: Support ARP proxy in logical switches.

2017-01-13 Thread Ben Pfaff
On Mon, Jan 09, 2017 at 04:08:08PM -0800, Han Zhou wrote: > This is an intermediate solution because a better way to do it is to > utilize the load-balancing feature of OVN to replace kubeproxy completely, > and the problem won't exist at all. It just takes more effort to integrate > and we are

Re: [ovs-dev] [RFC] libX: add new release / version info tags

2017-01-13 Thread Ben Pfaff
On Tue, Jan 10, 2017 at 10:42:52AM -0500, Aaron Conole wrote: > This commit uses the $PACKAGE_VERSION automake variable to construct a > release and version info combination which sets the library name to be: > >libfoo-$(OVS_MAJOR_VERSION).so.$(OVS_MINOR_VERSION).0.$(OVS_MICRO_VERSION) > >

Re: [ovs-dev] Unwildcarding of fields modified by set_field action

2017-01-13 Thread Jan Scheurich
Thanks Jarno, I understand the issue and the need for tracking the set mask now. We will stick to the post-xlate cleanup for the time being and possibly return to introducing a dedicated set-mask at some later stage. Jan On 2017-01-12 01:04, Jarno Rajahalme wrote: On Jan 11, 2017, at 12:10

Re: [ovs-dev] [PATCH] ofproto-dpif: Use acquire/release barriers with 'tables_version'.

2017-01-13 Thread Ben Pfaff
On Thu, Jan 12, 2017 at 10:17:32AM -0800, Jarno Rajahalme wrote: > Use memory_order_release when updating the tables version number to > make sure no memory accesses before the atomic_store (possibly > relating to setting up the new version) are reordered to take place > after the atomic_store,

Re: [ovs-dev] [BUG] ovs-ofctl version 2.5.0 will crash with OFPFMFC_BAD_COMMAND

2017-01-13 Thread Samuel Jean via dev
Thanks for the quick follow up Ben, So we'll indeed try against latest versions to rule out the possibility of a bug that has been fixed already although I could not find any commit with such mention. We'll report back here. At this moment, we can reproduce over and over within minutes. We've

Re: [ovs-dev] [PATCH] windows: Change driver and MSI company name to LF

2017-01-13 Thread Guru Shetty
On 6 December 2016 at 15:30, Alin Serdean wrote: > Until now we used 'Open vSwitch' as the company/organization name. > > The project is now under The Linux Foundation ownership. > > This patch updates the MSI and driver attributes to reflect that ownership. > >

Re: [ovs-dev] [PATCH v4] ofproto-dpif: Make ofproto/trace output easier to read.

2017-01-13 Thread Ben Pfaff
On Thu, Jan 12, 2017 at 01:31:43PM -0800, Justin Pettit wrote: > > > On Jan 12, 2017, at 9:23 AM, Ben Pfaff wrote: > > > > On Mon, Jan 09, 2017 at 08:46:28PM -0800, Justin Pettit wrote: > >> I think it would be helpful to have a comment describing this > >> function. Also

[ovs-dev] [PATCH] ovn-trace: Style improvements.

2017-01-13 Thread Ben Pfaff
Signed-off-by: Ben Pfaff --- ovn/utilities/ovn-trace.c | 12 +--- 1 file changed, 9 insertions(+), 3 deletions(-) diff --git a/ovn/utilities/ovn-trace.c b/ovn/utilities/ovn-trace.c index b1ffe1f..b5ccc28 100644 --- a/ovn/utilities/ovn-trace.c +++

[ovs-dev] [PATCH] ovn-trace: Fix memory leaks.

2017-01-13 Thread Ben Pfaff
Suggested-by: Justin Pettit Signed-off-by: Ben Pfaff --- ovn/utilities/ovn-trace.c | 36 ++-- 1 file changed, 34 insertions(+), 2 deletions(-) diff --git a/ovn/utilities/ovn-trace.c b/ovn/utilities/ovn-trace.c index

Re: [ovs-dev] [BUG] ovs-ofctl version 2.5.0 will crash with OFPFMFC_BAD_COMMAND

2017-01-13 Thread Ben Pfaff
On Thu, Jan 12, 2017 at 03:54:42PM -0500, Samuel Jean via dev wrote: > It seems that shelling out to ovs-ofctl very quickly can lead to bug where > it reports an OFPT_ERROR. > > We were able to constantly reproduce within minutes of running the above > flow modifications on Unbutu. > > Any help,

[ovs-dev] Peace Of The Lord Be With And Your Family

2017-01-13 Thread fernandolumbrer...@ono.com
Dear friend, I am Mrs Alice Banneth from Burkina Faso are you online? I have important issue to discus with you. Reply to my private email address :(mrsalicebanne...@yahoo.com) ___ dev mailing list d...@openvswitch.org