Re: Units on numbers [was Re: S28ish]

2005-03-28 Thread mjreed
>From: [EMAIL PROTECTED] >The problem with using the >units(1) database is that it only >deals with >multiplicative relations -- so, e.g., >It won't handle temperature. So the temperature functions available in units(1) aren't defined in the database? They're hard-coded? I find that unlikely.

RE: Unknown level of hash

2005-03-28 Thread Zhuang Li
Yes. I think it's both useful and fun. I was thinking something similar to @[EMAIL PROTECTED] = map{1} @a; But getting "$hash->{E1}->{E2}->...->{En} = 1;" instead of "$hash{E1} = 1; ... $hash{En} =1;". What I'd really like to do is: Given @a = ('E1', 'E2', ..., 'En'); @b = ('K1', 'K2',

Re: return of copies vs references

2005-03-28 Thread Darren Duncan
At 7:10 AM +0100 3/29/05, Piers Cawley wrote: Doesn't that rather depend on the type of the attribute? Personally, if I get an object back from accessor method then I expect that any modifications of that object's state will be seen the next time I look at the results of that accessor method. This

Re: S28ish [was: [Pugs] A couple of string interpolation edge cases]

2005-03-28 Thread Rod Adams
Larry Wall wrote: On Sat, Mar 26, 2005 at 02:37:24PM -0600, Rod Adams wrote: : Please convince me your view works in practice. I'm not seeing it work : well when I attempt to define the relevent parts of S29. But I might : just be dense on this. Well, let's work through an example. multi meth

Re: return of copies vs references

2005-03-28 Thread Piers Cawley
Darren Duncan <[EMAIL PROTECTED]> writes: > At 11:26 PM -0700 3/16/05, Luke Palmer wrote: >> > For each of the above cases, is a copy of or a reference to the >>> attribute returned? For each, will the calling code be able to >>> modify $obj's attributes by modifying the return values, or not?

Re: .method == $self.method or $_.method?

2005-03-28 Thread Piers Cawley
Larry Wall <[EMAIL PROTECTED]> writes: > I've been thinking about this in my sleep, and at the moment I think > I'd rather keep .foo meaning $_.foo, but break the automatic binding > of the invocant to $_. Instead of that, I'd like to see a really, > really short alias for $self. Suppose we pick

Re: xx and closures

2005-03-28 Thread Eirik Berg Hanssen
Juerd <[EMAIL PROTECTED]> writes: > I wonder now if that can just be > > my $password = any('a'..'z') x 5; Wouldn't that generate a junction, and so need a .pick? my $password = (any('a'..'z') x 5).pick; Or perhaps just leave it a junction, to use as a generator: my $any_passw

Re: Unknown level of hash

2005-03-28 Thread Uri Guttman
> "ZL" == Zhuang Li <[EMAIL PROTECTED]> writes: ZL> Hi, given an array: @a = ('E1', 'E2', ..., 'En'); ZL> Is there an easy way, hopefully one liner, to do the following without a ZL> loop? If not, will Perl support this in Perl 6? ZL> $hash->{E1}->{E2}->...->{En} = 1; i think perl6

getting Perl 6 special support in text editors

2005-03-28 Thread Darren Duncan
This message is largely FYI, and some of its details are only relevant to Mac OS X users, though the general theme is not. Following today's release of BBEdit 8.1 text editor, which among its new features is integrated Subversion support (it had CVS for awhile already), I have been compelled to

Re: Units on numbers [was Re: S28ish]

2005-03-28 Thread Andrew Rodland
On Monday 28 March 2005 05:48 pm, Craig DeForest wrote: > The problem with using the units(1) database is that it only deals with > multiplicative relations -- so, e.g., it won't handle temperature. [EMAIL PROTECTED]:~$ units 2084 units, 71 prefixes, 32 nonlinear units Among those "nonlinear unit

Re: Units on numbers [was Re: S28ish]

2005-03-28 Thread Aaron Sherman
On Mon, 2005-03-28 at 17:48, Craig DeForest wrote: > The problem with using the units(1) database is that it only deals with > multiplicative relations -- so, e.g., it won't handle temperature. Well, that's fine. You don't have to get everything from one source. Larry is right though, units is a

Re: Units on numbers [was Re: S28ish]

2005-03-28 Thread Craig DeForest
The problem with using the units(1) database is that it only deals with multiplicative relations -- so, e.g., it won't handle temperature. Units resolvers are not so hard to come by -- the strategy is to try to break each compound unit out into a collection of fundamental quantities that are int

Re: Units on numbers [was Re: S28ish]

2005-03-28 Thread Aaron Sherman
On Mon, 2005-03-28 at 16:00, Larry Wall wrote: > I've always thought that we should make use of the database of the > "units" program for standardized names of units. The units database > has a pretty good list of which units are just differently scaled > units of the actual underlying fundamenta

Re: Units on numbers [was Re: S28ish]

2005-03-28 Thread Larry Wall
On Mon, Mar 28, 2005 at 01:30:14PM -0700, Craig DeForest wrote: : Yow -- units would be extra cool for perl6: I know of no other language that : has units support built in. It would go a long way toward making perl6 the : language of choice for students in the physical sciences... Well, yes. I

Re: Units on numbers [was Re: S28ish]

2005-03-28 Thread Larry Wall
On Mon, Mar 28, 2005 at 03:40:14PM -0500, Aaron Sherman wrote: : Now you can ask for whatever you like: : : say "We have {â.new $money}â" : : Though you might have some snazzy way of saying that. Just by the by, that's illegal syntax. Methods with arguments require parens. You could, how

Re: Units on numbers [was Re: S28ish]

2005-03-28 Thread Aaron Sherman
On Mon, 2005-03-28 at 15:07, Rod Adams wrote: > Markus Laire wrote: > > So do you actually envision perl6 to allow a junction of units on > > numbers? This would have huge implications, depending on what exactly > > is possible with these units... > > # import proper MMD-subs for + - * etc.

Re: Units on numbers [was Re: S28ish]

2005-03-28 Thread Craig DeForest
Yow -- units would be extra cool for perl6: I know of no other language that has units support built in. It would go a long way toward making perl6 the language of choice for students in the physical sciences... The perl5 CPAN modules already have a pretty good unit system that could be ported

Re: String Theory

2005-03-28 Thread Larry Wall
On Mon, Mar 28, 2005 at 11:53:07AM -0500, Chip Salzenberg wrote: : According to Larry Wall: : > On Fri, Mar 25, 2005 at 07:38:10PM -, Chip Salzenberg wrote: : > : And might I also ask why in Perl 6 (if not Parrot) there seems to be : > : no type support for strings with known encodings which ar

Re: string/list division

2005-03-28 Thread Aaron Sherman
On Mon, 2005-03-28 at 13:38, Luke Palmer wrote: > Your "list mod" idea is interesting, though. I fear that adding too > many list operators will start to make us look like Haskell, where we > have *extremely* expressive single lines that take an hour to write and > an hour to read (I call this "c

Re: Units on numbers [was Re: S28ish]

2005-03-28 Thread Rod Adams
Markus Laire wrote: Larry Wall wrote: Now, I admit that I've handwaved the tricksy bit, which is, "How do you know, Larry, that substr() wants 5`Codes rather than 5`Meters? It's all very well if you have a single predeclared subroutine and can look at the signature at compile time, but you wrote th

Re: String Theory

2005-03-28 Thread Chip Salzenberg
According to Larry Wall: > On Fri, Mar 25, 2005 at 07:38:10PM -, Chip Salzenberg wrote: > : And might I also ask why in Perl 6 (if not Parrot) there seems to be > : no type support for strings with known encodings which are not subsets > : of Unicode? > > Well, because the main point of Unicod

Re: string/list division

2005-03-28 Thread Luke Palmer
Juerd writes: > What if instead of > > my @copy = @array; > while (my @chunk = splice @copy, 0, $chunksize) { > ... > } # ^1 Well, I for one never write that. I very seldom use splice. > > we could just write > > for @array [/] $chunksize -> @chunk { ... } Well, we c

string/list division

2005-03-28 Thread Juerd
It was a matter of time, of course, after my last thread. How often do we want chunks of a string or list? And how often do we abuse a temporary copy and substr/splice for that? What if instead of my @copy = @array; while (my @chunk = splice @copy, 0, $chunksize) { ... } # ^

Re: strings, numbers and... lists?

2005-03-28 Thread Juerd
Juerd skribis 2005-03-28 16:44 (+0200): > splice @foo, $_, 1 given first { @foo[$_] ~~ 15 }, [EMAIL PROTECTED]; > @foo [-] 15; # whoa! Note: unfair comparison. The equal thing would be [-]=. In fact, this illustrates the problem even better, because to get @foo [-] 15 without [-], you n

strings, numbers and... lists?

2005-03-28 Thread Juerd
The discussion about x/xx made me wonder. We have this table: string list x xx ~ , And we also have this table: string number ~ + - x * eq == But there is overlap between the two tables: string number list x

Re: xx and closures

2005-03-28 Thread Juerd
Juerd skribis 2005-03-28 16:05 (+0200): > In the context of x, it makes even more sense. Especially if you > consider, for example, creating a random password: > my $password = { any('a'..'z').pick } x 5; I wonder now if that can just be my $password = any('a'..'z') x 5; (No reason to no

Re: xx and closures

2005-03-28 Thread Juerd
Luke Palmer skribis 2005-03-28 6:57 (-0700): > We were discussing on #perl6, and thought that the feature: > sub foo () { > say "Blech"; > } > { foo() } xx 5; In the context of x, it makes even more sense. Especially if you consider, for example, creating a random password:

xx and closures

2005-03-28 Thread Luke Palmer
We were discussing on #perl6, and thought that the feature: sub foo () { say "Blech"; } { foo() } xx 5; Would be useful. Since it is dwimmery, and you wouldn't want the closure to execute if you didn't know it was there, we decided that it would probably be best if this were

Re: Units on numbers [was Re: S28ish]

2005-03-28 Thread Markus Laire
Larry Wall wrote: > ... SKIP ... Okay, that looks scary, but if as in my previous message we define "chars" as the highest Unicode level allowed by the context and the string, then we can just write that in some notation resembling: substr($a, 5`Chars, 10`Chars); or whatever notation we end up