Re: maintainability and "or"

2017-03-21 Thread ToddAndMargo
Thank you all for the wonderful training and feedback!

Re: maintainability and "or"

2017-03-21 Thread ToddAndMargo
On 03/21/2017 11:25 AM, Brandon Allbery wrote: people comparing perl 5 speed to perl 6 should take note: perl 5 used to be slow too If you wanted "speed", code in C or assembly. I am after rapid development. Perl 6 is perfect. -- ~~ Computers are like

Re: maintainability and "or"

2017-03-21 Thread ToddAndMargo
On 03/21/2017 04:50 AM, Elizabeth Mattijsen wrote: $PathAndName.IO.open(:w).close unless $PathAndName.IO.f; Hi Liz, Now that is elegant! Thank you! -T -- ~~ Computers are like air conditioners. They malfunction when you open windows

Re: maintainability and "or"

2017-03-21 Thread Patrick R. Michaud
On Tue, Mar 21, 2017 at 02:46:43PM -0400, Brandon Allbery wrote: > On Tue, Mar 21, 2017 at 2:37 PM, Patrick R. Michaud > wrote: > > > On Tue, Mar 21, 2017 at 7:38 AM, ToddAndMargo > > wrote: > > > > $Name.IO.f or $Name.IO.open(:w).close; > > > > > >

Re: maintainability and "or"

2017-03-21 Thread Brandon Allbery
On Tue, Mar 21, 2017 at 2:37 PM, Patrick R. Michaud wrote: > On Tue, Mar 21, 2017 at 02:25:02PM -0400, Brandon Allbery wrote: > > On Tue, Mar 21, 2017 at 7:38 AM, ToddAndMargo > wrote: > > > $Name.IO.f or $Name.IO.open(:w).close; > > > > fwiw I

Re: maintainability and "or"

2017-03-21 Thread The Sidhekin
On Tue, Mar 21, 2017 at 7:28 PM, Brandon Allbery wrote: > On Tue, Mar 21, 2017 at 7:50 AM, Elizabeth Mattijsen > wrote: > >> $PathAndName.IO.open(:w).close unless $PathAndName.IO.f; > > > This has a readability issue, though: you've buried the lede.

Re: maintainability and "or"

2017-03-21 Thread Patrick R. Michaud
poor one for readability and maintainability, but one that used to be > fairly important (people comparing perl 5 speed to perl 6 should take note: > perl 5 used to be slow too). It's not entirely a perl3-to-5ism. Using || and && for conditional execution dates back to Unix shell programm

Re: maintainability and "or"

2017-03-21 Thread Brandon Allbery
On Tue, Mar 21, 2017 at 7:50 AM, Elizabeth Mattijsen wrote: > $PathAndName.IO.open(:w).close unless $PathAndName.IO.f; This has a readability issue, though: you've buried the lede. The condition should be up front where it stands out, not hidden at the back. The wide usage

Re: maintainability and "or"

2017-03-21 Thread Brandon Allbery
On Tue, Mar 21, 2017 at 7:38 AM, ToddAndMargo <toddandma...@zoho.com> wrote: > $Name.IO.f or $Name.IO.open(:w).close; fwiw I consider this a perl3_to_5-ism; it's an optimization, and a fairly poor one for readability and maintainability, but one that used to be fairly importan

Re: maintainability and "or"

2017-03-21 Thread H.Merijn Brand
On Tue, 21 Mar 2017 12:50:18 +0100, Elizabeth Mattijsen <l...@dijkmat.nl> wrote: > > On 21 Mar 2017, at 12:38, ToddAndMargo <toddandma...@zoho.com> wrote: > > This is just one of those chatter posts. > > > > To me, the holy grail of coding is maintainability,

Re: maintainability and "or"

2017-03-21 Thread Elizabeth Mattijsen
> On 21 Mar 2017, at 12:38, ToddAndMargo <toddandma...@zoho.com> wrote: > This is just one of those chatter posts. > > To me, the holy grail of coding is maintainability, > which is why I code in Top Down. > > Code like below get my goat because I have to look >

maintainability and "or"

2017-03-21 Thread ToddAndMargo
Hi All, This is just one of those chatter posts. To me, the holy grail of coding is maintainability, which is why I code in Top Down. Code like below get my goat because I have to look at it several times before I realize what is going on $Name.IO.f or $Name.IO.open(:w).close; Basically