Re: [HACKERS] Add CREATE support to event triggers

2013-11-24 Thread Andrew Tipton
Oid and the "old" and "new" pg_class rows. It's easy to then examine the old vs. new rows and determine what has changed. Kind regards, Andrew Tipton -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers

Re: [HACKERS] [PATCH] SQL assertions prototype

2013-11-24 Thread Andrew Tipton
nd raise an error if any rows were present. That should be a very quick operation. No need to invent some sort of "get access to the changed rows" mechanism especially for CREATE ASSERTION. Kind regards, Andrew Tipton -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.or

Re: [HACKERS] BackgroundWorkerInitializeConnection(NULL, ...) doesn't work

2013-08-10 Thread Andrew Tipton
e dbname and username brings things to a state where normal SPI can be used. This behaviour would be quite useful for certain classes of bgworker. Documentation-wise, it would be helpful to specify precisely what is/isn't allowed in this "shared catalogs only" mode. See the attach

[HACKERS] BackgroundWorkerInitializeConnection(NULL, ...) doesn't work

2013-08-10 Thread Andrew Tipton
rest of the code in InitPostgres expects MyDatabaseId to be set to something useful. Regards, Andrew Tipton

Re: [HACKERS] question about HTTP API

2013-08-09 Thread Andrew Tipton
planned and function code is being compiled for each request, of course...) This is going to be a very long series of patches, but IMHO we have to start somewhere! For some applications, performance is far less important than ease-of-use and ease-of-deployment. Regards, Andrew Tipton

Re: [HACKERS] question about HTTP API

2013-08-09 Thread Andrew Tipton
ation development dramatically easier. Regards, Andrew Tipton

Re: [HACKERS] question about HTTP API

2013-08-09 Thread Andrew Tipton
s against a Postgres database, but it isn't "generic" -- you have to configure it for each URL that should be handled. Regards, Andrew Tipton

Re: [HACKERS] how to pass data (tuples) to worker processes?

2013-08-03 Thread Andrew Tipton
a few more details on the enhancements you're planning for bgworkers? I seem to recall reading that communicating with the dynamic bgworkers after they had been launched was next on your agenda... Regards, Andrew Tipton

Re: [HACKERS] Add json_typeof() and json_is_*() functions.

2013-08-02 Thread Andrew Tipton
the user against forgetting about, say, the 'null' typeof() when constructing their check expression. Regards, Andrew Tipton

[HACKERS] Add json_typeof() and json_is_*() functions.

2013-07-29 Thread Andrew Tipton
the words "value", "object", and "array" are used in a consistent manner. "JSON object" and "JSON array" refer to parameters which must be an object or an array or to results which are always an object or an array. "JSON value" refers

Re: [HACKERS] Patch: add GiST support for BOX @> POINT queries

2011-06-17 Thread Andrew Tipton
On Fri, Jun 10, 2011 at 22:16, Hitoshi Harada wrote: > > I reviewed the patch and worried about hard-wired magic number as > StrategyNumber. At least you should use #define to indicate the > number's meaning. > > In addition, the modified gist_box_consistent() is too dangerous; > q_box is declared

Re: [HACKERS] foreign keys for array/period contains relationships

2011-03-20 Thread Andrew Tipton
> > On Mon, Oct 25, 2010 at 15:11, Peter Eisentraut wrote: > >> Example #4: PK is period, FK is timestamp. FK must be contained in some >> PK period. >> >> CREATE TABLE pk (a period PRIMARY KEY, ...); >> >> CREATE TABLE fk (x timestamp REFERENCES pk (a), ...); >> >> As above, we can probably arra

[HACKERS] Patch: add GiST support for BOX @> POINT queries

2011-02-23 Thread Andrew Tipton
While playing around with the BOX and POINT datatypes, I was surprised to note that BOX @> POINT (and likewise POINT <@ BOX) queries were not using the GiST index I had created on the BOX column. The attached patch adds a new strategy @>(BOX,POINT) to the box_ops opclass. Internally, gist_box_con