Re: [Pkg-javascript-devel] Babel

2019-09-01 Thread Nilesh Patra
Hi

>   * install: good, just to set a minimal version for pkg-js-tools to help
> backports (0.9 at least)
>
>  * tests: you didn't use pkg-js-tools for tests, then your autopkgtest
>   tests are bad. Todo:
>$ mkdir -p debian/tests/pkg-js
>$ git rm debian/tests/{control,require}
>$ echo 'tap test/*.js' > debian/tests/pkg-js/test
>$ git add debian/tests/pkg-js/test
>Then remove override_dh_auto_test entry from debian/rules, add
>missing "Testsuite: autopkgtest-pkg-nodejs" in debian/control and
>commit
>
>  * clean: you used an override_dh_auto_clean to remove on file, then
>   dh_auto_test is disabled. This is not a good practice. Prefer
>   to use a debian/clean file:
>$ echo 'debian/semver.1' > debian/clean
>$ git add debian/clean
>Then remove override_dh_auto_test from debian/rules and commit
>
>  * links: you didn't take a look at your package (using debc), you have
>   2 bad symlinks. To fix that (only one is needed):
> $ echo 'semver/bin/semver /usr/bin/semver' > debian/nodejs/links
>
> Then commit your changes in js-team/node-semver
>

I have done the changes. Could you please review, if it looks okay? I also
don't have access to js-team/node-semver, please grant me so that I may
push.
I also had a doubt:
I read the man pages, I kind of get an idea, but could you explain how debc
works, and how I can check bad symlinks (I am not sure about this one,
since doing debc on changes file didn't show bad links before)  ?
That would be great.

Thanks and Regards
Nilesh
-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] Babel

2019-08-31 Thread Xavier
Le 30/08/2019 à 16:40, Nilesh Patra a écrit :
> 
> Hi,
> 
> OK for removing the patch.
> 
> You removed debian/install without adding pkg-js-tools needed entries
> (d/control & d/rules), then your package is empty.
> 
> Cheers,
> Xavier
> 
> Hi
> I have rectified the issues. Could you review, if everything looks okay?

Hi,

 * install: good, just to set a minimal version for pkg-js-tools to help
backports (0.9 at least)

 * tests: you didn't use pkg-js-tools for tests, then your autopkgtest
  tests are bad. Todo:
   $ mkdir -p debian/tests/pkg-js
   $ git rm debian/tests/{control,require}
   $ echo 'tap test/*.js' > debian/tests/pkg-js/test
   $ git add debian/tests/pkg-js/test
   Then remove override_dh_auto_test entry from debian/rules, add
   missing "Testsuite: autopkgtest-pkg-nodejs" in debian/control and
   commit

 * clean: you used an override_dh_auto_clean to remove on file, then
  dh_auto_test is disabled. This is not a good practice. Prefer
  to use a debian/clean file:
   $ echo 'debian/semver.1' > debian/clean
   $ git add debian/clean
   Then remove override_dh_auto_test from debian/rules and commit

 * links: you didn't take a look at your package (using debc), you have
  2 bad symlinks. To fix that (only one is needed):
$ echo 'semver/bin/semver /usr/bin/semver' > debian/nodejs/links

Then commit your changes in js-team/node-semver

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] Babel

2019-08-31 Thread Utkarsh Gupta
Hey,

On 15/08/19 12:07 pm, Xavier wrote:
> Hi,
>
> "gulp build-babel-standalone" command succeeds here (7.5.5) with the
> following package:
>
> PACKAGE   : DEB-VERSION => GOOD-VERSION
>   --- upgraded ---
> babel-loader  : 7.1.5 => 8.0.6
> base64-js : 1.3.0 => 1.3.1
> chalk : 2.3.0 => 2.4.2
> color-convert : 1.9.0 => 1.9.3
> globals   : 11.1.0 => 11.12.0
> ieee754   : 1.1.12 => 1.1.13
> js-tokens : 2.0.0 => 4.0.0

Updated. Pushed.
RFS.


Best,
Utkarsh




signature.asc
Description: OpenPGP digital signature
-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] Babel

2019-08-30 Thread Nilesh Patra
Hi,
>
> OK for removing the patch.
>
> You removed debian/install without adding pkg-js-tools needed entries
> (d/control & d/rules), then your package is empty.
>
> Cheers,
> Xavier
>

Hi
I have rectified the issues. Could you review, if everything looks okay?
-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] Babel

2019-08-30 Thread Xavier
Le 29/08/2019 à 20:31, Nilesh Patra a écrit :
> 
> 
> On Wed, 28 Aug 2019 at 13:58, Xavier  > wrote:
> 
> Le 28/08/2019 à 09:19, Utkarsh Gupta a écrit :
> > Hey,
> >
> > On 15/08/19 12:07 pm, Xavier wrote:
> >> Hi,
> >>
> >> "gulp build-babel-standalone" command succeeds here (7.5.5) with the
> >> following package:
> >>
> >> PACKAGE               : DEB-VERSION => GOOD-VERSION
> >>   --- upgraded ---
> >> babel-loader          : 7.1.5 => 8.0.6
> >> base64-js             : 1.3.0 => 1.3.1
> >> chalk                 : 2.3.0 => 2.4.2
> >> color-convert         : 1.9.0 => 1.9.3
> >> globals               : 11.1.0 => 11.12.0
> >> ieee754               : 1.1.12 => 1.1.13
> >> js-tokens             : 2.0.0 => 4.0.0
> >> node-libs-browser     : 2.2.0 => 2.2.1
> >> regenerator-transform : 0.9.8 => 0.14.1
> >> regexpu-core          : 4.5.4 => 4.5.5
> >> resolve               : 1.5.0 => 1.12.0
> >> semver                : 5.5.1 => 5.7.1
> >> supports-color        : 4.4.0 => 5.5.0
> >> to-fast-properties    : 1.0.2 => 2.0.0
> >
> > Updated. Pushed.
> > RFS (or I can upload it with DM access).
> 
> Pushed to experimental with node-debug. I'll launch ci.debian.net
>  before
> backporting to unstable
> 
> Cheers,
> Xavier
> 
> -- 
> Pkg-javascript-devel mailing list
> Pkg-javascript-devel@alioth-lists.debian.net
> 
> 
> https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel
> 
> 
> Hi
> I had taken up node-semver.
> I removed a previous patch which causes the build to fail. Then I tried
> to replicate the same with a new patch, but that doesn't work out.
> However, without the patch the package builds perfectly. Could you, or
> other folks test it if it looks okay?
> That would be great.
> Here's the link: salsa.debian.org/gi-boi-guest/node-semver
> 

Hi,

OK for removing the patch.

You removed debian/install without adding pkg-js-tools needed entries
(d/control & d/rules), then your package is empty.

Cheers,
Xavier

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] Babel

2019-08-29 Thread Utkarsh Gupta
Hey,

On 15/08/19 12:07 pm, Xavier wrote:
> Hi,
>
> "gulp build-babel-standalone" command succeeds here (7.5.5) with the
> following package:
>
> PACKAGE   : DEB-VERSION => GOOD-VERSION
>   --- upgraded ---
> babel-loader  : 7.1.5 => 8.0.6
> base64-js : 1.3.0 => 1.3.1
> chalk : 2.3.0 => 2.4.2
> color-convert : 1.9.0 => 1.9.3
> globals   : 11.1.0 => 11.12.0

Updated. Pushed.
RFS.


Best,
Utkarsh




signature.asc
Description: OpenPGP digital signature
-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] Babel

2019-08-29 Thread Utkarsh Gupta
Hey,

On 15/08/19 12:07 pm, Xavier wrote:
> Hi,
>
> "gulp build-babel-standalone" command succeeds here (7.5.5) with the
> following package:
>
> PACKAGE   : DEB-VERSION => GOOD-VERSION
>   --- upgraded ---
> babel-loader  : 7.1.5 => 8.0.6
> base64-js : 1.3.0 => 1.3.1
> chalk : 2.3.0 => 2.4.2
> color-convert : 1.9.0 => 1.9.3
> globals   : 11.1.0 => 11.12.0
> ieee754   : 1.1.12 => 1.1.13
> js-tokens : 2.0.0 => 4.0.0
> node-libs-browser : 2.2.0 => 2.2.1
> regenerator-transform : 0.9.8 => 0.14.1

Updated. Pushed.
RFS.


Best,
Utkarsh





signature.asc
Description: OpenPGP digital signature
-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] Babel

2019-08-29 Thread Nilesh Patra
On Wed, 28 Aug 2019 at 13:58, Xavier  wrote:

> Le 28/08/2019 à 09:19, Utkarsh Gupta a écrit :
> > Hey,
> >
> > On 15/08/19 12:07 pm, Xavier wrote:
> >> Hi,
> >>
> >> "gulp build-babel-standalone" command succeeds here (7.5.5) with the
> >> following package:
> >>
> >> PACKAGE   : DEB-VERSION => GOOD-VERSION
> >>   --- upgraded ---
> >> babel-loader  : 7.1.5 => 8.0.6
> >> base64-js : 1.3.0 => 1.3.1
> >> chalk : 2.3.0 => 2.4.2
> >> color-convert : 1.9.0 => 1.9.3
> >> globals   : 11.1.0 => 11.12.0
> >> ieee754   : 1.1.12 => 1.1.13
> >> js-tokens : 2.0.0 => 4.0.0
> >> node-libs-browser : 2.2.0 => 2.2.1
> >> regenerator-transform : 0.9.8 => 0.14.1
> >> regexpu-core  : 4.5.4 => 4.5.5
> >> resolve   : 1.5.0 => 1.12.0
> >> semver: 5.5.1 => 5.7.1
> >> supports-color: 4.4.0 => 5.5.0
> >> to-fast-properties: 1.0.2 => 2.0.0
> >
> > Updated. Pushed.
> > RFS (or I can upload it with DM access).
>
> Pushed to experimental with node-debug. I'll launch ci.debian.net before
> backporting to unstable
>
> Cheers,
> Xavier
>
> --
> Pkg-javascript-devel mailing list
> Pkg-javascript-devel@alioth-lists.debian.net
>
> https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel


Hi
I had taken up node-semver.
I removed a previous patch which causes the build to fail. Then I tried to
replicate the same with a new patch, but that doesn't work out.
However, without the patch the package builds perfectly. Could you, or
other folks test it if it looks okay?
That would be great.
Here's the link: salsa.debian.org/gi-boi-guest/node-semver

Thanks and Regards
Nilesh
-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] Babel

2019-08-28 Thread Xavier
Le 28/08/2019 à 09:19, Utkarsh Gupta a écrit :
> Hey,
> 
> On 15/08/19 12:07 pm, Xavier wrote:
>> Hi,
>>
>> "gulp build-babel-standalone" command succeeds here (7.5.5) with the
>> following package:
>>
>> PACKAGE   : DEB-VERSION => GOOD-VERSION
>>   --- upgraded ---
>> babel-loader  : 7.1.5 => 8.0.6
>> base64-js : 1.3.0 => 1.3.1
>> chalk : 2.3.0 => 2.4.2
>> color-convert : 1.9.0 => 1.9.3
>> globals   : 11.1.0 => 11.12.0
>> ieee754   : 1.1.12 => 1.1.13
>> js-tokens : 2.0.0 => 4.0.0
>> node-libs-browser : 2.2.0 => 2.2.1
>> regenerator-transform : 0.9.8 => 0.14.1
>> regexpu-core  : 4.5.4 => 4.5.5
>> resolve   : 1.5.0 => 1.12.0
>> semver: 5.5.1 => 5.7.1
>> supports-color: 4.4.0 => 5.5.0
>> to-fast-properties: 1.0.2 => 2.0.0
> 
> Updated. Pushed.
> RFS (or I can upload it with DM access).

Pushed to experimental with node-debug. I'll launch ci.debian.net before
backporting to unstable

Cheers,
Xavier

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] Babel

2019-08-28 Thread Utkarsh Gupta
Hey,

On 15/08/19 12:07 pm, Xavier wrote:
> Hi,
>
> "gulp build-babel-standalone" command succeeds here (7.5.5) with the
> following package:
>
> PACKAGE   : DEB-VERSION => GOOD-VERSION
>   --- upgraded ---
> babel-loader  : 7.1.5 => 8.0.6
> base64-js : 1.3.0 => 1.3.1
> chalk : 2.3.0 => 2.4.2
> color-convert : 1.9.0 => 1.9.3
> globals   : 11.1.0 => 11.12.0
> ieee754   : 1.1.12 => 1.1.13
> js-tokens : 2.0.0 => 4.0.0
> node-libs-browser : 2.2.0 => 2.2.1
> regenerator-transform : 0.9.8 => 0.14.1
> regexpu-core  : 4.5.4 => 4.5.5
> resolve   : 1.5.0 => 1.12.0
> semver: 5.5.1 => 5.7.1
> supports-color: 4.4.0 => 5.5.0
> to-fast-properties: 1.0.2 => 2.0.0

Updated. Pushed.
RFS (or I can upload it with DM access).

>   --- downgraded -
> isarray   : 2.0.4 => 1.0.0
> source-map: 0.6.1 => 0.5.7
> tapable   : 1.0.0 => 0.2.9
> webpack   : 4.7.0 => 3.12.0
>
> NB: this is an automatic script, results may be false or incomplete


Best,
Utkarsh




signature.asc
Description: OpenPGP digital signature
-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] Babel

2019-08-28 Thread Xavier
Le 28/08/2019 à 06:22, Utkarsh Gupta a écrit :
> Hey,
> 
> On 28/08/19 9:41 am, Xavier wrote:
>> Le 28/08/2019 à 03:59, Utkarsh Gupta a écrit :
>>> Hey,
>>>
>>> On 15/08/19 12:07 pm, Xavier wrote:
 Hi,

 "gulp build-babel-standalone" command succeeds here (7.5.5) with the
 following package:

 PACKAGE   : DEB-VERSION => GOOD-VERSION
   --- upgraded ---
 babel-loader  : 7.1.5 => 8.0.6
 base64-js : 1.3.0 => 1.3.1
 chalk : 2.3.0 => 2.4.2
 color-convert : 1.9.0 => 1.9.3
 globals   : 11.1.0 => 11.12.0
 ieee754   : 1.1.12 => 1.1.13
 js-tokens : 2.0.0 => 4.0.0
 node-libs-browser : 2.2.0 => 2.2.1
 regenerator-transform : 0.9.8 => 0.14.1
 regexpu-core  : 4.5.4 => 4.5.5
 resolve   : 1.5.0 => 1.12.0
 semver: 5.5.1 => 5.7.1
 supports-color: 4.4.0 => 5.5.0
>>> The version in the archive was 6.1.0 which is needed for ava.
>>> In any case, I created a "downgrade" branch from the master and
>>> downgraded the version to 5.5.0.
>>> Hope this resolves the problem here :)
>>> Changes are pushed, shall upload myself by tonight if no one has any
>>> problem with it.
>> No, 6.1.0 was published, patch "ava" to use 6.1.0
> 
> In any case, we had to downgrade it to 5.5.0 for babel, no?
> Since 6.1.0 is already in the archive.
> 
> 
> Best,
> Utkarsh

Downgrading is the last thing to try, first we should try to patch

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] Babel

2019-08-28 Thread Pirate Praveen


I have created  to 
track progress.


On Wed, Aug 28, 2019 at 9:52 AM, Utkarsh Gupta 
 wrote:

In any case, we had to downgrade it to 5.5.0 for babel, no?
Since 6.1.0 is already in the archive.





We should go in this order

1. make an attempt to make all reverse dependencies work with new 
version first

2. if that fails we should embed the old version
3. and I think downgrade should be last resort when the first two 
cannot be done or if babel is the only reverse dependency.


-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] Babel

2019-08-27 Thread Utkarsh Gupta
Hey,

On 28/08/19 9:41 am, Xavier wrote:
> Le 28/08/2019 à 03:59, Utkarsh Gupta a écrit :
>> Hey,
>>
>> On 15/08/19 12:07 pm, Xavier wrote:
>>> Hi,
>>>
>>> "gulp build-babel-standalone" command succeeds here (7.5.5) with the
>>> following package:
>>>
>>> PACKAGE   : DEB-VERSION => GOOD-VERSION
>>>   --- upgraded ---
>>> babel-loader  : 7.1.5 => 8.0.6
>>> base64-js : 1.3.0 => 1.3.1
>>> chalk : 2.3.0 => 2.4.2
>>> color-convert : 1.9.0 => 1.9.3
>>> globals   : 11.1.0 => 11.12.0
>>> ieee754   : 1.1.12 => 1.1.13
>>> js-tokens : 2.0.0 => 4.0.0
>>> node-libs-browser : 2.2.0 => 2.2.1
>>> regenerator-transform : 0.9.8 => 0.14.1
>>> regexpu-core  : 4.5.4 => 4.5.5
>>> resolve   : 1.5.0 => 1.12.0
>>> semver: 5.5.1 => 5.7.1
>>> supports-color: 4.4.0 => 5.5.0
>> The version in the archive was 6.1.0 which is needed for ava.
>> In any case, I created a "downgrade" branch from the master and
>> downgraded the version to 5.5.0.
>> Hope this resolves the problem here :)
>> Changes are pushed, shall upload myself by tonight if no one has any
>> problem with it.
> No, 6.1.0 was published, patch "ava" to use 6.1.0

In any case, we had to downgrade it to 5.5.0 for babel, no?
Since 6.1.0 is already in the archive.


Best,
Utkarsh




signature.asc
Description: OpenPGP digital signature
-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] Babel

2019-08-27 Thread Xavier
Le 28/08/2019 à 03:59, Utkarsh Gupta a écrit :
> Hey,
> 
> On 15/08/19 12:07 pm, Xavier wrote:
>> Hi,
>>
>> "gulp build-babel-standalone" command succeeds here (7.5.5) with the
>> following package:
>>
>> PACKAGE   : DEB-VERSION => GOOD-VERSION
>>   --- upgraded ---
>> babel-loader  : 7.1.5 => 8.0.6
>> base64-js : 1.3.0 => 1.3.1
>> chalk : 2.3.0 => 2.4.2
>> color-convert : 1.9.0 => 1.9.3
>> globals   : 11.1.0 => 11.12.0
>> ieee754   : 1.1.12 => 1.1.13
>> js-tokens : 2.0.0 => 4.0.0
>> node-libs-browser : 2.2.0 => 2.2.1
>> regenerator-transform : 0.9.8 => 0.14.1
>> regexpu-core  : 4.5.4 => 4.5.5
>> resolve   : 1.5.0 => 1.12.0
>> semver: 5.5.1 => 5.7.1
>> supports-color: 4.4.0 => 5.5.0
> 
> The version in the archive was 6.1.0 which is needed for ava.
> In any case, I created a "downgrade" branch from the master and
> downgraded the version to 5.5.0.
> Hope this resolves the problem here :)
> Changes are pushed, shall upload myself by tonight if no one has any
> problem with it.

No, 6.1.0 was published, patch "ava" to use 6.1.0

>> to-fast-properties: 1.0.2 => 2.0.0
>>   --- downgraded -
>> isarray   : 2.0.4 => 1.0.0
>> source-map: 0.6.1 => 0.5.7
>> tapable   : 1.0.0 => 0.2.9
>> webpack   : 4.7.0 => 3.12.0
>>
>> NB: this is an automatic script, results may be false or incomplete
> 
> 
> Best,
> Utkarsh
> 
> 
> 

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] Babel

2019-08-27 Thread Utkarsh Gupta
Hey,

On 15/08/19 12:07 pm, Xavier wrote:
> Hi,
>
> "gulp build-babel-standalone" command succeeds here (7.5.5) with the
> following package:
>
> PACKAGE   : DEB-VERSION => GOOD-VERSION
>   --- upgraded ---
> babel-loader  : 7.1.5 => 8.0.6
> base64-js : 1.3.0 => 1.3.1
> chalk : 2.3.0 => 2.4.2
> color-convert : 1.9.0 => 1.9.3
> globals   : 11.1.0 => 11.12.0
> ieee754   : 1.1.12 => 1.1.13
> js-tokens : 2.0.0 => 4.0.0
> node-libs-browser : 2.2.0 => 2.2.1
> regenerator-transform : 0.9.8 => 0.14.1
> regexpu-core  : 4.5.4 => 4.5.5
> resolve   : 1.5.0 => 1.12.0
> semver: 5.5.1 => 5.7.1
> supports-color: 4.4.0 => 5.5.0

The version in the archive was 6.1.0 which is needed for ava.
In any case, I created a "downgrade" branch from the master and
downgraded the version to 5.5.0.
Hope this resolves the problem here :)
Changes are pushed, shall upload myself by tonight if no one has any
problem with it.

> to-fast-properties: 1.0.2 => 2.0.0
>   --- downgraded -
> isarray   : 2.0.4 => 1.0.0
> source-map: 0.6.1 => 0.5.7
> tapable   : 1.0.0 => 0.2.9
> webpack   : 4.7.0 => 3.12.0
>
> NB: this is an automatic script, results may be false or incomplete


Best,
Utkarsh




signature.asc
Description: OpenPGP digital signature
-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] Babel

2019-08-15 Thread Pirate Praveen



On Thu, Aug 15, 2019 at 12:52 PM, Xavier  wrote:

Le 15/08/2019 à 09:04, Pirate Praveen a écrit :



 On Thu, Aug 15, 2019 at 12:07 PM, Xavier > wrote:
 Hi, "gulp build-babel-standalone" command succeeds here (7.5.5) 
with

 the following package: PACKAGE : DEB-VERSION => GOOD-VERSION
 --- upgraded --- babel-loader : 7.1.5 => 
8.0.6


 This needs to be updated along with babel (babel-loader 8 needs 
babel 7).



 base64-js : 1.3.0 => 1.3.1 chalk : 2.3.0 => 2.4.2 color-convert :
 1.9.0 => 1.9.3 globals : 11.1.0 => 11.12.0 ieee754 : 1.1.12 => 
1.1.13

 js-tokens : 2.0.0 => 4.0.0 node-libs-browser : 2.2.0 => 2.2.1
 regenerator-transform : 0.9.8 => 0.14.1 regexpu-core : 4.5.4 => 
4.5.5

 resolve : 1.5.0 => 1.12.0 semver : 5.5.1 => 5.7.1 supports-color :
 4.4.0 => 5.5.0 to-fast-properties : 1.0.2 => 2.0.0 ---
 downgraded - isarray : 2.0.4 => 1.0.0 source-map :
 0.6.1 => 0.5.7 tapable : 1.0.0 => 0.2.9 webpack : 4.7.0 => 3.12.0


 We can adapt the webpack config to build with webpack 4.


 NB: this is an automatic script, results may be false or incomplete


 Thanks! babel-standalone is for browser only, try the build target 
we

 use in rules.


The "bootstrap" target calls "build" which launches this step. Other
build part work, except this one. So if you think we don't need this, 
we

have to change debian/rules to not call "make bootstrap": instead,
launch only needed gulp steps.


Good then. I don't use babel-standalone directly, but I think some one 
else wanted this.


We must make it work with webpack 4,
we should try to make it work with source-map 0.6.1
and if its not very hard, update isarray 2 and tapable (if it is hard 
we can embed old versions)



-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] Babel

2019-08-15 Thread Xavier
Le 15/08/2019 à 09:04, Pirate Praveen a écrit :
> 
> 
> On Thu, Aug 15, 2019 at 12:07 PM, Xavier  wrote:
>> Hi, "gulp build-babel-standalone" command succeeds here (7.5.5) with
>> the following package: PACKAGE : DEB-VERSION => GOOD-VERSION
>> --- upgraded --- babel-loader : 7.1.5 => 8.0.6
> 
> This needs to be updated along with babel (babel-loader 8 needs babel 7).
> 
>> base64-js : 1.3.0 => 1.3.1 chalk : 2.3.0 => 2.4.2 color-convert :
>> 1.9.0 => 1.9.3 globals : 11.1.0 => 11.12.0 ieee754 : 1.1.12 => 1.1.13
>> js-tokens : 2.0.0 => 4.0.0 node-libs-browser : 2.2.0 => 2.2.1
>> regenerator-transform : 0.9.8 => 0.14.1 regexpu-core : 4.5.4 => 4.5.5
>> resolve : 1.5.0 => 1.12.0 semver : 5.5.1 => 5.7.1 supports-color :
>> 4.4.0 => 5.5.0 to-fast-properties : 1.0.2 => 2.0.0 ---
>> downgraded - isarray : 2.0.4 => 1.0.0 source-map :
>> 0.6.1 => 0.5.7 tapable : 1.0.0 => 0.2.9 webpack : 4.7.0 => 3.12.0
> 
> We can adapt the webpack config to build with webpack 4.
> 
>> NB: this is an automatic script, results may be false or incomplete 
> 
> Thanks! babel-standalone is for browser only, try the build target we
> use in rules.

The "bootstrap" target calls "build" which launches this step. Other
build part work, except this one. So if you think we don't need this, we
have to change debian/rules to not call "make bootstrap": instead,
launch only needed gulp steps.

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] Babel

2019-08-15 Thread Pirate Praveen



On Thu, Aug 15, 2019 at 12:07 PM, Xavier  wrote:

Hi,

"gulp build-babel-standalone" command succeeds here (7.5.5) with the
following package:

PACKAGE   : DEB-VERSION => GOOD-VERSION
  --- upgraded ---
babel-loader  : 7.1.5 => 8.0.6


This needs to be updated along with babel (babel-loader 8 needs babel 
7).



base64-js : 1.3.0 => 1.3.1
chalk : 2.3.0 => 2.4.2
color-convert : 1.9.0 => 1.9.3
globals   : 11.1.0 => 11.12.0
ieee754   : 1.1.12 => 1.1.13
js-tokens : 2.0.0 => 4.0.0
node-libs-browser : 2.2.0 => 2.2.1
regenerator-transform : 0.9.8 => 0.14.1
regexpu-core  : 4.5.4 => 4.5.5
resolve   : 1.5.0 => 1.12.0
semver: 5.5.1 => 5.7.1
supports-color: 4.4.0 => 5.5.0
to-fast-properties: 1.0.2 => 2.0.0
  --- downgraded -
isarray   : 2.0.4 => 1.0.0
source-map: 0.6.1 => 0.5.7
tapable   : 1.0.0 => 0.2.9
webpack   : 4.7.0 => 3.12.0



We can adapt the webpack config to build with webpack 4.


NB: this is an automatic script, results may be false or incomplete


Thanks! babel-standalone is for browser only, try the build target we 
use in rules.



-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] babel 6 -> 7 transition - call for help

2018-10-23 Thread Pirate Praveen
On 10/23/18 7:06 PM, Pirate Praveen wrote:
> I started working on the update and just looked at the devDependencies,
> it needs browserify, webpack, rollup and gulp to build! This is new
> record even by node's own standard!

It seems webpack is used only for babel-standalone so I have patched out
its usage for now.

I have embedded all new build dependencies and got this far,

/<>/Gulpfile.js:121
gulp.task("default", gulp.series("build"));
  ^

TypeError: gulp.series is not a function
at Object. (/<>/Gulpfile.js:121:27)
at Module._compile (module.js:652:30)
at Object.Module._extensions..js (module.js:663:10)
at Module.load (module.js:565:32)
at tryModuleLoad (module.js:505:12)
at Function.Module._load (module.js:497:3)
at Module.require (module.js:596:17)
at require (internal/module.js:11:18)
at Liftoff.handleArguments (/usr/lib/nodejs/gulp/bin/gulp.js:119:3)
at Liftoff. (/usr/lib/nodejs/liftoff/index.js:198:16)
make[3]: *** [Makefile:13: build] Error 1

Looks like I need to update gulp to 4.x So another transition to go with
this.



signature.asc
Description: OpenPGP digital signature
-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] babel 6 -> 7 transition - call for help

2018-10-23 Thread Bastien ROUCARIES
On Tue, Oct 23, 2018 at 3:36 PM Pirate Praveen  wrote:
>
> Hi team,
>
> Webpack 3 -> 4 update was requested recently which needs babel 7. In
> addition to it, esm needs (which will allow us to skip rollup for ES
> modules to help fix many circular dependencies) babel 7, gitlab also
> needs babel 7.
>
> I started working on the update and just looked at the devDependencies,
> it needs browserify, webpack, rollup and gulp to build! This is new
> record even by node's own standard!
>
> Luckily we have a recent enough nodejs in unstable and we can skip most
> of the transpilation steps (tested with acorn) but it requires a manual
> conversion of ES modules to CJS. It is sad to see native support for ES
> modules remaining experimental for ever in nodejs.
>
> Let me know if anyone feel brave enough to join this effort.
>
> Thanks
> Praveen

Hi,

I have achieved to get node-acorn in shape

Will upload in experimental

>
> --
> Pkg-javascript-devel mailing list
> Pkg-javascript-devel@alioth-lists.debian.net
> https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel